Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

kstat_named(9S)

Name

kstat_named - obsolete structure for named kstats

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

Interface Level

Solaris DDI specific (Solaris DDI)

Description

Named kstats are an array of name-value pairs. These pairs are kept in the kstat_named structure. When a kstat is created by the kstat_create() function, the driver specifies how many of these structures will be allocated. The structures are returned as an array pointed to by the ks_data field. For more information, see the kstat_create(9F) man page.

Structure Members


union {
          char                   c[16];
          long                   l;
          ulong_t                ul; 
          longlong_t             ll;
          u_longlong_t           ull;
} value;  /* value of counter */ 

The only member exposed to drivers is the value member. This field is a union of several data types. The driver must specify which type it will use in the call to kstat_named_init().

See Also

kstat_named_init(9F), kstat_create(9F), kstat2_named(9S), kstat2_nv_init(9F), kstat2_create(9F)

Writing Device Drivers in Oracle Solaris 11.4

Notes

This data-structure is no longer used by the introduction of v2 kstats. It may be removed in a future release of Oracle Solaris. For information on creating a v2 kstat, see the kstat2_create(9F) man page, and for information on the new data-structure for named kstat values refer to the kstat2_named(9S) man page.