Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

kstat_io(9S)

Name

kstat_io - obsolete structure for I/O kstats

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

Interface Level

Solaris DDI specific (Solaris DDI)

Description

I/O kstat statistics are kept in a kstat_io structure. When the kstat_create() function creates an I/O kstat, the ks_data field is a pointer to one of these structures. The macro KSTAT_IO_PTR() is provided to retrieve this field. It looks like this:

#define KSTAT_IO_PTR(kptr)	((kstat_io_t *)(kptr)->ks_data)

For more information, see the kstat_create(9F) man page.

Structure Members

u_longlong_t      nread;      /* number of bytes read */
u_longlong_t      nwritten;   /* number of bytes written *]/
ulong_t           reads;      /* number of read operations */
ulong_t           writes;     /* number of write operations */

The nread field should be updated by the driver with the number of bytes successfully read upon completion.

The nwritten field should be updated by the driver with the number of bytes successfully written upon completion.

The reads field should be updated by the driver after each successful read operation.

The writes field should be updated by the driver after each successful write operation.

Other I/O statistics are updated through the use of the kstat_queue(9F) functions.

See Also

kstat_named_init(9F), kstat_runq_back_to_waitq(9F), kstat_create(9F), kstat_queue(9F), kstat_runq_enter(9F), kstat_runq_exit(9F), kstat_waitq_enter(9F), kstat_waitq_exit(9F), kstat_waitq_to_runq(9F), kstat2_lookup_template(9F), kstat2_create_with_template(9F), kstat2_io(9S), kstat2_runq_back_to_waitq(9F), kstat2_runq_enter(9F), kstat2_runq_exit(9F), kstat2_waitq_enter(9F), kstat2_waitq_exit(9F), kstat2_waitq_to_runq(9F)

Writing Device Drivers in Oracle Solaris 11.4

Notes

The use of the kstat_io structure is deprecated. The data-structure and functions used to manipulate its values may be removed in a future release of Oracle Solaris. Creating an I/O kstat is now achieved using the kstat2_lookup_template() function and passing the result to the kstat2_create_with_template() function. For more information, see the kstat2_lookup_template(9F) and kstat2_create_with_template(9F) man pages. The kstat queue functions which support the new type of kstat have the prefix "kstat2_" and take a pointer to the kstat2_io data-structure. For more information, refer to the kstat2_io(9S) man page.