Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Set_Locale (4)

Name

Set_Locale - set a tool's locale

Synopsis

Set_Locale(in string category,
in string locale
[...]);

Description

Desktop Services Message Sets                                    Set_Locale(4)



NAME
       Set_Locale - set a tool's locale

SYNOPSIS
       Set_Locale(in string category,
                  in string locale
                  [...]);

DESCRIPTION
       The Set_Locale request reports the POSIX locale of the indicated locale
       categories.

       The category argument is the locale category to set.  A locale category
       is  a  group  of data types whose output formatting varies according to
       locale in a similar way.  ISO C and locale categories are:

            LC_ALL
            LC_COLLATE
            LC_CTYPE
            LC_MESSAGES
            LC_MONETARY
            LC_NUMERIC
            LC_TIME

       The locale argument is the name of the locale to set the indicated cat-
       egory to.  The value of locale is implementation-defined.  For example,
       Solaris defines such locales as C, de, fr, it, etc.

ERRORS
       The ToolTalk service may return the following error in  processing  the
       Set_Locale request:

          TT_DESKTOP_EINVAL
                The locale argument is not valid on the handler's host.

APPLICATION USAGE
       The  ttdt_session_join(3),  function  can  be used to register for, and
       transparently process, the Set_Locale request.

EXAMPLES
       The Set_Locale request can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_SET_LOCALE,
                        my_callback);
            tt_message_arg_add(msg, TT_IN, Tttk_string, "LC_MONETARY");
            tt_message_arg_add(msg, TT_IN, Tttk_string, "de");
            tt_message_send(msg);

WARNINGS
       Set_Locale can also be sent as a multicast notice, as an edict  to  all
       tools in the scope of the message.  The consequences of doing so can be
       severe and unexpected.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       setlocale(3C) Solaris 2.3 Developer's Guide to Internationalization;
       tt_message_arg_add(3), tt_message_send(3), ttdt_sender_imprint_on(3),
       ttdt_session_join(3); Get_Locale request.




ToolTalk 1.3                     1 March 1996                    Set_Locale(4)