Sun Ethernet Fabric Operating System

Exit Print View

Updated: July 2015
 
 

Configure Simple Password Authentication

  1. Configure simple password authentication in SEFOS2.
    1. Type.
      SEFOS# configure terminal
      SEFOS(config)# router ospf
      SEFOS(config-router)# router-id 10.4.0.2
      
    2. Enable OSPF over the VLAN interface and associate the interface with an OSPF area.
      SEFOS(config-router)# network 10.4.0.2 area 0.0.0.0
      
    3. Exit Router Configuration mode.
      SEFOS(config-router)# exit
      
    4. Enter Interface Configuration mode.
      SEFOS(config)# interface vlan 1
      
    5. Configure the authentication key for simple password authentication.
      SEFOS(config-if)# ip ospf authentication-key 1234
      
    6. Enable simple password authentication.
      SEFOS(config-if)# ip ospf authentication
      
    7. Exit Interface Configuration mode.
      SEFOS(config-if)# exit
      
    8. Exit Configuration mode.
      SEFOS(config)# exit
      
  2. Configure simple password authentication in SEFOS4.
    1. Type.
      SEFOS# configure terminal
      SEFOS(config)# router ospf
      SEFOS(config-router)# router-id 10.4.0.4
      
    2. Enable OSPF over the VLAN interface and associate the interface with an OSPF area.
      SEFOS(config-router)# network 10.4.0.4 area 0.0.0.0
      
    3. Exit Router Configuration mode.
      SEFOS(config-router)# exit
      
    4. Enter Interface Configuration mode.
      SEFOS(config)# interface vlan 1
      
    5. Configure the authentication key for simple password authentication.
      SEFOS(config-if)# ip ospf authentication-key 1234
      
    6. Enable simple password authentication.
      SEFOS(config-if)# ip ospf authentication
      
    7. Exit Interface Configuration mode.
      SEFOS(config-if)# exit
      
    8. Exit Configuration mode.
      SEFOS(config)# exit
      
  3. Examine the authentication type configured.
    SEFOS# show ip ospf interface
     
    vlan1 is line protocol is up
    Internet Address 10.4.0.2, Mask 255.255.0.0, Area 0.0.0.0
    AS 1, Router ID 10.4.0.2, Network Type BROADCAST, Cost 1
    Transmit Delay is 1 sec, State 5, Priority 1
    Designated RouterId 10.4.0.4, Interface address 10.4.0.4
    Backup Designated RouterId 10.4.0.2, Interface address 10.4.0.2
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 0 sec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with the neighbor 10.4.0.4
    Simple password authentication enabled
    
  4. Examine the adjacency formed between the neighbors in SEFOS 2 and SEFOS 4.
    SEFOS# show ip ospf neighbor detail
     
    Neighbor 10.4.0.4, interface address 10.4.0.4
    In the area 0.0.0.0 via interface vlan1
    Neighbor priority is 1,  State is FULL/BACKUP, 5 state changes
    DR is 10.4.0.4 BDR is 10.4.0.2
    Options is 0x2
    
  5. Remove a previously assigned OSPF password.
    SEFOS(config-if)# no ip ospf authentication-key