Sun Ethernet Fabric Operating System CLI Enterprise Reference Manual
|
  
|
RIP |
RIP is a widely used protocol for managing router information within a self-contained network, such as a corporate LAN or an interconnected group of such LANs. RIP is classified by the IETF as one of several internal gateway protocols.
RIP sends routing-update messages at regular intervals and when the network topology changes. When a router receives a routing update that includes changes to an entry, it updates its routing table to reflect the new route. The metric value for the path is increased by 1, and the sender is indicated as the next hop. RIP routers maintain only the best route (the route with the lowest metric value) to a destination. After updating its routing table, the router immediately begins transmitting routing updates to inform other network routers of the change. These updates are sent independently of the regularly scheduled updates that RIP routers send. RIP uses a hop count as a way to determine network distance. Each host with a router in the network uses the routing table information to determine the next host to route a packet to for a specified destination.
6.1 RIP Commands
The list of CLI commands for the configuration of RIP is as follows:
6.1.1 router rip
Enters the router configuration mode. The no form of the command disables RIP on all the interfaces.
Syntax Description
|
router rip- Enables router configuration mode.
no router rip- Disables RIP on all interfaces.
|
Mode
|
Global Configuration
|
Example
|
SEFOS(config)# router rip
|
- network - Enables RIP on an IP network
- show ip rip - Displays IP RIP protocol database or statistics
6.1.2 ip rip security
Accepts or ignores RIP1 packets when authentication is in use. The no form of the command sets the security level to its default value.
ip rip security {minimum | maximum}
|
Syntax Description
|
minimum - Denotes that the RIP1 packets will be accepted even when authentication is in use.
maximum - Denotes that the RIP1 packets will be ignored when authentication is in use.
|
Mode
|
Router Configuration
|
Defaults
|
maximum
|
Example
|
SEFOS(config-router)# ip rip security minimum
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.3 ip rip retransmission
Configures the timeout interval and number of retries to retransmit the update request packet or an unacknowledged update response packet. The no form of the command sets the retransmission timeout interval or the number of retransmission retries to its default value.
ip rip retransmission {interval timeout_5-10 | retries 10-40}
|
no ip rip retransmission {interval | retries}
|
Syntax Description
|
interval - The timeout interval to be used to retransmit the update request packet or an unacknowledged update response packet.
retries - The maximum number of retransmissions of the update request and update response packets.
|
Mode
|
Router Configuration
|
Defaults
|
interval - 5
retries - 36
|
Example
|
SEFOS(config-router)# ip rip retransmission interval 6
SEFOS(config-router)# no ip rip retransmission retries
|
Notes
|
During retries, if no response is received the routes through the next hop router are marked unreachable.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.4 network
Enables RIP on an IP network or an unnumbered interface. The no form of the command disables RIP on an IP network or an unnumbered interface.
network ip-address [unnum {vlan 1-4094 | iftype ifnum}]
|
no network ip-address [unnum {vlan 1-4094 | iftype ifnum}]
|
Syntax Description
|
ip-address - IP address for the entry.
unum vlan - VLAN identifier for which no IP address is configured.
iftype - Interface type.
ifnum - Interface identifier.
|
Mode
|
Router Configuration
|
Example
|
SEFOS(config)# interface vlan 1
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 10.0.0.1 255.255.0.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
|
Notes
|
- The network number specified must not contain any subnet information. RIP routing updates will be sent and received only through interfaces on this network.
- RIP sends updates to the interfaces in the specified networks. Also, if the network of an interface is not specified, the interface will not be advertised in any RIP update.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.5 neighbor
Adds a trusted neighbor router. The no form of the command deletes a trusted neighbor router.
Syntax Description
|
ip-address - IP address of the trusted neighbor router.
|
Mode
|
Router Configuration
|
Example
|
SEFOS(config-router)# neighbor 10.0.0.5
|
Notes
|
- This command is used to configure the IP address of the router from which this router can accept RIP Packets.
- Multiple neighbor commands can be used to specify additional trusted neighbors or peers.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.6 passive-interface vlan
Suppresses routing updates on an interface. The no form of the command does not suppress routing updates from an interface.
passive-interface {vlan 1-4094 | interface-type interface-id}
|
no {vlan 1-4094 | interface-type interface-id}
|
Syntax Description
|
vlan - VLAN identifier.
interface-type - Interface type.
interface-id - Interface identifier.
|
Mode
|
Router Configuration
|
Example
|
SEFOS(config-router)# passive-interface vlan 1
|
Notes
|
If the sending of routing updates is disabled on an interface, the particular subnet will continue to be advertised to other interfaces, and updates from other routers on that interface continue to be received and processed.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.7 output-delay
Enables interpacket delay for RIP updates. The no form of the command disables interpacket delay for RIP updates. This command also helps in preventing the routing table from losing information by enabling the interpacket delay.
Mode
|
Router Configuration
|
Example
|
SEFOS(config-router)# output-delay
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.8 output-delay delay
This command configures the interpacket delay for the RIP updates. The interpacket delay ranges between 8 and 50 milliseconds. This command also helps in preventing the routing table from losing information by configuring the interpacket delay.
output-delay milliseconds_8-50
|
Syntax Description
|
output-delay - Configures the interpacket delay for RIP updates.
|
Mode
|
Router Configuration
|
Example
|
SEFOS(config-router)# output-delay 10
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.9 validate-update-source
Configures the validate source option for RIP. That is, this command enables the source IP address validation of incoming routing updates for RIP and IGRP routing protocols.
Mode
|
Router Configuration
|
Example
|
SEFOS(config-router)# validate-update-source
|
6.1.10 redistribute
Enables redistribution of corresponding protocol routes into RIP. The no form of the command disables redistribution of corresponding protocol routes into RIP.
redistribute {all | connected | ospf | static} [ route-map name_1-20]
|
no redistribute {all | connected | ospf | static} [ route-map name_1-20]
|
Syntax Description
|
all - Advertises all routes learned in the RIP process.
connected - Connected routes redistribution.
ospf - Advertises routes learned by OSPF in the RIP process.
static - Statically configured routes to advertise in the RIP process.
route-map - Name of the Route Map to be applied during redistribution of routes from Route Table Manager to RIP. If this is not specified, all routes are redistributed.
|
Mode
|
Router Configuration
|
Example
|
SEFOS(config-router)# redistribute all
|
6.1.11 default-metric
Sets the metric to be used for redistributed routes. The no form of the command sets the metric used with redistributed routes to its default value. The metric value ranges between 1 and 16. The metric value given in the no form of the command is ignored during the execution of the command.
Mode
|
Router Configuration
|
Defaults
|
3
|
Example
|
SEFOS(config-router)# default-metric 1
|
Notes
|
The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes.
|
- redistribute - Enables redistribution of corresponding protocol routes into RIP
- show ip rip - Displays IP RIP protocol database or statistics
6.1.12 auto-summary - enable | disable
Enables or disables the auto-summarization of routes in RIP.
auto-summary {enable | disable}
|
Syntax Description
|
enable - Enables the auto-summarization feature in RIP.
disable - Disables the auto-summarization feature in RIP.
|
Mode
|
Router Configuration
|
Defaults
|
Enabled
|
Example
|
SEFOS(config-router)# auto-summary disable
|
Notes
|
The auto-summarization feature must be disabled to configure interface specific aggregation with RIP version 2.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.13 auto-summary
Enables the auto-summarization feature in RIP. The no form of the command disables the auto-summarization feature in RIP. This command operates similarly to the command auto-summary - enable | disable.
Mode
|
Router Configuration
|
Defaults
|
Autosummarization is enabled.
|
Example
|
SEFOS(config-router)# no auto-summary
|
Notes
|
The auto-summarization feature must be disabled to configure interface specific aggregation with RIP version 2.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.14 ip rip default route originate
Sets the metric to be used for default route propagated over the interface. The no form of the command disables origination of default route over the interface.
ip rip default route originate metric_1-15
|
no ip rip default route originate
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
no ip rip default route originate
|
Example
|
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip default route originate 10
|
Notes
|
RIP must be enabled on the interface before executing this command.
|
- show ip rip - Displays IP RIP protocol database or statistics
- network - Enables RIP on an IP network
6.1.15 default-information originate
Sets the metric to be used for default route propagated over the interface. The no form of the command disables origination of default route over the interface.
This command operates similarly to the command ip rip default route originate.
default-information originate metric_1-15 [route-map string_32]
|
no default-information originate
|
Syntax Description
|
metric_1-15 - Specifies the metric value. This value ranges between 1 and 15.
route-map - Identifies the specified route-map in the list of route-maps. The length of the string ranges between 1 and 32. The keyword route-map is not supported.
|
Mode
|
Interface Configuration
Applicable in VLAN Interface only.
|
Defaults
|
Origination of default route over the interface is disabled.
|
Example
|
SEFOS(config)# interface vlan 1
SEFOS(config-if)# default-information originate 10
|
Notes
|
RIP must be enabled on the interface before executing this command.
|
- show ip rip - Displays IP RIP protocol database or statistics
- network - Enables RIP on an IP network
6.1.16 ip rip summary-address
Sets route aggregation over an interface for all subnet routes that fall under the specified IP address and mask. The no form of the command disables route aggregation with the specified IP address and mask.
ip rip summary-address ip-address mask
|
no ip rip summary-address ip-address mask
|
Syntax Description
|
ip-address - IP Address of the interface specific aggregation.
mask - Subnet mask.
|
Mode
|
Interface Configuration
Applicable only in VLAN interface.
|
Example
|
SEFOS(config)# router rip
SEFOS(config-router)# auto-summary disable
SEFOS(config-router)# exit
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip summary-address 60.0.0.0 255.0.0.0
|
Notes
|
- This command must not be used with RIPv1 send version.
- Auto-summarization overrides interface specific aggregation. Therefore, auto-summarization must be disabled for interface specific route aggregation.
|
6.1.17 ip summary-address rip
Sets the route aggregation for all subnet routes that fall under the specified IP address and mask. The no form of the command disables route aggregation with the specified IP address and mask. This command operates similarly to the command ip rip summary-address.
ip summary-address rip ip-address mask
|
no ip summary-address rip ip-address mask
|
Syntax Description
|
ip-address - IP address of the interface specific aggregation.
mask - Subnet mask.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Example
|
SEFOS(config-if)# ip summary-address rip 60.0.0.0 255.0.0.0
|
Notes
|
- This command must not be used with RIPv1 send version.
- Auto-summarization overrides interface specific aggregation. Therefore, auto-summarization must be disabled for interface specific route aggregation.
|
6.1.18 ip rip default route install
Installs the default route received in updates to the RIP database. The no form of the command does not install default route received in updates to the RIP database.
ip rip default route install
|
no ip rip default route install
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
no ip rip default route install
|
Example
|
SEFOS(config)# interface vlan 1
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 10.0.0.1 255.255.0.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip default route install
|
Notes
|
RIP must be enabled on the interface on which this command is executed.
|
6.1.19 ip rip send version
Sets the IP RIP version number for transmitting advertisements and the no form of the command sets IP RIP send version number to its default value.
ip rip send version {1 | 2 | 1 2 | none}
|
Syntax Description
|
1 | 2 | 1 2 | none - Indicates which version of RIP updates are to be sent.
- 1 - Sends RIP updates compliant with RFC 1058.
- 2 - Sends multicasting RIP updates.
- 1 2 - Sends both multicasting RIP updates and RIP updates compliant with RFC 1058.
- none - No RIP updates are send.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
1 2
|
Example
|
SEFOS(config-if)# ip rip send version 1
|
6.1.20 ip rip receive version
Sets the IP RIP version number for receiving advertisements. The no form of the command sets the IP RIP receive version number to its default value.
ip rip receive version {1 | 2 | 1 2 | none}
|
no ip rip receive version
|
Syntax Description
|
1 | 2 | 1 2 | none - Indicates which version of RIP updates are to be sent.
- 1 - Sends RIP updates compliant with RFC 1058.
- 2 - Sends multicasting RIP updates.
- 1 2 - Sends both multicasting RIP updates and RIP updates compliant with RFC 1058.
- none - No RIP updates are send.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
1 2
|
Example
|
SEFOS(config-if)# ip rip receive version 1
|
Notes
|
The command indicates which version of RIP updates are to be accepted. rip2 and rip1 2 implies reception of multicast packets.
|
6.1.21 version
Configures global version of the RIP. The no form of the command restores the default version for the RIP. This command operates similarly to the commands ip rip send version and ip rip receive version.
version {1 | 2 | 1 2 | none}
|
Syntax Description
|
1 | 2 | 1 2 | none - Indicates which version of RIP updates are to be sent.
- 1 - Sends RIP updates compliant with RFC 1058.
- 2 - Sends multicasting RIP updates.
- 1 2 - Sends both multicasting RIP updates and RIP updates compliant with RFC 1058.
- none - No RIP updates are send.
|
Mode
|
Router Configuration
|
Defaults
|
1 2
|
Example
|
SEFOS(config-router)# version 1
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.22 ip rip authentication mode
Configures authentication mode and key. The no form of the command disables authentication.
ip rip authentication mode {text | md5} key-chain key-chain-name_16
|
Syntax Description
|
text - Clear text authentication.
md5 - Keyed Message Digest 5 (MD5) authentication. More than one entry can be configured for an interface.
key-chain - The value to be used as the Authentication Key.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
No authentication
|
Example
|
SEFOS(config-if)# ip rip authentication mode text key-chain asdf123
|
Notes
|
If a string shorter than 16 octets is supplied, it will be left-justified and padded to 16 octets, on the right, with nulls (0x00).
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.23 ip rip authentication mode {text | md5}
Configures the authentication mode. The no form of the command disables authentication. This command operates similarly to the command ip rip authentication mode.
ip rip authentication mode {text | md5}
|
no ip rip authentication mode
|
Syntax Description
|
text - Clear text authentication.
md5 - Keyed Message Digest 5 (MD5) authentication.
This command will configure mode text and key-chain with defaults.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
Authentication is disabled.
|
Example
|
SEFOS(config-if)# ip rip authentication mode text
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.24 ip rip authentication key-chain
Configures the authentication key. The no form of the command disables authentication. This command operates similarly to the command ip rip authentication mode.
ip rip authentication key-chain key-chain-name_16
|
no ip rip authentication key-chain key-chain-name_16
|
Syntax Description
|
key-chain - Name of the authentication key to be used for authentication.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
Authentication is disabled.
|
Example
|
SEFOS(config-if)# ip rip authentication key-chain test
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.25 timers basic - update-value
Sets update, route age, and garbage collection timers. The no form of the command resets update, route age, and garbage collection timers to the default values.
timers basic update-value_10-3600 routeage-value_30-500 garbage-value_120-180
|
Syntax Description
|
update-value_10-3600 - 30
routeage-value_30-500- 180
garbage-value_120-180- 120
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
update-value_10-3600 - Interval time between updates.
routeage-value_30-500- Time after which the entry is put into garbage-collect interval.
garbage-value_120-180- Interval before deleting an entry after not hearing it.
|
Example
|
SEFOS(config-if)# timers basic 20 40 150
|
Notes
|
The advertisements of garbage-value entry is set to INFINITY, while sending to others.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.26 timers basic - update-interval
Configures the update, invalid, hold down, and flush timers for RIP. This command operates similarly to the command timers basic - update-value.
timers basic update-interval_10-3600 invalid_30-500 holddown_10-3600 flush_120-180 sleep_10-3600
|
Syntax Description
|
update-interval_10-3600 - Rate (in seconds) at which the updates are sent. This is the fundamental timing parameter of the routing protocol. This value ranges between 10 and 3600 seconds.
invalid_30-500 - Time interval (in seconds) after which a route is declared as invalid. This value ranges between 30 and 500 seconds.
holddown_10-3600 - Interval (in seconds) during which the routing information regarding better paths are suppressed.
This value ranges between 10 and 3600 seconds. The keyword holddown is not supported.
flush_120-180 - Time interval (in seconds) after which the route is removed from the routing table. This value ranges between 120 and 180 seconds.
sleep_10-3600 - Interval (in milliseconds) for postponing routing updates in the event of a flash update. This value ranges between 10 and 3600 milliseconds. The keyword sleep is not supported.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Defaults
|
update-interval_10-3600 - 30
invalid_30-500 - 180
holddown_10-3600 - 180
flush_120-180 - 240
|
Example
|
SEFOS(config-if)# timers basic 20 40 180
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.27 ip split-horizon
Sets the split-horizon status and the no form of the command disables the split-horizon status.
ip split-horizon [poisson]
|
Syntax Description
|
poisson - split-horizon with poisson reverse is enabled.
|
Mode
|
Interface Configuration
Applicable only in VLAN Interface.
|
Example
|
SEFOS(config-if)# ip split-horizon
|
Notes
|
The value split-horizon denotes that split-horizon must be applied in the response packets that are going out.
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.28 debug ip rip
Sets the debug level for RIP module. The no form of the command resets the debug level for RIP module.
debug ip rip {all | init | data | control | dump | os | mgmt | failure | buffer}
|
no debug ip rip {all | init | data | control | dump | os | mgmt | failure | buffer}
|
Syntax Description
|
all - All resources.
init - Initialization and shutdown messages.
data - Data path messages.
control - Control plane messages.
dump - Packet dump messages.
os - OS resource Messages.
mgmt - Management messages.
failure - All failure messages. (All failures including packet validation.)
buffer - Buffer messages.
|
Mode
|
Privileged EXEC
|
Defaults
|
init
|
Example
|
SEFOS# debug ip rip all
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.29 debug ip rip {database | events | triggers}
Sets the debug level for RIP module. The no form of the command resets the debug level for RIP module. This command operates similarly to the command debug ip rip.
debug ip rip {database | events | triggers}
|
no debug ip rip {database | events | triggers}
|
Syntax Description
|
database - Database debug messages.
events - Trace management messages.
triggers - Triggers debug messages.
|
Mode
|
Privileged EXEC
|
Example
|
SEFOS# debug ip rip database
|
- show ip rip - Displays IP RIP protocol database or statistics
6.1.30 show ip rip
Displays IP RIP protocol database or statistics.
show ip rip {database ip-address ip-mask | statistics}
|
Syntax Description
|
database - RIP protocol database for the specified IP address and IP mask of the RIP interface entry.
statistics - RIP statistics on the router.
|
Mode
|
Privileged EXEC
|
Example
|
SEFOS# show ip rip database 40.0.0.0 255.0.0.0
40.0.0.0/8 directly connected, vlan1
SEFOS# show ip rip statistics
Vrf default
RIP Global Statistics:
----------------------
Total number of route changes is 0
Total number of queries responded is 0
Total number of dropped packets is 0
RIP Interface Statistics:
-------------------------
Interface Periodic BadRoutes Triggered BadPackets Admin
IP Address Updates Sent Received Updates Sent Received Status
---------- ------------ --------- ------------ ---------- ------
10. 0.0.1 0 0 1 0 Enabled
|

Sun Ethernet Fabric Operating System CLI Enterprise Reference Manual
|
E26514-03
|
  
|
Copyright © 2013, Oracle and/or its affiliates. All rights reserved.