man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

Please tell us how to improve our documentation:


0 of 500

0 of 500



0 of 500
Thank you for your feedback! If you want to participate in content improvement and share additional information, please click Feedback button.
Rate this document:

noenable(9F)

Name

noenable - prevent a queue from being scheduled

Synopsis

#include <sys/stream.h>
#include <sys/ddi.h>

void noenable(queue_t *q);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the queue.

Description

The noenable() function prevents the q from being scheduled for service by insq(9F), putq(9F) or putbq(9F) when enqueuing an ordinary priority message. The queue can be re-enabled with the enableok(9F) function.

Context

The noenable() function can be called from user, interrupt, or kernel context.

See also

enableok(9F), insq(9F), putbq(9F), putq(9F), qenable(9F)

Writing Device Drivers for Oracle Solaris 11.2

STREAMS Programming Guide