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Preface

The FMW Composer Online Help provides information about using the various features of FMW Composer.




	Audience


	Documentation Accessibility


	Related Resources


	Conventions






Audience

 This document is intended for administrators who use FMW Composer to configure and manage Oracle Fusion Middleware.





Documentation Accessibility



For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.








Related Resources

For more information, see the Oracle Fusion Middleware documentation library.





Conventions

The following text conventions are used in this document:


	Convention	Meaning
	boldface

	Boldface type indicates graphical user interface elements associated with an action, or terms defined in text or the glossary.


	italic

	Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular values.


	monospace

	Monospace type indicates commands within a paragraph, URLs, code in examples, text that appears on the screen, or text that you enter.













1 Overview of FMW Composer

FMW Composer is a client application that provides a graphical user interface for describing the elements of a Fusion Middleware topology, such as the hosts, Oracle homes, domains, servers, and so on.

With FMW Composer, you can create a topology from scratch, as well as make edits and updates to an existing topology. Once you finish creating or updating a topology, you can save your topology to a topology file, which can be a XML or JSON file. You can use this file as input with the Oracle Lifecycle Management (LCM) standard actions to configure and manage your Fusion Middleware environment. For more information, see About the Lifecycle Management Tools in Configuring Oracle Fusion Middleware
Using Lifecycle Management Tools.

The following help topics provide information on using the menus, toolbar, panels, and other features in FMW Composer:







	File Menu Commands

The File menu includes commands for creating a file, opening a file, saving a file, displaying the Settings page, and quitting FMW Composer.
	Edit Menu Commands

The Edit menu includes commands for adding, assigning, removing, and deleting elements of your topology. This menu is context sensitive (the menu options that you can choose from are related to the selected element on the screen).
	Help Menu Commands

Use the Help menu to get help using the various features of the Oracle Lifecycle Management (LCM) Tools You can also use this menu to obtain and verify the version number for FMW Composer.
	About the FMW Composer Toolbar

The FMW Composer toolbar appears at the top of the window. You can use the toolbar to create a new file, save a file, add an element to the topology, delete an element, and more.
	Topology Properties

The Topology Properties panel allows you to specify information about the topology file you are editing, such as the name and version of the file.
	Blueprint

A blueprint file lists and defines the configuration templates required to create a domain.
	Domain Profile

You can use the domain profile file type to specify information about a domain, such as server, cluster, template, and server group information.
	About the Elements of a Topology File

You can use FMW Composer to create, define, and edit the elements of your topology. Specifically, FMW Composer has a context-sensitive panel located on the right side of the screen with fields where you can specify information about each element.
	Tuning Parameter Settings

Tuning parameters allow you to customize or tune additional configuration settings for various elements.
	Validation Panel

The validation panel allows you to see and correct any errors that occur while you are editing the topology file.




1.1 File Menu Commands

The File menu includes commands for creating a file, opening a file, saving a file, displaying the Settings page, and quitting FMW Composer.


	Command	Description
	New

	Creates a new, empty file.

The following file types are available:

	Topology: Use this file type to define the topology of a Fusion Middleware environment (hosts, Oracle homes, domains, etc.).


	Blueprint: Use this file type to define the configuration templates required to create a domain.


	Domain Profile: Use this file type to specify information about a domain in a separate file outside of the topology.




Shortcut: [image: New File icon]


	Open File...

	Opens an existing file.

Shortcut: [image: Open File icon]


	Save

	Saves the current page to a file. If the current page is already associated with a file, the page will be saved to that file.

If the current page is not associated with a file:

	If you are saving a topology, you will be prompted to enter a file name and specify a directory location on your system. The file name must include the suffix .json or .xml. For example, topology.xml.


	If you are saving a blueprint or domain profile, you will be prompted to specify a directory location on your system. The file name is automatically generated using the id-version.xml or id-version.json format.




Shortcut: [image: Save File icon]


	Save As...

	Saves the current page to a file. You can save the file either as a XML file or JSON file.

	If you are saving a topology, you will be prompted to enter a file name and specify a directory location on your system. The file name must include the suffix .json or .xml. For example, topology.xml.


	If you are saving a blueprint or domain profile, you will be prompted to specify a directory location on your system. The file name is automatically generated using the id-version.xml or id-version.json format.




Shortcut: [image: Save File icon]


	Settings

	Displays the Settings page. Use the Settings page to display and set Composer settings, such as the directory path of the Oracle home and the wallet file for environment credentials. On the Settings page, you can:

	Assign an existing wallet to a topology.


	Create a new wallet for a topology.


	Specify the location of an Oracle home directory for a topology.





	Exit

	Exits FMW Composer. Any unsaved changes will be discarded.












1.2 Edit Menu Commands

The Edit menu includes commands for adding, assigning, removing, and deleting elements of your topology. This menu is context sensitive (the menu options that you can choose from are related to the selected element on the screen).

You can invoke these commands using one of the following methods:

	From the Edit menu itself.


	From the right-click (context) menu.




Note that this menu will only list the actions that you can perform on the selected element.








1.3 Help Menu Commands

Use the Help menu to get help using the various features of the Oracle Lifecycle Management (LCM) Tools You can also use this menu to obtain and verify the version number for FMW Composer.


	Command	Description
	About the Life Cycle Tools

	Provides an introduction to the Oracle LCM Tools.


	Getting Started

	Provides information on how to get started using the LCM Tools, such as locating the LCM Tools in an Oracle home, using the LCM Tools tutorial, and getting help with FMW Composer.


	Tutorial

	Displays a tutorial that shows you step-by-step how to use the LCM Tools to configure a sample Oracle SOA Suite topology.


	About

	Displays the version number and build information for FMW Composer.












1.4 About the FMW Composer Toolbar

The FMW Composer toolbar appears at the top of the window. You can use the toolbar to create a new file, save a file, add an element to the topology, delete an element, and more.

Some of the toolbar buttons might appear grayed out. These options are context sensitive and become enabled only after you select an element on the current page. For example, if you select a host, then only the buttons related to that host are enabled. 

[image: FMW Composer toolbar. Each option is described in the surrounding text.]



	Button	Description	Menu Location
	[image: New File icon]	Creates a new, empty file.

The following file types are available:

	Topology: Use this file type to define the topology of a Fusion Middleware environment (hosts, Oracle homes, domains, etc.).


	Blueprint: Use this file type to define the configuration templates required to create a domain.


	Domain Profile: Use this file type to specify information about a domain in a separate file outside of the topology.




	Select File and then New


	[image: Open File icon]	Opens an existing file.

	Select File and then Open...


	[image: Save File icon]	Saves the current page to a file. If the current page is already associated with a file, the page will be saved to that file.

If the current page is not associated with a file:

	If you are saving a topology, you will be prompted to enter a file name and specify a directory location on your system. The file name must include the suffix .json or .xml. For example, topology.xml.


	If you are saving a blueprint or domain profile, you will be prompted to specify a directory location on your system. The file name is automatically generated using the id-version.xml or id-version.json format.




	Select File and then Save


	[image: Add New Item icon]	Adds a new element (host, Oracle home, etc.) to the active file. This button is only available for the Topology and Domain Profile file types.

This button is context-sensitive (the elements you can choose from are related to the selected element on the screen).

	Edit


	[image: Assign Existing Item icon]	Assigns or maps an existing element to another element. For example, you might use this button to assign an Oracle home to a host.

This button is context-sensitive (the elements you can assign are related to the selected element on the screen).

	Edit


	[image: Remove Item icon]	Removes or unassigns an existing element from another element. For example, you might use this button to remove an Oracle home from an assigned host.

You must select the element you want to remove.

	Edit


	[image: Delete Item icon]	Deletes an existing element from the active file. This button is only available for the Topology and Domain Profile file types.

You must select the element you want to delete.

	Edit


	[image: Diagram Help icon]	Use this option to get help for an element on the screen.

After you click this button, select an element (for example, a host) on the screen to open the online help for that element.

	N/A















1.5 Topology Properties

The Topology Properties panel allows you to specify information about the topology file you are editing, such as the name and version of the file.


	Property	Description
	ID

	A unique name for the topology file used to identify this file from other files.


	Version

	The version number of this topology file. For example, 1.0, 2.0, 3.0, and so on.

If you need to make an update to the topology, this property allows you to create multiple versions of the file and distinguish them from one another.


	FMW Version Range

	This field identifies the minimum or exact Fusion Middleware version of the file. For example, [12.1.3,) means any version starting from and including 12.1.3.


	Variables

	Use this field to define any variables you want to use when setting values in the topology file. A variable represents an actual value in your environment. A variable includes two parts: 	The Name of the variable. The name can contain alphanumeric characters. The % character should not be used in the variable name.


	The Value of the variable. This is an actual value from your environment that the variable name represents.







	Directories

	To add a LDAP directory component to the topology, click [image: Add New Item icon]. A dialog box will appear where you can specify information about a directory.

To remove a directory component from the topology, select the name of the directory and click [image: Delete item icon].

To edit the information for an existing directory component, select the name of the directory and click [image: Edit icon].


	Miscellaneous Properties

	Use this field to add additional property settings for a topology.

	To add a property setting to the topology, click [image: Add New Item icon]. A dialog box will appear where you can define a Name and Value for the property.


	To remove a property from the topology, select the name of the property and click [image: Delete item icon].


	To edit the value of an existing property, select the name of the property and click [image: Edit icon].














	Directory

The Directory panel contains fields that you can use to specify information (or attributes) for a LDAP directory.




1.5.1 Directory

The Directory panel contains fields that you can use to specify information (or attributes) for a LDAP directory.


	Attribute	Description
	ID

	A unique name used to identify the directory.

The default ID is dir.


	Type

	Use the drop-down list to specify the directory type of the LDAP server. Valid types include:

	OUD


	OID_LDAP


	AD


	LBR_OUD


	LBR_OID


	ODSEE_LDAP





	Port

	The port number of the LDAP server.


	RCU Connect String

	The connect string used by RCU to connect to the database:

db_host:db_port:service_name

Where db_host is the host name of the machine on which the database resides, db_port is the listener port of the database, and service_name is the service name identified for the database.


	Credential

	The password used to connect to the LDAP server.

Click select to select the password from the wallet or add the password to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.





	Search Base

	The search base for the LDAP server in DN format.


	User Search Base

	The user search base for the LDAP server in DN format.


	Group Search Base

	The group or enterprise search base for the LDAP server in DN format.


	LBR URL

	Load balancer URL


	Miscellaneous Config

	Use this field to add additional configuration property settings for a directory.

	To add a configuration setting for a directory, click [image: Add New Item icon]. A dialog box will appear where you can define a Name and Value for a property.


	To remove a property, select the name of the property and click [image: Delete item icon].


	To edit the value of an existing property, select the name of the property and click [image: Edit icon].

















1.6 Blueprint

A blueprint file lists and defines the configuration templates required to create a domain.

Attributes Tab
Use the Attributes tab to specify information about the blueprint file.


	Attribute	Description
	ID

	A unique name for the blueprint used to identify this blueprint file from other files.


	Version

	The version number of this blueprint. For example, 1.0, 2.0, 3.0, and so on.

If you need to make an update to the blueprint, this property allows you to create multiple versions of the file and distinguish them from one another.


	FMW Version Range

	This field identifies the minimum or exact Fusion Middleware version of the file. For example, [12.1.3,) means any version starting from and including 12.1.3.


	Referenced Blueprints

	Use this field to add a blueprint to the current file.











Templates Tab
Use the Templates tab to add or remove domain templates from the blueprint.








1.7 Domain Profile

You can use the domain profile file type to specify information about a domain, such as server, cluster, template, and server group information.

Attributes Tab
Use the Attributes tab to specify information about the file. 


	Attributes	Description
	ID

	A unique name for the domain profile file used identify this domain profile from other files.


	Version

	The version number of this file. For example, 1.0, 2.0, 3.0, and so on.

If you need to make an update to the file, this property allows you to create multiple versions of the file and distinguish them from one another.


	FMW Version Range

	This field identifies the minimum or exact Fusion Middleware version of the file. For example, [12.1.3,) means any version starting from and including 12.1.3.


	External Profile

	Use this field to add a domain profile to the current file.











Blueprints Tab
Use the Blueprints tab to define the blueprints for the domain.

	Click [image: Add New Item icon] to add a blueprint to the domain.

If you have not provided the path to the Oracle home directory on the Composer Settings page (located in the File menu), you will be prompted to specify the path to the Oracle home.


	To edit a blueprint, select the blueprint from the list and click [image: Edit icon].

This will open the blueprint file in a new tab.


	To remove a blueprint from the domain, select the blueprint from the list and click [image: Delete Item icon].







Server Groups Tab
The Server Groups tab displays a list of server groups only if at least one of the templates in a selected blueprint defines a server group. You can assign a server group to a server or cluster.










1.8 About the Elements of a Topology File

You can use FMW Composer to create, define, and edit the elements of your topology. Specifically, FMW Composer has a context-sensitive panel located on the right side of the screen with fields where you can specify information about each element.

You can access a panel by selecting an element on the screen.

For more information about each element panel, see the following topics:







	Host

The Host panel contains fields that you can use to specify information (or attributes) for a host in the topology.
	Oracle Home

The Oracle Home panel contains fields that you can use to specify information (or attributes) for an Oracle home in the topology.
	Domain

The Domain panel contains an Attributes tab that you can use to specify information (or attributes) for a domain in the topology. The Blueprints and Server Groups tabs allow you to add domain templates and server groups, respectively.
	Server

The Server panel contains an Attributes tab that you can use to specify information (or attributes) for a server in the topology. The Server Groups tab allows you to select and assign server groups to the selected server.
	Node Manager

The Node Manager panel contains fields that you can use to specify information (or attributes) for a Node Manager in the topology.
	Cluster

The Cluster panel contains an Attributes tab that you can use to specify information (or attributes) for a cluster in the topology. The Server Groups tab allows you to select and assign server groups to the selected cluster.
	Database

The Database panel contains fields that you can use to specify information (or attributes) for a database associated with the topology.
	Data Source

The Data Source panel contains fields that you can use to specify information (or attributes) for a data source.
	Schema

The Schema panel contains fields that you can use to specify information (or attributes) for a schema.
	Web Tier

The Web Tier panel contains fields that you can use to specify information (or attributes) for a web tier component in the topology.




1.8.1 Host

The Host panel contains fields that you can use to specify information (or attributes) for a host in the topology.


	Attribute	Description
	ID

	A unique name for the host used to identify this host from other elements.

When you add a new host, the default ID is host1. If host1 is already used in the topology, FMW Composer will default to host2, then host3, and so on.


	Address

	The primary IP address or DNS name of the host.


	Credential

	The credential from the wallet that will be used to connect to the host.

Click select to select the credential for the host from the wallet or add the credential to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.





	LCM Listen Port

	The port that the LCM Agent on this host is listening for REST requests on.


	Directory

	Use this field to add a directory to this host.

Click change to select a directory for the host. A dialog box will appear with a list of directories only if you added and defined at least one directory on the Topology Properties panel.

After you add a directory to this host, you can click edit to edit the information for that directory.


	Additional Addresses

	Use this field to specify additional IP addresses or DNS names for a host.












1.8.2 Oracle Home

The Oracle Home panel contains fields that you can use to specify information (or attributes) for an Oracle home in the topology.


	Attribute	Description
	ID

	A unique name for the Oracle home used to identify the Oracle home from other elements.

When you add a new Oracle home, the default ID is home1. If home1 is already used in the topology, FMW Composer will default to home2, then home3, and so on.


	Type

	Indicates whether the Oracle home is on a local file system (and disk) or on a shared file system (and disk).

Valid values are local or shared.


	Path

	The full path to a directory on the file system. This is the path to the directory where the Oracle home is (or will be) installed on your system.


	Java Home

	The full path to a directory on the file system. This is the path to a directory where a JDK is installed on your system.

For example, /home/Oracle/products/jdk1.8.0_77.


	Inventory Location

	The location where you want to create your central inventory.

This field is required if you are installing any Oracle product for the first time on a host that is running UNIX or Linux system software. For more information, see Understanding the Oracle Central Inventory in Installing Software with the
Oracle Universal Installer.


	Installations

	 Installation data required to create an Oracle home and install a product.

	ID: Enter a unique name to identify the distribution you are installing. For example, you might enter infra for Fusion Middleware Infrastructure or soa for Oracle SOA Suite.


	Install Type: Specify the type of install you want to perform. This value will differ depending on your product distribution.

For example, for the Fusion Middleware Infrastructure distribution, the following install types are valid:

	Fusion Middleware Infrastructure


	Fusion Middleware Infrastructure With Examples





	Installer: The full path and file name of the distribution installer file. For example, to install Fusion Middleware Infrastructure:

path_to_infrastructure_jar_file/fmw_12.2.1.1.0_infrastructure_generic.jar





	Patches

	List of patches to be applied to the Oracle home.

	Click [image: Add New Item icon] to add a patch to this list.


	To remove a patch, select the patch from the list and click [image: Delete Item icon].


	To edit a patch, select the patch from the list and click [image: Edit icon].















1.8.3 Domain

The Domain panel contains an Attributes tab that you can use to specify information (or attributes) for a domain in the topology. The Blueprints and Server Groups tabs allow you to add domain templates and server groups, respectively.

Attributes Tab




	Attribute	Description
	ID

	A unique name for the domain used to identify this domain from other elements.

When you add a new domain, the default ID is domain1. If domain1 is already used in the topology, FMW Composer will default to domain2, then domain3, and so on.


	Name

	The name of the domain.


	Type

	Indicates whether the domain directory is on a local file system (and disk) or on a shared file system (and disk).

Valid values are local or shared.


	Path

	The full path to a directory on the file system. This is the directory where the domain is (or will be) located on your system.


	Application Path

	The full path to a directory on the file system. This is the directory where selected applications related to the domains you configure will be created.


	Admin Credential

	The administrative credential from the wallet that will be used to access the domain’s WebLogic Administration Server.

Click select to select the credential from the wallet or add the credential to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.





	Admin Server Url

	The URL used to connect to the domain’s Administration Server in the following format:

http://adminserver_host:adminserver_port

Where:

	adminserver_host is the host name or IP address of the host where the Administration Server resides.


	adminserver_port is the port number used by the Administration Server.





	External Profile

	Use this field to select a domain profile for the domain.


	defaultCoherencePort

	The port of the Coherence cluster.


	Tuning Parameter Variables

	Use this field to define any variables you want to use when setting values for tuning parameters. A variable represents an actual value in your environment. A variable includes two parts: 	The Name of the variable. The name can contain alphanumeric characters. The % character should not be used in the variable name.


	The Value of the variable. This is an actual value from your environment that the variable name represents.






The following reserved variables are fixed and cannot be changed:

	%ADMINSERVER%, which will always resolve to the name of the Administration Server.


	%DOMAIN%, which will always resolve to the name of the domain.





	Tuning Parameter Imports

	Use this field to import tuning parameter settings from a separate tuning parameter XML or JSON file.


	Tuning Parameter Settings

	Composer provides a predefined list of tuning parameter settings that you can apply to a domain.

	To add a new tuning parameter, click [image: Add New Item icon] to display a dialog box with a drop-down menu of available tuning parameters you can set.


	To edit a value for an existing tuning parameter, select that parameter from the list of settings and click [image: Edit icon].


	To remove a tuning parameter, select that parameter from the list of settings and click [image: Delete Item icon] .





	Tuning Parameter External Settings

	Use this field to add, remove, or edit an external tuning parameter setting (either MBean or WLST).	Click [image: Add New Item icon] to add a MBean or WLST setting.


	To remove an external tuning parameter setting, select that setting from the list and click [image: Delete Item icon].


	To edit an existing external tuning parameter setting, select that setting from the list and click [image: Edit icon].













Blueprints Tab
Use the Blueprints tab to define the blueprints for the domain.

	Click [image: Add New Item icon] to add a blueprint to the domain.

If you have not provided the path to the Oracle home directory on the Composer Settings page (located in the File menu), you will be prompted to specify the path to the Oracle home.


	To edit a blueprint, select the blueprint from the list and click [image: Edit icon].

This will open the blueprint file in a new tab.


	To remove a blueprint from the domain, select the blueprint from the list and click [image: Delete Item icon].







Server Groups Tab
The Server Groups tab displays a list of server groups only if at least one of the templates in a selected blueprint defines a server group. You can assign a server group to a server or cluster in this domain.








1.8.4 Server

The Server panel contains an Attributes tab that you can use to specify information (or attributes) for a server in the topology. The Server Groups tab allows you to select and assign server groups to the selected server.

Attributes Tab

	Attribute	Description
	ID

	A unique name for the server used to identify this server from other elements in a domain.

When you add a new server to a domain, the default ID is server1. If server1 is already used in the domain, FMW Composer will default to server2, then server3, and so on.


	Is Admin Server

	Select this option if this server is the Administration Server.


	Name

	Name of the server.


	Listen Address

	The IP address or DNS name this server uses to listen for incoming connections.


	Listen Port

	The port that this server uses to listen for regular (non-SSL) incoming connections.


	SSL Listen Port

	The port that this server uses to listen for SSL incoming connections.


	Tuning Parameter Variables

	Use this field to define any variables you want to use when setting values for tuning parameters. A variable represents an actual value in your environment. A variable includes two parts: 	The Name of the variable. The name can contain alphanumeric characters. The % character should not be used in the variable name.


	The Value of the variable. This is an actual value from your environment that the variable name represents.






The following reserved variables are fixed and cannot be changed:

	%ADMINSERVER%, which will always resolve to the name of the Administration Server.


	%DOMAIN%, which will always resolve to the name of the domain.


	%SERVER%, which will always resolve to the name of the server.





	Tuning Parameter Imports

	Use this field to import tuning parameter settings from a separate tuning parameter XML or JSON file.


	Tuning Parameter Settings

	Composer provides a predefined list of tuning parameter settings that you can apply to a server.

	To add a new tuning parameter, click [image: Add New Item icon] to display a dialog box with a drop-down menu of available tuning parameters you can set.


	To edit a value for an existing tuning parameter, select that parameter from the list of settings and click [image: Edit icon].


	To remove a tuning parameter, select that parameter from the list of settings and click [image: Delete Item icon] .














Server Groups Tab
The Server Groups tab displays the server groups assigned to the server.

	Click [image: Add New Item icon] to select server group(s) to assign to the server. A dialog box will appear with a list of server groups only if at least one of the templates in a selected blueprint defines a server group.


	Click [image: Delete Item icon] to remove or unassign the selected server groups from the server.











1.8.5 Node Manager

The Node Manager panel contains fields that you can use to specify information (or attributes) for a Node Manager in the topology.


	Attribute	Description
	ID

	A unique name for the Node Manager used to identify this Node Manager from other elements.

When you add a new Node Manager, the default ID is nm1. If nm1 is already used in the topology, FMW Composer will default to nm2, then nm3, and so on.


	Name

	Name of the Node Manager.


	Credential

	The credential from the wallet that will be used to connect to the Node Manager.

Click select to select the credential from the wallet or add the credential to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.





	Tuning Parameter Variables

	Use this field to define any variables you want to use when setting values for tuning parameters. A variable represents an actual value in your environment. A variable includes two parts: 	The Name of the variable. The name can contain alphanumeric characters. The % character should not be used in the variable name.


	The Value of the variable. This is an actual value from your environment that the variable name represents.






The following reserved variable is fixed and cannot be changed:

	%NODEMANAGER%, which will always resolve to the name of the Node Manager.





	Tuning Parameter Imports

	Use this field to import tuning parameter settings from a separate tuning parameter XML or JSON file.


	Tuning Parameter Settings

	Composer provides a predefined list of tuning parameter settings that you can apply to a Node Manager, such as the Node Manager port.

	To add a new tuning parameter, click [image: Add New Item icon] to display a dialog box with a drop-down menu of available tuning parameters you can set.


	To edit a value for an existing tuning parameter, select that parameter from the list of settings and click [image: Edit icon].


	To remove a tuning parameter, select that parameter from the list of settings and click [image: Delete Item icon] .





	Tuning Parameter External Settings

	Use this field to add, remove, or edit an external tuning parameter setting (either MBean or WLST).	Click [image: Add New Item icon] to add a MBean or WLST setting.


	To remove an external tuning parameter setting, select that setting from the list and click [image: Delete Item icon].


	To edit an existing external tuning parameter setting, select that setting from the list and click [image: Edit icon].

















1.8.6 Cluster

The Cluster panel contains an Attributes tab that you can use to specify information (or attributes) for a cluster in the topology. The Server Groups tab allows you to select and assign server groups to the selected cluster.

Attributes Tab

	Attribute	Description
	ID

	A unique name for the cluster used to identify this cluster from other elements in a domain.

When you add a new cluster to a domain, the default ID is cluster1. If cluster1 is already used in the domain, FMW Composer will default to cluster2, then cluster3, and so on.


	Name

	The name of the cluster.


	Tuning Parameter Variables

	Use this field to define any variables you want to use when setting values for tuning parameters. A variable represents an actual value in your environment. A variable includes two parts: 	The Name of the variable. The name can contain alphanumeric characters. The % character should not be used in the variable name.


	The Value of the variable. This is an actual value from your environment that the variable name represents.






The following reserved variables are fixed and cannot be changed:

	%ADMINSERVER%, which will always resolve to the name of the Administration Server.


	%DOMAIN%, which will always resolve to the name of the domain.


	%CLUSTER%, which will always resolve to the name of the cluster.





	Tuning Parameter Imports

	Use this field to import tuning parameter settings from a separate tuning parameter XML or JSON file.


	Tuning Parameter Settings

	Composer provides a predefined list of tuning parameter settings that you can apply to a cluster, such as the cluster address.

	To add a new tuning parameter, click [image: Add New Item icon] to display a dialog box with a drop-down menu of available tuning parameters you can set.


	To edit a value for an existing tuning parameter, select that parameter from the list of settings and click [image: Edit icon].


	To remove a tuning parameter, select that parameter from the list of settings and click [image: Delete Item icon] .





	Tuning Parameter External Settings

	Use this field to add, remove, or edit an external tuning parameter setting (either MBean or WLST).	Click [image: Add New Item icon] to add a MBean or WLST setting.


	To remove an external tuning parameter setting, select that setting from the list and click [image: Delete Item icon].


	To edit an existing external tuning parameter setting, select that setting from the list and click [image: Edit icon].
















Server Groups Tab
The Server Groups tab displays the server groups assigned to the cluster.

	Click [image: Add New Item icon] to select server group(s) to assign to the cluster. A dialog box will appear with a list of server groups only if at least one of the templates in a selected blueprint defines a server group.


	Click [image: Delete Item icon] to remove or unassign the selected server groups from the cluster.











1.8.7 Database

The Database panel contains fields that you can use to specify information (or attributes) for a database associated with the topology.


	Attribute	Description
	ID

	A unique name for the database used to identify the database from other elements.

When you add a new database, the default ID is database1. If database1 is already used in the topology, FMW Composer will default to database2, then database3, and so on.


	Vendor

	The type of database server.

Valid values are ORACLE, EBR, SQLSERVER, IBMDB2, or MYSQL.


	Driver Class

	The fully qualified Java class name of the non-XA JDBC driver.


	XA Driver Class

	The fully qualified Java class name of the XA JDBC driver.


	RCU Connect String

	The connect string used by RCU to connect to the database:

db_host:db_port/service_name

Where db_host is the host name of the machine on which the database resides, db_port is the listener port of the database, and service_name is the service name identified for the database.


	DBA Credential

	The credential from the wallet that will be used for actions that require DBA privileges.

Click select to select the credential from the wallet or add the credential to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.





	DBA Role

	Select the database user role from the drop-down list:

	SYSDBA (for the SYS user on Oracle databases)


	Normal














	Node

The Node panel contains fields that you can use to specify information (or attributes) for a node assigned to a database.




1.8.7.1 Node

The Node panel contains fields that you can use to specify information (or attributes) for a node assigned to a database.


	Attribute	Description
	ID

	A unique name for the node element used to identify the node from other elements.

When you add a new node to a database, the default ID is node1. If node1 is already used within a database, FMW Composer will default to node2, then node3, and so on.


	Connect String

	The JDBC URL that is used to connect to the database repository.

For example, for Oracle databases:

jdbc:oracle:thin:@db_host:db_port/service_name

Where db_host is the host name of the machine on which the database resides, db_port is the listener port of the database, and service_name is the service name identified for the database.














1.8.8 Data Source

The Data Source panel contains fields that you can use to specify information (or attributes) for a data source.


	Attribute	Description
	Type

	The data source type. Valid types include:

	Generic: generic data source


	Multi: multi data source





	XA

	Specifies whether an XA driver must be used for the data source.


	Tuning Parameter Variables

	Use this field to define any variables you want to use when setting values for tuning parameters. A variable represents an actual value in your environment. A variable includes two parts: 	The Name of the variable. The name can contain alphanumeric characters. The % character should not be used in the variable name.


	The Value of the variable. This is an actual value from your environment that the variable name represents.






The following reserved variables are fixed and cannot be changed:

	%ADMINSERVER%, which will always resolve to the name of the Administration Server.


	%DOMAIN%, which will always resolve to the name of the domain.





	Tuning Parameter Imports

	Use this field to import tuning parameter settings from a separate tuning parameter XML or JSON file.


	Tuning Parameter Settings

	Composer provides a predefined list of tuning parameter settings that you can apply to a data source, such as a timeout on a data source.

	To add a new tuning parameter, click [image: Add New Item icon] to display a dialog box with a drop-down menu of available tuning parameters you can set.


	To edit a value for an existing tuning parameter, select that parameter from the list of settings and click [image: Edit icon].


	To remove a tuning parameter, select that parameter from the list of settings and click [image: Delete Item icon] .





	Tuning Parameter External Settings

	Use this field to add, remove, or edit an external tuning parameter setting (either MBean or WLST).	Click [image: Add New Item icon] to add a MBean or WLST setting.


	To remove an external tuning parameter setting, select that setting from the list and click [image: Delete Item icon].


	To edit an existing external tuning parameter setting, select that setting from the list and click [image: Edit icon].

















1.8.9 Schema

The Schema panel contains fields that you can use to specify information (or attributes) for a schema.


	Attribute	Description
	Shared

	Use the drop-down list to specify whether the schema is shared with other domains. Valid values are No, Primary, or Yes.

	No: The schema is not shared.


	Primary: The schema is owned by the current domain but shared with other domains.


	Yes: The schema is owned by another primary domain.





	Credential

	The password for the schema.

Click select to select the password from the wallet or add the password to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.





	Prefix

	Prefix for your schema.


	Component Info

	Full path to the location of the ComponentInfo.xml file. The default location is ORACLE_HOME/oracle_common/rcu/config.


	Storage Location

	Full path to the location of the StorageInfo.xml file. The default location is ORACLE_HOME/oracle_common/rcu/config.


	Tablespace

	Tablespace name of the component.


	Temp Tablespace

	TEMP tablespace name of the component.


	Auxiliary Schema Credentials

	The schema passwords for auxiliary schemas.












1.8.10 Web Tier

The Web Tier panel contains fields that you can use to specify information (or attributes) for a web tier component in the topology.


	Attribute	Description
	ID

	A unique name used for the web tier component.

When you add a new web tier, the default ID is tier1. If tier1 is already used in the topology, FMW Composer will default to tier2, then tier3, and so on.


	Name

	Name of the web tier component.


	Type

	Use the drop-down list to specify the component type:

	OHS: Oracle HTTP Server


	OTD: Oracle Traffic Director





	Address

	The listen address to use for this component.


	Admin Credential

	Click select to select the password from the wallet or add the password to the wallet. When you click select, a dialog box will appear with a list of credentials to choose from only if you have provided the path to a wallet on the Composer Settings page (located in the File menu).

	If the credential exists in the wallet, select the credential from the list and click OK.


	If the credential does not exist, click New to add the credential to the wallet.














	Virtual Host

The Virtual Host panel contains fields that you can use to specify information (or attributes) for a virtual host.




1.8.10.1 Virtual Host

The Virtual Host panel contains fields that you can use to specify information (or attributes) for a virtual host.


	Attribute	Description
	ID

	A unique name used for the virtual host.

When you add a new virtual host to a web tier component, the default ID is host1. If host1 is already used within a web tier, FMW Composer will default to host2, then host3, and so on.


	Name

	Name of the virtual host.


	Server Address

	The server address for this virtual host. 


	Server Admin

	The email address for the server administrator. This is displayed on error pages to help the user contact technical support.


	Protocol

	The protocol to use (HTTP or HTTPS).











	Location






1.8.10.1.1 Location




	Attribute	Description
	ID

	A unique name for the Location element.

When you add a new location element to a virtual host, the default ID is loc1. If loc1 is already used within a virtual host element, FMW Composer will default to loc2, then loc3, and so on.


	WebLogic Host

	The host name for the Administration Server.


	WebLogic Port

	The port for the Administration Server.


	WebLogic Cluster

	List of Oracle WebLogic clusters that can be used for load balancing.


	Handler

	weblogic-handler


	WL Proxy SSL

	Valid values are ON or OFF.


	WL Proxy SSL Pass Through

	Valid values are ON or OFF.


















1.9 Tuning Parameter Settings

Tuning parameters allow you to customize or tune additional configuration settings for various elements.

FMW Composer provides a predefined list of parameters that you can edit for the following elements:

	Domain


	Server


	Cluster


	Node Manager


	Data Source




To add a tuning parameter for an element, select that element on the current page. Then, in the Attributes panel, click [image: Add New Item] under Tuning Parameter Settings. This will display a dialog box with a drop-down menu of available tuning parameters you can set.








1.10 Validation Panel

The validation panel allows you to see and correct any errors that occur while you are editing the topology file.

To locate an error in FMW Composer, select the error message from the list, and then click [image: Go To icon]. You can also double-click the error message to go straight to the panel that contains the error.

After you correct the errors, click [image: Refresh icon] to refresh the list and verify that the errors have been resolved.
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