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About the Oracle WebCenter Forms Recognition Update Guide 

This guide provides information about updating WebCenter Forms Recognition products from a previous 

version to WebCenter Forms Recognition 14c (14.1.1.0.0). 

Read this guide before you update Runtime Server machines, Verifier and Designer workstations, and Web 

Verifier servers. 

We recommend completing the update procedure in a development environment before updating a production 

environment. 

Affected Workstations and Servers 

The update affects the following workstations or servers. 

 Runtime Server (RTS) machines 

 Verifier workstations 

 Development workstations 

 Web Verifier servers 

 Web Verifier workstations. Refer to Technical Specification Guide for supported browsers. 

Service Names 

The installer deletes the Runtime Service and the System Monitoring service and recreates them with new 

names when upgrading from version 12.2.1.3 or earlier. 
 

Possible previous service names New service name 

 IDC-distiller Runtime Service Manager 

 WebCenter Forms Recognition 

Distiller Runtime Service 

Management Console 

 Perceptive WebCenter Forms Recognition 
Runtime Service Manager 

WebCenter Forms Recognition Runtime Service 

Manager 

ABBY SDK 10 Licensing Service 

ABBY SDK 11 Licensing Service 

WebCenter Forms Recognition Core Service 

 IDC-distiller System Monitoring 

 WebCenter Forms Recognition Distiller 
System Monitoring 

 Perceptive WebCenter Forms 

Recognition System Monitoring 

WebCenter Forms Recognition System Monitoring 

 
Back Up all Data and Settings 

To retain your unique customizations and back up your settings, consult your database administrator to create 

a full database backup of the ORACLE or MS SQL Server database. Then, complete the following tasks. 

Note: Archive the backup data in read-only format until WebCenter Forms Recognition is running in a 
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production environment. Neither Oracle nor any of its authorized resellers are responsible for lost data caused 

by any update procedure described in this document. 

 Back Up Runtime Server Settings 

 Note the Runtime Service Manager Settings 

 Back Up Project-Related Data 

 Back Up the Application Files 

 Back Up the Configuration Files 

 Back Up Permissions and Security Settings 

Back Up Runtime Server Settings 

To back up the RTS settings, complete the following steps. 

1. Stop all WebCenter Forms Recognition services. 

2. Launch WebCenter Forms Recognition Runtime Service Management Console. 

3. In the WebCenter Forms Recognition Admin window, in the left pane, right-click the top machine 
node and click Stop All. 

4. Repeat the previous step for each machine. 

5. To export the settings, complete the following substeps. 

1. In the left pane, right-click an instance and then click Export Settings. 

2. In the Save As dialog box, navigate to your backup directory. 

3. In the File name box, type a name that uniquely identifies the instance, and then click 

Save. 
Note: Use a combination of the RTS machine name and the instance name to simplify 
re-importing. 

4. Repeat the previous substeps for all instances on all machines. 

6. Close WebCenter Forms Recognition Runtime Service Management Console. 

Note the Runtime Service Manager Settings 

To note the existing Runtime Service Manager settings for future reference, complete the following steps. 

1. Launch Windows Services and stop the following services. 

 WebCenter Forms Recognition Runtime Service Manager 

 WebCenter Forms Recognition System Monitoring 

2. Complete the following substeps. 

1. Right-click WebCenter Forms Recognition Runtime Service Manager and then click 
Properties. 

2. In the WebCenter Forms Recognition Runtime Service Manager Properties dialog box, 
on the Log On tab, note the specified settings. 

3. Repeat the previous steps for the WebCenter Forms Recognition System Monitoring 
service. 

3. Launch the Task Manager. 

4. If they are running, stop the DstHost.exe or DstMgr.exe tasks. 

Back Up Project-Related Data 
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When you save a project in WebCenter Forms Recognition 12.1.1.3 or later, you cannot open it in an earlier 

version. To back up all project-related data, complete the following steps. 

1. Stop all WebCenter Forms Recognition services. 

2. In Windows Explorer, navigate to the WebCenter Forms Recognition project directory. 

3. Copy all of the following files to your backup directory. 

 SDP project files 

 Learn set directories and files 

 ASSA pool files 

 INI files 

 SET files 

 DVS files 

 Any other project-related data, such as custom DLL files, scheduled tasks, or special 

configurations 

Note: For more information about your projects, see the project-related documentation. 

4. If the batch folder resides on the file system, copy the batch folder to your backup directory. 

Back Up the Application Files 

To back up the application files, complete the following steps. 

1. Stop all WebCenter Forms Recognition services. 

2. In Windows Explorer, navigate to the [Installation path] directory. 
3. Optional. To reduce the size of the backup, delete any log files that you no longer need. 

4. Copy all files to your backup directory. 

Note: The default Installation path is C:\Program Files (x86)\Oracle\WebCenter Forms Recognition\. 

Back Up the Configuration Files 

Use the CONFIG backup files only as reference to review custom settings used in previous versions. Do not 

copy any existing CONFIG files to the installation setup directory. Do not use any backed up CONFIG files 

with the new version. 

To back up the configuration files, complete the following steps. 

1. Stop all WebCenter Forms Recognition services. 

2. From the [Installation path]\Bin\bin directory, copy the following files to your backup directory. 

 DstDsr.exe.config 

 DstHost.exe.config 

 DstSlm.exe.config 

 DstWkBrw.exe.config 

 DstVer.exe.config 

 DstPmt.exe.config 

 DstCoreSvc.exe.config (if available) 

 If your installation includes Web Verifier, from the C:\Program Files 

(x86)\Oracle\WebCenter Forms Recognition Web Server directory, copy the 
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Web.config file to your backup directory. 

Back Up Permissions and Security Settings 

To back up permissions and security settings, complete the following steps. 

1. Stop all WebCenter Forms Recognition services. 

2. Note the permissions and security settings of any shared directories that WebCenter Forms 

Recognition uses, such as project data directories. 

3. Ensure that the share names remain the same for any directories you move. 

Upgrade to WebCenter Forms Recognition 14c (14.1.1.0.0) 

To upgrade to WebCenter Forms Recognition 14c (14.1.1.0.0), review or complete the following tasks as 
necessary. 

 Prepare for the Update 

 Upgrade WebCenter Forms Recognition 

 from versions 12.2.1.4 or later 

 Update the database schema 

 Oracle 

 SQL Server 

 Modify the Database Connection Strings 

 Convert Existing Project Files to the Current Version 

 Configure the Application Modules 

Prepare for the Update 

To prepare for the update, complete the following steps. 

1. In the Learn Set Manager, complete all pending accumulated documents and migrate them into 

the project. 

2. Verify that no pending batch exports exist. 

3. Verify that all users have logged out of the following programs. 

 Designer 

 Verifier 

 Learn Set Manager 

 Web Verifier 

4. Stop all RTS instances. 

5. Stop all WebCenter Forms Recognition services. 

6. Stop Internet Information Services (IIS). 

7. Stop all scheduled tasks and additional services related to WebCenter Forms Recognition. 

8. Optional. To specify the Help file locations, modify the SetupType.ini file. 

Note: See “Help files” in the Oracle WebCenter Forms Recognition Installation Guide for detailed 

steps and information. 

About Documentation 
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The installer removes any existing WebCenter Forms Recognition documentation files when upgrading from 

version 12.2.1.3 or earlier. 

Upgrade from Version 12.2.1.4 or Later 

To upgrade from version 12.2.1.4 or later, complete the following tasks. 

1. Upgrade from version 12.2.1.4 or later 

2. Upgrade to FineReader 11 

Upgrade from Version 12.2.1.4 or Later 

Complete the following steps. 

1. Refer to the section Download the Setup Package of the Oracle WebCenter Forms Recognition 
Installation Guide. 

2. Run [Installation Media]\setup.exe and complete the following substeps. 

1. In the WebCenter Forms Recognition Setup page, click Next. 

2. In the Setup page, select Repair and then click Next. 

3. Click Finish. 

3. Update the database schema. 

4. Launch Designer and convert existing project files. 

5. Restart all RTS instances. 

6. Restart all WebCenter Forms Recognition services. 

7. Restart Internet Information Services (IIS). 

8. Restart all scheduled tasks and additional services related to WebCenter Forms Recognition. 

9. If your implementation uses the file system, migrate the batches from the file system to the 

database. 

Upgrade to FineReader 11 

If your current implementation does not include FineReader 11, and you want to upgrade it, you must rerun the 

installation process. WebCenter Forms Recognition can work with existing projects that use FineReader 

8.1. 

However, we recommend that you upgrade to FineReader 11. 

To upgrade to FineReader 11, complete the following steps. 

1. Run [Installation Media]\setup.exe. 

2. In the WebCenter Forms Recognition Setup page, click Next. 

3. In the Setup page, select Modify and then click Next. 

4. In the Feature Selection page, select FineReader 11, or both, and then click Next. 

5. In the Icons on Desktop page, click Finish. 

About Projects Using the Recognita Barcode Engine 

The Recognita Barcode Engine is no longer part of WebCenter Forms Recognition. 

If you open a project that previously used the Recognita Barcode Engine, WebCenter Forms 

Recognition updates the project to the QualitySoft Barcode Engine and transfers the existing bar code 
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types if the QualitySoft Barcode Engine supports these types. 

About Projects Using the Recognita OCR Engine 

The Recognita OCR Engine is no longer part of WebCenter Forms Recognition. 

If you open a project that previously used the Recognita OCR Engine, WebCenter Forms Recognition 
updates the project to FineReader. 

Update the Oracle Database Schema 

To update the Oracle database schema, complete the following steps. 

Note: After the update, you cannot revert the database schema to an older version. 
  

1. Ensure that the WebCenter Forms Recognition user has the appropriate permissions. For 

more information, see "Create the database user" in the Oracle WebCenter Forms Recognition 

Installation Guide. 

2. To execute the update script using SQL Developer, complete the following substeps. 

1. Configure a connection for the WebCenter Forms Recognition user. 

2. From the [drive:]\[setup directory]\FirstPart\Database\UpdateScripts\Oracle directory, 
open the BRW_Upgrade_Database.sql script. 

3. Ensure that the connection is set to the WebCenter Forms Recognition user and then 
execute the script. 

3. To execute the update script using SQL Plus, complete the following substeps. 

1. Start SQL Plus and connect to the database as the WebCenter Forms Recognition user. 

2. From the [drive:]\[setup directory]\FirstPart\Database\UpdateScripts\Oracle directory, 
execute the BRW_Upgrade_Database.sql script. 

4. Review the Messages pane for errors. 

Note: If there are errors, you can run the script as often as required. 

Update the SQL Server Database Schema 

To update the database schema, complete the following steps. 

Note: After the update, you cannot revert the database schema to an older version. 

1. Launch the SQL Server Management Studio. 

2. Log on using an account with administrator rights. 

3. From the [drive:]\[setup directory]\FirstPart\Database\UpdateScripts\SQL Server directory, 

execute the BRW_Upgrade_Database.sql script against the WebCenter Forms 

Recognition database. 

4. Review the Messages pane for errors. 

Note: If there are errors, you can rerun the script as often as required. 

Revoke Oracle User Rights 

After creating or updating the Oracle database, you can revoke some of the permissions from the WebCenter 

Forms Recognition user because they are no longer needed. Complete the following step. 

 Revoke the permissions according to the following example. 

REVOKE 
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CREATE TYPE, 

CREATE INDEXTYPE, 

CREATE PROCEDURE, 

CREATE SEQUENCE, 

CREATE SYNONYM, 

CREATE PUBLIC SYNONYM, 

CREATE TRIGGER 

FROM BIC; 

Modify the Database Connection Strings 

To modify the database connection strings for all WebCenter Forms Recognition components, except Web 

Verifier, complete the following steps. 

Note: To modify the database connection strings for Web Verifier, see the “Replace Web.config and 

Brainware.System.Project.exe.config ” topic. 

1. From the C:\Program Files (x86)\Oracle\WebCenter Forms Recognition\Bin\bin\ directory, open 

DstDsr.exe.config in a text editor. 

2. Search for the <connectionStrings> element. 

3. For an ORACLE database, modify the following values. 

 Set Data Source to the data source. 

 Set User ID to the service account user ID. 

 Set Password to the service account password. 

4. For a SQL Server database, modify the following values. 

 Set Data Source to the data source. 
 Set Initial Catalog to the SQL Server database catalog. 

 Set User ID to the SQL Server user ID. 

 Set Password to the SQL Server password. 

5. Save and close the file. 

6. Repeat the previous steps for the following configuration files. 

 DstHost.exe.config 

 DstSlm.exe.config 

 DstVer.exe.config 

 DstWkBrw.exe.config 

 DstCoreSvc.exe.config 

 DstPmt.exe.config 

 Brainware.System.Project.config 

Add the ASP.NET 4.x Role to IIS 

To add the ASP.NET 4.x role to IIS, complete the following steps. 

1. In Server Manager, open the Add Roles and Features Wizard. 

2. In the Add Roles and Features Wizard dialog box, click Next. 

3. Select Role-based or feature-based installation and then click Next. 

4. Select Select a server from the server pool and then click Next. 

5. Open Web Server (IIS) > Web Server > Application Development. 
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6. Select ASP.NET 4.x and then click Next. 

7. Click Next and then click Install. 

 

Change the Application Pool .NET CLR Version to v4.0.30319 

To change the application pool .NET CLR version to v4.0.30319, complete the following steps. 

1. In Internet Information Server (IIS) Manager, open Sites, and then select the Web Verifier 

application. 

2. In the right pane, click Basic Settings. 

3. In the Edit Application dialog box, from the Application Pool field, note the pool name and then 

click OK. 

4. In the left pane, select Application Pools. 

5. In the middle pane, right-click the Web Verifier application pool name and then click Basic 

Settings. 

6. In the Edit Application Pool dialog box, from the .NET CLR version list, select .NET CLR 

Version v4.0.30319 and then click OK. 

Replace Web.config and Brainware.System.Project.exe.config 

If your installation includes Web Verifier, complete the following steps. 

1. Make a copy of the [Installation Media]\\Web.config.Template file, name it 

Web.config, and open it in a text editor. 

2. Search for the <connectionStrings> element. 

3. For an ORACLE database, modify the following values. 

 Set Data Source to the data source. 

 Set User ID to the service account user ID. 

 Set Password to the service account password. 

4. For a SQL Server database, modify the following values. 

 Set Data Source to the data source. 

 Set Initial Catalog to the SQL Server database catalog. 

 Set User ID to the service account user ID. 

 Set Password to the service account password. 

5. Search for the pathToProjectExe attribute and verify that the value corresponds to the location 

of DstDsr.exe. 

6. Compare all customized settings, such as formEvents, batchColumnsVisibility, and 

appSettings with your back-up Web.config file and modify the values if required. 

7. Save and close the file. 

8. Copy the Web.config file to the following directories. 

 C:\Program Files (x86)\Oracle\WebCenter Forms Recognition\Bin\bin\ 

 C:\Program Files (x86)\Oracle\WebCenter Forms Recognition Web Server\ 

9. In the C:\Program Files (x86)\Oracle\WebCenter Forms Recognition\Bin\bin\ directory, 

complete the following substeps. 
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1. Rename the Brainware.System.Project.exe.config file to a new name to save it as a 

backup, or delete it. 

2. Rename the Web.config file to Brainware.System.Project.exe.config. 

 

Database Connection String Example for SQL Server 

<connectionStrings> 

<add name="Entities" 

connectionString="metadata=res://*/Entity.Entities.csdl|res://*/Entity.Entiti 

es.ssdl|res://*/Entity.Entities.msl; provider=System.Data.SqlClient;provider 

connection string=&quot;Data Source=<DataSource>;Initial 

Catalog=<SQLServerDatabaseCatalog>;Integrated Security=false;User 

ID=<UserId>;Password=<UserPassword>;MultipleActiveResultSets=True&quot;" 

providerName="System.Data.EntityClient" /> 

</connectionStrings> 

 

Database Connection String Example for ORACLE 

<connectionStrings> 

<add name="Entities" 

connectionString="metadata=res://*/Entity.ORAEntities.csdl|res://*/Entity.ORA 

Entities.ssdl|res://*/Entity.ORAEntities.msl; provider=EFOracleProvider; 

Provider Connection String='Data Source=<OracleServerName\InstanceName>;User 

ID=<UserID>;Password=<UserPassword>'" providerName="System.Data.EntityClient" 

/> 

</connectionStrings> 

 

Modify the .NET Configuration for ORACLE 

If you use WebCenter Forms Recognition with an ORACLE database, complete the following steps. 

1. From <drive>:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\CONFIG, open 

machine.config in a text editor. 

2. Search for the <system.data> element. 

3. Under the <DbProviderFactories> element, verify or add the following element. 
Provider for Oracle testing" 

type="EFOracleProvider.EFOracleProviderFactory, EFOracleProvider, 

Version=1.0.0.0, Culture=neutral, PublicKeyToken=def642f226e0e59b"/> 

Note: To copy this example as a single line, open this document in Acrobat Reader and copy and 

paste the string from there. 

4. Save and close the file. 

Convert Existing Project Files to the Current Version 

You must convert project files created in an earlier version before you can use them. 

To convert existing project files, complete the following steps. 
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1. In Designer, click File > Load Project. 

2. In the WebCenter Forms Recognition – Load Project dialog box, select a project and click 

Open. 

3. In the WebCenter Forms Recognition – Project Logon dialog box, log on with Administrator 

credentials and then click OK. 

Note: The fully automated conversion process may take a few minutes, depending on the project size. 

4. If prompted, confirm the error message about the missing FineReader 8.1 engine. 

5. Verify if you need to modify the scripts. See the section Review Scripts for more information. 

6. To verify the settings, click Options > Settings. 

7. In the Settings dialog box, complete the following substeps. 

1. On the Input Mode tab, verify that the required job name is selected or that the Batch 

Root Directory points to the required batch directory. 

2. On the Train Mode tab, verify that the Learn Set Manager base directory points to the 

required directory and then click OK. 

8. Switch to Train Mode. 

1. On the Options menu, clear Incremental Learning. 
2. To rebuild the learn set under the current version, on the Toolbar, click Learn documents.  

9. Switch to Definition Mode. 

1. In the left pane, on the Classes tab, right-click the project and then click Show Properties. 

2. In the right pane, on the Project tab, click OCR settings. 

3. In the OCR Properties dialog box, complete the following substeps. 

• On the Recognition tab, under Available Engines, verify that 

FineReader 11 is selected. 

• Verify the settings on the different tabs. 

• WebCenter Forms Recognition now provides the possibility to perform a 

combined OCR for Korean and English in one selection. If your project uses 

Korean and English, in the OCR Properties dialog box, complete the 

following substeps. 

• On the Languages tab, under Used, remove English and Korean. 

• Under Installed, select Korean+English, click  and then click OK. 

10. Upgraded projects may have correlation enabled for table fields. To review and disable this setting 

if not applicable for this project, complete the following substep. 

 In Definition Mode, open the properties of all table fields and clear the correlation option 

on the Advanced tab of the Analysis pane. 

11. For local projects, complete the following substeps. 

1. Click Options > Users, Groups and Roles. 

2. On the Users tab, select Allow Database Authentication and then click OK. 

3. Update the local copies of the Project to other workstations. 

12. Click File > Save Project. 

13. Repeat the previous steps for each project. 

About Custom DLLs 
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Custom DLLs may have to be updated to remain valid with the current WebCenter Forms Recognition version. 

Configure the Application Modules 

After the update you configure the application modules. Complete the following tasks. 

 Configure RTS Settings on a Server 

 Verify Verifier settings 

 Verify Web Verifier settings on the server 

 Verify Web Verifier on a client 

 Re-Register the COM Components 
 

Configure RTS Settings on a Server 

To configure the RTS settings on a server, complete the following steps. 

1. In Windows Services, complete the following substeps 

1. Right-click WebCenter Forms Recognition Runtime Service Manager and then click 

Properties 

2. In the WebCenter Forms Recognition Runtime Service Manager Properties 

dialog box, on the Log On tab, change the settings according to those used in the 

previous version. 

3. Repeat the previous steps for the WebCenter Forms Recognition System Monitoring 
service. 

4. Start the WebCenter Forms Recognition Runtime Service Manager service. 

2. In WebCenter Forms Recognition Runtime Service Management Console, create the 

RTS group and the RTS machines using the same names than in the previous installation. 

Note: Refer to your backed up SET files to review the previously used names. 

3. Complete the following substeps. 

1. In the left pane, right-click one of the instances and then click Import Settings. 

2. In the Open dialog box, select the corresponding SET files and then click Open. 

3. Repeat the previous steps for each instance. 

4. Verify that the batch list displays for each instance. 

5. Verify that no errors display in the Statistics view. 

6. To verify the configuration, process a single document from import to export. 

Verify Verifier Settings 

To verify the Verifier settings on a server or client, complete the following steps. 

1. Copy the backed up Verifier settings file to the required location. 

2. To launch Verifier, double-click the settings file. 

3. In the WebCenter Forms Recognition – Project Logon dialog box, log on with Administrator 

credentials and then click OK. 

4. Verify that the batch list displays. 

5. Verify a batch to completion to ensure that no errors occur. 

Verify Web Verifier Settings on the Server 
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To verify the Web Verifier settings on the server, complete the following steps. 

1. On the WebCenter Forms Recognition Web server, in IIS Manager, start the Web Verifier 
application. 

2. Run iisreset as an administrator in a Command Prompt window. 

3. Open a web browser and delete all local cache information. 

4. Log on to Web Verifier. 
5. Click Help > About WebCenter Forms Recognition Web Verifier and verify the license file. 

6. Verify a batch to completion to ensure that no errors occur. 

Verify Web Verifier on a Client 

To verify Web Verifier on a client, complete the following steps. 

1. Open a web browser and delete all local cache information. 

2. Log on to Web Verifier. 

3. Verify a batch to completion to ensure that no errors occur. 

Re-Register the COM Components 

To re-register the COM components, complete the following steps. 

1. In the C:\Program Files (x86)\Oracle\WebCenter Forms Recognition\WebCenter Forms 

Recognition Web Server\Bin\ directory, run Register Web Server.bat as administrator. 

2. In the C:\Program Files (x86)\Oracle\WebCenter Forms Recognition\WebCenter Forms 

Recognition Web Server\Bin\ directory, open Register Web Server.log in a text editor and 

check the file for errors. 

Review Scripts 

To check if your scripts require modifications, review the following topics. 

1. About the Properties Filename and DocFileName 

2. About the Original File Name of a Page 

3. About Cutting and Appending Documents 

About the Properties Filename and DocFileName 

The Workdoc.Filename property now contains the workdoc’s database ID and name instead of the image 

file name from which the workdoc was created. 

To retrieve the image file name from which WebCenter Forms Recognition created the workdoc, use the 
Workdoc.DocFileName 

property. 

Ensure to modify your projects custom script accordingly. 

About the Original File Name of a Page 

The stapling process returns a single multipage-document referenced by the associated workdoc. 

Using the pWorkdoc.DocFileName(x) with an index greater than 0 results in an index-out-of-range error. 

To retrieve the original file name of a page, use the pWorkdoc.Pages 
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(x).OriginalDocumentFileName property. 

About Cutting and Appending Documents 

The process for cutting and appending documents has changed. 

Always use the pWorkdoc.DocFileCount property after appending and cutting operations to determine 

the number of documents. 

Migrate Batches from the File System to the Database 

If the RTS instance points to file system batches, you must migrate those batches to the database. 

To migrate a file system batch to the database, you need to perform the migration steps for each state within 

the batch starting with the lowest batch state. WebCenter Forms Recognition creates a single batch for each 

state. If a file system batch contains documents at two different states, WebCenter Forms Recognition splits 

this batch into two different batches in the database. 

To migrate the batches to the database, complete the following steps. 

1. Back up the file system batches. 

2. Launch WebCenter Forms Recognition Runtime Service Management Console. 

3. In the WebCenter Forms Recognition Admin window, in the left pane, right-click the RTS 

instance that points to a file system batch and then click Properties. 

4. In the WebCenter Forms Recognition Runtime Service Properties dialog box, on the Workflow 
tab, complete the following substeps. 

1. Enable the Database Export process step. 

2. Disable all other process steps and then click OK. 

5. In the WebCenter Forms Recognition Admin window, in the left pane, right-click the RTS instance 
and then click Properties. 

6. In the WebCenter Forms Recognition Runtime Service Properties dialog box, on the General tab, 
under Directories, create a new job or select an existing one. 

7. Complete the following substeps. 

1. In the WebCenter Forms Recognition Runtime Service Properties dialog box, on the 
Workflow tab, select the lowest batch state as Input State for Database Export. 

Note: Explore your batch list to determine the lowest state. 

2. Define separate states different from the existing default output states as Output State 

for Database Export, and then click OK. 

Note: Verify that the failed state is lower than the succeeded state. 

3. Right-click the instance and then click Start. 

4. Repeat the previous steps for all remaining states in your batch list. 

About Batches Exported from the Database 

When performing a database export from the Runtime Server, WebCenter Forms Recognition creates a new 

ID for the exported batches, such as 00001770_00000016. The left part of this ID represents the database ID 

while the right part represents the previous file system batch ID. 

This affects only the batches exported from the file system and is required to keep the string ID unique. If you 

import the batches directly into the database, the string ID consists of the reference to the database ID. 
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Find Exported Batches 

If a case in the file system has two different states, WebCenter Forms Recognition creates two different 
database batches. To find the batches created from the original single batch, complete the following 
step. 

 In the WebCenter Forms Recognition Admin window, in the right pane, in the Where box, 

type batch.name like ‘%_ [xx]’ and then click Request. 

Example If you want to display all documents for batch 16, type batch.name like ‘%_16’. 

Note: The RTS instance that points to a file system batch still shows the original number of 

documents even if a part of the documents was already exported. The exported documents are 

still part of the batch. However, after export they have a higher state according to the output 

state you defined for database export. 


