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1 Page Designer 

Page Designer provides an overview of the zones defined for each class and the recognition 
engines. This tool enables you to review reading zones for OCR, OMR, and Barcode recognition, 
and it lets you experiment with the zone properties. 

Note: Use this tool for testing purposes only. Never save any changes as doing so might corrupt 
the project. 

1.1 Page Designer User Interface 

Inside the Page Designer User Interface, the left pane displays the classes, their zones, and the 
used engines and the right pane displays the images. 

1.2 Load an Image 

To load an image, complete the following steps: 

1. Click File > Open Image. 

2. In the Select Image file dialog box, browse to the required directory, select a file and 
then click Open. 

3. Optional. Use the buttons on the toolbar to adjust the view to your needs. 

1.3 Load an Image List 

To load an image list, complete the following steps: 

1. Click File > Open Image List. 

2. In the Select Image List dialog box, under Imagepath Settings, complete the following 
substeps: 

a. Browse to the required directory. 
b. Select the file type. 

3. Complete one of the following substeps: 

a. From the Available images list, select the images you want to load and then click 
Add. 

b. To load all images listed in the Available images list, click Add all. 

4. Click OK. 

5. Optional. Use the buttons on the toolbar to adjust the view to your needs. 

1.4 Create a Project 

Do not create projects with Page Designer; this function is no longer in use. 
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1.5 Load a Project 

To load a project, complete the following steps. 

1. Click File > Load Project. 

2. In the Load project file dialog box, browse to the required directory. 

3. From the File Type list, select WebCenter Forms Recognition Project File (*.sdp). 

4. Select the project and then click Open. 

1.6 About Version Control 

The Page Designer version control feature is no longer in use. 

1.7 Display information about the Image 

To display path, resolution, size, bits per pixel, and color of the image, go to Image > Image Info. 

1.8 About Reading Zones 

See About reading zones and About the Zone Analysis Engine in the WebCenter Forms Recognition 
Designer Guide. 

1.8.1 Create a Reading Zone 

To create a reading zone, complete the following steps: 

Note: Always apply any modifications in Designer not in Page Designer. 

1. Complete the following options as needed: 

a. To create an OCR reading zone, click the Insert OCR zone button. 
b. To create an OMR reading zone, click the Insert OMR zone button. 
c. To create a bar code reading zone, click the Insert barcode zone button. 

2. On the document, drag to mark the required zone. 

Note: The zone must be large enough to hold the expected content, but not much larger. 

1.8.2 Adjust a Reading Zone 

To adjust a reading zone, complete any of the following steps: 

1. Drag the zone to another place. 

2. Resize the zone by dragging the corner handles. 

3. To adjust the zone size to the size of the entire page, right-click the zone and then click Fit 

to image size. 

4. To delete a zone, select the zone and then press [Del]. 
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1.8.3 Modify the Zone Properties 

To modify the zone properties, complete the following steps. 

1. In the image pane, right-click a zone and then click Properties. 

2. In the Zone Properties dialog box, modify the settings. 

Note: See Zone-level recognition settings in the WebCenter Forms Recognition Designer 
Guide for more information. 

1.9 About Anchors 

See About anchors in the WebCenter Forms Recognition Designer Guide for more information. 

1.9.1 Create an Anchor 

To create an anchor, complete the following steps: 

1. Click the Anchor button. 

2. On the document, drag to mark the anchor zone. 

Note: Ensure that the anchor zone is proportional to the geometric feature that you 
want to locate. For example, if all the documents in your class contain a 50 
mm line in the footer area, your anchor should not have a side length of 5 or 
250 mm. The anchor position should be close to the geometric feature you 
want to use. 

3. Optional. To create more anchors, repeat the previous steps. 

1.9.2 Modify the Anchor Properties 

To modify the anchor properties, complete the following steps: 

1. In the image pane, right-click the anchor and then click Properties. 

2. In the Anchor Properties dialog box, modify the properties. 

Note: See Modify the anchor properties in the WebCenter Forms Recognition Designer 
Guide.  

1.10  Read a Zone 

To read a zone, complete the following steps: 

1. Browse to the required image. 

2. On the image, select a zone. 

3. Click the Read active zone button. 

4. In the Zone dialog box, observe the result. 
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1.11 Read All Zones on an Image 

To read all zones on an image, complete the following steps. 

1. Browse to the required image. 

2. Click the Read all zones button. 

3. In the Recognition Result dialog box, observe the result. 

1.12 Read all Zones on all Images 

To read all zones on all images, complete the following steps: 

1. Click the Read zones at all images button. 

2. In the Recognition Result all dialog box, observe the result.  

3. Optional. To save the result in a text file, complete the following sub-steps: 

a. Click Save. 
b. In the Save Textfile dialog box, in the File name field, type a name and then click 

Save. 
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2 Workdoc Browser 

2.1 About Workdoc Browser 

Workdoc Browser enables you to review the workdoc data gained during processing, such as the 
found words and text blocks, the content of fields and their properties. This may help you to 
investigate errors, OCR problems, or to examine properties you want to use in scripting. 

Furthermore, you can review the whole structure of the documents storage base such as batches, 
folders, and workdocs. You can operate the batches of documents by filtering and sorting them. 
You can also create copies of the documents or batches of documents. It can be especially helpful, 
for example, in reviewing or reproducing issues in the document processing results. 

2.2 Workdoc Browser User Interface 

The user interface provides the following panes: 

 The upper left pane displays the directories on the file system or the jobs and batches 
from the database, depending on the selected view. 

 The lower left pane displays the workdocs of the selected batch. 

 The middle pane displays the selected workdoc. 

 The attributes pane displays the pages, words, text blocks, and text lines as well as 
several other attributes. 

 The properties pane displays the properties of the selected attribute. 

2.3 Configure the Database Connection 

To configure the database connection, complete the following steps: 

1. From the [Installation path]\Bin\bin directory, open DstWkBrw.exe.config in a 
text editor. 

2. Complete one of the following actions: 

Case Steps 

Configure the connection to an Oracle Database  Set Data Source to the data source. 
 Set User ID to the service account user ID. 
 Set Password to the service account password. 

Configure the connection to a SQL Server Database  Set Data Source to the data source. 
 Set Initial Catalog to the SQL Server database catalog. 
 Set User ID to the SQL Server user ID. 
 Set Password to the SQL Server password. 

3. Save and close the file. 

2.4 Open a Workdoc from the File System 

To open a workdoc from the file system, complete the following steps: 

1. On the toolbar, click the File System View button. 
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2. In the upper left pane, browse to the required directory. 

3. In the lower left pane, select the required workdoc. 

4. Optional. In the middle pane, use the buttons on the toolbar to adjust the view to your 
needs. 

2.5 Open a Workdoc from the Database 

To open a workdoc from the file system, complete the following steps: 

1. On the toolbar, click the Database View button. 

2. If the Login dialog appears, type your user name and password and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database. 

3. In the upper left pane, expand the required job and then select a batch. 

4. In the lower left pane, select the required workdoc. 

5. Optional. In the middle pane, use the buttons on the toolbar to adjust the view to your 
needs. 

2.6 Copy a Batch to the File System 

To copy a batch to the file system, complete the following steps: 

1. On the toolbar, click the Database View button. 

2. If the Login dialog appears, type your user name and password and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database. 

3. In the upper left pane, right-click a batch and then click Copy Batch To File System. 

4. In the Select Folder dialog box, type or browse to the required directory and then click 
OK. 

2.7 Copy a Batch to a Database 

To copy a batch to a database, complete the following steps: 

1. On the toolbar, click the Database View button. 

2. If the Login dialog appears, type your user name and password and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database. 

3. In the upper left pane, right-click a batch and then click Copy Batch to Database. 

4. In the Select The Target Database dialog box, select a database and then click OK. 
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The batch is copied to a job with the same name. A job is created if it does not exist in the 
target database already. If the batch is copied within the same database, a duplicate batch 

named [OriginalBatchName]_[ConsecutiveNumber] within the same job is 
created. 

5. On the View menu, click Refresh. 

2.8 Copy a Document to the File System 

To copy a workdoc WDC file and its associated documents to the file system, complete the 
following steps: 

1. On the toolbar, click the Database View button. 

2. If the Login dialog appears, type your user name and password and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database. 

3. In the lower left pane, right-click a document and then click Copy Document to File 

System. 

4. In the WebCenter Forms Recognition Workdoc Browser - Save Workdoc dialog box, 
type or browse to the required directory and then click OK. 

2.9 Filter and Sort the Batches 

To filter and sort the batches, complete the following steps: 

Note:  This function is only available in the Database View. 

1. On the toolbar, click the Filtering button. 

2. In the Batch Filtering & Sorting dialog box, in the Batch Filtering field, type a WHERE 
condition. 

Note:  See Batch filter conditions using column names in the WebCenter Forms Recognition 
Runtime Server Guide. 

3. Optional. In the Batch Sorting field, type the field you want to sort by and then click 
Request. 

2.10 Export Filtered Batches 

To export filtered batches, complete the following steps: 

1. In the upper left pane, right-click the job and then click Export All Filtered Batches.   

2. In the Select The Target Database dialog box, select a database and then click OK. 
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2.11 Examine the Attributes and Properties 

The attribute pane displays the attributes of the current workdoc. Complete any of the following 
steps: 

 To expand an entry that displays the book symbol to its left, double-click the entry, and 
then select any of the subordinate entries to display its properties. 

 To highlight the found words, text blocks, or text lines, select the corresponding entry.  

2.12 The Attributes Pane 

The attributes pane displays the following information. 

Attribute Description 

DocFiles The number of images contained in the workdoc displays in brackets. 
The subordinate entries display path and file name of the TIF file. Select an entry to 
display the image in the document pane. 

Pages The number of pages of the workdoc displays in brackets. 
The subordinate entries list the page indexes and their properties. Select an entry to 
display the page in the document pane. 

Words The number of words found during OCR displays in brackets. Select this attribute 
to highlight all words on the document. 
The subordinate entries list all words found on the document. Select an entry to 
highlight the word on the document and to display its properties. 

TextBlocks The number of blocks displays in brackets. Select this attribute to highlight all 
blocks on the document. 
During OCR, the found words that have a geometrical relationship are assigned to 
blocks, for example the vendor address on an invoice. 
The subordinate entries list all text blocks found on the document. Select an entry 
to highlight the text block on the document and to display its properties. 

TextLines The number of lines found by the Brainware line extraction or the Advanced line 
extraction displays in brackets. Select this attribute to highlight all lines on the 
document. 
During OCR, the words that are geometrically on the same line are assigned to text 
lines. 
The subordinate entries list all text lines found on the document. Select an entry to 
highlight the text line on the document and to display its properties. 

Fields The number of fields displays in brackets. 
The subordinate entries list all fields defined in the assigned class. Select an entry to 
display its properties. 
In the properties pane, select a candidate to highlight the candidate on the 
document. 

DocClassName Name of the assigned class. 

BlockCount Number of text blocks. 

DisplayPage Index of the currently displayed page. 

DocState Current state of the document within the workflow. 
See CDRDocState in the WebCenter Forms Recognition Scripting Guide. 

ErrorDescription Description of the error or blank if none occurred. 

FileName File name of the workdoc. 

Folder Folder name. 
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FolderIndex Index of the folder. 

Language Language activated for the workdoc. 

Showtooltips True: Display tool tips when the user moves the pointer over the workdoc. 
False: Do not display tool tips when the user moves the pointer over the workdoc. 

TextLineCount Number of lines. 

VersionCount Number of versions. 

WordSegmentationChars Characters that indicate the end of a word and the beginning of a new one. 
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3 Merge SLW Learnsets Tool 

3.1 About the Merge SLW Learnsets Tool 

An administrator who supports a highly distributed system of different workstations may be 
required to maintain a high number of separate knowledge bases, created at different locations, at 
different times. Thus in some cases it might be required to merge the learnsets (created in context 
of the same production global SLW project) from different project files, to be able to provide some 
additional considerations. 

Use this tool to quickly merge multiple SLW sub-projects, overtaking the “SLW knowledge” 
without using the learnset manager tool. The Merge SLW Learnsets tool enables you, for 
example, to quickly correct corresponding configuration errors related to “disconnected” local 
Advanced Verifier workstations. 

The tool works only with Supervised Learning Workflow (SLW) projects, which are the instances 
of the same master (global) SLW project. In this connection, only the SLW vendor classes can be 
populated and/or updated through this tool. The tool cannot update classes if the project 
contains any classes that are not created automatically by SLW.  

3.2 Merge SLW Learnsets 

To merge SLW learnsets, complete the following steps: 

1. From the Windows Start menu, launch the Merge SLW Learnsets tool. 

2. In the Source Project field, type or browse to the source project. 

3. In the Target Project field, type or browse to the target project. 

4. To discover and analyze the structures, click Scan Projects. 

5. In the Copy column, select the classes you want to merge. 

6. To merge the learnset into the target project, click Merge. 

Note: The Merge button is only active if the tool finds learnsets that can be merged. 

3.3 About the SLW Export Local Project Tool 

Use this tool to create local project templates to be used by Advanced Verifier workstations from 
your global project to provide the Supervised Learning content for the local projects. 

The tool automatically analyzes and creates the corresponding learnset directories and learnsets 
and saves them with the new project. 

3.4 Use the SLW Export Local Project tool 

To create a new local project from an existing global one, keeping either the entire settings of 
your base class, or learnset and the script, complete the following steps. 

1. From the Windows Start menu, launch the SLW Export Local Project Tool. 
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2. Click Load Project. 

3. In the Export Local Project dialog box, select a global project and then click Open. 

4. Optional. To save the entire export project configuration as a part of the global project’s 
stream, click Save Project. 

5. Click Export Project. 

6. In the Export Project dialog box, select the classes’ learnsets, and scripts you want to 
export and then click Export. 

Note: The project is marked with P, base classes are marked with B, and sub-classes are 
marked with S. 

7. In the Export Local Project dialog box, type a name for the new project and then click 
Save. 
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