UPDATE_ARCHIVAL_BACKUP_KEEP
This procedure updates the retention time of archival backup with the specified keep_until_time. Archival backup is identified by user specified restore_tag and restore_point.
This API has the following restrictions for input options:
-
If restore point doesn’t exist for the specified
restore_tagandrestore_pointof thedb_unique_namedatabase, this returns an error. -
If
keep_complianceof the protection policy is set toYESandkeep_until_timeis less than the existing retention time of archival backup, this returns an error.
Syntax
PROCEDURE update_archival_backup_keep(
db_unique_name IN VARCHAR2,
restore_tag IN VARCHAR2,
restore_point IN VARCHAR2 DEFAULT NULL,
restore_until_scn IN VARCHAR2,
keep_until_time IN TIMESTAMP WITH TIME ZONE,
comments IN VARCHAR2 DEFAULT NULL);
Parameters
Table 53 UPDATE_ARCHIVAL_BACKUP_KEEP Parameters
| Parameter | Description |
|---|---|
db_unique_name |
The DB_UNIQUE_NAME of the protected database. If this is not specified, or if the state of this database is not valid, this API returns with an error. |
restore_tag |
Specifies the user-defined tag of the archival backup. |
restore_point |
User specified restore point name of the archival backup. |
keep_until_time |
User specified retention time for the archival backup. If specified as NULL, then the archival backup will be KEEP FOREVER backup. |
comments |
Optional user supplied comment describing reason for executing this command. |