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Preface

Preface
Welcome to the JD Edwards EnterpriseOne documentation.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at  http://
www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc .

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit  http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info  or visit  http://www.oracle.com/pls/topic/
lookup?ctx=acc&id=trs  if you are hearing impaired.

Related Information
For additional information about JD Edwards EnterpriseOne applications, features, content, and training, visit the JD
Edwards EnterpriseOne pages on the JD Edwards Resource Library located at:

http://learnjde.com

Conventions
The following text conventions are used in this document:

Convention Meaning

Bold
 

Boldface type indicates graphical user interface elements associated with an action or terms defined in
text or the glossary.
 

Italics
 

Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular
values.
 

Monospace
 

Monospace type indicates commands within a paragraph, URLs, code examples, text that appears on a
screen, or text that you enter.
 

> Oracle by Example
 

Indicates a link to an Oracle by Example (OBE). OBEs provide hands-on, step- by-step instructions,
including screen captures that guide you through a process using your own environment. Access to
OBEs requires a valid Oracle account.
 

i

http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs
http://learnjde.com
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1  Welcome to JD Edwards EnterpriseOne
Configuration

Overview of the JD Edwards EnterpriseOne
Configuration Assistant  
The Configuration Assistant is a standalone Java-based tool that allows you to extract a subset of JD Edwards
EnterpriseOne configuration information into a portable archive. This data can then be loaded into any other JD
Edwards EnterpriseOne environment using Change Assistant.
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Tip:

The maximum size of a SQL Server Express (SSE) local database is 4 GB, while there is no limit for an Oracle Enterprise
Edition (OEE) local database. As a point of reference, the sample JD Edwards EnterpriseOne configurations are
typically less than 100 MB.

In JD Edwards EnterpriseOne Tools Release 8.98 and later, the configuration database is delivered as xml.

Note:

JD Edwards EnterpriseOne Compatibility: The Configuration Assistant tool is compatible with JD Edwards
EnterpriseOne Applications Release 8.11 SP1 and later. The tool supports cross-release data configuration imports and
exports; however it gives a cross-release warning.

For a description of how Configuration Assistant and Change Assistant are used together to create and distribute
the configurations, and how specific machine types are required for each function, see Packaging and Loading an
Extracted File onto a Target Machine.

CAUTION:  On the Microsoft Windows 2008 platform, you must start Configuration Assistant by using Run as
Administrator. Right-click the shortcut and select Run as Administrator from the drop-down list. For details about
creating a shortcut for Configuration Assistant, see: Manually Creating a Shortcut for Configuration Assistant.

CAUTION: 

Use careful design analysis as you configure your portable archive in the source environment to ensure that loading
it in the target environment (using replace and append) will not cause problems.

When designing data configurations, you should refer to the JD Edwards EnterpriseOne Configuration Development
Methodology Guide to ensure that you are adhering to known design constraints and are aware of risks inherent
with any data replacement strategy. This guide presents the guidelines you should follow when creating new User
Defined Codes (UDCs), Versions, Task Views, or special data types in order to avoid potential conflicts with the base
EnterpriseOne data set, and as a result core EnterpriseOne application functionality.

Additionally, you should be aware that some types of configuration data are inherently more risky than others. For
example, you should exercise care when dealing with any technical tables, such as Next Numbers. (The system will
not execute properly if you include tables associated with Next Numbers, and will fail to take the associated Next
Number table.)

Also, generally, you should not include any Control Tables or serialized object tables in your configuration. (You
should not include tables from any datasource other than Business Data.)

Configuration designers will do well to consider the axiom of trade craftsmen:

2



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 1
Welcome to JD Edwards EnterpriseOne Configuration

The Configuration Assistant is designed to work with the following specific types of JD Edwards EnterpriseOne
configuration information:

• Tables

• Object Management Workbench (OMW) Projects and OMW Objects (requires JD Edwards Tools Release 8.98 or
later)

• User Defined Codes

• Security (Public, Roles, and Users)

• Tasks Views

• Versions

The user interface for Configuration Assistant includes a main window and two panes. The left pane displays a tree
view of work in process and sample JD Edwards EnterpriseOne configurations that are delivered by default. Each
configuration node represents the definition of the contents. After you have completed the definition of a configuration,
you use a separate step to actually extract the data and create the portable archive.

This Welcome section also describes these topics:

• Icons Used by Configuration Assistant

• Productivity Hints

When you start Configuration Assistant, this dialog box is displayed the first time you start the program or if the
program has changed and needs to reload a more current version. This dialog indicates the relative progress of loading
the Configuration Assistant Java program:

News and Links  
The News and Links tab is available when you select the Configurations node and whenever you are connected to
Update Center (see Using the Authentication Tab in Using Preferences). The News and Links tab displays a replica of
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the page displayed by Update Center, which is a companion tool to Configuration Assistant. The page contains links
to a variety of collateral information such as known issues and workarounds, breaking news, and tips. The linked
information is instrumental to the entire Update Center and Configuration Assistant methodology, design, and end-user
processes.

Productivity Hints  
The Configuration Assistant user interface includes a variety of tools to enhance end-user productivity. These tools
include:

• Adding or Removing Items to Your Configuration

• Backing Up Your Target Database Environment

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Help Tab

• Icons Used by Configuration Assistant

4
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• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Adding or Removing Items to Your Configuration  
Whenever you select a check box in the right pane to add an item to your configuration, that item is immediately added
to your configuration, as displayed in the left pane. Likewise, if you clear a check box in the right pane, the item is
immediately removed from the configuration as well as the left pane.

To add an item or remove an item from your configuration (from the tool-populated list of available tables in this data
source), select the check box on the left of the item name; this is the first column of the table properties grid.

Tip:  If you remove a configuration node or specific item from the My Configurations tree structure in the left pane,
Configuration Assistant automatically clears the corresponding item in the right pane.

Backing Up Your Target Database Environment  
You should always back up your target database environment before performing any process that alters the data,
including the loading of an extracted configuration that was created using Configuration Assistant. Unless properly
designed and tested, when you are loading data from a configuration, you might overwrite production data.

As shown in the Environment Selection screen below, when you use Change Assistant to deploy an XML package, you
can choose to back it up. With the Backup option selected, Change Assistant creates a configuration that mirrors the

5



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 1
Welcome to JD Edwards EnterpriseOne Configuration

configuration that is being loaded and that contains data from the target system. To restore, you can load the backup
configuration from Change Assistant.

Edit Functions in Specific Nodes  
Configuration Assistant logically enables and disables these edit functions within specific nodes:

• Cut

• Paste

6
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• Delete

• Rename

Folder Structure in the Configuration Assistant  
In this portion of the tree, configuration definitions are grouped together by using folders and subfolders. You can use
folder structures to organize your configurations.

Tip:  You can right-click a folder and choose to create a new subfolder, or delete the selected folder.

Note:
• My Configurations

• JD Edwards Configurations

Help Tab  

Within Configuration Assistant, Help is mapped according to three specific nodes:

• Configurations

• My Configurations

• JD Edwards Configurations

Note:
• The topic Help in the section: Menu Options.

7
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Configurations  
This portion of Help provides overview information and includes a number of productivity hints regarding the user
interface of the Configuration Assistant.

When initially selected, the Help for this node maps to the file Welcome.html. This file name is displayed whenever you
click the Back or Next buttons in the Help navigation.

Tip:  Click the Home button to return to the beginning of the Welcome.html file. To see a complete index of Help
topics for Configuration Assistant, use this Home navigation at the bottom of any Help panel:

My Configurations  
This portion of Help includes a description of My Configurations and includes links to further help for all subnodes:

• Tables

• OMW Projects and OMW Objects (requires JD Edwards Tools Release 8.98 or later)

• User Defined Codes

• Security

• Task Views

• Versions

When initially selected, the help for this node maps to the MyConfigurations.html file. This file name is displayed
whenever you click the Back or Next buttons in the Help navigation.

Tip:  Click the Home button to return to the beginning of the My_Configurations.html file. To see a complete index of
Help topics for Configuration Assistant, use the Home navigation at the bottom of each help topic.

JD Edwards Configurations  
This portion of Help includes a description of JD Edwards Configurations and includes links to further Help for all
subnodes:

• Tables

• OMW Projects and OMW Objects

8
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• User Defined Codes

• Security

• Task Views

• Versions

When initially selected, the help for this node maps to the JDE_Configurations.html file. This file name is displayed
whenever you click the Back or Next buttons in the help navigation.

Tip:  Click the Home button to return to the beginning of the JDE_Configurations.html file. To see a complete index of
Help topics for Configuration Assistant, use the Home navigation at the bottom of each help topic.

Icons Used by Configuration Assistant  
This list includes the icons used within Configuration Assistant:

• About

Indicates that context-specific help is available.

• Add

Adds a new item from a list of available items that are logically determined according to the location from which
the command is invoked.

• APPL Object

Identifies an item as an APPL object within OMW.

• APPL Version Object

Identifies an item as an APPL version object within OMW.

• BL Object

Identifies an item as a BL object within OMW.

• BSFN Object

9
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Identifies an item as a BSFN object within OMW.

• BSFN SBF Object

Identifies an item as a BSFN SBF object within OMW.

• BSVW Object

Identifies an item as a BSVW object within OMW.

• Configuration

• Copy

Copies the selected item and places the contents on the clipboard.

• Cut

Cuts the selected item and places the contents on the clipboard.

• DD (Data Dictionary) Object

Identifies an item as a Data Dictionary (DD) object within OMW.

• Delete

Deletes the selected item and places the contents on the clipboard.

• Deselect All

Deselects all check boxes within an array displayed in the right pane.

• Document

Identifies the item as an attached document.
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• DSTR Object

Identifies an item as a DSTR object within OMW.

• End User Tasks

Identifies an item as an end user task.

• Exit

Exits a form clicked when the user clicks this icon on the form.

• Extract

Extracts the selected package or selected items.

• Find

Executes a search for objects based on criteria into the search dialog box, which are either entered by a user or
selected from a drop-down list.

• Folder

Identifies a node as a folder with no specific attributes known to Configuration Assistant.

• Folder Open

Indicates the selected node is an opened folder with no specific attributes known to Configuration Assistant.

• Help

Displays help for the selected subject.

• GT Media Object

Identifies an item as a GT media object within OMW.

• JD Edwards Configurations
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Identifies the currently selected item as a default read-only configuration located under the JD Edwards
Configurations node.

• My Configurations

Identifies the currently selected item as a user-defined configuration located under the My Configurations
node.

• None Exist

Indicates an error condition for a table. For example, it could indicate a table specification mismatch, that the
DD item missing, or that the table does not exist in the datasource to which it is mapped.

• OK

Indicates it is OK to accept a selection.

• OMW Object

Identifies an item as an OMW object.

• OMW Project

Identifies an item as an OMW project.

• OMW User Defined Code

Identifies an item as an OMW UDC.

• OMW User Defined Code Value

Identifies an item as an OMW UDC value.

• Paste

Pastes the current contents of the clipboard at the selected location.
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• Preferences

Identifies the item selection (from File > Preferences) as preferences for Configuration Assistant.

• Public

Indicates an item as containing *PUBLIC records within JD Edwards EnterpriseOne.

• Public Security Record

Indicates an item as a *PUBLIC security record within JD Edwards EnterpriseOne.

• Refresh

Identifies the Rename function in the file menu Edit > Rename.

• Rename

Refreshes and collapses the left pane node display within Configuration Assistant.

• Role

Indicates an item as containing roles records within JD Edwards EnterpriseOne.

• RPDF Object

Identifies an item as a RPDF object within OMW.

• Save

Saves the selected contents from memory to disk.

• Save All

Saves all currently unsaved items from memory to disk.
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• Security Data

Identifies an item as containing security records within JD Edwards EnterpriseOne.

• Select All

Selects all check boxes within an array displayed in the right pane.

• Solution Explorer Relationship

Identifies an item as a Solution Explorer relationship.

• Solution Explorer Task

Identifies an item as a Solution Explorer task.

• Solution Explorer Variant

Identifies an item as a Solution Explorer variant.

• SVCT Object

Identifies an item as a SVCT object within OMW.

• Table

Identifies an item as a JD Edwards EnterpriseOne database table.

• TBLE Object (existing)

Identifies an item as an existing TBLE object within OMW.

• TBLE Object (existing)

Identifies an item as an existing TBLE object within OMW.
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• Tables

Identifies items as JD Edwards EnterpriseOne database tables.

• TBLE Object (existing)

Identifies an item as an existing TBLE object within OMW.

• TBLE Object (non-existing)

Identifies an item as a non-existing TBLE object within OMW.

• Task Views

Identifies an item as a task view within JD Edwards EnterpriseOne.

• UBE Template Object

Identifies an item as a UBE template object within OMW.

• UBE Version Object

Identifies an item as a UBE version object within OMW.

• User Defined Code (UDC)

Identifies an item as a User Defined Code (UDC) within JD Edwards EnterpriseOne.

• User

Indicates an item as containing user records within JD Edwards EnterpriseOne.

• Version

Identifies an item as a JD Edwards EnterpriseOne version.
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• View

Identifies an item as a view within JD Edwards EnterpriseOne.

• Welcome

Identifies the item selection as the welcome for Configuration Assistant.

• Workflow Object

Identifies an item as a workflow object within OMW.

• XMLP Object

Identifies an item as an XMLP object within OMW.

Multiple Selects and Deselects  
You can select or deselect multiple items using the check uncheck (X) icons that are located at the top of the Tables tab.

Each icon has an associated drop-down list that enables you to perform the batch selection of:

Selects

• Highlighted

• All

• Tables with Data

Tip:  The check icon's drop-down list to select Tables With Data instructs the system to calculate the record count on
all the tables. Note that this process can take considerable time to complete depending on the extent of the database.

Deselects

• Highlighted
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• All

• Tables without Data

Tip:  This selection is temporarily disabled (grayed out) until the counts for the All Tables panel or the Search result
panel have been completed and populated.

If this functionality is disabled (that is, the icon group is completely grayed out), it is because the configuration is read-
only. For example, all JD Edwards Configurations are set to read-only.

Panes in the Configuration Assistant  
The Configuration Assistant allows you to display or hide the right pane of the display.

If the display is showing both panes, to hide the right panel click the lower arrow (right-facing) on the separator bar
between the panes.

If the display is showing a single pane, to show the left panel, click the upper arrow (left-facing).
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Search Drop-Down List - Selecting All  
If you select All from the Search drop-down list, the Configuration Assistant pulls in all items which are defined for the
selected node. This does not include transactional data.

Search Results  
For each Search that you execute, Configuration Assistant automatically creates and opens a new and separate tab
called Results. If you click a node of a different type, and then go back to the previous node, Configuration Assistant
recalls the results tabs that were open. This is true whether or not the nodes are in the same configuration. If you do
not want to save any search results, you should close them as appropriate. To close a results tab, right-click the tab and
select Close Results or Close All Results.

If you hover over a Results tab, the Search criteria of the results are displayed in a flyover panel. For example:

Search Strings - Valid Delimiters  
If you manually enter search strings, or if you copy them from any application such as a spreadsheet, then valid
delimiters for any search field can include the following characters, either singly or in any combination:

• space character(s)

• comma character(s)

• semicolon character(s)

• tab character(s)

If there are multiple contiguous valid delimiters, the system parses them to a single occurrence. For example, if you
enter the search string table1,,,,,table2, the system parses the search string as if a single comma delimiter were
entered and, assuming the system located the tables, the returned results are displayed as table1,table2.
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Search Strings - Wild Cards  
You can use an asterisk (*) as a wild card to substitute for any character in any position within a search string. However,
you cannot use any other operators or Boolean expressions in the search string.

Sorting Within Columns in a Grid  
You can sort (in ascending or descending order) the data in the column in a grid by clicking the column heading. To sort
multiple columns, hold the control (Ctrl) key and click the column headings.

Status Bar  
The bottom bar of the Configuration Assistant screen lists helpful status information for the selected node with these
segments (from left to right):

• Segment 1: Generally displays the name of the Java-based EnterpriseOne application. In this case,
Configuration Assistant.

Note:   Exceptions 

If you are working on a single new unsaved configuration within My Configurations, when you click Save
Definition this element is populated with the phrase NAME saved, where NAME is the name of your
configuration.

If you are working on multiple new unsaved configurations within My Configurations, when you click Save
All this element is populated with the phrase x configurations saved, where x is the number of previously
unsaved configurations that were saved.

• Segment 2: Name of the selected configuration.

• Segment 3: Name of the EnterpriseOne user who is currently signed on.

• Segment 4: Name of the EnterpriseOne environment that is currently signed in to.

• Segment 5: Role of the user who is currently signed on.
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Manually Creating a Shortcut for Configuration Assistant
 
This topic discusses how to manually create a shortcut for Configuration Assistant:

1. In Microsoft Windows, navigate to Start > Settings > Control Panel and double-click the Java icon.
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2. On Java Control Panel, on the General tab, in the Temporary Internet Files section, click the Settings... button.
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3. On the Temporary Files Settings screen, click the View Applications... button.

4. On Java Cache Viewer, with Configuration Assistant highlighted, click the icon to create a shortcut or from the
File Manual select Applications > Install Shortcuts.
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2  Menu Options

Menu Options  
Configuration Assistant provides these menu options:

• File

• Edit

• View

• Help

File  
From the File menu, you have the following selections:

• Adding a New Configuration

• Extracting a Configuration

• Saving a Configuration

• Saving All Configurations

Adding a New Configuration  

CAUTION:  You must be within the My Configurations folder in order to add a new configuration.

This section discusses:

• Accessing Configuration Properties

• Configuration Properties - General Tab

• Configuration Properties - Advanced Tab

Accessing Configuration Properties  
To add (create) a new configuration, you must access Configuration Properties by using one of the following three
methods, which are functionally equivalent:

1. From the Configuration Assistant toolbar, select File > Add > Configuration.
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2. Click the Add button and select Configuration from the drop-down list.

3. In the tree node view in the left pane, highlight and right-click the My Configurations node, and select Add
Configuration.

Using any of the preceding three methods, Configuration Assistant displays the Configuration Properties dialog box,
which enables you to specify the properties for the configuration that you are adding.

Note:
• Configuration Properties - General Tab

• Configuration Properties - Advanced Tab
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Configuration Properties - General Tab  
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On Configuration Properties, with the General tab selected, complete these fields

• Name

Enter a name for your configuration.

CAUTION:

This field is restricted to a maximum of 10 characters, and all characters must be in upper case. You must not
use any of these special characters in this field:

/~`!@#$%^&()+=[]{}|\":;,?\\><*.'";

Additionally, if you plan on extracting a configuration to a RDB, the name cannot start with a number due to
RDB restrictions.

• Description

Enter a description for your configuration.

CAUTION:  This field can contain a maximum of 30 characters.

• Documentation

Optionally, you can attach documentation to be delivered with your configuration. For example, you may
want to include some special installation instructions for your configuration in the form of an HTML file.
Documentation that is attached using this field will be displayed in the Task Assistant, which should be
associated with each task in the load schedule.

There is no restriction on the file types that you can attach as documentation.

You can only attach a single physical file from this field.

Tip: 

If you want to include multiple files as documentation, you can compress them into a single file and attach

the compressed file. Alternately, you can include the documentation (or any other files) that you want to
include in an extracted configuration by placing them in this directory:

<Solution Directory>/<solution name>/ 

All contents of the <solution name> directory are automatically included in the .par file created by
Configuration Assistant when it performs an Extract. However, even though the files are delivered to a
source location using this method, they are not associated with a task as they would be if you used the
Documentation field.

This directory is defined in Using Preferences.
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• Deploy To:

Note:  Use this option to limit the configuration consumer's deployment options when the extracted
configuration is deploying using Change Assistant. Use of this option does not limit the users of
Configuration Assistant.

Use the drop-down list to select the environments to which to deploy:

◦ Selected Environment(s)

Using this selection you can deploy to any selected environment, which can include local environments
as well.

◦ Local Environment Only

Using this section you can only deploy to local environment, regardless of whether the environment is
explicitly selected or not. When you select this option, all other selected environments are ignored.

◦ Local and Selected Environment

Using this selection you can deploy to all selected environments, including any local environment
regardless of whether local environment is explicitly selected or not.

Configuration Properties - Advanced Tab  
You should use the Advanced tab to make selections from preconfigured solutions, if you already have predefined OMW
Projects or Tasks Views, or if you are using languages.

JD Edwards Tools Release 8.97
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JD Edwards Tools Release 8.98 or greater
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On Configuration Properties, with the Advanced tab selected, complete the fields in these two sections:

• Industry/Region

• Additional Configuration
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Industry/Region  
In the Industry/Region section of the Advanced tab, complete these fields:

• Region

The drop-down list is populated based on the UDC Description01 field for the region (01RS/RC).

For example:

ANZ - Australia/New Zealand

• Industry

The drop-down list is populated based on the UDC Description01 field for the industry (01RS/RI).

For example:

MD - Manufacturing and Distributing

CAUTION:

The first time you define an industry or region in a configuration, the data is retrieved based on the
combination of the region and industry UDC values specified. If you subsequently change the industry or
region UDC, your changed configuration will still contain the original data because Configuration Assistant
only changes the definition of the data within the configuration, and not the data itself. When you extract the
configuration, Configuration Assistant assigns any Versions with the changed value.

For example, if you first design a configuration based on the ANZ region, Configuration Assistant pulls
in all record types associated with that UDC. If you subsequently change the region to Singapore, then
the previously retrieved data remains the same, while in the configuration the identifier for the records is
changed from ANZ to SIN. When you extract the configuration, Configuration Assistant changes the identifier
for Versions from ANZ to SIN. As a result,when the configuration is loaded into a target environment, there
are no artifacts from the ANZ region.

CAUTION:  For UDC values of the 01RS/RC and 01RS/RI tables other than the defaults provided by JD Ed-
wards EnterpriseOne:

◦ Customers should use values in the range of 900 to 999 for their configuration.

◦ Business partners should contact Oracle to obtain a unique code.

• Default Task View

The Default Task View is based on the values you select for region and industry. The field is populated
automatically after an industry and region are selected.
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Additional Configuration  
In the Additional Configuration region of the Advanced tab, complete these fields:

• OMW Projects (not displayed with JD Edwards Tools Release 8.98 or greater)

Click the browse button to select from existing OMW Project Names. This enables you to bring all configuration
information such as UDCs and Versions into your definition.

Note:  Configuration information does not include code or objects. For more information about product
packaging, see    JD Edwards EnterpriseOne Tools Package Management Guide   .

• Task Views

Click the browse button to select from an existing Task Master for tasks of type 00 (Task Views).

• Language

Configuration Assistant populates a drop-down list of languages based on the values of UDC 01/LP. When you
select a language from this drop-down list, the translation table (that is, "D" table) records for UDCs and Task
Views are included in your configuration.

For example, a language selection on the drop-down list might be:

P - Portuguese

Note:  Specifying a language pulls language records into your configuration for UDCs and Task Views only.
If you want to include the entire translation table for these, or any other data, you must specifically include
translation tables in the Tables section of your configuration definition.

Note:
• Configuration Properties - General Tab

Extracting a Configuration  
After you create a configuration, you can extract it to a portable database. The output of the extraction depends on the
JD Edwards EnterpriseOne Tools release, JD Edwards EnterpriseOne Applications Release, and the machine on which
the extraction is performed. This topic describes how to extract a configuration.

Tip:

On Web Development Clients (Fat Clients), the Extract function allows you to extract local specifications and Central
Objects.

On Standalone Clients and the Deployment Server, the Extract function only allows you to extract local specifications.

Extraction Output Matrix

Tools Release Output
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Extraction Output Matrix

  

Applications Release
8.12 or prior
 

Application Release 9.00
 

XML
 

XML -- with these extraction machine variables:
 

MSDE
 

Standalone:
 

Extract Local > XML
 

Deployment Server:
 

Extract Local > XML
 

8.98
 

SSE
 

Web Development Client:
 

Extract Central > XML
 
Extract Local > XML
 

8.97
 
8.96
 

Depends on installed
database on extraction
machine which can be
either of the following:
 

• MSDE

• SSE

MSDE
 

 

Note: 

• Troubleshooting Extract

• Packaging and Loading an Extracted File onto a Target Machine

• Tables Involved when Extracting a Configuration Definition with Configuration Assistant
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To extract a configuration, highlight the configuration to be extracted in the tree node display in the left pane:

1. From the Configuration Assistant toolbar, select File > Extract.

Note:  As an alternate method, you can either:

◦ Click the Extract button.

Extract button (Tools Release 8.97)

Extract button (Tools Release 8.98)

◦ Use the keyboard shortcut: Ctrl+T
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CAUTION:  If you accidentally click Extract, or if you want to stop the Extract process after it has begun, click
the Cancel button in the Extract Status dialog box.

The status of the extraction process is displayed in the  node_name -Extract Status panel.

If the Extract completes successfully, each extracted category will be flagged with a green check mark and the
bottom of the Extract Status panel will indicate Completed Successfully in the bottom left of the dialog box.

2. When the extraction is complete, select either Report to view the Extract Report or Close to close the Extract
Status window.

For details about the Extract Report, refer to Extract Report.

Tip:  The portable archive (.par file) of the configuration that you extract is placed into the directory you have
specified in Using Preferences. The prefix of the .par file (that you specified in Name field during the task
Adding a New Configuration) identifies each custom configuration you create in My Configurations.

Troubleshooting Extract  
If you have not previously extracted a report for the selected configuration, and you attempt to view the Extract Report,
this error message is displayed:
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If you have previous extracted a configuration, this error message is displayed:
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CAUTION:  If the Extract does not complete normally, each unsuccessful category will be flagged with a red X and the
bottom of the of the Extract Status panel will indicate Errors Occurred. Click the Report button to view the exception
report, which contains information useful in troubleshooting the error conditions.

Click Yes to view the Exception Report. For details about the Extract Report, see Extract Report.

Tip:  You can also use OMW logs to help in troubleshooting. In OMW, find the project named CFG  
_your_configuration_name  , click the project, and use the form exit to view the logs.

Packaging and Loading an Extracted File onto a Target Machine  
Configuration Assistant. This tool is used to create configurations and to extract them into a portable archive.
Typically the machine on which the tool is running must use a Microsoft Windows operating system. Also typically,
such a machine would be either a JD Edwards EnterpriseOne Standalone Client or a JD Edwards EnterpriseOne Web
Development Client (also known as a Fat Client).

The output of the extraction depends on the JD Edwards EnterpriseOne Tools release, JD Edwards EnterpriseOne
Applications release, and the machine on which the extraction is performed. For details, see the Extraction Output table
in the section entitled: Extracting a Configuration.

Change Assistant. This tool is used to load an extraction onto a target machine, which must be a JD Edwards
EnterpriseOne Deployment Server or Standalone Client. By definition, the Deployment Server must also be running
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a Microsoft Windows operating system. By default, Configuration Assistant creates the .par file in the directory you
specified in Using Preferences.

To summarize the Change Assistant steps:

1. To avoid having Change Assistant inadvertently locate test extractions or perhaps other extractions that you
might not be ready to share, copy the .par file to an appropriate folder under the Change Assistant downloads
directory on the Deployment Server or Standalone Client.

2. Navigate to the specified source directory containing the .par file and select the .par file from the Change
Assistant display.

3. Click the Deploy button.

Change Assistant displays a list of available JD Edwards EnterpriseOne installed environments on this machine
(which is either a Deployment Server or Standalone Client).

4. Select the target JD Edwards EnterpriseOne environment into which you want to load the contents of the
configuration.

CAUTION:  Always beware of data integrity concerns, especially in production data environments. See Backing Up
Your Target Database Environment.

Tables Involved when Extracting a Configuration Definition with Configuration
Assistant  
This section lists the tables involved when extracting a configuration definition with Configuration Assistant.

1. OMW Projects and OMW Objects

These tables and objects will have records extracted corresponding to the OMW projects and OMW Objects
specified in the advanced options:

Table Description or Object Type

F98220
 

OMW Project Header
 

F98222
 

OMW Project Objects
 

F9860
 

TBLE -- Object Librarian Master Table
 

F9861
 

TBLE -- Object Librarian Status Detail
 

F98710, F98711, F98712, F98713
 

TBLE
 

F98720
 

BSFN
 

F98740, F98741
 

ER
 

F98743 DSTR
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Table Description or Object Type

  

F98750, F98751
 

APPL
 

F98760, F98761
 

UBE
 

2. Versions

These tables will have records extracted corresponding to the Versions specified in the configuration definition:

◦ F983051 - Versions List

◦ F983052 - Versions List Tag Table

◦ F98740 - Event Rules - Link Table

◦ F98741 - Event Rules - Spec Table

◦ F98760 - Report Design Aid Text Information

◦ F98761 - Report Design Aid Specification Information

3. User Defined Codes

These tables will have records extracted corresponding to the UDC codes and values specified in the
configuration definition:

◦ F0004 - User Defined Code Types

◦ F0005 - User Defined Code Values

Note:  If language is specified, these tables will also be extracted.

◦ F0004D - User Defined Code - Alternate Language

◦ F0005D - User Defined Code - Alternate Language Description
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4. Task Views

These tables will have records extracted corresponding to the Task Views specified in the configuration
definition:

◦ F9000 - Task Master

◦ F9001 - Task Relationships

◦ F9005 - Variant Description

◦ F9006 - Variant Detail

Note:  If language is specified, these tables will also be extracted.

◦ F9002 - Task Alternate Description

◦ F9005D - Variant Description Alternate Description

◦ F9006D - Variant Detail Alternate Description

5. Security

These tables will have records extracted corresponding to the users and roles specified in the configuration
definition, and the address book information associated with these users will also be extracted:

◦ F0092 - Library List - Users

◦ F00921 - User Display Preferences

◦ F00922 - User Display Preferences Tag File

◦ F00924 - User Install Packages

◦ F00925 - User Access Definition

◦ F00926 - Anonymous User Access Table

◦ F00927 - E1 Users PIM Information

◦ F0093 - Library List Control

◦ F00950 - Security Workbench Table

◦ F95921 - Role Relationships Table

◦ F95922 - Permissions List Relationship Table

◦ F98OWSEC - One World Security

◦ F0101 - Address Book Master

◦ F0111 - Address Book - Who's Who

Saving a Configuration  

CAUTION:  You must be within the My Configurations folder in order to save a configuration.

To save a configuration that you have created (or modified), select Save Definition:

1. Highlight the node for the definition you want to save.
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2. From the Configuration Assistant toolbar, select File > Save Definition.

Note:  As an alternate method, perform either of the following actions:

◦ Click the Save Definition button.

◦ Use the keyboard shortcut: Ctrl+S

Saving All Configurations  

CAUTION:  You must be within the My Configurations folder in order to save all configurations.

To save all configurations that you have created (or modified), select Save All:

1. Highlight the node for the definition you want to save.
2. From the Configuration Assistant toolbar, select File > Save All.

Note:  As an alternate method, you can perform either of the following actions:

◦ Click the Save All button.

◦ Use the keyboard shortcut: Ctrl+Shift+S

Edit  
From the Edit menu, you can perform functions as described in these sections:

• Using Standard Editing Functions (Cut, Copy, Paste, Delete, Rename)

• Using Preferences
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Using Standard Editing Functions (Cut, Copy, Paste, Delete,
Rename)  

CAUTION:

All configurations within the JD Edwards Configurations node are read-only. Configuration Assistant logically enables
and disables certain standard editing functions as applicable, depending on which tree node you select and the
context of the
configuration.

If you select Delete, there is no direct recovery (or "undo") from within the Configuration Assistant program. However,
if you do not perform Save or Save All subsequent to an inadvertent Delete action, you can effectively recover by not
saving, then exiting from Configuration Assistant, and then re-entering with the previously saved state.

This section describes these standard editing functions:

• Cut

• Copy

• Paste

• Delete

• Rename

Tip: 

The functionality of the standard editing functions is also duplicated with Drag and Drop.

For example, if you want to copy the security roles from JD Edwards Configuration to My Configurations, you can

either:

• In the source JD Edwards Configuration, highlight the Roles node and choose the standard editing function
Copy (either from the Edit menu or with a right-click).

In the target My Configuration, highlight either the Roles node (if it exists), or the Security node (if the Roles
node does not exist) and choose the standard editing function Paste.

• In the source JD Edwards Configuration, highlight the Roles node and drag it.

In the target My Configuration, drop the Roles node that you are dragging either to the Roles node (if it exists)
or the Security node (if the Roles node does not exist).

Note:
• The topic Edit Functions in Specific Nodes in the section Productivity Hints.
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Cut  
If you use the standard editing function Cut from either the Edit menu or with the keyboard shortcut Ctrl+C key, the
currently selected node is deleted and its contents are copied to the clipboard.

Copy  
If you use the standard editing function Copy from either the Edit menu or with the keyboard shortcut Ctrl+C, the
contents of the selected node are copied to the clipboard and can be pasted into a new location by using the Paste
command.

If you right-click and select Copy, this dialog box prompts you to enter the new name of the selected node:

Tip:  Use the browse button or enter a fully qualified path to the target directory to which you want to
copy the selected node. For example:  c:\Change Assistant\Packages\Configurator\My Configurations\ 
copied_configuration_name

Paste  
If you use the standard editing function Paste from either the Edit menu or with the keyboard shortcut Ctrl+V key, the
current contents of the clipboard are pasted into the currently selected node.

Delete  
If you use the standard editing function Delete from either the Edit menu or with the keyboard shortcut Delete key, you
are prompted to confirm the deletion:

Rename  
If you use the standard editing function Rename from either the Edit menu or with the keyboard shortcut F2, you are
prompted to enter the new name for the selected node:
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Using Preferences  
From Edit > Preferences you can select preferences from the tabs described in these sections:

• Using the Authentication Tab

• Using the Advanced Tab

• Using the My Configurations Tab
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Using the Authentication Tab  

If you want to use the optional Configuration Assistant Update Center Authentication functionality, complete these
fields:

• User ID

• Password

• User Name

• E-mail

• Phone

If you want to disable the automatic connection to the Update Center, select this check box:

Disable Update Center Connection

If you want Configuration Assistant to always prompt for authentication credentials during startup, you can select this
check box:

Always Prompt at Startup?
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Using the Advanced Tab  

If you want to use the optional Configuration Assistant advanced functionality for connections to the Update Center and
for proxy server authentication, complete these fields:

Update Center Connection

• Timeout (milliseconds)

The default value is 300,000 milliseconds.

• Number of Retries

The default value is 5 retries.

Proxy Server Authentication

• User ID

• Password

• Domain

If you want to be prompted for any advanced functionality on this tab during the startup of Configuration Assistant, you
can select this check box:

Always Prompt at Startup?

Using the My Configurations Tab  
Use the My Configurations tab to define the default working directory for your Configuration Assistant. This is the
working folder for all configurations that you create.

47



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 2
Menu Options

On Preferences, with the My Configurations tab selected, complete this field:

Enter the Configuration Directory

Enter the directory path or use the browse button to enter the directory for your configurations, which the Configuration
Assistant displays under the My Configurations node.

CAUTION:  If you plan to extract RDB configurations this path cannot lead to a mapped drive.

View  
The View menu enables you to generate HTML versions of these reports:

• Summary Report

• Extract Report

48



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 2
Menu Options

• Compare Report

• Refresh

Summary Report  

Note:  As a design aid, you can view a Summary Report for any new or existing configuration regardless of whether it
has been extracted using the Extract function of Configuration Assistant.

The Summary Report provides a listing of all the information contained in the configuration. The report provides links
so that you can easily navigate to each section, including:

• Definition

• OMW Projects and OMW Objects

• Tables

• UDCs

Note:  The system generates UDCs in this report if you specify one UDC value at a time. If you specify an
entire table, the system generates UDCs in the Tables section of this report.

• Versions

• Security

• Task View

The report only displays a link if information exists for the section. That is, if you do not include a Task View in the
configuration, the Summary Report does not create a link to Task View.

In addition, if any documentation is attached to the report, the system provide an active link to it. The generated
source HTML file for the Summary Report is located in the directory of the node name. For example, if you generate a
Summary Report for RSMDGR, then the file is located here:

x:  \Change Assistant\Packages\  your_configuration_name

In this location,  x:  is the drive on which your configurations reside, and

Also,  your_configuration_name  is the name of the node that defines your configuration.

To generate a Summary Report:

1. Highlight any node in an existing configuration.
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2. From the View menu, select Summary Report.

The following status panel is displayed to indicate the report is generating as requested:

After the report is generated, the HTML output is displayed by your default browser as shown in this example:

Extract Report  
The Extract Report provides a listing of all the information about the extraction process and the resulting .par file. The
report provides links so that you can easily navigate to each section, including:

• Definition
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• Action

• Activity

You can only view an Extract Report for configurations that you have previously extracted. To verify if a configuration
has already been extracted, check the directory of the node to verify if a <node_name>_EXTRACT.html file exists. If this
file exists, an Extraction has previously been attempted for the selected configuration. To verify that the Extract process
is valid, open the Extract Report file and verify that the extraction completed with no errors.

To view an Extract Report:

1. Highlight a configuration for which you have previously performed an Extract.
2. From View, select Extract Report.
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Compare Report  
If you want to compare the contents of one configuration against another, you can view the Compare Report, which
presents a side-by-side comparison of the components for the two configurations that you choose. The Compare
Report provides two groups of links, which you can use to review the configurations differently:

• All

The links in this grouping provide a listing of the components for the first configuration and a second column
that describes whether the component exists in the second configuration. For example, All Tables provides a
listing of all the tables in the first configuration and a Yes/No value in the column for the second configuration
to indicate whether the second configuration table is included there.

• Added and Removed

The links in this grouping provide the differences noted in the All comparisons categories. For example, if you
clicked the Added Tables link, the system displays the additional business units in the first configuration that
are not in the second. If there are more tables in the second configuration than the first, a link for Removed
Tables lists the tables in the second configuration.

To compare configurations:

1. Highlight an existing configuration and from the View menu select Compare Report.

The system displays this window:

2. Use the browse button or enter the path to locate the configuration that you want to use for the comparison.
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3. Click Open.

Configuration Assistant generates the Compare report and opens it in your default browser. For example:

4. Use the links at the top of the report to navigate through the different sections of the report. Each topic
contains a comparison of items (by names, numbers, and descriptions) that exist in one configuration, but not
the other.

Note:  In this context, the term “removed" indicates that no add or append action occurred resulting in a
difference between the compared configuration, where the source configuration contains an item while the
target configuration does not.

Refresh  
From the View menu, if you select Refresh (or use the keyboard shortcut F5), the Configuration Assistant refreshes the
screen and returns the tree node display in the left-hand pane to a fully collapsed state. The contents display in the right
pane is not affected.
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CAUTION:  When you make changes (which the system indicates by bold portions of a configuration and affected
nodes), clicking Refresh will cause the system to disregard any changes that you made but did not save.

Help  
When you select Help from the menu selections, you can choose from:

• Show Log

• About Configuration Assistant

Note:
• The topic Help Tab in the section: Welcome to JD Edwards EnterpriseOne Configuration.

Show Log  
The Configuration Assistant creates a new log file every time you start Configuration Assistant. If a log file exists from a
prior startup, it is overwritten.

The type of errors written to this log are typically those for which Configuration Assistant has specific knowledge, such
as Java exceptions, or if Configuration Assistant detects that Update Center is down.

The log file is written to the Configuration Directory specified on the My Configurations tab of Preferences, as described
in Using Preferences of this guide. The name of the log file is ConfigurationAssistantLog.txt

This an example of the contents of a Configuration Assistant log file:
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Tip:  The logging levels cannot be selectable by the end user.

About Configuration Assistant  

If you choose About Configuration Assistant from the Help menu, a dialog box is displayed that contains this
information about Configuration Assistant:

• Version

• Build date

• Install date
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Click OK to close the dialog box and return to Configuration Assistant.
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3  My Configurations

My Configurations  

The My Configurations folder stores the definitions that the Configuration Assistant tool uses to create the portable
archive of a configuration. Your customized My Configurations contain the framework for specific solutions packaged
by the Extract function of the Configuration Assistant tool into the portable archive.

You can use any portion of the JD Edwards read-only configurations as a basis for your custom configuration. For a
description of the Configuration Assistant tools you can use to duplicate any functionality, see Using Standard Editing
Functions (Cut, Copy, Paste, Delete, Rename).

These subnodes of My Configurations are described separately:

• Tables

• Tables

• OMW Projects and OMW Objects

• User Defined Codes

• Security

• Task Views

• Versions
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Note:
• Adding a New Configuration

• Extracting a Configuration

◦ Troubleshooting Extract

◦ Packaging and Loading an Extracted File onto a Target Machine

• Saving a Configuration

• Saving All Configurations

• The topic Status Bar in the section Productivity Hints.
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4  JD Edwards Configurations

JD Edwards Configurations  

This folder is used to store predefined sample versions of configurations that were created using the Configuration
Assistant tool. JD Edwards Configurations are all shipped as read-only.

You can review all of the components of each configuration and use all or any portion as templates to create your own
configurations. Use the Drag and Drop features of the configuration definition tools or standard editing functions to
duplicate the functionality you want. For a description of Configuration Assistant tools you can use to duplicate any
functionality, see Using Standard Editing Functions (Cut, Copy, Paste, Delete, Rename).

These subnodes of My Configurations are described separately:

• Tables

• Tables

• OMW Projects and OMW Objects

• User Defined Codes

• Security

• Task Views

• Versions

• The topic Status Bar in the section Productivity Hints.
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5  Configuration Properties

Overview  
To access the Properties of any configuration under My Configurations and JD Edwards Configurations, click on the
node for the configuration.

The chapter describes these sections of the Properties screen for configurations:

• Configuration

• Advanced

• Default Load Actions

• Object Counts
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Configuration  
The Configuration section of Configuration Properties describes these fields:

• Name

Displays the name of the configuration selected in the Configurations tree view, either in the My Configuration
or JD Edwards Configurations node. This name was defined when the configuration was created, and is not
editable.

• Description

Displays a description of the selected configuration. This Properties Configuration field is editable in this view.

CAUTION:  This field can contain a maximum of 30 characters.

• Documentation

Optionally, you can attach documentation to be delivered with your configuration. For example, you may
want to include some special installation instructions for your configuration in the form of an HTML file.
Documentation that is attached by using this field will be displayed in the Task Assistant, which should be
associated with each task in the load schedule.

There is no restriction on the file types that you can attach as documentation.

You can only attach a single physical file from this field.

Tip:

If you want to include multiple files as documentation, you can compress them into a single file and attach
the compressed file. Alternately, you can include the documentation (or any other files) that you want to
include in an extracted configuration by placing them in this directory <Solution Directory>/<solution
name>/

All contents of the <solution name> directory are automatically included in the .par file created by
Configuration Assistant when it performs an Extract. However, even though the files are delivered to a
source location using this method, they are not associated with a task as they would be if you used the
Documentation field.

See the definition of this directory in Using Preferences.
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• Release

Configuration Assistant populates this value based JD Edwards EnterpriseOne release number that is printed
on the machine on which Configuration Assistant is running at the time the configuration is created.

Tip:  Although this Release value is programmatically determined when creating a configuration, an
enhancement to Change Assistant allows configurations to be applied to any release. If there is a mismatch in
the Release value during deployment, Change Assistant issues a warning that cautions the user that although
cross release application of the configuration is allowed, it should not be done without full knowledge of the
consequences and thoughtful testing.

• Deploy To:

Note:  Use this option to limit the configuration consumer's deployment options when the extracted
configuration is deploying by using Change Assistant. Using this option does not limit the use of
Configuration Assistant.

Use the drop-down list to select the environments to which to deploy:

◦ Selected Environment(s)

Use this selection to deploy to any selected environment, which can include a local environment.

◦ Local Environment Only

Use this section to only deploy to a local environment, regardless of whether the environment is explicitly
selected or not. When you select this option, all other selected environments are ignored.

◦ Local and Selected Environment

Use this selection to deploy to all selected environments including local environments, regardless of
whether local environment is explicitly selected or not.

Advanced  
The Advanced section of the Configuration Properties describes these fields:

• Region

The drop-down list is populated based on the UDC Description01 field for the region (01RS/RC).

For example:

ANZ - Australia/New Zealand
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• Industry

The drop-down list is populated based on the UDC Description01 field for the industry (01RS/RI).

For example:

MD - Manufacturing and Distributing

CAUTION:

The first time you define an industry or region in a configuration the data is retrieved based on the
combination of the region and industry UDC values specified. If you subsequently change the industry
or region UDC, your changed configuration will still contain the original data because the Configuration
Assistant only changes the definition of the data within the configuration, not the data itself. When you
extract the configuration, the Configuration Assistant assigns any versions with the changed value.

For example, if you first design a configuration based on the ANZ region, the Configuration Assistant pulls
in all record types associated with that UDC. If you subsequently change the region to Singapore, then
the previously retrieved data remains the same, while in the configuration the identifier for the records
is changed from ANZ to SIN. When you extract the configuration, the Configuration Assistant changes
the identifier for Versions from ANZ to SIN. As a result, when the configuration is loaded into a target
environment, there are no artifacts from the ANZ region.

CAUTION:  For UDC values for the 01RS/RC and 01RS/RI tables other than the defaults provided by JD
Edwards EnterpriseOne:

◦ Customers should use values in the range of 900 to 999 for their configuration.

◦ Business partners should contact Oracle to obtain a unique code.

• Language

Configuration Assistant populates a drop-down list of languages based on the values of UDC 01/LP. When
you select a language from this drop-down, the translation table (that is, "D" tables) records for UDCs and Task
Views are included in your configuration.

For example, a language selection in the drop-down might be:

P - Portuguese

Note:  Specifying a language pulls language records into your configuration for UDCs and Task Views only.
If you want to include the entire translation table for these, or any other data, you must specifically include
translation tables in the Tables section of your configuration definition.
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Default Load Actions  
The Default Load Actions section of Configuration Properties consists of these sections:

• Tables

• UDCs

• Security

Tables  
Use the options to select a data load action into your database when the configuration data is loaded for your target
environment:

• Replace Tables

The table in the target environment will be replaced with the table in the configuration.

CAUTION:

If any records exist in the target tables to be replaced, they will be lost because Replace Table selection
indicates that you want to replace the table with data from the portable archive created by Configuration
Assistant.

You should always beware of data integrity concerns, especially in production data environments. See,
Backing Up Your Target Database Environment.

• Replace Records

Table records in the target environment will be replaced with the records in the configuration table.

CAUTION:

Replace Records does not clear the table before it copies. It replaces records in the target with the same key.
Any new records are appended.

You should always beware of data integrity concerns, especially in production data environments. See,
Backing Up Your Target Database Environment.

• Append Records

Only records that do not exist in the target environment will be copied from the configuration tables.

CAUTION:

You cannot create a configuration to extract and deliver an empty table. That is, you cannot define an empty
table in your source environment to overwrite an existing populated table in your target environment.

You should always beware of data integrity concerns, especially in production data environments. See
Backing Up Your Target Database Environment.

65



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 5
Configuration Properties

UDCs  
Use the options to select a data load action into your database when the configuration data is loaded for your target
environment:

• Replace UDCs

The UDCs in the target environment will be replaced with the UDCs in the configuration.

CAUTION:

If any UDCs exist in the target tables to be replaced, they will be lost because this selection indicates that you
want to replace the UDC with data from the portable archive created by Configuration Assistant.

You should always beware of data integrity concerns, especially in production data environments. See
Backing Up Your Target Database Environment.

• Replace Records

Table records in the target environment will be replaced with the records in the configuration table.

CAUTION:

Replace Records does not clear the table before it copies. It replaces records in the target with the same key.
Any new records are appended.

You should always beware of data integrity concerns, especially in production data environments. See
Backing Up Your Target Database Environment.

• Append Records

Only records that do not exist in the target environment will be copied from the configuration tables.

CAUTION:

You cannot create a configuration to extract and deliver an empty table. That is, you cannot define an empty
table in your source environment to overwrite an existing populated table in your target environment.

You should always beware of data integrity concerns, especially in production data environments. Refer to
Backing Up Your Target Database Environment.
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Security  
Use the options to select a data load action into your database when the configuration data is loaded into your target
environment:

• Replace *Public/Role/User

*Public/Role/User in the target environment will be replaced with *Public/Role/User in the configuration.

CAUTION:

If any *Public/Role/User exists in the target tables to be replaced, they will be lost because this selection
indicates that you want to replace *Public/Role/User with data from the portable archive created by
Configuration Assistant.

You should always beware of data integrity concerns, especially in production data environments. See
Backing Up Your Target Database Environment.

• Replace Records

Table records in the target environment will be replaced with the records in the configuration table.

CAUTION:

Replace Records does not clear the table before it copies. It replaces records in the target with the same key.
Any new records are appended.

You should always beware of data integrity concerns, especially in production data environments. See
Backing Up Your Target Database Environment.

• Append Records

Only records that do not exist in the target environment will be copied from the configuration tables.

CAUTION:

You cannot create a configuration to extract and deliver an empty table. That is, you cannot define an empty
table in your source environment to overwrite an existing populated table in your target environment.

You should always beware of data integrity concerns, especially in production data environments. See
Backing Up Your Target Database Environment.

Object Counts  
This section provides quantity statistics of the selected configuration for these individual items:

• Business Data Tables

• User Defined Codes

• Public Security

67



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 5
Configuration Properties

• Roles

• Users

• Task Views

• Versions

• Projects

• Objects
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6  Tables

Overview  
The Tables node lists and describes JD Edwards EnterpriseOne tables that are available in Configuration Assistant. You
typically use Configuration Assistant with configuration tables and not transactional tables. Oracle provides a way to
identify just the configuration tables using the Search and All Tables functions.

Tip:  In addition to the tables that Configuration Assistant automatically identifies as transactional, you can manually
select D tables if you need them.

CAUTION:  Because JD Edwards EnterpriseOne Tools Release 8.98 uses the XML format, if the target table has new
columns, the database default value for the new column is used for each record added. It is recommended that
configurations containing such tables should not be done without full knowledge of the consequences and thoughtful
testing.

You can include all or a subset of these tables in your configuration. Because Configuration Assistant retrieves the
tables from the JD Edwards EnterpriseOne database, it provides a set of known and assigned attributes assigned to
these tables, which are helpful in determining their contents and suitability for inclusion in your configuration:

• Table number (as assigned by JD Edwards EnterpriseOne)

• Number of rows in the table

• Load action (as defined with Configuration Assistant; the action that will be performed in the target
environment for this configuration)

• Data class

• Copy data

• Description

• Object use

• System code

• Reporting code

• Data source

To populate the Tables node, you can use these tabs:

• Search

• All Tables
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Note:  These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Search  
With the Tables node selected, the Search tab provides these functions:

• Search button
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• Drop-down lists (predefined database query)

Drop-down lists include predefined database queries. When you make a selection the Table Name field
is automatically populated with the table names associated with the selection. These drop-down lists of
predefined database queries and their predefined tables are:

◦ Non-Transactional Tables

The list of tables was created by Oracle applications development. It does not include any system code
74, 75, or 76 tables. When you choose this search type the Table Name field is automatically populated
with the list, which includes hundreds of tables. To view the complete list, you can manually copy the
contents out of the field display and into a readable form.

◦ Business Data

Includes all tables that have a data class of B, which is automatically populated in the applicable Criteria
field.

◦ System Tables

Includes all tables that have a data class of S, which is automatically populated in the applicable Criteria
field.

◦ Control Tables

Includes all tables that have a data class of T, which is automatically populated in the applicable Criteria
field.

◦ Foundation Tables

Includes all tables for system code 00.

◦ Distribution Tables

Includes all tables for system codes 40, 41, 42, 43, 43Q, 45, 46, 49, 40, 40G, 40R, 41B, 43C, 43E, 46L, and
46R.

◦ Manufacturing Tables

Includes all tables for system codes 30, 31, 31B, 32, 34, 37, 40, 41, F30L, F31, F31K, and F34R.
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• Search Criteria Fields

◦ Table Name

◦ Description

◦ System Code

◦ Reporting Code

◦ Data Class

◦ Copy Data Flag

All Tables  
When you select the Tables tab in the right panel, the Configuration Assistant displays a list of all JD Edwards
EnterpriseOne tables in the Tables datasource for the environment you are logged in to.

The grid contains a variety of information about each table, including the current row count.

By default, the lists of Tables is shown with a split screen where the top portion lists all the tables, and the bottom
portion is used to display the records in the specified table. You can click the up and down arrow in the separator bar to
toggle the split screen on and off (“See the figure below for the location of the arrows.").

Note:  The system performs the data retrieval and table analysis in a method that improves memory
management.The table search starts the first time you click on the Table node of a configuration. The table record
count is not calculated until you select a table. To select all tables with data, you can use the check drop-down list
to select Tables With Data, which instructs the system to calculate the record count on all the tables. You can then
deselect unwanted tables. For details about using the check option, see Multiple Selects and Deselects.
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Note:  The Tables tree node in the left pane displays subnodes for selected records if All Tables or Selected Tables are
selected. The tree subnode shows record level detail such as *All records or the Primary Key for Selected Records.

You can use the lower half of the All Tables split panel to search and select individual records within a table. To view a
specific record within a table, use the checkbox in the top half of the split panel to select a table. The bottom half of the
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split panel displays each record, where boldfaced entries indicate key fields (not necessarily the Primary Key). To search
for specific key values within a record, enter a value in the data entry field on the Search panel and click the Search tab.
Individual Results tabs are created to display the results of each search.

CAUTION:  A value of blank in any field indicates a wild card search for any value. Because tables with a large number
of records can consume more memory than available, Configuration Assistant displays a warning if a search is going
to return too much data. In this case, you should either narrow the search or select the entire table.

Tip:   Hover Text: You can hover over any field description within a record to ascertain the literal key name. For
example, in F0002, if you hover on Product Code the key name NNSY is displayed.

Tip:   None Exist Icon: This icon in the Rows column of a listed table indicates an error condition for a table. For
example, it could indicate a table specification mismatch, that a DD item is missing, or that the table does not exist in
the datasource to which it is mapped.

74



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 7
OMW Projects and OMW Objects

7  OMW Projects and OMW Objects

Overview  
You can include all or a subset of OMW Projects and OMW Objects in your configuration. As it retrieves the OMW
Projects and OMW Objects from the JD Edwards EnterpriseOne database, Configuration Assistant provides a set of
known and assigned attributes assigned to these projects, which are helpful in determining their contents and suitability
for inclusion in your configuration:

OMW Projects

• Project Name

• Description

• Status

• Type

• System Code

• Release

OMW Objects

• Object

• Status

• Type

• System Code

• Reporting Code

To populate the OMW Projects node, you can use these tabs:

• Search

• All Projects
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Note:  These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Search  
With the OMW Projects node selected, the Search tab provides these functions:

• Search button

• Drop-down selection (All)

• Search Criteria Fields:

◦ Project Name

◦ Description

◦ System Code

◦ Status

◦ Type

◦ Release

Under the OMW Projects node, with the EnterpriseOne Objects node selected, you can choose from these object search
categories:

• Object Librarian (APPL, BSFN, BSVW, DSTR, TBLE, UBE)

• Data Dictionary
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• OMW Project

• Workflow

• User Overrides

• Business Service Property

• Report Definition

• XMLP Publisher Object (Business Intelligence)

The following screens show example searches for each of the above listed object search categories.

Object Search Category: Object Librarian

Object Search Category: Data Dictionary

77



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 7
OMW Projects and OMW Objects

Object Search Category: OMW Project
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Object Search Category: WorkFlow
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Object Search Category: User Overrides
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Object Search Category: Business Service Property
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Object Search Category: Report Definition
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Object Search Category: XMLP (Business Intelligence)
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All Projects  
When you select the Tables tab in the right panel, Configuration Assistant displays a list of all JD Edwards EnterpriseOne
OMW Projects and OMW Objects in the OMW Projects datasource for the environment that you are logged in to.

The grid contains a variety of information about each OMW Project and OMW Object.
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8  User Defined Codes

Overview  
The User Defined Codes node lists and describes JD Edwards EnterpriseOne UDCs which Configuration Assistant
has identified from the data source. You can include all or a subset of these UDCs in your configuration. Because
Configuration Assistant retrieves the UDCs from the JD Edwards EnterpriseOne database, it provides a set of known and
assigned attributes assigned to these tables, which are helpful in determining their contents and suitability for inclusion
in your configuration. Different attributes are displayed in the right pane depending on the level of detail:

• Upper part of right pane

◦ Product Code

◦ Code Type

◦ Description

• Lower part of right pane

◦ Product Code

◦ Code Type

◦ Value

◦ Description 01

◦ Description 02

Note:  For any selected records, the non-changeable default load action is to replace records.

CAUTION:  Some UDCs contain technical values related to your JD Edwards EnterpriseOne environment setup.
Carefully consider how these might affect your target environment if you choose to extract all UDCs.

To populate the User Defined Codes node, you can use these tabs:

• Search

• All User Defined Codes
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Note:  These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Search  
With the User Defined Codes node selected, the Search tab provides these functions:

• Search button

• Drop-down list from predefined searches by industry or other category (for example, Financials)
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• Search Criteria fields:

◦ Code|Type (combination search for code type pairs, for example: 01|AB and 02|CD)

◦ Product Code

◦ Code Type

◦ Type Description

◦ Value

◦ Value Description 01

◦ Value Description 02

All User Defined Codes  
When you select the All User Defined Codes tab in the right panel, the Configuration Assistant displays a list of all JD
Edwards EnterpriseOne UDCs in the User Defined Codes datasource for the environment you are logged in to.

The grid contains a variety of information about each UDC, including types and descriptions.
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9  Security

Overview  
The Security node contains these subnodes:

• Public

• Roles

• Users

When you click the Security tab, the system displays a grid showing all currently defined security records for the
selected node:
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Note:  These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar
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Public  

With the Public node selected, the Search tab provides these functions:

• Search button

• Drop-down list from predefined searches
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• Search Criteria fields:

◦ Security Type

You can use the drop-down list to select one of these security types:

1 - Action Security

2 - Column Security

3 - Application Security

4 - Row Security

5 - Processing Option Security

6 - Hyper Exit Security

7 - External Calls Security

◦ User Name

The system displays a static value of *PUBLIC for this field. This value cannot be changed.

◦ Object Name

◦ Version Name

◦ Data Item

◦ System Code

Note:  For any selected records, the non-changeable default load action is to replace records.
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Tip:  If you have a configuration that was created by a prior version of Configuration Assistant that did
not support this function, the security node in the tree view will not have a Public node underneath it.
You can add the Public node by using the Add > Security button.

This displays all three security nodes (Public, Role, User) underneath the Security node.
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Roles  

CAUTION:  When you use Configuration Assistant to select User or Role records, the system also selects any
corresponding security records that are set up for User and Role, including: Action, Solution Explorer, Environment,
and Application. The system automatically tags the selected roles with the information provided for the Region and
Industry fields that you used when you added the configuration properties while extracting the data.

With the Roles node selected, the Search tab provides these functions:

• Search button

• Drop-down list from predefined searches
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• Search Criteria fields:

◦ Address Book

CAUTION:  User input in this field is restricted to numeric data. No alpha characters are allowed in
order to avoid database errors.

• Name

• Description

• Region

• Industry

Note:  For any selected records, the non-changeable default load action is to replace records.

Tip:  For searches, you can use the drop-down list to select from predefined values for the Region and Industry fields.
See Configuration Properties - Advanced Tab for a description of the UDC values that are used by Configuration
Assistant to complete the fields selected from the drop-down list.

Users  

With the Users node selected, the Search tab provides these functions:

• Search button
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• Drop-down list from predefined searches

• Search Criteria fields:

◦ Address Book

CAUTION:  User input in this field is restricted to numeric data. No alpha characters are allowed in
order to avoid database errors.

◦ Name

◦ Description

◦ Region

◦ Industry

Note:  For any selected records, the non-changeable default load action is to replace records.

Tip:  For searches, you can use the drop-down list to select from predefined values for the Region and Industry fields.
See Configuration Properties - Advanced Tab for a description of the UDC values that are used by Configuration
Assistant to complete the fields selected from the drop-down list.
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10  Task Views

Task Views  
When you select the Task Views tab, the system displays a grid showing all currently defined task views for the selected
node:

Note:  The selection of task views is only from the highest level within JD Edwards EnterpriseOne. You cannot select
only specific sections within a task view. You must either select the entire task view or not.

With the Task Views node selected, the Task Views tab presents a list of the Task View categories. If you expand a
Task View category, Configuration Assistant retrieves and populates the display with all task views associated with the
category. During the retrieval, Configuration Assistant displays a status indicating the progress of the record retrieval.

Note:  For any selected objects, the non-changeable default load action is to replace objects.
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CAUTION:  This can be a time-consuming process, depending on the number of records that are retrieved. You
cannot cancel the record load after you have initiated it. However, you can continue to use other functionalities of
Configuration Assistant while the load is in progress.

Note:  These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

100



JD Edwards EnterpriseOne Tools
Configuration Assistant User's Guide

Chapter 11
Versions

11  Versions

Overview  
When you click the Versions node, in the right panel you can select from these tabs:

• Search

• All Versions

Note:  These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Search  
With the User Defined Codes node selected, the Search tab provides these functions:

• Search button
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• Drop-down list from predefined searches by industry or other category (for example, Rapid Start)

Note:  If you select All from the Search drop-down list, the Configuration Assistant pulls in all items that are
defined for the selected node. These items do not include transactional data.

• Search Criteria fields:

◦ Code Type

◦ Product Code

◦ Type Description

◦ Value

◦ Value Description 01

◦ Value Description 02

Note:  For any selected objects, the non-changeable default load action is to replace objects.

All Versions  
When you select the All Versions tab in the right panel, the Configuration Assistant displays a list of all JD Edwards
EnterpriseOne Versions in the Version datasource for the environment you are logged in to.

The grid contains a variety of information about each version, including object, version, and description.
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Note:  When you select All Versions, the Configuration Assistant displays all default JD Edwards EnterpriseOne
versions (such as those that are prefixed with XJDE and ZJDE) as well as versions associated with Rapid Start (those
that are prefixed with RIS).
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