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* e CHAPTER 1

Overview of the Oracle Developer Studio IDE

This chapter describes the advantages of using Oracle Developer Studio IDE.

Why Use the Oracle Developer Studio IDE?

Oracle Developer Studio offers a graphical integrated development environment (IDE) that is
built on the NetBeans platform and configured with Oracle Developer Studio tools suite directly
in the environment. In the IDE, you can do the following:

= Compile and build code with Oracle Developer Studio C, C++, and Fortran compilers
and the dmake distributed make command.

®  Debug code with dbx debugger For more information, see Chapter 7, “Debugging Your
Application™.

m  Profile your code with profiling tools that integrate Oracle Developer Studio analysis tools:
= Run Monitor tools uses Performance Analyzer's data collection.

= Memory Analysis tool uses discover's dynamic memory checking. For more
information, see “Running Memory Access Checking on Your Project” on page 93.

= Static Code Checking uses Code Analyzer's static error data collection. For more
information, see “Using Static Code Error Checking” on page 43.

= Data Races and Deadlocks tool uses Thread Analyzer's data collection and analysis.

m  Run the IDE locally while Oracle Developer Studio compilers and tools installed
on a remote server using remote development. For more information, see “Remote
Development Setup” on page 97.

m  Create a special distribution of the IDE while it's running on your remote build server with
remote desktop distribution.

The rest of this guide shows how to use all these features in the IDE.

Chapter 1 « Overview of the Oracle Developer Studio IDE 9
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¢ e CHAPTER 2

Creating a New Application

This chapter shows the steps for creating a new application project in the IDE,
sometimes called a managed project. For more information, see “Creating an Application
Project” on page 11.

To learn about how to create a project with existing sources, see Chapter 4, “Creating a Project
From Existing Sources”.

This chapter also explains other tasks you can do with your project, such as:

= “Switching Between the Logical View and the Physical View of the Project” on page 13
= “Adding Files to Your Project” on page 14

m  “Setting Properties and Configurations” on page 16

= “Building Your Project” on page 18

= “Compiling a Single File” on page 19

Creating an Application Project

Open the New Project wizard by choosing File > New Project (Ctrl+Shift+N).
In the wizard, select the C/C++/Fortran category.

The wizard gives you a choice of several types of new projects. Select C/C++/Fortran
Application and click Next.

Chapter 2 « Creating a New Application 11



Creating an Application Project

'] ¢) New Project ]
Steps Choose Project
1. Choose Project Q, Filter: |
2. .. -
Categories: Projects:
3 cfc++iFortran [ c/C++/Fortran Project with Existing Source
3 Tuxedo CfC++/Fortran Project from Binary File
o [ Samples 5] c/C++/Fortran Application
m C/C++/Fortran Dynamic Library
C/C++/Fortran Static Library

=

C/C++ Ot Application
C/C++ Qt Dynamic Library
C/C++ Ot Static Library
C/C++ Database Application

-

[ T»]

Description:

Creates a new project that uses an existing makefile or configure script and existing
sources. It uses vour makefile to build the project.

| < Back || MNext = || Finish || Cancel || Help |

4. Create a new C/C++/Fortran Application project from the wizard using the defaults. You
can choose the name of the project and the location of the project.

5. Click Finish to exit the wizard.
A project is created with several logical folders, which are displayed in the Projects window:

= Header Files
= Resource Files
= Source Files
= Important Files

A C, C++, or Fortran Project with Existing Sources is created with one logical folder, Important
Files.

A logical folder is not a directory. It is a way for you to organize your files and does not reflect
where the files are physically stored on disk. Files added to the Source Files Folder, Header
Files folder, and other logical folders become part of the project and are compiled when you
build the project.
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Switching Between the Logical View and the Physical View of the Project

Note - Header files added to the Header Files folder must be referenced in your source files
through #include statements in the usual way if you want them to be compiled into the
program.

Files added to the Important Files folder are not part of the project and are not compiled when
you build the project. These files are just for reference and are convenient when you have a
project with an existing makefile.

Switching Between the Logical View and the Physical View
of the Project

A project has both a logical and a physical view. You can switch between the logical view
and the physical view of your project. When you create a project, the first tab that opens is the
Projects tab, which displays in logical view.

1. Select the Files tab. This window shows the physical view of your project. It displays files
and folders as they are stored on disk.

Projects Files X |Classes Services [=]

¢ |j Cppapplication_1
¢ |j nbproject

o= |j private
"E'I Makefile-Debug.mk
"E'I Makefile-Release.mk
"E'I MMakefile-impl.mk
"E'I Makefile-variables .mk
g@ Package-Debug bash
g@ Package-Release bash
configurations xmil
project xml

T Makefile

@ main.cpp

2. Select the Projects tab. This window shows the logical view of your project.

Chapter 2 « Creating a New Application 13



Adding Files to Your Project

Proje... * |Files Classes Services

o[ Arguments 1
- E Header Files
- Resource Files

-] E Source Files
B args.c

o [ Important Files
o= D CppApplication_1

Adding Files to Your Project

The following sections describes how to add different types of files and folders to your current
project, either by creating them or introducing existing sources.

m  “Creating Logical Files and Folders for Your Project” on page 14
= “Creating New Source Files for Your Project” on page 15
m  “Creating Header Files for Your Project” on page 15

m  “Adding or Removing Existing Files to Your Project” on page 15

Creating Logical Files and Folders for Your Project

You can create logical folders and add them to your project. Note that a logical folder is not
stored on a disk, since it aims to organize your project files in physical view.

Click the Projects tab.

2. Right-click the project node of your CppApplication_1 project and choose New Logical
Folder. A new logical folder is added to the project.

3. Right-click the new logical folder and select Rename. Type the name you would like to give
the new folder.

You can add both files and folders to an existing folder. Logical folders can be nested.

14 Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017



Adding Files to Your Project

Creating New Source Files for Your Project

You can create new source files and add them to your project.

1. Right-click the Source Files folder and choose New > C Main File.
2. On the Name and Location page, newmain is displayed in the File Name field.
3. Click Finish.

Note - In this case, you do not need the main. cpp file that was added by default when you
created the project.

Creating Header Files for Your Project

You can create new header files and add them to your project.

1. Right-click the Header Files folder and choose New > C Header File.
2. On the Name and Location page, newfile is displayed in the File Name field.
3. Click Finish.

The newfile.h file is created on disk in the project directory and added to the Header Files
folder.

Adding or Removing Existing Files to Your Project

You can add existing files to your project in two ways:

m  Right-click the Source Files folder and choose Add Existing Item. You can point to an
existing file on disk using the Select Item dialog box and add the file to the project.

= Right-click the Source Files folder and choose Add Existing Items from Folders. Use the
Add Folders dialog box to add folders that contain existing files.

Do not use the New menu item to add existing items. The Name and Location panel will tell
you the file already exists.

You can also remove files from the project folders by right-clicking on the file name. Then,
choose Remove From Project.

Chapter 2 « Creating a New Application 15



Setting Properties and Configurations

Setting Properties and Configurations

16

The following sections describe how to set and manage your properties for both the current
project and individual files.

m “Setting Project Properties” on page 16
m  “Managing Configurations” on page 17
m “Setting Source File Properties” on page 17

Setting Project Properties

When the project is created, it has two configurations, Debug and Release. A configuration is
a collection of settings used for the project, which enables you to easily switch many property
settings at once. The Debug configuration builds a version of your application that includes
debug information. The Release configuration builds an optimized version.

The Project Properties dialog box contains build and configuration information for your project.
To open the Project Properties dialog box:

= Right-click the project node of the CppApplication project and choose Properties.

ﬁ t) Project Properties - CppApplication_1 m
Categories:
o |General Manage Configurations... |
¢ @ Build

C Compiler Project Location: fhomejvbox/DevStudioProjects/CppApplication_1

C++ Compiler

2 Source Folders:

@ Fortran Compiler - Add
=]

@

@

Assembler
Linker
Packaging

Run

Profile

Debug Ignored Folders Pattern:

Related Projects [~(nbproject|build|test|tests)$ | Default

Formatting (See also IDE lewvel file filter in Options-=Miscellaneous-=Files]

|

D Qo 0 9 9

Encoding: |UTF-8 |v|

| QK || Cancel || Apply || Help
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Setting Properties and Configurations

You can modify the compiler settings and other configuration settings in the Project Properties
dialog box by selecting a node in the left panel and modifying the properties in the right panel.
Select some of the nodes and property values and notice the properties you can set. When

you set General properties, you are setting them in all configurations of the project. When

you set Build, Run, or Debug properties, you are setting properties in the currently selected
configuration.

Managing Configurations

When a project is created, it has a Debug configuration and a Release configuration. A
configuration is a collection of settings used for the project. You can easily switch many
settings at once when you select a configuration. The Debug configuration builds a version
of your application that includes debug information. The Release configuration builds an
optimized version.

Properties changed in the Project Properties dialog box are stored in the makefile for the current
configuration. You can edit the default configurations or create new ones.

To create a new configuration:

1. Click the Manage Configurations button in the Project Properties dialog box.

2. In the Configurations dialog box, select the configuration which most closely matches your
desired configuration. In this case, select the Release configuration and click the Duplicate
button. Then click Rename.

3. In the Rename dialog box, rename the configuration to Performance Release. Click OK.

4. Click OK in the Configurations dialog box.

5. In the Project Properties dialog box, select the C Compiler node in the left panel. Note that
the PerformanceRelease configuration is selected in the Configuration drop-down list.

6. In the property sheet in the right panel, change the Development Mode from Release to
PerformanceRelease. Click OK.

You have created a new configuration that will compile the application with a different set of
options.

Tip - You can also set the active configuration in the IDE's toolbar, or by right-clicking the
project node and selecting Set Configuration.

Setting Source File Properties

When you set the project properties for your project, the relevant properties apply to all files in
the project. You can set some properties for a specific file.

Chapter 2 « Creating a New Application 17



Building Your Project

Right-click the newmain. c source file and choose Properties.

Click the General node in the Categories panel and see that you can select a different
compiler or other tool to build this file. You can also select a checkbox to exclude the file
from the build of the currently selected project configuration.

Click the C compiler node and note that you can override the project compiler settings and
other properties for this file.

Cancel the Project Properties dialog box.

Building Your Project

To build your project:

1.

Right-click the project and choose Build. The project builds. The build output is shown in
the Output window.

]

Output - CppApplication_1 (Build) X
gmake[2]: Entering directory ~/home/vbox/DevStudicProjects/Cppapplication_L° a
mkdir -p build/Debug/GNU-Solaris-x86

|>1> rm -f "build/Debug/GNU-Solaris-x86/main.o.d"

g++ - -g -MMD -MP -MF "build/Debug/GNU-Sclaris-x86/main. o.d" -o build/Debug/GNU-Solaris-x86/main.o main.cpp
E mkdir -p dist/Debug/GNU-Solaris-x86
g++ -0 dist/Debug/GNU-Solaris-x86/cppapplication_1 build/Debug/GNU-Solaris-x86/main. o

gmake[2]: Leaving directory ~/home/vbox/DevStudioProjects/CppApplication_1'
gmake[1]: Leaving directory °~/home/vbox/DevStudioProjects/CppApplication_1'

BUILD SUCCESSFUL (total time: 488ms)

2. Switch the configuration from Debug to Performance Release in the configuration drop-

down list in the main toolbar. Now the project will be built using the Performance Release
configuration.

Right-click the project and choose Build. The project builds. The build output is shown in
the Output window.

To build multiple configurations of the project at the same time, choose Run > Batch Build
Project and select the configurations you want to build in the Batch Build dialog box.

You can build, clean, or both clean and build the project by right-clicking the project and
choosing actions from the menu. The project also keeps object files and executables from
different configurations separate, so you do not have to worry about mixing files from multiple
configurations.
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Compiling a Single File

To compile a single source file:

®  Right-click on the newmain. c file and choose Compile File. Only this file is compiled.
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Running a Project

This chapter describes how to run a project in the IDE and contains the following sections:

= “Running a Project” on page 21

= “Launchers” on page 22

Running a Project

The Arguments sample program prints command-line arguments. Before running the program,
you will set some arguments in the current configuration. Then you will run the program.

To create the Arguments_1 project, set some arguments, and run the project:

Choose File > New Project.

2. In the project wizard, expand the Samples category.

W

Select the C/C++ subcategory, then select the Arguments project. Click Next, then click
Finish.

Right-click the Arguments_1 project node and choose Build. The project builds.
Right-click the Arguments_1 project node and choose Properties.

In the Project Properties dialog box, select the Run node.

In the Run Command text field, type 1111 2222 3333 after the output path. Click OK.

N ook
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ﬁ ¢ Project Properties - Arguments_1 m
Categaries:
@ General Configuration:|Debug (active) |V| | Manage Configurations...
¢ @ Build
@ C Compiler o EeEnerel
& C4++ Compiler Run Command "${OUTPUT_PATH}" "arg 1" "arg 2" "... = |:|
@ Fortran Compiler Run Directory D
@ Assembler Environment D
& Linker Build First
@ Packaging Console Type Int?rnal Terminal -
o External Terminal Tvpe Default
o Profile Remove Instrumentation Ask -
@ Debug
@ Related Projects
@ Formatting
Debug
| oK || Cancel | | Apphy | | Help

8. Choose Run > Run Main Project. The application builds and runs. Your arguments are
displayed in another tab..

Launchers

launcher.properties is a file located in nbproject that is used to manage Run or Debug
configuration settings in a project. You can create launchers from the project context menu
and enter different arguments for it. You can also run a launcher file with a script. To create a
launcher file from the project's context menu, click Manage Launchers.
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File Edit Wiew Mavigate Source Refactor Run Debug Profile Team Tools Window Help Q'

rPEES| D N TW b B e

%|Files |servi...|Clas.. | = (“StartPage x| [ leuncher.properfies x| M=l
[ Welcome_2 ’—"—| ) R
Header Files SIS I T E - @ - E % '5 E ? % % Ei I;->E H

[ Resource Files launcher1000.displayName=0a0ns
¢ [ Source Files launcherl000. runCommand=5{ OUTPUT_PATH} " uname -a " -
B welcome. cc
¢ E Important Files
T Makefile

- Launchers ox

launcher2000.displayMName=g[;.
launcher2000. runCommand=3{OUTPUT PATH: "My ENY"
launcher2000.env.MY_ENV=Vzlus of my o

O AWM

Launchers List Launcher Name [env |
% common Properties Run Cgmmand

[> Common Properties ${OUTPUT_PATH} "$MY_ENWV"

[ uname

B env

Build Command | |

[»|@

Run Directory | |

Symbol Files | |

Environment Variables

4r: Oms; system: Oms

Name | Value
MY_ENY [value of my env

v ] Cmmee (] i Gl
Run in Own Output Tab

"
| 3kl | NS

Once you have created your launcher, you can directly configure your project's Run or Debug
settings from the context menu.
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24

File Edit View MNawigate Source Refactor Run

Debug

Profile Team Tools Window Help

FEE%| 9@

— R B R

Projects X |Files Services Classes =
¢ [E] welc =

o—He

New 4

Start Page x ::@ launcher.properties x

Source History @ E - E - a EI 5 E

Manage Launchers...

Open Required Projects

@ Re{ Add Existing Item... 1| launcher1000.d1splayName=unane
¢ (@ 50! Add Existing Items from Folders... 2 launcherlg00.runCommand=5{OUTFLUT_PATHF " uname -2 "
New Logical Folder... 3
¢ @ m — 5 4 launcher2000.displayName=cry.
= LT 5 launcher2000. runCommand=2{OUTELT_PATHY " $MY_ENY"
Clean and Build 6 launcher2000.env.My_ENV=Value of my gny
More Build Commands 3 7
Set Configuration »
Set Build Host 3
Debug M env
Step Into M Default
Test Alt-F6

Output - Welcome_2 (Run uname) Xl =]
Navigator X | Close =
g Welcome ... -
@ mainlit Rename
Mave. .. » Arguments:
1: Sun05 beta 5.11 11.3 186pc 1386 186pc
Copy...
Delete Delete u> RUN UMAME FINISHED; exit value O; real time: Oms; user: Oms; system: Oms
Code Assistance v & 0
Find Ctrl-F 20T
Versioning »
History »
Properties
=
1:1 INS
Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017




* e CHAPTER 4

Creating a Project From Existing Sources

You can also create projects from existing sources that already include a makefile, or that

build a makefile when you run configure scripts. This type of project is called an unmanaged
project. For more information about projects and makefiles, see the C/C++/Fortran Projects and
Makefiles page in the IDE help.

This chapter contains the following sections:

m  “Creating a Project From Existing Sources” on page 25
m  “Creating a Project From a Binary File” on page 27
m  “Code Assistance” on page 29

Creating a Project From Existing Sources

With a C/C++/Fortran Project From Existing Sources, the IDE relies on your existing makefile
for instructions on how to compile and run your application.

Choose File > New Project.
Select the C/C++/Fortran category.

Select C/C++/Fortran Project From Existing Sources and click Next.

El S

On the Select Mode page of the New Project wizard, click the Browse button. In the Select
Project Folder dialog box, navigate to the directory where your source code is located. Click
Select.
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| t) Mew Project X|
Steps Select Mode
1. Choose Project Specify the folder that contains existing sources:
2. Select Mode
3 |,"homef’\.fbox.*tools_1| |v || Browse...
Build Host: ||0(a|hgst |v|
Tool Collection: |Default {GNU (GNU Solaris)) |V|

Select Configuration Mode:
@) Autormnatic (using Makefile)
) Customn

Select Automatic to enable automatic configuration of project settings from an
existing makefile or configure script in the source folder. Select Custom if there is
no makefile ar configure script in the source folder, or to view or change project
settings before the project is created.

Important:

After the project is created, the Clean and Build actions specified in the existing
makefile are run automatically. Compiled binaries in the project folders will be
overwritten. To disable this action, select Custom mode and then deselect Clean
and Build after Finish.

I.-'Lr'.lote that Clean and Build actions will be run automatically

| < Back || ext = || Finish || Cancel || Help

Use the default configuration mode, Automatic. Click Finish.

The project is created and opened in the Projects window, and the IDE automatically
runs the Clean and Build sections specified in the existing Makefile. The project is also
automatically configured for code assistance.

You have created a project that is a thin wrapper around existing code.

Building and Rebuilding Your Project

To build the project:
= Right-click the project node of the project and choose Build.
To rebuild the project:

= Right-click the project node of the project and choose Clean and Build.

26 Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017



Creating a Project From a Binary File

Creating a Project From a Binary File

With a C/C++/Fortran project from a binary file, you can create a project from an existing
binary file in multiple ways.

Creating a Project from a Binary File With New
Project Wizard

Choose File > New Project.
Select the C/C++/Fortran category.
Select C/C++/Fortran Project from Binary File and click Next.

On the Select Binary File page of the New Project wizard, click the Browse button. In the
Select Binary File dialog box, navigate to the binary file from which you want to create a
project.

Ll S

The root directory for the source files from which the binary was built is filled in
automatically. By default, only the source files from which the binary was built are included
in the project. By default, dependencies are included in the project. The shared libraries
required by the project are automatically listed.
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ﬁ ) New Project B

Steps Select Binary Files

1. Choose Project
2. Select Binary Files Binary Files: |,fhomerox."tooIsfbuildalljpty_open |v| | Select... |

3. Project Name and

Location Sources Root: [inetisolaris vbox/hame/vbox/tools |

Include into Project |Source files used in build |v|

Dependencies: |Inc|ude Dependencies into the Project |v|
...|Shared Libr. . Library Path

Clibeso. T |flib/libe.so.1 L]

< Back || Mext = || Finish || Cancel || Help |

5. Click Next.

6. On the Project Name and Location page, you can choose the name and location of the
project. Click Finish.

Creating a Project from Binary File in Files
Window

1. In the Files window, go to the Arguments_1 project and expand the build node all the way
down to args.o.

2. Do one of the following to bring up the Create Project wizard:
®  Right-click the args.o file and click Create Project.

®  Drag the args. o file to the source editor.
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[~ ¢) Create Project (%]

Executable: |f’home;’\.-'boxf’DevStudioProjectsJ"Arguments lfbuildeebungNU—So|aris-x86fsrcf’a|
Working Directory: |_."home,'\.-'box,"De\.-'StudioP‘rojects,"Arguments 1/build/Debug/GNU-Solaris-«86/src |

Arguments: [ |

Environment: [ |

Project: |-:create new project= |v|

Configuration: | | |

Dependencies: |Inc|ude Dependencies into the Project |v|

Project Mame: |args.o |

Project Location: |jhome,ﬁ.-'box,"DevStudioF‘rojects |

Project Folder: /homefvbox/DevStudioProjects/args.o

Create Project || Cancel |

The Create Project wizard pops up, with Executable and Working Directory pre-filled out.

3. Input any arguments and environment variables you would like to use when running the
project. In the Project drop-down menu, choose <create new project>.
If you click the Create Project button on the bottom right corner, a new project called
Args.o will be created in the projects tab.

4. Click cancel.

Code Assistance

Code Assistance is a set of IDE features that help you navigate and edit source code,
specifically for unmanaged projects. For more information about editing and navigating, see
Chapter 6, “Editing and Navigating Source Files”.

For an unmanaged project, you can specify how your code will be parsed to enable the code

assistance features of the IDE. This section will discuss how to configure code assistance and
code assistance cache sharing.
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Configuring Code Assistance

When you create a project, you can specify the include files and macro definitions that will be
used by the built-in parser to create the configuration. If the project has been built with debug
information, you can have the built-in parser automatically search for the include files and
macro definitions for each compiled source file.

To specify additional code assistance configuration information that will improve the accuracy
of the code assistance features of the IDE for a project, use the Configure Code Assistance
wizard. To start the wizard, right-click your project and choose Configure Code Assistance. To
learn more about configuring Code Assistance and the Configure Code Assistance wizard, see
the relevant help sections in the IDE.

Code Assistance Cache Sharing

When parsing C/C++ source code, the IDE stores parse results on a disk in the Code Assistance
cache. When you open a project, the IDE examines the cache to see if it is up to date. If the
cache is up to date, the IDE does not parse your project and just loads the required data for code
navigation form the Code Assistance cache.

By default, the IDE creates one code assistance cache for all your projects in your user directory
in the $userdir/var/cache folder. The cache in your user directory cannot be copied or shared
to another location.

However, if the Code Assistance cache is placed inside a project, it can be copied to another
computer if the computer's operating system is identical to the operating system where the code
was parsed and if the tool collection used by the project is available in the same location on the
computer.

For more information about Code Assistance Cache sharing and to learn how to instruct the
IDE to please the Code Assistance cache inside your project metadata, see “Code Assistance
Cache Sharing” on page 30 and Relocating the Code Assistance Cache for Version
Controlled Projects in the IDE help.

Project Properties Options for Code Assistance

The IDE now provides the following project properties to make it easier for you to use
unmanaged projects in version control systems.

Transient macros You can provide a list of macros (-D options) that are volatile.
They depend on time, date, or specific environment. These macros
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environment variable values will not be stored with the project's public

metadata.
User Environment You can provide a list of environment variables that the project uses to
Variables pass system-specific paths. These macros environment variable values

will not be stored with the project's public metadata. For unmanaged
projects, you can specify the list of environment variables to be used
when storing project metadata. When the IDE stores the compiler options
and an option value coincides with a variable value, a macros will be
written instead.

Search File System for C/C++ Header Files

If you create an unmanaged project where the sources have not been built and does not contain
any debugging information, the IDE might have trouble configuring code assistance. In

this case, you can specify in the Configure Code Assistance wizard to use a special mode,
Search file system for C/C++ header files. In this mode, the IDE tries to resolve failed include
directives by searching the file system for headers. The wizard asks you to enter the path to
search for headers. By default, the path is the project source root.
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Creating an Oracle Database Project

This chapter describes how to create an Oracle Database project in the IDE and points to
several references to learn more about Oracle Database projects and how to use them in the
IDE. For more resources about Oracle Database Projects and the IDE, see “Oracle Database
Projects” on page 107.

Creating an Oracle Database Project

You can create a project for an Oracle Database application. In order to do so, the Oracle
Developer Studio installation you are using must include the optional Oracle Instant Client
component.

Choose File > New Project.

2. Inthe New Project dialog box, select the C/C++/Fortran category and the C/C++ Database
Application project. Click Next.

3. On the Project Name and Location page, you can choose the name and location of the
project. Click Next.

4. On the Master table page, select jdbc:derby://localhost:1527/sample from the
Database Connection drop-down list. The IDE connects to the database.

If there is no database listed under Database Connection, wait a few moments and try again.
Derby is a database that is built into JDK 6 and later versions.

If you would like to create a new database connection, see “Creating a New Database
Connection” on page 34.

5. Select the master table for your project from the Database Table drop-down list.

Use the arrow keys between the Available Columns and Columns to Include lists to select
the table columns you want to include in your project.
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34

i) New C/C++ Database Application

Steps

Master Table

1. Choose Project

2. Project Name and
Location

3. Master Table

Database Connection: |jdbc:derby:ﬂ’localhost:152?fsamp|e [app on APP] |v|

Database Table:

Available Columns

|CUSTOMER

M

=

bl

Columns to Include

CUSTOMER_ID
DISCOUNT_CODE
ZIP

MAME
ADDRESSLINEL
ADDRESSLINEZ
CITY

STATE

PHOME

FAX

EMAIL
CREDIT_LIMIT

(2w ]

= Back || lext =

|| Finish || Cancel || Help

7. Click Finish.

Creating a New Database Connection

To set up a new connection to an Oracle database:

1. On the Master Table page, select New Database Connection to create a new database

connection.
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Creating an Oracle Database Project

[+ §J New Connection Wizard (%

Customize Connection

Driver Narmes: |Orac|e Thin (Service ID (SID)) on Oracle Thin (ojdbc7) |'|

Host: [localhost | port:[1521

Service ID (SID): [XE |

User Name: | |
Password: | |
[ ] Remember password
‘ Connection Properties ‘ | Test Connection
IDBC URL: |jdbc:oracle:thin:@Iocalhost:lE?l:XE|
= Back | | Mext = | ‘ Einizh | ‘ Cancel ‘ | Help

Enter the database address and your user name and password on the Customize Connection
page of the New Connection wizard, then click Next.

On the Choose Database Schema page of the New Connection wizard, enter the database
schema or select it from the list. Click Finish.
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Editing and Navigating Source Files

The IDE enables you to edit and navigate through your source files in the editor. This chapter
contains the following sections:

m  “Editing Source Files” on page 37
m  “Navigating Source Files” on page 49

Editing Source Files

The Oracle Developer Studio IDE provides advanced editing and code assistance features to
help you in viewing and modifying your source code. To explore these features, use the Quote
project:

1. Choose File > New Project.

2. Inthe project wizard, expand the Samples category and the C/C++ subcategory, then select
the Quote project. Click Next, then click Finish.

Setting the Formatting Style

You can use the Options dialog box to configure default formatting style for your projects.

Choose Tools > Options.
Click Editor in the top pane of the dialog box.
Click the Formatting tab.

El S

Select the language for which you want to set formatting style from the Language drop-
down list.

5. Select the style you want to set from the Style drop-down list.
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=] ¢ Options %]
: Q [ritter ictri+F) |
%l & 8 &
v | ECHn I8 W
General |Editor| Fonts & Colors Keymap ¢j/c++ Team Appearance Miscellangous Tuxedo
Code Templates r Hints r/ Highlighting r/ Macros r On Save r Spellchecker r Go To |
General r/ Folding r Formatting Code Completion
Language: |C++ .eview
: include <Map= |~
LCategory: Formatting Style = *
Stvle: |NetBeans |v|| Manage namespace A { 1
[] override Global Options class ClassA : InterfaceA, InterfaceB, InterfaceC {
public:
¢ Indents [a] int number;
Indent Size 4 = .
Expand Tabs to Spac | enum inner 1
Tab Size g PLUS, MINUS
Statement Continuati 8 . 1
Constructor Continua 0 private:
S char#+ cc;
Preprocessor DirectivNone - A
5 : public:
# at Start Line
Indent Namespaces Classal) : ccl({"a", "B", "C", "D"}), number(2) {
Indent Case Stateme
Absolute Label Indent
Indent Visibility None Al = int method(char* text, int number) { |
Moo S Do (L — if (tevt == miutl o hd
| Export... ‘ ‘ Import... | | 0K | ‘ Apply || Cancel ‘ ‘ Help

Modify the style properties as desired.

Folding Blocks of Code in C and C++ Files

For some types of files, you can use the code folding feature to collapse blocks of code so that
only the first line of the block appears in the Source Editor.

In the Quote 1 application project, open the Source Files folder, then double-click the cpu.
cc file to open it in the Source Editor.

Click the collapse icon (small box with minus sign) in the left margin to fold the code of
one of the methods.

Mouse over the {...} symbol to the right of the folded block to display the code in the block.
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Using Semantic Highlighting

You can set an option so that when you click on a class, function, variable, or macro, all
occurrences of that class, function, variable, or macro in the current file are highlighted.

N

9.

ok wh =

Choose Tools > Options.

Click C/C++ in the top pane of the dialog box.

Click the Highlighting tab.

Make sure that all of the check boxes contain checkmarks.
Click OK.

In the customer. cc file of the Quote_1 project, notice that the function names are
highlighted in bold.

Click on an occurrence of the Customer class.

All of the occurrences of the Customer class in the file are highlighted with a yellow
background.

: E customer.cc = m E @

Source | History = - o v 3 3 SEnE: @ B fE s
24 SUBSTITUTE GOODS F. SEEVICES; LO33 OF USE, DATA, FE. FPROFITS: F. BUSINESS - m
25 * INTERRUPTICH) HOWEVEER CAUSED AND CIN ANY THECEY OF LIABEILITY, WHETHEERE IN
26 * CCHNTRACT, STRICT LTAEILITY, F TORT (IMCLUDING MEGLIGENCE COR COTHERWISE
27 * ARISING IN ANY WAY COUT OF THE USE OF THIS SCFTWARE, EVEN IF ADVISED OF
28 * THE POSSIEILITY OF SUCH DAMAGE
29 '
30
3l fiinclude "customer.h"
3z
2 Customer::Customer (const string initName, int initDiscount)
34 names (initNames) ,
35 % discount (inicDiscount) |
36 } B
37
38 int Customer::GetDiscount () const {
38 T return discount:
a0 } -
41
42 string Customer::GetWHame () const {
43 T return name; T
44 }
45
46 ostreams operator << (0STreams OUCPUL, CONST CUSTOMEr & CUSTOWEL) {
47 output << customer.nams << " has discount " << customer.discount << '%';
48 return output;
49 }
In the customer.h file, notice that class fields are highlighted in bold.
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4 ]=]|O

E“] customer.cc X = 'E‘] customerh =

I

M.
f2

Source History A R

28 L IBEILITY OF SUCH DAI I e
29 -
30

31 [ #ifndef _customer H

3z #define customer H

33

34 f#include <iostream:>

35

36 using namespace std;

37

38 [ class Customer {

39 public:

40 Customer (const string initName, int initDiscount);

41 string GetName () const; ]
4z int GetDiscount () const;

43

44 private:

45 String name;

48 int discount;

47 A
48 friend ostream& operator<< (ostreamé&, const Customer&); T
48 -~ }:

50

51| - #endif

Using Code Completion

The IDE has a dynamic C and C++ code completion feature that enables you to type one or
more characters and then see a list of possible classes, methods, variables, and so on that can be
used to complete the expression.

Open the quote. cc file in the Quote 1 project.

2. On the first blank line of the quote. cc file, type a capital C and press Ctrl-Space. The
code completion box displays a short list that includes the Cpu and Customer classes. A
documentation window also opens and displays the message No documentation found
because the project source code does not include documentation.

3. Expand the code completion list by pressing Ctrl-Space again.

40 Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017



Editing Source Files

@ customer.cc X @ customerh |- @ quote.cc x

Source | History E-H- &S

<[~

I
I
&

ot
28

("]
31
3z
33
34
35
36
37
38
38
40
41
4z
43
44
45
48
47
48
45
50
51
52
53
54
55
56
57
L1}

L * THE POSSIBILITY

E

CF

SUCH DAMAGE

ISE) Cpu
&) Customer

@ CUsStomers
#= -

cpu_flag t
ctid T

LE_TCE
LOCKS_FPER_SEC

list<Customer:>

tomer (3)) 1" << endl;
dl:

-

o documentation found.

it !'= customers.end();

r instance

| »
u

+

-

[»]

| 30j2

| NS

4. Select a standard library function such as calloc() from the list and the documentation
window displays the man page for the function if the man page is accessible to the IDE.

Select the Customer class and press Enter.

Complete the new instance of the Customer class by typing andrew;. On the next line, type
the letter a and press Ctrl-Space. The code completion box displays andrew. If you press
Ctrl-Space again, the code completion box displays a list of choices starting with the letter
a, such as method arguments, class fields, and global names, that are accessible from the
current context.
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30 Customer andrew;

o a

2 @ andrew Customer |*
33| | & arc Max
34| | &5 asserte (EX)
35 | alczone long
36| |8 ansi_1 3
37 | @ acal(const char*) long
38| | @ abort i woid
39 | @ absiint) int |

0 | @ acos (double) double

41 | @ acosfifloat) float

2| | @ acoshidouble) double

43| | @ acoshf (float) float

44 | ® acoshl(long double) long double

45 | @ acoslilong double) long double

46 | @ aditime (timeval”*, timeval®) int Ze () <<
47| | @ ascftime {char*, const char®*, tm®) int [le===== !
48 | @ asctime (tm*) char* E

7. Double-click the andrew option to accept it and type a period after it. You are automatically
provided with a list of the public methods and fields of the Customer class.

30 Customer andrew;
3l andrew.

2 #Hinc discount int
33 Hinc @ name string
34 #inc| O GetDiscount|() int
35 (0 GetMame () string
3B finclude "customer.h"

37 finclude "svystem.h'

8. Delete the code you have added.
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Using Static Code Error Checking

When you type code in a source or header file in the Source Editor, the editor performs static

code error checking as you type and displays an error icon ®in the left margin when it detects

dn error.

1. 1Inthe quote. cc file of the Quote 1 project, type #include "m" on line 40. A code
completion box pops up, recommending two header files that begin with m.

37
38
358
40
41
42
43
44

B

finclude "di=sk.h"

finclude "cpu.h"

finclude "memory.h"

Hincluds "m"

namespalf memory. h .
lis™df module.n

Press 'Ctl+5PACE Again for Al kems

viold outCustomersList ()

{

Click in the source editor away from your added code. Notice the error icon that appears in

Backspace over the second quotation mark and complete the statement by typing odule.h”,

and notice that error icon disappears as soon as the statement references an existing header

2.
the margin.
37 finclude "di=sk.h"
38 H#include "cpu.h"
38 H#include "memory.h"
@ L finclude "m"
41 [ namespace {
4z list«<Customer> CUsSLOomers;
43
44 [T] viold ountCustomersListi() {
3.
file.
4. Delete the statement you have added.

For more information about how to choose which errors to see or to disable static code error
checking, see the relevant help page in the IDE.
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Adding Source Code Documentation

You can add comments to your code to generate documentation for your functions, classes, and
methods. The IDE recognizes comments that use Doxygen syntax and automatically generates
documentation. It can also automatically generate a comment block to document the function
below the comment.

1. Inthe quote.cc file, place your cursor on the line above the line int readNumberOf (const
char* item, int min, int max) {.

2. Type a forward slash and two asterisks (/**) and press Enter. The editor inserts a Doxygen-
formatted comment for the readNumberOf class.

73 return -1;

74 }

75 & —
76

77 =
78

79 |
80

8l

BZ| = int readWumberOf (const char?* item, int min, int max) {

83 [f cout << "Enter number of " << item << " (" << min << " <= I <= ' << max <<

Add some descriptive text to each of the @param lines and save the file.

Click the readNumberOf class to highlight it in yellow, and click one of the occurrences
marks on the right to jump to a location where the class is used.

74 £ }

75 C ||
76
77
78
79
80
81

82 [ int readfumberOf (const char* item, int min, int max) {

83 cout << "Enter number of ' << item << " " << min << " <= I <= ' << max <<
g4

85 string s;

86 getline (cin, s):

a7 if jecin.ecfi) || cin.faili)) |

ga8 exit (EXIT _FAILUERE) ;

5. Click the readNumberoOf class in the line you jumped to, and press Ctrl-Shift-Space to show
the documentation you just added for the parameters.
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170
171 int amount = readNumberOf("CPUs", 1, 10);
172
173 Cpu MyCpul
174 Parameter:
1735 MySystem. & jiem Type of item B
176 1
177 response =|(Parameter: a1 o -|
178 min Least amount of item customer can order —
179 switch (re
180 case '|Parameter:
181 re max Maximum amount of item customer can order
182
183 case '|Returns:
184 ty
185 br L
188 =
T E— T
| 171118 | mns

Click anywhere else in the file to close the documentation window, and click on the
readNumberOf class again.

Choose Source > Show documentation to open the documentation window for the class
again.

Using Code Templates

The Source Editor has a set of customizable code templates for common snippets of C, C++,
and Fortran code. You can generate the full code snippet by typing its abbreviation and pressing
the Tab key. For example, in the quote. cc file of the Quote_1 project:

Type uns followed by a tab and uns expands to unsigned.
Type iff followed by a tab and iff expands to if (exp) {}.
Type ifs followed by a tab and ifs expands to if (exp) {} else {}.

Type fori followed by a tab and fori expands to for (int i=0; i< size; i++)
{ Object size = array[i]; }.

To see all of the available code templates, modify them, create your own code templates, or
select a different key to expanded the templates:

=

Choose Tools > Options.
In the Options dialog box, select C/C++, and click the Code Templates tab.
Select a language from the Language drop-down list.

Add or remove items using the New or Remove buttons. You can also edit current templates
in the Expanded Text tab or add a description of the template in the Description tab.
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ﬂ &) Options m
8/ - . R Q]
%l a C& IS [=

General |Editor| Fonts & Colors Keymap ¢j/c++ Team Appearance Miscellangous Tuxedo

F Code Templates r Hints r/H\ghIighting r/ Macros rOn Save r Spellchecker rGo To |

General r/ Folding r Formatting r Code Completion
[a]
Language |C++ |v| §
Templates:
Abbreviation Expanded Text Description New
EX EXEC SQL -
br break
ca case
cl class
cls class ${CLS newVarhame default="Class"} .. [Creates declaration of new class (without in...
clss #include "${CLS newVarName default="Clas... |Creates implementation of class =
o continue -

(Ezpandad Text rges(ription ‘
bool

— —

Export... ‘ ‘ Import... oK | ‘ Apph || Cancel ‘ ‘ Help

Using Pair Completion

When you edit your C and C++ source file, the Source Editor does “smart” matching of pair
characters such as brackets, parentheses, and quotation marks. When you type one of these
characters, the Source Editor automatically inserts the closing character.

1. Inthe Quote_1 project, place the cursor after the { on line 116 of the module. cc file and
press Return to open a new line.

2. Type enum state { and press Return. The closing curly bracket and the semi-colon are
added automatically and the cursor is placed between the brackets.

3. Type invalid=0, success=1 to complete the enumeration.

On the line after the closing }; of the enumeration, type if (. The closing parenthesis is
added automatically and the cursor is placed between the parentheses.

5. Type v==null. Then type i and newline after the right parenthesis. The closing bracket is
added automatically.
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6.

Delete the code you have added.

Finding Text in Project Files

You can use the Find in Projects dialog box to search projects for instances of specified text or a
regular expression.

1.

2.

4.

Open the Find in Projects Dialog box by right-clicking a project in the Projects window and
choose Find or choose Edit > Find in Projects (Ctrl+Shift+F).

In the Find in the Projects dialog box, select the Default Search tab or the Grep tab. The
Grep tab uses the grep utility, which provides a faster search, especially for remote projects.

& #) Find in Projects (X |
l/Default Search |/Grep |

Containing Text: | |v|

[The text will be used literally) test

[ ] Match Case [ | Whole Words  Match: |Literal |v|

Scope: |LT‘_"| Open Projects |v|

[]search in Archives [ ]| Search in Generated Sources

File Name Patterns: | |‘,|

[Example: * java, FZP?7?.jsp)

[[]Use lgnore List (=dit! [_] File Path Regular Expression (test

ﬁ Please specify text to find or file name pattern.

Open In Mew Tab | Find | | Close || Help |

In the Grep tab, type the text or regular expression that you want to search, specify the
search scope and file name pattern, and select the check box for Open in New Tab so you
can save multiple searches in separate tabs.
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48

rDefault Search rGrep |

Regexpr to find (grep swntax):

|public

Search scope:

Filename pattern:

[[]Match case [ | whole Words

Cpen In New Tab Eind | | Close || Help |
5. Click Find.
ut Search Resutts X =]
File Full Path | File Size

¢ [ Found & matching files.
s system.h
[ public: ~ [Line: 42
? ®moduleh
[ public: ~ [Line: 41]
¢ 1 customer h
[ public.  [Line 39)
o ] memary h
o @ diskh
o B cpuh

Eel€] @]

lexporthomeldemol /Sample/Quote_1 .I’S'y'st...|:| 2110
lexporthomeldemao’ /Sample/Gucte_1imod... |:| 2018
lexporthomeldemol /Sample/Quote_1 .l’c:ust...|:| 1978
lexporthomeldemol /Sample/Quote_1 m1em...|:| 2010

lexporthomeldemol /Sample/Qucte_1idisk.h |:| 2030
lexporthomeldemo’ fSample/Qucte_1icpuh |:| 2051

Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017




Navigating Source Files

The Search Results tab lists the files in which the text or regular expression is found.
Buttons in the left margin enable you to change your view of the search results.

6. Click the Expand/Collapse button to collage the list of files so only the files names are
shown.

7. Double-click one of the items in the list and the IDE takes you to the corresponding location
in the source editor.

Find and Replace

You can use the Find/Replace feature in the editor and it works entirely in the Find tool bar at
the bottom of the editor window, instead of a separate dialog box for replacing. The Replace
field and buttons are displayed in the tool bar under the Find field and buttons. Press Ctrl+F to
activate the Find tool bar and Ctrl+H to activate the Replace feature.

Using Your Clipboard History

Once you find the text you were looking for, you might want to copy and use this text in other
areas of your code.

You can view the last nine buffers of text that were copied to your desktop clipboard and select
one to paste. With your cursor at the point where you want to insert text, press Ctrl+Shift+D

to open a popup of the clipboard entries. Use the arrow keys to navigate through the clipboard
buffers and see the full contents in the window below the list of buffers. To paste the contents of
a buffer, type the number of the buffer, or press Enter when the buffer is selected. Note that this
buffer contains content copied from any window on your desktop, not just the IDE.

Tip - You can copy a file path to your clipboard by hovering the mouse cursor over any file in
the IDE and press Alt+Shift+L.

Navigating Source Files

The IDE provides advanced navigation features for viewing your source code. To explore these
features, continue using the Quote 1 project.
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Window Management and Grouping

You can perform actions on groups of windows in addition to individual windows. Each
window belongs to a group you can minimize, drag to a new location, float in a separate
window, or dock back into the IDE window.

1. Minimize the Projects, Files, Classes, Classes, and Services windows in the top left by
clicking the Minimize Window Group button on the right side of the group.

2. Right-click in the tab area of the group or choose Window > Configure Windows and select
Maximize (Shift+Escape) to maximize the Window Group.

Note that you can choose other options such as Float or Dock your window group.

Using the Classes Window

The Classes window lets you see all of the classes in your project, and the members and fields
for each class.

1. Click the Classes tab to display the Classes window.
2. Expand the Quote 1 node. All classes in the project are listed.

3. Expand the Customer class.
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Projects Files Classes X | Services [=]

o= Iﬁ a.out
o= ﬁ Arguments_1
o= ﬁ Cppapplication_1
¢ (57 Quote_1
o= IZ% Libraries
o= M unnamed (quote.cc)
o= ﬁ; Cpu
' ﬁ; Customer
@ discount
@ name
£» Customer(const string inthlame, int intDis
() GetDiscourt() const
) GetMame() const
@ operator ==(ostreams, const Customer&)
Disk

- D

o= ﬁ; Memory

o &Y Module

o= ﬁ; System
@ mainfint arge, char** argv)
é operator ==(ostream, const Customer&)
é operator ==(ostream, const Module&)
é operator ==(ostream, const Systema)

4. Double-click on the name variable to open the customer.h header file.

Using the Navigator Window

The Navigator window provides a compact view of the file that is currently selected, and
simplifies navigation between different parts of the file. If the Navigator window is not open,
choose Window > Navigating > Navigator (Ctrl-7) to open it.

1. Click anywhere in the quote. cc file in the Editor. window.

2. A compact view of the file is displayed in the Navigator window. Click the node at the top
of the window to expand the view.
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& Mavigator

¢ G

customers

(.-:J fetchCustomersList()

(.-:J getDiscountFor{string name)

(.-:J outCustomersList()

(.-:J readChari{const char* prompt, char defaut&nswer)
(.-:J readMumnberCf{const char® tem, int min, int max)

5
|
p=
=
2

@ mainfint arge, char** argv)

3. To navigate to an element of the file, double-click the element in the Navigator window and
the cursor in the Editor window moves to that element.

4. Right-click in the Navigator window to see options for sorting the elements in the window,
grouping the items, or filtering.

5. To see what the icons in the Navigator window represent, open the IDE online help
by choosing Help > Help Contents. In the Help browser, click the Search tab and type
navigator icons in the Find field.

Finding Class, Method, and Field Usages

You can use the Usages window to show you everywhere a class (structure), function, variable,
macro, or file is used in your project's source code.

1. 1Inthe customer.cc file, right-click the Customer class on line 42, and choose Find Usages
(Alt-F7).
In the Find Usages dialog box, click Find.

The Usages window opens and displays all of the usages of the Customer class in the source
files of the project.
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glysages of Class Customer: [16 occurrences, 3 fitered
o [ quote_1
? E‘] customer.cc
@ 33 Customer:Customer(const string initMame, int intDiscount) :
@ 38 int Customer: GetDiscourt() const {
@ 42 string Customer: GetMame() const {
@ 46 ostream& operator =<{ostream& output, const Customers customer) {
? |E‘| customer h
© 48 friend ostream& operator<< (ostream&, const Customera);
? E‘] quote.cc

© 42 list=Customer= customers;

i e D B
It @ [#

@ 48 for{list=Customer=:iterator it = customers begin(); it = customers enc(); ++it) {
@ 58 customers push_back{Customer(". U100

@ B0 customers push_back{Customer("l/il I

@ B1: customers push_back{Customer('F 130y

@ B2 customers push_back{Customer b

© B3 customers push_back{Customer( 0", A

@ &7 for{list=Customer=:iterator it = customers begin(); it = customers enc(); ++it) {

LT';,Output | a412 |ms

Find Usages runs in the background so you can do other tasks while it is search a large
number of files. The Usages window updates results as they are incrementally found. There

is a progress indicator and an incrementing count of occurrences. You can stop the search at
any point and your search results up to that point are saved. You can navigate between the
search hits, change the view from logical to physical, and run Find Usages again with different
settings.

Using the Call Graph

The Call Graph window displays two views of the calling relationships between functions in the
classes. A tree view shows the functions called from a selected function, or the functions that
call that function. A graphical view shows the calling relationships using arrows between the
called and calling functions.

1. Inthe quote. cc file, right-click on the main function and choose Show Call Graph.

2. The Call Graph window opens and displays a tree view and a graphical view of all of the
functions called from the main function.
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Call Graph X =
main  x
8+ @00 :
= % @uend : basic_jos:: @ readNumberof
| @‘ o (@i fetchCustomersList O eof
o (@l outCustomersList
L= o @k getiine
J o (i eof in basic_ios ;
o Gufal inbasic ios E
o @y exit i @ exit I @ main
o (@ getDiscountFor :
o (@ readChar
o @y readNumberof
o @y AddModule in System
& (G GetSupportMetric in System System:: baS‘ ‘05 SVS%
O GetSupportMetric Add|
|®get|lne ‘@endl|
[l T ] D
| (& output 1188 | ins

If you do not see all of the functions shown in the screen shot, click Who is Called From the
Function button on the left side of the Call Graph window to show who is called from the
main function.

Expand the end1 node to display the functions called by that function. Notice that the graph
is updated to add the functions called by end1.

Select the end1 node and click the Bring Into Focus button on the left side of the window to
focus on the endl function, then click the Who Calls This Function button to view all of the
functions that call the end1 function.
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Call Graph % =
[endl = |
? @ end
& %@ main
o %4 operator <<

& %@ outCustomersList
o %@ readchar

L5 readumberor

o

®

‘ @ outCustnmersList‘ | @ main‘

[ cout << inimimieimieie Bl T

D cout << "Customer list (" << customers.size() << " % :

1187 INS

5. Expand some of the nodes in the tree to see more functions.
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call Graph x|

endl x

—_—

W

EEEER

¢ @ end

o %@ main

o R operator <<

o R4 operator <=

e "(‘P) outCustomersList
o %@ main

9 ﬁ@ readChar
o 5@ main

¢ 5@ readNumberof

o 8@ main

T e

@ readNumberof

1] cout =<

[ cout =<

<< customers sizell <

- << endl;

| £ operator <<|

‘ 4 operator <<

& output

Using Hyperlinks

118:7 | Ins

Hyperlink navigation lets you jump from the invocation of a class, method, variable, or constant
to its declaration, and from its declaration to its definition. Hyperlinks also let you jump from a
method that is overridden to the method that overrides it, and the reverse.

1.

56

In the cpu. cc file of the Quote 1 project, mouse over line 37 while pressing Ctrl. The
ComputeSupportMetric function is highlighted and an annotation displays information
about the function.

33
34

36
37
38

#include "cpu.h”

Cpu::Cpuiint type

*= MEDIT]|

"generic"

Method woid ComputeSupportMetric()
From class Cpu

Cirl+Alt+ Click Navigates To O il

ComputeSupportMetric () ;

T Module (" CPU,
}

/. int units w= L))

Click the hyperlink and the editor jumps to the definition of the function.
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34

35 Cpu::Cpuiint type , int architecture , int units 1
36 Module ("CFU", "gensric', type, architecture, units) {
37 T ComputeSupportMetric() ;

38 }

39

40

41

4z

43

44

45
@ ‘JDid Cpu: :ComputeSupportMetric() {
47 int metric = 100 * GetUnitsi);
438

3. Mouse over the definition while pressing Ctrl, and click the hyperlink. The editor jumps to
the declaration of the function in the cpu.h header file.

4. Click the left arrow in the editor tool bar and the editor jumps back to the definition in cpu.

CcC.

Hover the mouse cursor over the green circle @ in the left margin and see the annotation
that indicates that this method overrides another method.

37 L ComputeSupportMetric() ;

38 }

39

40 &

41

42

43

44 -

a5 |O\rerrides Module:: ComputeSupportMetric |

@ [ woid Cpu::ComputeSupportMetric() {
47 int metric = 100 * GetUnitsi);
48

49 switch (GetTypeID()) |

50 case MEDIUM:

6. Click the green circle to go to the overridden method and the editor jumps to the module.h
header file, which shows a gray circle in the margin to indicate the method is overridden.

7. Click the gray circle and the editor displays a list of methods that override this method.
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58

4]
@
71
72
73
74
75
76
77
8

protected:
virtual wvoid ComputeSupportMetric()
Iz Overridden

3}; Cpu:: ComputeSupportMetric

@:}; Disk:: ComputeSupportMetric

@Q; Memory:: ComputeSupportMetric

int type;

int cat “Y:

int units;

int supportMetric;

= o;

8. Click the Cpu: : ComputerSupportMetric item and the editor jumps back to the declaration
of the method in the cpu.h header file.

Using the Include Hierarchy

The Include Hierarchy window lets you inspect all header and source files that are directly
or indirectly included in a source file, or all source and header files that directly or indirectly
include a header file.

1. Inthe Quote 1 project, open the module.cc file in the Source Editor.

2. Right-click on the #include "module.h" line in the file and choose Navigate > View
Includes Hierarchy.

3. By default, the Hierarchy window displays a plain list of files that directly include the
header file. Click the Show Tree View button at the bottom of the window . Click the Show
Direct Includes Only button to display all files that include or are included. Expand the
nodes in the tree view to see all of the source files that include the header file.
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maodule h - Hierarchy X [=]

¢ &
s @ cpuh
% cpu.cc
% gquote oo
¢ 509 disk h
% disk.cc
% gquote oo
' @ memaory.h
% MEMary .cc
% gquote oo
% mocule.co
T @ system.h
% gquote oo
% system.cc

B8] %) ||

Using the Type Hierarchy

The Type Hierarchy window lets you inspect all subtypes or supertypes of a class.

In the Quote_ 1 project, open the module. h file.

2. Right-click on the declaration of the Module class and choose Navigate > View Type
Hierarchy.

3. The Hierarchy window displays all of the subtypes of the Module class.
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Madule - Hierarchy > [=]

¢ Q) Endule
o= Q) Cpu
o [ Disk

o= Q) Memory

el [%E
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Debugging Your Application

This chapter discusses how to create breakpoints for your project and how to use those
breakpoints to debug your code. This chapter contains the following sections:

m  “Creating Breakpoints” on page 61

= “Debugging a Project” on page 64

= “Debugging an Executable File” on page 68

m  “Debugging at the Machine-Instruction Level” on page 69

= “Debugging a Running Program by Attaching to It” on page 71
= “Debugging a Core File” on page 73

Creating Breakpoints

You can create and manipulate breakpoints in your code at any time. In order to run the
debugger, you must have breakpoints set in your code so the debugger knows where to pause
execution so you can examine the values of variables, step through lines of code, and fix errors.

Creating and Removing a Line Breakpoint

1. Inthe Quote 1 project, open the quote.cc file.
2. Set a line breakpoint by clicking in the left margin of the Editor window next to line 171

(response = readChar("Enter disk module type: (S for single disks, R for

RAID; Q - exit)", 'S');). The line is highlighted in red to indicate that the breakpoint is
set.
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: @ quote.ce = EHE@
Souce | Hstoy | [@E-8- QRSB F B EE 00 & =EE
166 )}
187 Cpu MyCpu(type, 0O, amount):; Create CPU module obhject
1&8
169 MvSystem. AddModule ( &MyCpu) ; Add CFU Module t© system specification
170 Breakpoint
(=] regsponse = readChar ("Enter disk module type: (5 for single disks, B for BAID; Q - exit)"
172
173 switch (response) {
174 case 'Q'
175 return I; Prematurs user requested termination

3. You could remove the breakpoint by clicking on the icon in the left margin.

4. Choose Window > Debugging > Breakpoints to open the Breakpoints window. Your line
breakpoint is listed in the window.

Breakpoints X

Marme | Context
O guote.cc:171 I

|

2

Creating a Function Breakpoint

1. Choose Debug > New Breakpoint (Ctrl+Shift+f8) to open the New Breakpoint dialog box.
2. In the Breakpoint Type drop-down list, set the type to Function.

3. Type the function name Customer: :GetDiscount in the Function text field. Click OK.
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gosoon e focion [

rSettings
Function: |Custumer::GetDiscuunt|
)] Unigue Function With this Mame
i All Member Functions With this Name
i) on Return
Fitters
Condition: | |
Count Lirnit: | | - | Current Court:
While In: | |
Threac!: Ii
~Actions
Action; |S‘tnp | - |
Script: |

OK Cancel

4. Your function breakpoint is set and is added to the list in the Breakpoints window.
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7] ¥) Oracle Developer Studio = (= 83
File Edit View MNavigate Source Refactor Run Debug Team Tools Window Help Q-
P = @ | |0 S oGRe N L [ER . .l 3 8
PE@RS| D v HMTHDI R SH DG OO0 B&:
& Projects X | Call Stack El . :q &) memory.cc xr_}lﬂsystem.cc xr@quote.cc = [ [E] customer.cc x | r|[*][O]
Mo] ¢ @ ouote 1 |_—“—| [ =9 o o
= o [[F Header Files Sourie History -8 Q584 2 &2 @ E| *
% o [{F Resource Files B T “m
= T Source Files 24 .
) cpu.ce 38 1nt Customer::GetDiscount() const {
—] = = return discount;
o % customer.cc 40 P
) T disk.cc a1 =
— &) memorv.cc 42 string Customer::GetMName() const {
5 ) module cc 43 return name; -
E & guote.cc [4] i [+
la= & system.cc &) » ¢ Customer:Customer % x
" o [i§ Important Files
g Variables Breakpoints X
% | Name | Context
% O cpu.ce:50 [10085] quote_1 =
T EH memory.cc:79 [10085] quote_1
§ B O system.cc53 [10085] quote 1
'an E quote.cc:127 [10085] quote_1
@ [ customer.cc:39 [10085] quote 1
P
H =
=] |@Test Results | Q, search Results || & Terminal || & output |0t3_1 (Debug) [ &= 37:1 L&

Grouping Breakpoints

You can group breakpoints using several different categories such as per file, per project, by
type, by language, etc.

Choose Window > Debugging > Breakpoints window.
Click the Select Breakpoint Groups icon.
3. Select the breakpoint group.

The breakpoints are arranged according to your selection.

Debugging a Project

When you start a debugging session, the IDE starts the debugger in the project's associated
tool collection (by default, the dbx debugger), then runs the application inside the debugger.
The IDE automatically opens debugger windows and prints debugger output to the Debugger

Console window.
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Starting a Debugging Session

1.

Start a debugging session for the Quote 1 project by right-clicking one of the project nodes
and selecting Debug. The debugger begins to run the application and the Debugger Console
windows open.

Cutput Debugger Console X [=]
Reading libe.so 1 Z
(edbx) ecd "/export/home/demol/Sample/Jucte_1"
(dbx) runargs
(dbx) intercept -set -—unhandled, -unexpected
(dbx) ### dbxenv run_pty /dev/pts/Ll0
(dlbx) ##§ dbxenv rte_error_log file name /dev/null
(cdbx) stop at "/fexport/home/demol/Sample/Quote_Ll/quote. co":171 N
(dbx) stop in Customer::GetDiscount
(dbx) run 1
Punning: ¢uote_1 T
(process id 47100
Peading libe_psr.so.l

-

Open the Variables window by choosing Window > Debugging > Variables (Alt+Shift-1).

Open the Sessions window by choosing Window > Debugging > Sessions (Alt+Shift-6).
The debugging session is shown in this window.

ﬂ %) Oracle Developer Studio

File Edit View Navigate Source Refactor Run Debug Team Tools Window Help

FEES 9 B ETE B &
P Projects X |Debugging | Call Stack El k (a & memory.cc xr_}l_i:]system.c( x[’Tﬂ__:‘]quote.c( x E;E.:']customer.cc x 1HE@

1 ¢ [E Quote_1 IT"—| =T 75 [=9 e

% °' Header Files Sourie Elston B-5- Q%54 #0% &% 0 B
§' . Resource Files 36 T m
= o[ Source Files &z : :

® ) cpu ce 38 int Customer::GetDiscount() const {

= = P = return discount;

E.“] customer.cc

- ) diok cc 40 ¥

& & disl a1 =
— b string Customer::GetName() cons

) memory.cc 42 tring Cust GetName (] t 1

E & module.cc 43 return name; ~
E} T quote.cc [4] I [+

= ] system.cc = » @ Customer:GetDiscount x
P o ﬁ' Important Files

g Variables Breakpoints Sessions X

% Name Process 1D Process State | Host

wn -

% quate_1 10085 Paused localhost -
o

o

i

in

=

(=)

il

n

£ -
& [ Test Results | Q Search Results | [@ Terminal | [E output jote_1 (Debug) | I a1:1 | NS
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Inspecting the State of the Application

1. The Quote 1 application prompts you for input in the Output window. Enter a customer
name after the Enter customer name: prompt.

2. 1Inthe customer.cc file, the green program counter arrow appears on top of the breakpoint
icon on the first line of the GetDiscount function.

[+] ¢) Oracle Developer Studio == 3
File Edit View MNavigate Source Refactor Run Debug Team Tools Window Help Q-
RS e - T @ b G- | 0@
=2 X |Deb... |Call... 5] @ Cpu.cc xr@ MEemory. cc x@ system.cc xr@ quote.cc x| E] customer cc
| ¢ [E ouote_1 = B ——
% - Header Files Source | History B-F QR FBE &85 <o
T
g o= Resource Files Eo ¥
= o Source Files 7 . .
® B 38 int Customer::GetDiscount() const {
o= ﬁ' Important Files :
=l = return discount;
— 40 K
=2 41
— 42 string Customer::GetMame() const {
w
B a3 return name;
i_] 44
= [«] 1
= =) > ¢ Customer:: Customer } X
g
5 Variables Breakpoints X | Sessions =]
% | Name | Context E&g
L=l B cpu.ce:50 [10085] quote_1 o
n
= B memory.cc:79 [10085] quote_1
0
'—J B system cc:53 [10085] quote_1
@ B quote.cc:127 [10085] quote_1
T| 2> customer.cc:39 [10085] quote 1
5 =
= | [ Test Results ” Q, search Results " B Terminal " & output |°t9,1 (Debug) | & S0 INS

3. Open the Call Stack window (Alt+Shift-3). The call stack shows three frames.
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& CallStack X =]
Mame

[ Customer:GetDiscount(this = 0x2cdad)

[]__unnamed_WCZhKvPURSE3T:: getDiscountFor{name = CLASS)

[Imain(arge =1, argv = Oxffbffafd)

[ b

| ﬁ' Projects " 5 Files " Il-ﬂﬂ] Services " @1 Classes |

4. Click the Variables window and note that one variable is displayed. Click the nodes to
expand the structure.

|V‘nriﬂ1lm ™ xi Braakpaints | Debugger Cansale | Sessians | Qutput |
&2 | Name ] Walue [_S
& 7 sathis Oxd4cI0B 2]

~ Ename 1¢haB *Ann"), 42048572050, struct _rwstd:s_null_string_ref_rap...|J

b @_ data_ a8 *Anr
tinpos 42945672951 L

ey struct rwstd::__null_sting_ret_rep<char std::char_trats<char> st...
lIref Il _string_ref_rep=char,std:ch h 8]

D discount 11

C

5. Click the Continue button. The GetDiscount function is executed, printing the customer
discount to the Output window. Then you are prompted for input.

6. Enter the input in response to the prompts. The program stops at the next breakpoint, the
line breakpoint you set earlier. Click the Variables window and note the long list of local
variables.
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|vanables ¥ x| Breakpoints | Debugger Console | Sessions | Cuitput
| | Mame | Walue 2]
& Ui
& | @ang Onffbled1a [®
i MyDisk

@ type
& MyCpu
¥ & customeriame
b & MySystem
@ response M R
& MyMermary [

& arge

Look at the Call Stack window and note that there is only one frame in the stack.

G
Click Continue “2/ and continue entering input in response to the prompts in the Output

window until the program is completed. When you enter the last input to the program, your
debug session ends. To end the debug session before the execution of the program was
complete, you could right-click the session in the Sessions window, and choose Finish.

Debugging an Executable File

68

You can debug an executable binary that is not in an IDE project. However, the executable
should be located with the source code that was used to build it so the debugger can find
debugging information. This is also called Projectless Debugging.

To debug an executable:

1. In the menu, choose Debug > Debug Executable.
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] ¢) Debug X
Host: |I0ca|host |v| | Manage ... |
Executable: |Ju|'ce5_-'WeIcome_l_-"dist-"Debug_."OracleSoIarisStudio-Solari5-x86_."welc0me_l|vl | Erowse... |
Arguments: |-: in| |

Working Directory: |E_-"\.-'b ox/demo/sources/Welcome_1/dist/Debug/OracleSolarisStudio-Solaris -x86|

Environment:

I Debug Il Cancel

2. In the Debug dialog box, select which development host you want to use from the Host
drop-down list.

3. Click the Browse button to find the executable path or type it directly into the Executable
text field. If you clicked Browse to find the executable path, the Working Directory text
field is auto generated.

4. Add any arguments to the Arguments text field.

5. If the Working Directory is not specified, either type the working directory path directly
into the Working Directory text field or by click Browse and selecting the directory in the
Working Directory Dialog box and then clicking Select.

. Specify any environment variables by typing the settings in the Environment pane.
7. Click Debug.

The program you selected is loaded into the IDE, but is in the Pause state. You can continue
debugging by clicking Continue.

For more information about Debugging an Executable, see the corresponding IDE help page.

Debugging at the Machine-Instruction Level

The debugger provides windows that let you debug your project at the machine-instruction
level.

1. Right-click the Quote_1 project and choose Debug.
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2. In the Output window, type a customer name in response to the prompt.

3. When the program pauses at the breakpoint on the GetDiscount function, choose Window
> Debugging > Disassembly to open the Disassembly window as in the Editor window. The
green program counter arrow appears on top of the breakpoint icon at the instruction on
which the program is paused.

( Start Page Xr E COMMon.c Xr @ guote.co Xr @ customer.cc |4 ﬁ‘_] Disassembly =

[][=][O]

Source Histary R R ﬁ % 5 DD ? {B DD E ':E @ = &
1 34 names | initMame) , [~
2 15 discount (initDiscount) {

] 36 1 -
4 0x00015308: Customer+0x0030: ret C

5 0x0001530c: Customer+0x0034: restore

3] 37 —

7 38 int Customer::GetDiscount() const {

8 39 return unt

g 0x00015320: GetDiscount : save %s3p, —-l04, %sp

10 0x00015324: GetDiscount+0x0004: =14 %i0, [%fp + €8]
=3 0x00015328: GetDiscount+O0x0008: 1d [fp + &8], %10

1z 0x0001532c: GetDiscount+0x000c: 1d [510 + 4], %10

L3 0x00015330: GetDiscount+0x0010: 14 510, [sfp - 4]

14 40 }

BIRE] 0x00015334: GetDiscount+0x0014: 1ld [5fp - 4], %10

18 0x00015338: GetDiscount+0x0018: or %10, %g0, %i0

17 0x0001533c: GetDiscount+0x001c: ret

18 0x00015340: GetDiscount+0x0020: restore

19 41 |

20 42 string Customer::GetWame() const { |

Goto:| |v| File: customer.cc

4. Choose Window > Debugging > Registers to open the Registers window, which displays
the contents of the registers.

Output Variahles Breakpoints Call Stack Registers X =]
Mame alue
gl-gl 0x00000000 0x00000000 O0x00000000 Ox0010554c -
gl-g3 0x00000000 0x00000000 0x00000000 Ox00000O0OO B
gd-gb 0x00000000 0x00000000 0x00000000 Ox00000O0OO =
gE-g7 0x00000000 0x00000000 0x00000000 OxffldZa0n
ol-ol 0x00000000 Ox£ffLE£882 0x00000000 Ox00000000
ol-o3 0x00000000 0x00000000 0x00000000 Ox00000OOL
od-ob 0x00000000 Ox££252714 0x00000000 Ox0004c778
oE-o7 0x00000000 Ox£f£fLE£720 0x00000000 Ox000LT7E5Lle
10-11 0x00000000 Ox£ffLE£8028 0x00000000 Oxffhffoog
1z-13 0x00000000 0x000Zc350 0x00000000 Ox00000O0OO
14-15 0x00000000 OxfflffSc0 0x00000000 Ox000000O00
1e-17 0x00000000 0x00000000 0x00000000 Ox00000O0OO |
in-il 0x00000000 0x0004c348 0x00000000 0x00000000 -

5. Choose Window > Debugging > Memory to open the Memory window, which displays the
contents of memory currently used by your project At the bottom of the window, you can

Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017



Debugging a Running Program by Attaching to It

specify a memory address to browse, change the length of the memory browse, or change

the format for memory information.

Output

ariahles

Breakpoints

Call Stack

Registers

Memory X

0x000173c0:
0x000173d0:
0x000173e0:
0x000173£0:
0x00017400:
0x00017410:
Ox000174Z20:
0x00017430:
0x00017440:
0x00017450:
0x00017460:

wain

waint0x0010:
waint0x0020:
waint0x0030:
maintOx0040:
maint0xz0050:
maint0x00&0:
waint0x0070:
waint0x0080:
waint0x0020:

waint0x00a0:

0x9de3hes000000000
0xa0l1422£000000000
0x400052L800000000
0x400052cc00000000
0x40005Z0800000000
Dxall0Z£££00000000
0x5014000000000000
0x400052L000000000
0x210000L000000000
0x9014000000000000
0x210000L000000000

0x£f027a04400000000
0x230000600000000
0x5214400000000000
0x5214000000000000
0x5214000000000000
Oxe0Z7LE££800000000
Oxal07k££400000000
0x5214400000000000
Oxall4Z22£000000000
0x5214400000000000
0xall4235000000000

0x£227a04800000000
OxaZl4EZ£500000000
0x2100005500000000
0x2100005500000000
Ox7E££££cZc00000000
0xa007L £7L00000000
0xaZ07L£7L00000000
0x7f£££ccE00000000
0x2300006=00000000
0x4000525a00000000
0xaZ07h££400000000

0x210000L000000000
0x9014000000000000
0xa0l4228800000000
0xa0l4228800000000
0xl00000000000000

0x400052kLZ00000000
0x5014000000000000
0x100000000000000

0xaZl4631200000000
0x100000000000000

0x9014000000000000

o

-

Address |main|

Debugging a Running Program by Attaching to It

If you want to debug a program that is already running, you can attach the debugger to the
appropriate process.

A

Choose File > New Project.

Select the Freeway Simulator project. Click Next and then click Finish.

In the New Project wizard, expand the Samples node and select the C/C++ category.

Freeway application starts. In the Freeway GUI window, choose Actions > Start.
5. Inthe IDE, choose Debug > Attach Debugger.

Chapter 7 « Debugging Your Application

|v | Length |SD Format |Hexacdecimal (8 bytes) | w

Right-click the Freeway 1 project you created and choose Run. The project builds and the
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(%] ¥ Attach (%]
Debugger: |Using Dbx Debugger |v| [
Host: |Iuca|hust |v” Hosts |
Filter: | |'H &8 Refresh |
Process to attach:

uip | PID | PPID STIME cMD

vbox 1868 173 19:15:21 fusrflibiradirad -m fusrflibjraditransport -m fusrflib/rad/protocal -m fusr/lib[a] |=

vbox 1754 1 19:15:03 Jusrfbin/dbus-launch —exit-with-session --sh-syntax ]

vbox 1779 1 19:15:03 Jusrflibjgconfd-2

wbox 1794 1725 19:15:07 Jusr/bin/nautilus

vbox 1789 1 19:15:06 Jusrflibjgvfsd

vbox 1755 1 19:15:03 Jusrflib/dbus-daemon -fork --print-pid & --print-address & --session

wvbox 2119 1998 19:17:06 Jvarjtmp/dlight_vbox/6f9b0c56/01203964994/pty --no-pty --env LANG=C /...

vbox 1796 1 19:15:08 fusrflib/bonobo-activation-server —-ac-activate —-ior-outputfd=21 =

vbox 1787 1 19:15:06 fusrflib/gnome-settings-daemon

vbox 1153 1176 13:14:22 Jusr/bin/Xorg ;0 -nolisten tcp -br -novtswitch -auth /tmp/gdm-auth-cookie...

wvbox 1725 1541 19:15:02 Jusr/bin/gnome-session |

wbox 1791 1725 19:15:07 fusribin/gnome-panel

vbox 1730 1725 19:15:06 Jusrfbin/metacity

vbox 17939 1725 19:15:08 Jusrfbin/xscreensaver -nosplash

vbox 1882 1851 19:15:31 jusrflib/gnome-pty-helper |

vbox 1793 1 19:15:07 fusrflib/gvfs-hal-valume-monitor

vbox 1881 1 19:15:30 fusr/bin/gnome-terminal

vbox 1886 1885 13:15:42 Jusrfbin/bash /.. jplatform/lib/nbexec —-jdkhome --clusters fhomefvbox/s... |

wbox 1884 1881 19:15:31 Jusr/bin/bash =4
| oK || Cancel || Help

6. 1Inthe Attach dialog box, type Freeway in the Filter field to filter the list of processes.

7. Select the Freeway process from the filtered list.

8. Click OK.

9. A debugging session is started and execution of the Freeway process pauses at the point
where the debugger attached to it.

10. @
Click Continue to continue execution of Freeway, which is now running under control
of the debugger. If you click Pause O, execution of Freeway pauses, and you can examine
variables, the call stack, and such.

11.

Click Continue again and then click Finish Debugger Session . The debugger session
ends, but the Freeway process continues executing. Choose File > Exit in the Freeway GUI
to exit the application.
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Debugging a Core File

If your program is crashing, you might want to debug the core file (the memory image of your
program when it crashed). To load a core file into the debugger:
1. Choose Debug > Debug core file.

2. Type the full path to a core file in the Core File field or click Browse and navigate to your
core file in the Select Core File dialog box.

| ¢) Debug Core File &3

Select a core file and an executable to use with it.
Host: ||0ca|host |v|| T |
Debug Engine: |dbx |v|
Core File: |,fh0me,'\.fbox.f‘toolsfcore |V || Browse... |
Executable: |-:fr0m core= |V || Browse... |
Project: |-:n0 project= |v|

| Debug ” Cancel |

3. If the debugger cannot associate the core file you specified with an executable, it displays
an error message. If this situation occurs, type the path name of the executable in the
Executable text box, or click the Browse button and use the Executable dialog box to select
the executable.

4. By default, the Project text field displays either <no project> or the name of an existing
project that exactly matches the name of the executable. If you want a new project created
for the executable, select <create new project>.

5. Click Debug.

For a more in-depth tutorial on debugging, see the Oracle Developer Studio 12.6: dbxtool
Tutorial.
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Monitoring a Project

The IDE provides tools for examining the behavior of your running C/C++/Fortran project, in
order for you to detect runtime problems in your applications. These types of problems might
not be detectable when debugging your code. The profiling tools are the following:

m  CPU Usage

m  Thread Usage

= Memory Usage

m  Memory Access Errors

This chapter describes what these tools are and how to use them and contains the following
sections:

= “Profiling a Project with the Run Monitor Profiling Tools” on page 75
= “Running Memory Access Checking on Your Project” on page 93

Profiling a Project with the Run Monitor Profiling Tools

The Run Monitor profiling information is collected using Oracle Developer Studio performance
analysis tools and the underlying operating system. The Run Monitor tools graphically show
information and have buttons that you can click for more information about problem areas

in your code. This section will set up a profiling demo project, enable the Profile tools in the
project's properties, and examine the Run Monitor profiling tools results.

Setting Up the Profiling Project

This tutorial will use the ProfilingDemo sample project. To create this demo:

1. Choose File > New Project (Ctrl+Shift+N).
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2. Inthe New Project wizard, expand the Samples node and select the C/C++ category.

3. Select the Profiling Demo project. Click Next and then click Finish.

To configure the project and enable profiling:

Right-click the ProfilingDemo_1 project node in the Projects tab, and select Properties.

2. Select the Build node in the Categories panel, and make sure the Tool Collection is set to

Oracle Developer Studio.

3. Select the Run node in the Categories panel, and make sure the Console Type is set to
Internal Terminal. This enables you to see the program output in the IDE's Output window
instead of an external terminal window.

ﬁ i) Project Properties - ProfilingDemo_1 B
Categories:
@ General Caonfiguration:|Default (active) |V| | Manage Configurations... |
¢ @ Build
@ C Compiler o (SEEE
@ C++ Compiler Run Command "${OUTPUT_PATH}" - D
@ Fortran Compiler R BITEER) | D
& Assembler Environment I:l
o Linker Build First
o Packaging Console Type Internal Terminal -
> Run External Terminal Type Default
& Profile Femowve Instrumentation Ask -
@ Debug
2 Related Projects
@  Formatting
Run Directory
The directory which the binary should be executed from
| QK || Cancel || Apply || Help

4. Select the Profile node in the Categories panel. Notice that the Show profiling indicators
during run option is checked. You can check this option in any of your projects to show the

Run Monitor Tools tab.
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ﬁ ¢) Project Properties - ProfilingDemo_1 m
Categories:
@ General Configuration:|Default (active) |V| | Manage Configurations...
¢ @ Build
@ C Compiler o EEETE
© Ct+ Compiler Run Command "${OUTPUT_PATH}" ~ [.]
@ Fortran Compiler Run Directory D
& Assembler Environment D
o Linker Build First
© Packaging Console Type Internal Terminal -
o Run External Terminal Type Default
o Profile Remaowe Instrumentation Ask -
2 Debug
@ Related Projects
2 Formatting
Console Type
Controls where a program is run
| QK || Cancel || Apply || Help

Select C/C++ Oracle Developer Studio Standard in Profile Configuration. Click the ...
button next to the Profile Configuration list.

Notice the tools selected for the C/C++ Oracle Developer Studio Standard are Thread
Usage, Memory Usage, and CPU Usage.
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i) Project Properties - ProfilingDemo_1 B
Categories:
@ General Configuration:|Default (active) |v| | Manage Configurations... |
¢ @ Build
@ C Compiler o (FEmEEl
@ C4+ Compiler Show profiling indicators during ru
@ Fortran Compiler Prafile Configuration C/C++ Oracle Developer Studi... w D
@ Assembler
@ Linker
@ Packaging
@ Run
o
@ Debug
@ Related Projects
@ Formatting
Default
0K || Cancel || Apphy || Help

Note - If you select CC++ Simple (indicators only) or C/C++ Simple Oracle Solaris
(indicators only), then only the indicators in the Run Monitor window will display. Clicking
the details buttons in each indicator window will give the following message: Detailed
information is not available in the current profile configuration. To see details, select a
different Profile Configuration in your project properties and run the project again.

7. Click OK in the Project Properties dialog box.

Building and Running the ProfilingDemo_1 Project

To build and run ProfilingDemo_1:

1. Right click the ProfilingDemo_1 project node and select Build.
The Output window shows the results of the build.
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Qutput X| [=]
g =nts_1 (Clean, Build) = rQuote_l (Build] = rOuote_l (Debug) = rProfiIingDemo_l (Build, Run] x 4| »
mkdir -p build/Default/GMU-Solaris-xB86 [
D> rm -f "build/Default/GNU-Solaris-x86/sequential . o.d" o,
gcc -Cc -g -MMD -MP -MF "build/Default/GNU-Solaris-x86/sequential.o.d" -o build/De
. 4 mkdir -p build/Default/GNU-Solaris-x86
rm -f "build/Default/GNU-Solaris-x86/spinlock. o.d"
|E gcc -Cc -g -MMD -MP -MF "build/Default/GNU-Solaris-x86/spinlock.o.d" -o build/Defa
. mkdir -p dist/Default/GNU-Solaris-x86
B gcc -o dist/Default/GNU-Solaris-x86/profilingdemo_1 build/Default/GNU-Solaris-x8

gmakel[2]: Leaving directory ~/home/vbox/DevStudioProjects/ProfilingDemo_1° —
gmake[1]: Leaving directory ~/home/vbox/DevStudioProjects/ProfilingDemo_1°

BUILD SUCCESSFUL (total time: 1s)

[«]

[4] li | [v]

2. Right-click the ProfilingDemo_1 project node and select Run. The Run Monitor window
opens to display indicators with dynamic graphs for CPU Usage, Memory Usage, and
Thread Usage.
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Run Monitor - profiingdemo_1 X

CPU Usage Haot Spots...
N [ system
75 [ W user

50 -
25
B 1 1 1 1 1 1 1 1 1 1 1 1 1 1 I 1 1
2:45 2:50 2:585 3:00
Memory Usage Memory Leaks. ..
141K B Heap
105 K
TOK
35K
L e——0 Max: 128K
2:50 2:55 3:00
Thread Usage Sync Problems...
G [ Threads
M Lock waits
W T I
PP PP T
PP PP T
2:45 2:50 2:55 3:00

Notice in the Output window, the ProfilingDemo_1 program tells you what it is doing,
so you can match it to the data that the IDE is graphically representing in the tools. For
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example, the program displays how much memory it is allocating, performs calculations,
and then frees memory. You can see the graph reflect this activity.
3. Press Enter each time you are requested until the program is finished.

Hover your mouse cursor over the indicators to see tooltips explaining what each graph
represents. Each indicator includes a button for more detailed information, which will be
explored in later sections.

Using the Indicator Controls

At the bottom of the Run Monitor window, there are sliders for controlling your view of the
graphs: View slider, Details slider, and Time slider. The controls are also used for filtering data.
The following image labels the controls.

8:36
[ b

Details Slider View Slider f

Time Slider

Place your mouse cursor over the end points of the sliders for information about the sliders.

2. Click and hold the mouse button on the Time slider, the horizontal scroll bar at the bottom.
All the graphs slide in unison so you can see CPU, memory, and threads at any given time
and to see the relationships between them.
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Run Monitor - profiingdemo_1 X [=]
CPU Usage Haot Spots...
“::E : O system
7O [ W user

53 -
28
(S S | U Lo R 8 S S A S I S S L
aa 5:00
Memory Usage Memory Leaks...
ity i M Heap
am
27M [
1.3M [~
= Mazx: 4.9M
Ny s ..V e i s i W S
aa 5:00
Thread Usage Sync Problems...
36

[ Threads

27 M Lock waits

18

Drag the time slider from left to right to see the complete run.
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Move your mouse to the view slider, the controls that overlay the time units. The view
slider controls the part of the run time displayed in the indicator.

Click and drag the handles of the start point of the view slider to the beginning of the run.
The indicators show the entire run. The effect is similar to zooming out. Notice that the
time scroll bar is maximized when you select the complete run time, since you are already
looking at all the data.

Drag the view slider's start point to where the PTHREAD_MUTEX_DEMO starts. As you
drag the handle, the indicators zoom in to focus on this area. Notice that the scroll bar can
again be used to scroll the run time.

Place your mouse cursor over the end points of the orange-colored details slider for a
description of how to use the slider. The details slider controls enable you to select a portion
of the runtime for examining the detailed information.
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Run Monitor - profiingdemao_1 X [=]
CPU Usage Haot Spots...
106 [~
= O System
7O W user
53
iz
28
g:00 8:10 8:20 8:30
Memory Usage Memory Leaks. ..
53M |-
L M Heap
Al -
27M |-
1.3M |-
= Mazx: 4.9M
1 L 1 ! T T
g:00 8:10 8:20 8:30
Thread Usage Sync Problems...
[ Threads
W Lock waits
g:00 8:10 8:20 8:30

Drag the details slider's start point handle past the view slider's start point. Notice that
the indicators grey out the area in from the of the detail slider's start point. This gives
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a highlighting effect to the graph between the start and end points. When you click an
indicator's detail button, the details tab shows the data for the area highlighted.

7. Drag the start point of the details slider back to the beginning so you can see all the data.

Note - You can slide either the starting handle or ending point handle for the view slider and the
details slider, so you can view and get details at any time of your run.

Exploring CPU Usage

The CPU Usage graph shows the percentage of the total CPU time used by your application
during its run.

1.

Click the CPU Usage Hot Spots... button to display details about the CPU Time.

The CPU Time Per Function window opens to display the functions of the program, along
with the CPU time used by each function. The functions are listed in order of CPU time
used, with the function that used the most time listed first. If the program is still running,
the time initially displayed is the time consumed at the moment you clicked the graph.

Output CPU Time Per Function X =]
Time Filter  Start: |D:DD Iil Endl: |max Iil Filter: |

@E\l Function Mame | CPU Time (Exclusive) | CPU Time (Inclusive) E

work_run_usrcpu £13.079 613490~

22986 22986|=

memcpy 0771 Al
gettimeofday 02 02
time_before 015 015
007 23076

0.08 008

nnes naml T

Click the Function Name column head to sort the functions alphabetically.

Notice the difference between the two columns of CPU Time. CPU Time (Inclusive) shows
the total CPU time spent form the time the function is entered until the time it is exited,
including the time of all other functions that are called by the listed function. CPU Time
(Exclusive) shows the time used only by the specific function, not including any functions
that it calls.

Click the CPU Time (Inclusive) column head to place the most time-consuming functions
back at the top.
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Notice that in our example, the work run_usrcpu() function has 613.079 CPU Time
(Exclusive) versus a 613.499 CPU Time (Inclusive). This means that a small amount of the
CPU time was actually used by other functions that it calls, but the work run_usrcpu()
function itself used most of the time.

Some of the functions are listed in bold. You can go to the source file that calls these
functions. Double-click the work_run_usrcpu() function.

ﬁ §) Oracle Developer Studio a @a
File Edit View Navigate Source Refactor Run Debug Team Tools Window Help Q-

PEES DE M FTH B & %
PEES D6 e HTH PR S | BESS
& | Run Monitor - profilingdemo_1 X B [/ common.c x 4] [=l[O]
s i = - [ == =} EE @

2 - Source | History - & GRS L% S @ H =]
o 7 -
= = 52 ]
@ 100

Syst . . . .

= s F Eu-s:m 54| B static void work_run_i k_id, leng micres)

50 55 TRACE("work %d: sl - %]d microseconds wi

o 25 - 56 usleep(micros); =
- o o= oo gre) 57 TRACE("work %d: , work_1d); =

o 58 - 1
= =]

i 60| B 43.1 | 60.0 static void werk_run_usrcpu{int work_id, long micros

Memory Usage Memory Leaks oac —elod. Starting mathematical caleculatio

E ry L] v g; U T el 4507 E)tcn ting mathematical calculatior
w|| 205k F CPU Time (Inclusive):60.012| 9%
= 154K [~ [ |™He= 63 double p1 = O;

5 103K - ri I “i 64 struct timeval curtime, endtime;

L £ 65 ettimeofday (&endtime, 0);

= - | Max: 187K ge yise g H

= I M 66 time_add{&endtime, micros);

= 00 030 1:00 1:30 —

@ 67 E—E for (531 1 |
i an B s £ i |
= 1 [} 3

g 0.0 | 0.0 Lv)

@ Thread Usage Sync Problems... Qutput CPU Time Per Function X =

[wl 2F I Threads _ _ i
E Eln B Lock maits Time Filter  Start: [0:00 | End: [max |  Filter:

3 I

= 1 Function Name | CPU Time (Exclusive) | CPU Time (Inclusive)

00 0:30 1:00 1:30 work _run_usrcpu at 43.07 60.012| =
£ o 15.713 15.713
= ogo 0:30 100 130
g 1:52 16.972 16.972
= [« [v] _ 0.05 0.05|>
| Test Results | Q, search Resuits | [§ Terminal| @) 60:1 [Ins

The common. c file opens, with the cursor resting on the work run_usrcpu() function, line
60. Some numbers are displayed in the left margin for this line.

Place your cursor over the numbers in the left margin. The numbers are the same metrics for
exclusive and inclusive CPU time for the functions displayed in the CPU Time Per Function
window. The metrics are rounded to the nearest tenth, but the unrounded value pops up
when you hover the mouse over them. Metrics for CPU-consuming lines such as the for ()
loop that does calculations within the work run usrcpu() function are also shown in the
common . ¢ source file.

In the CPU Time Per Function window, change the Time Filter start time to 0:40 by either
typing the time and pressing Enter, or using the arrows to scroll through the seconds. The
graphic indicators change just as they did when you moved the handles on the data filtering
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control. If you drag the handles, the Time Filter settings in the CPU Time Per Function
window are updated to match. More importantly, the data shown for the functions in the
table is updated to reflect the filter so only the CPU time used during that time period is

shown.
(+] ¥ Oracle Developer Studio = =8
File Edit View Navigate Source Refactor Run Debug Team Tools Window Help Q-
PEES D@ | e TR B & | BMESY
P Run Monitor - profilingdemo_1 X El (7 commen.c x <[]
5 E Hist: @ &~ 8- (= B SEwE @
8| cruusace ource | Histery | BR-F- ARSRL £ @ o @[ s
= 100 F 0 Systern 60/ B 43.1 | 60.0 btatic void work_run_usrcpu(int work_id, long micros)—|
= 5 .U" 61 TRACE("work % rting mathematical calculatior
@ 50 = 62 long1 =0, ] =
o 25 63 double p1 = 0; L
- on o ol A 64 struct timeval curtime, endtime; ==
o 65 gettimeofday(&endtime, 0);
A 66 time_add(&endtime, micros);
i 67| B for (550 1
[[4| Memory Usage M 68 gettimeofday(&curtime, 0);
Mol 205 F an 69 B 0.0 0.0 1f (Itime_before(&curtime, &endtime)) {
g e r r\n - iy ereak;
@ lzii: |1 ! 1] Max 187K ;; 1.2 1.2 \}‘or (] =1+ 1000; 1 = 3; ++1) {
& I e R e 72 | 10.9] 10.9 pi+= 1.0/ (1 * 4.0+ 1.0);
= T L.00 1:30 -
9 74 21,9 | 21.9 pi -= 1.0 / (i * 4.0 + 3.0); —
H - hd
] [4] Il I [»]
= v wu
S| vhread usage outout | S50 Time par Function =
= =B
w M Threads
& 3 B Lock waits Time Filter Start: [0:40 E End: [max & Filter:
o 20
S
£ 1n Function Name | CPU Time (Exclusive) | CPU Time (Inclusive)
0o 30 L00 1:30 work run_usrcpu at .. 43.07 60.012(+
“-‘m" I [ [ [ [ I | 17.162 17.102
= oldo 0:30 100 130
E A @ T 16.962 16.962:‘
= [4] [»] 0.05 0.05/~
& [ Test Results | @, Search Results || @ Terminal | @] 60:1 IS

You can also filter for data that meet a certain metric. Right-click on the CPU Time

(Exclusive) metrics for work run_usrcpu(). In our example, right-click the 43.07 in the
CPU Time Per Function window. Select Show only where > CPU Time (Exclusive) ==
43.07. All the rows are filtered away, and only the row whose exclusive CPU time is equal

to 43.07 is displayed.

Exploring Memory Usage

The Memory Usage indicator shows how your project's memory heap changes over its runtime.
You can use it to identify memory leaks, which are points in your program where memory

that is no longer needed fails to be released. Memory leaks can lead to increased memory
consumption in your program. If a program with a memory leak runs long enough, it can

eventually run out of usable memory.
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1.

Slide the time slider in the Run Monitor to the left and right to see how the memory

heap increases and decreases over time. There should be four spikes that occur in
ProfilingDemo_1. The first two occur during the Sequential Demo, the third occurs during
the Parallel Demo, and the last occurs during the Pthread Mutex Demo.

Click the Memory Leaks button to display the Memory Leak Details window. This shows
details about which functions exhibit memory leaks. Only functions that are producing
memory leaks are listed in the table. If your program is running when you click the button,
the leak locations shown are those that exist at the moment you clicked the button. More
leaks may occur as time goes on, so you should click the Refresh button. If no memory
leaks are detected by the end of the run, the Memory Leak Details tab indicates that no
memory leaks were found.

You can change the Start and End times to filter the data, or use the orange colored details
slider in the Run Monitor window, same as in the Exploring CPU Usage section. There are
no memory leaks in this example.

;1 Memory Leak Details  x 4| p|>][O
Time Filter  Start: |D:DD| IZIA Enck: |max IZIA Filter: | |v|@
&)

Mo problems detected ..

Double-click a function and the corresponding file opens at the line where the memory
leak occurs in the function. The memory leak metrics are displayed in the left margin in the
source editor.

Mouse over them to display the details as we did with the CPU Usage metrics.

Right-click the metrics in the table to filter the data in the table. This data filtering in the
table is possible with all the profiling tools.
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Exploring Thread Usage

The Thread Usage indicator shows the number of threads in use by your program, and any
moments where a thread has to wait to get a lock in order to proceed with its task. This data is
useful for multithreaded applications, which must perform thread synchronization in order to
avoid expensive wait times.

1. The Thread Usage indicator shows the number of threads running during a project's run
time. Slide the time slider back to the beginning and notice the number of threads is 1 until
the Parallel Demo starts. In the following image, this is at 8:07, with a jump of 1 to 32
threads.
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Run Monitor - profiingdemo_1 X [=]
CPU Usage Haot Spots...
1'?'5 : O System
7O [ W user

53 -
28
(S S | U Lo R 8 S S A S I S S L
aa 5:00
Memory Usage Memory Leaks...
ity i M Heap
am
27M [
1.3M [~
= Mazx: 4.9M
Ny s ..V e i s i W S
aa 5:00
Thread Usage Sync Problems...
36

[ Threads

27 M Lock waits

18

8:36

3

2. Move the view slider endpoint handle to where the Parallel Demo just starts.
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Run Monitor - profiingdemao_1 X [=]
CPU Usage Haot Spots...
106 [~
= O System
7O W user
53
iz
28
g:00 8:10 8:20 8:30
Memory Usage Memory Leaks. ..
53M |-
L M Heap
Al -
27M |-
1.3M |-
= Mazx: 4.9M
1 L 1 ! T T
g:00 8:10 8:20 8:30
Thread Usage Sync Problems...
[ Threads
W Lock waits
g:00 8:10 8:20 8:30

Notice that in the CPU Usage and Memory Usage indicators for the same time period
has the single thread performing some activity that uses CPU time and memory. This
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corresponds to the Sequential Demo portion, in which the main thread writes to a file and
then performs some calculations sequentially. CPU and memory usage both decrease when
the program waits for the user to press Enter and the number of threads remains at 1.

Slide the time slider to the right until you see the two points where the threads increase in
number.

The increase in threads at 8:07 corresponds to the Parallel Demo portion of the project
running. The main threads starts additional threads to the work of writing to a file and
performing calculations in parallel. Notice the increase in memory usage and CPU usage,
but the two tasks are completed in much less time.

The number of threads returns to 1 after the Parallel Demo threads finish, and the main
thread waits for you to press Enter. The thread count increases again as the Pthread Mutex
Demo portion of the program runs.

Notice that a lock waits appears, shown in orange, during the Pthread Mutex Demo portion.
The Pthread Mutex Demo uses mutual exclusion locks to prevent overlapping access to
certain functions by multiple threads, which causes the threads to wait to obtain a lock.

Click the Sync Problems button to display details about thread locks in your project. The
Thread Synchronization Details window opens and lists functions that had to wait to obtain
a mutex lock. Also displayed are metrics for the number of milliseconds that the function
spent waiting and the number of times the function had to wait for a lock. This example had
no sync problems.

Thread Synchronization Details  x 4 r[x][o
Time Fiter  Start [+40 [ Ena fmax E  Fiter:

€

Mo problems detected ...

If you click the Sync Problems button while the program is running, you might need to
click the refresh button & to update the display with the latest thread lock information.
Click the Wait Time column to sort the functions in order of time spent waiting.

Click the Lock Waits column to sort the functions by the number of times a thread was
waiting in the functions.

Double-click a function to open the source file in the editor where the function responsible
for locking a memory location. The metrics for Wait Time and Lock Waits are displayed in

Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017



Running Memory Access Checking on Your Project

the left column f the source file. Place your mouse over the metrics to see the details, which
matches what is shown in the Thread Synchronization Details window.

Right-click on the metrics and deselect Show Profiler Metrics. The metrics are no longer
displayed in the source editor for any of the profiling tools. To display the metrics again,
choose View in the IDE menu bar and select Show Profiler Metrics.

Running Memory Access Checking on Your Project

You can use the Memory Analysis Tool to find memory access errors in your project. The tool
allows you to find these errors easily by pointing out exactly where each error occurs in your
source code.

The Memory Analysis tool catches and reports memory access errors dynamically during
program execution, so if a portion of your code is not executed at run time, errors in that portion
are not reported.

1.

If you have not already done so, download the sample applications zip file from the

Oracle Developer Studio 12.6 Sample Applications web page at http://www.oracle.com/
technetwork/server-storage/solarisstudio/downloads/solaris-studio-12-4-samples-2333090.
html, and unzip the file in a location of your choice. The memorychecks application is
located in the CodeAnalyzer subdirectory of the OracleDeveloperStudiol2.5-Samples
directory.

Create a project from existing sources using the memorychecks application.

Right-click the project and choose Properties. In the Project Properties dialog box, select
the Run node, and type Customer.db after the output path in the Run Command. Click OK.
Run the project.

Build the project with instrumentation for memory analysis.

Click the down arrow next to the Profile Project button ijD and select Profile Project
to find Memory Access Errors from the drop-down list.

b. In the Select Analysis Type dialog box, select All Memory Access Errors from the
drop-down list.
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Running Memory Access Checking on Your Project

ﬁ t) Select Analysis Type m

Collect Data For:  |All Memory Access Errars |v

Leak Detection and API Check
All Memory Access Errors

Manitor Main Project

b

Memaory Access Errors

Data Races and/or Deadlocks

Overhead:

| Cancel || Start

The Overhead field displays High or Moderate to indicate the load that will be placed
on the system. The performance of other programs running on your system might be
affected when the overhead is high, which is the case when you are detecting both data
races and deadlocks.

c. Click Start.

6. The Run Memory Profile dialog box opens to let you know that your binary will be
instrumented. Click OK.

7. The project is built and instrumented. The application starts running and the Memory
Analysis window opens. When your project run is complete, the Memory Analysis window
lists the memory access error types found in your project. The number of errors of each type
is shown in parentheses after the error type.

Memory Analysis - memorychecks
:&nal':.-'sis complete, see results below
7 &8 Bug type
Memory Leak (7
ABW (Beyond Array Bounds Write) (27
ABR (Beyond Array Bounds Read) (1)
UME (Uninttialized Memory Read) (1)

8. When you click on an error type, the errors of that type are displayed in the Memory
Analysis Tool window.
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Memory Analysis Tool X =
? @mem{es{.c | ¢ D Call Stack
| @ MemoryLeak at line 40 cpi = (char *Jmalloc(ARRAY_SIZE); E ' main ot menest 40

: l@ _start in memtest+0x10a30

(7] Memoryleak atline 48 cpl = (char “)malloc{ ARRAY_SIZE);
& ("] Memoryleak atline 63 cpl = (char “imalloc{ARRAY _SIZE),
[*] Memoryleak atline 67 cpl = (char “)malloc{ ARRAY _SIZE),
7 Ebld_cust_list.c
("] Memoryleak atline 34 new_cust_ptr = (cust_rec *) maloc (sizeof (cust_rec)),
(7] MemoryLeak at line 51 new_order_ptr = (order_rec *) malloc (sizeof (order_rec));
? [@libe.so
("] MemorylLeak atline -1

| @ Output " @ Usages " E.g endl - Call Graph ‘

By default, the errors are grouped by the source file in which they were found. When you
click on an error, the call stack for that error is displayed. Double-click a function call in the
stack to display the associated lines in the source file.
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* e CHAPTER 9

Remote Development Setup

This chapter describes how to setup your remote development environment and how to use the
remote development toolbar. It also provides a brief description of remote desktop distribution.

Remote Development Setup

You can build, run, and debug projects on the local host (the system from which you started the
IDE) or on a remote host running a UNIX® operating system. Remote development lets you
run the IDE locally in your familiar desktop environment, while using the computing power and
development tools on a remote server to build your projects.

You can configure remote development hosts in the Build Tools tab of the Options dialog box.
To add a remote host:

Choose Tools > Options, and click the C/C++ category.
In the Build Tools tab of the Options dialog box, click Edit.
In the Build Hosts Manager dialog box, click Add.

On the Select Host page in the New Remote Build Host wizard, type the system name of the
host in the Hostname field or double-click an available host in the Network neighborhood
list to select it and clicklick Next.

A=
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ﬂ ¢) New Remote Host Setup m
Steps Select Host
1. Select Host Hostname: [my-remote-pc| | Port: [22 |
2. Setup Host
3. Summary Network neighborhood:
Server name | S5H

Refreshing hosts list ...

o= Proxy Settings

| < Back || Mext = || FEinish || Cancel || Help

5. On the Setup Host page, type your ID into the Login field.

6. Click Connection Settings. An expandable drop-down list appears, where you can set your
list of connections in order of preference or establish a connection timeout.
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@ New Remote Host Setup

Steps Setup Host

1. Select Host Identification
2. Setup Host
3. Summary

Login: |demol

Authentication
@ Password

) 55H Key File

¢ |Connection Settings

Preferred Authentications:

GSS-API

[[] Public key
Keyboard-interactive
Password

Timeout: IOE

i 1

Remote Files Cache Settings

Default Location =

[] clear on exit

Automatically find compilers and tools

[] Check ACL-based remote file permissions

| = Back || Mext = || Finish || Cancel || Help

7. Once you elect your settings, click the Password node and click Next.

The wizard prompts you for a password, connects to the host, and displays a Summary
page. Click Finish.

9. After the host is added to the Build Hosts list in the Build Hosts Manager dialog box, click
OK.

10. You can set properties that specify how the IDE uses the remote host in the Services
window. Expand the C/C++ Build Hosts node, right-click the remote host, and choose
Properties. Set the desired properties in the Host Properties dialog box.

11. To set the remote host as the default build host, right-click the host in the C/C++ Build
Hosts node in the Services window, and choose Set as Default.

To develop a project on a remote host, the project must be on a shared filesystem that is visible
on both the local host and the remote host. Typically such a filesystem is shared using NFS
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or Samba. You can define the mapping between local and remote paths to project source files
when you define the remote host.

When you create a project, the default build host is selected as the build host for the project.
You can change the build host for the project on the Build panel of the Project Properties dialog
box. You can also specify the build host when you are debugging an executable or a core file.

To work on a project that resides on a remote host on your local host, choose File > Open
Remote C/C++ Project.

Using the Remote Development Toolbar

The IDE provides a Remote Development Toolbar, for easier access to projects and files on
the remote host. You can use the icons to select a remote host you have already configured and
work on projects and files on the remote host the same as if they were local. This is known as
full remote development.

To learn more about remote development modes, see the C/C++ Remote Development Modes
help page in the IDE.

You can do the following with the remote toolbar:

m  Click the Connect Status icon to connect or disconnect to the server selected in the list next
to the icon.

m  Click the Create Remote Project icon to create a new project on the currently connected
host.

m  Click the Open Remote Project icon to open a project on the currently connected host.
m  Click the Open Remote File icon to open a file on the currently connected host.

Using the Terminal Window for a Build Host

You can open a terminal window in the IDE for a local or remote host. The terminal window
opens as a tab in the Output area of the IDE. A remote host does not need to be set up in
advance for the IDE, but must be running the SSH daemon.

To learn about how to open a terminal window in the IDE, see Opening a Terminal Window for
a Build Host in the IDE help. To open a terminal window for a local host, choose Window >
IDE Tools > Terminal.

You can also personalize the display options of the command line terminal window. For more
information, see Options Window: Miscellaneous: Terminal in the IDE help.
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Remote Desktop Distribution

The Remote Desktop Distribution feature lets you generate a zip file containing a distribution of
the IDE and the Code Analyzer that will run on almost any operating system and use the Oracle
Developer Studio compilers and tools on a remote server. When you run the IDE on a desktop
system, it will recognize the server on which you generated the distribution as a remote host and
access the tool collection in your Oracle Developer Studio installation.

For more information about Remote Desktop Distribution, see How to Develop Code from
a Remote Desktop with Oracle Developer Studio (http://www.oracle.com/technetwork/
articles/servers-storage-dev/howto-use-ide-desktop-1639741.html).
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Packaging an Application

This chapter describes how to package an application after you've finished creating, compiling,
and debugging your application.

Packaging an Application

You can package a completed application as a tar file, zip file, Oracle Solaris SVR4 package,
RPM, or Debian package.

1. Right-click the Arguments 1 project and choose Properties.

2. In the Project Properties dialog box, select the Packaging node.

3. Select the Oracle Solaris SVR4 package type from the drop-down list.
4

Change the output path if you want to use a different destination directory or filename for
the package.

5. Click the Packaging Files browse button. In the Packaging Files dialog box (for an SVR4
package), modify the package parameters on the Info tab as needed.
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#) Debug - Packaging Files

Additional info:

lflnfo | Files |

Parameters:

Mame |\-"a|ue |

PEG argumentsl -~ |

MAME Package description ...

ARCH 386

CATEGORY application

WERSION 1.0

EASEDIR fopt

PSTAMP 20160602191605

=] Down

Abbreviation for the package being installed. All characters in the abbreviation must be a
alphanumeric. You can also use the - and + characters in the abbreviation. The first character
cannot be numeric, a + or a - The abbreviation is limited to a maximum length of 32 -

-

-

QK

|| Cancel H Help

6. For all package types, add files to the package using the buttons on the Files tab. For each
file, you can specify the path you want it to have in the package in the File or Directory
Path in Package column of the Files list. Click OK when your Files list is complete.
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[+ ¢ Debug - Packaging Files (%
e
Top Directory: |argumentsl |
Files:
Type |Fi|e or Direct... |Original File ... |Permis... Owner |Group | ‘ New ‘
File argumentsl/... dist/Debug/G... 755 root bin -
| ‘ Add File or Directory ‘
‘ Add Files from Directory ‘
‘ Add Softlink ‘
‘ Duplicate ‘
‘ Bemowve ‘
[ » ]
‘ Down ‘
|
Default File Properties (used when adding files or directories):
rw x  w x r w x Owner and Group
Regular Files: [w]w][] I WL ][] 644 Owner: [root
Exe Files: WL [®]1k] 755 Group: |bin
| [s]'4 H Cancel H Help

Turn off verbose mode if you wish by clicking the checkbox.
Click OK.

To build your package, right-click the project and choose More Build Commands > Build
Package.
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More Information About the IDE

This chapter points you to other resources about Oracle Developer Studio IDE.

Learn More About the IDE

You can learn about using the Oracle Developer Studio IDE by reading the IDE's integrated
help, which you can access through the IDE's Help menu or by pressing the F1 key. Many
dialog boxes also have a Help button for information about how to use the dialog box.

The tutorials on the NetBeans IDE C/C++ Learning Trail can also be helpful for learning how
to use the Oracle Developer Studio IDE, although there are some differences between the user

interfaces and features. In particular, NetBeans documentation about debugging does not apply
to Oracle Developer Studio IDE.

Oracle Database Projects

For more information about the database explorer in the IDE, see How to Use the Database
Explorer in the Oracle Developer Studio IDE.

For information about Oracle Instant Client in the IDE, see How to Use Oracle Instant Client in
the Oracle Developer Studio IDE.

Remote Development

For information on choosing a remote development mode, see How to Select a Remote
Development Mode in Oracle Developer Studio.

Chapter 11 « More Information About the IDE 107


https://netbeans.org/kb/trails/cnd.html
http://www.oracle.com/technetwork/articles/servers-storage-dev/howto-dbexplorer-studio-ide-1845679.html
http://www.oracle.com/technetwork/articles/servers-storage-dev/howto-dbexplorer-studio-ide-1845679.html
http://www.oracle.com/technetwork/articles/servers-storage-dev/inst-client-studio-ide-1849257.html
http://www.oracle.com/technetwork/articles/servers-storage-dev/inst-client-studio-ide-1849257.html
http://www.oracle.com/technetwork/articles/servers-storage-dev/howto-use-remote-ide-1648699.html
http://www.oracle.com/technetwork/articles/servers-storage-dev/howto-use-remote-ide-1648699.html

Version Control Systems

For more general information about remote development, see the Overview of C/C++ Remote
Development help page in the IDE. This page also directs you to other useful pages about
remote development.

Version Control Systems

The IDE is integrated with the option to use several version control systems, like Mercurial,
Subversion, CVS, and Git, enabling easier source code management for your projects. For more
information, see How to Use IDE Projects Under Version Control.

108 Oracle Developer Studio 12.6: IDE Quick Start Tutorial « June 2017


http://www.oracle.com/technetwork/articles/servers-storage-dev/ide-version-control-1719427.html

	Oracle® Developer Studio 12.6: IDE Quick Start Tutorial
	Contents
	Chapter 1 • Overview of the Oracle Developer Studio IDE
	Why Use the Oracle Developer Studio IDE?

	Chapter 2 • Creating a New Application
	Creating an Application Project
	Switching Between the Logical View and the Physical View of the Project
	Adding Files to Your Project
	Creating Logical Files and Folders for Your Project
	Creating New Source Files for Your Project
	Creating Header Files for Your Project
	Adding or Removing Existing Files to Your Project

	Setting Properties and Configurations
	Setting Project Properties
	Managing Configurations
	Setting Source File Properties

	Building Your Project
	Compiling a Single File

	Chapter 3 • Running a Project
	Running a Project
	Launchers

	Chapter 4 • Creating a Project From Existing Sources
	Creating a Project From Existing Sources
	Building and Rebuilding Your Project

	Creating a Project From a Binary File
	Creating a Project from a Binary File With New Project Wizard
	Creating a Project from Binary File in Files Window

	Code Assistance
	Configuring Code Assistance
	Code Assistance Cache Sharing
	Project Properties Options for Code Assistance
	Search File System for C/C++ Header Files


	Chapter 5 • Creating an Oracle Database Project
	Creating an Oracle Database Project
	Creating a New Database Connection


	Chapter 6 • Editing and Navigating Source Files
	Editing Source Files
	Setting the Formatting Style
	Folding Blocks of Code in C and C++ Files
	Using Semantic Highlighting
	Using Code Completion
	Using Static Code Error Checking
	Adding Source Code Documentation
	Using Code Templates
	Using Pair Completion
	Finding Text in Project Files
	Find and Replace
	Using Your Clipboard History


	Navigating Source Files
	Window Management and Grouping
	Using the Classes Window
	Using the Navigator Window
	Finding Class, Method, and Field Usages
	Using the Call Graph
	Using Hyperlinks
	Using the Include Hierarchy
	Using the Type Hierarchy


	Chapter 7 • Debugging Your Application
	Creating Breakpoints
	Creating and Removing a Line Breakpoint
	Creating a Function Breakpoint
	Grouping Breakpoints

	Debugging a Project
	Starting a Debugging Session
	Inspecting the State of the Application

	Debugging an Executable File
	Debugging at the Machine-Instruction Level
	Debugging a Running Program by Attaching to It
	Debugging a Core File

	Chapter 8 • Monitoring a Project
	Profiling a Project with the Run Monitor Profiling Tools
	Setting Up the Profiling Project
	Building and Running the ProfilingDemo_1 Project
	Using the Indicator Controls
	Exploring CPU Usage
	Exploring Memory Usage
	Exploring Thread Usage

	Running Memory Access Checking on Your Project

	Chapter 9 • Remote Development Setup
	Remote Development Setup
	Using the Remote Development Toolbar
	Using the Terminal Window for a Build Host
	Remote Desktop Distribution


	Chapter 10 • Packaging an Application
	Packaging an Application

	Chapter 11 • More Information About the IDE
	Learn More About the IDE
	Oracle Database Projects
	Remote Development
	Version Control Systems


