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Oracle Workshop for WebLogic Version 
10.3 Release Notes

This document contains information on the following subjects:

What's New in Workshop Version 10.3?

Location of Supported Platform Information

Known Limitations for Workshop 10.3

What's New in Workshop Version 10.3?

Support for Java Enterprise Edition 5
Workshop supports the following JEE5 technologies: 
• Servlet 2.5
• JSP 2.1 
• JSF 1.2
• JSTL 1.2
• EJB 3.0
• JAX-WS 
• JAXB 2.0 

Built on Eclipse 3.3.2 and Web Tools Platform 2.0.3 
Workshop version 10.3 is built on the Eclipse Platform, an open source framework that is now 
widely used for Java development. Workshop extends Eclipse 3.3.2 and the Web Tools Platform 
2.0.3
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Supported by Windows Vista
Workshop version 10.3 is supported by Windows Vista.

XMLBeans
Workshop version 10.3 supports XMLBeans 2.3. 

Workshop for WebLogic IDE Launcher
The WorkSpace Studio launcher has been discontinued. The Workshop for WebLogic IDE 
launcher is WORKSHOP_HOME/workshop[.exe]. 

Location of Supported Platform Information
For more information on platform support, including hardware and software requirements, see 
the Supported Platforms web site.

Known Limitations for Workshop 10.3
Table 1 lists the known limitations found in Workshop for WebLogic.

http://e-docs.bea.com/platform/suppconfigs/configs102/102_over/overview.html
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Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3

Problem ID Description

CR282777 The first time you run Project > Clean after importing a project, Workshop for WebLogic may 
not clean all of the files from the .apt_src directory

When a user imports a project including build directories such as .apt_src, all files in that 
directory might not get removed the first time a clean is performed. This only happens the first 
time, subsequent cleans correctly handle the generated directories.

Platform: All

Workaround: Manually delete the files in the .apt_src directory when performing a clean the 
first time after import. Once deleted, the new files that go into that directory are correctly handled 
by the clean action.

CR287585 When a web service or other artifact is in a web project that is part of more than one EAR, the 
Run on Server can produce the wrong URL.

Using the Run on Server action on artifacts in a web project that is associated with multiple EARs 
in the workspace can launch the browser to the incorrect URL. That is, it will use the URL 
associated with the last EAR with which is was associated.

Platforms: All

Workaround: 
To workaround this issue, you can either 
a) close the EAR that is not to be used for the launch, 
b) remove the web project from the EAR that is not used for the launch, or 
c) manually update the URL in the browser to hit the correct EAR.

CR293197 Lost JVMTI events (especially breakpoints) when debugging with JRockit

When debugging with the JRockit JVM you may experience performance problems and missed 
breakpoints.

Platforms: All

Workaround: Update to JRockit 5.0 R27.1 or later.
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CR294199 Invocation of buffered Control methods will fail at runtime if deployed (via the IDE) to a server 
with more than one JMS Server

The IDE will auto-deploy required Workshop libraries when deploying an application.   The use 
of @MessageBuffer on Control methods creates a dependency on application-scoped JMS 
resources in the weblogic-controls library. If the weblogic-controls library is deployed (by the 
IDE) to a server with more than one JMS server, the library will deploy, but the 
application-scoped JMS resources will not be available. This is because the IDE depends on 
default sub-module targeting, and default sub-module targeting relies on the target containing 
exactly one JMS Server. A message similar to the following warns that there is an issue with the 
deployment:

<The JMS module named "WlwRuntimeAppScopedJMS" inside 
application "testLibWebApp" does not have a sub-deployment stanza
named "WlwRuntimeAppScopedJMS". Without such a stanza no entities
inside the module will be deployed, since the sub deployments
inside of the sub-deployment stanza named
"WlwRuntimeAppScopedJMS" control where JMS entities inside this
module are targeted.>

Note that even though there is a warning message, the library is deployed to the server. This 
means that applications that are dependent on the library will also successfully deploy. However, 
invocation of buffered Control methods will fail at runtime with a message similar to the 
following:

"Failed to invoke end componentFailed to invoke methodMessage
buffering is not available - either the buffering MDB did not
deploy or we are in a standalone WAR"

Note that this situation is most likely to occur when using domains that were not created with 
support for "Workshop for Weblogic Platform.

Platforms: All

Workaround: 
Manually deploy the library using the weblogic.Deployer command. The form of the command 
is:
java weblogic.Deployer 
  -username weblogic 
  -password weblogic 
  -adminurl t3://localhost:7001 
  -deploy 
  -name weblogic-controls-10.0
  -source %WL_HOME%/common/deployable-libraries/weblogic-controls-10.0.ear
  -targets cgServer
  -submoduletargets cgJMSServer@WlwRuntimeAppScopedJMS@WseeJmsServer
  -library -libspecver 10.0 
  -libimplver 10.0
Where: 
- WseeJmsServer is the name of the JMS Server to host the application-scoped 
destinations.
- targets is the development server

The command updates the library definition in config.xml.  Therefore it only needs to be run 
once.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR301661 Buffered methods on ServiceControl may fail over JMS protocol

Buffered operations on a ServiceControl must be void. However the Message Exchange Pattern 
(MEP) in the underlying WSDL can be either request/response (with an empty response), or 
oneway (a request with no response).

In the case of a request/response MEP over JMS, the presence of @MessageBuffer will cause 
the request to deadlock and eventually timeout. The following warning message will generally 
be produced:

Potential blocking operation
{http://someNamespace}someOperation: a synchronous
request/response invocation within a transaction using the JMS
transport can cause deadlocks. Please refer to WebLogic
documentation for details.

The resulting error message will include text similar to:

javax.xml.rpc.soap.SOAPFaultException: Failed to receive message 
java.io.IOException: Request timed out

Note: this only occurs when the transport protocol for the request is JMS.

Platforms: All

Workaround: If you can influence the design of the target JWS, having the JWS operation 
annotated with @Oneway will direct that the underlying MEP be oneway, and will avoid this 
situation. If you can not influence the design of the target JWS, then the workaround is to add 
the TransactionAttribute annotation to the ServiceControl operation:

@MessageBuffer
@TransactionAttribute(TransactionAttributeType.NOT_SUPPORTED)
public void voidMethod();

Note that the presence of the @TransactionAttribute will not change the transactional behavior 
of actions that occur within the calling application.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR304008 Servlet 2.5 Implementation In WebLogic Server 10.0 Can Break 9.2 Beehive Applications

Description: An issue may surface when a 9.2 Beehive application is deployed on WebLogic 
Server 10.0. The symptom with this scenario is a java.lang.IllegalStateException being thrown. 
The underlying issue is with the javax.servlet.ServletException which changed from Servlet 2.4 
to Servlet 2.5.

Platforms: WebLogic Server 10.0 or higher

Workaround: Upgrade the application to use Beehive 10.0 libraries (which work with either 
Servlet 2.4 or Servlet 2.5). If the 9.2 application cannot be compiled in 10.0, then manually 
updating the deployment descriptors in the 9.2 application EAR to use the 10.0 Beehive libraries 
will resolve this issue. For example:

For each .war in the 9.2 .ear, modify the following section of the web-inf/weblogic.xml:

<wls:library-ref>
<wls:library-name>beehive-netui-1.0</wls:library-name>
<wls:specification-version>1.0</wls:specification-version>
<wls:implementation-version>1.0</wls:implementation-version>

</wls:library-ref>

to look like:

<wls:library-ref>
<wls:library-name>beehive-netui-1.0.1-10.0</wls:library-name>
<wls:specification-version>1.0</wls:specification-version>
<wls:implementation-version>1.0.1.1</wls:implementation-version>

</wls:library-ref>

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR304502 Users who upgrade an 8.x application to a 9.x/10.x application may experience issues when 
making multiple method calls to a JDBC control from a single page flow method

Due to a change in transaction scope from page flows which has been documented in 

http://e-docs.bea.com/workshop/docs92/ws_platform/upgrading/conChangesDuringUpgrade.ht
ml

See the section labeled: 'Controls are Not Automatically Run Within the Scope of a Transaction'

Users who upgrade an 8.x application to a 9.x/10.x application may experience issues when 
making multiple method calls to a JDBC control from a single page flow method. The crux of 
the issue is that when the first call is made to the JDBC control a new transaction is created by 
our transaction interceptor. When that call returns the transaction is either committed or rolled 
back. 

On the next call to the JDBC control a new transaction is created, but the JDBC connection being 
used by the control cannot be used in another transaction (it has been associated as a resource of 
the first transaction).

The behavior in 8.x page flows was for the JDBC control to release its JDBC connection after 
each method invocation. The transaction scope for a control method being invoked from a page 
flow was to start a transaction at the beginning of the control method invocation, and end the 
transaction on the return of the method. If the control rolled back the transaction, all operations 
performed within that transaction would be rolled back as well. 

Platforms: All
Workaround: There are several workarounds available:

1) If you do not want to use transactions (they were implicit in
8.x) the transaction interceptor annotations (inserted by the upgrader) can be removed from the 
control methods.

2) If you want to use transactions, create a JTA transaction in the page flow method and either 
commit or rollback once the calls to the JDBC control are completed.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description


http://e-docs.bea.com/workshop/docs92/ws_platform/upgrading/conChangesDuringUpgrade.html
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CR308749 Duplicate simple class names are not supported for web service controls with callbacks

When multiple web service controls, with callbacks, have identical class names (ignoring 
package name) an error will occur in jwsc. This error will appear in the publish step in the ide, 
during the usable step in exported ant scripts, or when exporting an ear file from the ide. In 
previous versions of Workshop the exported ant scripts would incorrectly report that the 
assemble step had succeeded even though this condition was present. This was because the ant 
script did not attempt to run jwsc on garnered java files.

Platforms: All
Workaround: When using web service controls (SerivceControl) with callbacks make sure that 
each control file has a unique un-qualified class name. Differing the package name is not 
sufficient.

CR313306 Service control generation can produce incorrect callback method names

Service control generation based on WSDL callbacks named with underscores and numbers can 
result in incorrect callback method names. This will occur if a lower case letter follows an 
underscore or number.

For example, the following WSDL callback names:

a_b
a4b

will result in the generation of the following callback method names:

a_B
a4B

Note that the first character after a number or underscore has been capitalized.

When the method is invoked, the following error will result.

javax.xml.rpc.JAXRPCException: SOAPFaultException - FaultCode
[{http://schemas.xmlsoap.org/soap/envelope/}Client] FaultString
[Failed to get operation name from the incoming request] 

Platforms: 10.x

Workaround: Avoid callback method names with a lower case letter following an underscore 
or number.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR326326 Workshop startup.jar cannot be used to run in headless mode on Linux unless an additional 
system property is defined

The startup.jar provided with Workshop cannot be used to run in headless mode on Linux, unless 
the following system property is set to true:

m7.disable.swt.init

Platforms: Workshop 10.1

Workaround: Launch workshop in headless mode with the system property m7.disable.swt.init 
set to true. Note that the DISPLAY system property must not be set for this workaround to 
succeed.

CR326466 Issue with Hibernate JPA deployment on Weblogic Server 10.0

Hibernate JPA projects created in Workshop 10.1 or imported from Workshop Studio 3.x fail to 
deploy on Weblogic Server 10.0. The below workaround will help Hibernate JPA projects 
deploy but redeployment will require a server restart

Platforms: Workshop 10.1 and later

Workaround: For EAR Projects - Modify weblogic-application.xml and add the following

<prefer-application-packages>

<package-name>antlr.*</package-name>

<package-name>org.apache.commons.*</package-name>

<package-name>org.apache.oro.*</package-name>

<package-name>oracle.*</package-name>

</prefer-application-packages>

For Web Applications - Add the web project to an EAR and then modify 
weblogic-application.xml as described above.

Note: Redeployment of the project requires a server restart.

CR327602 After renaming project, old project is not undeployed from the server

If you rename a project that belongs to an EAR, the previous project name will not be undeployed 
from WebLogic Server. 

Platforms: Workshop 10.1
Workaround: To remove the project from the server, undeploy and redeploy the application 
from WebLogic Server.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR327849 Problems deploying EJB project upgraded using command line upgrader

You may encounter problems deploying an EJB project that has been upgraded using the 
command line upgrade tool upgradeStarter.

Platforms: Workshop 10.1
Workaround: Upgrade the project using the IDE instead of the command line tool. To upgrade 
using the Workshop IDE.

CR328406 Incomplete AppXRay database may be produced after upgrade

After upgrade from Workshop version 8.1.x to 10.2 or migration from 9.2 through 10.0 to 10.2 
the initial build of the upgraded application may produce an incomplete AppXRay database for 
web projects that have the AppXRay feature enabled. In this case the user may notice that the 
App Xaminer view does not show all dependencies correctly. 

Platforms: Workshop 8.1 and later

Workaround: To correct this situation clean and rebuild the workspace (by selecting Project > 
Clean).

CR334542 ExceptionInInitializerError deploying web service on WebLogic Server 9.2

When deploying a web service to pre-MP1 versions of WebLogic Server 9.2, you may encounter 
a ExceptionInitializerError.

Platforms: Workshop 10.2 and WebLogic Server 9.2

Workaround: Implement one of the following solutions:

(1) Upgrade your WebLogic Server 9.2 installation to 9.2 MP1 or higher.

(2) Or add the following flag to both the workSpaceStudio.ini file and WebLogic Server’s start 
script for the VM.

-Dcom.sun.xml.namespace.QName.useCompatibleSerialVersionUID=1.0

CR336597 Web application deployment descriptor graphical editor doesn't support <resource-ref> 
elements

Workshop’s graphical editor for deployment descriptors does not support <resource-ref> 
elements. The Deployment Descriptor Elements tree view (located above the source editor) 
and the Outline view do not support adding or editing <resource-ref> elements.

Platforms: All

Workaround: Use source view to add and edit <resource-ref> elements.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR340273 Filter dispatcher warnings from JSF webapp deploy

The version of MyFaces bundled with Workshop logs warnings to the WebLogic Server console 
due to a bug in the MyFaces web.xml parser. This bug is tracked here:

  http://issues.apache.org/jira/browse/MYFACES-1415

The warnings are harmlessOracle Workshop for WebLogic 10.3 Release Notes and result in no 
loss of functionality.

Platforms: All

Workaround: These warnings can be ignored.

CR342837 Some Workshop text fields do not support Ctrl+V paste

In the presence of the WebLogic Portal Eclipse plugins, some of the Workshop text fields do not 
support the Ctrl+V paste operation. 

Platforms: All

Workaround: Manually type text into these text fields.

CR342995 Linux: Workshop JSP design view does not support drag and drop

On Linux, the Workshop JSP design view does not support drag and drop from the Design 
Palette.

Platform: Linux

Workaround: Drag-and-drop from the Design Palette onto the source view.

CR344306 Minimal support for JSP XML syntax

The Workshop JSP designer does not support JSP's XML syntax and gives warnings when 
parsing XML JSPs. For example, use of an entity reference “&amp;” for the character "&" will 
report a warning in the Problems view that deployment is prevented.

Platforms: All

Workaround: These warnings can be ignored: JSP XML syntax does not hinder deployment of 
the application.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description



Orac le  Workshop fo r  WebLog ic  Ve rs ion  10 .3  Re lease  No tes

12 Oracle Workshop for WebLogic 10.3 Release Notes

CR350342 Projects upgraded from Workshop Studio 3.3 may require manual upgrade of Kodo license

The Kodo license bundled with Workshop Studio 3.3 release has expired, so older applications 
which have the license file at <Project_Home>/src/license.bea need a manual upgrade.

Platforms: Applies to JPA/Kodo applications upgraded from Workshop Studio 3.3 to Workshop 
10.1 and later.

Workaround:

Create a new project that supports JPA/Kodo. For details, see 
http://edocs.bea.com/wlw/docs101/guide/ormworkbench/conAddingEJB3Support.html

Copy the license.bea file from the new project into the original project’s src folder.

CR355189 Licensing concerns when Workshop Studio 10.2 and Workshop for WebLogic 10.2 are installed 
in same the BEA Home

If a user has both Workshop for WebLogic 10.2 and Workshop Studio 10.2 installed in the same 
BEA_HOME and either the Workshop Studio trial or full license expires, all Workshop 
functionality (including both Workshop Studio and Workshop for WebLogic) will be 
unavailable.

Platforms: Workshop for Weblogic 10.2 and Workshop Studio 10.2.

Workaround: Uninstall Workshop Studio 10.2 by performing the following: 

Run uninstall, deselecting all components except Workshop Studio in the uninstall wizard. 
Launch the product again. The Workshop for WebLogic license will be used and Workshop for 
WebLogic functionality returns.

CR356110 Workshop closes console when the server fails to start

When WebLogic Server fails to start in Workshop, the Console view may be closed making it 
difficult to monitor the errors associated with the failure to start.

Platforms: Workshop 10.2

Workaround: Follow the procedure below:
1. In the Server view, double-click the server instance to open the Server Overview.
2. In the section Startup and Deployment, uncheck Launch WebLogic server in Eclipse 
Console.
3. Start WebLogic Server using the start up script located at 
<domain_home>\bin\startWebLogic.cmd|.sh.
4. To view the errors associated with the start up failure consult the command shell console 
output.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR362046 WorkSpace Studio About Box may stop displaying plugin and configuration details after a BEA 
Product is removed from the BEA Home directory

After uninstalling a BEA product from your BEA Home directory in which you have other 
products installed, the Plugin Details and Configuration Details buttons in the WorkSpace Studio 
IDE about box (Help > About BEA WorkSpace Studio) may stop working. This is due to the 
fact that under some circumstances empty plugin directories may still be present after the plugins 
are removed and the IDE expects to locate, but can not find, plugin details in those directories.

Platforms: WorkSpace Studio 1.1

Workaround: Launch WorkSpace Studio with -clean.

CR365358 Error When Processing JAX-RPC Style Web Service Annotations Using JDK 6

The following error occurs when JAX-RPC style web service annotations are processed by an 
Ant script generated with WebLogic Server 10.0 using JDK 6:

[apt] C:\mywebservice\JAXRPCService.java: Class: mywebservice.JAXRPCService contains 
mixed bindings. SOAPBinding.Style.RPC and SOAPBinding.Style.DOCUMENT cannot be 
mixed.

Platforms: Workshop for WebLogic 10.3
Workaround: Re-export the Ant script for the web service using Workshop 10.3 and reprocess. 
The Ant script export wizard is available by selecting File > Export > Workshop Build Scripts 
> Workshop Ant Scripts.

CR367817 Error When Adding JAR to Web Module Through J2EE Module Dependencies Dialog

The following error:

IWAE0010E An internal error occurred" 

may occur if you attempt to add a JAR to a web module in the following way:

1) Right-click the project in the Project Explorer view.

2) Select Properties.

3) Select on J2EE Module Dependencies.

4) Click Add Jars.

5) Select the target JAR.

6) Click OK and click OK on the Properties dialog.

Platforms: Workshop for WebLogic 10.3
Workaround: Add the JAR using the following dialog: right-click the project in the Project 
Explorer view and select Properties > Java Build Path.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description
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CR370200 Failure to Deploy Web Services Generated From WSDLs

Web services generated from different WSDLs in a single JAX-WS project cannot be 
successfully deployed without manually modifying the deployment descriptors. 

Note that in a JAX-RPC project, you can simply add a WLS-specific annotation (i.e., 
WLHttpTransport). In a JAX-WS project, WLS-specific annotations are not supported.

Platforms: Workshop for WebLogic 10.3
Workaround: Documentation on modifying the deployment descriptors is located in the 
WebLogic Web Service Deployment Descriptor Element Reference (see the 
service-endpoint-address element).

CR370893 Problems With Imported JSP Files With UTF-16LE Encoding

After importing a JSP file with UTF-16LE encoding, Workshop sets the encoding to UTF-16, 
and, after editing and saving the file, the encoding will be reset to ISO-8859-1.

Platforms: Workshop for WebLogic 10.2 and 10.3
Workaround: Close the JSP file, right-click the target JSP file in the Project view and select 
Properties. On the Resource page, in the Text file encoding section, select Other, set the 
encoding to UTF-16LE and click Ok.

CR371257 JAXB -> XJC tool issue -> resolving URIs like schemaLocation in folder selection 

When selecting a folder in the JAXB XJC wizard (File > New > Other > Web Services > JAXB 
XJC Wizard), binding file schema locations will not be resolved from the contents of the 
binding file. For example, if you have a folder that contains

/folder
/binding.xjb
/foo.xsd

and the contents of the binding file contain the declaration

<jxb:bindings schemaLocation="foo.xsd" node="/xs:schema">

then selecting the /folder and running the wizard will result in the same error as running the 
wizard with only the binding file, i.e., it will not be able to locate foo.xsd.

Platforms: Workshop for WebLogic 10.3
Workaround: If your JAXB binding file makes use of the schemaLocation attribute, ensure the 
schema specified is explicitly checked during file selection.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)

Problem ID Description

http://e-docs.bea.com/wls/docs100/webserv_ref/dd.html
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CR372626 Web Services: Properties Editor Displays Incorrect Elements on Web Service Creation

After opening a web service in a web service project configured using the facet set Annotated 
Web Service Facets JAX-RPC (Recommended) (v10.3), the Properties view may display no 
elements or incorrect elements.

Platforms: Workshop for WebLogic 10.3
Workaround: Refresh the Properties view by switching between the web service Source View 
and Design View.

CR373745 JBoss 4.2 & 5.0 Fails to Suspend on a Breakpoint Using the Workshop JSP Editor

When debugging JSP files running on JBoss 4.2 or 5.0, where your workspace contains two web 
projects each with index.jsp files with breakpoints set in them, the breakpoints may fail to 
suspend.

Platforms: Workshop for WebLogic 10.3
Workaround: Set the breakpoint using the WTP JSP editor: 
- Close the Workshop JSP Editor.
- Right click the JSP in the Project Explorer and select Open With > JSP Editor.
- Switch to the Debug perspective.
- Select Run > Debug As > Debug on Server.

CR374069 Workshop Source Editor Does not Support Files with UTF-32(BE:0000 feff)/UTF-32(LE:fffe 0000) 
BOM

Workshop for WebLogic 10.3 does not currently support saving JSP files with the following 
encodings:

UTF-32, big endian (0000 feff)

UTF-32, little endian (ffef 0000)

Platforms: Workshop for WebLogic 10.3
Workaround: To view UTF-32BE and UTF-32LE encoded files in Source view, see the 
workaround for CR374070 below. However, the BOM is not preserved in the resulting saved 
artifact.

Table 1  Known Limitations in Oracle Workshop for WebLogic Version 10.3 (Continued)
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CR374070 Source View Incorrectly Displays UTF-16BE and UTF-32BE Encoded JSP Files 

After importing a JSP file with UTF-16BE or UTF-32BE encoding, the Source View may fail to 
display the page correctly.

Platforms: Workshop for WebLogic 10.2 and 10.3
Workaround: Close the JSP file, right-click the target JSP file in the Project view and select 
Properties. On the Resource page, in the Text file encoding section, select Other, set the 
encoding to UTF-16BE or UTF-32BE as appropriate and click Ok.

CR374342 IBM WebSphere 5 & 6 Fails to Start in Debug Mode When Workshop is Started Using JRockit VM

When IBM WebSphere 5 or 6 is started in debug mode when Workshop has been started using 
the JRockit VM, the following error will occur: 

org.eclipse.core.runtime.CoreException: socket closed

    at 
com.m7.wide.eclipse.debugger.launch.WideSocketLaunchConnector.a
bort(WideSocketLaunchConnector.java:128) ...

Platforms: Workshop for WebLogic 10.3
Workaround: Switch the default JDK to the Sun JDK when developing
with IBM Websphere app server. To switch the default JDK, change the -vm argument in the 
WORKSHOP_HOME/workshop.ini file.

CR374804 Tomcat server 4.1.x Fails to Start in Debug Mode Using JDK 1.4

Workshop does not support Tomcat server version 4.1.x in debug mode when using JDK 1.4. 
When attempting to start server the following error occurs: 

!ENTRY org.eclipse.wst.server.core 4 0 <time_stamp>

!MESSAGE Timeout waiting for Tomcat v4.1 at localhost to start.

Platforms: Workshop for WebLogic 10.3
Workaround: Switch to JDK 1.5. Note that you can switch the JDK version during server 
creation. Select File > New > Server. Select Apache > Tomcat v4.1 > Next. Use the JRE 
dropdown and the Installed JREs button to switch to JDK 1.5.
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