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Introduction

Introduction

The tutorials presented in this document introduce you to some of the common tasks you perform
in developing the pieces of a portal project and organizing those parts into a version that end users
see. The tools you use to perform these tasks include BEA Workshop for WebLogic Platform and

BEA WebLogic Portal®, including the WebLogic Portal Administration Console.

This document describes the following tasks, organized by chapter:
e Chapter 2, “Setting Up Your Portal Development Environment”
e Chapter 3, “Creating a Portal in Your Development Environment”

e Chapter 4, “Assembling a Desktop in Your Staging Environment”
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CHAPTERa

Setting Up Your Portal Development
Environment

This tutorial helps you prepare your Workshop for WebLogic environment for portal
development.

For more detailed information about each dialog of the wizards used in this chapter, refer to the
Portal Development Guide.

Before You Begin

Before starting this tutorial, do the following:
e Install Workshop for WebLogic and WebLogic Portal.

e Complete the tutorial “Getting Started with BEA Workshop for WebLogic Platform”
located in the BEA Workshop for WebLogic Programmers s Guide.

This task is optional, but if you are unfamiliar with the Eclipse development environment
on which Workshop for WebLogic is based, the Getting Started tutorial is highly
recommended; the tutorial shows you how to start Workshop for WebLogic and navigate
the workbench user interface, introduces terminology associated with the workbench, and
shows you how to create a simple web application.

Tutorial Steps

Using the tutorial, you will perform tasks that are required to get your Workshop for WebLogic
environment ready for portal development.

The tutorial includes instructions on how to perform these tasks:
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Create a Portal Domain

Create a Portal EAR Project
e Associate the EAR Project with the Server
e Create a Portal Web Project

e Create a Datasync Project

In your actual development environment you do not need to follow the order of the steps as
presented in this tutorial; for example, you can create the portal domain affer performing all the
other steps. However, we recommend that you follow the steps as presented here so that you can
easily see the relationships among the parts of a portal project.

Create a Portal Domain

The portal domain is a group of WebLogic Server resources that contain the application server
used by the portal. You must have a server domain that is WebLogic Portal — enabled in order to
test the portal that you create. This customized domain is generally called a portal domain.

To create a portal domain, perform these steps:
1. Start Workshop for WebLogic.

2. When asked to select a workspace, click Browse and select (or create) a workspace folder.
Follow the dialog prompts as appropriate. For this tutorial, we recommend that you create a
new workspace.

The Workshop for WebLogic workbench displays.

3. If the Portal perspective is not already open, select it by choosing Window > Open
Perspective > Portal.

The instructions and figures in this tutorial are based on the views that are available in the
Portal perspective.

4. Choose File > New > Other.

The New — Select a Wizard dialog displays, as shown in Figure 2-1.

BEA WebLogic Portal Tutorial



Tutorial Steps

Figure 2-1 New — Select a Wizard Dialog
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5. Expand Server in the tree, click Server in the expanded tree, and then click Next.

The New Server — Define a New Server dialog displays, as shown in Figure 2-2.
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Figure 2-2 New Server — Define a New Server Dialog

Define a New Server
Choose the type of server to create

Server's host name: | localhost -

Select the server bype:
+- 7= Apache
—I-[7= BEA Systems, Inc.
ey BEA WebLogic v9.2 Server

‘Wiews By: |Yendor -

Description: BEA Weblogic 9.2 Server

Server runtime: |BEA Weblogic v9.2 j Installed Runtimes. ..

< Back | Mexk = | | Cancel |

6. Inthe tree, verify that BEA Systems, Inc. is expanded and that BEA WebLogic v9.2 Server
is selected, then click Next.

The host name localhost is shown in the Host name field. For the tutorial, leave this entry
unchanged.

The New Server — New BEA WebLogic Server dialog displays, as shown in Figure 2-3.
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Figure 2-3 New Server — New BEA WebLogic Server Dialog
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7. Click the link that is labeled Click here to launch Configuration Wizard to create a new
domain.

The BEA WebLogic Configuration Wizard starts, as shown in Figure 2-4.
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Figure 2-4 BEA WebLogic Server Configuration Wizard
0 AR
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messaging (IMS) settings. You can also incorporate additional functionality in your domain, for exarmple, by
including Aqualogic Service Bus.
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8. Follow the wizard prompts and enter the values shown in Table 2-1. Click Next as appropriate
to continue through the wizard.

Table 2-1 Configuration Wizard Values

In this Wizard Page... Select or Enter...

Welcome Create a new WebLogic domain (the default)

Select Domain Source In the Generate a domain configured automatically to
support the following BEA products list, select WebLogic
Portal.

Notice that a WebLogic Portal GroupSpace check box is
available on this wizard dialog; portal projects based on the
GroupSpace sample application must have a a
GroupSpace-enabled domain. This tutorial does not use
GroupSpace.
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Table 2-1 Configuration Wizard Values (Continued)

In this Wizard Page... Select or Enter...

Configure Administrator Username User name: weblogic

and Password User password: weblogic

Confirm user password: weblogic

Configure Server Start Mode and JDK + Development Mode (the default)
* JRockit SDK (recommended)

Customize Environment and Services  No (the default)
Settings

Create WebLogic Domain Domain name: myPortalDomain

Domain location: Accept the default, or specify another
directory on your system.

9. When you are finished with these entries, click Create in the Create WebLogic Domain
dialog.

The Creating Domain status page appears, indicating the progress of the domain creation.
10. When the domain is created, click Done.

The display returns to the New Server — New BEA WebLogic Server dialog.

11. Click Browse and navigate to the directory of the domain that you just created. By default,
the path is BEA_ HOME\user projects\domains\myPortalDomain.

12. In the Browse for Folder dialog, select the domain directory and click OK to return to the
Define a New Server — New BEA WebLogic Server dialog.

13. Click Finish.

The new server displays in the Servers view in the Workshop for WebLogic workbench,
and a Servers node is added to the tree in the Package Explorer view. Figure 2-5 shows the
Servers view and the new server.

For now, you do not need to start the server. Later in this tutorial, you will create a simple
portal application, start the server, and run the portal application on the server.
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Figure 2-5 New Server Displayed in Workbench
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Create a Portal EAR Project

An EAR project collects the component projects of the application for deployment; you create
one EAR project per enterprise application. The EAR project contains JAR files, deployment
descriptors, build files, and auto-generated files. For more information about EAR projects and
their relationship to the other projects in the workbench, refer to the “Applications and Projects”
topic in the Workshop for WebLogic Help.

In this task, you will create an Enterprise Application (EAR) project that is customized to contain
WebLogic Portal information. For more information about the Portal EAR Project, refer to the
Portal Overview.

To create a Portal EAR project, perform these steps:

1. Be sure you have set up the example environment and domain, as explained previously in
“Create a Portal Domain” on page 2-2.

2. From the File menu, select New > Project...
The New Project — Select a wizard dialog displays.

Expand the WebLogic Portal folder if needed, and select WebLogic Portal > Portal EAR
Project, as shown in Figure 2-6.
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Figure 2-6 New Project — Select a Wizard Dialog with Portal EAR Project Selected
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Tutorial Steps

4. Inthe New Portal EAR Project dialog, enter myPortalkaR in the Project Name field, leave
the other entry fields unchanged, and click Next.

The New Portal EAR Project — Select Project Facets dialog displays, as shown in

Figure 2-7.
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Figure 2-7 New Portal EAR Project — Select Project Facets Dialog
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5. In the New Portal EAR Project — Select Project Facets dialog, verify that WebLogic Portal
and all features that fall under the WebLogic Portal node are selected, as shown in

Figure 2-7.

The selections WebLogic Portal (Optional) and WebLogic Portal Collaboration are also
available here. These selections are not needed for the tutorial; leave them unselected. For
more information about what happens when you select these options, refer to the Portal

Development Guide.

6. Click Finish.

The Portal EAR Project node is added to the Package Explorer view, as shown in

Figure 2-8. If you expand the folder you can see the EAR content folder and the required

APP-INF and META-INF directories for the project.
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Figure 2-8 Package Explorer View including Portal EAR Project
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Note: The error icon on the EAR folder appears because the Portal EAR Project references
library modules that have not yet been added to the project. Later in this tutorial when
you create a Portal Web Project, the library modules will be added and the error icon will
disappear when Workshop for WebLogic automatically rebuilds the workspace.

Associate the EAR Project with the Server

You need to explicitly associate the EAR project with the server that you created previously, so
that later you can test the project on that server.

To associate the Portal EAR Project with the server, perform these steps:

1. In the Servers view (as shown in Figure 2-5), right-click BEA WebLogic v9.2 Server @
localhost, then select Add and Remove Projects.

The Add and Remove Projects dialog displays, as shown in Figure 2-9.
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Figure 2-9 Add and Remove Projects Dialog
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2. Click to select myPortalEAR in the Available projects column and then click Add.
The project is added to the Configured projects column on the right.
3. Click Finish.

The Portal EAR Project is now associated with the server. To verify this, in the Servers
view you can expand the server node to view the server’s associated projects. The
myPortalEAR project should be shown as a subordinate node.

Create a Portal Web Project

In this task you create the web project that will contain the actual portal.

To create the portal web project, perform these steps:

1. Select File > New > Project.

The New Project — Select a Wizard dialog box displays.

2. Inthe dialog, select WebLogic Portal > Portal Web Project, as shown in Figure 2-10.
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Figure 2-10 New Project — Select a Wizard Dialog with Portal Web Project Selected
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The New Portal Web Project dialog displays, as shown in Figure 2-11.
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Figure 2-11 New Portal Web Project Dialog
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4. Inthe New Portal Web Project dialog, enter myPortaliiebProject in the Project name
field.

In the Project contents area of the dialog, leave the default setting unchanged.

5. Select the Add project to an EAR check box.

Because myPortalkAR is the only EAR project, it appears in the dropdown menu by
default.

This associates the Portal EAR project that you created previously with this Portal Web
Project.

Tip: Ifyou create a portal web project without associating it with an EAR, you can do this
step later by right-clicking the EAR project in the Package Explorer tree and selecting
Properties; then use the J2EE Module Dependencies setting to associate the project
with the EAR.

6. Click Next.

The New Portal Web Project — Select Project Facets dialog displays, as shown in
Figure 2-12.
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Figure 2-12 New Portal Web Project — Select Project Facets Dialog
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7. Inthe New Portal Web Project — Select Project Facets dialog, verify that the WebLogic
Portal node is selected. Also, be sure that all of the features under the WebLogic Portal node

are selected, as shown in Figure 2-12.

8. Click Finish.

The myPortaliiebProject folder now appears in the Package Explorer view, as shown in
Figure 2-13. If you expand the folder you can see the default library modules and required
directory structure for the project. For more information about the use of Library Modules
in WebLogic Portal, refer to the Portal Development Guide.
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Figure 2-13 Portal Web Project Added to the Package Explorer
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Create a Datasync Project

A datasync project is an optional project that stores general purpose portal services data that is
used in the development of personalized applications and portals. These portal services include
User Profiles, Session Properties, Campaigns and others. You can share a single datasync project
among several EAR projects if you wish.

To create the datasync project, perform these steps:

1. Select File > New > Project.

The Select a Wizard dialog box displays.

2. Inthe dialog, select WebLogic Portal > Datasync Project, as shown in Figure 2-14.

Figure 2-14 New Project—Select a Wizard Dialog with Datasync Project Selected
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3. Click Next.

The Create New Datasync Project — Add Datasync Project dialog displays, as shown in
Figure 2-15.
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Figure 2-15 Create New Datasync Project Dialog
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4. In the Create New Datasync Project — Add Datasync Project dialog, enter myData in the
Project name field.

In the other areas of this dialog, leave the default settings unchanged.
5. Click Next.

The Create New Datasync Project — EAR Projects dialog displays, as shown in
Figure 2-16.
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Figure 2-16 Create New Datasync Project — EAR Projects Dialog
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6. Select the myPortalEAR check box.

This associates the Datasync project with the Portal EAR project that you created
previously.

Tip: If you create a datasync project without associating it with an EAR, you can do this
step later by right-clicking the datasync project in the Package Explorer tree and
selecting Properties; then expand the Datasync node in the tree and select EAR
Projects to associate the project with the EAR.

7. Click Finish.

The myData folder now appears in the Package Explorer window, as shown in Figure 2-17.
If you expand the folder you can see the src folder and the data directory structure for the
project.
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Figure 2-17 Datasync Project Added to the Package Explorer
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Summary

With the completion of this tutorial, you have created the basic required elements of a portal
development environment. These components are created on your file system in your current
workspace.

To learn about some basic portal development tasks using the Workshop for WebLogic
workbench, continue to Chapter 3, “Creating a Portal in Your Development Environment.”
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CHAPTERa

Creating a Portal in Your Development
Environment

This tutorial helps you learn how to create a portal and portlets using WebLogic Portal in the
Workshop for WebLogic workbench. For m ore detailed information about each dialog of the
wizards used in this chapter, refer to the Portal Development Guide.

Before You Begin

The tasks described in this chapter are based on those described in Chapter 2, “Setting Up Your
Portal Development Environment”, so it is important that you complete that tutorial before
starting the tasks described here.

Tutorial Steps

Using the tutorial, you will create a portal and two portlets, create an additional page for the
portal, and then place the portlets onto a page of the portal.

The tutorial includes instructions on how to perform these tasks:

Create a Portal

Add a Page to Your Portal

Deploy and View Your New Portal

Create Portlets

Add Portlets to the Portal and View the Result
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Create a Portal

In this task you will create a portal for the project that you created in “Create a Portal Web

Project” on page 2-12.

To create a portal, perform these steps:

1. If the Portal perspective is not already open, select it by choosing Window > Open

Perspective > Portal.

Using the Portal perspective is optional, but the instructions and figures in this tutorial are

based on the views that are available in the Portal perspective.

2. Navigate to the myPortalWebProject/WebContent directory, right-click and then select

New > Portal.

The New Portal dialog displays, as shown in Figure 3-1.

Because you started this wizard by right-clicking the web content directory, the parent

folder field automatically displays that directory name.

Figure 3-1 New Portal Dialog

W New Portal

New Portal

structure.

Enter or select the parent folder:

A portal is an aggregation of applications and content inko a common, coherent

(X

| myPortalwebProject fwebContent

[y
+-122 myData
+-EF myPortalEAR.
= E myPortalwebProject
= .apt_src
= .settings
+-[= build
= src
+-[>= WebContent

File name: | myPortal

Advanced =

Cancel
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As a best practice, you should locate your portal file in a web content directory that is
subordinate to the web project directory. The default web content directory name is
WebContent, and is assigned when you use the Portal Web Project Wizard. You can

change the name of your web content directory if you wish; for more information, refer to

the Portal Development Guide.

3. In the File name field, enter myPortal.

A file type of .portal is required for portals; you can type the .portal extension to the
portal’s name if you wish, but WebLogic Portal automatically adds the extension if you
don’t enter it.

4. Click Finish.

The wizard adds myPortal.portal to the WebContent folder in the Portal web project
and a view of the portal displays in the workbench, as shown in Figure 3-2.

Figure 3-2 Portal Displayed in Workbench

myPortal.portal X =0

Mew Portal Desktop

Header

Book: Main Page Book:

["] Page 1
Page: Page 1

| Footer |

The created portal includes a desktop, header, footer, book, and page. A desktop is a
user-specific view of the portal content. A portal can support many desktops. A single portal

might support an employee-specific desktop, a customer-specific desktop, and others, where each

BEA WebLogic Portal Tutorial
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desktop exposes different kinds of content to different sets of users. Any part of a portal can be
included or excluded from a desktop, including a book, a page, a specific application, or an
individual link.

Desktops can also define the look and feel attributes of a Portal. Desktops can be associated with
a particular skin that defines the color scheme, fonts, and images used. Desktops also contain a
header and footer—you can place images, text, or any web content in these areas to give
consistency to the look and feel of a desktop.

You use books to organize your content and navigation in a hierarchical manner. Books can
contain other books or pages. In a browser, a book is rendered as a set of tabs or links. Each portal
contains a main book called, by default, “Main Page Book.” A page consists of a set of columns
and/or windows that organize the actual content of your portal. You navigate to a page by clicking
on an individual tab or a link.

Add a Page to Your Portal

In this task you will add a second page to the portal’s main book. When the portal is rendered in
a browser, the two pages will appear as two clickable tabs. You add a new page by dragging and
dropping the new page into the main work area. You will also set properties on the new page
using the Properties view.

To add a new portal page, perform these steps:

1. From the Palette view, drag and drop the Page icon to the area directly to the right of the Page
1 tab. Figure 3-3 shows the result when you release the mouse button.

Tip: If you do not see the Palette tab, select Window > Show View > Palette.
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Figure 3-3 Adding a Page to a Portal in the Workbench
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The new page has a default title of “New Page.” To change it, perform these steps:
1. Click the new page tab to select it.

2. In the Properties view, enter “Page 2” as the new title, as shown in Figure 3-4.

PR W T W "t

When you enter the new value, the editor shows that the title has changed from New Page

to Page 2.
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Figure 3-4 Changing a Page Title in the Workbench Properties View
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3. Save your changes.

Deploy and View Your New Portal

This portal isn’t very interesting yet, but as a quick test, you will deploy your new portal to the
server and view it in a browser window that is contained within Workshop for WebLogic.

Follow these steps:

1. Right-click myPortal.portal in the Package Explorer view and select Run As > Run on
Server, as shown in Figure 3-5.

Figure 3-5 Selecting to Run the Portal on the Server
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=i Library Madule [F Debug as [Y e ; »
=i, Library Module [H Toam . ] 2 Java Applet Ale+Shift+, & J
+ g S:il:c - Compare With v Ef» 3 Java Application Ale+shifte+3, 1 4
= ‘ebConten ] ) ]
i ¥ Ju 4 Uit Plug-in Test Ale+shift+x, P
(= METAINF Replace With i ) (
[ WEB-INF Source ¥| Ju 5 Junit Test alb+shift+, T ||
index. jsp Properties Alk-+Enter |=1| & SWT Application Ale+shift+x, 5 ;
¥
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The Run On Server - Define a New Server dialog displays. Make sure the server that you
created during the previous WebLogic Portal tutorial task is highlighted.

2. Click Finish to begin the deployment process.
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Wait while Workshop for WebLogic starts the server, deploys files to the server, and runs
the application. While deployment is in process, you can view status messages in the status
bar at the bottom of the window.

The results appear in a new tab in the editor view, as shown in Figure 3-6.

Tip: Ifyou previously deployed a project of the same name and that project is in a different
location, you need to undeploy that project. To do this, double-click the server in the
Servers view, and delete myPortalWebProject (not the library modules) from the
Published Modules list. For more information about this task, refer to the “Managing
Servers” section of the Workshop for WebLogic help.

Figure 3-6 Portal Display in the Workbench Editor View

myPortal.portal op =0
2| Bl

Page 1 Page 2

Leave this new tab open; after you add portlets you will refresh this display to view them.

Tip:  You can choose to always use an external web browser to view your portal if you
wish. To do so, select Window > Preferences and select General > Web Browser
in the property tree; then select the Use external Web browser radio button.

Create Portlets

In this task you will create two portlets: a Browser URL portlet and a simple JSP portlet.

Create a Folder to Contain the Portlets

To organize your portlets, it’s a good idea to store them in a subfolder in your web content
directory.

To create a portlet folder, follow these steps:

1. Right-click the webContent directory and select New > Folder.
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The New Folder dialog displays, as shown in Figure 3-7.

Figure 3-7 New Folder Dialog - Create Folder for Portlets

Folder

Create a new folder resource.

Enter or select the parent folder:

B

| myPortalwebProject fwebContent
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+-122 myData
+- =k myPortal EAR
= 'bd myPortalwebProject
= .apt_src
= .settings
+-[= build
= src
+- 2= WebContent

Folder name: | portlsts|

Advanced =

Cancel

2. Type the folder name portlets and click Finish.

Create a Browser URL Portlet

Browser portlets, also called Content URI portlets, are basically HTML portlets that use URLSs to
retrieve their content. Unlike other portlet types that are limited to displaying data contained
within the portal project, browser portlets can display URL content that is outside the portal

project.

To create the browser portlet, perform these steps:

1. Right-click the portlets folder and select New > Portlet.

The New Portlet dialog displays, as shown in Figure 3-8. The folder for the portlet displays

automatically in the parent folder field.
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Figure 3-8 New Portlet Dialog
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Enter or select the parent folder:

Tutorial Steps

m(Ed]

| myPortalwebProjectfwebContent/portlets

+-122 myData
+- =k myPortalEAR
= 'bd myPortalwebProject
= .apt_src
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+-[= build
= src
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File name: |

Advanced =
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Cancel |

The Finish button is initially disabled; the button enables when you select a valid parent
folder and type a portlet name. If you select an invalid portal project in the folder tree on
this dialog, an error message appears in the status area near the top of the dialog explaining

that the project is not a valid portal project.

2. Type myBrowserPortlet as the file name for the new portlet.

3. Click Finish.

The Portlet Wizard displays the Select Portlet Type dialog.

4. Click Browser (URL) Portlet and then click Next.

The Portlet Wizard displays the Portlet Details dialog; Figure 3-9 shows an example.
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Figure 3-9 Creating a Browser URL Portlet - Portlet Details Dialog
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5. Specify the values for this portlet, using Table 3-1 as a guide.

Tahle 3-1 Portlet Wizard - Browser Portlet Data Entry Fields

Field Value/Description

Title BEA Browser Portlet
This value appears in the title bar of the portlet in the editor view
of the Workshop for WebLogic workbench.

Content URL http://www.bea.com
This is the value for the Content URL (external URL) that the
portlet should use to retrieve its information.

Has Titlebar Leave the box checked.
In order for a portlet to have changeable states or modes, the
portlet must have a title bar.

State Select all four check boxes: Minimizable, Maximizable,
Floatable, and Deleteable.

Available Modes  Leave these fields blank.
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6. Click Create.

The Workshop for WebLogic window updates, adding the myBrowserPortlet.portlet
file to the portlets folder and displaying the new portlet in the editor, as shown in
Figure 3-10.

Figure 3-10 New Browser Portlet Displayed in Editor
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Create a JSP Portlet

JSP portlets are very similar to simple JSP files. In most cases you can reuse existing JSP files to
build portlets from them. JSP portlets are recommended when the portlet is simple and does not
require the implementation of complex business logic.

In this task, you will create a simple JSP file and then use that file to generate a portlet.

Follow these steps:

1. Double click the file index.jsp in the Package Explorer view.

The index.jsp file is located in the WebContent directory, and is included with any Portal
Web Project that you create.

The source code for the file displays in an editor view.

2. Change the default body text to Simple JSP Portlet as shown in Figure 3-11.
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Figure 3-11 JSP File Showing Edited Body Text
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3. Select File > Save As and save this JSP file as jsp_portlet.jsp.
4. Dragthe jsp portlet.jsp file into the portlets folder.

5. Right-click jsp_portlet.jsp and select Generate Portlet from the menu.

Because you are generating a portlet from an existing . jsp file, the Portlet Wizard goes
directly to the Portlet Details dialog; Figure 3-12 shows an example.

3-12 BEA WebLogic Portal Tutorial



Tutorial Steps

Figure 3-12 Portlet Wizard - JSP Portlet Details Dialog
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6. Specify the values specified in Table 3-2.

Table 3-2 Portlet Wizard - JSP Portlet Data Entry Fields

Field Value/Description
Title Simple JSP Portlet
Content URI /portlets/jsp_portlet.jsp

Because you are creating this portlet based on an existing JSP file,
WebLogic Portal automatically fills in this value.

Has Titlebar Leave this box checked.

State Select the check boxes Minimizable and Maximizable.

7. Click Create.

The Workshop for WebLogic window updates, adding the jsp _portlet.portlet file to
the portlets folder.

BEA WebLogic Portal Tutorial 3-13



Creating a Portal in Your Development Environment

Checkpoint: Your WebContent directory should look like the example shown in Figure 3-13.

Figure 3-13 WehContent Directory Including Portal, Browser Portlet, and JSP Portlet
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Add Portlets to the Portal and View the Result

In this task you will add your new portlets to the portal and view your changes.

\\_.a\-us‘ﬁ—&u.“,

Follow these steps:
1. In the editor, click the myPortal.portal tab to display it.
2. Click the Page 1 tab in the portal to select it.

3. Dragthe JSP portlet (with the file name jsp_portlet.portlet) onto the left column (placeholder)
of the portal page.

4. Drag the Browser portlet (with the file name myBrowserPortlet.portlet) onto the right
placeholder of the portal page.

Your result should look like the example in Figure 3-14.
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Figure 3-14 Portal in Editor View with Portlets Added
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5. Save your change.

To view the new portlets in a browser, follow these steps:
1. Click to select the New Portal Desktop tab in the editor view.

2. On the toolbar, click Refresh .

Because your change does not require redeploying the change to the server, you do not
need to select the Run on Server option to see the new portlets.

Your updated portal should look like the example shown in Figure 3-15.
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Figure 3-15 Running Portal with Browser Portlet and JSP Portlet Added
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Summary

With the completion of this tutorial, you have created a portal, added a portal page, and created
two new portlets that can be displayed in the portal. These components are created on your file
system in your current workspace.

To learn about creating desktops using the WebLogic Portal Administration console, continue to
Chapter 4, “Assembling a Desktop in Your Staging Environment.”
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Assembling a Desktop in Your Staging
Environment

This tutorial helps you learn how to use the WebLogic Portal Administration Console for some
basic portal organization tasks.

For more detailed information about each dialog of the wizards used in this chapter, refer to the
Portal Development Guide.

Before You Begin

The tasks described in this chapter are based on those described in Chapter 2, “Setting Up Your
Portal Development Environment” and Chapter 3, “Creating a Portal in Your Development
Environment,” so it is important that you complete those tutorials before starting the tasks
described here.

Introduction to the Administration Console

The WebLogic Portal Administration Console is the tool that portal administrators use to not only
control the behavior, content, and appearance of portals, but to perform many traditional system
administration activities such as user management and security management as well. This tutorial
focuses on basic tasks that assemble portals into desktops.

The WebLogic Portal Administration Console is organized according to the following categories
of tasks:

e Portal Management — Portals, desktops, books, pages, portlets, and other portal resources.
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This tutorial describes some of the basic Portal Management tasks. The Portal
Development Guide and Portlet Development Guide provide details about Portal
Management tasks.

User, Groups, & Roles — User and group management, security provider configuration,
Delegated Administration, and Visitor Entitlements.

The User Management Guide and Security Guide provides detailed information about the
tasks in this category.

Configuration Settings — Server settings for Cache Management, Server Maintenance
Mode, Personalization, Security, Unified User Profiles, and WSRP.

The Security Guide, Portal Development Guide, Federated Portals Guide, Interaction
Management Guide, and User Management Guide provide detailed information about the
tasks in this category.

Interaction Management — Campaigns, Placeholders, User Segments, And Content
Selectors.

The Interaction Management Guide provides detailed information about the tasks in this
category.

Content Management — Content and repositories.

The Content Management Guide provides detailed information about the tasks in this
category.

Tutorial Steps

Using the tutorial, you will create a portal desktop based on the portal and portlets created
previously, make some modifications to your desktop, and then view your results.

42

The tutorial includes instructions on how to perform these tasks:

Open the Administration Console

Log in to the Administration Console

Create a Portal and Desktop

Update the Desktop Page Contents to Rearrange Portlets

Create a New Page on the Desktop
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Open the Administration Console

Before you can begin using the WebLogic Portal Administration Console, the server must be
running. Depending on the state of your Workshop for WebLogic workbench, you might need to
start the server before opening the Administration Console.

If you are continuing from Chapter 3, “Creating a Portal in Your Development Environment,”
and you have not closed/opened Workshop for WebLogic, you can skip to Step 4.

If you closed Workshop for WebLogic after finishing the tutorial in Chapter 3, “Creating a Portal
in Your Development Environment,” follow these steps:

1. Start Workshop for WebLogic and return to the workspace that you used for the previous
tutorials:

2. Inthe Servers view, click the server to select it.

3. Click Start @ in the Servers view toolbar.

Wait while Workshop for WebLogic starts the server. This process might take some time,
depending on the speed of your system.When the process completes, the Status column in
the Servers view displays Started and the square Stop the Server button g becomes

active.
4. Click myPortal.portal in the Package Explorer view to select it.

5. From the main menu, select Run > Open Portal Administration Console, as shown in the
example in Figure 4-1.

Figure 4-1 Menu Selection for Run > Open Portal Administration Console

Window  Help

% Run Last Launched Chrl+F11
%, Debug Last Launched Fi1
Run Histary 4
Run As L4
e A o e e F N

E Portal Cache Manager

Open Portal Administr: ale...

13 Add Java Exception Breakpaint. ..
® add Class Load Breakpoint. ..
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The Administration Console opens in a new tab in the workbench editor view, with the
login dialog displayed, as Figure 4-2 shows.

Figure 4-2 WebLogic Portal Administration Console Login Dialog
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Sign in to work with \WeblLogic Portal

Username: | |

Password: | |

Log in to the Administration Console

The Administration Console login dialog requires a WebLogic Server system administrator or a
WebLogic Portal administrator user name and password. WebLogic Server system
administrators have full security privileges for the entire domain and can log in to and use the
WebLogic Server Administration Console tools. WebLogic Portal administrators have full
security privileges for a Portal Web Project, which can include multiple portals.

Table 4-1 shows the default system administrator user names and passwords:

Table 4-1 Default User Names and Passwords for the WebLogic Portal Administration Console

User Name Password Description
portaladmin portaladmin Administrator for the portal domain
weblogic weblogic WebLogic Server system administrator with full

privileges in the domain

For purposes of this tutorial, you will use the default WebLogic Server login so that you have full
privileges.

To log in to the WebLogic Portal Administration Console, follow these steps:
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1. Type the user name weblogic and password weblogic into the dialog and click Sign In.
The main menu of the Administration Console displays.

2. To get a better view of the console and its functions, click Maximize (5] in the editor view
toolbar. Your display should look like the example in Figure 4-3.
Note: If you set up your Workshop for WebLogic preferences to open external browsers
instead of the internal browser, you do not need to perform this step.

Figure 4-3 Administration Console Main Page, Maximized
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Create a Portal and Desktop

To create a desktop, you first create a portal to contain it.
To create a portal and desktop, follow these steps:
1. Click the Portal Management menu shortcut on the Administration Console home page.

The Portal Management page displays; the Portal Resources tree displays in the left pane
of the page, as shown in Figure 4-4.
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Figure 4-4 Portal Resources Tree in the Administration Console
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Notice that the display is based on the Portal Web Project that you created in Chapter 3,
“Creating a Portal in Your Development Environment.” if you expand the Library >
Portlets portion of the tree, you can see the portlets that you created earlier.

2. Click Portals in the tree.

The Portals page displays, with the Browse Portals tab active. Because no portals exist yet,
the table containing portals is empty.

3. Click Create New Portal.
The Create a New Portal dialog displays, as shown in Figure 4-5.

Figure 4-5 Create a New Portal Dialog in Administration Console

Create a New Portal

Paortal Marme: * |myBEAportal
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4. Enter values for the portal, using Table 4-2 as a guide:
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Table 4-2 Create a New Portal Dialog Field Descriptions

Field Value/Description
Portal Name myBEAportal
Description general BEA portal
Partial URL myBEAportal

URI (default resource) (leave blank)

5. Click Create New Portal.

When the Portals page displays again, the Browse Portals table includes the portal you
created, and the Portal Resources tree includes the new portal.

6. Click myBEAportal in the Browse Portals table to view the details for this portal.

The Portals page displays, with the Browse Desktops tab active. Because no desktops exist
yet, the table containing desktops is empty.

7. Click Create New Desktop.
The Create Desktop wizard displays, as shown in Figure 4-6.
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Figure 4-6 Create Desktop Wizard in Administration Console

f“& Create Desktop

Create Desktop: Step 1 of 5

Select Create Method

) Use a Desktop Template

contents to quickly get your desktop up and running.

Enter Desktop Properties

) Select resources in the Library

Review Properties resources and provide additional desktop properties,

Finish Select a .portal file

desktop properties.

Select how you want to create a desktop, and click Next.

Select Source Choose from a list of templates that define the desktops's shell, look and feel, and

Choose the primary book, shell, and look and feel for your desktop from available

Select from a list of Jportal files in the current webapp, and provide additional

| Previous | | Finizh | | Cancel |

8. Enter values for the desktop in the appropriate wizard pages, using Table 4-3 as your guide:

Table 4-3 Create Desktop Wizard Field Descriptions

Field or Selection Value/Description

Step 1: Select how you 1. Select a .portal file radio button.
want to create a desktop... 7 (]ick Next.
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Tahle 4-3 Create Desktop Wizard Field Descriptions (Continued)

Field or Selection Value/Description
Step 2: Search for 1. Click Show All.
templates

The portal you created using Workshop for
WebLogic displays in the list.

2. Click to select myPortal.portal.
Click Next.

Step 3: Enter desktop * Title — myDesktop
properties... + Description — general desktop
+ Partial URL — desktopl

*  Default Shell — (leave as is)

* Look and Feel — (Ieave as is)

9. Click Next to review the desktop properties, and Next again to create the desktop.

A confirmation dialog confirms that the desktop has been created and displays related
information.

10. Click Finish to return to the main Administration Console page.

The Browse Desktops table includes the desktop you created, and the Portal Resources tree
includes the new desktop, as shown in Figure 4-7, which shows the expanded tree.

Figure 4-7 New Desktop in Portal Resources Tree

Home = Portal = Portal Management P

b |
Portal Resources for : myPortalWebProjecy

Update Webhipp

EE’J Portal Resources
= Library
Bl Portals
B myBEAportal
iECommunities
-1l Templates
=5 myDesktop
=i Main Page Book
B[ Page 1
[ simple ISP Portiet ;
_ BEA Browser Partlet
[ Paga 2

My et A P Ak

Notice that the portlets that you created for this portal (which was used as the template for
this desktop) appear automatically in the new desktop.
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Update the Desktop Page Contents to Rearrange Portlets

In this task you view the portlets for a desktop page—the portlets that you created using
Workshop for WebLogic—and rearrange them on the page. Then you will view your work.

To update your desktop page, follow these steps:

1. Inthe Portal Resources tree for myPortal WebProject, expand the tree to display the pages for
the desktop, as shown in Figure 4-8.

Figure 4-8 Expanded Portal Resources Tree Showing Desktop Pages

Home = Portal = Portal Management P

-~

Portal Resources for : myPortalWebProje

Update Webhipp

EE’J Portal Resources
= Library
Bl Portals
B myBEAportal
EmCommunities
-1l Templates
=5 myDesktop
=i Main Page Book
E-[J Page 1
Simple 15P Portlet 4
BEA Browser Portlet®

A M e A P e

2. Click Page 1 to select it.
The Page 1 details display in the right pane of the Administration Console.

3. Select the Edit Contents tab; it appears, as shown in Figure 4-9.
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Figure 4-9 Page 1 Edit Contents Tab

D Page 1 L5 Move

Details | | Edit Contents | Entitlements | Delegated Admin

J
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Layout: | Twa Calumn Layout Position Elements: & sing Drag & Dro
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[ Addl Contents | | [ Add Cortents
A hlew Book : i hlew Book

Save Changes
- PP P T Sy o el P SR

4. Drag the BEA Browser Portlet into the same placeholder as the Simple JSP Portlet, as shown
in Figure 4-10.

¥
AL AN L AT N b

g TN

o

Figure 4-10 Moving the BEA Browser Portlet by Dragging

[,

| JPage 1 ;

Details | | Edit Contents | Entitlements | Delegated Admin ¢
Help Topics ;

i

Layout: | Two Column Layout v Position Elements: @ Using Dw,
OManuay
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BE4 Bruwser%u{tlet 2’3\

[k Add Contents || [ #ed Contents
dscld Mewr Book : dscld Mewr Book

Save Changes
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When you release the portlet, it displays above the Simple JSP Portlet, as shown in
Figure 4-11.
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5. Click Save Changes.

Figure 4-11 Result After Moving the BEA Browser Portlet in the Administration Console
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¢
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6. In the Portal Resources tree, click myDesktop to display the Details page.
7. Click View Desktop.

The desktop displays in a browser, with the portlets in their new positions, as shown in
Figure 4-12.
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Figure 4-12 Desktop in Browser Showing Moved Portlets
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Create a New Page on the Desktop

In this task, you will create a new page for your desktop. Follow these steps:

1. In the Portal Resources tree for myPortal WebProject, expand the Library node in the tree to
display the pages, as shown in Figure 4-13.

Figure 4-13 Expanded Portal Resources Tree Showing Desktop Pages

Update Webhipp

Portal Resources for : myPortalWebProject

E|*-=-°3 Portal Resources
E-f Library
- Partlets

1l Books

H- {5 Layouts
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[ G Page 2

b
b
b
b
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o EBIE s ]

2. Click Pages to display the Browse Pages tab, as shown in Figure 4-14.
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Figure 4-14 Browse Pages Tah

E Pages

Browse Pages | Entitlements | Delegated Admin

Help Topics..

Search Pages

Page title | starts with V||

|| %Search| | %Clear Search

MNote: search is case sensitive
¥ advanced Search Options

Browse Pages in Library
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3. Click Create New Page.

Title Description Last Modified Delete
]
Fage 1 Mar 19, 2006 .}
Fage 2 Mar 19, 2006
@ Previous | Mext @ Ttems per page
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The Create New Page dialog displays, as shown in Figure 4-15.

Figure 4-15 Create New Page Dialog in Administration Console

=
|_¥' Create New Page

Title: * |Tut0ria| Phge |

Description: | new page for tutorial

Layout: |Three Colurnn Layout V|

Therne |N0ne v|

* Required information

[ Edit page contents now
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4. Enter values for the new page, using Table 4-4 as a guide:

Table 4-4 Create New Page — Field Descriptions

Field Value/Description
Title Tutorial Page
Description new page for tutorial
Layout Three Column Layout
Theme (leave as is - None)

5. Click Create.

Summary

The new page is added, and is displayed in the Details page for the desktop; the Portal

Resources tree updates to include the new page, as shown in Figure 4-16.

Figure 4-16 New Page Added to the Portal Resources Tree

Summary
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G LATemgatE . L . .

With the completion of this tutorial, you have created a basic desktop and performed some
additional tasks to become familiar with the staging environment and the WebLogic Portal

Administration Console.

To get started with actual portal development and desktop staging, refer to WebLogic Portal

document library on e-docs.

BEA WebLogic Portal Tutorial

4-15


http://edocs.bea.com/wlp/docs92/index.html

Assembling a Desktop in Your Staging Environment

4-16 BEA WebLogic Portal Tutorial



	Introduction
	Introduction

	Setting Up Your Portal Development Environment
	Before You Begin
	Tutorial Steps
	Create a Portal Domain
	Create a Portal EAR Project
	Associate the EAR Project with the Server
	Create a Portal Web Project
	Create a Datasync Project

	Summary

	Creating a Portal in Your Development Environment
	Before You Begin
	Tutorial Steps
	Create a Portal
	Add a Page to Your Portal
	Deploy and View Your New Portal
	Create Portlets
	Create a Folder to Contain the Portlets
	Create a Browser URL Portlet
	Create a JSP Portlet

	Add Portlets to the Portal and View the Result

	Summary

	Assembling a Desktop in Your Staging Environment
	Before You Begin
	Introduction to the Administration Console
	Tutorial Steps
	Open the Administration Console
	Log in to the Administration Console
	Create a Portal and Desktop
	Update the Desktop Page Contents to Rearrange Portlets
	Create a New Page on the Desktop

	Summary



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /FRA <>
    /ENU (Use these settings to create PDF documents with higher image resolution for improved printing quality. The PDF documents can be opened with Acrobat and Reader 5.0 and later.)
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308000200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e30593002537052376642306e753b8cea3092670059279650306b4fdd306430533068304c3067304d307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e30593002>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
  >>
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


