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Introduction

Introduction

The tutorials presented in this document introduce you to some of the common tasks you perform
in developing the pieces of a portal project and organizing those parts into a version that end users
see. The tools you use to perform these tasks include WorkSpace Studio and BEA WebL ogic
Portal, including the WebLogic Portal Administration Console.

This document describes the following tasks, organized by chapter:

e Chapter 2, “Setting Up Your Portal Development Environment”
e Chapter 3, “Creating a Portal in Your Development Environment”

e Chapter 4, “Assembling a Desktop in Your Staging Environment”

BEA WebLogic Portal Tutorial 1-1



Introduction

1-2 BEA WebLogic Portal Tutorial



CHAPTERa

Setting Up Your Portal Development
Environment

This tutorial helps you prepare your WorkSpace Studio environment for portal development.

For more detailed information about each dialog of the wizards used in this chapter, refer to the
Portal Development Guide.

Before You Begin

Before starting this tutorial, do the following:
o Install WorkSpace Studio and WebL ogic Portal.

e Complete the tutorial “Getting Started with Workshop” located in the BEA Workshop
User’s Guide.

This task is optional, but if you are unfamiliar with the Eclipse development environment
on which WorkSpace Studio is based, the Getting Started tutorial is highly recommended,;
the tutorial shows you how to start WorkSpace Studio and navigate the workbench user
interface, introduces terminology associated with the workbench, and shows you how to
create a simple web application.

Tutorial Steps

Using the tutorial, you will perform tasks that are required to get your WorkSpace Studio
environment ready for portal development.

The tutorial includes instructions on how to perform these tasks:
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Create a Portal Domain

Create a Portal EAR Project

Associate the EAR Project with the Server
e Create a Portal Web Project

e Create a Datasync Project

In your actual development environment you do not need to follow the order of the steps as
presented in this tutorial; for example, you can create the portal domain after performing all the
other steps. However, we recommend that you follow the steps as presented here so that you can
easily see the relationships among the parts of a portal project.

Create a Portal Domain

The portal domain is a group of WebLogic Server resources that contain the application server
used by the portal. You must have a server domain that is WebLogic Portal-enabled in order to
test the portal that you create. This customized domain is generally called a portal domain.

To create a portal domain, perform these steps:
1. Start WorkSpace Studio.

2. When asked to select a workspace, click Browse and select (or create) a workspace folder.
Follow the dialog prompts as appropriate. For this tutorial, we recommend that you create a
new workspace.

If necessary, dismiss the Welcome screen to display the workbench.

3. If the Portal perspective is not already open, select it by choosing Window > Open
Perspective > Other > Portal.

The instructions and figures in this tutorial are based on the views that are available in the
Portal perspective.

4. Choose File > New > Other.

The New — Select a Wizard dialog displays, as shown in Figure 2-1.
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Figure 2-1 New — Select a Wizard Dialog
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5. Expand Server in the tree, click Server in the expanded tree, and then click Next.

The New Server — Define a New Server dialog displays, as shown in Figure 2-2.
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Figure 2-2 New Server — Define a New Server Dialog

W New Server [Z|
Define a New Server

Choose the type of server to create
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Select the server bype:
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= Apache
[=)-[= BEA Systems
G eblogic

Description: BEA WebLogic Server 10,0

Server runtime: |BEA WeblLogic w10.0 w | [Installed Runtirmes. .. ]
@

6. Inthe tree, verify that BEA Systems, Inc. is expanded and that BEA WebL ogic v10.0 Server
is selected. The host name localhost is shown in the Host name field. For the tutorial, leave
this entry unchanged.

7. Click Next.
The New Server — BEA WebLogic Server v10.0 dialog displays, as shown in Figure 2-3.
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Figure 2-3 New Server — New BEA WebLogic Server Dialog
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Tutorial Steps

8. Click the link that is labeled Click here to launch Configuration Wizard to create a new

domain.

The BEA WebLogic Configuration Wizard starts, as shown in Figure 2-4.
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Figure 2-4 BEA WebLogic Server Configuration Wizard
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9. Follow the wizard prompts and enter the values shown in Table 2-1. Click Next as appropriate
to continue through the wizard.

Table 2-1 Configuration Wizard Values

In this Wizard Page... Select or Enter...

Welcome Create a new WebLogic domain (the default)

Select Domain Source In the Generate a domain configured automatically to
support the following BEA products list, select WebLogic
Portal.

Notice that a WebLogic Portal Collaboration Repository and
GroupSpace check box is available on this wizard dialog; portal
projects that use these features must have domains that include
them. This tutorial does not use either of these features, so they
can remain unselected.

2-6 BEA WebLogic Portal Tutorial



Tutorial Steps

Table 2-1 Configuration Wizard Values (Continued)

In this Wizard Page... Select or Enter...

Configure Administrator Username User name: weblogic

and Password User password: weblogic

Confirm user password: weblogic

Configure Server Start Mode and JDK ¢  Development Mode (the default)
» JRockit SDK (recommended)

Customize Environment and Services  No (the default)
Settings

Create WebLogic Domain Domain name: myPortalDomain

Domain location: Accept the default, or specify another
directory on your system.

10. When you are finished with these entries, click Create in the Create WebLogic Domain
dialog.

The Creating Domain status page appears, indicating the progress of the domain creation.
11. When the domain is created, click Done.

The display returns to the New Server — BEA WebLogic Server v10.0 dialog.

12. Click Browse and navigate to the directory of the domain that you just created. By default,
the path is <BEA_HOME>/user_projects/domains/myPortalDomain.

13. In the Browse for Folder dialog, select the domain directory and click OK to return to the
Define a New Server — BEA WebLogic Server v10.0 dialog.

14. Click Finish.

The new server displays in the Servers view in the WorkSpace Studio workbench, and a
Servers node is added to the tree in the Package Explorer view. Figure 2-5 shows the
Servers view and the new server.

For now, you do not need to start the server. Later in this tutorial, you will create a simple
portal application, start the server, and run the portal application on the server.

BEA WebLogic Portal Tutorial 2-1



Setting Up Your Portal Development Environment

2-8

$ 0 D =

State o

Republish

Create a Portal EAR Project

An EAR project collects the component projects of the application for deployment; you create
one EAR project per enterprise application. The EAR project contains JAR files, deployment
descriptors, build files, and auto-generated files. For more information about EAR projects and
their relationship to the other projects in the workbench, refer to the “Applications and Projects”
topic in the WorkSpace Studio Help.

In this task, you will create an Enterprise Application (EAR) project that is customized to contain
WebLogic Portal information. For more information about the Portal EAR Project, refer to the
Portal Overview.

To create a Portal EAR project, perform these steps:

1. Be sure you have set up the example environment and domain, as explained previously in
“Create a Portal Domain” on page 2-2.

2. From the File menu, select New > Portal EAR Project.

3. Inthe New Portal EAR Project dialog, enter myPortal EAR in the Project Name field, leave
the other entry fields unchanged, and click Next.

The New Portal EAR Project — Project Facets dialog displays.

4. Inthe New Portal EAR Project — Project Facets dialog, verify that WebLogic Portal and all
features that fall under the WebL ogic Portal node are selected, as shown in Figure 2-6.
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Figure 2-6 New Portal EAR Project — Select Project Facets Dialog
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The selections WebL ogic Portal (Optional) and WebL ogic Portal Collaboration are also
available here. These selections are not needed for the tutorial; leave them unselected. For

more information about what happens when you select these options, refer to the Portal
Development Guide.

5. Click Finish.

The Portal EAR Project node is added to the Package Explorer view, as shown in

Figure 2-7. If you expand the folder you can see the EAR content folder and the required
APP-INF and META-INF directories for the project.

Figure 2-7 Package Explorer View including Portal EAR Project

% Package Explorer X

=I-fz= EarContent
+- (= APP-INF

+- 3% META-INF ﬁ
I 4

N S
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Note: The error icon on the EAR folder appears because the Portal EAR Project references
library modules that have not yet been added to the project. Later in this tutorial when
you create a Portal Web Project, the library modules will be added and the error icon will
disappear when WorkSpace Studio automatically rebuilds the workspace.

Associate the EAR Project with the Server

You need to explicitly associate the EAR project with the server that you created previously, so
that later you can test the project on that server.

To associate the Portal EAR Project with the server, perform these steps:

1. Inthe Servers view (as shown in Figure 2-5), right-click BEA WebLogic v10.0 Server, then

select Add and Remove Projects.

The Add and Remove Projects dialog displays, as shown in Figure 2-8.

Figure 2-8 Add and Remove Projects Dialog

‘%

Add and Remove Projects

Available projects:

|8 myPartalEar

Modify the projects that are configured on the server

Move projects to the right to configure them on the server

Add =
[ |

Add all ==

]|

Configured projects:

| Finish | Cancel |

2. Click to select myPortalEAR in the Available projects column and then click Add.

The project is added to the Configured projects column on the right.
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3. Click Finish.

The Portal EAR Project is now associated with the server. To verify this, in the Servers
view you can expand the server node to view the server’s associated projects. The
myPortal EAR project should be shown as a subordinate node.

Create a Portal Web Project

In this task you create the web project that will contain the actual portal.

To create the portal web project, perform these steps:

1. Select File > New > Portal Web Project. The New Portal Web Project dialog displays, as
shown in Figure 2-9.

Figure 2-9 New Portal Web Project Dialog

VW New Portal Web Project g|
B
New Portal Web Project @
Project name: | myPortalwebProject
Project conkents:
Use default
Target Runkirme
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Configurations
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EAR Membership
Add project to an EAR.
EAR Project Mame: | Viasie] =l w
@ [ Mext = ] [ Finish ] [ Cancel ]

2. Inthe New Portal Web Project dialog, enter myPortalWebProject in the Project name
field.

In the Project contents area of the dialog, leave the default setting unchanged.
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3. Select the Add project to an EAR check box.

Because myPortalEAR is the only EAR project, it appears in the dropdown menu by

default.

This associates the Portal EAR project that you created previously with this Portal Web

Project.

4. Click Next.

The New Portal Web Project — Project Facets dialog displays.

5. Inthe New Portal Web Project — Select Project Facets dialog, verify that the WebL ogic
Portal node is selected. Also, be sure that all of the features under the WebL ogic Portal node

are selected, as shown in Figure 2-10.

Figure 2-10 New Portal Web Project — Select Project Facets Dialog

VW New Portal Web Project g|
Project Facets 3
‘Workshop Facet For BEA Kodo, \)
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= weblogic Partal
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|=| Portal Framewark 10.2.0
= Portal Framework Struts 10,2,0_1.2 ..,
|Z] Portal Yisitor Taals 10.2.0
|=| Portal Web Application Se 10.2.0
|=] WSRP Producer 10.2.0
#-[1 |=| WebLoaic Portal {Ootional) 9
<< Show Runtimes
@ < Back ][ Mext = ] [ Finish ] [ Cancel

6. Click Finish.

The myPortalWebProject folder now appears in the Package Explorer view, as shown in
Figure 2-11. If you expand the folder you can see the default library modules and required
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directory structure for the project. For more information about the use of Library Modules
in WebLogic Portal, refer to the Portal Development Guide.

Figure 2-11 Portal Web Project Added to the Package Explorer
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Create a Datasync Project

A datasync project is an optional project that stores general purpose portal services data that is
used in the development of personalized applications and portals. These portal services include
User Profiles, Session Properties, Campaigns and others. You can share a single datasync project
among several EAR projects if you wish.

Tip:  For more detailed information on the Create New Datasync Project wizard, see Portal
Dataysnc Project Wizard in the Portal Development Guide.

To create the datasync project, perform these steps:

1. Select File > New > Datasync Project. The Create New Datasync Project — New Datasync
Project dialog displays, as shown in Figure 2-12.

Figure 2-12 Create New Datasync Project Dialog

New Datasync Project

Project name must be specified

Project name: |

Use default location

Datasync Source Folder

() Use project as source Folder

(%) Use a local directory as source Folder

Mame: | ste

[ Link ta folder in the fils system

Create default project directories
Create default project files
EAR Membership

Add project to an EAR.
EAR Project Mame |myPortalEAR v| [New... ]
@
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2. Inthe Create New Datasync Project — New Datasync Project dialog, enter myData in the
Project name field.

In the other areas of this dialog, leave the default settings unchanged.

3. Click Next.

The Create New Datasync Project — EAR Projects dialog displays, as shown in
Figure 2-13.

Figure 2-13 Create New Datasync Project — EAR Projects Dialog

EAR Projects
Select the EAR projects which will utilize this datasync project.

[ = rvPortalEar

< Back | | Finish | Cancel

4. Be sure the myPortalEAR check box is selected.

This associates the Datasync project with the Portal EAR project that you created
previously.

Tip:  If you create a datasync project without associating it with an EAR, you can do this
step later by right-clicking the datasync project in the Package Explorer tree and
selecting Properties; then expand the Datasync node in the tree and select EAR
Projects to associate the project with the EAR.
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5. Click Finish.

The myData folder now appears in the Package Explorer window, as shown in Figure 2-14.
If you expand the folder you can see the src folder and the data directory structure for the
project.

Figure 2-14 Datasync Project Added to the Package Explorer

B2 ryDaka

B sre

""" = campaigns

""" = catalog

[#-[= contentselectors
[#-[= discounts
[#-[= events

""" = placehalders

""" = propset

[#-[= request

[#-[= segments

""" = session

[#-[= userprofiles !
----- wsrpregistrﬂnpm}ertigs ,/’

oY

Summary

With the completion of this tutorial, you have created the basic required elements of a portal
development environment. These components are created on your file system in your current
workspace.

To learn about some basic portal development tasks using the WorkSpace Studio workbench,
continue to Chapter 3, “Creating a Portal in Your Development Environment.”
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CHAPTERa

Creating a Portal in Your Development
Environment

This tutorial helps you learn how to create a portal and portlets using WebLogic Portal in the
WorkSpace Studio workbench. For m ore detailed information about each dialog of the wizards
used in this chapter, refer to the Portal Development Guide.

Before You Begin

The tasks described in this chapter are based on those described in Chapter 2, “Setting Up Your
Portal Development Environment”, so it is important that you complete that tutorial before
starting the tasks described here.

Tutorial Steps

Using the tutorial, you will create a portal and two portlets, create an additional page for the
portal, and then place the portlets onto a page of the portal.

The tutorial includes instructions on how to perform these tasks:

e Create a Portal

Add a Page to Your Portal

Deploy and View Your New Portal

Create Portlets

Add Portlets to the Portal and View the Result

BEA WebLogic Portal Tutorial 3-1
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Create a Portal

In this task you will create a portal for the project that you created in “Create a Portal Web
Project” on page 2-11.

To create a portal, perform these steps:

1. If the Portal perspective is not already open, select it by choosing Window > Open
Perspective > Portal.

Using the Portal perspective is optional, but the instructions and figures in this tutorial are
based on the views that are available in the Portal perspective.

2. Navigate to the myPortalWebProject/WebContent directory, right-click and then select
New > Portal.

The New Portal dialog displays, as shown in Figure 3-1.
Because you started this wizard by right-clicking the web content directory, the parent
folder field automatically displays that directory name.

Figure 3-1 New Portal Dialog

M (D}

ew Portal
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| myPortalwebProject fwebContent
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File: name: |

®
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As a best practice, you should locate your portal file in a web content directory that is
subordinate to the web project directory. The default web content directory name is
WebContent, and is assigned when you use the Portal Web Project Wizard. You can

change the name of your web content directory if you wish; for more information, refer to

the Portal Development Guide.

3. In the File name field, enter myPortal.

A file type of _portal is required for portals; you can type the .portal extension to the
portal’s name if you wish, but WebL ogic Portal automatically adds the extension if you
don’t enter it.

4. Click Finish.

The wizard adds myPortal .portal to the WebContent folder in the Portal web project
and a view of the portal displays in the workbench, as shown in Figure 3-2.

Figure 3-2 Portal Displayed in Workbench

myPortal.portal X =0

Mew Portal Desktop

Header

Book: Main Page Book:

["] Page 1
Page: Page 1

| Footer |

The created portal includes a desktop, header, footer, book, and page. A desktop is a
user-specific view of the portal content. A portal can support many desktops. A single portal

might support an employee-specific desktop, a customer-specific desktop, and others, where each

BEA WebLogic Portal Tutorial
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desktop exposes different kinds of content to different sets of users. Any part of a portal can be
included or excluded from a desktop, including a book, a page, a specific application, or an
individual link.

Desktops can also define the look and feel attributes of a Portal. Desktops can be associated with
a particular skin that defines the color scheme, fonts, and images used. Desktops also contain a
header and footer—you can place images, text, or any web content in these areas to give
consistency to the look and feel of a desktop.

You use books to organize your content and navigation in a hierarchical manner. Books can
contain other books or pages. In a browser, a book is rendered as a set of tabs or links. Each portal
contains a main book called, by default, “Main Page Book.” A page consists of a set of columns
and/or windows that organize the actual content of your portal. You navigate to a page by clicking
on an individual tab or a link.

Add a Page to Your Portal

In this task you will add a second page to the portal’s main book. When the portal is rendered in
a browser, the two pages will appear as two clickable tabs. You add a new page by dragging and
dropping the new page into the main work area. You will also set properties on the new page
using the Properties view.

To add a new portal page, perform these steps:

1. From the Design Palette view, drag and drop the Page icon to the area directly to the right of
the Page 1 tab. Figure 3-3 shows the result when you release the mouse button.

Tip:  If you do not see the Design Palette tab, select Window > Show View > Design
Palette.
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Figure 3-3 Adding a Page to a Portal in the Workbench
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The new page has a default title of “New Page.” To change it, perform these steps:

1. Click the new page tab to select it.
2. Inthe Properties view, enter “Page 2” as the new title, as shown in Figure 3-4.

When you enter the new value, the editor shows that the title has changed from New Page
to Page 2.
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Figure 3-4 Changing a Page Title in the Workbench Properties View
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3. Save your changes.

Deploy and View Your New Portal

This portal isn’t very interesting yet, but as a quick test, you will deploy your new portal to the
server and view it in a browser window that is contained within WorkSpace Studio.

Follow these steps:

1. Right-click myPortal .portal in the Package Explorer view and select Run As > Run on
Server, as shown in Figure 3-5.

Figure 3-5 Selecting to Run the Portal on the Server

Refactor Ale+shift+T »

4
£2g Import... ¢
£ Export... '

L.
P Refresh F5 3

Yalidate ;
Convert To Community File,.. )
Run As 4 1Runo Alb+shift+¥, R
Debug As
Team v G Run. <
Compare With 4 f
Replace With L4 -
Source L4 (i
e P s, A v AbIEHErbEe PN W = l‘)
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The Run On Server - Define a New Server dialog displays. Make sure the server that you
created during the previous WebLogic Portal tutorial task is highlighted.

Tip:  When you select Run On Server, the portal web application is automatically published.
Publishing involves copying project files, such as resource and configuration files, to the
correct location for the server to locate and use them. WorkSpace Studio detects
whenever a file changes that requires republishing. When this happens, the state of the
server changes to Republish. (You can see this reflected in the Servers view.) To
republish the application, you can right-click the server in the Servers view and select
Publish, select the Publish icon, or select the portal in the Project view and pick Run As
> Run On Server.

2. Click Finish to begin the deployment process.

Wait while WorkSpace Studio starts the server, deploys files to the server, and runs the
application. While deployment is in process, you can view status messages in the status bar
at the bottom of the window.

The results appear in a new tab in the editor view, as shown in Figure 3-6.
Figure 3-6 Portal Display in the Workbench Editor View

550 myPartal.partal # New Portal Desktop X =8
= | = B

Page 1 Page 2

Leave this new tab open; after you add portlets you will refresh this display to view them.

Tip:  You can choose to always use an external web browser to view your portal if you
wish. To do so, select Window > Preferences and select General > Web Browser
in the property tree; then select the Use external Web browser radio button and pick
a browser type from the list. If no browsers appear in the list you can search for
available browsers and add them to the list.

BEA WebLogic Portal Tutorial 3-1



Creating a Portal in Your Development Environment

Create Portlets

In this task you will create two portlets: a Browser URL portlet and a simple JSP portlet.

Create a Folder to Contain the Portlets
To organize your portlets, it’s a good idea to store them in a subfolder in your web content

directory.

To create a portlet folder, follow these steps:

1. Right-click the webContent directory and select New > Folder.

The New Folder dialog displays, as shown in Figure 3-7.

Figure 3-7 New Folder Dialog - Create Folder for Portlets

Folder

Create a new folder resource.

Enter or select the parent folder:

| myPortalwebProject fwebContent

[
+-122 myData
+- =k myPortal EAR
= 'bd myPortalwebProject
= .apt_src
= .settings
+-[= build
= src
+- 2= WebContent

Folder name: | portlsts|

Advanced =

Cancel

2. Type the folder name portlets and click Finish.
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Create a Browser URL Portlet

Tutorial Steps

Browser portlets, also called Content URL portlets, are basically HTML portlets that use URLS
to retrieve their content. Unlike other portlet types that are limited to displaying data contained
within the portal project, browser portlets can display URL content that is outside the portal

project.

To create the browser portlet, perform these steps:

1. Right-click the portlets folder and select New > Portlet.

The New Portlet dialog displays, as shown in Figure 3-8. The folder for the portlet displays

automatically in the parent folder field.
Figure 3-8 New Portlet Dialog

W New Portlet

New Portlet

The file' name is empty,

Enter or select the parent folder:

m(Ed]

| myPortalwebProjectfwebContent/portlets

+-122 myData
+- =k myPortalEAR
= b‘J myPortalwebProject
= .apt_src
= .settings
+-[= build
= src
= [>= WebContent
(= META-INF
= portlets
+- 22 WEB-INF

File name: |

Advanced =

EE

Cancel |

The Finish button is initially disabled; the button enables when you select a valid parent
folder and type a portlet name. If you select an invalid portal project in the folder tree on
this dialog, an error message appears in the status area near the top of the dialog explaining

that the project is not a valid portal project.

2. Type myBrowserPortlet as the file name for the new portlet.
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3. Click Next.
The Portlet Wizard displays the Select Portlet Type dialog.
4. Click Browser (URL) Portlet and then click Next.
The Portlet Wizard displays the Portlet Details dialog; Figure 3-9 shows an example.

Figure 3-9 Creating a Browser URL Portlet - Portlet Details Dialog
- x|

sees: Portlet Details

1. Select Portlet Type
2. Portlet Details

Please fill in the general details for the partlet.

Title : |BEA Browser Portiet

Content URL : [ttp:/fwwn bea.com

[ Has TitleBar

State : Available Modes

I+ Minimizable [~ Help ,7 A M
[¥ Maximizable [~ Edit ’7 J M

[ Floatable

[V Deletable

Previous | ‘ Create I Cancel

5. Specify the values for this portlet, using Table 3-1 as a guide.

Table 3-1 Portlet Wizard - Browser Portlet Data Entry Fields

Field Value/Description

Title Browser Portlet

This value appears in the title bar of the portlet in the editor view
of the WorkSpace Studio workbench.

Content URL http://lwww.bea.com

This is the value for the Content URL (external URL) that the
portlet should use to retrieve its information.
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Tahle 3-1 Portlet Wizard - Browser Portlet Data Entry Fields

Field Value/Description

Has Titlebar Leave the box checked.

In order for a portlet to have changeable states or modes, the
portlet must have a title bar.

State Select all four check boxes: Minimizable, Maximizable,
Floatable, and Deleteable.

Available Modes  Leave these fields blank.

6. Click Create.

The WorkSpace Studio window updates, adding the myBrowserPortlet.portlet file to
the portlets folder and displaying the new portlet in the editor, as shown in Figure 3-10.

Figure 3-10 New Browser Portlet Displayed in Editor

Browser Portlet g @

g_p Event Handlers: Mo event handlers

Portlet Modes

Fortlet Preferences

Create a JSP Portlet

JSP portlets reference JSP files. In most cases you can reuse existing JSP files to build portlets
from them. JSP portlets are recommended when the portlet is simple and does not require the
implementation of complex business logic.

In this task, you will create a simple JSP file and then use that file to generate a portlet.

Follow these steps:

1. Double click the file index. jsp in the Package Explorer view.
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3-12

The index.jsp file is located in the WwebContent directory, and is included with any Portal
Web Project that you create.

The source code for the file displays in an editor view. Select the Source tab just below the
source code window to display just the source code.

2. Change the default body text to Simple JSP Portlet as shown in Figure 3-11.
Figure 3-11 JSP File Showing Edited Body Text

myPortal. portal & Mew Portal Deskhop E myBrowserPortlet. portlet B *index.jsp X

<%l page language="java"™ contentType="text/html;charset=UTF-58"%:>

<%ftaylih uri="http://beehive.apache.org/netuis/tags-—html-1.0" prefix="netui"
<%ftaylilh uri="http:/ /beehive.apache.org/necui/tags—databinding-1.0" prefix=
<4ftaglibh uri="http://bechive.apache.org/necui/tags-tewplate-1.0" prefix="nes

<netui:html>
<heads>
<netui:base/>

</ head:>
<netui::body>

Simple J3P Portlet
</netui:hodys>
</netuithemls>

o 0

P S LU PP S
3. Select File > Save As and save this JSP file as jsp_portlet. jsp.

4. Drag the jsp_portlet. jsp file into the portlets folder.

5. Right-click jsp_portlet.jsp and select Generate Portlet from the menu.

Because you are generating a portlet from an existing . jsp file, the Portlet Wizard goes
directly to the Portlet Details dialog; Figure 3-12 shows an example.
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Figure 3-12 Portlet Wizard - JSP Portlet Details Dialog
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Po ard - Portlet Deta

seps:  Portlet Details

1. Select Portlet Type
2. Portlet Details

Please Fill in the general details for the portlet.

Title : |jspjo|'tlet

Content Path :

|,fpo|'tlets,fjspjortlet.]'sp

New...| (= Browse...

Error Page Path : |

|+ Has TitleBar

[+ Minimizable
[ Maximizable

I Deletable

Previous

State : Available Modes :

I~ Help =
[~ Floatable L J [ 2

New...| (= Browse...

| Create | Cancel

6. Specify the values specified in Table 3-2.

Tahle 3-2 Portlet Wizard - JSP Portlet Data Entry Fields

Field Value/Description
Title Simple JSP Portlet
Content Path Iportlets/jsp_portlet.jsp

Because you are creating this portlet based on an existing JSP file,
WebLogic Portal automatically fills in this value.

Has Titlebar Leave this box checked.

State Select the check boxes Minimizable and Maximizable.

7. Click Create.

The WorkSpace Studio window updates, adding the jsp_portlet.portlet file to the

portlets folder.

Checkpoint: Your WebContent directory should look like the example shown in Figure 3-13.
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Figure 3-13 WebContent Directory Including Portal, Browser Portlet, and JSP Portlet

&= Lbrary Module | 013n-datasync-app-liv)
=, Library Module [beehive-netui-resources-1,0]
+-[= build
== WebContent
+-[= META-INF
== portlets
|2 jsp_portlet.jsp
[=] isp_portlet, portlet
E myBrowserPortlet, portlet
+- 22 WEB-INF
|2 index.jsp

ﬁ myPartal, portal . /

Add Portlets to the Portal and View the Result

In this task you will add your new portlets to the portal and view your changes.

e Y YW T

bk,

Follow these steps:
1. In the editor, click the myPortal .portal tab to display it.

2. Click the Page 1 tab in the portal to select it.

3. Drag the JSP portlet (with the file name jsp_portlet.portlet) onto the left column (placeholder)
of the portal page.

4. Drag the Browser portlet (with the file name myBrowserPortlet.portlet) onto the right
placeholder of the portal page.

Your result should look like the example in Figure 3-14.
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Figure 3-14 Portal in Editor View with Portlets Added

myPortal.portal X @ Mew Portal Deskhop E sp_portlet, portlet =0

Mew Portal Desktop

Header

Book: Main Page Book:

(71| Page 1 l ] Page 2
Page: Page 1

Simple J5P Portlet BEA Browser Portlet

| Footer

5. Save your change.

To view the new portlets in a browser, follow these steps:
1. Click to select the New Portal Desktop tab in the editor view.

2. On the toolbar, click Refresh /.

Because your change does not require redeploying the change to the server, you do not
need to select the Run on Server option to see the new portlets.

Your updated portal should look like the example shown in Figure 3-15.
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Figure 3-15 Running Portal with Browser Portlet and JSP Portlet Added

myPortaI.portaI # New Portal Desktop X @ myBrowserPortlet, portlet jsp_partlet.jsp =0

& | =l >
Page 1 Page 2
Simple JSP Portlet  [H[F]| |BEA Browser Portlet EEEE
Simple ISP Portlet '.’,." ~
% hea )
Think liquid.”

Solutions  Products  Services  Support

v

< ) >
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Summary

With the completion of this tutorial, you have created a portal, added a portal page, and created
two new portlets that can be displayed in the portal. These components are created on your file
system in your current workspace.

To learn about creating desktops using the WebLogic Portal Administration console, continue to
Chapter 4, “Assembling a Desktop in Your Staging Environment.”
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CHAPTERa

Assembling a Desktop in Your Staging
Environment

This tutorial helps you learn how to use the WebLogic Portal Administration Console for some
basic portal configuration tasks.

For more detailed information about each dialog of the wizards used in this chapter, refer to the
Portal Development Guide.

Before You Begin

The tasks described in this chapter are based on those described in Chapter 2, “Setting Up Your
Portal Development Environment” and Chapter 3, “Creating a Portal in Your Development

Environment,” so it is important that you complete those tutorials before starting the tasks
described here.

Introduction to the Administration Console

The WebLogic Portal Administration Console is the tool that portal administrators use to not only
control the behavior, content, and appearance of portals, but to perform many traditional system
administration activities such as user management and security management as well. This tutorial
focuses on basic tasks that assemble portals into desktops.

The WebL ogic Portal Administration Console is organized according to the following categories
of tasks:

e Portal Management — Portals, desktops, books, pages, portlets, and other portal resources.
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This tutorial describes some of the basic Portal Management tasks. The Portal
Development Guide and Portlet Development Guide provide details about Portal
Management tasks.

e User, Groups, & Roles — User and group management, security provider configuration,
Delegated Administration, and Visitor Entitlements.

The User Management Guide and Security Guide provides detailed information about the
tasks in this category.

e Content Management — Content and repositories.

The Content Management Guide provides detailed information about the tasks in this
category.

e Interaction Management — Campaigns, Placeholders, User Segments, And Content
Selectors.

The Interaction Management Guide provides detailed information about the tasks in this
category.

e Configuration & Monitoring — Server settings for Cache Management, Server
Maintenance Mode, Personalization, Security, Unified User Profiles, and WSRP.

The Security Guide, Portal Development Guide, Federated Portals Guide, Interaction
Management Guide, and User Management Guide provide detailed information about the
tasks in this category.

Tutorial Steps

42

Using the tutorial, you will create a portal desktop based on the portal and portlets created
previously, make some modifications to your desktop, and then view your results.

The tutorial includes instructions on how to perform these tasks:

e Open the Administration Console

Log in to the Administration Console

Create a Portal and Desktop

Update the Desktop Page Contents to Rearrange Portlets

Create a New Page on the Desktop
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Tutorial Steps

Open the Administration Console

Before you can begin using the WebLogic Portal Administration Console, the server must be
running. Depending on the state of your WorkSpace Studio workbench, you might need to start
the server before opening the Administration Console.

If you are continuing from Chapter 3, “Creating a Portal in Your Development Environment,”
and you have not closed/opened WorkSpace Studio, you can skip to Step 4.

If you closed WorkSpace Studio after finishing the tutorial in Chapter 3, “Creating a Portal in
Your Development Environment,” follow these steps:

1. Start WorkSpace Studio and return to the workspace that you used for the previous tutorials:
2. Inthe Servers view, click the server to select it.
3. Click Start gy in the Servers view toolbar.

Wait while WorkSpace Studio starts the server. This process might take some time,
depending on the speed of your system.When the process completes, the Status column in
the Servers view displays Started and the square Stop the Server button g becomes

active.
4. Click myPortal .portal in the Package Explorer view to select it.

5. From the main menu, select Run > Open Portal Administration Console, as shown in the
example in Figure 4-1.

Figure 4-1 Menu Selection for Run > Open Portal Administration Console

Window  Help

% Run Last Launched Chrl+F11
%, Debug Last Launched Fi1
Run Histary 4
Run As L4
e A o e e F N

E Portal Cache Manager, ..

Open Portal Administration Console. .. k

13 Add Java Exception Breakpaint. ..
® add Class Load Breakpoint. ..

@ External Toals 4
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4-4

The Administration Console opens in a new tab in the workbench editor view, with the
login dialog displayed, as Figure 4-2 shows.

Figure 4-2 WebLogic Portal Administration Console Login Dialog

myPartal, portal =] isp_partlet. partlet (@ New Portal Deskkop . administration ¢ . =0

7] Qéh |http:,l’,l’localhost:?DD1,l’myP0rtaIEARAdmin,l’login,l’LoginControIIer.ij,'JSESSIONID_ADMINTOOLS=GdKNNNbsk?GFgj =

+~s  WEBLOGIC PORTAL

Zbea apminisTRATION CONSOLE

Sign in to work with \WeblLogic Portal

Username: | |

Password: | |

Log in to the Administration Console

The Administration Console login dialog requires a WebLogic Server system administrator or a
WebLogic Portal administrator user name and password. WebLogic Server system
administrators have full security privileges for the entire domain and can log in to and use the
WebLogic Server Administration Console tools. WebL ogic Portal administrators have full
security privileges for a Portal Web Project, which can include multiple portals.

Table 4-1 shows the default system administrator user names and passwords:

Table 4-1 Default User Names and Passwords for the WebLogic Portal Administration Console

User Name Password Description
portaladmin portaladmin Administrator for the portal domain
weblogic weblogic WebLogic Server system administrator with full

privileges in the domain

For purposes of this tutorial, you will use the default WebLogic Server login so that you have full
privileges.

To log in to the WebLogic Portal Administration Console, follow these steps:
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1. Type the user name weblogic and password weblogic into the dialog and click Sign In.

Tutorial Steps

The main menu of the Administration Console displays.

Figure 4-3 Administration Console Main Page
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E Flacehalders Help Topics (
&} Segrments Help Topics }

4
Content Selectars Help Topics j

O R - B ot Bt b P el N SPE

To create a portal and desktop, follow these steps:

1. Click the Portal Management menu shortcut on the Administration Console home page.

The Portal Management page displays; the Portal Resources tree displays in the left pane
of the page, as shown in Figure 4-4.
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Figure 4-4 Portal Resources Tree in the Administration Console
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Notice that the display is based on the Portal Web Project that you created in Chapter 3,
“Creating a Portal in Your Development Environment.” if you expand the Library >
Portlets portion of the tree, you can see the portlets that you created earlier.

2. Click Portals in the tree.

The Portals page displays, with the Browse Portals tab active. Because no portals exist yet,
the table containing portals is empty.

3. Click Create New Portal.

The Create a New Portal dialog displays, as shown in Figure 4-5.

Figure 4-5 Create a New Portal Dialog in Administration Console

Create a New Portal

Paortal Marme: * |myBEAportal

Description: |yeneral BEA portal

Fartial URL: * | myBEAportal

URI {default resource):

| Create Mew Portal | | Cancel |

4. Enter values for the portal, using Table 4-2 as a guide:
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Table 4-2 Create a New Portal Dialog Field Descriptions

Field Value/Description
Portal Name myBEAportal
Description general BEA portal
Partial URL myBEAportal

URI (default resource) (leave blank)

5. Click Create New Portal.

When the Portals page displays again, the Browse Portals table includes the portal you
created, and the Portal Resources tree includes the new portal.

6. Click myBEAportal in the Browse Portals table to view the details for this portal.

The Portals page displays, with the Browse Desktops tab active. Because no desktops exist
yet, the table containing desktops is empty.

7. Click Create New Desktop.

The Create Desktop wizard displays, as shown in Figure 4-6.
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Figure 4-6 Create Desktop Wizard in Administration Console

| {& Create Desktop

Create Desktop: Step 1 of 5 (]

Select Create Method

~Select how you want to create a desktop, and click Next.

() Use a Desktop Template
Select Source Choose from a list of termplates that define the desktops's shell, look and feel, and
contents to quickly get your desktop up and running.

Enter Desktop Properties
() Select resources in the Library
Choose the primary book, shell, and look and feel for your desktop from available

Review Properties resources and provide additional desktop properties,
i Select a .portal file
%Select from a list of .portal files in the current webapp, and provide additional

desktop properties.

| Previous | Mext | Cancel |

8. Enter values for the desktop in the appropriate wizard pages, using Table 4-3 as your guide:

Table 4-3 Create Desktop Wizard Field Descriptions

Field or Selection Value/Description

Step 1: Select how you 1. Select a .portal file radio button.
want to create a desktop... 2 Click Next.
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Tahle 4-3 Create Desktop Wizard Field Descriptions (Continued)

Field or Selection Value/Description

Step 2: Selecta .portal file 1. Click Show All.

The portal you created using WorkSpace
Studio displays in the list.

Click to select myPortal.portal.

Click Next.
Step 3: Enter desktop e Title — myDesktop
properties...  Description — general desktop

» Partial URL - desktopl
e Default Shell — (leave as is)
e Look and Feel — (leave as is)

9. Click Review Properties to review the desktop properties, and Create Desktop again to
create the desktop.

A confirmation dialog confirms that the desktop has been created and displays related
information.

10. Click Finish to return to the main Administration Console page.

The Browse Desktops table includes the desktop you created, and the Portal Resources tree
includes the new desktop, as shown in Figure 4-7, which shows the expanded tree.

Figure 4-7 New Desktop in Portal Resources Tree

Home = Portal = Portal Management P
Portal Resources for : myPurtaIWebPruier"
:
»

EE’J Portal Resources 4‘
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B[] myDesktop )

=i Main Page Book 4

E‘S Page 1 €

[ simple ISP Portiet ;
BEA Browser Portlet‘)
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Notice that the portlets that you created for this portal (which was used as the template for
this desktop) appear automatically in the new desktop.

Update the Desktop Page Contents to Rearrange Portlets

In this task you view the portlets for a desktop page—the portlets that you created using
WorkSpace Studio—and rearrange them on the page. Then you will view your work.

To update your desktop page, follow these steps:

1. Inthe Portal Resources tree for myPortalWebProject, expand the tree to display the pages for
the desktop, as shown in Figure 4-8.

Figure 4-8 Expanded Portal Resources Tree Showing Desktop Pages
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Update Webhipp

EE’J Portal Resources
= Library
Bl Portals
B myBEAportal
~@Communities

E||_u| rmyDesktop
=i Main Page Book
E-[J Page 1
[E] Simple 15P Partlet
[E] BEA Browser Partlet
[J Page 2

P Y W R

‘\_—a'\

el oF A U

2. Click Page 1 to select it.
The Page 1 details display in the right pane of the Administration Console.

3. Select the Edit Contents tab; it appears, as shown in Figure 4-9.
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Figure 4-9 Page 1 Edit Contents Tab
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4. Drag the BEA Browser Portlet into the same placeholder as the Simple JSP Portlet, as shown
in Figure 4-10.
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Figure 4-10 Moving the BEA Browser Portlet by Dragging
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When you release the portlet, it displays above the Simple JSP Portlet, as shown in
Figure 4-11.
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5. Click Save Changes.

Figure 4-11 Result After Moving the BEA Browser Portlet in the Administration Console
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6. Inthe Portal Resources tree, click myDesktop to display the Details page.
7. Click View Desktop.

The desktop displays in a browser, with the portlets in their new positions, as shown in
Figure 4-12.
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Figure 4-12 Desktop in Browser Showing Moved Portlets
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Create a New Page on the Desktop

In this task, you will create a new page for your desktop. Follow these steps:

1. In the Portal Resources tree for myPortalWebProject, expand the Library node in the tree to
display the pages, as shown in Figure 4-13.

Figure 4-13 Expanded Portal Resources Tree Showing Desktop Pages
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2. Click Pages to display the Browse Pages tab, as shown in Figure 4-14.
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Figure 4-14 Browse Pages Tah
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3. Click Create New Page.
The Create New Page dialog displays, as shown in Figure 4-15.

Figure 4-15 Create New Page Dialog in Administration Console
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4. Enter values for the new page, using Table 4-4 as a guide:
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Summary

Table 4-4 Create New Page — Field Descriptions

Field Value/Description

Title Tutorial Page
Description new page for tutorial
Layout Three Column Layout
Theme (leave as is - None)
Hidden (leave as is - unchecked)

5. Click Create.

The new page is added, and is displayed in the Details page for the desktop; the Portal
Resources tree updates to include the new page, as shown in Figure 4-16.

Figure 4-16 New Page Added to the Portal Resources Tree

Portal Resources for : myPortalWebProject

Update Webhipp

EE’J Portal Resources

E-f Library

#-liF Portlets

----- i Portlet Categories
-1} Books

-5 Layouts

- Look & Feels

[

E

H-{ = Menus

-6 Portlet Producers
FH-L= Shells
o IZII;{L,g]'Ire’mglaigs . e o

Summary

With the completion of this tutorial, you have created a basic desktop and performed some
additional tasks to become familiar with the staging environment and the WebLogic Portal
Administration Console.

To get started with actual portal development and desktop staging, refer to WebLogic Portal
document library on e-docs.
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