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C H A P T E R 1

Introduction

This topic introduces the trading partner integration tutorials and describes the setup steps 
required before starting the tutorials. It contains the following sections:

About the Tutorials for Trading Partner Integration

Before You Begin

Setting Up the Tutorials

Next Steps

About the Tutorials for Trading Partner Integration
This document provides the following tutorials:

Table 1-1  Tutorials in This Document

Tutorial Description Business Protocol

Chapter 3, “Tutorial: 
Building ebXML 
Solutions”

Describes how to build the ebXML (Electronic 
Business using eXtensible Markup Language) 
business process examples.

http://www.ebXML.org 

Chapter 2, “Tutorial: 
Building RosettaNet 
Solutions”

Describes the components of two completed 
RosettaNet examples (PIP3B2 and PIP3A4) and 
suggests how to adapt the examples for other PIP 
implementations.

http://www.rosettanet.org

http://www.rosettanet.org
http://www.ebXML.org
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These are standalone tutorials. You can complete both tutorials, if you want, but you can also 
complete just the ebXML tutorial without the RosettaNet tutorial, and vice versa.

Before You Begin
Before you begin using the trading partner integration tutorials:

You must have WebLogic Platform 8.1 installed on your system. For more information, see 
Installing WebLogic Platform, which is available at 
http://edocs.bea.com/platform/docs81/install/index.html.

It is recommended that you complete the following tutorials so that you know how to build 
business processes and create data transformations in WebLogic Workshop:

– Tutorial: Building Your First Business Process, which is available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.h
tml 

– Tutorial: Building Your First Data Transformation, which is available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIn
tro.html 

You should be familiar with basic trading partner integration concepts, as described in 
Introducing Trading Partner Integration, which is available at 
http://edocs.bea.com/wli/docs81/tpintro/index.html.

You should first create the tptutorial domain and install the tutorial files, as described in 
“Setting Up the Tutorials” on page 1-2.

Setting Up the Tutorials
Before you start using the trading partner integration tutorials, you need to complete the 
following steps:

Step 1: Create a New WebLogic Integration Domain

Step 2: View the Default Trading Partner Information

Step 3: Install the Tutorial Files

http://edocs.bea.com/platform/docs81/install/index.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/platform/docs81/install/index.html
http://edocs.bea.com/wli/docs81/tpintro/index.html
http://edocs.bea.com/wli/docs81/tpintro/index.html


Set t ing  Up  the  Tuto r ia ls

Tutorials for Trading Partner Integration 1-3

Step 1: Create a New WebLogic Integration Domain
The trading partner integration tutorials require a WebLogic Integration domain that you must 
create using the BEA WebLogic Platform Configuration Wizard. The domain name used in this 
document is tptutorial, but you can use any valid domain name you want.

Note: You can also use an existing WebLogic Integration for these tutorials. However, creating 
a new, separate domain ensures that the required default trading partner configuration is 
available for use with the tutorials.

To create a new WebLogic Integration domain:

1. Start the Configuration Wizard:

– Windows: From the Start menu, choose Programs→BEA WebLogic 
Platform→Configuration Wizard.

– Unix: Open a command shell, change to the /common/bin subdirectory of the product 
installation directory (such as /bea/weblogic81/common/bin), and enter the 
following command: sh config.sh.

The Configuration Wizard starts and displays the initial screen.

2. In the Configuration Wizard, make the following selections in each screen, and then click 
the Next button to continue:
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Note: These instructions assume mostly default selections. For more information about 
advanced configuration options, see the Configuration Wizard online help.

3. Click the Create button.

By default, the Configuration Wizard creates the new domain in 
BEA_HOME\user_projects\domains\domainName, where:

– BEA_HOME is the BEA home directory (such as c:\bea).

– domainName is the name of the domain you created (such as tptutorial).

4. On the Creating Configuration screen, select (click) Start Admin Server.

5. Click the Done button.

Step 2: View the Default Trading Partner Information
When you create a new WebLogic Integration domain using the Configuration Wizard, the 
Configuration Wizard automatically populates the Trading Partner Management (TPM) 
repository with default trading partners and protocol bindings. The trading partner integration 
tutorials use this default configuration. To learn more about the TPM repository, see Trading 

Table 1-2  Selections in the Configuration Wizard

Screen Name Recommended Selection

Create or Extend a Configuration Create a new WebLogic configuration (default)

Select a Configuration Template Basic WebLogic Integration Domain (from the list of WebLogic 
configuration templates).

Choose Express or Custom 
Configuration

Express (default)

Configure Administrative Username 
and Password

Specify the administrator password (required) and change 
defaults as needed.

Configure Server Start Mode and 
Java SDK

Startup Mode: Development Mode (default)

Java SDK Selection: Sun SDK (default)

Create WebLogic Configuration For Configuration Name, specify tptutorial or another 
name that you want to use for this domain.

http://edocs.bea.com/wli/docs81/manage/tpm.html
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Partner Management (available at http://edocs.bea.com/wli/docs81/manage/tpm.html) in 
Managing WebLogic Integration Solutions.

By default, BEA WebLogic Integration runs in Test (development) mode, which allows you to 
use the default protocol bindings and to run business processes from separate trading partners on 
the same machine (collocated). In a production environment, each trading partner would run its 
respective business process on its own separate BEA WebLogic Integration server, service 
profiles would need to be explicitly configured, both trading partners would need to be enabled, 
and the service profile would need to be enabled. For more information about the Test and 
Production modes, see “Configuring the Mode and Message Tracking” in Trading Partner 
Management (available at http://edocs.bea.com/wli/docs81/manage/tpm.html) in Managing 
WebLogic Integration Solutions.

Default Trading Partners
The WebLogic Integration domain provides two preconfigured trading partners for development 
and testing:

Default Protocol Bindings
Each default trading partner comes with the following preconfigured protocol bindings:

ebXML 1.0

ebXML 2.0

RosettaNet Implementation FrameWork (RNIF) 1.1

Table 1-3  Default Trading Partner Configuration in WebLogic Integration Domain

Trading Partner Name Trading 
Partner ID

Description

Test_TradingPartner_1 000000001 Default local trading partner. In the tutorials, this trading 
partner is usually the initiator of conversations.

In the absence of specific trading partner information, the 
default trading partner is designated as the trading partner 
used for sending or receiving messages for the local host 
system 

Test_TradingPartner_2 000000002 In the tutorials, this trading partner is usually the 
participant in conversations.

http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
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RNIF 2.0

Each protocol binding (except ebXML 1.0) is marked as default. At run-time, the default binding 
can be used automatically in the absence of specific protocol information.

Viewing Trading Partner Information (Optional)
You view and update the contents of the TPM repository using the WebLogic Integration 
Administration Console. If you want, you can use the WebLogic Integration Administration 
Console to browse the preconfigured settings in the TPM repository. The trading partner 
integration tutorials use the preconfigured settings, so no changes to the TPM repository are 
required unless otherwise stated in the tutorials.

Note: If you make any changes to the preconfigured settings in the TPM repository, you should 
adjust the instructions in the tutorials accordingly. For configuration instructions, see 
Trading Partner Management (available at 
http://edocs.bea.com/wli/docs81/manage/tpm.html) in Managing WebLogic Integration 
Solutions.

To view the default trading partner information:

1. Start the WebLogic Integration Administration Console by doing either of the following:

– From the Start menu, choose Programs→BEA WebLogic 
Platform→Examples→WebLogic Integration→Integration Admin Console.

– In a browser, enter the following URL: http://localhost:7001/wliconsole.

2. When prompted, specify the username and password.

The WebLogic Integration Administration Console displays the home page.

http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
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Note: If you want more information about a particular screen in the WebLogic Integration 
Administration Console, click the Help icon.

3. Select the Trading Partner Management module to see the Trading Partner Management 
home page.
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4. On the Trading Partner Management home page, select the Profile Management module to 
see the profiles for the preconfigured trading partners.

5. From the left panel, select Bindings, select Test_TradingPartner_1, and click the Go 
button to see the preconfigured bindings for the default trading partner.
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Note: By default, trading partner endpoints are configured to listen on localhost:7001. 
If you configured WebLogic Server to listen on a different port, adjust the trading 
partner binding information accordingly.

Step 3: Install the Tutorial Files
The documentation and example files for the trading partner integration tutorials are distributed 
in an archive file (tptutorial.zip) that you obtain from BEA’s dev2dev Online site. This 
archive file contains the completed ebXML and RosettaNet applications used in the tutorials, as 
well as schema files and sample XML files.

To install the files for the trading partner integration tutorials:

1. Download the tptutorial.zip file from the WebLogic Integration 8.1 page at the following 
URL:

http://dev2dev.bea.com/codelibrary/code/tptutorial.jsp

2. Extract the contents of the tptutorial.zip file (using folder names) to a local directory. 
The extracted files have the following directory structure:

http://dev2dev.bea.com/codelibrary/code/tptutorial.jsp
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Next Steps
After you have set up the tutorial domain and extracted the tutorial files, you can begin using the 
following tutorials:

Chapter 3, “Tutorial: Building ebXML Solutions”

Chapter 2, “Tutorial: Building RosettaNet Solutions”

Both tutorials use the same WebLogic Integration domain that you created in “Setting Up the 
Tutorials” on page 1-2. These are standalone tutorials. You can complete both tutorials, if you 
want, but you can also complete just the ebXML tutorial without the RosettaNet tutorial, and vice 
versa.

Table 1-4  Contents of tptutorial.zip

Folder / File Description

tptutorialapps\tptutorial.pdf Documentation for the trading partner integration tutorials.

tptutorialapps\ebxml Completed application that you can refer to if you encounter 
difficulties while building the business processes during the 
ebXML tutorial. Also contains schema files and sample XML 
data files.

tptutorialapps\rosettanet Application containing example implementations of PIPs 3B2 
and 3A4.
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C H A P T E R 2

Tutorial: Building RosettaNet Solutions

This topic describes how to implement RosettaNet solutions for trading partner integration in 
BEA WebLogic Integration. It contains the following sections:

Before You Begin

Tutorial Goals

Tutorial Overview

Tutorial Steps

Implementing New PIPs Based on the Example PIPs

RosettaNet is a business protocol that enables enterprises to conduct business over the Internet. 
To learn about RosettaNet, see http://www.rosettanet.org.

http://www.rosettanet.org
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Tutorial Goals
This tutorial has the following goals:

To demonstrate two common RosettaNet design patterns (asynchronous single-action and 
asynchronous two-action activity, both with notification of failure interactions) that form 
the basis of most PIP implementations.

To describe example WebLogic Workshop public business processes that implement two 
RosettaNet Partner Interface Processes (PIPs)—PIP3B2 (an asynchronous single-action 
activity) and 3A4 (an asynchronous two-action activity).

To describe the example private business processes, which are stubs that represent 
integration with back-end systems.

To explain how to run the example PIPs, using example XML data, so that you can view 
them at runtime.

To explain how you can easily implement business processes for other PIPs using the 
provided PIP implementations as starting points.

Before You Begin
This topic describes tasks that you should perform before you begin using this tutorial. It contains 
the following sections:

Prerequisites

Suggested Reading

Note About Obtaining RosettaNet W3C XSD Schemas

Prerequisites
To use this tutorial, you must have:

Installed WebLogic Platform 8.1 on your system according to the instructions in Installing 
WebLogic Platform, which is available at 
http://edocs.bea.com/platform/docs81/install/index.html. 

Completed the tutorial setup procedure according to the instructions in “Setting Up the 
Tutorials” on page 1-2. 

http://edocs.bea.com/platform/docs81/install/index.html
http://edocs.bea.com/platform/docs81/install/index.html
http://edocs.bea.com/platform/docs81/install/index.html
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Suggested Reading
To gain a detailed understanding of how RosettaNet solutions are implemented in WebLogic 
Integration, consider reading the following material:

For an overview of integrating trading partners using BEA WebLogic Integration, see 
Introducing Trading Partner Integration, which is available at 
http://edocs.bea.com/wli/docs81/tpintro/index.html.

For an introduction to RosettaNet solutions using BEA WebLogic Integration, see 
Introducing RosettaNet Solutions (available at 
http://edocs.bea.com/wli/docs81/tpintro/rosettanet.html) in Introducing Trading Partner 
Integration.

For more information about using the RosettaNet control in initiator business processes, 
see RosettaNet Control in the WebLogic Workshop Online Help, which is available at:

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsRosettaNet.html

For information about using participant business processes, see the following topics in the 
WebLogic Workshop Help:

– Building RosettaNet Participant Business Processes, which is available at:

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideRosettaNet.h
tml

– @jpd:rosettanet Annotation, which is available at:

http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.ht
ml

To learn how to build business processes and create data transformations in WebLogic 
Workshop, consider completing the following tutorials:

Tutorial: Building Your First Business Process, which is available at: 
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html 

Tutorial: Building Your First Data Transformation, which is available at: 
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.
html 

To learn more about the RosettaNet business protocol and how to implement RosettaNet 
solutions, see:

The RosettaNet web site, which is available at:

http://edocs.bea.com/wli/docs81/tpintro/index.html
http://edocs.bea.com/wli/docs81/tpintro/rosettanet.html
http://edocs.bea.com/wli/docs81/tpintro/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsRosettaNet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsRosettaNet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideRosettaNet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/wli/docs81/tpintro/index.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideRosettaNet.html
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http://www.rosettanet.org

RosettaNet Implementation Framework: Core Specification (RNIF Specification), available 
at: http://www.rosettanet.org

Note About Obtaining RosettaNet W3C XSD Schemas
The RosettaNet W3C XSD schemas for selected PIPs are included in the RosettaNet Self-Test 
Kit (STK) which can be downloaded from the Developer Tools area on the RosettaNet Ready 
Web site, available at: http://www.rosettanet.org.

If the schema for the PIP you are using is not available on this web site, it is possible to implement 
RosettaNet solutions in WebLogic integration using RosettaNet message definitions specified as 
DTD files. However, it is recommended to use W3C XSD files instead, since many of the 
WebLogic Integration tools such as the XQuery mapping tools (used to define data 
transformations) only support XSD schemas.

If you want to use the graphical XQuery mapping tools, you need to convert the RosettaNet DTD 
files to W3C XSD files (using a tool like XML Spy Enterprise Edition) and then import the XSD 
files into your project. Make sure that you refer to the RosettaNet Message Guidelines for the PIP 
which DTD file you are converting and add the appropriate validation rules for Service Content 
Validation to your XSD file after the conversion. For instructions on how to convert the files 
using XML Spy, see “Converting RosettaNet DTD Schemas to XSD Schemas” on page 2-40.

In this tutorial, all the XSDs necessary to complete the examples are included in the tutorial files.

Tutorial Overview
The RosettaNet example includes business process definitions (JPDs), schemas, and other files 
that illustrate how to implement RosettaNet PIPs using WebLogic Integration 8.1. The example 
business process files implement common design patterns and provide a head start for building 
initiator and participant business processes for RosettaNet conversations. Rather than build the 
business processes from scratch, you can easily adapt the example files to implement any PIP.

This topic contains the following sections:

PIPs Implemented In These Examples

Folders in the RosettaNet Tutorial Application

RosettaNet Design Patterns

The PIPs implemented in this tutorial follow RosettaNet Implementation Framework (RNIF) 2.0.

http://www.rosettanet.org
http://www.rosettanet.org
http://www.rosettanet.org
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PIPs Implemented In These Examples
The following table describes the RosettaNet examples that are provided in this tutorial:

Table 2-1  RosettaNet Examples

PIP Description

0A1 Implements PIP0A1: Notification of Failure.

You can initiate this business process from any other business process in which a RosettaNet 
notification of failure is required. For example, you can use this business process in 
conjunction with the RosettaNet Participant Business Process template provided in 
WebLogic Workshop. For more information, see Building RosettaNet Participant Business 
Processes in the WebLogic Workshop Help.

3B2 Implements PIP3B2: Notify of Advance Shipment. Described in “Step 3: Open the PIP3B2: 
Notify of Advance Shipment Example” on page 2-16.

3A4 Implements PIP3A4: Request Purchase Order. Described in “Step 4: Open the PIP3A4: 
Request Purchase Order Example” on page 2-26.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideRosettaNet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideRosettaNet.html
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Folders in the RosettaNet Tutorial Application
The following table describes the folders you see in your application tab when you open the in 
the \tptutorialapps\rosettanet directory:

Table 2-2  Folders in \tptutorialapps\rosettanet

Directory Description

PIP0A1Schema Schema project for the PIP0A1 schema.

PIP3A4Schema Schema project for the PIP3A4 schema.

PIP3B2Schema Schema project for the PIP3B2 schema.

pips Contains business process folders for each example PIP implementation 
(PIP0A1Processes, PIP3A4Processes, and PIP3B2Processes) and 
the private administrator alert notification (privateAdmin).

System Schema project for standard BEA WebLogic Integration system schemas.

Modules Empty by default. Standard WebLogic Workshop folder for compiled Java code.

Libraries Empty by default. Standard WebLogic Workshop folder for compiled Java code.

Security Roles Empty by default. Standard WebLogic Workshop folder for defining security 
roles for this application.
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RosettaNet Design Patterns
RosettaNet PIPs follow one of the following design patterns:

The example PIP implementations provided in this tutorial allow you to quickly and easily build 
any PIPs that following the same design patterns, as described in “Implementing New PIPs Based 
on the Example PIPs” on page 2-39.

For more information about RosettaNet design patterns and conversation choreography, see the 
following documents:

Table 2-3  RosettaNet PIP Design Patterns

Directory Description

Asynchronous 
single-action activity

Involves a single action message and a receipt acknowledgment:
• Initiator sends a business message to the participant.
• The participant sends a receipt acknowledgement to the initiator.

The PIP3B2 (Notify of Advance Shipment) example, which implements this 
design pattern, is described in “Step 3: Open the PIP3B2: Notify of Advance 
Shipment Example” on page 2-16.

Asynchronous 
two-action activity

Involves actions messages and receipt acknowledgments from both trading 
partners:
• Initiator sends a business message to the participant.
• The participant sends a receipt acknowledgement to the initiator.
• The participant sends a business message to the initiator.
• The initiator sends a receipt acknowledgement to the participant.

The PIP3A4 (Request Purchase Order) example, which implements this 
design pattern, is described in “Step 4: Open the PIP3A4: Request Purchase 
Order Example” on page 2-26.

Synchronous 
one-action / two-action 
activity

Synchronous versions of the above design patterns, in which an immediate 
response is required. The current release of BEA WebLogic Integration does 
not support synchronous design patterns.

Note: Synchronous RosettaNet design patterns usually do not 
implement the receipt acknowledgments described in the 
asynchronous single-action and two-action activity design 
patterns.
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“PIP Design Patterns” in Introducing RosettaNet Solutions (available at 
http://edocs.bea.com/wli/docs81/tpintro/rosettanet.html.) in Introducing Trading Partner 
Integration.

RosettaNet Implementation Framework Core Specification (version V02.00.01) at 
http://www.rosettanet.org.

Tutorial Steps
This section describes the following tutorial steps:

“Step 1: Open the RosettaNet Example Application” on page 2-8

“Step 2: Open the PIP0A1: Notification of Failure Example” on page 2-9

“Step 3: Open the PIP3B2: Notify of Advance Shipment Example” on page 2-16

“Step 4: Open the PIP3A4: Request Purchase Order Example” on page 2-26

Before you proceed through these steps, make sure that you have reviewed the material in 
“Before You Begin” on page 2-2.

Step 1: Open the RosettaNet Example Application
The RosettaNet example application contains all the PIP implementations described in “PIPs 
Implemented In These Examples” on page 2-5. 

To open the RosettaNet example application:

1. Start WebLogic Workshop, if you have not already done so.

2. From the File menu, choose Open→Application.

3. Navigate to the tptutorialapps folder that you created in “Step 3: Install the Tutorial 
Files” on page 1-9.

4. Open the rosettanet folder 

5. Open the rosettanet.work file. 

Note: If you are prompted to select a WebLogic Integration domain and server, select the 
WebLogic Integration domain that you created in “Step 1: Create a New WebLogic 
Integration Domain” on page 1-3 (such as 
c:\bea\user_projects\domains\tptutorial)

http://www.rosettanet.org
http://edocs.bea.com/wli/docs81/tpintro/rosettanet.html
http://edocs.bea.com/wli/docs81/tpintro/rosettanet.html
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The Application tab displays the contents of the RosettaNet tutorial application, which is 
described in “Folders in the RosettaNet Tutorial Application” on page 2-6.

6. On the Application tab, right-click the root rosettanet folder and choose Properties.

7. In the Application Properties dialog, verify that the Server Home Directory points to the 
WebLogic Integration domain that you created in “Step 1: Create a New WebLogic 
Integration Domain” on page 1-3 (such as 
c:\bea\user_projects\domains\tptutorial), and then click the OK button.

8. On the Application tab, select the root rosettanet folder and select Build→Build 
Application (or press F7) to build your application.

Note: You may see green compilation warnings in the build tab. You can ignore these 
warnings, the example will still execute correctly.

9. On the Application tab, double-click the pips folder to display folders containing the 
example business processes.

Step 2: Open the PIP0A1: Notification of Failure Example 
This topic describes the example implementation of PIP0A1: Notification of Failure. It contains 
the following sections:

About the PIP0A1 Example

Components of the PIP0A1 Example

Walkthrough of the Failure Notifier Business Process

Walkthrough of the Report Administrator Business Process

For detailed information about PIP0A1, see http://www.rosettanet.org.

http://www.rosettanet.org
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About the PIP0A1 Example
PIP0A1 is an example of how to implement the PIP0A1 Notification of Failure. 
The PIP0A1Processes folder contains business process definitions for PIP0A1. 
The PIP0A1Schemas schema project contains the schema file for the PIP0A1 message.

The PIP0A1 demonstrates how to set up business logic, properly process error messages, and 
then, based on the business logic and error messages, open the correct channel to use when 
sending notifications of failure to the appropriate failure administrator. In this tutorial, the 
PIP0A1 Notification of Failure scenarios are:

The Buyer side of PIP 3A4 example found the Purchase Order Syntactically correct and 
sent a Receipt Acknowledgment. However, when while the private process is processing, it 
finds a disagreement/error with the Purchase Order Response. Since the Seller process 
would have completed its instance, a new instance of PIP0A1 is started to notify the Seller 
about the disagreement/error.

The Receiver side of PIP3B2 finds a disagreement/error while processing the Advance 
Shipment Notification in its Private process. However, the participant side has already sent 
a Receipt Acknowledgment after syntactically verifying the Advance Shipment 
Notification from the Shipper. Since the Shipper instance would have completed upon 
Acknowledgment receipt, a new instance of PIP0A1 is started to notify the Shipper about 
the disagreement/error.

Note: For demonstration purposes, the business processes in the tutorial examples are 
purposely configured to trigger Notification of Failure.

The following steps provides a brief overview of the PIP A01 business logic:

1. The PIP0A1 Failure Notifier business process (PIP0A1.jpd) receives a Notification of 
Failure request from either the PIP3A4 Seller or the PIP3B2 Receiver side.

2. The Failure Notifier processes the Notification of Failure request and sends a Notification 
of Failure message to the appropriate Report Administrator (in this case the 
PIP0A1ReportAdmin.jpd). The Failure Notifier process also writes a notification on the 
WebLogic Server Console to show that it has sent the message.

3. The Report Administrator process validates the Notification of Failure message and sends a 
receipt acknowledgement to the Failure Notifier. The process also writes a notification on 
the WebLogic Server Console to show that it has received the message.
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Components of the PIP0A1 Example
When you open the PIP0A1Processes folder in WebLogic Workshop, the application tab 
displays the contents of the folder.

The following table summarizes the components of the PIP0A1 example:

Table 2-4  Components of the PIP0A1: Notification of Failure Example

Role / Component Description

PIPA01.jpd The initiator business process that receives the 
Notification of Failure from the PIP3A4 initiator 
or the PIP3B2 participant. It then sends a 
Notification of Failure to the failure administrator 
business process by using an instance of the 
RosettaNet control.

Rn.jcx RosettaNet control definition file used to 
exchange messages with the failure administrator 
business process. For more information about the 
RosettaNet control, see RosettaNet Control in the 
WebLogic Workshop Online Help.

PIPA01Control.jcx Process control definition file that wraps 
PIPA01.jpd for use in other processes. 
Automatically generated by right-clicking the 
PIPA01.jpd file in the Application tab and 
choosing Generate Process Control.

PIP0A1ReportAdmin.jpd Business process that demonstrates the back end 
business logic used to process error messages and 
notifications.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsRosettaNet.html
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Walkthrough of the Failure Notifier Business Process
This section describes the example initiator business process (PIP0A1.jpd). To view this 
business process:

1. On the Application tab in WebLogic Workshop, open the PIP0A1Processes folder.

2. Double click the PIP0A1.jpd file.

3. If necessary, collapse the Retry block paths to see only the main (success) path.

PIP0A1Transformation.dtf Transformation control definition file which is 
used to generate XQueries. To learn more about 
transformation and XQueries, see Guide to Data 
Transformation.

getStaticProperties.xq XQuery that was generated when the 
getStaticProp Control Send with Return node was 
configured.

getFailureNotificationDoc.xq XQuery that was generated when the 
getFailureNotificationDoc Control Send with 
Return node was configured.

Sample Data Directory which contains sample XML data 
illustrating typical elements and data suggested 
by RosettaNet Message guidelines. 

Note: The data in this directory is not used in 
this tutorial since the input used when 
running the example is generated through 
an XQuery.

Table 2-4  Components of the PIP0A1: Notification of Failure Example (Continued)

http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguideIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguideIntro.html
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Success Process Path
The success path of the business process is as follows:

1. The Client Request node named Start receives a notification of failure message.

2. The Control Send with Return node named getStaticProp extracts the RosettaNet 
Context properties from the incoming message. For more information about RosettaNet 
Context, see RosettaNet Control Interface.

3. The setProperties Control Send node maps the extracted properties to a document based on 
the PIP0A1 Schema 

4. The Control Send with Return node named getFailureNotification uses the PIPA01 
transformation query to map the RosettaNet Context properties to a document based on 
the PIPA01 Schema. 

To view the fields that are being mapped, in the Application tab, double click on the 
getFailureNotification.xq file.

5. The Perform node named setDocType sets the DOCTYPE DTD value in the transformation 
output.

Note: This step is necessary since the WebLogic Integration transformation output by 
default does not contain the DOCTYPE property.

6. The group named Retry block contains a Control Send node named Send Notification of 
Failure and a Control Receive node named Receipt acknowledgement. This block sends a 
notification of failure to the PIP0A1ReportAdmin business process and waits for an 
acknowledgement that the message was received.

For demonstration purposes, the Send Notification of Failure node also prints a message to 
the WebLogic Server Console after it has sent the message to the PIP0A1ReportAdmin 
process.

7. The Client Response node at the end of the business process is a place holder for any 
business logic that would take place after the Notification of Failure message is sent to the 
PIP0A1ReportAdmin business process.

Failure Paths
The OnTimeout path handle failure management, such as in the event of a network failure. To 
view the failure path:

1. Expand the OnTimeout path next to the group of nodes named Retry block.

http://edocs.bea.com/workshop/docs81/doc/en/integration/java-class/com/bea/control/RosettaNetControl.html
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This path represents a standard BPM OnTimeout construct. The timeout value is set to two 
hours (the standard PIP retry interval) and three retries (the standard PIP retry count). 
Thus, if for any reason the acknowledgement fails to arrive within two hours, the group 
will be retried and the sendNotification of Failure step will be executed again. The 
OnTimeout path contains a condition that determines whether retries have been exhausted 
and, if so, logic could be added to the path which takes the appropriate action.

Walkthrough of the Report Administrator Business Process
The participant business process of the PIP0A1 example is named PIPA01ReportAdmin.jpd. 
To view the participant business process in WebLogic Workshop, in the Application tab, double 
click on PIPA01ReportAdmin.jpd.
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The Report Administrator business process includes the following steps:

1. The Notification of Failure message arrives at the Client Request node named Receive NoF.

2. The Perform node named Print NOF on System Console prints an acknowledgement on 
the WebLogic Server Console window. This node is a place holder for any business logic 
that would take place in a PIP0A1 Report Administrator business process used in 
production mode. 

3. The Client Response node named Send NoF Receipt Acknowledgment sends an 
acknowledgement back to the Failure Notifier process.

The following two examples in this tutorial, both utilize the PIP0A1 notification of failure 
example. To see how the example works, complete either “Running the PIP3B2 Example” on 
page 2-25 or “Running the PIP3A4 Example” on page 2-37.

Step 3: Open the PIP3B2: Notify of Advance Shipment Example 
This topic describes the example implementation of PIP3B2: Notify of Advance Shipment. 
It contains the following sections:
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About the PIP3B2 Example

Components of the PIP3B2 Example

Walkthrough of the Shipper Business Process

Walkthrough of the Receiver Business Process

Walkthrough of the Private Business Processes

Running the PIP3B2 Example

For detailed information about PIP3B2, see http://www.rosettanet.org.

About the PIP3B2 Example
PIP3B2 is an example of the asynchronous single action activity design pattern described in 
“RosettaNet Design Patterns” on page 2-7. The PIP3B2Processes folder contains business 
process definitions for PIP3B2. The PIP3B2Schemas schema project contains the schema file for 
the PIP3B2 message. The sampledata directory contains sample XML documents that you can 
use in section “Running the PIP3B2 Example” on page 2-25.

The following steps provides a brief overview of the PIP3B2 business logic:

1. The Shipper (initiator process PIP3B2.jpd) constructs an Notify of Advance Shipment 
message and sends it to the Receiver (participant process- PIP3B2Participant.jpd).

2. The Receiver validates the message and sends a receipt acknowledgement to the Shipper.

3. The Receiver submits the message to the backend system 
(PIP3B2ParticipantPrivate.jpd) for further processing.

4. The backend system encounters a problem during processing and invokes the PIP0A1 
example.

Components of the PIP3B2 Example
When you open the PIP3B2Processes folder in WebLogic Workshop, the application tab 
displays the contents of the folder.

http://www.rosettanet.org
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The following table summarizes the components of the PIP3B2 example:

Table 2-5  Components of the PIP3B2: Notify of Advance Shipment Example

Role / Component Description

Shipper (Initiator) RosettaNet role name.

PIP3B2.jpd Public initiator business process that sends the 
message, waits for the acknowledgement, and 
handles failures. Uses Rn.jcx, a RosettaNet 
control instance.

Rn.jcx RosettaNet control definition file which is used to 
exchange messages with the Receiver via RNIF. 
For more information about the RosettaNet 
control, see RosettaNet Control in the WebLogic 
Workshop Online Help.

The annotations on this control instance in 
PIP3B2.jpd include the PIP name and version, 
role names.

PIP3B2Control.jcx Process control definition file that wraps 
PIP3B2.jpd for use in other processes. 
Automatically generated by right-clicking the 
PIP3B2.jpd file in the Application tab and 
choosing Generate Process Control.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsRosettaNet.html
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Walkthrough of the Shipper Business Process
This section describes the example initiator business process (PIP3B2.jpd) for PIP3B2. To view 
this business process:

1. On the Application tab in WebLogic Workshop, double-click the PIP3B2Processes folder.

PIP3B2Private.jpd Private business process that invokes the 
PIP3B2.jpd business process via a process 
control.

This private business process can utilize the full 
power of BEA WebLogic Integration to access 
the backend systems, assemble the information, 
and transform the request data into the data format 
required for PIP3B2.

PIP3B2PrivateTransformation.dtf and 
PIP3B2PrivatepIP3B2ControlStart.xq 
(the associated.xq file)

Example transformation file. Automatically 
generated when a transformation is defined in a 
process node.

PIP3B2Transformation.dtf and 
getStaticProperties.xq (the associated.xq 
file)

Example transformation file. Automatically 
generated when a transformation is defined in a 
process node.

Receiver (Participant) RosettaNet role name.

PIP3B2Participant.jpd Public business process that receives the RNIF 
message and sends the receipt acknowledgement 
to the Shipper. The RosettaNet annotations 
include the PIP name, version, and role. For more 
information, see @jpd:rosettanet Annotation. in 
the WebLogic Workshop online help.

PIP3B2ParticipantPrivate.jpd Private business process that represents the 
backend processing of the shipment notice.

PIP3B2ParticipantPrivateControl.jcx Process control that wraps the private process for 
use in PIP3B2Participant.jpd. 
Automatically generated by right-clicking the 
PIP3B2ParticipantPrivate.jpd file in 
the Application tab and choosing Generate 
Process Control.

Table 2-5  Components of the PIP3B2: Notify of Advance Shipment Example (Continued)

http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
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2. Double-click the PIP3B2.jpd file.

3. If necessary, collapse the OnTimeout and On Error Message paths, as well as the Set static 
properties for header and Retry block groups to see only the main (success) path.

Success Path
The success path is the main path of the business process:

1. The Client Receive node named Start invokes the process when the Notify of Advance 
Shipment XML document (in this tutorial, the client request comes from the private process) 
is received.
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2. The Set static properties for header group contains a Control Send with Return node 
named getStaticProperties and a Control Send node named setStaticProperties. These two 
nodes extract the RosettaNet properties from the message and then map them to a document 
based on the PIP3B2 Schema.

3. The Retry block group contains a two nodes. The Control Send node named sendMessage 
sends a message to the Receiver (participant) via the sendMessage method on the 
RosettaNet control. The Control Receive node named Receipt acknowledgement waits for 
the receipt acknowledgement callback (rn_onAck method) from the Receiver.

4. Once the acknowledgement is received, the process responds to the private process via the 
Client Response node named Return Success.

Because PIP3B2 implements the single-action activity design pattern, no business action is 
returned from the Receiver—only a business signal (Receipt Acknowledgment or Exception). 
The response to the private process merely indicates a successful completion and returns no data.

Failure Paths
The OnTimeout and On Error Message paths handle failure management, such as in the event of 
a network failure. To view the failure paths:

1. Expand the OnTimeout path next to the group of nodes named Retry block.
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This path represents a standard BPM OnTimeout construct. The timeout value is set to two 
hours (the standard PIP retry interval) and three retries (the standard PIP retry count). 
Thus, if for any reason the acknowledgement fails to arrive within two hours, the group 
will be retried and the sendMessage step will be executed again. The OnTimeout path 
contains a condition that determines whether retries have been exhausted and, if so, the 
PIP 0A1 (Notification of Failure) subprocess is triggered (via a Control Send node), and 
the process responds to the private process with an error and finishes.

2. Expand the On Error Message path next to the PIP3B2 node at the top of the process.
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The Global Process Timeout is configured for the standard PIP timeout value of 24 hours. 
If the whole process fails to complete within this time, the PIP0A1 (Notification of Failure) 
subprocess is triggered and an error is returned to the private process.

Finally, the Receiver might reject the message for a variety of reasons (for example, the 
message fails validation). The message rejection is represented as the onError callback on 
the RosettaNet control. You can see that the global On Error Message handler is prepared 
to receive the error at any time and, if it does, it starts a subprocess to notify the 
administrator of the problem, returns an error to the private process, and exits. Notice that, 
if we cannot successfully send the message (for example, due to network problems), the 
business process starts the PIP0A1 (Notification of Failure) to try to notify the remote 
partner of the problem. Similarly, upon receipt of an error from the Receiver, the business 
process should notify the local administrator as well as the remote administrator.

Walkthrough of the Receiver Business Process
To view the participant business process in WebLogic Workshop, open the 
PIP3B2Participant.jpd file.
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The participant business process includes the following nodes:

1. The Client Request node named Receive Advance Shipping Notice receives the Notify of 
Advance Shipment message.

2. The Check if Notification of Advance Shipment Decision node validates the message 
and:

– Sends a receipt acknowledgement through the Send receipt acknowledgement Client 
Response node if the message is correct.

– Sends an error message through the send Exception Client Response node if there is a 
problem with the message.

3. In the Invoke private process group, the Control Send node named processShipment, 
passes the Notify of Advance Shipment to a private business process for further processing 
while the get Private Response Control Receive node waits for an acknowledgement from 
the private process.

Walkthrough of the Private Business Processes
The private processes on both sides are place holders for processes which in production 
environments would interact with backend applications. For example, the shipment notice can be 
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inserted into an ERP application via the Application View control and BEA adapters, sent on a 
message queue, and written out to file or database.

The public/private process pattern used in this example is not mandatory and is merely a 
recommended approach. You are free to partition your processes as best suits your environment. 
It is entirely possible to not use the private processes and implement all the necessary backend 
integration as well as RosettaNet interactions in a single process. However, separating processes 
into public (those that only deal with RosettaNet choreography) and private (those that deal with 
backend system integration) may improve the reuse and maintainability of your application.

In this example, the PIP3B2ParticipantPrivate.jpd is purposely configured to trigger an 
error and invoke the PIP0A1 example when you run the process.

Running the PIP3B2 Example
By default, BEA WebLogic Integration runs in Test (development) mode, which allows you to 
run the PIP3B2 example business processes on the same machine (collocated). In a production 
environment, each trading partner would run its respective business process on its own separate 
BEA WebLogic Integration server. For more information about the Test and Production modes, 
see “Configuring the Mode and Message Tracking” in Trading Partner Management (available at 
http://edocs.bea.com/wli/docs81/manage/tpm.html) in Managing WebLogic Integration 
Solutions.

To run the PIP3B2 example:

1. If it is not already running, start WebLogic Server. To do so, select Tools→WebLogic 
Server→Start WebLogic Server from the WebLogic Workshop menu.

If WebLogic Server is running, the following indicator is visible in the status bar at the 
bottom of the WebLogic Workshop visual development environment:

2. Open PIP3B2Participant.jpd and click on the WebLogic Workshop menu.

If your application is not already built, WebLogic Workshop builds your project. 

Note: You may see green compilation warnings in the build tab. You can ignore these 
warnings, the example will still execute correctly.

A Web browser is launched to display the Workshop Test Browser, through which you can 
test your business process using sample input values.

http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
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Note: It may take a while before the Test Browser window is launched after the application 
has completed the built process.

Do not actually try to execute it from the test browser. This step is needed to “prime” the 
participant process.

3. Return to WebLogic Workshop, open PIP3B2Private.jpd and click on the WebLogic 
Workshop menu.

4. In the test browser, Click Browse, and navigate to 
[file location]\rosettanet\pips\PIP3B2Processes\sampledata\3B2AdvanceSh
ipmentNotificationMessageBase.xml

Where [file location] is the directory in which you installed the tutorial files as 
described in “Step 3: Install the Tutorial Files” on page 1-9.

5. Click clientRequest.

6. In a few moments, the end-to-end choreography will execute. The client response will echo 
back the XML message.Bring up your WebLogic Server Console

7. In a few moments, you should see the following messages on the console:

>>>>> PIP0A1.jpd: Sent Notification of Failure

>>>>> PIP0A1ReportAdmin.jpd: GOT Notification of Failure.

8. Optionally, you can open the BEA WebLogic Integration Administration Console and 
observe message tracking and process tracking entries.

Step 4: Open the PIP3A4: Request Purchase Order Example
This topic describes the example implementation of the PIP3A4: Request Purchase Order. 
It contains the following sections:

About the PIP3A4 Example

Components of the PIP3A4 Example

Walkthrough of the Seller Business Process

Walkthrough of the Buyer Business Process

Walkthrough of the Private Business Processes

Running the PIP3A4 Example
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For detailed information about PIP3A4, see http://www.rosettanet.org.

About the PIP3A4 Example
PIP3A4 is an example of the asynchronous two-action activity design pattern described in 
“RosettaNet Design Patterns” on page 2-7. The PIP3A4Processes folder contains business 
process definitions for PIP3A4. The PIP3A4Schemas schema project contains the schema file for 
the PIP3A4 message. The sampledata directory contains sample XML documents that you can 
use when “Running the PIP3A4 Example” on page 2-37.

The PIP3A4 Request Purchase Order involves the following steps:

1. The Buyer (initiator) constructs a Purchase Order Request message and sends it to the Seller 
(participant).

2. The Seller validates the message and sends a receipt acknowledgement to the Buyer.

3. The Seller then submits the order request message to the backend system for further 
processing.

4. The Seller’s backend system generates a Purchase Order Confirmation (which confirms the 
availability of requested products and the expected ship dates).

5. The Seller sends the confirmation to the Buyer.

6. The Buyer acknowledges the receipt of the message to the Seller.

7. The Buyer passes the Purchase Order Confirmation to its backend system for processing, 
but encounters an error during processing which triggers the PIP A01 example.

Components of the PIP3A4 Example
When you open the PIP3A4Processes folder in WebLogic Workshop, the application tab 
displays the contents of the folder.

http://www.rosettanet.org
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The following table describes the components of the PIP3A4 example implementation.

Table 2-6  Components of the PIP3A4 (Request Purchase Order) Example

Role / Component Description

Buyer (Initiator) RosettaNet role name.

PIP3A4.jpd Public business process that exchanges 
messages with the seller, waits for the 
acknowledgement, and handles failures. Uses 
the RosettaNet control instance (Rn.jcx).

Rn.jcx RosettaNet control definition file used to 
exchange messages with the Seller via RNIF. 
For more information about the RosettaNet 
control, see RosettaNet Control in the 
WebLogic Workshop Online Help.

The annotations on this control instance in 
PIP3A4.jpd include the PIP name, version, 
and role names.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsRosettaNet.html
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PIP3A4Control.jcx Process control definition file that wraps 
PIP3A4.jpd for use in other processes. 
Automatically generated by right-clicking the 
PIP3A4.jpd file in the Application tab and 
choosing Generate Process Control.

PIP3A4Private.jpd Private business process that invokes the 
PIP3A4 process via a process control. This 
business process can utilize the full power of 
BEA WebLogic Integration to access the 
backend systems, assemble the information, 
and transform it into the required format for 
PIP3A4.

PIP3A4PrivateTransformation.dtf and the 
associated.xq files

PIP3A4Transformation.dtf and the associated 
getStaticProperties.xq file

Example transformation file. Automatically 
generated when a transformation is defined in a 
process node.

Seller (Participant) RosettaNet role name.

PIP3A4Participant.jpd Public business process that receives the 
message and sends the receipt 
acknowledgement, responds with a message 
and receives acknowledgement. The 
RosettaNet annotations include the PIP name, 
version, and role. For more information, see 
@jpd:rosettanet Annotation. in the WebLogic 
Workshop online help.

PIP3A4ParticipantPrivate.jpd Private business process that represents the 
backend processing of the purchase order and 
the creation of the PO Confirmation.

fc.jcx File control definition file which is used to read 
the PO Confirmation sample file from the local 
file system.

Table 2-6  Components of the PIP3A4 (Request Purchase Order) Example (Continued)

http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
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Walkthrough of the Seller Business Process
This section describes the example initiator business process (PIP3A4.jpd) for PIP3B2. To view 
this business process:

1. In WebLogic Workshop, open the PIP3A4.jpd file.

2. If necessary, collapse the OnTimeout and On Error Message paths, as well as any groups to 
see only the main (success) path.

PIP3A4ParticipantPrivateControl.jcx Process control that wraps the private process 
for use in PIP3A4Participant.jpd. 
Automatically generated by right-clicking the 
PIP3A4ParticipantPrivate.jpd file in 
the Application tab and choosing Generate 
Process Control.

PIP3A4ParticipantTransformation.dtf 
and the associated getStaticProperties1.xq 
file

Example transformation file. Automatically 
generated when a transformation is defined in a 
process node.

Table 2-6  Components of the PIP3A4 (Request Purchase Order) Example (Continued)
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Success Path
The success path business logic is as follows:

1. The Client Request node named Start receives the Purchase Order Request XML document 
message (in this tutorial, the client request comes from the private process).

2. The Set properties that go into service header group contains a Control Send with Return 
node named getStaticProperties and a Control Send node named setStaticProperties. 
These two nodes extract the RosettaNet properties from the message and then map them to 
a document based on the PIP3B2 Schema.

3. The Retry block group contains two nodes. The Control Send node named sendMessage 
sends a message to the Seller (participant) via the sendMessage method on the RosettaNet 
control. The Control Receive node named Receipt acknowledgement waits for the receipt 
acknowledgement callback (rn_onAck method) from the Receiver.

4. Once the acknowledgement is received, the business process waits for the Purchase Order 
Confirmation at the Control Receive node named onMessage.

5. The Correctnonamespace Perform Node adds the correct name space to the received XML 
Bean. (This step is necessary since Schemas in the project folder cannot have the same 
name space.) 

6. After receiving the Purchase Order Confirmation, the Decision node validates the message 
and:

– Sends a receipt acknowledgement through the Send PO Ack receipt 
acknowledgement Control Send node if the message is correct.

– Sends an error message through the sendError Control Send node if there is a problem 
with the message.

7. The business process responds to the private process with the PO Confirmation through the 
Return PO ack Client Response node.

8.  The Process Message Perform node is purposely configured to trigger an error and invoke 
the PIP0A1 example.

Note: BEA WebLogic Integration allows the receipt acknowledgement and business message 
to be received in either order, in conformance with RosettaNet specifications. If the 
initiator receives the response message before the receipt acknowledgement, the 
response message is queued for later processing.
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Failure Paths
The OnTimeout and On Error Message paths handle failure management, such as in the event of 
a network failure. To view the failure paths:

1. Expand the OnTimeout path next to the group of nodes named Retry block.

This path represents a standard BPM OnTimeout construct. The timeout value is set to two 
hours (the standard PIP retry interval) and three retries (the standard PIP retry count). 
Thus, if for any reason the acknowledgement fails to arrive within two hours, the group 
will be retried and the sendMessage step will be executed again. The OnTimeout path 
contains a condition that determines whether retries have been exhausted and, if so, the 
PIP 0A1 (Notification of Failure) subprocess is triggered (via a Control Send node), and 
the process responds to the private process with an error and finishes.
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2. Expand the On Error Message path next to the PIP3A4 node at the top of the process.

The Global Process Timeout is configured for the standard PIP timeout value of 24 hours. 
If the whole process fails to complete within this time, the PIP0A1 (Notification of Failure) 
subprocess is triggered and an error is returned to the private process.

Finally, the Receiver might reject the message for a variety of reasons (for example, the 
message fails validation). The message rejection is represented as the onError callback on 
the RosettaNet control. You can see that the global On Error Message handler is prepared 
to receive the error at any time and, if it does, it starts a subprocess to notify the 
administrator of the problem, returns an error to the private process, and exits. Notice that, 
if we cannot successfully send the message (for example, due to network problems), the 
business process starts the PIP0A1 (Notification of Failure) to try to notify the remote 
partner of the problem. Similarly, upon receipt of an error from the Receiver, the business 
process should notify the local administrator as well as the remote administrator.

Walkthrough of the Buyer Business Process
The participant business process (PIP3A4Participant.jpd) on the Seller side is less complex 
than the initiator business process. To view the participant business process in WebLogic 
Workshop, open the PIP3A4Participant.jpd file.
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The participant business process includes the following steps:

1. The Client Request node Receive PO message receives the Purchase Order Request message.

2. The Check for noNamespace and do the correction Perform node adds the correct name 
space to the received XML Bean. (This step is necessary since Schemas in the project folder 
cannot have the same name space.)

3. The Decision node validates the PO and:
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– Sends a receipt acknowledgement to the Buyer through the Send receipt 
acknowledgement Client Response node if the PO is correct.

– Sends an error message through the send Exception Client Response node if there is a 
problem with the PO.

4. In the Invoke Private Process group, the processOrder Control Send node passes the PO 
Request to a private business process for further processing, while the onPOAck Control 
Receive node waits for the response back from the private process. The private process 
constructs the response that was sent after reading the confirmation using a File Control.

5. The Controls Send with Return node named getStaticProp extracts the RosettaNet 
Context properties from the incoming message. These properties are needed only in case 
of errors. These properties can be saved for later use and contains the information that is 
needed to construct the PIP0A1 Notification of Failure. For example: from / to / message id 
/ etc.

6. In the Retry block group, the Send PO Acknowledgement Client Response node sends the 
Purchase Order Confirmation message to the buyer using the sendReply callback method, 
while the Receive receipt acknowledgement Client Request node waits for the receipt 
acknowledgement.

Unlike the 3B2 participant business process, which merely receives the message, the 3A4 
participant business process sends out a response, so it is necessary to account for failure 
scenarios, such as network failures or validation failure. Open the onTimeout path on the Retry 
Block to display the time-outs and retries. Note that this path is similar to the onTimeout path in 
the 3B2 initiator business process described in “Walkthrough of the Shipper Business Process” 
on page 2-19. In addition, there is a global onMessage handler that handles errors returned by the 
Buyer.

Walkthrough of the Private Business Processes
As in the 3B2 example, the private processes on both sides are merely place holders for backend 
business logic. The participant private process actually echoes the received message. You would 
typically customize these processes to tie them with the backend applications. For example, the 
shipment notice can be inserted into an ERP application via the Application View control and 
BEA adapters, sent on a message queue, written out to file or database. 

The public/private process pattern used in this example is not mandatory and is merely a 
recommended approach. You are free to partition your processes as best suits your environment. 
It is entirely possible to not use the private processes and implement all the necessary backend 
integration as well as RosettaNet interactions in a single process. However, separating processes 
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into public (those that only deal with RosettaNet choreography) and private (those that deal with 
backend system integration) may improve the reuse and maintainability of your application.

Running the PIP3A4 Example
To run the PIP3A4 example:

1. This example uses a File Control to read the PO Confirmation message from your local file 
system. Before you can run the example, you have to set the directory path in the fc.jcx file 
so that it can find the correct sample data file:

a. In the Application tab, double-click the fc.jcx file.

b. Click the Source View tab.

c. Set the directory-name attribute to:
[file location]\tptutorialapps\rosettanet\pips\PIP3A4Processes\sampl
edata

Where [file location] is the directory in which you installed the tutorial files as 
described in “Step 3: Install the Tutorial Files” on page 1-9.

2. If it is not already running, start WebLogic Server. To do so, choose Tools→WebLogic 
Server→Start WebLogic Server from the WebLogic Workshop menu.

If WebLogic Server is running, the following indicator is visible in the status bar at the 
bottom of the WebLogic Workshop visual development environment:

3. Open PIP3A4Participant.jpd and click on the WebLogic Workshop menu.

If the project is not already built, WebLogic Workshop builds your project. 

Note: You may see green compilation warnings in the build tab. You can ignore these 
warnings, the example will still execute correctly.

A Web browser is launched to display the Workshop Test Browser, through which you can 
test your business process using sample input values.

Note: It may take a while before the Test Browser window is launched after the application 
has completed the built process.

Do not actually try to execute it from the test browser. This step is needed to “prime” the 
participant process.
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4. Return to WebLogic Workshop, open PIP3A4Private.jpd and click .

5. In the test browser, Click Browse, and navigate to 
[file location]\rosettanet\pips\PIP3A4Processes\sampledata\3A4PurchaseO
rderRequestMessageBase_0010.xml

Where [file location] is the directory in which you installed the tutorial files as 
described in “Step 3: Install the Tutorial Files” on page 1-9.

6. Click clientRequest.

In a few moments, the end-to-end choreography will execute. The client response will echo 
back the XML message.

7. Bring up your WebLogic Server Console

In a few moments, you should see the following messages on the console:

>>>>> PIP0A1.jpd: Sent Notification of Failure

>>>>> PIP0A1ReportAdmin.jpd: GOT Notification of Failure.

8. Optionally, you can open the BEA WebLogic Integration Administration Console and 
observe message tracking and process tracking entries.
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Implementing New PIPs Based on the Example PIPs
This topic describes implementing new PIP based on the example PIPs in this tutorial. It contains 
the following topics:

About Implementing New PIPs

Copying and Customizing PIP Implementations

Converting RosettaNet DTD Schemas to XSD Schemas

About Implementing New PIPs
You can implement a new PIP based on an existing PIP implementation with a similar design 
pattern. For example, PIP 3A2: Request Price and Availability, is an example of a message send 
with response design pattern. Therefore, the business process choreography is identical to that of 
PIP3A4. The main differences are that the request and response message schemas are different 
and the annotations must be changed. You can duplicate and rename the 3A4 processes and 
change the schema type of the messages to easily create a PIP 3A2. implementation. For detailed 
information about PIP3A4, see http://www.rosettanet.org.

Copying and Customizing PIP Implementations
To implement a new PIP based on an existing PIP implementation, complete the following tasks:

1. Download the PIP distribution, including the specification and any DTDs, from the 
RosettaNet web site at http://www.rosettanet.org.

2. Optionally, convert any DTDs to XSD files, as described in “Converting RosettaNet DTD 
Schemas to XSD Schemas” on page 2-40.

3. Copy the example PIP implementation associated with the design pattern that you want to 
use.

4. In WebLogic Workshop, import the schema for the new PIP into the project and then 
change the schema definition to the new PIP.

5. Change the RosettaNet annotations for the new PIP:

– For public initiator business processes, you change the pip and pip-version, 
to-role, and from-role attributes (and others if needed) in the @jc:rosettanet 
Annotation, which is available at 

http://www.rosettanet.org
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jc/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jc/rosettanet.html
http://www.rosettanet.org
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http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jc/rosettanet.html
.

– For public participant business processes, you change the pip-name, pip-role and 
pip-version attributes (and others if needed) in the @jpd:rosettanet Annotation, 
which is available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.ht
ml. 

6. Rename the JPD and JCX files and change the names of other components to be more 
descriptive of the new PIP implementation, if you want.

7. Change the implementation of any private business processes as needed.

8. Make any other changes as needed.

Converting RosettaNet DTD Schemas to XSD Schemas
The RosettaNet W3C XSD schemas for selected PIPs are included in the RosettaNet Self-Test 
Kit (STK) which can be downloaded from the Developer Tools area on the RosettaNet Ready 
Web site, available at: http://www.rosettanet.org.

If the schema for the PIP you are using is not available on this web site, it is possible to implement 
RosettaNet solutions in WebLogic integration using RosettaNet message definitions specified as 
DTD files. However, it is recommended to use W3C XSD files instead, since many of the 
WebLogic Integration tools such as the XQuery mapping tools (used to define data 
transformations) only support XSD schemas.

If you want to use the graphical XQuery mapping tools, you need to convert the RosettaNet DTD 
files to W3C XSD files (using a tool like XML Spy Enterprise Edition) and then import the XSD 
files into your project. Make sure that you refer to the RosettaNet Message Guidelines for the PIP 
which DTD file you are converting and add the appropriate validation rules for Service Content 
Validation to your XSD file after the conversion.

When converting the files, consider the following issues:

When you convert the DTD to W3C schema, you might get an error message about the 
xml:lang name. To fix the problem, replace the following text:

<xs:extension base="xs:string">

<xs:attribute name="xml:lang" type="xs:string"/>

</xs:extension>

with the following text:

http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jc/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/rosettanet.html
http://www.rosettanet.org
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<xs:extension base="xs:string">

<xs:attribute ref="xml:lang"/>

</xs:extension>

and add the following import statement:

<xs:import namespace="http://www.w3.org/XML/1998/namespace"
 schemaLocation="http://www.w3.org/2001/xml.xsd"/>

Save the schema file, and then drag and drop it into a Workshop schema project.

The schema generated by XMLSPY has elements that have both a name and reference, as 
shown in the following example.

<xs:element name="ActionIdentity" ref="ActionIdentity"/>

This creates problems in WebLogic Workshop. To fix the file, open it in WebLogic 
Workshop, press Ctrl+H, make sure that wildcard pattern matching is enabled, and then 
replacing all occurrences of:

name="*" ref

with

ref

as in the following example:

<xs:element ref="ActionIdentity"/>

In some cases, two different schemas will contain identical element definitions, which results in 
schema compilation problems. The name collisions can be avoided by using explicit 
targetNamespace. For example for the 3A4 Purchase Order Request W3C Schema in this 
tutorial we use: <xs:schema id="Pip3A4PurchaseOrderRequest" 
targetNamespace="Pip3A4PurchaseOrderRequest" 

xmlns="Pip3A4PurchaseOrderRequest">

After you build the schema projects, the PIP types will become available in the type system for 
use in parameter and variable types.
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C H A P T E R 3

Tutorial: Building ebXML Solutions

The ebXML language (Electronic Business using eXtensible Markup Language) is a business 
protocol that enables enterprises to conduct business over the Internet. WebLogic Workshop uses 
ebXML controls for initiator processes and ebXML Participant Business Processes templates for 
participant processes to build business processes systems which exchange ebXML business 
messages between trading partners. The ebXML control provides the initiator business process 
with predefined customizable methods for sending and receiving ebXML messages in a 
conversation. The ebXML Participant Business Process template provides a head start for 
building public participant business processes for ebXML conversations. Although the template 
is not required to build ebXML participant business processes, it includes the nodes and business 
process annotations needed to integrate easily with ebXML initiator business processes. The 
purpose of this tutorial is to demonstrate the different options available for ebXML trading 
partner management in WebLogic Workshop and WebLogic Integration.

Before You Begin
This topic describes tasks that you should perform before you begin using this tutorial. It contains 
the following sections:

Prerequisites

Suggested Reading

Prerequisites
To use this tutorial, you must have:
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Installed WebLogic Platform 8.1 on your system according to the instructions in Installing 
WebLogic Platform, which is available at 
http://edocs.bea.com/platform/docs81/install/index.html.

Completed the tutorial setup procedure according to the instructions in “Setting Up the 
Tutorials” on page 1-2.

Suggested Reading
To gain a detailed understanding of how ebXML solutions are implemented in WebLogic 
Integration, consider reading the following material:

For an overview of integrating trading partners using BEA WebLogic Integration, see 
Introducing Trading Partner Integration, which is available at 
http://edocs.bea.com/wli/docs81/tpintro/index.html.

For an introduction to ebXML solutions using BEA WebLogic Integration, see Introducing 
ebXML Solutions in Introducing Trading Partner Integration, which is available at 
http://edocs.bea.com/wli/docs81/tpintro/ebxml.html.

For more information about using the ebXML control in initiator business processes, see 
ebXML Control in the WebLogic Workshop Online Help. 

For information about using participant business processes, see the following topics in the 
WebLogic Workshop Help:

– Building ebXML Participant Business Processes, which is available at

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.htm
l

– @jpd:ebXML Annotation, which is available at

http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html

To learn how to build business processes and create data transformations in WebLogic 
Workshop, consider completing the following tutorials:

Tutorial: Building Your First Business Process, which is available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html 

Tutorial: Building Your First Data Transformation, which is available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.
html

http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/wli/docs81/tpintro/index.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html
http://edocs.bea.com/wli/docs81/tpintro/ebxml.html
http://edocs.bea.com/wli/docs81/tpintro/ebxml.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransIntro.html
http://edocs.bea.com/platform/docs81/install/index.html
http://edocs.bea.com/wli/docs81/tpintro/index.html
http://edocs.bea.com/wli/docs81/tpintro/ebxml.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html
http://edocs.bea.com/platform/docs81/install/index.html
http://edocs.bea.com/platform/docs81/install/index.html
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Tutorial Overview
In this tutorial, the first couple of examples contains detailed instructions of how to use the 
WebLogic Workshop user interface and the WebLogic Integration Administration Console user 
interface to perform the steps outlined in the example. The preceding examples build on the skills 
you learn in the first couple of sections, but do not outline the steps in quite as much detail.

The tutorial is organized into these parts:

“Step 1: Getting Started” on page 3-4
This section describes how to create the business process application in which you will 
create the business processes and other components required for the examples of the 
tutorial. It also describes how to import the sample data and schemas which are included 
in the zipped archive of the tutorial files.

“Step 2: Sending an XML Message through an One-Way ebXML Exchange” on page 3-9
This example demonstrates how to send an XML message from one trading partner to 
another through a simple one-way ebXML exchange. In this example, you will learn how 
to create participant and initiator business processes as well as, how to create and 
configure ebXML and file controls. The section also contains a detailed description of 
how to deploy and test business processes using the WebLogic Workshop Test Browser.

“Step 3: Selecting the Trading Partner Information Dynamically Through Typed XML” on 
page 3-23

This example is similar to the preceding one except for that this example demonstrates 
how to specify the trading partner information dynamically by using an XQuery selector, 
rather than specifying it statically in the ebXML control. It also describes how to 
configure the ebXML control to use typed XML data and specific method names.

“Step 4: Sending Raw Data (Binary File) Through an ebXML Exchange” on page 3-32
In this example, you learn how to use ebXML to send binary data between two trading 
partners through a Message Broker channel.

“Step 5: Creating a Roundtrip ebXML Conversation” on page 3-38
This section describes how to implement an ebXML conversation in which when a request 
message (order) is received, a response (invoice) message is sent back by adding a Client 
Response node to the participant business process and using the ebXML control callback 
feature to send the response message.

“Step 6: Implementing the Public/Private Pattern” on page 3-46
This example illustrates how to use subprocesses to implement the public/private pattern. 
The public/private pattern can be used to keep the details of backend integration contained 
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to a private process definition, while the public process definitions are dedicated to trading 
partner interaction.

“Step 7: Using the TPM Control and Callbacks” on page 3-51
In this section, you learn how to at run time obtain trading partner information from the 
TPM repository. You also learn how to use the onAck callback of the ebXML control.

“Step 8: Setting Partner ID Dynamically Based on Directory Name” on page 3-56
In this example, you investigate the already built application included with the tutorial 
files to learn how to read the name of a sub-directory and use that as the partner ID. The 
business process sets the partner ID dynamically using the setProperties method included 
in the ebXML control.

“Step 9: Creating a Distributed Setup” on page 3-61
This example briefly explains how to move to a distributed setup where one trading 
partner operates in one WebLogic Integration instance while the other trading partner 
operates in another instance. This is the setup that you would use in a production scenario 
where the two trading partners are running on two physically separated systems.

“Step 10: Configuring Non-Default Protocol Settings” on page 3-62
In this section you will learn how to add a service and a service profile in the WebLogic 
Integration Administration Console, which will give you control over trading partner 
communications.

“Step 11: Exchanging Messages with WebLogic Integration - Business Connect” on page 
3-64

This example describes how to send messages between WebLogic Integration and 
WebLogic Integration - Business Connect. WebLogic Integration - Business Connect is a 
separate application which enables you to securely exchange large volumes of documents 
with your trading partners. You must have a current license of WebLogic Integration - 
Business Connect to be able to complete this example.

Step 1: Getting Started
Before you start the ebXML tutorial, you have to complete the procedures described in “Setting 
Up the Tutorials” on page 1-2. If you have not yet completed these procedures, please do so 
before proceeding with this section. 

In this step, you use WebLogic Workshop to create application, in which you build the ebXML 
tutorial business processes. You then import the sample data and schemas provided in the zipped 
archive that came with the tutorial files (see, “Step 3: Install the Tutorial Files” on page 1-9). The 
sample data and schemas are used to illustrate the functionality of the ebXML tutorial examples. 
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Lastly, you create two directories on your hard drive which are used throughout the tutorial to 
read files from and to write files to.

This section contains the following procedures: 

“Creating the Business Process Application” on page 3-5

“Importing the Tutorial Sample Data” on page 3-8

“Importing the Tutorial Schemas” on page 3-8

Creating the Business Process Application
WebLogic Integration extends the WebLogic Workshop to allow the building of integrated 
enterprise applications. An application in turn contains projects and files. A project can contain 
several components including, business processes, Web services, and XML files. In this section, 
you will create the Business Process Application in which you will later build the ebXML tutorial 
processes and process components.

To Create a Business Process Application

1. Start WebLogic Workshop:

To Start WebLogic Workshop on Windows:

a. Invoke WebLogic Workshop from the Start menu by choosing: 

Start→Programs→BEA WebLogic Platform 8.1→WebLogic Workshop 8.1. 

If this is the first time WebLogic Workshop is started since it was installed, the samples 
project, which contains sample services installed with WebLogic Workshop, is 
displayed. Otherwise, the project which was opened last is displayed. 

To Start WebLogic Workshop on Linux:

a. Using a file system browser or shell, locate the Workshop start script at: 
$HOME\bea\weblogic81\workshop\Workshop.sh 

Where HOME is your Workshop install directory.

b. Start WebLogic Workshop using one of the following methods: 

-Use the following command from the command line: 

sh Workshop.sh 

-From a file system browser, double-click Workshop.sh. 
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2. From the WebLogic Workshop menu, click File→New→Application. The New 
Application dialog box is displayed.

3. In the New Application dialog box, select Process in the left pane, and select Process 
Application in the right pane.

4. In the Directory field, select the directory in which you want to create your application. 
The examples in this tutorial assumes that the application will be created in: 
C:\myapps\tptutorialapps. If you create the directory in a different location or use 
another name, adjust the instructions accordingly.

5. In the Name field, enter ebXML.

6. Click the arrow beside the Server field to display a list of servers. Then choose the server 
which you created when you set up your domain in “Step 1: Create a New WebLogic 
Integration Domain” on page 1-3. 

7. Click Create.

8. Your Process Application is created and displayed in the Application pane. If the 
Application pane is not visible in WebLogic Workshop, choose View→Application from 
the menu bar.
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The Application pane displays a hierarchical representation of the files and resources 
available in your application. The components we will work with in this tutorial includes 
the following:

ebXML—The application folder.

ebXMLWeb—A Web application project folder. Every application contains one or more 
projects. Projects represent WebLogic Server Web applications. In other words, when you 
create a project, you are creating a Web application. (The name of your project is included 
in the URL your clients use to access your application.)

Web Applications are J2EE deployment units that define a collection of Web resources 
such as business processes, Web services, JSPs, servlets, HTML pages, and can define 
references to external resources such as EJBs.

Note: The Web application project folder is named by appending Web to the name you gave 
your application.

Schemas—A Schemas project that contains the XML Schemas and the Message Broker 
channel file used in the application. It also contains ebXML envelope schemas that are 
used to package ebXML messages.

9. Expand the ebXMLWeb folder.

The processes folder inside the ebXMLWeb folder is created when you created your 
business process application. Since we do not need it for our tutorial, you can delete it:

10. Right-click on the processes folder and select Delete from the drop-down menu.

11. Click Yes in the confirmation dialogue.

You have now completed the first step in this tutorial and are ready to start creating the tutorial 
ebXML business processes. For more information about business process applications, see Guide 
to Building Business Processes available at: 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideIntro.html

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideIntro.html
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Importing the Tutorial Sample Data
In this tutorial, we use sample data files to send in the ebXML messages. You can use your own 
XML data files if you wish, but some sample data files have been provided for you in the 
tptutorial.zip archive that you downloaded from the http://dev2dev.bea.com web site (see, “Step 
3: Install the Tutorial Files” on page 1-9). 

To Import the Sample Data Into Your Project Application

1. In the Application pane, right click on ebxmlWeb.

2. Select Import... from the drop-down menu.

The Import File window opens.

3. In the Import File window, navigate to [unzip 
location]\tptutorialapps\ebxml\ebxmlWeb\sampledata where [unzip 
location] is the directory to which you unzipped the files from the tptutorial.zip (see, 
“Step 3: Install the Tutorial Files” on page 1-9).

4. Click Import.

A folder named sampledata which contains the files sampleinvoice.xml and 
sampleorder.xml is added to your Application pane.

Note: Instead of the preceding steps, you could simply drag and drop the sampledata folder 
from any file browser directly into your Application pane in Weblogic Workshop.

Importing the Tutorial Schemas
In this tutorial, specific schemas are used for the XML data that is sent by the ebXML messages. 
This section describes how to import the schemas into your schemas folder in your ebXML 
application. 

To Import the Tutorial Schemas

1. In the Application tab, right-click on a Schemas folder. (If the Application tab is not visible 
in WebLogic Workshop, choose View→Application from the menu bar.)

2. From the drop-down menu, select Import....

The Import Files dialog box is displayed.

http://dev2dev.bea.com
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3. Navigate to: [unzip location]\tptutorialapps\ebxml\Schemas. Where [unzip 
location] is the directory to which you unzipped the files from the tptutorial.zip file 
(see,“Step 3: Install the Tutorial Files” on page 1-9).

4. Select b2bborder.xsd and b2binvoice.xsd by clicking on the files while holding down the 
ctrl key.

5. Click Import.

When a XSD or MFL file is imported, a build of the current Schemas project folder is triggered. 
(The build verifies that the schema file is well formed. For XSD files, it also verifies that the 
element and attribute names in the XML Schema do not conflict with the XSD files that have 
already been imported into the current Schemas project folder.) For more information about what 
gets generated when you import schemas, see Importing Schemas available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguidemapperimportschema
s.html.

Creating the Read and Write Directories
To demonstrate how messages can be exchanged by ebXML, several of the examples in this 
tutorial write out files to and read files from directories on your hard drive. Before you start 
working with any of the examples in this tutorial, create the following two directories on your 
hard drive:

C:\tptutorial\binary-in

C:\tptutorial\binary-out

Note: This is assuming that you created your application in “Creating the Business Process 
Application” on page 3-5 on the C drive. If you created the application on another drive, 
please place the above directories at the root level of that drive.

Step 2: Sending an XML Message through an One-Way ebXML 
Exchange

In this example, you will learn how to send an XML message from one trading partner to another 
using ebXML. Imagine that one of the trading partners is accepting and processing orders. We 
refer to this partner as the seller and it is the participator of the ebXML conversation. The other 
trading partner, which we call the buyer, sends an XML order to the seller. The buyer is the 
initiator of the conversation. The seller accepts the message and simply writes it out to a file. This 
section contains the following procedures:

http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguidemapperimportschemas.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguidemapperimportschemas.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguidemapperimportschemas.html
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“Building the Seller Business Process” on page 3-10

“Building the Buyer Business Process” on page 3-17

Building the Seller Business Process
The Seller business process is the participator of our ebXML conversation. When building 
ebXML participator processes, you can use the ebXML Participant Process file which comes 
pre-configured with the nodes, variables, and other components necessary for building 
participants processes. In this example, you add a File control to the business process which 
writes the test data out to a file located on your hard drive. This section includes the following 
tasks:

“To Create the Seller Business Process File”

“To Create the File Control and the Control Node” on page 3-12

“To Configure the Control Node” on page 3-14

“To View the ebXML Source View Parameters” on page 3-15

“To Test the Seller Process” on page 3-16

To Create the Seller Business Process File

1. In the Application pane, right-click ebxmlWeb and select New→Folder....

The New Folder dialogue opens.

Note: If the Application pane is not visible in WebLogic Workshop, choose 
View→Application from menu bar.

2. In the New Folder dialogue, enter ebxml as the name of your new folder.

3. Click OK.

A new folder named ebxml is added as a sub folder under ebxmlWeb in the Application 
pane. 
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4. In the same way as described in the preceding steps, create another new folder as a sub 
folder under ebxml and name it oneway.

5. Right-click on oneway and select New→Process File in the drop-down menu.

The New File window opens.

6. In the New File window, select Processes from the left pane and ebXML Participant 
Process File from the right pane.

7. In the File name field, enter Seller.jpd.
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8. Click Create.

A new ebXML participant process file is created in your oneway folder in the Application 
pane and is displayed in Design View.

The ebXML participant process file is created pre-configured with the nodes and business 
process annotations needed to integrate easily with ebXML initiator business processes. 
For more information about ebXML participant process files, see Building ebXML 
Participant Business Processes available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.html.

9. In this example, we will not respond to the buyer process, so we can delete the Respond to 
request node: right-click on the node and select Delete from the drop-down menu.

In this example, instead of responding to the buyer process, we add a File control which will write 
out the incoming ebXML messages to a file. This File control is then added to the business 
process as a Control Send with Return node.

To Create the File Control and the Control Node

1. In the Controls section of the Data palette, select Add→Integration Controls→File.

The Insert Control - File window opens.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideEbXML.html
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2. In the Insert Control - File window, enter the following:

a. In the STEP 1, enter file as the name of the variable to use for the File control. This name 
must be a valid Java identifier.

b. In STEP 2, select the Create a new File control to use option and enter File as the name 
of the new JCX file that will be created.

c. In STEP 3, enter /tptutorial as the directory-name. This is the directory to which the 
message received by the Seller.jpd will be written. In this tutorial, we always use the 
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tptutorial directory that you created in the “Creating the Read and Write Directories” on 
page 3-9 section as the directory to read from and write to.

d. In STEP 3, enter order.xml as the file mask This is the name of the file to which the 
message received by the Seller.jpd will be written.

e. In STEP 3, select XmlObject as the type of data contained in the received message from 
the file-type drop-down menu.

3. Click Create.

The File control instance is added to your list of controls in the Data palette, and a JCX 
file corresponding to the File control is added to the Application palette. For more 
information about File controls, see File Control available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsFile.html. For 
more information about JCX files, see JCX Files: Extending Controls available at 
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html.

4. In the Data palette, expand the File control by clicking on the + next to it.

The methods associated with the File control are displayed.

5. Select the FileControlPropertiesDocument write(XmlObject someData)method.

6. Drag the selected method into Design View and drop it on the  which appears 
immediately following the Receive request node.

A new Control Send with Return node named write is added to your business process. 
For more information about Control Send with Return nodes, see Interacting With 
Resources Using Controls available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html.

The next step in our procedure is to configure the Control Node we just created with the correct 
variables and method assignments.

To Configure the Control Node

1. Double-click the new write node.

The write node builder is invoked.

2. Click Send Data.

3. From the Select variables to assign drop-down menu, select payload as the variable to 
assign to the write method.

http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsFile.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsFile.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
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4. Click Apply to apply your selection.

5. Click Close to close the node builder.

6. Select File→Save or enter Ctrl+S to save your work. 

Your seller side ebXML process is now complete. The process is invoked when an XML message 
is received from the Buyer initiator process by the Receive request node, the Receive request 
node assigns the XML to a variable, and the write node writes the XML message to a file named 
order.xml via the File control.

Note: The grey check box icon is there because the receive data tab of the node has not been 
configured which marks the node as incomplete. However, since the example is not 
receiving any data, no more configuration is necessary for the business process to run 
properly.

To View the ebXML Source View Parameters
The ebXML binding information and service name of the business process is displayed in the 
Property Editor in Source View. To view these properties:

1. Click the Source View tab.

2. Click on public class Seller implements com.bea.jpd.ProcessDefinition to 
display the Property Editor for the Seller class.

3. In the Property Editor, note the following: 

– In the process section, the binding is listed as ebxml.

– In the ebxml section, the ebxml-service-name property is set to Seller. This is the 
name you gave your process and it corresponds to the eb:Service entry in the ebXML 
message envelope. It is also the name used by the initiator business process as the 
ebXML service name. This is the name that trading partners will use to identify this 
service, it also matches the initiator process with the participant process.

For more information about Source View ebXML process annotations, see @jpd:ebxml 
Annotation available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html.

We are now ready to test the Seller business process. WebLogic Workshop provides a 
browser-based interface through which you can test the functionality of your business process. 
Using this Test View interface, you play the role of the client, invoking the business process's 
methods and viewing the responses. 

http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/javadoc-tag/jpd/ebxml.html
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To Test the Seller Process

1. If it is not already running, start WebLogic Server. to do so, choose Tools→WebLogic 
Server→Start WebLogic Server from the WebLogic Workshop menu.

If WebLogic Server is running, the following indicator is visible in the status bar at the 
bottom of the WebLogic Workshop visual development environment:

2. Click on the WebLogic Workshop menu.

WebLogic Workshop builds your project. If there are no errors in the project, a Web 
browser is launched to display the Workshop Test Browser, through which you can test 
your business process using sample input values.

Note: It may take a while before the Test Browser window is launched after the application 
has completed the built process.

3. If not already displayed in the Test Browser window, click Test Form.

4. To enter test data, do one of the following:

– Click Browse, and navigate to 
C:\myappstptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml.

– Cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml, 
except for the first line of the file, into the xml variable (payload) field.

5. Click request.

The Test Form page refreshes to display a summary of your request parameters.

6. Click Refresh to refresh the summary.

7. Scroll down to the Operation request section to see the content of the sampleorder.xml 
file.

8. Using a file browser or command line tool, navigate to your C:\tptutorial directory.

It now contains a file named order.xml with identical content to that of sampleorder.xml. 
This file was written by the File control that you created and configured in the section “To 
Create the Seller Business Process File” on page 3-10.

9. Return to WebLogic Workshop and click  on the tool bar to stop and close the Test 
Browser.
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For more information about the different options in the Test Browser and how to use it to test your 
business processes, see Running and Testing Your Business Process available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideTest.html.

Your Seller business process is now deployed and ready to accept ebXML messaged. By default 
the protocols specified in the default ebXML 2.0 binding will be used, so no additional 
configurations are required. In production scenarios however, you typically create a TPM service 
profile using the WebLogic Workshop Administration Console. For more information about 
creating service profiles, see Adding Service Profiles to a Service in Trading Partner Management 
(available at http://edocs.bea.com/wli/docs81/manage/tpm.html) in Managing WebLogic 
Integration Solutions.

Building the Buyer Business Process
The Buyer business process is the initiator of our ebXML conversation. After creating the Buyer 
business process, we will use an ebXML control to communicate with the Seller participator 
business process. This section contains the following procedures:

“To Create the Buyer Business Process File” on page 3-17

“To Configure the Client Request Node” on page 3-19

“To Create the ebXML Control and Control Node” on page 3-20

“To Configure the Request Node” on page 3-22

“To Test the Buyer Business Process” on page 3-23

To Create the Buyer Business Process File

1. In the Application pane, right-click on oneway and select New→Process File.

The New File window opens.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideTest.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideTest.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
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Since we are creating a initiator business process file this time and will use a ebXML file 
control to communicate with the participator process, we will create a default process file 
rather than an ebXML participant process file.

2. In the New File window, select Processes from the left pane and Process File from the 
right pane.

3. Enter Buyer.jpd in the File name field.

4. Click Create.

A new Buyer.jpd file is added to your Application pane and displayed in Design View.
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The Buyer.jpd file contains a Start node, a Starting Event place holder and a Finish node. 

5. Double-click on the Starting Event place holder.

The Starting Event selection window is displayed.

6. Select Invoked via a Client Request.

7. Click OK.

A Client Request node is added as the Starting Event to your business process.

We will now configure the Client Request node with the correct methods and variable types.

To Configure the Client Request Node

1. Double-click the Client Request node.

The Client Request node builder is invoked.

2. In the General Settings tab:

a. Change the method name from clientRequest to startBuyer.

b. Click Add.

c. If not already selected, select the XML option.

d. Scroll down to the un-typed XML types.

e. Select XmlObject.

f. Click OK

The XmlObject parameter type is added to the pane.
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g. Click Apply to specify the XMLObject type as the expected type of the startBuyer 
method.

3. Click Receive Data.

4. In the Receive Data tab:

a. Select Create New Variable... from the Select Variables to Assign drop-down menu.

The Create Variable window opens.

b. Enter order as the variable name.

c. Note that the type XmlObject is preselected for you since this is the type you specified 
on the General Settings tab.

d. Click OK.

The new order variable is added to the Select variables to assign drop-down list.

e. Click Apply.

f. Click Close.

Your Client Request node is completed. To learn more about Client Request nodes, see 
Receiving Messages From Clients available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceive
Node.html. To learn more about variables and data types, see Working with Data Types 
available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWork
ing.html.

It is now time to add the ebXML control which will be used to communicate with the Seller 
process. This control represents what would normally be the remote service we are trying to 
contact, although in this example, the service runs on the same machine as the Buyer process.

To Create the ebXML Control and Control Node

1. In the Controls section of the Data palette, select Add→Integration Controls→ebXML.

The Insert Control - ebXML window opens.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
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2. In the Insert Control - ebXML window, enter the following:

a. In the STEP 1, enter sellerControl as the name of the variable to use for the control. This 
name must be a valid Java identifier.

b. In STEP 2, select the Create a new File control to use option and enter SellerControl 
as the name of the new JCX file that will be created.

c. In STEP 3, enter Seller as the ebxml-service-name. This value must always match the 
value in the participant (in our case the Seller) business process. This service name 
corresponds to the eb:Service entry in the ebXML message envelope.

d. In STEP 3, leave the from field blank. This will default to the 000000001 at runtime, the 
default trading partner.

e. In STEP 3, enter 000000002 in the to field. This sets the participating trading partner id 
as a static value.
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f. In STEP 3, select XmlObject as the type of data contained in the received message from 
the message-arg-type drop-down menu.

3. Click Create.

The ebXML control instance is added to your list of controls in the Data palette, and a 
JCX file corresponding to the ebXML control is added to the Application palette. You 
can double-click on the JCX file to open it in Design View and review the values which 
you just entered. For more information about ebXML controls, see ebXML Control. 
available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html. 
For more information about JCX files, see JCX Files: Extending Controls available at 
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html.

4. In the Data palette, expand the ebXML control by clicking on the + next to it.

The methods associated with the ebXML control are displayed.

5. Select the void request(XmlObject payload)method. The name of the method on this 
control must match the method name of the Receive request node in the participant process.

6. Drag the selected method into Design View and drop it on the  which appears 
immediately following the Client Request node.

A new Control Send node named request is added to your business process. For more 
information about Control Send nodes, see Interacting With Resources Using Controls 
available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html.

We will now configure the request node with the correct variable assignment.

To Configure the Request Node

1. Double-click the new request node.

The request node builder is invoked.

2. Click Send Data.

3. From the Select variables to assign drop-down menu, select order as the variable to assign 
to the request method.

4. Click Apply to apply your selection.

5. Click Close to close the node builder.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
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6. Select File→Save or enter Ctrl+S to save your work. 

Your buyer side ebXML process is now complete. The process sends a message to the Seller 
business process which is then written to a file named order.xml via the File control in the Seller 
process.

To Test the Buyer Business Process

1. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, “To 
Test the Seller Process” on page 3-16.)

2. To enter test data, do one of the following:

– Click Browse, and navigate to 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml.

– Cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml 

into the xml variable (payload) field.

3. Confirm that the order.xml file was written out correctly to the C:\tptutorial directory 
by checking that the time stamp of the file is current.

This part of the tutorial is now complete. You have successfully sent an XML message over 
ebXML from one trading partner to another. The participant (Seller) process wrote the XML out 
to the file system.

Step 3: Selecting the Trading Partner Information Dynamically 
Through Typed XML

In this example we build on what you learned in the previous exercise, “Step 2: Sending an XML 
Message through an One-Way ebXML Exchange” on page 3-9. You will learn how to specify the 
trading partner information dynamically using an XQuery selector rather than specifying it 
statically in the ebXML control. Then you will customize the ebXML control in the initiator 
(buyer) process and the participant process file (Seller) to use typed XML and business specific 
method names. 

This step contains the following procedures:

“Building the SelectorSeller Business Process” on page 3-24

“Building the SelectorBuyer Business Process” on page 3-27
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Building the SelectorSeller Business Process
In this procedure, you create an ebXML participant business process which will accept typed 
XML data instead of the XmlObject variable you used in the previous example’s participant 
process. This section contains the following tasks: 

“To Create the SelectorSeller Business Process File” on page 3-24

“To Configure the Receive Request Node” on page 3-25

“To Create the File Control and Control Node” on page 3-26

“To Configure the Control Node” on page 3-26

“To Test the SelectorSeller Process” on page 3-27

To Create the SelectorSeller Business Process File

1. Create a sub folder named selector under \ebxml\oneway in your Application tab. (For 
detailed instructions, refer back to “To Create the Seller Business Process File” on page 3-10.)

2. Create a new ebXML Participant Process File named SelectorSeller.jpd.

Your Application tab should look similar to the following.

3. As in the previous example, remove the Respond to request node.
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The next step involves configuring the Receive request node to accept XML data of a type that is 
specified in the Schemas which you imported into your application in “Importing the Tutorial 
Schemas” on page 3-8. 

To Configure the Receive Request Node

1. Double-click the Receive request node.

The Receive request node builder is invoked.

2. In the General Settings tab:

a. Change the method name from request to processOrder.

a. Select XmlObject payload.

b. Click Remove

c. Click Add.

d. If not already selected, select the XML option.

e. Expand the b2border.xsd by clicking on the + next to it.

f. Select Order from the expanded list.

g. Click OK

The OrderDocument parameter type is added to the pane.

h. Click Apply to specify the OrderDocument type as the expected type of the 
processOrder method.

3. Click Receive Data.

4. In the Receive Data tab:

a. Select Create New Variable... from the Select Variables to Assign drop-down menu.

The Create Variable window opens.

b. Enter order as the variable name.

Note: The type of the variable is already specified to be 
com.bea.tutorial.order.OrderDocument which is what you specified in the 
preceding steps.

c. Click OK.
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The new order variable is added to the Select variables to assign drop-down list.

d. Click Apply.

e. Click Close.

Your Client Request node is completed. To learn more about Client Request nodes, see 
Receiving Messages From Clients available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceive
Node.html. To learn more about variables and data types, see Working with Data Types 
available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWork
ing.html.

As in the previous example, you will add a file control to the business process file, which 
will write the order variable out to a file.

To Create the File Control and Control Node
Refer to the instructions in “To Create the File Control and the Control Node” on page 3-12 to 
create a new File control. To save time, you can also drag and drop File.jcx from the 
\ebxml\oneway folder in the Application tab directly on to the Design View of the 
SelectorSeller. The control definitions you created earlier will be reused in a new instance for 
this business process.

To Configure the Control Node

1. Double-click the new write node.

The write node builder is invoked.

2. Click Send Data.

3. From the Select variables to assign drop-down menu, select order as the variable to assign 
to the write method.

4. Click Apply to apply your selection.

5. Click Close to close the node builder.

6. Select File→Save or enter Ctrl+S to save your work. 

This concludes the creation of the SelectorSeller business process. 

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
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To Test the SelectorSeller Process

1. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, “To 
Test the Seller Process” on page 3-16.)

2. To enter test data, do one of the following:

– Click Browse, and navigate to 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml.

– Cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml 

into the xml variable (payload) field.

3. Confirm that the order.xml file was written out correctly to the C:\tptutorial directory 
by checking that the time stamp of the file is current

You are now ready to go on and create a SelectorBuyer initiator process.

Building the SelectorBuyer Business Process
For the initiator process in this example you use an XQuery selector to retrieve the trading partner 
ID dynamically rather than specifying it statically in the ebXML control as done in the previous 
example. This section contains the following tasks:

“To Create the SelectorBuyer Business Process File” on page 3-27

“To Configure the Client Request Node” on page 3-27

“To Create the ebXML Control” on page 3-29

“To Modify the ebXML Control Definition File” on page 3-29

“To Create the processOrder Control Send Node” on page 3-31

“To Test the SelectorBuyer Process” on page 3-32

To Create the SelectorBuyer Business Process File
Create a business process file named SelectorBuyer.jpd in the selector folder by following the 
instructions in “To Create the Buyer Business Process File” on page 3-17.

To Configure the Client Request Node

1. Double-click the Client Request node.

The Client Request node builder is invoked.
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2. In the General Settings tab:

a. Click Add.

b. If not already selected, select the XML option.

c. Expand the b2border.xsd by clicking on the + next to it.

d. Select Order from the expanded list.

e. Click OK

The OrderDocument parameter type is added to the pane.

f. Click Apply to specify the OrderDocument type as the expected type of the 
processOrder method.

3. Click Receive Data.

4. In the Receive Data tab:

a. Select Create New Variable... from the Select Variables to Assign drop-down menu.

The Create Variable window opens.

b. Enter order as the variable name.

Note: The type of the variable is already specified to be 
com.bea.tutorial.order.OrderDocument which is what you specified in the 
preceding steps.

c. Click OK.

The new order variable is added to the Select variables to assign drop-down list.

d. Click Apply.

e. Click Close.

Your Client Request node is completed. To learn more about Client Request nodes, see 
Receiving Messages From Clients available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceive
Node.html. To learn more about variables and data types, see Working with Data Types 
available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWork
ing.html.

In the next step you add a ebXML control and configure this control with an XQuery selector.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideClientsReceiveNode.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideDataTypesWorking.html
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To Create the ebXML Control

1. In the Controls section of the Data palette, select Add→Integration Controls→ebXML.

The Insert Control - ebXML window opens.

2. In the Insert Control - ebXML window, enter the following:

a. In the STEP 1, enter selectorSellerControl as the name of the variable to use for the 
control. This name must be a valid Java identifier.

b. In STEP 2, select the Create a new ebXML control to use option and enter 
SelectorSellerControl as the name of the new JCX file that will be created.

c. In STEP 3, enter SelectorSeller as the ebxml-service-name. This value must always 
match the value in the participant (in our case the SelectorSeller) business process. This 
service name corresponds to the eb:Service entry in the ebXML message envelope.

d. In STEP 3, leave the from field blank. This will default to the 000000001 at runtime, the 
default trading partner.

e. In STEP 3, leave the to field blank. This will be determined at runtime by the XQuery 
selector which you will define in the next section.

f. In STEP 3, select XmlObject as the type of data contained in the received message from 
the message-arg-type drop-down menu.

3. Click Create.

The ebXML control instance is added to your list of controls in the Data palette, and a 
JCX file corresponding to the ebXML control is added to the Application palette. You 
can double-click on the JCX file to open it in Design View and review the values which 
you just entered. For more information about ebXML controls, see ebXML Control 
available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html. 
For more information about JCX files, see JCX Files: Extending Controls available at 
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html.

You will now modify the control definition file of the ebXML control. In the next section, you 
change the method name, change the message type, and add an XQuery selector.

To Modify the ebXML Control Definition File

1. In the Data Palette, right-click on the ebXML selectorSellerControl.

2. Select Edit from the drop-down menu.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsebXML.html
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/devenv/conJwiFiles.html
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The SelectorSellerControl is displayed in Design View.

3. Right-click on the arrow going to the request method, as illustrated in the following 
graphic.

4. Select Rename from the drop-down menu.

5. Enter processOrder. 

6. Press the Enter key.

The method name now matches the name of the method on the participant business 
process. This method name corresponds to the eb:Action element in the ebXML message 
envelope.

7. Right-click on the arrow going away from the response method.

8. Select Delete from the drop-down menu.

You deleted the pre-configured response method since we are not sending a response in 
this example.

9. Click on processOrder.

The ebXML Source View opens.

10. Change the line void processOrder(XmlObject payload); to void 
processOrder(OrderDocument payload); 

11. The tooltip editor displays a suggested package to import, press Alt+Enter to accept.

This ebXML control is now set up to use XML typed according to the schema you 
imported in “To Import the Tutorial Schemas” on page 3-8 rather than generic untyped 
XML.

12. Click the Design View tab.

13. Double-click the arrow which points to processOrder.
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The Property Editor window opens with a graphical representation of the Start Method 
Schema. In this example, we assume that the target trading partner ID is contained in the 
Supplier ID element.

14. Click Supplier_ID to select it.

A selector XQuery statement is generated. 

15. Click OK.

16. Select File→Save or enter Ctrl+S to save your work.

17. Close the SelectorSellerControl.jcx by clicking the x in the top right corner of the window.

The ebXML control is now configured to pick out the trading partner ID from the message 
according to the specifications of the XQuery statement you generated in the selector. The next 
step is to add a processOrder Control Send node to the business process.

To Create the processOrder Control Send Node

1. In the Data Palette, expand the selectorSellerControl by clicking on the + next to it.

2. Select the void processOrder(OrderDocument payload) method. The name of the 
method on this control must match the method name of the Receive request node in the 
participant process.

3. Drag the selected method into Design View and drop it on the  which appears 
immediately following the Client Request node.

A new Control Send node named processOrder is added to your business process. For 
more information about Control Send nodes, see Interacting With Resources Using 
Controls available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html.

4. To specify the order variable as the input variable:

a. In the Data Palette, select order from the list of XML variables.

b. Drag and drop it onto the processOrder Control Send node.

This concludes the creation of the SelectorBuyer business process. In this section, you learned 
how to customize the participant and initiator processes to use typed XML and custom method 
names. You also learned how to use and XQuery selector to extract the target trading partner ID 
form the payload message rather than declaring it statically. The next section describes how to 
test your business processes.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControls.html
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To Test the SelectorBuyer Process

1. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, “To 
Test the Seller Process” on page 3-16.)

2. To enter test data, do one of the following:

– Click Browse, and navigate to 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml.

– Cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml 

into the xml variable (payload) field.

3. Confirm that the order.xml file was written out correctly to the C:\tptutorial directory 
by checking that the time stamp of the file is current.

Step 4: Sending Raw Data (Binary File) Through an ebXML 
Exchange

In this example, we will use ebXML to send binary data between two trading partners through a 
Message Broker channel. This example builds on the examples describes in previous sections. If 
at any time you need more information about how to complete a task that was previously 
explained, refer back to the preceding sections. This section contains the following procedures:

“Building the BinarySeller Business Process” on page 3-32

“Building the BinaryBuyer Business Process” on page 3-33

Building the BinarySeller Business Process
This example builds on what you have learned in the previous examples. If at any time you need 
more detailed instructions, refer back to “Building the Seller Business Process” on page 3-10. 
This section contains the following tasks:

“To Create the BinarySeller Business Process” on page 3-32

“To Test the BinarySeller Business Process” on page 3-33

To Create the BinarySeller Business Process

1. Create a new folder in your application under \ebxml\oneway\binary.

2. Create a new ebXML participant process in this folder named BinarySeller.jpd.
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3. Remove the Respond to request node.

4. Modify the Receive request node as follows:

a. Remove the XmlObject parameter data type.

b. Add a RawData parameter data type (found in NonXML option).

c. Create a new variable named data of type RawData.

d. Specify the new variable as the one to assign to the request method.

5. Create a new File control with the following values specified:

– Variable name: file

– New JCX name: File

– directory-name: /tptutorial/binary-in

– file-mask: data.bin (this is an arbitrary file name, it could be anything)

– file-type: RawData

6. Drag and drop the write method of the file control after the Receive request node in the 
business process.

7. Double-click the write node and on the Send Data tab, specify data as the variable to assign 
to the write method.

To Test the BinarySeller Business Process

1. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, “To 
Test the Seller Process” on page 3-16.)

2. Use any binary file (for example an image file) as binary payload test data.

3. Confirm that the data.bin file was written out correctly to the 
C:\tptutorial\binary-in directory by checking that the time stamp of the file is 
current.

Building the BinaryBuyer Business Process
For the initiator side of this example, the process will look very similar to those in previous 
examples, except that it will be invoked through a subscription to a file event which will cause 
the process to pick up a file from a directory. This section contains the following tasks:
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“To Create the BinaryBuyer Business Process File” on page 3-34

“To Create the Channel File” on page 3-34

“To Configure the Subscription Node” on page 3-35

“To Create the ebXML Control” on page 3-35

“To Test the BinaryBuyer Business Process” on page 3-36

To Create the BinaryBuyer Business Process File
Use the instructions outlined in detail in “Building the Buyer Business Process” on page 3-17 to 
complete the following tasks:

1. In the ebxml\oneway\binary folder, create a new business process named BinaryBuyer.jpd.

2. Double-click the Starting Event and select the Subscribe to a Message Broker channel 
and start via an event (Timer, Email, File, Adapter, etc.) option.

Before you can start to configure the Message Broker Subscription node, you need to create a 
subscription channel file to which the subscription node can listen for events. 

To Create the Channel File

1. In the Application tab, right-click on the Schemas folder.

2. Select New→Channel File

3. Enter tptutorial.channel as the file name.

4. Click Create.

The new channel file is created, added under the Schemas folder in the Application tab, 
and displayed on screen. An application build is also started automatically to build the 
Schemas project.

5. In the channel file code, locate the following line:
<channel name="SampleRawDataChannel" messageType="rawData"/>

6. Remove the comment tags <!-- and --> preceding and following the line.

7. Select File→Save or enter Ctrl+S to save the channel file.

The Schemas project builds again. 

8. Close the Channel file by clicking the x in the top right corner of the window.
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The sample channels defined in the file are now available for selection in the subscription node. 
For more information about channels, see Publishing and Subscribing to Channels available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/howdoI/howPubSub.html.

To Configure the Subscription Node

1. Double-click the Subscription node.

The Subscription node builder is invoked.

2. On the General Settings tab, select the SampleRawDataChannel from the Channel name 
drop-down list.

3. In the Receive Data tab:

a. Create a variable named data of type RawData

b. Select it to be the variable to assign to the subscription method.

4. Click Apply.

5. Click Close.

You have now completed the configuration of your subscription node. To learn more about 
subscription nodes, see Subscription Start (Asynchronous) available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideStartSub.html and 
Subscription Start (Synchronous) available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideStartSyncSub.html.

In the next section, you create a ebXML control to be used to communicate with the participator 
business process.

To Create the ebXML Control

1. Use the instructions in “To Create the ebXML Control and Control Node” on page 3-20 to 
create an ebXML with the following values:

– Variable name: binarySellerControl

– New JCX name: BinarySellerControl

– ebxml-service-name: BinarySeller (must match the value in the participant process)

– from: leave blank

– to: 000000002

– method-arg-type: RawData

http://edocs.bea.com/workshop/docs81/doc/en/integration/howdoI/howPubSub.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/howdoI/howPubSub.html
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2. Click Create.

3. From the Data Palette, drag and drop the void request(RawData payload) method 
on the target appearing in the business process below the Subscription node.

4. From the Data Palette, drag and drop the data variable in the Non-XML list onto the 
request node.

The BinaryBuyer business process is now complete, run and test it to ensure that it is working 
properly.

To Test the BinaryBuyer Business Process

1. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, “To 
Test the Seller Process” on page 3-16.)

2. Use an image file as the binary payload test data.

3. Confirm that the data.bin file was written out correctly to the 
C:\tptutorial\binary-in directory by checking that the time stamp of the file is 
current.

Note: Before you test your business process, make sure that you have completed the “To Create 
the Channel File” on page 3-34 section. If you do not create a channel file before testing 
the process, you will encounter an error.

Creating a File Event Generator
In this section you create the file event which will invoke the BinayBuyer business process when 
a raw data type file is dropped in a directory.

To Create the File Event

1. Create the following new directory on your hard drive:

– C:\tptutorial\errors

2. If not already running, start your WebLogic Server by selecting Tools→WebLogic 
Server→Start WebLogic Server.

3. After the Server is running, open the WebLogic Administration Console by selecting 
Tools→WebLogic Integration→WebLogic Administration Console.

4. Log in to the console using the server user name and password that you specified in the 
“Step 1: Create a New WebLogic Integration Domain” on page 1-3 section.
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5. Click Event Generators.

The Event Generators page opens.

6. Click Create New.

7. Enter TPTutorial as the Generator Name.

8. Click Submit.

The File Event Generator Definition page opens

9. Click Define a New Channel Rule.

The File Generator Channel Rule Definition page opens.

10. Enter the following parameters:

– File Type: Disk File

– Channel Name: /SamplePrefix/Samples/SamplesRawDataChannel (rawData)

– Message Encoding: leave blank

– Directory: /tptutorial/binary-out

– Pass by file name: No

– Scan subdirectories: No

– File pattern: leave blank, it defaults to *.*

– Sort by Arrival?: No

– Polling interval: 3 seconds (small enough to avoid a long wait)

– Read limit: 0

– Post Read Action: Delete

– Archive Directory: leave blank

– Error Directory: /tptutorial/errors

– Description: Raw data file.

11. Click Submit.

You have completed creating the File Event. For more information about the WebLogic 
Administration Console and Event Generators, see Event Generators available at 
http://edocs.bea.com/wli/docs81/manage/evntgen.html. 

http://edocs.bea.com/wli/docs81/manage/evntgen.html
http://edocs.bea.com/wli/docs81/manage/evntgen.html
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To Test the Sending Raw Data Example

1. Click on the WebLogic Workshop menu to deploy and run the BinaryBuyer business 
process.

2. Put a binary file in the binary-out directory you created earlier. In a few seconds it should 
disappear and a file named data.bin should appear in the binary-in directory.

Note: About Message Tracking: In this and previous examples, all messages sent via ebXML 
are tracked in the tracking database. In the WebLogic Administration Console, navigate 
to Trading Partner Management→Message Tracking to look at the messages. Basic 
message information and payload information are both tracked. You can also navigate 
from the message to the process that created or consumed the message. For more 
information see, Trading Partner Management (available at 
http://edocs.bea.com/wli/docs81/manage/tpm.html) in Managing WebLogic Integration 
Solutions.

Step 5: Creating a Roundtrip ebXML Conversation
This example illustrates how to implement an ebXML conversation in which a request message 
(order request) is followed by a response message (invoice). The first part of the conversation is 
identical to the one-way scenario you developed earlier. In this example, you add a Client 
Response node to the participant business process and use the ebXML control callback for the 
response message. This section contains the following procedures:

“Building the RoundtripSeller Business Process” on page 3-38

“Building the RoundtripBuyer Business Process” on page 3-42

Building the RoundtripSeller Business Process
This example builds on the previous examples that you have completed. If at any time you need 
more detailed instructions, refer back to “Building the Seller Business Process” on page 3-10 to 
complete the following sections:

“To Create the Business Process File and Configure the Receive Request Node” on page 
3-39

“To Create the File Controls and Configure the Control Nodes” on page 3-39

“To Configure the Respond to Request Node” on page 3-41

“To Deploy the RoundtripSeller Business Process” on page 3-41

http://edocs.bea.com/wli/docs81/manage/tpm.html
http://edocs.bea.com/wli/docs81/manage/tpm.html
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To Create the Business Process File and Configure the Receive Request Node

1. Create a new folder in your application named roundtrip as a sub folder of the ebxml folder.

2. In the roundtrip folder, create a new ebXML participant process named 
RoundtripSeller.jpd, but do not delete the Respond to request node.

3. Double-click the Receive request node and configure as follows:

a. Rename the method to processOrder.

b. Remove the XmlObject payload parameter type.

c. Add the parameter type OrderDocument (from b2border.xsd)

d. Create a new variable named order of type OrderDocument and select it as the variable 
to be assigned to the method.

e. Click Apply, then click Close.

For illustration purposes, this example simplifies the order/invoice process.The seller will again 
write the incoming order out to file and for the response, the seller will read an invoice document 
from the file system. The invoice will be the same for each order. In production scenarios, the 
seller process could instead read the information from a database, obtain it from a message queue, 
or get it from a backend application as an event from an Application View control. The process 
could also delegate processing of the order to a subprocess, which is illustrated in the next 
example “Step 6: Implementing the Public/Private Pattern” on page 3-46. For more information 
about Application View controls, see Application View Control available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsAppView.html.

To Create the File Controls and Configure the Control Nodes

1. Add a new File control named file and configure it to write out order.xml to C:\tptutorial\

Note: To save time, you can drag and drop the File.jcx in the oneway folder onto the 
RoundtripSeller.jpd Design View. This will create a new instance of the File.jcx.

2. Drag and drop the write method to the target that appears below the Receive request node.

3. Double-click on the write node.

4. Configure the node to send the order variable to the write method.

5. Create a new directory on your hard drive named C:\tptutorial\invoice.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsAppView.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsAppView.html
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6. Copy the file 
C:\myapps\tptutorialapps\ebxml\ebxmlWeb\sampledata\sampleinvoice.xml to 
the C:\tptutorial\invoice directory

7. Rename sampleinvoice.xml to invoice.xml.

8. Create a second new File control named invoiceFile and configure it to read an XmlObject 
(invoice.xml) from the C:\tptutorial\invoice directory by using the following 
configurations:

– file-mask: invoice.xml

– directory-name: /tptutorial/invoice

9. Drag and drop the read method to the target that appears below the write node.

10. Double-click the read node.

11. Click Receive Data.

The method expects untyped XML (XmlObject) but our invoice.xml file contains typed 
XML so we will need to do a simple transformation between the two.

12. Select the Transformation Option.

13. Click Select Variable→Create New Variable....

The Create Variable window opens.

14. Enter invoice as variable name.

15. Expand b2binvoice.xml and select Invoice.

16. Click OK.

The Create Variable window closes and your new variable is listed in the variable pane of 
the node builder.

17. Click Create Transformation.

The Transformation Tool window opens.

18. Drag and drop the XmlObjectDoc in the Source Schema pane to the Invoice root in the 
Target Schema pane.

An XQuery transformation is created a corresponding transformation control is created and 
stored in the RoundtripSellerTransformation.dtf file, which was created in your 
Application pane when you opened the Transformation tool.
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19. Close the Transformation Tool window by clicking on the x in the top right corner of the 
window.

20. Click Yes in the Save Before Closing dialogue window.

21. Click Close in the node builder.

The transformation you created in the preceding steps, only transforms from one data type to 
another. In production scenarios, you would use the Transformation Tool to convert from the 
backend system format to the format expected by the trading partner. You can also use the 
Transformation Tool to manipulate data. For more information about the Transformation Tool, 
see Guide to Data Transformation available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguideIntro.html.

The next step in this example is to configure the Respond to request node.

To Configure the Respond to Request Node

1. Double-click the Respond to request node.

2. Rename the method name to onInvoice.

3. Remove the XmlObject payload parameter type.

4. Add a parameter of type Invoice from the b2binvoice.xsd schema.

5. Click Apply.

6. Click Send Data.

7. Select invoice from the Select variables to assign drop-down list.

8. Click Apply.

9. Click Close.

You have completed building the seller (participant) side of this example. The seller will receive 
an order document from the buyer, write it out to file, read in an invoice file and send it to the 
buyer. The name of the ebXML service created for this transaction is RoundtripSeller. The 
message exchange will be carried out as a single ebXML conversation. The Trading Partner 
Integration (TPI) system automatically manages the ebXML conversation and ensures that the 
same conversation ID is used within the same participant process instance.

To Deploy the RoundtripSeller Business Process

1. Click on the WebLogic Workshop menu to deploy the business process.

http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguideIntro.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguideIntro.html


3-42 Tutorials for Trading Partner Integration

2. Close the Test Browser window.

Testing the process at this point would create an exception on the callback method since you have 
not yet created the initiator process. That is why you only deploy the process so that it will run 
properly when you test the initiator process later on.

Building the RoundtripBuyer Business Process
This section builds on the tasks that you have learned in previous examples. If at any time you 
need more detailed descriptions, refer back to “Building the Buyer Business Process” on page 
3-17 while completing the following tasks:

“To Create the Business Process and Configure the Client Request Node” on page 3-42

“To Create and Configure the ebXML Control” on page 3-43

“To Create and Configure the ebXML Control Nodes” on page 3-43

“To Create and Configure the Client Response Node” on page 3-44

“To Specify the Trading Partner ID in an XML Variable” on page 3-44

“To Test the Business Processes” on page 3-45

To Create the Business Process and Configure the Client Request Node

1. In the roundtrip folder, create a new business process named RoundtripBuyer.jpd.

2. Double-click the Starting Event.

3. Select Invoked via a Client Request.

4. Click OK.

5. Double-click the Client Request node and configure as follows:

a. Change the method name to startBuyer.

b. Add a parameter type of type Order from the b2border.xsd schema

c. On the Receive Data tab, create a new variable named order of type Order and specify 
it to be assigned to the method.

d. Click Apply, then click Close.
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To Create and Configure the ebXML Control

1. Add a new ebXML control and configure it as follows:

– Variable name: roundtripSellerControl

– New JCX name: RoundtripSellerControl

– ebxml-service-name: RoundtripSeller (matches the participant side)

– Accept defaults for all other fields.

2. In the Data Palette, right-click on the ebXML control and select Edit.

3. Right-click on the arrow pointing to request and select rename.

4. Enter processOrder and press the enter key.

5. In a similar fashion, rename response to onInvoice.

6. Click processOrder.

7. In processOrder, change XmlObject to OrderDocument.

8. Press Alt+Enter to import the suggested package.

9. In onInvoice, replace XmlObject with InvoiceDocument.

10. Press Alt+Enter to import the suggested package.

11. Save your work by selecting File→Save or enter Ctrl+S

12. Close the ebXML Source View by clicking the x in the top right corner of the window.

You have now completed the ebXML control configuration. In the next step, you create control 
nodes associated with the methods of your ebXML control.

To Create and Configure the ebXML Control Nodes

1. In the Data Palette, expand the ebXML control.

2. Drag and drop the processOrder method to the target that appears below the Client 
Request node.

3. Drag and drop the order variable onto the processOrder node.

4. Drag and drop the onInvoice callback to the target that appears below the processOrder 
node.
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5. Double-click the onInvoice node.

6. Click Receive Data.

7. Select Create New Variable... from the Select variables to assign drop-down list.

8. Create a new variable named invoice of type Invoice.

9. Click OK.

10. In the node builder, click Apply.

11. Click Close.

You have completed adding the ebXML controls. The next step is to add a Client Response node 
and configure it to return the contents of the invoice variable.

To Create and Configure the Client Response Node

1. Drag and drop a Client Response node from the Palette to the target that appears below the 
onInvoice node.

2. Double-click the Client Response node.

3. Change the method name to onBuyerComplete.

4. Add a parameter type of type Invoice (under b2binvoice.xsd).

5. Click Send Data.

6. Select the invoice variable from the Select variables to assign drop-down list.

7. Click Apply.

8. Click Close.

The buyer side of this example is almost complete, but you have not yet specified the ID of the 
trading partner. In the previous examples, you provided it as a static value in the ebXML control 
and also configured the control to pick the ID out at runtime from the payload. In this example, 
you specify the ID in a process XML variable using an XQuery selector. 

To Specify the Trading Partner ID in an XML Variable

1. In the Data Palette, click on roundtripSellerControl.

2. In the Property Editor, locate the ebxml attribute section.
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In the previous examples, we specified the ebXML attributes in the control definition (the 
JCX file). The values of those attributes apply wherever the control is used. Here you 
specify the control instance attributes, which only apply to the instance of the control 
declared in this business process. For more information about control properties for control 
types and control instances, see Setting Control Properties available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControlsProperti
es.html

3. In the ebxml-service-name filed, enter RoundtripSeller.

Note: This value has to be specified again although it exists in the controls definition JCX 
file. This is because any required fields in the configuration will not be inherited from 
the controls definition file but instead needs to be specified in each instance of the 
control.

4. In the to-selector field, click on....

The Property Editor window opens with a graphical representation of the schemas of the 
typed variables in the business process.

5. Click on Supplier_ID in the order schema.

An selector XQuery is generated in the Selected Element pane. Based on this XQuery, the 
trading partner ID will be determined at runtime.

6. Click OK.

The buyer side is now complete. You can run and test your processes using the WebLogic Test 
Browser. 

To Test the Business Processes

1. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, “To 
Test the Seller Process” on page 3-16.)

2. To enter test data, cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml into 
the xml variable (payload) field.

3. Confirm that the Supplier_ID field in the test data has the correct trading partner ID 
(000000002).

4. Click the Refresh link to see the callback method.

5. Confirm that the order.xml file was written out correctly to the C:\tptutorial directory 
by checking that the time stamp of the file is current.

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControlsProperties.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguideControlsProperties.html
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Step 6: Implementing the Public/Private Pattern
This example illustrates how to use subprocesses to implement the public/private pattern. You 
can use this pattern to keep the details of backend integration confined to a private process 
definition and keep the public process definitions dedicated to trading partner interaction. This 
example contains the following procedures:

“Building the PublicBuyer Business Process” on page 3-46

“Building the PrivateBuyer Business Process” on page 3-47

“Building the PrivateSeller Business Process” on page 3-48

“Testing the Public/Private Pattern Example” on page 3-51

Building the PublicBuyer Business Process
In this example we reuse some of the files that you have created in the previous examples.

1. Create a new folder under the ebxml folder in the Application pane named publicprivate.

2. Click on the RoundtripBuyer.jpd in the roundtrip folder and drag it to the publicprivate 
folder while holding down your Ctrl key. 

3. Release your mouse button. 

A copy of the RoundtripBuyer.jpd file is created in the publicprivate folder.

Note: Whenever you duplicate a business process file, the new copy still reference the same 
(old) controls, even if you duplicate folders which include control files.

4. Right-click on the new business process and select rename.

Note: You may have to stop the WebLogic Server before you can rename the business 
process. To do so, select Tools→WebLogic ServerStop→WebLogic Server.

5. Enter PublicBuyer.jpd.

6. Right-click on PublicBuyer.jpd and select Generate Process Control.

A new JCX control definition file is created in your publicprivate folder. This control can 
be used in other processes to invoke the PublicBuyer.jpd business process. You use this 
control in the PrivateBuyer business process to invoke the PublicBuyer process.
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Building the PrivateBuyer Business Process
This section builds on the tasks you learned in previous examples. If at any time you need more 
detailed information, refer back to “Building the Buyer Business Process” on page 3-17 while 
completing the following tasks:

1. Create a new business process in the publicprivate folder named PrivateBuyer.jpd.

2. Configure the process to be invoked by a Client Request node.

3. Configure the Client Request node according to the following:

– Method name: startPrivateBuyer

– Expected parameter type: Order from the b2border.xsd schema.

– Receive data tab: create a new XML variable named order of type Order and specify 
it to be assigned to the method.

4. Add a Client Response node.

5. Configure the Client Response node according to the following:

– Method name: onPrivateBuyerComplete

– Expected parameter type: Invoice from the b2binvoice.xsd schema.

– Send Data tab: create a new XML variable named invoice of type Invoice and specify 
it to be assigned to the method.

6. Drag and drop the PublicBuyerControl.jcx from the Application palette onto the Design 
View.

An instance of the publicBuyerControl is added to your Controls list in the Data Palette.

7. Expand the new process control.

8. Drag and drop the startBuyer method onto the target that appears after the Client Request 
node.

9. Drag and drop the order variable onto the startBuyer node.

10. Drag and drop the onBuyerComplete method onto the target that appears after the 
startBuyer node.

11. Drag and drop the invoice variable onto the onBuyerComplete node.

12. Save your work.
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The buyer side business processes are now complete.

Building the PrivateSeller Business Process
If at any time you need detailed instructions while completing the tasks in the section, refer back 
to “Building the Seller Business Process” on page 3-10.

1. In the publicprivate folder, create a new business process named PrivateSeller.jpd.

2. Configure it to be invoked by a Client Request node.

3. Configure the Client Request node as follows:

– Method name: privateProcessOrder

– Expected variable type: Order from the b2border.xsd schema.

– Receive Data tab: Create a new variable named order of type Order and specify it to 
be assigned to the method.

4. Add a Client Response node to the business process, following the Client Request node.

5. Configure the Client Response node as follows:

– Method name: onPrivateInvoice

– Expected variable type: Invoice from the b2binvoice.xsd schema.

– Send Data tab: create a new variable named invoice of type Invoice and specify it to 
be assigned to the method.

There are several options for processing a private process. For example, you may choose to 
send the order to an ERP system (most likely having transformed it first) via an 
Application View control, and then subscribe to an event from the backend system with 
invoice information. Since this example is for illustration purposes only, you use a simple 
file control to read and write the data from and to the file directory system.

6. Drag and drop File.jcx from the oneway folder in the Application pane onto the Design 
View.

7. Drag and drop the write method onto the target that appears below the Client Request 
node.

8. Configure the node to send the order variable to the write method.

9. Drag and drop InvoiceFile.jcx from the roundtrip folder in the Application pane to the 
Design View.
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10. Drag and drop the read method to the target that appears below the write node.

11. Double-click the read node.

12. Click Receive Data.

The method expects untyped XML (XmlObject) but our invoice.xml file contains typed 
XML so we will need to do a simple transformation between the two.

13. Select the Transformation Option.

14. Click Select Variable and select invoice from the drop-down menu.

15. Click Create Transformation.

The Transformation Tool window opens.

16. Drag and drop the XmlObjectDoc in the Source Schema pane to the Invoice root in the 
Target Schema pane.

An XQuery transformation is created a corresponding transformation control is created and 
stored in the PrivateSellerTransformation.dtf file, which was created in your 
Application pane when you opened the Transformation tool.

17. Close the Transformation Tool window by clicking on the x in the top right corner of the 
window.

18. Click Yes in the Save Before Closing dialogue window.

19. Click Close in the node builder.

20. Save your work.

21. Right-click on PrivateSeller.jpd and select Generate Process Control.

You have completed building the PrivateSeller business process. In the next section, you will 
create the public process for the seller side of the conversation.

Building the PublicSeller Business Process
To create the PublicSeller business process, you re-use some of the files that you created in the 
previous example. You can refer back to the detailed instruction in “Building the Seller Business 
Process” on page 3-10 to complete the tasks in this section.

1. Drop and drag the RoundtripSeller.jpd file from the roundtrip folder to the publicprivate 
folder while holding down your ctrl key.
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2. Right-click on the new process file and select rename.

3. Enter PublicSeller.jpd.

4. Double-click on PublicSeller.jpd.

5. Click the Source View tab.

6. In the Property Editor, change the ebxml-service-name to PublicSeller.

7. Click Design View.

8. Delete the write node.

9. Delete the read node

10. In the Data Palette Controls section, delete all three control instances (file, invoiceFile, and 
transformations).

11. Drag and drop the PrivateSellerControl.jcx file from the Application pane onto Design 
View.

12. Expand the privateSellerControl in the Data Palette.

13. Drag and drop the privateProcessOrder method onto the target that appears just below the 
Receive request node.

14. Drag and drop the order variable onto the privateProcessOrder node.

15. Drag and drop the onPrivateInvoice method onto the target that appears just below the 
privateProcessOrder node.

16. Drag and drop the invoice variable onto the onPrivateInvoice node.

You have completed the seller side of the conversation. The public process receives a message 
via ebXML and passes it on to the private process. When the private process responds, it calls 
back to the public process, which returns the invoice information via ebXML to the initiating 
trading partner.

You need to do one final adjustment before running and testing this example:

1. Double-click on PublicBuyer.jpd.

2. In the Data Palette, select the roundtripSellerControl.

3. In the Property Editor, change the ebxml-service-name to PublicSeller to match the 
participant side.
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Testing the Public/Private Pattern Example
1. Open PublicSeller.jpd.

2. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, 
“To Test the Seller Process” on page 3-16.)

3. Switch back to WebLogic Workshop and open PrivateBuyer.jpd.

4. Click on the WebLogic Workshop menu. 

5. To enter test data, do one of the following:

– Click Browse, and navigate to 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml.

– Cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml 

into the xml variable (payload) field.

6. Refresh the browser after a few seconds. The log entry for 
callback.onPrivateBuyerComplete will have the content of the response with the 
Invoice document.

7. Confirm that the order.xml file was written out correctly to the C:\tptutorial directory 
by checking that the time stamp of the file is current.

Step 7: Using the TPM Control and Callbacks
This example illustrates how to obtain trading partner information from the Trading Partner 
Management (TPM) repository at runtime by using the TPM control. It will also show you how 
to use the onAck callback of the ebXML control. In the example you send an ebXML message 
and wait for the ebXML acknowledgement. If the acknowledgement times out, for example, 
because the remote partner is offline, and the TPM protocol binding for both local and remote 
trading partners have “once and only once” or “at least once” delivery schematics, an email alert 
is sent to that remote trading partner. You obtain the email address by querying the TPM database 
using a TPM control.

This example contains the following sections:

“Building the BuyerAlert Business Process” on page 3-52

“Testing the BuyerAlert Business Process” on page 3-56
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Building the BuyerAlert Business Process
Use the skills you have learned in previous sections to complete the following tasks:

“To Create the BuyerAlert Business Process” on page 3-52

“To Create and Add the TPM Control to the Process” on page 3-53

“To Create and Add an Email Control to the Business Process” on page 3-53

“To Specify the Target Trading Partner ID” on page 3-55

“To Specify the Email Address for the Trading Partner Profile” on page 3-55

To Create the BuyerAlert Business Process

1. Create a new folder named tpm off the root (ebxmlWeb) of your project.

2. Add a new process file named BuyerAlert.jpd.

3. Configure the business process to be invoked by a Client Request node.

4. Configure the Client Request node as follows:

– Expected Parameter Types: XmlObject and String

– Receive Data tab: Create a new XmlObject variable named payload and a new String 
variable named partnerId. Select them to be assigned to the corresponding methods.

5. Add an ebXML control and configure it as follows:

– Variable name: sellerControl

– New JCX file: SellerControl.jcx

– ebxml-service-name: Nonesuch (use any value that does not correspond to an actual 
deployed participant service)

– Accept defaults for all other fields

6. From the Data Palette, drag and drop the request method of the sellerControl onto the 
target that appear below the Client Request node.

7. Drag and drop the payload variable onto the request node.

8. Drag and drop the onAck callback onto the target that appears below the request node.
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This callback will occur when the ebXML message sent in the previous step is 
acknowledged. In case the acknowledgement does not arrive, you add logic in the next 
steps that alerts the trading partner.

9. Right-click on the onAck node.

10. Select Add Timeout Path from the drop-down menu.

11. In the Property Editor for the timer, provide a duration value of 10 seconds by typing 10s.

To Create and Add the TPM Control to the Process

1. Create a new TPM control by selecting Add→Integration Controls→TPM in the Controls 
section of the Data Palette.

2. Enter tpm as the variable name.

3. Click Create.

For more information about the TPM control, see TPM Control available at 
http:/edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsTPM.html

4. Expand the new TPM control.

5. Drag and drop the TradingPartnerDocument getBasicProperties(String 
partnerId) onto the target that appears in the timeout path below the timer.

6. Double-click the getBasicProperties node.

7. Click Send Data.

8. Select partnerId from the Select variables to assign drop-down list.

9. Click Receive Data.

10. Create a new variable named basicPartnerInfo of type TradingPartnerDocument and 
specify it to be assigned to the method.

11. Click Apply.

12. Click Close.

To Create and Add an Email Control to the Business Process

1. Create a new Email control by selecting Add→Integration Controls→Email in the 
Controls section of the Data Palette.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsTPM.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsTPM.html
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2. Configure the Email control as follows:

– Variable name: alert

– New JCX file name: Alert

– SMTP host: <your SMTP host name, e.g. mail.mycompany.com>

– from-address: <a reply address, e.g.admin@mycompany.com>

– from-name: <Name, e.g. Administrator>

– body-type: String

For more information about the Email control, see Email Control available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsEmail.html.

3. Expand the new Email control.

4. Drag and drop the sendEmail method onto the target that appears after the 
getBasicProperties node in the timeout path.

5. Double-click the sendEmail node.

6. Click on Send Data.

7. Select the Transformation option.

8. Click Select Variable and select basicPartnerInfo.

9. Click Create Transformation.

10. Drop and drag the email leaf from the Source Schema onto the arg1 (corresponds to the 
email ‘To’ filed) leaf in the Target Schema.

11. Right-Click on arg4 (corresponds to the email ‘Subject’ field).

12. Select Create Constant.

13. Enter Problem Sending Order.

14. Click OK.

15. Right-Click on arg5 (corresponds to the email body).

16. Select Create Constant.

17. Enter We encountered a problem while sending you an order.

18. Click OK.

http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsEmail.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/controls/controlsEmail.html
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19. Close the Transformation Tool by clicking the x in the top right corner.

20. Click Yes in the Save Before Closing? dialogue.

21. Click Close in the node builder.

The last step in this example is to specify the ID of the target trading partner in our ebXML 
control. In this example, you use the setProperties method of the control to accomplish this.

To Specify the Target Trading Partner ID

1. Select the setProperties method under the ebXML control in the Data Palette.

2. Drop and drag the method onto the target that appear between the Client Request node and 
the request node.

3. Double-click on the setProperties node.

4. Click Send Data.

5. Select the Transformation option.

6. Select partnerId as the variable.

7. Click on Create Transformation.

8. Drag the string variable from the Source Schema pane to the ‘to’ element in the Target 
Schema pane.

9. Close and Save your transformation.

10. Close the node builder

Before you can test the example, you need to specify the email address in the trading partner 
profile. 

To Specify the Email Address for the Trading Partner Profile

1. If not already running, start your WebLogic Server by selecting Tools→WebLogic 
Server→Start WebLogic Server.

2. After the Server is running, open the WebLogic Administration Console by selecting 
Tools→WebLogic Integration→WebLogic Administration Console.

3. Log into the console using your server user name and password you specified in the “Step 
1: Create a New WebLogic Integration Domain” on page 1-3 section.
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4. Click Trading Partner Managment.

5. Click Profile Management.

6. Click Test_TradingPartner_2.

7. Click Edit profile.

8. In the Email field, enter you email. This is where the alert messages will be deliver.

9. Click Submit.

10. Close the console.

Testing the BuyerAlert Business Process
1. Click on the WebLogic Workshop menu to test the BuyerAlert business process.

2. Specify any XML data as the payload.

3. Enter 000000002 for the string parameter.

4. After the process completes, check your email for the alert message. 

These emails where sent since an error occurred and triggered the email control to send an 
email to the address you specified when you set up the control. 

Step 8: Setting Partner ID Dynamically Based on Directory 
Name

In this example you look at the already built application which was distributed with the zipped 
archive that contained this tutorial (see, “Step 3: Install the Tutorial Files” on page 1-9). This 
example demonstrates how to use the name of a sub-directory on your hard drive as the partner 
ID and set it dynamically using the setProperties method in the ebXML control. This example 
contains the following sections:

“Reviewing the Initiator Side of the Example” on page 3-56

“Reviewing the Participant Side of the Example” on page 3-59

Reviewing the Initiator Side of the Example
In this example you begin with looking at the initiator side of the application. Use the skills you 
learned in previous sections to complete the following tasks:
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“To Set Up the Initiator Side of the Example” on page 3-57

“To Review the Configuration of the DynamicBinaryBuyer Process” on page 3-57

“To Add a New Rule in the File Event Generator” on page 3-58

“To Test the DynamicBinaryBuyer Process” on page 3-59

To Set Up the Initiator Side of the Example

1. Create the following two directories on your hard drive:

– C:\tptutorial\binary-out\dynamic\000000002

– C:\tptutorial\binary-in\dynamic\000000001

2. Open up your file browser and navigate to 

3. Select File→Open→Application.

4. Locate the advanced folder in the [unzip 
location]\tptutorialapps\ebxml\ebxmlWeb\ebxml\oneway\binary directory 

where [unzip location] is the location where you unzipped the tutorial archive in 
“Step 3: Install the Tutorial Files” on page 1-9.

5. Drag and drop the advanced folder from the file browser onto the binary folder in your 
Application tab.

WebLogic Workshop will update your class and package names.

6. In the Application pane, navigate to and expand the 
ebxml\ebxmlWeb\ebxml\oneway\binary\advanced folder.

7. Double-click on DynamicBinaryBuyer.jpd

DynamicBinaryBuyer.jpd opens in Design View.

To Review the Configuration of the DynamicBinaryBuyer Process

1. This application uses the name of a sub directory as the partner ID and sets it dynamically 
using the setProperties method in the ebXML control. You can double-click on any of the 
nodes to note the following:

– The business process is invoked by a RawData message coming through on the channel 
which the starting event subscribes to through the Subscription node.

– The Extract partner id node contains custom Java code which extracts the partner id 
from the incoming message. To learn about writing custom Java code in business 
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processes, see Writing Custom Java Code in Perform Nodes available at 
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguidePerform.htm
l.

– The setProperties node takes the trading partner ID and assigns it to a string variable 
which corresponds to the ‘to’ parameter of the ebXML envelope.

– The request sends the message to the trading partner.

2. In the Application pane, double-click on the ebxml\Schemas\tptutorial.channel file.

The channel file opens in Source View.

3. Add the following line to your channel file:

– <channel name="TutorialChannel" messageType="rawData"
qualifiedMetadataType="eg:FileEventGenerator"/>

This line specifies a new channel which listens messages that are sent using event a 
File event generator. All event generators and some applications send metadata with 
messages.

The next step in the process is to add a new rule in the File Even Generator in the WebLogic 
Integration Administration Console to listen to the correct folder on your hard drive. 

To Add a New Rule in the File Event Generator

1. If not already running, start your WebLogic Server by selecting Tools→WebLogic 
Server→Start WebLogic Server.

2. After the Server is running, open the WebLogic Administration Console by selecting 
Tools→WebLogic Integration→WebLogic Administration Console.

3. Log into the console using your server user name and password you specified in the “Step 
1: Create a New WebLogic Integration Domain” on page 1-3 section.

4. Click Event Generators.

5. Click TPTutorial in the Name column.

6. Click Define a New Channel Rule.

7. Enter the following parameters:

– File Type: Disk File

– Channel Name: /SamplePrefix/Samples/TutorialChannel (rawData)

http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguidePerform.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguidePerform.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/wfguide/wfguidePerform.html
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– Message Encoding: leave blank

– Directory: /tptutorial/binary-out/dynamic

– Pass by file name: No

– Scan subdirectories: Yes

– File pattern: leave blank, it defaults to *.*

– Sort by Arrival?: No

– Polling interval: 3 seconds (small enough to avoid a long wait)

– Read limit: 0

– Post Read Action: Delete

– Archive Directory: leave blank

– Error Directory: /tptutorial/errors

– Description: Raw data file.

8. Click Submit.

9. Close the WebLogic Integration Administration Console.

You are now ready to build and test the application.

To Test the DynamicBinaryBuyer Process

1. Click on the WebLogic Workshop menu to build and deploy the DynamicBinaryBuyer.jpd 
business process.

2. Place a binary file in the C:\tptutorial\binary-out\dynanmic\000000002 directory.

The file disappears is delivered to the trading partner.

You have completed the steps for the initiator side of this example.

Reviewing the Participant Side of the Example
The next step involves reviewing the participant side. Use what you have learned in previous 
examples to complete the following tasks:

“To Review the Participant Side of the Example” on page 3-60

“To Test the Example” on page 3-60
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To Review the Participant Side of the Example

1. Double-click on DynamicBinarySeller.jpd

The DynamicBinarySeller.jpd opens in Design View. 

2. Double-click on the Receive request node and note that there are two parameter types; one 
for the payload and the other for the ebXML envelope.

3. Close the node builder.

4. Right-Click on the Receive request node and select View Code. 

5. Select the request method and look at the Property Editor parameter entered for the 
ebxml-method envelope. The {env} parameter indicates that the ebXML envelope will be 
placed in the second parameter, env.

6. Click the Design View tab.

7. In the Data Palette, select the baseDirectory variable. In the Property Editor, note that 
the value of the variable is “/tptutorial/binary-in/dynamic/”. This is the base 
directory from which the application will read the sub-directory name and use it as the 
trading partner ID.

8. The remaining two nodes:

– setProperties—invokes the setProperties on the file control with a transformation that 
concatenates the “From” ID from the ebXML envelope and the directory base string. 
To review the transformation, double-click on the 
DynamicBinarySellerfileSetProperties.xq in the Application tab.

– write—this node reads and writes the binary files from and out to the directories you 
created on your hard drive. 

To Test the Example

1. Click on the WebLogic Workshop menu to run and deploy the process.

2. Drop a file into the C:\tptutorial\binary-out\dynamic\000000002 directory and 
watch it appear in a few moments in the 
C:\tptutorial\binary-in\dynamic\000000001 directory.
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Step 9: Creating a Distributed Setup
In all of the examples so far, the initiator (000000001) and the participant (000000002) are both 
located in the same WebLogic Integration instance and are using the same database repository. 
In practice, the two sides will operate on two physically separated systems. This examples briefly 
describes how to move to a distributed setup where 000000001 operates in one WebLogic 
Integration instance and the 000000002 in another. 

1. Install and configure a second WebLogic instance on another machine. 

a. Complete the procedure described in “Step 1: Create a New WebLogic Integration 
Domain” on page 1-3.

2. In the WebLogic Integration Administration Console navigate to the Trading Partner 
Management→Profile Management, for the first WebLogic Integration Server, modify 
the Test_Trading Partner_2 (000000002) trading partner information as follows:

a. Change Test_TradingPartner_2(000000002) to remote instead of local.

b. Modify the ebXML 2.0 binding by changing the EndPoint URL to include the correct 
server/port of the second WebLogic Integration server. The examples use ebXML 2.0 
binding by default, modify this to other bindings if you use them.

3. For the second WebLogic Integration server modify the Test_TradingPartner_1 
(000000001) as follows:

a. Deselect the default option.

b. Change local to remote.

c. Modify the ebXML 2.0 binding by changing the EndPoint URL to include the correct 
server/port of the first WebLogic Integration server. 

4. On each of the servers, start WEbLogic Workshop and open the tutorial application.

5. Navigate to Tools→Application Properties→WebLogic Server and ensure that the 
Server Home Directory field is set to the correct path.

6. Before testing any of the examples: use the WebLogic Test Browser to run the participant 
side processes to force them to build and deploy.
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Step 10: Configuring Non-Default Protocol Settings
In the previous examples, default values were used for the initiator trading partner and the 
protocol information. The default values were used as follows:

from field (initiator ID)—trading partner which is marked as default in the WebLogic 
Integration Administration console, 000000001 in the previous examples.

Protocol information—taken from the binding which is marked as default for each 
business protocol (ebXML MS 2.0; RNIF 1.1, 2.0).

In production scenarios, you will typically add a service and service profile entry which gives you 
control over the trading partner communication. This example illustrates how to add a service and 
a service profile by using the Seller and Buyer business processes which you created in “Step 2: 
Sending an XML Message through an One-Way ebXML Exchange” on page 3-9. It contains the 
following sections:

“Configuring the Participant Side” on page 3-62

“Configuring the Initiator Side” on page 3-63

Configuring the Participant Side
The Seller business process is the participant of the ebXML communication. 

1. If not already running, start your WebLogic Server by selecting Tools→WebLogic 
Server→Start WebLogic Server.

2. After the Server is running, open the WebLogic Administration Console by selecting 
Tools→WebLogic Integration→WebLogic Administration Console.

3. Log in to the console using the server user name and password that you specified in the 
“Step 1: Create a New WebLogic Integration Domain” on page 1-3 section.

4. Click Trading Partner Management.

5. Click Service Management.

6. In the Services panel, click View All.

A list of all participant processes which are currently deployed on your server is displayed.

7. Click on ebxmlWeb\ebxml\oneway\Seller.jpd

The View And Edit Service Details window opens.
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8. Click Add Service Profile.

The Add Service Profile window opens.

9. In the Name row, select Test_TradingPartner_2 as the LOCAL trading partner. This is the 
partner actually hosting the Seller service.

10. In the Name row, select Test_TradingPartner_1 as the REMOTE trading partner. This is 
the partner who will use the service.

11. Select ebXML 2.0 bindings for both the LOCAL and REMOTE binding.

12. Click Submit.

Configuring the Initiator Side
For the initiator side, service configuration information is added to the ebXML control that 
represents the remote service.

1. Go back to the Service Management page by clicking on Service Management in the 
navigation tool bar.

2. In the Services pane, click Create New.

3. Next to the name filed, click Browse.

A list of currently deployed participant business processes on your server and controls 
which are referenced from currently deployed processes is displayed.

4. Click on ebxml.oneway.SellerControl.

5. Click Add Service.

6. Click Add Service Profile.

7. In the Name row, select Test_TradingPartner_1 as the LOCAL trading partner. This is the 
initiator partner on the local system.

8. In the Name row, select Test_TradingPartner_2 as the REMOTE trading partner. This is 
the remote partner who hosts the actual service.

9. Select ebXML 2.0 bindings for both the LOCAL and REMOTE binding.

10. Click Submit.

You have now completed setting up the protocol settings. For each of the examples in this 
tutorial, you can create a corresponding service entry for each participant and initiator side. There 
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is no limit to how many service profiles you enter, you can create as many as you need for each 
service entry to reference different protocol bindings.

Step 11: Exchanging Messages with WebLogic Integration - 
Business Connect

WebLogic Integration - Business Connect is a separate application which enables you to securely 
exchange large volumes of documents with your trading partners. The application packages 
documents in secure envelopes that are transmitted among trading partners according to 
schedules.

Note: You must have WebLogic Integration - Business Connect installed to complete this 
example.

To learn more about WebLogic Integration - Business Connect, see the Using WebLogic 
Integration - Business Connect, available at 
http://edocs.bea.com/wlibc/docs81/admin/index.html.

This example contains the following sections:

“Configuring WebLogic Integration - Business Connect with Trading Partner Information.” 
on page 3-64

“Configuring WebLogic Integration with Trading Partner Information” on page 3-66

“Setting Up a Trading Partner Service Profile” on page 3-67

“Sending a Message from WebLogic Workshop to WebLogic Integration - Business 
Connect” on page 3-68

“Sending a File from WebLogic Workshop to WebLogic Integration - Business Connect” 
on page 3-69

Configuring WebLogic Integration - Business Connect with 
Trading Partner Information.
To avoid typing the trading partner information by hand, you can export it directly from 
WebLogic Integration and then import it into WebLogic Integration - Business Connect.

To Export the Trading Partner Information

1. If not already running, start your WebLogic Server by selecting Tools→WebLogic 
Server→Start WebLogic Server.

http://edocs.bea.com/wlibc/docs81/admin/index.html 
http://edocs.bea.com/wlibc/docs81/admin/index.html 
http://edocs.bea.com/wlibc/docs81/admin/index.html 


Step  11 :  Exchanging  Messages  wi th  WebLogic  In tegrat ion  -  Bus iness  Connect

Tutorials for Trading Partner Integration 3-65

2. After the Server is running, open the WebLogic Administration Console by selecting 
Tools→WebLogic Integration→WebLogic Administration Console.

3. Log in to the console using the server user name and password that you specified in the 
“Step 1: Create a New WebLogic Integration Domain” on page 1-3 section.

4. Navigate to Trading Partner Management→Partner Profile Import/Export.

The Import Trading Partner Management Data window opens.

5. In the Import/Export pane, select Export.

6. Select the Trading Partner option.

7. Click Browse next to Trading Partner.

8. Deselect Test_TradingPartner_2.

9. Click Done.

10. For the Format option, select Business Connect.

11. Click Export.

12. If a File Download dialogue opens, click Save.

13. In the Save As window navigate to the location which you want to save the exported file to.

14. Enter a filename and click Save.

Note: Remember the navigation path to the file or copy it to the clipboard. You will need 
this in the next procedures.

To Import the Trading Partner Information

1. Start the Weblogic Integration - Business Connect Administration tool by selecting 
Start→Programs→BEA WebLogic Integration - Business Connect 8.1→Administrator.

2. Use Administrator as the user name and leave the password field blank.

3. Click Partner Profiles.

4. Right-click in the white area and select Import from the menu.

5. Enter the path to the exported file location or paste it from the clipboard.

6. When prompted to select active protocol, click OK.
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You have now imported the information about the trading partner hosted on the WebLogic 
Integration server into WebLogic Integration - Business Connect. The next step is to configure 
WebLogic Integration with the trading partner information of the partner which is using 
WebLogic Integration - Business Connect.

Configuring WebLogic Integration with Trading Partner 
Information
In this section you create a trading partner in WebLogic Integration - Business Connect and 
export the trading partner profile to a file which will be imported into WebLogic Integration.

To Create and Export the Trading Partner Profile

1. In the Weblogic Integration - Business Connect Administration tool, click Company 
Profiles.

2. Click New and enter BCTradingPartner as the name and BCTP-id as the ID.

3. Fill out the basic profile contact information.

4. In the Inbound Protocols tab, add ebXML to the list.

5. Click OK.

6. In the Do you want to setup a certificate for this company? window, click No. Since we 
are not testing the security in this example, there is no need to set up a certificate.

7. Right-click on the profile entry and select Export from the menu.

8. Accept the defaults.

9. Remember the path to the export file location or copy it to the clipboard.

10. Click OK.

To Import the Trading Partner Profile

1. On the WebLogic Integration Administration Console→Trading Partner 
Management→Partner Profile Import/Export screen, in the Import/Export pane, click 
Import.

2. In the File Name field, enter the location to the file you exported from WebLogic 
Integration - Business Connect or paste the path from the clipboard.

3. Select Business Connect as the Import Format.
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4. Click Import.

You have now completed the configuration of WebLogic Integration and WebLogic Integration 
- Business Connect. If for any reason you have to create the WebLogic Integration - Business 
Connect trading partner by hand in the WebLogic Integration Administration Console, use the 
following values:

TP Name: BCTradingPartner.

ID: BCTP-id

Default: false

LOCAL/REMOTE: REMOTE

Binding Information: add ebXML 2.0 with the following settings:

– Name: ebxml-20

– Default binding: true

– Transport: HTTP, version: 1.1

– Endpoint: http//host:4080/exchange/BCTP-id where host is the IP address of your 
machine.

– Delivery semantics: Once and only once, retry count: 3

Setting Up a Trading Partner Service Profile
In this example you set up a trading partner service profile between the 000000001 trading 
partner in WebLogic Integration and the BCTP-id trading partner in WebLogic Integration - 
Business Connect. Service profiles specify the protocol binding and URL endpoints for the local 
and remote trading partners that offer and call the service.

To Set Up the Trading Partner Service Profile

1. If not already running, start your WebLogic Server by selecting Tools→WebLogic 
Server→Start WebLogic Server.

2. After the Server is running, open the WebLogic Administration Console by selecting 
Tools→WebLogic Integration→WebLogic Administration Console.

3. Log in to the console using the server user name and password that you specified in the 
“Step 1: Create a New WebLogic Integration Domain” on page 1-3 section.
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4. Navigate to Trading Partner Management→Service Management.

The View and Edit Services window opens.

5. In the Services panel, select Create New.

The Add Service window opens.

6. Click Browse (by the Name field).

7. The Choose Service window opens.

8. Select ebxml.oneway.binary.BinarySellerControl.

The Add Service window is displayed with the BinarySellerControl added to the Name 
field.

9. Click Add Service.

The View and Edit Services window is displayed with the new Service Details.

10. Click Add Service Profile.

The Add Service Profile window opens.

11. From the Name LOCAL drop-down menu, select Test_TradingPartner_1.

12. From the Name REMOTE drop-down menu, select BCPartner.

13. Click Submit.

14. Skip the authentication steps by selecting No.

15. Select ebxml.oneway.selector.SelectorSellerControl and repeat steps 9-14.

You have completed setting up the trading partner service profile and are ready to begin the 
tutorial examples of this section.

Sending a Message from WebLogic Workshop to WebLogic 
Integration - Business Connect
In this section, you use one of the initiator processes that you created in an earlier example to send 
a message. Recall that the SelectorBuyer business process in “Step 3: Selecting the Trading 
Partner Information Dynamically Through Typed XML” on page 3-23 selects the trading partner 
ID from the incoming data. In this example you use the files from that example, but modify the 
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incoming data with the correct trading partner ID to send the message to WebLogic Integration - 
Business Connect. 

1. Start the WebLogic Integration - Business Connect selecting Start→Programs→BEA 
Weblogic Integration-Business Connect 8.1→Start Server.

Note: For information about how to start the server on platforms other than Windows, see 
the Getting Started of Using WebLogic Integration - Business Connect available at 
http://edocs.bea.com/wlibc/docs81/admin/get_started.html.

Return to the WebLogic Integration application, and in the Applications tab, double-click 
on ebxml\oneway\selector\SelectorBuyer.jpd.

2. Click on the WebLogic Workshop menu. (For more detailed instructions refer back to, 
“To Test the Seller Process” on page 3-16.)

3. To enter test data, cut and paste the content of 
C:\myapps\tptutorialapps\ebXML\ebXMLWeb\sampledata\sampleorder.xml into 
the xml variable (payload) field.

4. In the test data pane, modify the Supplier_ID element to have the value BCTP-id.

5. Run the test.

6. Confirm that a file appeared in the inbound XML directory of your WebLogic Integration - 
Business Connect installation: 
[BC_HOME]\data\BCTP%2did\xmlin where [BC_HOME] is the directory in which you 
installed WebLogic Integration - Business Connect (such as C:\WLI-BC).

Sending a File from WebLogic Workshop to WebLogic 
Integration - Business Connect
Recall that in the advanced binary file example, the folder name is used as the name of the target 
trading partner. In this section, you use the DynamicBinaryBuyer and DynamicBinarySeller 
business processes to send a file to WebLogic Integration - Business Connect.

The first step in the process is to enable WebLogic Integration - Business Connect to receive 
binary files.

To Enable WebLogic Integration - Business Connect to Receive Binary Files

1. Start the Weblogic Integration - Business Connect Administration tool by selecting 
Start→(All) Programs→BEA WebLogic Integration - Business Connect 
8.1→Administrator.

http://edocs.bea.com/wlibc/docs81/admin/get_started.html
http://edocs.bea.com/wlibc/docs81/admin/index.html
http://edocs.bea.com/wlibc/docs81/admin/get_started.html
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2. Use Administrator as the user name and leave the password field blank.

3. Click Partner Profiles.

4. Double-click 000000001 to open the trading partner profile.

5. Click on the Binary Directories tab.

The Binary Directories tab opens with BCTP-id listed in the Companies field.

6. Click Add.

7. Click OK.

8. Note the inbound and outbound directories.

Note: WebLogic Integration -Business Connect replaces the ‘-’ character with ‘%2’ in 
default directory names.

To Run the Example

1. Create the C:\tptutorial\binary-out\dynamic\BCTP-id directory on your hard drive.

2. In WebLogic Workshop Application pane, navigate to and expand the 
ebxml\ebxmlWeb\ebxml\oneway\binary\advanced folder.

3. Double-click on DynamicBinaryBuyer.jpd

DynamicBinaryBuyer.jpd opens in Design View.

4. Click on the WebLogic Workshop menu to run and deploy the business process.

5. Drop a binary file into the C:\tptutorial\binary-out\dynamic\BCTP-id directory on 
your hard drive

The file will disappear in a few moments and appear in the inbound binary directory of your 
WebLogic Integration - Business Connect installation: 
[BC_HOME]\data\BCTP%2did\binaryin\TP1%2did where [BC_HOME] is the 
directory in which you installed WebLogic Integration - Business Connect.

Note: Make sure that the 000000001 partner is Active in the WebLogic Integration - Business 
Connect.
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