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Introduction

BEA XQuery Mapper is a graphical mapping tool that enables you to transform data between
XML, non-XML, and Java data types, allowing you to integrate heterogeneous applications
rapidly. For example, you can package data transformations in BEA WebL ogic Integration (WLI)
as controls and reuse the controls in multiple business processes and applications. You can also
use .xq files created in XQuery Mapper as resources in BEA Aqualogic Service Bus (ALSB).

The output of XQuery Mapper is a query in the XQuery language, which is defined by the World
Wide Web Consortium (W3C). For more information about W3C and the XQuery language, see
http://www.w3.0rg/XML/Query/.

Overview of XQuery Mapper

You can use XQuery Mapper to transform data between XML, non-XML, and Java data types.
For example, XML data that is valid against one schema can be converted to XML that is valid
against a different schema. The data can be based on XML schemas, Web Service Definition
Language (WSDL) file, and Message Format Language (MFL) files.

When you select the Simple source type, you can transform standard schema types, such as
boolean, byte, double, float, int, long, short, String, and Date, to any other required
target data format.

A data transformation can have multiple input types, but only one target type. For example, data
can be transformed from two sources to one target, as shown in the following figure.
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Figure 1-1 Data Transformation from Multiple Sources to One Target
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Support for XQuery 2002 and 2004

WLI supports data transformation for the following versions of XQuery:
e XQuery 2004: Graphical design view (XQuery Mapper), source view, and test view.

e XQuery 2002: Source view and test view.

Note: For XQuery 2002-compliant XQuery files, the source view does not show
compilation errors.

When you open an XQuery 2002-compliant XQuery file, it opens automatically in the
XQuery 2002 Transformation Editor, which has Source and Test views, but no Design view.
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Support for XQuery 2002 and 2004

Restrictions Applicable to the XQuery Test View

Table 1-1 Restrictions Applicable to the XQuery Test View

Restriction Applicable  Applicable
to XQ2002? to XQ2004?

If an XQuery calls a Java user function, the Java method must be static. Yes Yes

If an input Java type argument to an XQuery is an abstract class or an Yes No

interface, the test view can not process it. An error message is displayed in
the results view.

The input Java type and its member variables (except those of type  Yes No
primitive, String, java.sql .Date and java.util .Date)
must follow the standard Java Bean guidelines.

Transforming Data Using XQuery Mapper 1-3
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CHAPTERa

Transforming Data Using XQuery
Mapper

You can use the graphical interface of XQuery Mapper to create data transformations, by
mapping elements in source schemas to elements in a target schema. XQuery Mapper generates
an XQuery, which is saved as an -xq file.

The procedure to transform data using XQuery Mapper is described in the following sections:

e Launching XQuery Mapper

Creating the XQuery Mapper Sample Project

Creating an XQuery Mapper Project

Importing and Creating Schema Files

e Selecting Source and Target Data Types

Creating Data Transformations

Editing Data Transformations

Testing Data Transformations
e Graphical Features in Design View

e XML Global Elements, Global Types, Local Elements, and Attributes

Transforming Data Using XQuery Mapper 2-1
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Launching XQuery Mapper

1. Choose Start > Programs > BEA > WorkSpace Studio.
The Workspace Launcher dialog box is displayed.

Figure 2-1 Workspace Launcher

W Workspace Launcher, @

Select a workspace

BE#A Warkshop For WeblLogic stores vour projects in a folder called a workspace,
“hoose a workspace Folder bo use For this session.

Waorkspace: | ot\bealuser_projecksiworkspacesiworkshopd “ | [ Browse... |

[use this as the default and do nat ask again

[ OK ] [ Cancel ]

2. In the Workspace field, specify the folder in which the project files must be stored.

Note: If required, select the Use this as the default and do not ask again check box, and
click OK.

3. Open the XQuery transformation perspective by choosing Window > Open Perspective >
XQuery Transformation from the WorkSpace Studio menu.

The XQuery transformation perspective launches automatically when you open an XQuery
file. If, however, XQuery Mapper is open and no XQuery file is open, you must launch the
XQuery transformation perspective manually.

Creating the XQuery Mapper Sample Project

The XQuery Mapper sample project includes sample schema and XML files, which you can use

to create XQuery transformations as described in Chapter 3, “Examples: Data Transformation
Using XQuery Mapper.”

You can create the sample project by using a wizard from within the XQuery transformation
perspective.

1. From the WorkSpace Studio menu bar, choose File > New > Other > Data Transformation
> Tutorial: XQuery Transformation, and click Next.
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Creating an XQuery Mapper Project

2. Enter a name for your sample project and click Finish.

The sample project is created and displayed in the Navigator view. The project contains
the following folders:

— schemas folder: Contains the XML schema (.xsd) files of the sample project.
— XML folder: Contains test XML files required by some of the samples.

— XQueryTransformations folder: This is the folder in which you will create the
XQuery files for the samples.

To learn more about creating projects and importing the files you need for those projects, see the
following topics:

e Creating an XQuery Mapper Project
e Importing and Creating Schema Files

e Chapter 3, “Examples: Data Transformation Using XQuery Mapper”

Note: You can import project-specific XML schemas, Web Service Definition Language
(WSDL) files, and Message Format Language (MFL) files from any location. Before you
import the files, it is recommended that you create a folder structure that meets your
business needs. For more information, see “Importing and Creating Schema Files” on
page 2-4.

Creating an XQuery Mapper Project

1. Switch to the XQuery transformation perspective by choosing Window > Open Perspective
> XQuery Transformation.

2. Choose File > New > Project.

The New Project wizard is displayed.
3. Choose General > Project and click Next.
Enter a name for the project.

Ensure that the Use default location check box is selected.

o o &

Click Finish.
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Importing and Creating Schema Files

2-4

S

chema files can be created in and imported from any location. The following schema types are

supported:

1.

5.

e XSD (XML Schema Definition): XML schemas describe and constrain data in XML files.
Multiple namespaces are supported in XQuery Mapper. For example, you can transform
data from two source XML files that are valid against a specific namespace to an XML file
that is valid against another namespace.

e WSDL (Web Service Definition Language): XML schema defined in the WSDL file can
be used in data transformations.

e MFL (Message Format Language): MFL files describe and constrain data in non-XML
files (COBOL copybooks and C structure definitions, for example). The namespace of the
MFL elements is derived from the name of the MFL file.

MFL files are created using the Format Builder tool and have the .mf1 extension. For
more information, see the Format Builder Online Help.

mporting XML Schemas and MFL Files

Switch to the XQuery transformation perspective by choosing Window > Open Perspective
> XQuery Transformation.

In the Navigator view, select the project into which you want to import the XML schema or
MFL file.

Choose File > Import.
The Import wizard is displayed.

You can import XML schemas and MFL files from a variety of sources. Select the appropriate
source and click Next.

Browse for and select the required file, and click Finish.

After the schemas files or MFL files are imported, they are available in the New XQuery
Transformation wizard.

The following figure shows how the imported XML schemas are displayed in the New XQuery
Transformation wizard.
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Figure 2-2 New XQuery Transformation
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Creating XML Schemas

You can create XML schemas by using the XML Schema Editor.

1. Switch to the XQuery transformation perspective by choosing Window > Open Perspective

> XQuery Transformation.

2. Inthe Navigator view, select the project in which you want to create the schema files.

3. Select File > New > Other ...

The New screen is displayed.

Transforming Data Using XQuery Mapper
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Figure 2-3 Select a Wizard
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Expand the XML node.

A

Select XML Schema and click Next.

Sk

Select the parent folder in which you want to create the schema file.

7. Enter a name for the schema file and click Finish.

The schema file is created in the specified project. You can now specify the details of the schema
and save the file.

For information about using the XML Schema Editor, see Introduction to the XSD Editor at
http://www.eclipse.org/webtools/community/tutorials/ XMLSchemaEditor/XMLSchemaEditorT
utorial.html.

Creating XML Files from XML Schemas

1. Switch to the XQuery transformation perspective by choosing Window > Open Perspective
> XQuery Transformation.
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2. Inthe Navigator view, select the project in which you want to create the schema files.
3. Select File > New > Other ...
The New screen is displayed.

Figure 2-4 Select a Wizard - XML File
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4. Expand the XML node.

5. Select XML and click Next.
The Create XML File dialog box is displayed.
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Figure 2-5 Create XML File
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6. Select the Create XML file from an XML schema file option and click Next.

7. Select the parent folder in which you want to create the XML file.
8. Enter a name for the XML file and click Next.
9. Select the XML schema based on which you want to create the XML file and click Next.

10. Select the root element of the XML file and click Finish.

The XML file is created in the specified folder. You can now specify the details of the file and
save it.

For information about using the XML Editor, see Creating XML files Tutorial at
http://www.eclipse.org/webtools/community/tutorials/ XML Wizards/XMLWizards.html.

Creating WSDL Files

1. Switch to the XQuery transformation perspective by choosing Window > Open Perspective
> XQuery Transformation.

2. Inthe Navigator view, select the project in which you want to create the WSDL files.

3. Select File > New > Other ...
The New wizard is displayed.

4. Expand the XML node, select WSDL, and click Next.

5. Select the parent folder in which you want to create the WSDL file.
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Selecting Source and Target Data Types

Enter a name for the WSDL file and click Next.
Enter the target namespace and prefix of the WSDL file.
If required, select the Create WSDL Skeleton check box.

Select the protocol and the binding option and click Finish.

The WSDL file is created in the specified project.

For information about using the WSDL Editor, see Introduction to the WSDL Editor at:
http://www.eclipse.org/webtools/community/tutorials/WSDLEditor/WSDLEditorTutorial.html.

Creating MFL Files

You can create MFL files by using the Format Builder tool (Start > Programs > BEA Products
> Tools > Format Builder).

For more information about the Format Builder tool, see Format Builder Online Help.

Selecting Source and Target Data Types

Before you create a data transformation, you must define the source target types and a target data
type. The source and target types can be non-XML, XML, and simple data types.

1.
2.

Select the project for which you want to select source and target data types.
Right-click and choose New > XQuery Transformation.

The New XQuery Transformation wizard is displayed.

Enter a name for the .xq file.

Click Next.

The Source Types dialog box is displayed.

In the Available Source Types pane select the source data types.
— If the source is XML data, choose XML.
— If the source is MFL data, choose Non-XML.

— If the source data is of standard types, such as boolean, String, and int, then choose
Simple.

Select the required source data elements.

Transforming Data Using XQuery Mapper 2-9
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Note: For schemas to be displayed in the Available Source Types and Available Target
Types pane, the XML and non-XML files that contain these schemas must first be
imported into or created in WorkSpace Studio.

The Available Source Types and Available Target Types panes show only schemas
that exist in the schemas folder of the XQuery Transformation project. If you prefer
to keep your schemas in any other folder, you must specify the path to that folder in
the XMLBeans settings for the project (by choosing Project > Properties, the
XMLBeans page, and then the Source Paths tab).

For example, to add input data from schemas/Dates.xsd, select the date element in the
schema as the input element and click Add, as shown in the following figure.

Figure 2-6 Selecting Source Types
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The elements and attributes that make up the selected element are displayed in the Selected
Source Types pane.

7. After selecting the required source types, click Next.

The Target Types dialog box is displayed.

8. Inthe Available Target Types pane, select the target data type, and click Add.
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Creating Data Transformations

The elements and attributes that make up the selected element are displayed in the Selected
Target Type pane.

Note: You can specify only one target data type.

9. Click Finish.
The .xq file is displayed in the Design view. It shows the source and target data types that you
selected.

Creating Data Transformations

You can perform the following types of data transformations:
e Basic element transformations: Mapping a source element to a target element.
e Basic attribute transformations: Mapping a source attribute to a target attribute.

e Complex transformations: Mapping a complex source (for example, a repeating element) to
a complex target (for example, a nonrepeating element).

Creating Basic Element Transformations

Basic element transformation involves mapping a source element to a target element. The source
and target elements may have the same name, type, or scope.

The following are some examples of the types of basic element transformation that you can
perform:

e Element to element: A source element is mapped to a target element.

e Element combination: Multiple source elements are combined to create a single target
element.

e Element explosion: XQuery string functions are exploded from a single source element to
multiple target elements.

Prerequisite
The XQuery file is created as described in “Selecting Source and Target Data Types” on page 2-9.

Creating Element-to-Element Links

1. Select the project for which you want to create element-to-element links, and open the
XQuery file in which the transformation must be stored.
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2. Drag the required element from the Source pane to the target element in the Target pane.

For example, to create a link between the customer-name element in the source schema
and the customer-name element in the target schema, drag customer-name from the
Source pane to the Target pane. An arrow connects the two elements, as shown in the
following figure.

Figure 2-7 Element-to-Element Links

Source Target

—-f#] customer - customer
@ customer-d @ customer4d
@ customer-name = pen{igly. CUSOMET -NEME
@ customer-address @ customer-address

Note: While dragging from the Source pane to the Target pane, a dashed line appears
temporarily between the two elements. For more information about link patterns,
“Link Patterns” on page 2-29.

3. After creating the required element-to-element links, save the changes.

Creating Basic Attribute Transformations

Basic attribute transformation involves mapping a source attribute to a target attribute. The source
and target attributes may have the same name, type, or scope.

The following are some examples of basic attribute transformations:
e Element to attribute: A source element is mapped to a target attribute.
e Attribute to element: A source attribute is mapped to a target element.
e Attribute to attribute: A source attribute is mapped to a target attribute of the same name.

Prerequisite
The XQuery file is created as described in “Selecting Source and Target Data Types” on page 2-9.

Creating an Attribute-to-Element Link

1. Select the project for which you want to create attribute-to-element links, and open the
XQuery file in which the transformation must be stored.
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Creating Data Transformations

2. Drag the required attribute from the Source pane to the appropriate element in the Target
pane.

For example, to create a link between the street attribute of the address element in the
source schema and the street element of the target schema, drag the street attribute
from the Source pane to the Target pane, as shown in the following figure.

Figure 2-8 Attribute-to-Element Link
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3. After creating the required links, save the changes.

Similarly, you can create element-to-attribute and attribute-to-attribute links.

Creating Complex Transformations

Complex transformations involve mapping a complex source (for example, a repeating element)
to a complex target (for example, a nonrepeating element). The following are some examples of
complex transformations:

e Repeating group to repeating group: The source contains a variable number of instances
of a group of elements; each source instance is mapped to an instance of the target group.

e Repeating group to nonrepeating element: The source contains a variable number of
instances of a group of elements; each source group is mapped to an instance of the target
element.

Prerequisite
The XQuery file is created as described in “Selecting Source and Target Data Types” on page 2-9.

Creating a Complex Transformation

1. Select the project for which you want to create the links, and open the XQuery file in which
the transformation must be stored.
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2. Drag the required element or attribute from the Source pane to the appropriate element or
attribute in the Target pane.

For example, to create a link between product (a repeating group in the source schema)
and product (a repeating group in the target schema), drag product from the Source

pane to the Target pane, as shown in the following figure.

Figure 2-9 Repeating-Group—to—Repeating-Group Link

3. After creating the required links, save the changes.

Editing Data Transformations

2-14

After creating a data transformation in the Design view, you can add, change, and delete XQuery
code either by editing code directly in the Source view or by adding complex expressions in the

Design view.

Note:

This section contains information about the following topics:

Viewing and Editing XQuery Files

Creating Joins and Unions

Creating If-Then-Else Expressions

Source Target
I -[#) products --[#) products
= 6“ e 1o ——— | T = | —— G-;‘ product
@ partld @ partid
@ quantity @ quantity
@ price @ price

For information about the XQuery language, see http://www.w3.org/XML/Query.

Creating For-Let-Where-Order By-Return (FLWOR) Expressions

Creating Typeswitch Expressions

Inserting XQuery Functions

Inserting Expression Variables

Viewing Schema Properties

Transforming Data Using XQuery Mapper
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Editing Data Transformations

Viewing and Editing XQuery Files

1.
2.

5.

Select the project containing the XQuery file that you want to edit.

Double-click the XQuery file.

Note: If the XQuery file is XQuery 2002-compliant, it opens automatically in the XQuery
2002 Transformation Editor, which has only Source and Test views. For more
information, see “Support for XQuery 2002 and 2004” on page 1-2.

Select the Source view.
The XQuery code is displayed. Invalid code is underlined in red.

Make the required changes.

Note: If necessary, you can delete the data transformations in the Source view by deleting
all the code within the function except the root element.

Save the changes.

Creating Joins and Unions

The Constraints view in the XQuery transformation perspective allows you to constrain or
manipulate the relationship between source and target repeating elements.

The following Constraint Type options are available in the Constraints view:

e Repeatability/Join option

When you create transformations between repeating elements, for loops are generated to
iterate through the repeating elements. You can limit or constrain the target repeating
elements by adding where clauses to the for loops in the Where Clause pane of the
Constraints view.

You can create complex conditions (joined by OR or AND operators) for the where clause,
as shown in the following code example:

((data($PurchaseOrderDoc/partld) > 200 and
data($PurchaseOrderDoc/partld) <= 400))

At run time, the for loop iterates over only those repeating elements that fulfill the
complex condition.

For a detailed example on using the Constraints view, see “Creating Repeating-Source to
Nonrepeating-Target Transformations” on page 3-17.
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e Union

See “Creating Unions” on page 3-14.

Creating If-Then-Else Expressions
The Target Expression view allows you to create if-then-else expressions.

When a query that contains an if-then-else expression is executed, the conditions that make up
the i expression are evaluated. Depending on the result, different values are returned for the
target node.

Figure 2-10 shows XQuery code that can be used to implement the following logic:

o If the value of the quantity source node is more than 500, then return 4554 as the value
of the 1D target node

e If quantity is less than or equal to 500, then return 5894 as the ID.

Figure 2-10 Example of If-Then-Else Expression

Source XML Data Query
(example data: (XQuery Code)

PurchaseOrder.xml)
<Supplier=
{id}{
<?xml version="1.0" encoding="UTF-8"7> if (data($PurchaseOrderDoc/quantity) > 500)
=PurchaseQrder= then
=partld=345</partid> 4554
=guantity=678</gquantity= else
=maxVolumeForSupplier=1000 5894 }<fid=
=/maxVolumeFarSupplier= </Supplier=>
=countryCode=UK</countryCode=>
=/PurchaseOrder>

.~ Target XML Data

<?xml version="1.0" encoding="UTF-8"7>
<Supplier=

<id>4554<fid=
=/Supplier=

You can add multiple expressions to the If condition, as shown in the following figure.
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Figure 2-11 If-Then-Else Expression in Target Expression View
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You can change the position of a condition by selecting it and then clicking the Move Up or
Move Down button. You can also remove a condition by selecting it and then clicking Remove.

Note:

In the Edit If Condition pane, even if you remove all the expressions by using the
Remove button, the if-then-else expression is not removed entirely in the Source view.
The expressions associated with the if condition are removed, but the then and else
expressions are retained, as shown in the following listing.

<nsO:partld>

if (fn:boolean('true'™))
then 4554
else 5894

3
</nsO:partld>
The XQuery always returns the then expression. The else expression is retained in the
code so that you can reuse it in the future, if required.

For more information, see “Creating Nested If-Then-Else Expressions” on page 3-24.

Creating For-Let-Where-0rder By-Return (FLWOR)
Expressions

The Target Expression view allows you to create FLWOR expressions, as shown in the
following figure.
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Figure 2-12 FLWOR Expression

Constraints | Problems | Console | Upgrade

Expression Type: () General (If Then Else  (*) For.. .Return () Typeswitch

For-Let-Where-OrderBy-Return Expression
Expression Structure ‘iew For-Let-Where-OrderBy-Return Expression

= 7 Far...Return
¥ For Clause for Sorder-item in [ Sitem )
Let Clause
Where Clause
COrder By Clause

Rekurn Expression

pe < iR

return
Sorder-item

RadF

let fpart := | Sorder-item/ns0:part-—nuwher )
where jorder—-item/ns0:quantity-nunber > 100
order by Sorder-itemy/ns0:part-nuwwher

The following table describes the components of FLWOR expressions.

Table 2-1 Clauses of FLWOR Expressions

Component  Description Optionalor  Allowed Nested
Mandatory  Expressions
For clause The For clause iterates over a sequence of input items and At least e If-Then-Else
returns a value for each item. oneForor . FELWOR
Let clause .
e Typeswitch
Let clause The Let clause declares a variable and assigns a value to the At least e If-Then-Else
variable. oneForor , ELWOR
Let clause .
e Typeswitch
Where The Where clause specifies the basis for filtering input data. It Optional
clause is similar to the If clause.
Order By The Order By clause specifies the basis for sorting the output ~ Optional e If-Then-Else
clause of the query. « FLWOR
e Typeswitch
Return The Return expression defines the output of the query. Mandatory <  If-Then-Else
expression (onlyone) . ELWOR
e Typeswitch
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You can insert nested expressions under For, Let, Order By, and Return by right-clicking on them
and selecting the required expression from the menu.

Note: In the Design view, if you create a link between repeating elements, a For...Return
expression (implicit FLWOR expression) is generated automatically in the Source view.
You can add Where clauses to this FLWOR expression by using the Constraints view,
but you cannot add Let and Order By clauses. Implicit FLWOR expressions are not
shown in the Target Expression view.

For more information, see “Creating FLWOR Expressions” on page 3-29.

Creating Typeswitch Expressions

Typeswitch expressions may be required in the following situations:

e When an XML schema contains a <choice> element, which allows only one of the
elements defined in the <choice> declaration to be present in the containing element, you
can use a typeswitch expression to determine the type of the <choice> element that is
present in the source XML file and, accordingly, return a value.

e When an XML schema contains a substitution group, which allows one element to be
substituted for another, you can use a typeswitch expression to determine the type of the
element that is actually in the source XML file and, accordingly, return a value.

The Target Expression view lets you create typeswitch expressions, as shown in the following
figure.

Figure 2-13 Typeswitch Expression

Expression Type: () General (O IF Then Else (JFor...Return  (3) Typeswitch
Typeswitch Expression

Expression Structure View Typeswitch Expression
= ?{j’ Ty
a4
L) Case Clause
L) Case Clause
L Case Clause
L) Default Clause

typeswitch (5addressl/ | nzl:zip_code | ns0:pin code | ns0:postal code ))

case $zipCodeType as element ins0:zip code) return | Saddressl.fnso:zip_code ]

case $pinCodeType as element ins0:pin_code) return | Saddressl.fnso:pin_code ]

case $postalCodeType as element ins0:postal_code] return | Saddressl.fnso:postal_code ]

default )
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The following table describes the components of typeswitch expressions.

Table 2-2 Clauses of Typeswitch Expressions

Component Description Optional or Allowed Nested
Mandatory Expressions
Operand The Operand is the expression for which the type istobe ~ Mandatory
expression evaluated. (only one)
Case clause Each Case clause specifies the name of the type to be Mandatory e If-Then-Else
evaluated and the expression to be returned if the (atleastone) . EFLWOR

evaluation is true.

e Typeswitch

Default The Default clause specifies the return expression that Mandatory
clause must be used if the value of the operand expression (only one)

matches none of the types specified in the Case clauses.

* If-Then-Else
+ FLWOR
e Typeswitch

2-20

Inserting XQuery Functions

A set of standard W3C XQuery functions and operators is provided in XQuery Mapper. You can
add standard XQuery or user-defined functions in XQuery files and data transformation files. For
example, you can, use the upper-case XQuery String function to convert the characters in an

XML String value to uppercase characters.

Note: For more information about XQuery 1.0 and XPath 2.0 functions and operators (W3C

Working Draft 23 July 2004), see
http://www.w3.0rg/TR/2004/WD-xpath-functions-20040723/.

1. Switch to the XQuery transformation perspective by choosing Window > Open Perspective

> XQuery Transformation.

The Expression Functions view is part of the XQuery transformation perspective.

2. Open the XQuery file in which you want to insert XQuery functions.

3. Inthe Design view, select or create a link to add the function call.

The link becomes green.

4. Select the Target Expression view.

If the Target Expression view is not visible, choose Window > Show View > Target

Expression.
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In the General Expression pane, the XQuery code linking the selected target and source
node is displayed and is selected. Keep this selected for the next step.

Delete the existing XQuery code in the General Expression pane.

Find the function that you want to insert in the Expression Functions view.

For this example, from the String Functions folder, select the upper-case function,
which converts all the characters of the source element to upper case.

Drag the upper-case function to the General Expression pane.

Leave the parameter of the selected function (the $string-var parameter of the
upper-case function in this example) in the General Expression pane selected.

Note: XQuery functions that are defined by BEA (example: trim-left) are prefixed with
fn-bea:.

Note: XQuery functions that are not listed in the Expression Functions view but defined
in the XQuery specification, can be used with the fn: prefix.

. Select a source parameter for the function using one of the following options:

— From the Source pane of the Design view, select a source element, drag it to the
General Expression pane and drop it over the $string-var parameter.

— From the Expression Variables view, select a source variable, drag it to the General
Expression pane and drop it over the $string-var parameter.

. After inserting the required functions and assigning parameters to the functions, click Apply
in the General Expression pane.

Inserting Expression Variables

The variables (and their subelements) that you can use in an XQuery are displayed in the
Expression Variables view.

Note: If the Expression Variables view is not displayed, choose Window > Show View >
Expression Variables.

The following types of variables are displayed in the Expression Variables view:

e Source: The variables displayed under the Source node in the Expression Variables view
are those that are selected for the transformation in the Source Types dialog box of the
New XQuery Transformation wizard.
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e Structural Link: The variables displayed under the Structural Link node in the
Expression Variables view are the loop iteration variables that are associated with the
XQuery for loops generated by structural links.

These variables are in scope for all the subelements of the node that has the structural link.

You can insert expression variables in the following ways:

e Drag-and-drop

Drag the variables or their subelements from the Expression Variables view, and drop
them in the Constraints or Target Expression view.

e Enter $ and choose a variable from the pop-up menu

a. Enter the dollar symbol ($) in the required text field. For example, enter $ in the General
Expression pane of the Target Expression view.

A pop-up menu containing a list of the available variables is displayed.
b. Choose the required variable and then enter a forward slash (/).

If subelements exist, a pop-menu containing a list of the available subelements is
displayed.

c. Choose the required subelement and then enter a forward slash (/).

If further subelements exist, a pop-menu containing a list of the available subelements
is displayed.

d. Repeat step c until you finish entering the required variable.

Viewing Schema Properties

While editing an XQuery file in the Design view, you can view the schema properties of nodes
in the current transformation in the Properties view, without opening the source and target XSD
or MFL files.

To display the Properties view, choose Window > Show View > Properties.

e If you select an element or attribute in the Source, Target, or Expression Variable view,
the associated schema properties are displayed in the Properties view.

o If you select a link, the schema properties of the target and source elements of the link are
displayed in the Properties view.
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e To deselect a link (including the target and source nodes of the link), click anywhere in the
empty area of the pane between the Source and Target panes of the Design view.

Note: To change the schema properties of an element or attribute, edit the corresponding
schema file (XSD for XML schema and MFL for non-XML schema).

Restricting Output of Optional Elements

If the target schema in a data transformation contains an optional element (minOccurs=*0""), you
can design the link to the element such that the element is included in the output XML file only
if it contains a value (that is, the element is not empty in the source XML file).

Consider the source XML data in the following listing.

Listing 2-1 XML Data with Optional Element

<address>

<Address_Line_1>1 EIm Street</Address_Line_1>
<Address_Line_2/>

<City>San Jose</city>
<State>California</State>
<Country>US</Country>

</address>

The Address_Line_2 element is optional and empty. If Address_Line_2 is mapped to a
corresponding element in the target schema, then, by default, the output XML file contains an
empty Address_Line_2 element.

You can restrict output of such optional elements by right-clicking on the link and selecting
Remove Empty Node, as shown in the following figure.
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Figure 2-14 Remove Empty Node

@ address_Linel -
@ address_Line2 -

| | ----------------------------- @ Address_Linel
G; Address_Linez

T view Code

g ity Disable Target Mode g City
State Remnove Empty Mode State
@ Country @ Country

Delete Link,

L - -

The XQuery code underlying the link is enclosed in an if-then-else expression that causes the
target element to be produced only if the transformation results in a nonempty value.

You can remove the if-then-else expression by right-clicking on the link and selecting Retain
Empty Node, as shown in the following figure.

Figure 2-15 Retain Empty Node

9 address_Lingl Hef fddress_Line
6? Address_Linga e - s = - View Codeh G; Address_Line2
ik i it
g St:te Disable Target Mode g Sta'ie
@ Countr Retain Empty Mode L@ Countr
=N~ . H,Y Delete Link - H,Y

Note: The Remove Empty Node (or Retain Empty Node) option is displayed only when you
right-click on a link to an optional target element.

Testing Data Transformations

2-24

After creating an XQuery transformation in the Design view, you can test whether the expected
XML or non-XML output is generated properly in the Test view.

You can use the autogenerated XML files or your own custom XML and non-XML files for
testing the transformations.

Features of the Test View

The following figure shows the features of the Test view.
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Figure 2-16 Test View

Generate Data
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e Source Variable

The values available in the Source Variables drop-down list are based on the source XML
schemas of the transformation that you are testing. When you select one of these schemas,
an XML file is generated automatically and displayed.

Note: These XML files are not saved automatically; you can save them by clicking the
Export icon.

To use a custom XML file (instead of the autogenerated XML files) or a non-XML
file (such as MFL) for testing the transformation, you can import the file by clicking
the Import icon.

e Generate Data

When you select the Test view, XQuery Mapper generates an initial set of sample data and
displays it in the Source Data pane.

If you want to regenerate the sample data, click Generate Data. You might, for example,
want to start testing afresh with new sample data if edits have resulted in XML data that is
no longer valid for the input schema.
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If the XQuery that you want to test has multiple source types, you can generate sample
data for each source type by selecting the required source type in the Source Variable
drop-down list and then clicking the Generate Data icon.

You can also manually edit the generated XML data.

Note: For complex input schemas, the generated XML data may not comply with the
schema. Validation errors are underlined in yellow in the Source Data tab. When you
place the mouse pointer over an error, details of the error are displayed. You can
correct the generated XML data to make it comply with the input schema.

Import File

You can import data from an XML (or non-XML) file and test the transformation using
that data.

In addition, if the XQuery that you want to test has multiple source types, you can import
sample data for each source type by selecting the required source type in the
Source Variable drop-down list and then clicking the Import File icon.

If the Auto Validate option is selected, then, when you import data, the data is validated
against the associated schema. Errors are underlined in yellow. When you place the mouse
pointer over an error, details of the error are displayed.

Note: You can import XML data for global types and local elements, but global types and
local elements are not validated and no errors or warnings are reported for invalid
data. For more information, see “XML Global Elements, Global Types, Local
Elements, and Attributes” on page 2-31.

Export to File: You can save the data in the Source Data pane or the results of the
transformation in the Result Data pane to an XML file.

Test XQuery: When you select this option, the XQuery is executed on the data in the
Source Data pane and the result of the transformation is displayed in the Results Data
pane.

Options for validating at design time

The Auto Validate option in the Source Data pane and the Validate option in the Result
Data pane are enabled only if the source parameter or result data is an XML global
element.

The validation options are not available for the following data types:
— Typed non-XML

Note: Inany case, untyped non-XML (raw) data cannot be used in data transformations.
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— XML global type
— XML local element

For more information, see “XML Global Elements, Global Types, Local Elements, and
Attributes” on page 2-31.

Selecting the Auto Validate option causes the source data to be validated automatically
against the source schema every time the data is changed.

You can use the Validate option to validate the result of the transformation against the
target schema.

Note: The validation at design time in the Test view is not the same as the schema validation
that occurs at run time. Validation at design time does not modify the resulting XML
document, but it does check for existence of elements and attributes that are defined
as required in the schema.

Related Topics
Restrictions Applicable to the XQuery Test View

Graphical Features in Design View

This section provides information to help you use the graphical features of XQuery Mapper and
interpret the graphical representations in the Design view of XQuery Mapper.

Right-Click Menu Options

The following table lists the options available in the Design view of XQuery Mapper when you
right-click on a link or element.

Table 2-3 Right-Click Menu Options

Menu Option Appears When You ... Result ...
View Code Right-click on any link or ~ The view switches to the Source view, and the XQuery code for
target element the link is selected.
Create Right-click on any Lets you assign a constant value to the target element.
Constant simple-type target
element
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Table 2-3 Right-Click Menu Options

Menu Option

Appears When You ...

Result ...

Disable Target
Node

Right-click on any link or
target element

Blocking XQuery code is added around the XQuery code of the
selected link. The blocking code prevents the XQuery code for
the link from being executed at run time.

Note: The Disable Target Node menu option is not available

for the root node of the target type.

Enable Target
Node

Right-click on a disabled
link or target element

The blocking XQuery code is removed from around the selected
link so that, at run time, the XQuery code for the link is
executed.

Remove Empty
Node

Right-click onalink to an
optional target element.

Surrounds the link with an if-then-else expression that causes
the target element to be produced only if the transformation
results in a nonempty value.

Retain Empty
Node

Right-click on a link (to
an optional target
element) for which you
selected the Remove
Empty Node option
earlier.

Removes the if-then-else expression that causes the target
element to be produced only if the transformation results in a
nonempty value.

Redefine
Wildcard Node

Right-click on a wildcard
(any type) source or
target element

Lets you define a specific data type for a wildcard element.

Note: After you redefine a wildcard node (that is, define a
specific data type), you cannot use Ctrl+Z to revert to

the any type.

Revert to
Wildcard Node

Right-click on a wildcard
(any type) source or
target element, for which
you defined a specific
data type earlier by using
the Redefine Wildcard

Changes the data type of the element from the specific type that
you defined earlier to wildcard (any type).

Node option.
Induce Map Right-click onastructural ~ Data links or data structural links are created between the child
link. nodes of the selected structural link if source and target child
elements of the link are the same subschema type.

Note: For the Induce Map option to create child links, the
target and source child elements must have the same
name and data type, and must be in the same order.
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Table 2-3 Right-Click Menu Options
Menu Option Appears When You ... Result ...

Delete Link Right-click on any link. e Design view: The link is deleted.
e Source view: The XQuery code underlying the link is

deleted.
Delete All Right-click anywhere in « Design view: The lines representing the transformation
Links the empty pane between between source and target elements/attributes are deleted.
the Source and Target . gource view: The generated XQuery code is deleted.

panes.
Note: Right-clicking anywhere in the empty pane between the

Source and Target panes causes all the nodes to be
deselected.

Link Patterns

Links in XQuery Mapper are shown in different colors and patterns to help you distinguish easily
between different link types. The following table describes the graphical representation of the
links that you create in XQuery Mapper.

Table 2-4 Link Patterns

Link Type Description Link Representation
Currently
Selected?
Data Link A link that converts the value of the source node Not
directly to the value of the target node. Selected

Selected R
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Table 2-4 Link Patterns

Link Type Description Link Representation
Currently
Selected?
Implied A data link for which you modified the underlying Not
Link XQuery code. Selected
A link for which the XQuery code cannot be Selected
interpreted by the XQuery Mapper. L=
Examples:
e Alink for which you inserted the
fn:upper-case XQuery function by using the
General Expression section of the Target
Expression view.
¢ The data links generated between a second set of
child nodes when a union constraint is applied to
a set of two structural links. The child nodes must
be of the same subschema.
Structural A link between two parent structures and that does Not -
Link not map data directly. Selected
Selected Becssmssp
Data A data structural link is a combination of a data link  Not B .
Structural  and a structural link. Selected
Link Example: A link between the optional child nodes of Selected
a repeating element. L
Constraint A link that constrains or limits the resulting dataofa  Not
Link join between source parent structures. The constraint ~ Selected
link is created with two source nodes.
Example: A a join between two source repeating
elements to return the data only when the values of a
particular source element are equal to each other. Selected
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Table 2-4 Link Patterns

Link Type Description Link Representation
Currently
Selected?

Copy Link A link between two identical schema substructures. ~ Not
At run time, the source data is copied directly, as a Selected
block, to the target data.

A copy link is also generated when you map an
untyped XML node to a typed XML complex-type ~ Selected e ——]
node.

Link Colors

When you drag a node from the Source pane to the Target pane, a temporary link (dashed line)
appears between the two nodes. The color of the line changes depending on the compatibility
between the source and target nodes.

e Red: The link cannot be created between the source node and the target node because the
data type of the target node cannot be converted to the data type of the source node. For
example, a node of XML String data type cannot be converted to an XML repeating node.
An error message is displayed when you drag the source node over the target node.

e Orange: The link can be created between the source and target nodes, but the data types
are not completely compatible. A warning message describing the incompatibility or any
necessary conversion is displayed when you drag the source node over the target node.

e Green: The link can be created between the source and target nodes. The data type of the
target node is compatible with the data type of the source node.

When you finish creating the link, a dotted or dashed line (depending on the source and target
nodes) is displayed.

XML Global Elements, Global Types, Local Elements, and
Attributes

An XML schema type or element is considered global if it is a direct child of the schema element
and local if it is not a direct child of the schema element (that is, the element is nested within
another element).
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The following example XML schema illustrates this difference.

Listing 2-2 XML Schema with Global and Local Elements

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.0rg/2001/XMLSchema’
targetNamespace="http://www.acme.org/globalExample®
xmlns="http://www.acme.org/globalExample"
elementFormDefault="qualified"
attributeFormDefault=""unqualified">
<xs:element name="globalElement">
<xs:complexType>
<xs:sequence>
<xs:element name="localElement™
minOccurs="1" maxOccurs="1"
type="'xs:string" />
</Xs:sequence>
<xs:attribute name="attribute"
type=""xs:string" use="required'/>
</xs:complexType>
</xs:element>
<xs:complexType name="globalType">
<xs:sequence>
<xs:element name="anotherLocalElement"
minOccurs="0" maxOccurs="unbounded"
type=""xs:string" />
</Xs:sequence>
</xs:complexType>
</xs:schema>

In the preceding XML schema, globalElement is global because it is a direct child of the
schema element, whereas localElement is local because it is a child of globalElement.

You can also define a global type, as shown by the global Type element toward the end of the
preceding XML schema. While you can have only one global element in an XML schema, you

2-32 Transforming Data Using XQuery Mapper



XML Global Elements, Global Types, Local Elements, and Attributes

can declare many elements (with different names) of the same global type in a single XML

schema.

The following table shows the graphical representations of the different XML components in

XQuery Mapper.

Table 2-5 Graphical Representation of XML Components

Component Graphical Representation Name in Preceding Example XML Schema
Global Element globalElement
globalElement
Local Element — localElement
i) localElernent
Global Type globalType
= "-—&IE Global Types
k3 globalType
Attribute attribute defined for globalElement

—-f#] globalElement
&) attribute
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CHAPTERa

Examples: Data Transtormation Using
XQuery Mapper

The examples described here are based on the sample project that is included in the product. For
information about opening the sample project, see “Creating the XQuery Mapper Sample
Project” on page 2-2.

Examples are provided for the following scenarios:

e Combining Data from Different Schemas

Mapping Repeating Elements and Creating Joins

Creating Unions

Creating Repeating-Source to Nonrepeating-Target Transformations

Creating Nonrepeating-Source to Repeating-Target Transformation

Creating Nested If-Then-Else Expressions

Creating FLWOR Expressions

Using Recursive Schemas

e Grouping Data by Key Fields
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Combining Data from Different Schemas

You can use XQuery Mapper to combine content from two different schemas, as shown in the

following figure.

Figure 3-1 Combining Data From Different Schemas

Source XML Data
(valid to XML Schema in Custinfo.xsd)

<7xml version="1.0" encoding="UTF-8"7=

=customer xmins="hiip:/fwww.creditpo.orgiCustinfo™
<customer-id>123456789</customer-id>
<customer-name>CustomerX </customer-name=
=customer-address=AddressX=</customer-addres:

<jcustomer=

-
o)

Source XML Data
(valid to the XML Schema in PO.xsd)

<7Pxml version="1.0" encoding="UTF-8"7=
<purchase-crder xmins="http:fwww. creditpo org/PO"=
=line-items=
<line-item=
<part-no=1</part-no=>
=guantity=10=/guantity=
<fline-iterm:=
<line-item=
=pari-no=2</part-no=
<guantity=20=</quantity=
=fline-iterm:=
<line-item=
<part-no>3</part-no>
<guantity=30=/guantity>
=/line-item=
<fline-iterms=
</purchase-crder=

Result XML Data
(valid to the XML Schema in POCustinfo.xsd)

<7xml version="1.0" encoding="UTF-8"7>
<poc:purchase-order xmins:poc="http:/f'www. creditpo.org/
POCustinfo"=

<pocicustomer=

<gus customer-id xmins cus="http/iwww creditpo orgl
Custinfo"=123456 TBS=/cus cusiomer-id=
<gus customer-name xmins.cus="hitp:/fwww.creditpo.ong/

Custinfo"=Customari</cus: customer-namea=

=gus:cusiomer-address xmins cus="http:fwww.creditpo.org/
ustinfo"=AddressX<fcus:customer-address=
</poccustomers
(=pocline-items=
<poc;line-item=

<poc: part-no=1</poc:part-no=
=pociguantity=10</pac:guantity=
</pociline-item=
<poc:line-item=>

=poc: part-no=2=<pac:par-no>

In this example, customer data (valid against CustiInfo.xsd) is merged with a repeating element

L J

<poc;quantity=20</poc: quantity=
<ipoc:line-item>
=poc:line-ilem=>
<poc; part-no>=3<fpoc:part-no>
<poc:guantity>30</poc:quantity>
</poc:line-itam=>
<fpoc line-items=

E/poc:purchase-order>

line-items (valid against PO.xsd) to form a single XML document that is valid against the

POCustInfo.xsd schema.

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”

on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper

Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.

3-2
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3. Choose New > XQuery Transformation.

4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations.

5. Enter combineData as the file name and click Next.

6. Select the following source elements and click Next:
— CustiInfo.xsd\customer
— PO.xsd\purchase-order
7. Select POCustiInfo.xsd\purchase-order as the target element and click Finish.

The combineData.xq file is created in the /XQuery
Transformation/XQueryTransformations folder.

The source and target elements that you selected are displayed in the Design view, as
shown in the following figure.

Figure 3-2 Design View of XQuery Transformation

=3
Source Target
=[] customerl = [ purchass-order
@ customer-id =@ customer
@ customer-name @ customer-id
@ customer-address @ customer-name
= purchase_orderl @ customer-address
=@ line-items =@ line-items
= 6* line-item = G-* ling-item
@ part-no @ part-no
@ quantity @ quantity

Design | Source | Test
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8. Create links between the following source and target elements by dragging elements from the
Source pane to the Target pane.

Source Element

Target Element

customerl

purchase-order\customer

customerl\customer-id

purchase-order\customer\custome
r-id

customerl\customer-name

purchase-order\customer\custome
r-name

customerl\customer-addre
ss

purchase-order\customer\custome
r-address

purchase_orderl\line-ite
ms\line-item

purchase-order\line-items\line-
item

purchase-orderl\line-ite
ms\line-item\part-no

purchase-order\line-items\line-
item\part-no

purchase-orderl\line-ite
ms\line-item\quantity

purchase-order\line-items\line-
item\quantity

Note: Dotted lines represent Structural links, which are created between parent structures

and do not map data directly.

Solid lines represent Data links, which convert the value of the source node directly
to the value of the target node.

For more information, see “Graphical Features in Design View” on page 2-27.

The links between the Source and Target elements are displayed, as shown in the
following figure.
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Figure 3-3 Data Transformation in Design View

¥ combineData.xg X

%Query TransformationjcombineData. xq | Target

= @ purchase-order
=g customer

@ customer-id

Source
= @ customerl
@ custamer-id
@ customer-name
@ customer-address @ customer-name
= @ purchase_orderl G_f customer-address
=@ line-items =@ line-items
=@ line-item - line-item
@ part-no @ part-no
@ q ...... Q‘r quantity

Design | Source | Test

9. Save the changes.

For information about testing XQuery transformations, see “Testing Data Transformations” on
page 2-24.

Mapping Repeating Elements and Creating Joins

You can join data from XML files that are valid against different schemas (in this example,
PriceQuote.xsd, Avai lableQuote.xsd, and taxrate.xsd), and create an XML file that is
valid against a single schema: Quote . xsd.

This example includes the following steps:
e Step 1. Create an XQuery File
e Step 2. Add a Constraint
e Step 3. Add Data to Return Element
e Step 4. Add Function to Calculate Value of Quote
e Step 5. Add a Constraint with Multiple Conditions
e Test the XQuery
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Step 1. Create an XQuery File

In this step, we create an XQuery transformation by using the Avai IQuote.xsd,
PriceQuote.xsd, and taxrate.xsd schemas. Then, we map several priceQuote and
avai IRequest source elements to corresponding target elements.

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”

on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper

Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.

3. Choose New > XQuery Transformation.

4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations

5. Enter Join as the file name and click Next.

6. Select the following source elements and click Next:

— PriceQuote.xsd\priceQuote

— PriceQuote.xsd\taxRate

— AvailQuote.xsd\avai IRequest

7. Select Quote.xsd\quote as the target element and click Finish.

The Join.xq file is created in the XQueryTransformation/XQueryTransformations

folder

8. Create links between the following source and target elements by dragging elements from the

Source pane to the Target pane.

Source Element

Target Element

priceQuotel\customerName

quote\name

priceQuotel\shipAddress\street

quote\address

priceQuotel\shipAddress\city

quote\address

priceQuotel\shipAddress\state

quote\address
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Source Element Target Element

priceQuotel\shipAddress\zip quote\address

priceQuotel\priceRequests\priceR quote\guoteResp

equest onse

avai lRequestl quote\quoteResp
onse

The links are displayed, as shown in the following figure.

Figure 3-4 Data Transformation in Design View

% combinelata, xq % *Join.xg i =0
Source Target
= priceCuokel = quaoke
T T TE——————— I
=@ shipaddress @ address
\:]_'3 street _4..,—-—3- —E‘;‘J quokeResponse
&3 ity )i @ widgetd
&3 state - PR & unitPrice
\:Tj zip P 9 requestedCuanity
=@ priceRequests 7 7 @ filorder
=@ priceRequest -] - . @& shipDate
@ widgetid £ @& taxRate
@ price ’ @& totalcost
taxRatel - ‘
= P [T TS [——— -
@ widgetld
@ requestedduanity
@ quanityavai
6? shipDate
=@ line-items
6* line-item

Design | Source | Test

9. Save the changes.

Step 2. Add a Constraint

The priceQuote/priceRequests and avai IRequest source elements share the common
element widgetld. In this step, we add a constraint that if widgetld of the avai IRequest
schema is equal to widgetId of the priceQuote/priceRequests element, then the query must
return the target repeating element, quoteResponse.
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1. Open Join.xq in the Design view.

2. Drag the priceQuotel/priceRequests/priceRequest/widgetld element from the
Source pane and drop it on the avai IRequest1/widgetld element of the Source pane.

A connecting line appears between the two widgetld nodes in the Source pane, as shown
in the following figure.

Figure 3-5 Adding a Constraint
& x - B

Source Target

% combineData.xg

= priceCuotel
@ customertame -
=@ shipaddress

= quoke

Ay name
gy address

a7 8 ~=-{gF quoteResponse
&3 i e @ widget1d
a5 Y @ unitPrice
.c]j Fip o PR 9 requestedQuanity
=@ priceRequests " . @ Ffillorder
=@ priceRequest - - ,' @ shipDate
@ widgetid - L @ taxRate
@ price ’ @ totalcast
taxFatel - ’
= availRequest] - .

@ widgetid
@ requestedduanity
@ quanityaeesi
6? shipDate
=@ line-items
G‘ line-item

Design | Source | Test

3. Save the changes.

4. View the changes in the Source view.

The link between the two widgetld nodes is represented by a where clause within the for
loop. The where clause specifies that the for loop must return the result of the expression
only if the where clause is true. In this example, if widgetld of the avai lRequest
element is equal to widgetld of the priceRequest element, the expression returns the
XML data specified in the quoteResponse element.

Note: You can also view the where clause in the Constraints view.

The quoteResponse element is currently empty. We add content to the element in the next step.
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Step 3. Add Data to Return Element

In this step, we add data links in the quoteresponse target element.

Open Join.xq in the Design view and create links between the following source and target
elements:

Source Element Target Element

priceQuotel\priceRequests\priceR quote\quoteResponse\widgetid
equest\widgetid

priceQuotel\priceRequests\priceR quote\quoteResponse\unitprice
equest\price

avai lRequestl\requestedQuantity quote\quoteResponse\requestedQuantity

avai lRequestl\quantityAvail quote\quoteResponse\fillOrder

avai lRequestil\shipDate quote\quoteResponse\shipDate

The links between the Source and Target elements are displayed, as shown in the following
figure.
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Figure 3-6 Adding Data in the QuoteResponse Element

% combineData.xg m =0

Source
= @ priceQuotel
T T ————
=@ shipaddress
i;-[,?; skreet
@z ity e
E‘]j‘ &
17 _
e ——
=-{@) priceRequests
=@ priceRequest - G;Z shipbrate
@ widgetid - @& taxRate
@ price @ totalCost
taxF.akel
= availfkequestl -
@ widgetid -
@ requestedQuanity
@ quanityavai
6? shipDate -
=@ line-items
G-* line-item

-y address
(& quoteResponse

@ requestedquanity
@y filorder

Design | Source | Teskt

Step 4. Add Function to Calculate Value of Quote

In this step, we add a function to calculate the total value of the quote.

1. Open the Join.xq file in Source view.

2. Insert the following function declaration at any point in the source code between the
namespace declarations and the Join function call. You can, for example, insert it just before
the Join function declaration.

Listing 3-1 calculateTotalPrice Function

declare function xf:calculateTotalPrice(
$taxRate as xs:float,
$quantity as xs:float,
$price as xs:float)

as xs:float {

let $taxQuantity := ($taxRate * $quantity)
let $totalTax := ($taxQuantity * $price)
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let $costNoTax :
let $totalCost :

($quantity * $price)
($totalTax + $costNoTax)

return $totalCost

3. Switch to the Design view.

Note: Join.xqg now includes two function declarations: calculateTotalPrice and
Join. When more than one function exists in an XQuery file, the function with the
same name as the XQ file is rendered in the Design view. In this case, the Join
function is displayed in the Design view.

4. In the Target pane, select the totalCost node. Keep it selected for the next step.
5. Select the Target Expression view and select the General option.

6. Insert the following code in the General Expression pane.

xf:calculateTotalPrice($taxRatel,$availRequest/nsl:requestedQuanity,$pr
iceRequest/nsO:price)

7. Click Apply.
The expression is added to the totalCost element in the XQuery.

8. Save the changes.

The Design view shows the calculation for the totalCost target element.
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Figure 3-7 totalCost Calculation in Design View

B X T m
SOUrce Target
= priceuotel = quoke
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':‘j skrest
g7
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taxRakel -
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6 widgetTd -
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6? SHIRDIEE e
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& line-item

Design | Source | Test

Step 9. Add a Constraint with Multiple Conditions

You can create a constraint by using the Where Clause pane of the Constraints view to limit the
target repeating elements that are returned by the XQuery. At run time, the for loop in the
XQuery iterates over only those repeating elements that satisfy the where clause.

In this step, we add another condition (resulting in a complex condition) to the where clause of
the for loop to further limit the data returned by the for loop.
1. Open the join.xq file.

2. In the Design view, select the link between the avai IRequestl source element and the
quote\quoteResponse target element.

The single condition that makes up the where clause is displayed in Where Clause pane
of the Constraints view.

data($priceRequest/nsO:widgetld) = data($availRequest/nsl:widgetld)

3. Drag the avai IRequestl/requestedQuanity element from the Source pane and drop it in
the Left Hand Expression area of the Where Clause pane.

The left hand expression of the where clause is created as follows:
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data($availRequest/nsl:requestedQuanity)

Select the < operator.

Remove the text in the Right Hand Expression area of the Where Clause pane, and enter
“50”.

Note: Enter the number 50 within quotation marks (50, not 50).
From the Join Type field select the AND option.

The Join Type determines how the conditions that make up the where clause are evaluated
at run time.

Click Add. The second condition is added to the where clause of the for loop.

Save the changes.

This step completes the creation of the following where clause.

Listing 3-2 Where Clause

where (data($availRequest/nsl:widgetld) = data($priceRequest/nsO:widgetid)

and data($availRequest/nsl:requestedQuanity) < "50'")

Test the XQuery

Perform the following steps to verify that the XQuery works when both the conditions of the
where clause you created are satisfied.

1.
2.

Switch to the Test view.

In the Source Data pane of the Test view, select priceQuote in the Source Variable field,
and click the Generate Data icon.

Note the value of the widgetld element in the test XML data.

<nsO:widgetld>value</nsO:widgetld>

In the Source Data pane, select avai IRequest in the Source Variable field, and click the
Generate Data icon.
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5. Edit the value the value of the widgetld element in the test XML data to match the value
displayed in the priceQuote test XML data.

<nsO:widgetld>value</nsO:widgetld>
6. Locate the requestedQuanity element and edit the value to a number less than 50.

For example: <ns0: requestedQuanity>25</ns0: requestedQuanity>

7. Inthe Result Data pane, click the Test XQuery icon and view the results of the XQuery.

Creating Unions

In this example, we use the Union option in the Constraints view to construct an XQuery that
maps data of the same type into larger sets of data.

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”
on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.
3. Choose New > XQuery Transformation.

4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations.

5. Enter union as the file name and click Next.

6. Inthe Source Types dialog box, select PO.xsd\purchase-order twice, and then click Next.

Note: To add an element more than once, you must change the parameter name.

7. Select Order.xsd\order as the target type and then click Finish.

The union.xq file is created.
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8. Create links between the following source and target elements:

Source Element Target Element

purchase-orderl\line-items\line-item order\items\item

purchase-order2\line-items\line-item order\items\item

The following figure shows how the links appear in the Design view.

Figure 3-8 Creating a Union

Saurce Target
= purchase_orderl = order
=@ line-items =@ items
= 6* [T — | =SS S S PN S O e 6%‘ ikem
9 part-no 2™ G park-number
9 quantity Pid G quantity-number
= purchase_order2 =
=@ line-items - ’
= 6* line-item - =
e part-no
e quantiky

Design | Source | Test

9. Select the link between the $purchase-orderl/line-items/line-item source element
and the order/items/item target element.

10. In the Constraint Type pane of the Constraints view, select Union.

11. Create links between the following source and target elements:

Source Element Target Element

purchase-orderl\line-items\part-no order\items\item\part-number

purchase-orderl\line-items\quantity order\items\item\quantity-number

Note: When you want to create links between source and target elements of the same name,
you can use the Induce Map option instead of creating the links manually. For more
information, see “Right-Click Menu Options” on page 2-27.
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Since the two structural links have a union constraint, a set of implied data links between
the second set of subelements is generated as shown in Figure 3-9. The gray lines represent
implied links that were created because Union was selected as the constraint type.

Figure 3-9 Creating Implied Links

Saurce Target
= @ purchase_orderi = @ order
=@ line-items =@ items
=@ line-item EI--G%;E item

@ part-no - @ part-number
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=@ line-items -
2@ line-itam
@ part-no -
@ quantity —

Design | Source | Teskt

12. Save the changes.

For information about testing XQuery transformations, see “Testing Data Transformations” on
page 2-24.
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Creating Repeating-Source to Nonrepeating-Target

Transformations

In this example, we map a repeating source XML element to a nonrepeating target XML element.

The following figure depicts the transformations that we create in this example.

Figure 3-10 Repeating-Source—to—Nonrepeating Target Transformation

During run time, the first generated XQuery for loop iterates
through the list of source repeating elements of type date.

If the constraint (date/tyoe = *BILLINGY) is true, then the
contents of the date/walue element is returned as the contents
of the target FODate/billing~-date alemeant.

Source XML Data
(valid to the XML Schema in
Dates.xsd)

Result XML Data

<7aml version="1.0" encoding="UTF-8"7>
=dates xmins="hitp:'www.acme.crg/Dates™
<date>
<type>DELIVERY </type>
=value=03/31/2004</value=>
</date>
=date=

{valid to the XML Schema in PODate.xsd)

<Paml version="1.0" encoding="UTF-8"%=

<pod:PODate xmins: pod="http:/fwww acme.org/PODate"
# <pod:billing-date>03/29/2004</pod billing-date=>

I——b <pod:delivery-date=03/31/2004</pod: delivery-date=

</pod:PODate>

<typa=BILLIN G=itypa=
<value=03/29/2004<value>
</date=>
=/dates>

During run time, the second generated XQuery o loop iterates through the list

of source repeating elaments of type date,

If the constraint ([date/type = DELIVERY)Iis true, then the contents of the
date/wvalue elament is returnad as the contants of the target Fobate/
delivery-date element.

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”

on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.

3. Choose New > XQuery Transformation.

4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations.

5. Enter repeatToNonRepeat as the file name and click Next.
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6. Select Dates.xsd\dates as the source schema and click Next.

7. Select PODate . xsd\PODate as the target schema and click Finish.

The repeatToNonRepeat.xq file is created and displayed, as shown in the following
figure.

Figure 3-11 Repeating-Source—to—Nonrepeating-Target Data Transformation

*g tepeatTolonRepeat.xq X =0
Source Target
= (2] datest = (2] Pobate
= 6" date @ biling-date
@ tvpe @ delivery-date
@ value
Design | Saurce | Test

8. Create a link between the dates1/date repeating element in the Source pane and the
PODate/bil ling-date element in the Target pane.

Keep this link selected for the next step.
9. Select the Constraints view.

10. Drag the dates1/date/type element from the Source pane to the Left Hand Expression
area of the Where Clause pane in the Constraints view.

11. Select the = operator.

12. In the Right Hand Expression area, enter "BILLING" (including the quotation marks), and
click Add.

13. Create a link between the dates1/date/value element in the Source pane and the
PODate/bil ling-date element in the Target pane.

The constraint that you created in the preceding steps specifies that the value of the
dates1/date/type element in an XML document must be compared with the value
"BILLING".

At run time, if the value of the dates1/date/type element is "BILLING", the XQuery
returns the value of dates1/date/value as the value of bil ling-date.

14. Create a link between the dates1/date repeating element in the Source pane and
PODate/delivery-date element in the Target pane.

Keep this link selected for the next step.
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16.
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Drag the dates1/date/type element from the Source pane to the Left Hand Expression
area of the Where Clause pane in the Constraints view.

Select the = operator.

In the Right Hand Expression area, enter "'DELIVERY"" (including the quotation marks), and
click Add.

Create a link between the dates1/date/value repeating element in the Source pane and
PODate/del ivery-date element in the Target pane.

The constraint created in the preceding steps specifies that the value of the
datesl/date/type element in an XML document must be compared to the value
"DELIVERY".

At run time, if the value of the dates1/date/type element is "DELIVERY", the XQuery
returns the value of dates1/date/value as the value of delivery-date.

Figure 3-12 Repeating-Source—to—Nonrepeating-Target Data Transformation

19.

B &3 -0
Source Target
= dates1 = PODate
= 6" Y —— W--==azz----—=-= @ biling-date
@ tvpe == & delivery-date
9 IV M ——

Design | Source | Test

Save the changes.

For information about testing XQuery files, see “Testing Data Transformations” on page 2-24.
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Creating Nonrepeating-Source to Repeating-Target
Transformation

In this example, we map a nonrepeating source element to a repeating target element.

The following figure depicts the transformations that we create in this example.

Figure 3-13 Nonrepeating-Source—to—Repeating-Target Transformation

During run time, the query executes the following actions:

1) If the name of the source input element is equal to "oilling-date”,
then the string: EILLIHS is retumed as the data for the valus node.

2) The value of the source XML element o111 1ing-dats becames the
value of the target tvoe XML element.
\ Result XML Data
(valid to the XML Schema in Dates.xsd)
Source XML Data
['d'a"d to the XML Schema in PODate.xsd <?xml version="1.0" encoding="UTF-8"7=
<dat:dates xmins:dat="hitp:/fwww_acme org/Dates™
<?xml version="1.0" encoding="UTF-8"?> =dal:date>
<pod:PODate  xmins:pod="http://www.acme.org/PODate">| <dat:type=BILLING</dat:type=
<pod:billing-date>3/30/2004</pod: billing-date> —— p <datvalue=3730/2004</datvalua=
<pod:delivery-date=>4/04/2004</pod:delivery-date> 4 =/dat:date>
</pod:PODate> <dat:date>
= <dat'typa>DELIVERY </dat:typa=>
=datvalue>4/04/2004</dat:value=
</dat:date>
</dat:dates=>

3) If the name of the source input element is equal to “delivesy-date”,
then the string: b2LIvEEY is returned as the data for the vz e noda.

4) The value of the source XML element dolivery-date becomeas the
value of the target tyoe XML element.

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”
on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.
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3. Choose New > XQuery Transformation.

4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations

o

Enter nonRepeatToRepeat as the file name and click Next.

Select PODate . xsd\PODate as the source schema and click Next.

N o

Select Dates.xsd\dates as the target schema and click Finish.
8. The nonRepeatToRepeat.xq file is created and displayed in the Design view.

9. Create links between the following source and target elements:

Source Pane Target Pane

pODatel/billing-date dates/date

pODatel/delivery-date dates/date

The following listing shows the XQuery code that is generated.

Listing 3-3 XQuery Code

<nsl:dates>

{
for $PODate in $PODatel/nsO:billing-date union $PODatel/nsO:delivery-date
return
<nsl:date/>

}

</nsl:dates>

At run time, the for loop is executed twice. In the first execution, the iteration variable
$PODate is equal to the first element in the union $PODatel/nsO:billing-date; in the
second execution, $PODate is equal to $PODatel/ns0:delivery-date.
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The XQuery returns two empty XML elements with the tag <ns1:date/>.

In the following steps, we add the XQuery code to return the billing and delivery dates to
the query.

10. Switch to the Design view.

11. Create a link between the poDatel/bi Il ing-date source element and the dates/value
target element in the Target pane.

Two data links are created, as shown in the following figure.

Figure 3-14 Creating a Union for Structural Links

6 X -0
Source Target
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The following structural links were joined when we created the link from
pODatel/billing-date to dates/value.

— pODatel/billing-date t0 dates/date
— pODatel/delivery-date t0 dates/date

A second data link between the pODatel/del ivery-date element and dates/value
element was created automatically.

12. Create a link between the pODatel1/bi I ling-date source element and the dates/type
target element.

Two data links are created.

Keep the pODatel/billing-date t0 dates/type link selected for the next step.
13. Select the Target Expression view.
14. Select the If Then Else option.

The following XQuery if-then-else expression is added to the link:
if (fn:boolean(“true’)) then
data($PODate)
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16.

17.

18.

19.

20.
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else

O
In this step, we add a condition to the iF section of the if-then-else expression.
a. Select If Condition in the Expression Structure area.
The Edit If Condition pane is displayed.
b. Inthe Expression Functions view, expand Node Functions.

c. Drag the 1ocal-name function to the Left Hand Expression area of the Edit If
Condition pane. Leave the $node-var argument in the function selected.

d. Select the Expression Variables view.

e. Drag the PODate structural link variable to the $node-var argument of the local-name
function in the Left Hand Expression area of the Edit If Condition pane.

f. Select the = operator.

g. Inthe Right Hand Expression area of the Edit If Condition pane, enter
“billing-date” (including quotation marks), and then click Add.

The following condition is added to the i f section of the if-then-else expression:
fn:local-name($P0ODate)=billing-date”
Select Then Expression in the Expression Structure area.

The Edit Then Condition pane is displayed.

Replace the existing text with “BILLING” (including quotation marks), and then click the
Apply icon.

Select Else Expression in the Expression Structure area.
The Edit Else Condition pane is displayed.

Replace the existing text with “DELI1VERY” (including quotation marks), and then click the
Apply icon.

Select If Then Else in the Expression Structure area.
The following XQuery code is displayed in the Expression Structure pane.

ifT (fn:local-name($PODate) = "billing-date') then
“BILLING”
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else
“DELIVERY”
21. Save the changes.
For information about testing XQuery files, see “Testing Data Transformations” on page 2-24.

Creating Nested If-Then-Else Expressions

3-24

In this example, we create an XQuery transformation that calculates price based on a widget ID
and tax rate for a state. We create an if-then-else expression for the following logic:

e If widget ID is from 0 to 200, the price is $10.00
e Else if the widget ID is from 201 to 400, price is $20.00
e Else If the widget ID is from 401 to 600, price is $30.00

This example includes the following steps:
e Step 1. Create the XQuery Transformation
e Step 2. Create the First “If” Condition
e Step 3. Create the First Nested If-Then-Else Condition

e Step 4. Create the Second Nested If-Then-Else Condition

Step 1. Create the XQuery Transformation

In this step, we create an XQuery transformation by using the PurchaseAgree . xsd and
Supplier.xsd schemas.

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper
on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.

3. Choose New > XQuery Transformation.
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4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations.

5. Enter ifthenelse as the file name and click Next.
6. Select Supplier.xsd\Supplier as the source type and click Next.

7. Select PurchaseAgree.xsd\PurchaseOrder as the target type and click Finish.

The ifThenElse.xq file is created.

8. Create links between the following source and target elements.

Source Element Target Element

supplierl/products/product PurchaseOrder/products/product

supplierl/products/product/price PurchaseOrder/products/product/price

The links are displayed, as shown in the following figure.

Figure 3-15 XQuery Transformation for If-Then-Else Example

"‘:{.; ifthenelse.xq X =8
Source Target
= (2] supplier1 = [2) Purchaseorder
@ name @ orderld
@ id — = 3| =g products
=@ address =@ product
&3 street @ partid
&3 ity @ quantity
g; o = = . A | FA—— 9: price
&5 zip
=@ products
= 6“ L T e —|
@ widgetld
e [ Re—
[Design | Source | Test

Step 2. Create the First “If” Condition

In this step, we create an 1 expression to specify that if the widget ID is from 0 to 200, then the

price is $10.00.

Transforming Data Using the XQuery Mapper
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1. Select the link between the supplieri/products/product/price source element and the
PurchaseOrder/products/product/price target element.

2. Select the Target Expression view.
3. Select the If Then Else expression type.

4. Inthe Expression Structure pane, select If Condition.

The Edit If Condition pane is displayed.

5. Drag the supplierl\products\product\widgetID element from the Source pane and
drop it in the Left Hand Expression pane.

Select the >= operator.
In the Right Hand Expression pane, enter 0" (including quotation marks), and click Add.

Select the <= operator.

© © N o

In the Right Hand Expression pane, enter <200,
10. Click the arrow next to the Update button and select Add.

11. In the Expression Structure pane, select Then Condition.

The Edit Then Condition pane is displayed.
12. In the Edit Then Expression pane, delete the existing data and enter “$10.00.
13. Click the Apply icon.

14. In the Expression Structure pane, select If Then Else.

The if-then expression is displayed as shown in the following listing.

Listing 3-4 1f-Then Expression

if ((xs:string(data($product/nsO:widgetld)) >= 0"
and xs:string(data($product/nsO:widgetld)) <= '"200')) then

"$10.00"

else

O
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Step 3. Create the First Nested If-Then-Else Condition

In this step, we create an 1 expression to specify that if the widget ID is from 201 to 400, then
the price is $20.00. To accomplish this, we insert a nested if-then-else inside the Else expression
we created in the previous step.

1. Inthe Expression Structure pane, right-click Else Expression, and select Insert Nested
If-Then-Else.

2. Inthe nested If-Then-Else expression, select If Condition.

3. From the Source pane, drag the widget1D element and drop it in the Left Hand Expression
pane.

4. Select the >= operator.

5. Inthe Right Hand Expression pane, enter <201 (including quotation marks), and click
Add.

Select the <= operator.
In the Right Hand Expression pane, enter <400,

Click the arrow next to the Update button and select Add.

© © N o

In the Expression Structure pane, select Then Expression.
10. In the Edit Then Expression pane, enter “$20.00”.
11. Click the Apply icon.

12. In the Expression Structure pane, select If Then Else.

The if-then-else expression appears as shown in the following listing.

Listing 3-5 Nested If-Then-Else Expression

if ((xs:string(data($product/nsO:widgetld)) >= "0"
and xs:string(data($product/nsO:widgetld)) <= "200')) then

"$10.00"
else

ifT ((xs:string(data($product/nsO:widgetld)) >= "201"
and xs:string(data($product/nsO:widgetld)) <= ""400')) then
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"'$20.00""

else

O

Step 4. Create the Second Nested If-Then-Else Condition

In this step, we create an 1 expression to specify that if the widget ID is from 401 to 600, then
the price is $30.00. To accomplish this, we insert a nested if-then-else expression within the Else
expression that we created in the previous step.

1.

o a0 ~ w N

8.
9.

In the Expression Structure pane, select the Else clause of the nested if-then-else expression
created in “Step 3. Create the First Nested If-Then-Else Condition” on page 3-27

Right-click and select Insert Nested If-Then-Else.

Select the I'F condition in the nested if-then-else expression that we just created.

From the Source pane, drag widgetlD and drop it in the Left Hand Expression pane.
Select the >= operator.

In the Right Hand Expression pane, enter ““401”, and then click Add.

Select the <= operator.

In the Right Hand Expression pane, enter “600”, and then click Add.

In the Expression Structure pane, select Then Expression.

10. In the Edit Then Expression pane, enter “$30.00”, and click the Apply icon.

11. In the Expression Structure pane, select If Then Else.

The nested if-then-else expression is as shown in the following listing.

Listing 3-6 Nested If-Then-Else Expression

it ((xs:string(data($product/nsO:widgetld)) >= 0"

and xs:string(data($product/nsO:widgetld)) <= "200')) then
""$10.00""
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else

if ((xs:string(data($product/nsO:widgetld)) >= ""201"
and xs:string(data($product/nsO:widgetld)) <= "400")) then

*'$20.00""
else

if ((xs:string(data($product/nsO:widgetld)) >= "401"
and xs:string(data($product/nsO:widgetld)) <= "600")) then

"'$30.00"
else

O

For information about testing XQuery files, see “Testing Data Transformations” on page 2-24.

Creating FLWOR Expressions

In this example, we use a For-Let-Where-Order By-Return expression to extract widget IDs from
a quotation, for items with a total value more than 2000.

1. Create the XQuery file.

a. Launch WorkSpace Studio and open the sample project.

 For information about launching WorkSpace Studio, see “Launching XQuery
Mapper” on page 2-2.

» For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

b. Right-click the XQuery Transformations folder.
c. Choose New > XQuery Transformation.

d. \erify the name of the parent folder.

e. Enter flwor as the file name and click Next.

f. Select Quote.xsd\quote as the source type and click Next.
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g. Select Quote.xsd\quote as the target type and click Finish.

The Flwor.xq file is created, as shown in the following figure.

Figure 3-16 XQuery Example - FLWOR Expression

2. Create the FLWOR expression.

a. Click on the quote\quoteResponse repeating element in the target pane.
b.

=B
Source
= (2] quatel
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@ widgetid @ widgetid
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In the Target Expression view, select the For...Return option.

The view changes, as shown in the following figure.

Figure 3-17 FLWOR Expression

C.

Leturn
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&

Expression Structure

.| Return Expression

Expression Type: () General (OIf Then Else &3 For,. Return () Typeswitch

For-Let-Where-OrderBy-Return Expression

\iew Faor-Let-Where-OrderBy-Return Expression

for §for—varl in ()
let flet—varz := ()
return

0

In the Expression Structure pane, select For Clause.
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Creating FLWOR Expressions

The Edit For Clause pane is displayed.
In the Variable field, replace the existing value with quote.
In the Expression Variables view, expand the quotel node.

Drag quotel/quoteresponse from the Expression Variables view, and drop it in the
Single Expression field.

Click Update.

3. Design the Let clause.

Note: For this example, the let clause is not essential. It is used here merely to illustrate how

f.

to design it in XQuery Mapper.

In the Expression Structure pane, select Let Clause.

The Edit Let Clause pane is displayed.

In the Variable field, replace the existing value with widget.
Select the Expression Variables view.

Expand the quote node within the Structural Link folder.

Drag quote/widgetID from the Expression Variables view and drop it in the Single
Expression field.

Click Update.

4. Design the Where clause.

a.

In the Expression Structure pane, right-click For...Return and select Insert Where
Clause.

Select Where Clause.

The Edit Where Condition pane is displayed.

Drag quote/totalCost from the Structural Link folder of the Expression Variables
view, and drop it in the Left Hand Expression field.

Select the > operator.
Enter 2000 in the Right Hand Expression area.
Click Add.
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5. Design the Order By clause.

a. Inthe Expression Structure pane, right-click For...Return, and select Insert Order By
Clause.

b. Select Order By Clause.
The Edit Order By Clause pane is displayed.

c. Inthe Sort Order field, select ascending.

d. Inthe Single Expression field, enter $widget, which is the name of the variable that is
declared in the Iet clause.

e. Click Update.
6. Design the Return expression.
a. Inthe Expression Structure pane, select Return Expression.
b. Inthe Expression Variables view, expand the Structural Link folder.

c. Drag quote from the Expression Variables view, and drop it in the Single Expression
field.

d. Click the Apply icon.

7. Save the changes.

You can view the source code of the FLWOR expression by selecting For...Return in the
Expression Structure pane. The code is as shown in the following listing.

Listing 3-7 Code for FLWOR Expression

for $quote in ($quotel/quoteResponse)
let $widget := ($quote/widgetlid)
where $quote/totalCost > 2000

order by $widget ascending

return

$quote
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For information about testing XQuery transformations, see “Testing Data Transformations” on
page 2-24.

Using Recursive Schemas

In this example, we create a data transformation with schemas that have recursive elements.

An element in a schema is considered recursive when it contains a child element of the same type
as the parent, as shown in the example in Listing 3-8. In this example, the product element is a
recursive element because it is of type productType, and productType contains a
child-product element which is also of type productType (productType refers to itself).

Listing 3-8 Example of Recursive Schema

<?xml version="1.0"?>

<xs:schema xmlns:xs="http://www.w3.0rg/2001/XMLSchema™
targetNamespace="http://www.acme.org/Product”
xmlns="http://www.acme.org/Product” elementformDefault="qualified”
attributeFormbefault="unqualified”>

<xs:complexType name=""productType’>
<xs:sequence>

<xs:element name="part-description” minOccurs="0"
maxOccurs="unbounded” type="xs:string” />

<xs:element name="child-product” minOccurs="0"
maxOccurs="unbounded” type="producttype” />

</Xs:sequence>
</xs:complexType>
<xs:element name=""product” type="productType”>
</xs:element>

</xs:schema>

Perform the following steps to create a transformation with recursive schemas:
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Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”
on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

Right-click the XQuery Transformations folder.

. Choose New > XQuery Transformation.

. Verify the name of the parent folder. For this example, the parent folder is /XQuery

Transformation/XQueryTransformations

Enter recursive as the file name and click Next.

. Select SupplierAcme.xsd\supplier_acme as the source schema and click Next.

. Select Product.xsd\product as the target schema and click Finish.

The recursive.xq file is created.

. Create links between the following source and target elements:

Source Element Target Element

supplier_acmel\part-description-00100 product\part-description

supplier_acmel\part-description-00101 product\child-product\part-descr
iption

supplier_acmel\part-description-00101 product\child-product\child-prod
uct\part-description

The following figure shows the links from the source elements to the recursive chi ld-product
target elements.
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Figure 3-18 Mapping Recursive Elements

B X T m
Source Target

= supplier_acmel = product
part-description- T | A part-description
@ part-description-00100 &5 part-descripti
part-description- = Child-produc
t-description-00101 5 child-product
part-description- S e | A part-description
t-d iption-00102 ? t-d ipki
= 6* child-product
....................................... 6? part-description
+ G’F child-product

Design | Source | Teskt

9. Save the changes.
For information about testing XQuery files, see “Testing Data Transformations” on page 2-24.

Grouping Data by Key Fields
You can use the Group by Key Fields feature to group data based on one or more key values.

Note: The Group-By feature is not supported graphically in XQuery Mapper and there is no
representation of the XQuery in the Design view. You must write the Group-By
expression in the Source view.

The following listing shows the XML document that we use as input in this example.

Listing 3-9 Example Input XML Document

<input-warehouse-inventory xmlns="http://www.creditpo.org/repkeyin'>

<input-line-item>
<input-warehouse-id>Warehousel</input-warehouse-id>
<input-location-desc>Locationl</input-location-desc>
<input-part-no>1</input-part-no>
<input-quantity>10</input-quantity>

</input-line-item>

<input-line-item>

<input-warehouse-id>Warehouse2</input-warehouse-id>
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<input-location-desc>Location2</input-location-desc>
<input-part-no>2</input-part-no>
<input-quantity>20</input-quantity>

</input-line-item>

<input-line-item>
<input-warehouse-id>Warehousel</input-warehouse-id>
<input-location-desc>Locationl</input-location-desc>
<input-part-no>3</input-part-no>
<input-quantity>30</input-quantity>

</input-line-item>

</input-warehouse-inventory>

In this example, we use the input-warehouse-id and input-location-desc elements as the
key fields to group data in the output document:

The first and third instances of the input-1ine-item repeating element contain the same values
for the input-warehouse-id and input-location-desc elements: Wwarehousel and
Locationl respectively.

The goal of this example is to write an XQuery that groups the first and third instances of the line
items, by using the Wwarehouse1 and Locationl keys in the output document, as shown in
Listing 3-10.

Listing 3-10 Example Output XML Document

<nsO:output-inventory xmlns:nsO="http://www.creditpo.org/repkeyout';>
<ns0:output-warehouse-inventory>
<ns0:output-warehouse-id>Warehousel</ns0:output-warehouse-id>
<ns0:output-location-desc>Locationl</ns0:output-location-desc>
<nsO:output-line-item>

<ns0:output-part-no>1</ns0:output-part-no>
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<nsO:output-quantity>10</ns0:output-quantity>
</nsO:output-line-item>
<nsO:output-line-item>
<ns0:output-part-no>3</ns0O:output-part-no>
<ns0:output-quantity>30</ns0:output-quantity>
</nsO:output-line-item>
</ns0:output-warehouse-inventory>
<nsO:output-warehouse-inventory>
<ns0:output-warehouse-id>Warehouse2</ns0:output-warehouse-id>
<ns0:output-location-desc>Location2</ns0:output-location-desc>
<nsO:output-line-item>
<ns0:output-part-no>2</ns0O:output-part-no>
<nsO:output-quantity>20</ns0:output-quantity>
</nsO:output-line-item>
</ns0:output-warehouse-inventory>

</nsO:output-inventory>

Perform the following steps to create a Group-By expression:

1. Launch WorkSpace Studio and open the sample project.

— For information about launching WorkSpace Studio, see “Launching XQuery Mapper”
on page 2-2.

— For information about opening the sample project, see “Creating the XQuery Mapper
Sample Project” on page 2-2.

2. Right-click the XQuery Transformations folder.
3. Choose New > XQuery Transformation.

4. Verify the name of the parent folder. For this example, the parent folder is /XQuery
Transformation/XQueryTransformations
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5. Enter groupby as the file name and click Next.

6. Select regroupKeyFldIn.xsd\input-warehouse-inventory as the source schema, and
click Next.

7. Select regroupKeyFldout.xsd\output-inventory as the target schema, and click
Finish.

The groupby . xq file is created.
8. Select the Source view.

9. Replace the existing code with the code in the following listing.

Listing 3-11 XQuery Code for Group-By Expression

declare namespace nsO = "http://www.creditpo.org/repkeyin’;
declare namespace nsl = "http://www.creditpo.org/repkeyout™;

declare function Regrouping($input-warehouse-inventory as
element(nsO: input-warehouse-inventory))

as element(nsl:output-inventory) {
<nsl:output-inventory>

{
for $input-line-item in $input-warehouse-inventory/nsO:input-line-item
group $input-line-item as $group by
$input-line-item/ns0: input-warehouse-id as $keyO,
$input-line-item/nsO: input-location-desc as $keyl
return
<nsl:output-warehouse-inventory>
<nsl:output-warehouse-id>{ data($key0) }</nsl:output-warehouse-id>
<nsl:output-location-desc>{ data($keyl) }</nsl:output-location-desc>
{
for $group0 in $group return

<nsl:output-line-item>

<nsl:output-part-no>{xs:byte(data($group0/ns0: input-part-no))}
</nsl:output-part-no>
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<nsl:output-quantity>{xs:byte
(data($group0/ns0: input-quantity)) }

</nsl:output-quantity>
</nsl:output-line-item>
}
</nsl:output-warehouse-inventory>
}
</nsl:output-inventory>
¥

declare variable $input-warehouse-inventory as
element(nsO: input-warehouse-inventory) external;

Regrouping($input-warehouse-inventory)

10. Save the changes.
The changes are not visible in the Design view.
11. With the groupby . xq file open in the Source view, select the Test view.

12. In the Source Data pane, click the Import icon.

13. Import the Regrouping.xml file provided in the sample project (from the
XML Transformation/XMmL/ folder).

14. In the Result Data pane, select the Test XQuery icon.
The result of the XQuery is displayed, as shown in Listing 3-10.
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This section describes the procedure for upgrading inline XQuery code and stand alone XQuery
files from XQuery 2002 to 2004.

This section contains the following topics:
e Upgrading Inline XQuery Code
e Upgrading XQuery Files

Upgrading Inline XQuery Code

When you upgrade a WLI 8.x project to 10.2, by default, inline XQuery 2002 code (embedded in
JPD files) is not converted to XQuery 2004. You can convert the inline XQuery code to XQuery
2004, by performing the following steps in the Source Upgrade screen of the upgrade wizard.
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Figure A-1 Source Upgrade Screen of the Upgrade Wizard
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1. Expand JPD Document Upgrader options.
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2. Select the Upgrade XQ2002 to XQ2004 check box, as shown in the following figure.
Figure A-2 Upgrade XQ2002 to XQ2004
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3. Continue with the application upgrade process.

When the upgrade process is completed, XQuery 2002-compliant code that is embedded in
JPD files (inline XQuery code) is converted to XQuery 2004.
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Upgrading XQuery Files

XQuery 2002-compliant XQuery files (unlike inline XQuery code) are not converted
automatically to XQuery 2004 during the application upgrade process.

You can upgrade XQuery 2002-compliant XQuery files to XQuery 2004 by right-clicking the
XQuery file in the Navigator view in Workshop and choosing Upgrade to XQuery 2004.
However, the following XQuery constructs and functions are not converted to XQuery 2004:

e Constructs for which the syntax has changed in XQuery 2004:

Table A-1 Constructs For Which the Syntax Has Changed in XQuery 2004

XQuery 2002 XQuery 2004 Note

precedes << In some cases, merely changing the
syntax might not give correct results.

follows >>

add-timezone-to-dat
eTime

fn:adjust-dateTime-
to-timezone

remove-timezone-fro
m-dateTime

fn:adjust-dateTime-
to-timezone

The syntax and parameter type have
changed. In the XQuery 2004 syntax,
the operation is addition regardless of
the sign of the parameter. In XQuery
2004, the operation depends on the sign
of the parameter.

document() fn:docQ The parameter type and return type
might be different.
foreach for $i in ... There is no direct replacement for

Foreach. The construct must be
rewritten by using a for loop.

some $x in (1, 2,
3), xs:integer $y
in (2, 3, 4)

some $x in
(1,2,3),%y in
(2,3,4)

every $x in (1, 2,
3), xs:integer $y
in (2, 3, 4)

every $x in
(1,2,3), 3y in
2,3.4)

Existence of the optional type
declaration makes it difficult to reliably
convert this construct.
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e Functions for which the semantics have changed in XQuery 2004

Table A-2 Functions For Which Parameter Types and Order Have Changed in XQuery 2004

XQuery 2002 XQuery 2004
xf:resolve-uri(anyURl $base, fn:resolve-uri($relative as
anyURI $relative) xs:string?, $base as xs:string)

xf:distinct-values(item* $srcval) fn:distinct-values ($arg as
= item* xdt:anyAtomicType*) as
xdt:anyAtomicType*

e Constructs for which the casting rule has changed: eq, ne, It, gt, le, and ge.

e Functions for which the return type has changed in XQuery 2004
— Most time/date-related functions and operators

— Queries containing sortby
— generic-divide
— div

— expanded-QName
— namespaces

— QName

— node-name

— namespace-uri
— subsequence

— integer-divide
— round

— name

e Function not supported in XQuery 2004: jul ianDay-from-date

During the upgrade process, XQuery 2002 constructs and functions that are not supported by
XQuery 2004 are flagged with comment entries indicated by “: Warning :” in the code. In
addition, a warning message is displayed during the upgrade process, informing you that
unsupported constructs and functions were encountered.
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Figure A-3 Warning Message: Unsupported XQuery 2002 Constructs

W Conversion Failed

) One or more XQuery 2002 constructs could not be upgraded.
Look for (: Warning :) comments in the XQuery source,

After the upgrade process, you can identify the constructs and functions that are not upgraded to
XQuery 2004 by looking for the “: Warning :” comments. You must then manually change the
unsupported constructs and functions to make them comply with the XQuery 2004 standard.
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