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Introduction 

Introduction 

About This Manual 
This document describes the process for installing BEA WebLogic Mobility Server™ version 
3.5. 

Please read this document before commencing installation to ensure you comply with the 
installation pre-requisites and have access to relevant installation configuration information. 

Note: The WebLogic Mobility Server installer also installs the Device Repository that WebLogic 
Mobility Server uses to obtain device profile information 

Intended Audience  
It is recommended that your IT department, database/development team or a technical consultant 
perform the tasks outlined in this document. 

Begin by reading the section below, which explains how to use the guide. 

Using This Guide 
The document is divided into five chapters: 

1. The “1—Perform Pre-Installation Task” chapter explains how to configure the Java path.  

2. The “2—Install WebLogic Mobility Server 3.5” chapter describes the WebLogic Mobility 
Server installation process and is split into two sections: “Install WebLogic Mobility Server 
on MS Windows 2000” and “Install WebLogic Mobility Server on Sun Solaris, RedHat 
Linux and HP-UX”. Complete the steps in the section relevant to your operating system.   

3. Complete the steps in chapter “3—Additional Configuration: Mobility Plugin for BEA 
Workshop for WebLogic Platform 9.1 Installations” if you installed WebLogic Mobility 
Server on BEA WebLogic Platform 9.X, or opted to install the Mobility Plugin for BEA 
Workshop while completing the steps described in the installation chapter.  

4. Complete the steps in chapter “5—Additional Configuration: Mobility Extension for BEA 
WebLogic Workshop 8.1 Installations” if you installed WebLogic Mobility Server on BEA 
WebLogic 8.1, or opted to install the Mobility Extension for BEA Workshop while 
completing the steps described in the installation chapter 

See the “Next Steps” chapter for information on how to proceed once you have installed 
WebLogic Mobility Server and performed any necessary configuration.  

The Appendices chapter explains how to update the WebLogic Mobility Server install location 
with BEA WebLogic Workshop and describes the Mobility Framework for WebLogic Portal 9.2. 

Notes:  

• The term “Mobility Extension for BEA Workshop” used in the document refers to both the 
Mobility Extension for BEA WebLogic Workshop 8.1 and the Mobility Plugin for BEA 
Workshop for WebLogic Platform 9.X 

• The term  <WLMS_install_directory> refers to either 
<BEA_install_directory>\weblogic81\mobility or 
<BEA_install_directory>\weblogic92\mobility depending on your installation 
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1—Perform Pre-Installation Task 

Configure the Java Path 
Before you install the product, you must ensure that the search path contains an entry pointing to 
an executable Java binary file, and that the “JAVA_HOME” environment variable points to the 
directory containing a full JDK. For instructions on how to do this, see either the “Configure the 
Java path on MS Windows 2000” or the “Configure the Java path on Sun Solaris, RedHat Linux 
and HP-UX” section below, according to your operating system. 

Configure the Java path on MS Windows 2000 
The example used here assumes that Java is installed at C:\jdk1.4.2_05. 

1. Choose Start → Settings → Control Panel. In the Control Panel, double-click on the 
System icon to launch the System Properties dialog.  

2. Click the Advanced tab and click Environment Variables.  

3. Modify either the “User variables” or the “System variables” as required. Firstly, verify that 
your system is not pre-configured by inspecting the “JAVA_HOME” and “Path” settings to 
ensure that your chosen JDK is not mentioned. Then follow these steps:  

• Create or edit the “JAVA_HOME” entry, setting it to “C:\jdk1.4.2_05” 

• Edit the “Path” entry by adding “C:\jdk1.4.2_05\bin;” to the beginning of this entry 

Note: To edit a variable, select the variable in the User variables/System variables section 
and click Edit. The “Edit System Variable” dialog is displayed. Edit the value in the 
Variable value field by clicking in the field and placing the cursor at the start of the entry, 
and then entering “C:\jdk1.4.2_05\bin;” BEFORE the entry. Click OK. Click OK again. 

4. Now, to report your Java version, launch a command window and execute: 

• java  –version 

Configure the Java path on Sun Solaris, RedHat Linux and HP-UX 
The example used here assumes that Java is installed at /opt/jdk1.4.2_05. 

1. To ensure that the “Path” and “JAVA_HOME” environment variables do not already point to 
your JDK, launch a command prompt and execute: 

• env  

2. Then follow these steps: 

For bash and other sh-compatible shells, execute the following commands:  

• JAVA_HOME=/opt/jdk1.4.2_05 

• export JAVA_HOME 

• PATH=$JAVA_HOME/bin:$PATH 

• export PATH 

For csh-compatible shells, execute the following commands:  

• setenv JAVA_HOME  /opt/jdk1.4.2_05 
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• set path=($JAVA_HOME/bin  $path) 

3. Now, to report your Java version, execute: 

• java  –version 

Note: These settings only remain valid for the duration of this command window.
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2—Install WebLogic Mobility Server 3.5 
This chapter describes the installation of WebLogic Mobility Server 3.5 and is split into two 
sections: “Install WebLogic Mobility Server on MS Windows 2000” and “Install WebLogic 
Mobility Server on Sun Solaris, RedHat Linux and HP-UX”. Complete the steps in the section 
relevant to your operating system 

Install WebLogic Mobility Server on MS Windows 2000 
This section explains the installation procedure for installing WebLogic Mobility Server on MS 
Windows 2000. 

Introduction 
The mobilityServer35_win.exe installation application is used to install WebLogic Mobility 
Server on MS Windows 2000. 

License  
A BEA WebLogic Mobility Server license file must be integrated into the bea.license file of your 
WebLogic Server. 

Your sales representative should provide this file to you along with the product CDs.  Please 
contact your sales representative if you have not yet received your license file. 

Once you have updated your license, you will be able to develop and test mobile-device ready 
content. If you have a developer or evaluation license, the software installer will install an 
evaluation version of the Device Repository enabling testing on a number of popular device 
emulators as well as a number of popular mobile and PDA devices.  A production license must be 
present to install and use the full Device Repository. Note: An invalid license will result in 
HTML being delivered. 

Please contact a sales representative if you wish to extend your evaluation or developer license or 
upgrade to a production license. 

Installation Prerequisites 
This installation application requires 140 MB of free space on the machine in order to complete 
the install. 

Software Prerequisites 
The following software must be installed prior to installing WebLogic Mobility Server: 

Operating System 
• MS Windows 2000/XP (development) or 2003 (deployment) 

Application Server  
The application server is required in order to use WebLogic Mobility Server:  

• BEA WebLogic Server 8.1 SP2 - SP6 

• BEA WebLogic Platform 8.1 SP2 - SP6 

• BEA WebLogic Sever 9.X 

• BEA WebLogic Platform 9.X 
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Authoring Environment 
An authoring environment facilitates working with mobility tags: 

• BEA WebLogic Workshop 8.1 

OR 

• BEA Workshop for WebLogic Platform 9.X 

Internet Browser 
• Netscape 4.75 or higher 

OR 

• Internet Explorer 5 or higher 

Database (optional) 
• MySQL 3.53 and above 

• Oracle 9i, 10i 

• PointBase 4.4 

• Postgres 7.3.2 and above 

• SQL Server 2000 

• Sybase Adaptive Server Enterprise 12.5 

• IBM DB2 Universal Database 8.1 

JDK 
For WebLogic: 

• Sun JDK 1.4.X or Sun JDK 1.5.X or JRockit 1.4.X or JRockit 5.0 

Note: Java JDK/JRE must be on the search path, with JAVA_HOME set correctly. 

Administration Rights 
This installation application requires administration rights on the machine in order to complete 
the installation.  
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Installation Procedure for Windows 

1. Run the WebLogic Mobility Server installation application.  

2. The installation “Introduction” dialog is displayed. 

WebLogic Mobility Server Introduction dialog  

 
 

3. Select Next to continue. 
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4. The “Supported Platforms” dialog is displayed. 

WebLogic Mobility Server Supported Platforms dialog  

 

 

5. Click Next. 
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6. The “License Agreement” dialog is displayed.  

License Agreement dialog  

 

 

7. Read the license agreement and select the I accept the terms of the License Agreement 
radio button if you are satisfied with the terms. 

8. Click Next to continue with the install. 

Note: The Next button is unavailable if the terms are not accepted. 

8 - BEA WebLogic Mobility Server Installation Guide 



2—Install WebLogic Mobility Server 3.5 

9. The “Choose Install Set” dialog is displayed. 

Choose Install Set dialog  

 
 

10. Select the appropriate installation option and click Next to continue: 

• The WebLogic Mobility Server for Workshop 9.2 option features the Mobility Plug-in 
for BEA Workshop for WebLogic Platform 9.X, which extends the BEA Workshop IDE, 
enabling the creation of multi-channel applications and extending existing applications 
for access from wireless devices 

• The WebLogic Mobility Server for Workshop 8.1 option features the Mobility 
Extension for BEA WebLogic Workshop 8.1, which extends the BEA Workshop IDE, 
enabling the creation of multi-channel applications and extending existing applications 
for access from wireless devices 

• The WebLogic Mobility Server option features regular WebLogic Mobility Server 
installation 

• The Custom option allows you to choose the WebLogic Mobility Server components that 
you want to install 

Note: The installer will place mobility tutorials at 
<WLMS_install_directory>/samples/tutorials as part of the install. See the “Deploy the 
Getting Started Tutorials” chapter of the BEA WebLogic Mobility Server Getting Started 
Guide with regard to the tutorials. 
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11. IF you chose the Custom option on the “Choose Install Set” dialog, the second “Choose 
Install Set” dialog is displayed. 

Second Choose Install Set dialog  

 

 

12. From the Install Set drop-down, select the appropriate option (Custom is default). 

13. The WebLogic Mobility Server components contained within the selected install set will 
display with their corresponding check boxes selected in the section underneath. Select or de-
select components for installation as required. 

Note: This dialog allows you to de-select or select additional components for installation 
from the Custom install set as required. The installer will not allow you to de-select or select 
components from the other install sets—it will revert to the Custom option if you attempt to 
do so. 

Note: If you have been using an old WebLogic Mobility Server installation, and want to 
install a new version of WebLogic Mobility Server in a new location, when you first start 
BEA Workshop you must update the new WebLogic Mobility Server install location (for 
WebLogic 8.X and 9.X platforms). See the Appendix for details on how to do this. 

14. Click Next. 
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15. The “Locate BEA Installation” dialog is displayed.  

Locate BEA Installation dialog  

 
 

16. Select the folder where you would like to install WebLogic Mobility Server.  

17. Click Next to continue. 
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18. The “Pre-Installation Summary” dialog is displayed. 

Pre-Installation Summary dialog  

 
 

19. Review the installation configuration information. If the information is correct, click Install. 
Otherwise, click Previous to go back through the screens and modify the provided 
information 
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20. IF you installed the Mobility extension on BEA WebLogic 8.1, the “Online Documentation” 
dialog is displayed. 

Online Documentation dialog  

 

 

21. Indicate if you would like to view the Online Documentation and install the Mobility Help in 
WebLogic Workshop. Click Next.  

Note: If you select the View Online Documentation check box, the online help will display 
in your Internet browser 
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22. When the installation completes, the “View Online Documentation” dialog is displayed.  

View Online Documentation dialog  

 
 

23. Indicate if you would like to view the Online Documentation. Click Next.  
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24. The “Install Complete” dialog will be displayed following a successful install. 

Install Complete Screen  

 
 

25. Click Done to exit the installer. 

Note: Next Step 
• Ensure that the BEA WebLogic Mobility Server license file is integrated into the bea.license 

file of your WebLogic Server to enable multi-channel content delivery 

• If you installed the Mobility Plugin and plan to edit tags using BEA Workshop for WebLogic 
Platform 9.X, see chapter “3—Additional Configuration: Mobility Plugin for BEA Workshop 
for WebLogic Platform 9.X Installations”. 

• If you installed the Mobility Extension and plan to edit tags using BEA WebLogic Workshop 
8.1, see chapter “4—Additional Configuration: Mobility Extension for BEA WebLogic 
Workshop 8.1 Installations”. 
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Install WebLogic Mobility Server on Sun Solaris, RedHat Linux 
or HP-UX 
This chapter explains the installation procedure for installing WebLogic Mobility Server on Sun 
Solaris, Redhat Linux, and HP-UX 11. 

Introduction 
The mobilityServer35_unix.bin installation application is used to install WebLogic Mobility 
Server 3.5 on: 

• RedHat Linux 

• Sun Solaris  

• HP-UX 

License 
A BEA WebLogic Mobility Server license file must be integrated into the bea.license file of your 
WebLogic Server. 

Your sales representative should provide this file to you along with the product CDs.  Please 
contact your sales representative if you have not yet received your license file. 

Once you have updated your license, you will be able to develop and test mobile-device ready 
content. If you have a developer or evaluation license, the software installer will install an 
evaluation version of the Device Repository enabling testing on a number of popular device 
emulators as well as a number of popular mobile and PDA devices.  A production license must be 
present to install and use the full Device Repository. Note: An invalid license will result in 
HTML being delivered. 

Please contact a sales representative if you wish to extend your evaluation or developer license or 
upgrade to a production license. 

Installation Prerequisites 

Software Prerequisites 
The following software must be installed prior to installing WebLogic Mobility Server: 

• A supported operating system, from the following list: 

• Sun Solaris 10 

• RedHat Linux 2.1, 3.0 

• HP-UX 11 

• An application server: 

• BEA WebLogic Platform 8.1 SP2 - SP6 

• BEA WebLogic Server 8.1 SP2 - SP6 

• BEA WebLogic Platform 9.X 

• BEA WebLogic Server 9.X 
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• An authoring environment: 

• BEA WebLogic Workshop 8.1 

• BEA WebLogic for Workshop Platform 9.X 

• An Internet browser: 

• Netscape 4.75 or higher, or 

• Internet Explorer 5 or higher 

• A database, from the following list (optional):  

• Oracle 9i, 10i 

• PointBase 4.4 

• Postgres 7.3.2+ 

• MySQL 3.53 and above 

• SQL Server 2000 

• Sybase Adaptive Server Enterprise 12.5 

• IBM DB2 Universal Database 8.1 

•  An SDK: 

• Sun JDK 1.4.X or Sun JDK 1.5.X or JRockit 1.4.X or JRockit 5.0 

• Note: Java JDK/JRE must be on the search path, with JAVA_HOME set correctly 

• A PDF viewer: 

Either Adobe Acrobat Reader 4.0.x – 7.0.x or Xpdf is required on the search path; otherwise 
an error message will be displayed when you attempt to view PDF documents. 
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Installation Procedure for Sun Solaris, RedHat Linux, and HP-UX 

1. Open an xterm, telnet, or console window and run the WebLogic Mobility Server 
installation application, mobilityServer35_unix.bin. 

2. The first stage of the installation is the “Introduction”. Press <Enter> to continue. 

3. The “Supported Platforms” stage is next. Please read this and ensure that the installation 
environment meets the stated requirements. Press <Enter> to continue. 

4. The “License Agreement” screen is displayed next. Read the license agreement text and enter 
the value Y if you accept the terms of the license agreement, or the value N if you do not  

Note: Selecting “N” will cancel the installation after prompting you to confirm cancellation 

5. The following stage of the installation is “Choose Install Set”. 

Select the appropriate installation option and click Next to continue. Enter the value “1” (or 
press <Enter>) to select the “WebLogic Mobility Server for Workshop 9.2” installation 
option, “2” to select the “WebLogic Mobility Server 3.5 for Workshop 8.1” option, “3” to 
select the “WebLogic Mobility Server” option or “4” to select the “Customize…” option. 
Press <Enter> to continue. 

6. IF you selected the “Customize…” installation at the “Choose Install Set” stage, the “Choose 
Product Features” stage is next. 

Select or de-select components for installation as required. To accept the default press 
<Enter>. To de-select a checked component, type its corresponding number. To select a 
(non-checked) component, type its corresponding number.  

Note: Ensure that you insert commas if you are entering a list.  

Press <Enter> to continue. 

Notes 

• If you select only the Mobility Extension for BEA Workshop component for installation 
(for WebLogic 8.X and 9.X platforms), the Uninstall BEA WebLogic Mobility Server.exe 
will be placed at the WebLogic Mobility Server install location 
(<WLMS_install_directory>/UninstallerData/), allowing you to uninstall the Mobility 
Extension for BEA Workshop and samples at a later stage  if required 

• If you have been using an old WebLogic Mobility Server installation, and want to install 
a new version of WebLogic Mobility Server in a new location, when you first start BEA 
Workshop you must update the new WebLogic Mobility Server install location (for 
WebLogic 8.X and 9.X platforms). See the Appendix for details on how to do this 

7. The “Locate BEA Installation” stage is displayed. Specify the folder at which BEA 
WebLogic 8.1 or 9.X is installed. The Mobility Extension for BEA Workshop will be 
installed in the Weblogic81/Weblogic92 directory at this location. Press <Enter> to 
continue. 

8.  The “Pre-Installation Summary” stage is next. Review the displayed installation 
configuration settings to ensure they are correct. If you are satisfied with the configuration 
settings, press <Enter> to continue. Otherwise, type back to return to a previous step and 
modify the configuration settings. 
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9. IF you installed the Mobility Extension for BEA Workshop on a WebLogic 8.1-8.5 platform, 
the “Install Mobility Help” dialog is displayed when the installation completes. Read the 
message and then indicate if you want to install the Mobility Help in WebLogic Workshop. 
The Mobility Help describes the key features provided by the Mobility Extension and lists the 
JSP Tag References. Press <Enter> to continue. 

10. The “Installation Complete” message will display following a successful install. Press 
<Enter> to exit the installer. 

Note: Next Step 
• Ensure that the BEA WebLogic Mobility Server license file is integrated into the bea.license 

file of your WebLogic Server to enable multi-channel content delivery 

• If you installed the Mobility Plugin and plan to edit tags using BEA Workshop for WebLogic 
Platform 9.X, see chapter “3—Additional Configuration: Mobility Plugin for BEA Workshop 
for WebLogic Platform 9.X Installations”. 

• If you installed the Mobility Extension and plan to edit tags using BEA WebLogic Workshop 
8.1, see chapter “4—Additional Configuration: Mobility Extension for BEA WebLogic 
Workshop 8.1 Installations”. 
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3—Additional Configuration: Mobility Plugin for BEA 
Workshop for WebLogic Platform 9.X Installations 
Important notes:  

• This chapter is only relevant if you selected the “WebLogic Mobility Server for Workshop 
9.2” installation option or opted to install the Mobility Plugin for BEA Workshop, and are 
using BEA Workshop for WebLogic Platform 9.X to author content 

• The Mobility Plugin is installed as part of the WebLogic Mobility Server installation process, 
therefore you are not required to install it separately here  

Configure the WebLogic Mobility Server Install Location in 
Workshop  
The location of the WebLogic Mobility Server install was configured during installation to 
<WLMS_install_directory>. If you have a new WebLogic Mobility Server install in a different 
location to that of a previous version, follow the steps here, which describe how to re-configure 
the WebLogic Mobility Server location for use with the Mobility Sample Projects for BEA 
Workshop and BEA Portal.  

Note: If you have multiple WebLogic Mobility Server installs on the same machine and want to 
uninstall these, please note that the Add or Remove Programs function in the Control Panel (for 
Windows installations) will only remove the most recently-installed version of WebLogic 
Mobility Server. It is necessary to uninstall older versions manually, by navigating to 
<WLMS_install_directory>\UninstallerData\ and running Uninstall BEA WebLogic Mobility 
Server.exe. 

To configure the WebLogic Mobility Serve location: 

1. Open Workshop.  

 
 

 

2. From within your BEA Workshop Environment, choose Window →  Preferences.  
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3. The “Preferences” dialog is displayed.  

 
 

 

4. Select the Mobility folder.  

5. The location of the WebLogic Mobility Server install was configured during installation to 
<WLMS_install_directory> and displays in the WLMS Installation Directory field.  

To change the location to point at a different WebLogic Mobility Server installation, enter the 
location of the WebLogic Mobility Server installation in the WLMS Installation Directory 
field or click Browse to browse to the location.  This will enable access to device diagnostic 
and device management tools from within Workshop. 

6. Click OK. 
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Configure the Device Emulators for use within BEA Workshop 
for WebLogic Platform 9.X 
This section describes how to configure the emulators for use within BEA Workshop. You can 
use the device emulators to see how the mobilized content will look on a particular device (for 
example phones, PDAs). Several emulators are available for download free of charge on the 
Internet. 

1. To configure the tools and emulators for usage within the BEA Workshop environment, 
select Preferences from the Window Menu. Choose Window → Preferences. 
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2. The “Preferences” dialog is displayed. To configure the emulators, select the Emulators tab. 

 

 

3. Select WAP1.x emulator by browsing to the appropriate emulator executable file. 

Note: It is recommended that you use the Openwave Emulator, which can emulate WAP 1.x 
and XHTML-MP devices. However, emulators from Nokia, Ericsson, or others can also be 
used. If using an Openwave Emulator, select the OSDK62http.exe (for version 6.2) or the 
OSDK61http.exe (for version 6.1) in the installation directory where the emulator is installed, 
for example C:\Program Files\Openwave\SDK 6.1\program\http. 

4. Select WAP2.0 emulator by browsing to the appropriate emulator executable file.  

Note: As Workshop for BEA WebLogic 9.X already has an in-built full browser emulator, 
you can specify a WAP2.0 emulator by browsing to the same location as above and selecting 
Override device recognition to force WAP 1.x content checkbox in under the WAP 1.x 
emulator field. 

5. Specify a PDA emulator in the PDA emulator field by browsing to the appropriate emulator 
executable file: 

• You can find a PDA emulator at <WLMS_install_directory>/tools/emulators/PDA.exe 

• Alternatively, to set up MS Internet Explorer to function as a PDA emulator, browse to 
your iexplore.exe, and select the Override device recognition to force PDA content 
check box underneath 

6. Click OK. 
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Create the Workshop Domain  

Introduction 
This section describes creating a BEA Workshop Domain called “Mobility” for later use with 
tutorials and exercises. 

Create the “Mobility” Workshop Domain 
To create the “Mobility” Domain: 

1. Launch the BEA WebLogic Configuration wizard from the Windows Start menu. Choose 
Start → Programs → BEA Products → Tools → Configuration Wizard. 

2. The “Welcome” dialog is displayed.  

 

 

3. Select Create a new WebLogic domain and click Next. 
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4. The “Select Domain Source” dialog is displayed. 

 

 

5. Select the Workshop for WebLogic Platform checkbox. 

6. Click Next. 
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7. The “Configure Administrative Username and Password” dialog is displayed.  

 

 

8. Enter “weblogic” for the username and “weblogic” for the password and click Next. 
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9. The “Configure Server Start Mode and Java SDK” dialog is displayed.  

 

 

10. Select Development Mode within the WebLogic Domain Startup Mode section. 

11. Select an SDK from within the supplied JDKs section and click Next. 
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12. The “Customize Environment and Services Settings” dialog is displayed. 

 

 

13. Click Next. 
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14. The “Create WebLogic Domain” dialog is displayed.  

 

 

15. Set the Domain Name to “Mobility” and click Create. 
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16. The configuration wizard will now create the domain.  

 

 

17. When it completes, click Done on the Creating Domain screen. 
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Create the Portal Domain and Create the Sample Mobility Portal 
Project 
This section describes how to create a BEA Portal Domain (“MobilityPortal”) and a new 
application, and how to subsequently create a Sample Mobility Portal Project in the newly created 
domain using the supplied template. 

Create the “MobilityPortal” Portal Domain 
To create the “MobilityPortal” Domain: 

1. Launch the BEA WebLogic Configuration wizard from the Windows Start menu. Choose 
Start → Programs → BEA Products → Tools → Configuration Wizard. 

2. The “Welcome” dialog is displayed.  

 

 

3. Select Create a new WebLogic domain and click Next. 
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4. The “Select Domain Source” dialog is displayed. 

 

 

5. Select the Workshop for WebLogic Platform and WebLogic Portal checkboxes. 

6. Click Next. 
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7. The “Configure Administrative Username and Password” dialog is displayed.  

 

 

8. Enter “weblogic” for the username and “weblogic” for the password and click Next. 
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9. The “Configure Server Start Mode and Java SDK” dialog is displayed.  

 

 

10. Select Development Mode within the WebLogic Domain Startup Mode section. 

11. Select an SDK from within the supplied JDKs section and click Next. 
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12. The “Customize Environment and Services Settings” dialog is displayed. 

 

 

13. Click Next. 
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14. The “Create WebLogic Domain” dialog is displayed.  

 

 

15. Set the Domain Name to “MobilityPortal” and click Create. 
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16. The configuration wizard will now create the domain.  

 

 

17. When it completes, click Done on the Creating Domain screen. 

 

BEA WebLogic Mobility Server Installation Guide - 37 



3—Additional Configuration: Mobility Plugin for BEA Workshop for WebLogic Platform 9.X 
Installations 

Create the MobilityPortalApp EAR Project 
To create the MobilityPortalApp EAR project: 

1. To create a new EAR Project in Workshop, choose File → New → Other. 
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2. The “New” dialog is displayed. 

 

 

3. Expand WebLogic Portal and select Portal EAR Project.  

4. Click Next. 
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5. The “New Portal EAR Project” dialog is displayed. 

 

 

6. Enter “MobilityPortalApp” in the Project Name field. 

7. Ensure “BEA WebLogic v9.X” is specified in the Target runtime field. 

8. Click Finish to create the EAR project. 

9. The following message will be displayed.  

 

 

10. Click Yes. 

Now that you have created a new domain and an EAR project, you need to create the portal web 
project. 
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Create the Sample Workshop Mobility Portal Project—“maportal”  

Create a Portal Web Project 
When WebLogic Mobility Server was installed, a Sample Mobile Portal Project template was 
created. Create the sample Workshop mobility portal project using this template as described 
below and then refer to the BEA Sample Mobility Portal Guide for an explanation of the features 
of the sample portal.  

1. From Workshop, expand the File menu.  

 
 

 

2. Choose New → Portal Web Project. 
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3. The “New Portal Web Project” dialog is displayed.  

 

 

4. Enter “maportal” in the Project Name field. 

5. Select the Add project to an EAR checkbox (—ensure that the “MobilityPortalApp” project 
is selected in the EAR Project Name field). 

6. Click Next. 
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7. The “Select Project Facets” dialog is displayed. 

 

 

8. Select the WebLogic Mobility Server checkbox.  

9. Click Finish. 

Note: If the WebLogic Mobility Server installation directory has not been configured 
correctly, the Finish button on this screen will not be enabled and you will firstly need to 
click Next until you reach a screen that allows you enter the correct location. 

Note: You will see the Mobility Framework for WebLogic Portal facet in the image above. 
Please refer to “Appendix B: Mobility Framework for WebLogic Portal 9.2” for a description 
of this feature. 
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Import the Sample Portal Files 
You now need to import the sample portal files. 

1. Right-click on the “maportal” project. 

 

 

2. Select “Import” from the drop-down menu that is displayed. 
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3. The “Import” dialog is displayed. 

 

 

4. Select File System and click Next. 

BEA WebLogic Mobility Server Installation Guide - 45 



3—Additional Configuration: Mobility Plugin for BEA Workshop for WebLogic Platform 9.X 
Installations 

5. The “File System” dialog is displayed. 

 
 

6. Click Browse in the From directory field and navigate to 
<WLMS_install_directory>\samples\BEAPortal9\maportal. 

7. Ensure that the folders and sub-folders are expanded and selected as illustrated above. 

8. Select the Overwrite existing resources without warning checkbox and the Create 
selected folders only option. 

9. Click Finish. 
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Define a New Server 
You will need to define a server for use in BEA Workshop for WebLogic Platform 9.X and set it 
as default. 

1. Select the “maportal” portal file on the left hand side of the screen. 

 

 

2. Double-click on it to open it. 
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3. Now, run the portal. 

 

 

4. Right-click on the “maportal” portal file and select Run → Run As → Run on Server. 
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5. The “Define a New Server” dialog is displayed. 

 

 

6. Select the Set Server as project default checkbox and click Next. 
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7. The “Run on Server” dialog is displayed. 

 

 

8. In the Domain home field, click Browse and navigate to the “MobilityPortal” domain that 
you previously created.  

9. Select the Use default checkbox and click Finish. 
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10. The portal is then displayed. 

 

 

The Sample Mobility Portal Guide document explains the features of the “maportal” sample 
project 
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4—Additional Configuration: Mobility Extension for BEA 
WebLogic Workshop 8.1 Installations 
Important notes  

• This chapter is only relevant if you selected the “WebLogic Mobility Server for Workshop 
8.1” installation option or opted to install the Mobility Extension for BEA Workshop, and are 
using BEA Workshop to author content. 

• The Mobility Extension is installed as part of the WebLogic Mobility Server installation 
process, therefore you are not required to install it separately here 

Configure the WebLogic Mobility Server Location (Optional) 
The location of the WebLogic Mobility Server install was configured during installation to 
<WLMS_install_directory>. If you have a new WebLogic Mobility Server install in a different 
location to that of a previous version, follow the steps here, which describe how to re-configure 
the WebLogic Mobility Server location for use with the Mobility Sample Projects for BEA 
Workshop and BEA Portal. 

Notes 

• This step is optional 

• If you have multiple WebLogic Mobility Server installs on the same machine and want to 
uninstall these, please note that the Add or Remove Programs function in the Control Panel 
(for Windows installations) will only remove the most recently-installed version of 
WebLogic Mobility Server. It is necessary to uninstall older versions manually, by navigating 
to <WLMS_install_directory>\UninstallerData and running Uninstall BEA WebLogic 
Mobility Server.exe. 

To configure the WebLogic Mobility Server location: 

1. Open BEA WebLogic Workshop. 

IDE Properties  

 

 

2. From within your BEA Workshop Environment, choose Tools → IDE Properties.  
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3. The IDE Properties dialog is displayed.  

WebLogic Mobility Server Location  

 

 

4. Select the Mobility folder.  

5. The location of the WebLogic Mobility Server installation was pre-configured during the 
installation to <BEA_install_directory>\weblogic81\mobility and displays in the 
WebLogic Mobility Server Install Location field.  

To change the location to point at a different WebLogic Mobility Server installation, enter the 
location of the WebLogic Mobility Server installation in the WebLogic Mobility Server 
Install Location field or click Browse to browse to the location.  This will enable access to 
device diagnostic and device management tools from within BEA WebLogic Workshop. 

6. Click OK. 
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Configure the Device Emulators for use within BEA WebLogic 
Workshop 8.1 
This section describes how to configure the emulators for use within BEA WebLogic Workshop 
8.1. You can use the device emulators to see how the mobilized content will look on a particular 
device (for example phones, PDAs). Several emulators are available for download free of charge 
on the Internet. This section describes how to configure the emulators for use within BEA 
Workshop. 

1. To configure the tools and emulators for usage within the BEA Workshop environment, 
select IDE properties from the Tools Menu. Choose Tools → IDE Properties 

Select IDE Properties  
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2. The “IDE Properties” dialog is displayed. To configure the emulators, select the Emulators 
tab.   

Setting up Internet Explorer as a PDA Emulator  

 

 

3. Select WAP1.x emulator by browsing to the appropriate emulator executable file. 

Note: It is recommended that you use the Openwave Emulator, which can emulate WAP 1.x 
and XHTML-MP devices. However, emulators from Nokia, Ericsson, or others can also be 
used. If using an Openwave Emulator, select the OSDK62http.exe (for version 6.2) or the 
OSDK61http.exe (for version 6.1) in the installation directory where the emulator is installed, 
for example C:\Program Files\Openwave\SDK 6.1\program\http. 

4. Select WAP2.0 emulator by browsing to the appropriate emulator executable file. 

5. Select PDA emulator by browsing to the appropriate emulator executable file. 

• You can find a PDA emulator at <WLMS_install_directory>\tools\emulators\PDA.exe 

• Alternatively, to set up MS Internet Explorer to function as a PDA emulator, browse to 
your iexplore.exe in the PDA emulator text box as can be seen in the diagram below and 
select the Override device recognition to force PDA content check box 

6. Click OK. 
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Create the Workshop Domain and Install the Sample Workshop 
Projects 

Introduction 
This section describes creating a BEA Workshop Domain, creating a new application, and then 
importing the provided Sample Workshop Projects into the newly created domain. 

Create the Mobility Domain 
To create the Mobility Domain: 

1. Launch the BEA WebLogic Configuration wizard from the Windows Start menu; choose 
Start → Programs → <BEA install directory> → Configuration Wizard 

If you have BEA Workshop open, you can also launch it from the tools menu; choose Tools 
→ WebLogic Server → Configuration Wizard 

2. The “Configuration Wizard – Create a new WebLogic Configuration” dialog is displayed. 

Configuration Wizard – Create a new WebLogic Configuration  

 

 

3. Select Create a new WebLogic configuration and click Next. 
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4. The “Select a Configuration Template” dialog is displayed.  

Configuration Wizard – Basic WebLogic Workshop Domain 

 

 

5. IMPORTANT: Ensure that you select Basic WebLogic Workshop Domain and click Next. 
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6. The “Choose Express or Custom Configuration” dialog is displayed.  

Configuration Wizard – Express Configuration  

 

 

7. Select “Express” and click Next 
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8. The “Configure Administrative Username and Password” dialog is displayed.  

Configuration Wizard – User Name and Password  

 

 

9. Enter “weblogic” for the username and “weblogic” for the password and click Next. 
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10. The “Configure Server Start Mode and Java SDK” dialog is displayed.  

Configuration Wizard – Start Mode  

 

 

11. Select Development Mode within the WebLogic Configuration Startup Mode section. 

12. Select your preferred JDK within the Supplied SDKs section and click Next. 
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13. The “Create WebLogic Configuration” is displayed. 

Configuration Wizard – Mobility  

 

 

14. Enter “Mobility” in the Configuration Name field at the lower right-hand corner of the 
screen and click Create. 
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15. The configuration wizard will now create the domain.  

Configuration Wizard – Creating Configuration  

 

 

16. When it completes, click Done on the Creating Configuration screen. 
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Create the Mobility Application 
To create the Mobility application: 

1. To create a new application in Workshop, choose  File → New→ Application  

Create New Application  
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2. The “New Application” dialog is displayed. 

New Application Dialog  

 

 

2. From the window: 

• Select “Default Application” 

• IF DESIRED: Click Browse next to the Directory field and browse the Domains 
directory, selecting your newly created “Mobility” domain. 

(Some people choose to put the application into the domain – it means that you can zip 
the entire thing up to move it around. On the other hand, you can deploy an application to 
multiple domains if you want, so some people prefer to keep them separate, e.g. in the 
applications directory (default).) 

• Enter “MobilityApp” in the Name field – this is the application where you will import 
the sample mobility application 

• Click Browse next to the Server field and select the config.xml file inside the newly 
created “Mobility” domain 

3. Once you have filled in the fields as above, click Create and the application will be created 

Now that you have created a new domain and a new application, you can import the sample 
Workshop mobility project. 
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Import the Sample Workshop Mobility Project 
The sample Workshop Mobility project is located in the 
<WLMS_install_directory>\samples\BEAWorkshop directory.  

Two versions of the project called restaurantWeb and restaurantWeb_After were installed 
during the Mobility Extension installation. The restaurantWeb project has not yet been 
mobilized, while the restaurantWeb_After project has already been fully mobilized.  

You can install the restaurantWeb project as described below and then follow the steps 
described in the BEA Sample Workshop Mobility Project Guide to mobilize it. 

1. Right-click the newly created “MobilityApp” application in the Application tree window. 

Import Project  

 

 

2. Choose Import Project. 
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3. The “Import Project – New Project” dialog is displayed.  

Import New Project  

 

 

4. Click Browse next to the Directory: field and browse to the 
“<WLMS_install_directory>\samples\BEAWorkshop\” directory. 

Locate restaurantWeb  

 

5. Select “restaurantWeb” and click Open. 
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6. Back on the “Import Project - New Project” dialog, the Directory will now be filled in, with a 
default Name for the application set to “restaurantWeb”.  

Import restaurantWeb project  

 

 

7. Select Web Project from the right hand pane. 

8. Ensure that the Copy into Application Directory check box is selected. 

9. Click Import. 

You can also choose to import the restaurantWeb_After project to see the final version. The 
BEA Sample Workshop Mobility Project Guide document explains the steps to mobilize the 
restaurantWeb project to reach the same results as in the restaurantWeb_After project. 

Note: You can import the “restaurantWeb_After” project at the same time as the “restaurantWeb” 
project, or afterwards, but you MUST import the “restaurantWeb” project. 
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Create the Portal Domain and Create the Sample Mobility Portal 
Project 

Introduction 
This section describes creating a BEA Portal Domain, creating a new application, and then 
creating a Sample Mobility Portal Project in the newly created domain using the supplied 
template. 

Create the MobilityPortal Domain 
To create the MobilityPortal Domain: 

1. Launch the BEA WebLogic Configuration wizard from the Windows Start menu. Choose   
Start → Programs → <BEA install directory> → Configuration Wizard. If you have 
BEA Workshop open, you can also launch it from the tools menu; choose Tools → 
WebLogic Server → Configuration Wizard. 

2. The “Create or Extend a Configuration” dialog is displayed. 

Configuration Wizard – Create a new WebLogic Configuration  

 

 

3. Select Create a new WebLogic configuration and click Next. 
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4. The “Select a Configuration Template” dialog is displayed. 

Configuration Wizard – Basic WebLogic Portal Domain  

 

 

5. IMPORTANT: Ensure that you select Basic WebLogic Portal Domain and click Next. 
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6. The “Choose Express or Custom Configuration” dialog is displayed.  

Configuration Wizard – Express Configuration  

 

 

7. Select Express and click Next. 
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8. The “Configure Administrative Username and Password” dialog is displayed.  

Configuration Wizard – User Name and Password  

 

 

9. Enter “weblogic” for the username and “weblogic” for the password and click Next. 
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10. The “Configure Server Start Mode and Java SDK” dialog is displayed.  

Configuration Wizard – Start Mode  

 

 

11. Select Development Mode within the WebLogic Configuration Startup Mode section. 

12. Select the Sun JDK within the Java SDK Selection section and click Next. 
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13. The “Create WebLogic Configuration” dialog is displayed. 

Configuration Wizard – Mobility Portal  

 

 

14. Set the Configuration Name to “MobilityPortal” and click Create. 
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15. The configuration wizard will now create the domain. 

Configuration Wizard – Creating MobilityPortal Configuration  

 

 

16. When it completes, click Done on the Creating Configuration screen. 
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Create the MobilityPortalApp Application 
To create the MobilityPortalApp application: 

1. To create a new application in Workshop, choose File → New → Application  

2. The New Application dialog is displayed. 

Create New Application  

 

 

3. From the New Application window: 

• Select Portal Application. 

Note: Do not select Default Application as per earlier. 

• Click Browse next to the Directory field and browse the Domains directory, selecting 
your newly created “MobilityPortal” domain. 

• Enter “MobilityPortalApp” in the Name field – this is the application where you will 
import the sample mobility portal application. 

• Click Browse next to the Server field and select the config.xml file inside the newly 
created “MobilityPortal” domain. 
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4. Once you have filled in the fields as above, click Create and the application will be created. 

Create Portal Application Dialog  

 

 

Now that you have created a new Domain and a new Portal Application, you can import the 
sample Workshop mobility portal project. 
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Create the Sample Workshop Mobility Portal Project 
When WebLogic Mobility Server was installed, a Sample Mobile Portal Project template was 
created. Create the sample Workshop mobility portal project using this template as described 
below and then refer to the BEA Sample Mobility Portal Guide for an explanation of the features 
of the sample portal.  

1. Right click the newly created “MobilePortalApp” application in the Application tree window. 

New Portal Project  

 
 

2. Choose New → Project. 
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3. The “New Project” dialog is displayed.  

Create New Project  

 

 

4. Select “Mobility” and “Sample Mobile Portal”. 

5. Enter “maportal” in the Project Name field. 

6. Click Create. 

The BEA Sample Mobility Portal Guide document explains the features of the “maportal” sample 
project. 

 

 

 
  

78 - BEA WebLogic Mobility Server Installation Guide 



 

Next Steps 

Install the Device Repository 
If you want to deploy the Device Repository at a different location, you will need to update the 
mis.properties file to reflect the new Device Repository connection details—see chapter 2 of the 
Device Repository Guide for more information. If you wish to deploy the Device Repository into 
a database, you will also need to run the Device Repository Manager tool. See chapter 1 of the 
Device Repository Guide for instructions on how to do so.  

Additional Steps 

Configuration of a WebLogic Mobility Server-Enabled Web 
Application 
Please see the BEA WebLogic Mobility Server Administration Guide for details on: 

• Creating the deployment environment for a mobilized web application 

• Configuring the Mobility servlet filter 

• Configuring the web application’s Web Deployment Descriptor (web.xml file) for the 
Mobility servlet filter 

Mobilize Your Own Applications  
Once you have installed and configured WebLogic Mobility Server and the Device Repository, 
you are almost ready to begin mobilizing your own web applications and portal projects.  

If you installed WebLogic Mobility Server with the Mobility Extension for BEA Workshop, it is 
recommended that you go through the BEA Mobilize Your Portal Guide and the BEA Sample 
Mobility Portal Guide after using this guide. The BEA Mobilize Your Portal Guide explains how 
to mobilize a portal and the BEA Sample Mobility Portal Guide illustrates the features of a 
mobilized BEA Portal Framework. 

If you installed WebLogic Mobility Server with the Mobility Extension for BEA WebLogic 
Workshop version 8.1, you should have subsequently imported the Sample Workshop Project 
(“restaurantWeb”) provided with the product. For a step-by-step exercise in mobilizing the sample 
workshop application, see the BEA Sample Workshop Mobility Project Guide 

Additionally, see the “Working with Diagnostics” section of the BEA WebLogic Mobility Server 
User Guide for information on configuring and using the Diagnostics tools. 

Note: Documentation can be accessed from the BEA website.  
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Appendices  

Appendix A: Update the WebLogic Mobility Server Install 
Location with BEA WebLogic Workshop 
If you had been using an old WebLogic Mobility Server installation with the Mobility Extension 
for BEA Workshop, and install a new version of WebLogic Mobility Server with Mobility 
Extension in a new location (on a BEA WebLogic 8.1 or 9.X platform), when you first start BEA 
Workshop you will need to configure which installation to use.  

Note: In BEA WebLogic Workshop 8.1, a warning will be displayed when you first start 
Workshop informing you that a new WebLogic Mobility Server been installed, and that you 
should click OK to configure which installation to use. Clicking OK will launch the “IDE 
Properties” dialog 

In the “IDE Properties” dialog (8.1) or Windows “Preferences” panel (9.X) the default WebLogic 
Mobility Server Install Location setting points to the old location—click Browse and specify 
the new install location. 

Note: If you re-installed WebLogic Mobility Server with the Mobility Extension for BEA 
Workshop over an old location, WebLogic will automatically pick up the new files, etc. without 
any user input. 

Sample Workshop 8.1 WebLogic Mobility Server Location  
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Appendix B: Mobility Framework for WebLogic Portal 9.2 
 

The Select Project Facets panel is displayed when you create new BEA WebLogic Portal portal 
web projects, dynamic web projects or EAR projects.  

Select the Mobility Framework for WebLogic Portal to insert the Mobility Framework into 
your portal project….  

 
 

Note: You can add facets when creating the projects, or you can return and add them in at a later 
stage. 

Deploying WebLogic Mobility Server as an EAR file in BEA WebLogic 9.2 Portal 
If you select the Mobility Framework for WebLogic Portal facet when creating an EAR file and 
attempt to deploy this file on another WebLogic 9.2 instance, you will receive an error unless you 
perform the following step: 

Necessary step: Deploy the portal/lib/modules/wlp-mobility-web-lib.war file as a library onto 
the new server using the WLS Admin Console. This deployment adds an entry to the server's 
config.xml file and resolves the issue. 
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