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Introduction 

Introduction 

About This Manual 
This document describes the process for installing BEA WebLogic Mobility Server™ version 
3.3. 

Please read this document before commencing installation to ensure you comply with the 
installation pre-requisites and have access to relevant installation configuration information. 

Intended Audience  
It is recommended that your IT department, database/development team or a technical consultant 
perform the tasks outlined in this document. 

Begin by reading the section below, which explains how to use the guide. 

Using This Guide 
The document is split into two sections: 

1. “Install WebLogic Mobility Server on MS Windows 2000”. This section describes the 
installation and configuration of:  

• WebLogic Mobility Server on MS Windows 2000, including the Mobility Extension for 
BEA WebLogic Workshop 8.1 on MS Windows 2000 

• A BEA Sample Workshop Mobility Project used to illustrate how to use the features 
provided by the Mobility Extension 

• A BEA Sample Mobility Portal Project for BEA WebLogic Platform 8.1, demonstrating 
the features of the Mobilized BEA WebLogic Portal Framework solution 

It also describes: 

• Configuration of device emulators in BEA WebLogic Workshop 

• Creating the necessary Domains and Applications required for importing the sample 
projects using the BEA Configuration Wizard 

• Importing the Sample Projects into BEA WebLogic Workshop 

2. “Install WebLogic Mobility Server on Sun Solaris, RedHat Linux and HP-UX”. This section 
describes the installation and configuration of WebLogic Mobility Server on Sun Solaris, 
RedHat Linux and HP-UX. 

Note: This is the first guide that you will use in the process of installing and running the 
product—once you have completed the instructions here, proceed to the Device Repository Guide 
and then the BEA WebLogic Mobility Server Administration Guide. However, if you have 
installed WebLogic Mobility Server on MS Windows 2000, it is recommended that you go 
through the BEA Mobilize Your Portal Guide, the BEA Sample Workshop Mobility Project Guide 
and the BEA Sample Mobility Portal Guide after using this guide. The BEA Mobilize Your Portal 
Guide explains how to mobilize a portal, the BEA Sample Workshop Mobility Project Guide 
provides a step-by-step exercise in mobilizing a sample workshop application, and the BEA 
Sample Mobility Portal Guide illustrates the features of a Mobilized BEA Portal Framework. 
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1—Install WebLogic Mobility Server on MS Windows 
2000 
This section explains the installation procedure for installing WebLogic Mobility Server on MS 
Windows 2000. 

Introduction 
The mobilityServer33_win.exe installation application is used to install WebLogic Mobility 
Server on MS Windows 2000. 

License  
A BEA WebLogic Mobility Server license file must be integrated into the bea.license file of your 
WebLogic Server. 

Your sales representative should provide this file to you along with the product CDs.  Please 
contact your sales representative if you have not yet received your license file. 

Once you have updated your license, you will be able to develop and test mobile-device ready 
content. If you have a developer or evaluation license, the software installer will install an 
evaluation version of the Device Repository enabling testing on a number of popular device 
emulators as well as a number of popular mobile and PDA devices.  A production license must be 
present to install and use the full Device Repository. Note: An invalid license will result in 
HTML being delivered. 

Please contact a sales representative if you wish to extend your evaluation or developer license or 
upgrade to a production license. 

Installation Prerequisites 

Software Prerequisites 
The following software must be installed prior to installing WebLogic Mobility Server: 

Operating System 
• Microsoft Windows NT4, 2000, 2003 

Application Server  
The application server is required in order to use WebLogic Mobility Server, but not required 
prior to installation 

• BEA WebLogic Platform 8.1 SP2 and above 

Internet Browser 
• Netscape 4.75 and above 

• Internet Explorer 5 and above 
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Database (optional) 
• Oracle 9i, 10i 

• Postgres 7.3.2 and above 

• PointBase 4.4 

• MySQL 3.53 and above 

• SQL Server 2000 

• Sybase Adaptive Server Enterprise 12.5 

• IBM DB2 Universal Database 8.1 

JDK 
For WebLogic 8.x: 

• Sun JDK 1.4.x or JRockit 1.4.x 

Note: Java JDK/JRE 1.4.x must be on the search path, with JAVA_HOME set correctly. 

Administration Rights 
This installation application requires administration rights on the machine in order to complete 
the installation.  

 

 

BEA WebLogic Mobility Server Installation Guide - 3 



1—Install WebLogic Mobility Server on MS Windows 2000 

Installation Procedure for Windows 

1. Run the WebLogic Mobility Server installation application.  

2. The installation “Introduction” dialog is displayed. 

WebLogic Mobility Server Introduction dialog  

 
 

3. Select Next to continue. 
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4. The “License Agreement” dialog is displayed.  

License Agreement dialog  

 

 

5. Read the license agreement and select the I accept the terms of the License Agreement 
radio button if you are satisfied with the terms. 

6. Click Next to continue with the install. 

Note: The Next button is unavailable if the terms are not accepted. 
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7. The “Choose Install Folder” dialog is displayed. 

Choose Install Folder dialog  

 
 

8. Select the folder where you would like to install WebLogic Mobility Server. Click Next to 
continue. 
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9. The “Pre-Installation Summary” dialog is displayed. 

Pre-Installation Summary dialog  

 
 

10. Review the installation configuration information. If the information is correct, click Install. 
Otherwise, click Previous to go back through the screens and modify the provided 
information 
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11. When the installation completes, the “View Release Notes?” dialog is displayed.  

View Online Documentation dialog  

 
 

12. Indicate if you would like to view the Online Documentation and install the Mobility Help in 
WebLogic Workshop. Click Next.  

Note: If you select the View Online Documentation check box, the online help will display 
in your Internet browser. 
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13. The “Install Complete” dialog will be displayed following a successful install. 

Installation Complete Screen  

 
 

14. Click Done to exit the installer. 
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Configure the WebLogic Mobility Server Location (Optional) 
The location of the WebLogic Mobility Server installation was pre-configured during the 
installation to <bea installation directory>\weblogic81\mobility. For advanced users who may 
have multiple installations of WebLogic Mobility Server, this section describes how to re-
configure the WebLogic Mobility Server location for use with the Mobility Sample Projects for 
BEA Workshop and BEA Portal.  

Note: Please note that this step is optional. 

To configure the WebLogic Mobility Server location: 

1. Open BEA WebLogic Workshop. 

IDE Properties  

 

 

2. From within your BEA Workshop Environment, choose Tools → IDE Properties.  

10 - BEA WebLogic Mobility Server Installation Guide 



1—Install WebLogic Mobility Server on MS Windows 2000 

3. The IDE Properties dialog is displayed.  

WebLogic Mobility Server Location  

 

 

4. Select the Mobility folder.  

5. The location of the WebLogic Mobility Server installation was pre-configured during the 
installation to <bea installation directory>\weblogic81\mobility and displays in the 
WebLogic Mobility Server Install Location field.  

To change the location to point at a different WebLogic Mobility Server installation, enter the 
location of the WebLogic Mobility Server installation in the WebLogic Mobility Server 
Install Location field or click Browse to browse to the location.  This will enable access to 
device diagnostic and device management tools from within BEA WebLogic Workshop. 

6. Click OK. 
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Create the Workshop Domain and Install the Sample Workshop 
Projects 

Introduction 
This section describes creating a BEA Workshop Domain, creating a new application, and then 
importing the provided Sample Workshop Projects into the newly created domain. 

Create the Mobility Domain 
To create the Mobility Domain: 

1. Launch the BEA WebLogic Configuration wizard from the Windows Start menu; choose 
Start → Programs → <BEA install directory> → Configuration Wizard 

If you have BEA Workshop open, you can also launch it from the tools menu; choose Tools 
→ WebLogic Server → Configuration Wizard 

7. The “Configuration Wizard – Create a new WebLogic Configuration” dialog is displayed. 

Configuration Wizard – Create a new WebLogic Configuration  

 

 

8. Select Create a new WebLogic configuration and click Next. 
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9. The “Select a Configuration Template” dialog is displayed.  

Configuration Wizard – Basic WebLogic Workshop Domain 

 

 

10. Select Basic WebLogic Workshop Domain and click Next. 
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11. The “Choose Express or Custom Configuration” dialog is displayed.  

Configuration Wizard – Express Configuration  

 

 

12. Select “Express” and click Next 
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13. The “Configure Administrative Username and Password” dialog is displayed.  

Configuration Wizard – User Name and Password  

 

 

14. Enter “weblogic” for the username and “weblogic” for the password and click Next. 
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15. The “Configure Server Start Mode and Java SDK” dialog is displayed.  

Configuration Wizard – Start Mode  

 

 

16. Select Development Mode within the WebLogic Configuration Startup Mode section. 

17. Select Sun JDK within the Java SDK Selection section and click Next. 
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18. The “Create WebLogic Configuration” is displayed. 

Configuration Wizard – Mobility  

 

 

19. Enter “Mobility” in the Configuration Name field and click Create. 
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20. The configuration wizard will now create the domain.  

Configuration Wizard – Creating Configuration  

 

 

21. When it completes, click Done on the Creating Configuration screen. 
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Create the Mobility Application 
To create the Mobility application: 

1. To create a new application in Workshop, choose  File → New→ Application  

Create New Application  
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2. The “New Application” dialog is displayed. 

New Application Dialog  

 

 

3. From the window: 

• Select Default Application. 

• Click Browse next to the Directory field and browse the Domains directory, selecting 
your newly created “Mobility” domain. 

• Enter “MobilityApp” in the Name field – this is the application where you will import 
the sample mobility application. 

• Click Browse next to the Server field and select the config.xml file inside the newly 
created “Mobility” domain.    

4. Once you have filled in the fields as above, click Create and the application will be created 

Now that you have created a new domain and a new application, you can import the sample 
Workshop mobility project. 
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Import the Sample Workshop Mobility Project 
The sample Workshop Mobility project is located in the 
<bea>\weblogic81\mobility\samples\BEAWorkshop directory.  

Two versions of the project called restaurantWeb and restaurantWeb_After were installed 
during the Mobility Extension installation. The restaurantWeb project has not yet been 
mobilized, while the restaurantWeb_After project has already been fully mobilized.  

You can install the restaurantWeb project as described below and then follow the steps 
described in the BEA Sample Workshop Mobility Project Guide to mobilize it. 

1. Right-click the newly created “MobilityApp” application in the Application tree window. 

Import Project  

 

 

2. Choose Import Project. 
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3. The “Import Project – New Project” dialog is displayed.  

Import New Project  

 

 

4. Click Browse next to the Directory: field and browse to the 
“<bea>\weblogic81\mobility\samples\BEAWorkshop\” directory. 

Locate restaurantWeb  

 

 

5. Select “restaurantWeb” and click Open. 
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6. Back on the “Import Project - New Project” dialog, the Directory will now be filled in, with a 
default Name for the application set to “restaurantWeb”.  

Import restaurantWeb project  

 

 

7. Select Web Project from the right hand pane. 

8. Ensure that the Copy into Application Directory check box is selected. 

9. Click Import. 

You can also choose to import the restaurantWeb_After project to see the final version. The 
BEA Sample Workshop Mobility Project Guide document explains the steps to mobilize the 
restaurantWeb project to reach the same results as in the restaurantWeb_After project. 
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Create the Portal Domain and Create the Sample Mobility Portal 
Project 

Introduction 
This section describes creating a BEA Portal Domain, creating a new application, and then 
creating a Sample Mobility Portal Project in the newly created domain using the supplied 
template. 

Create the MobilityPortal Domain 
To create the MobilityPortal Domain: 

1. Launch the BEA WebLogic Configuration wizard from the Windows Start menu. Choose   
Start → Programs → <BEA install directory> → Configuration Wizard. If you have 
BEA Workshop open, you can also launch it from the tools menu; choose Tools → 
WebLogic Server → Configuration Wizard. 

2. The “Create or Extend a Configuration” dialog is displayed. 

Configuration Wizard – Create a new WebLogic Configuration  

 

 

3. Select Create a new WebLogic configuration and click Next. 
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4. The “Select a Configuration Template” dialog is displayed. 

Configuration Wizard – Basic WebLogic Portal Domain  

 

 

5. Select Basic WebLogic Portal Domain and click Next. 
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6. The “Choose Express or Custom Configuration” dialog is displayed.  

Configuration Wizard – Express Configuration  

 

 

7. Select Express and click Next. 
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8. The “Configure Administrative Username and Password” dialog is displayed.  

Configuration Wizard – User Name and Password  

 

 

9. Enter “weblogic” for the username and “weblogic” for the password and click Next. 

BEA WebLogic Mobility Server Installation Guide - 27 



1—Install WebLogic Mobility Server on MS Windows 2000 

10. The “Configure Server Start Mode and Java SDK” dialog is displayed.  

Configuration Wizard – Start Mode  

 

 

11. Select Development Mode within the WebLogic Configuration Startup Mode section. 

12. Select the Sun JDK within the Java SDK Selection section and click Next. 
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13. The “Create WebLogic Configuration” dialog is displayed. 

Configuration Wizard – Mobility Portal  

 

 

14. Set the Configuration Name to “MobilityPortal” and click Create. 
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15. The configuration wizard will now create the domain. 

Configuration Wizard – Creating MobilityPortal Configuration  

 

 

16. When it completes, click Done on the Creating Configuration screen. 

 

30 - BEA WebLogic Mobility Server Installation Guide 



1—Install WebLogic Mobility Server on MS Windows 2000 

Create the MobilityPortalApp Application 
To create the MobilityPortalApp application: 

2. To create a new application in Workshop, choose File → New → Application  

2. The New Application dialog is displayed. 

Create New Application  

 

 

3. From the New Application window: 

• Select Portal Application. 

Note: Do not select Default Application as per earlier. 

• Click Browse next to the Directory field and browse the Domains directory, selecting 
your newly created “MobilityPortal” domain. 

• Enter “MobilityPortalApp” in the Name field – this is the application where you will 
import the sample mobility portal application. 

• Click Browse next to the Server field and select the config.xml file inside the newly 
created “MobilityPortal” domain. 
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4. Once you have filled in the fields as above, click Create and the application will be created. 

Create Portal Application Dialog  

 

 

Now that you have created a new Domain and a new Portal Application, you can import the 
sample Workshop mobility portal project. 
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Create the Sample Workshop Mobility Portal Project 
When WebLogic Mobility Server was installed, a Sample Mobile Portal Project template was 
created. Create the sample Workshop mobility portal project using this template as described 
below and then refer to the BEA Sample Mobility Portal Guide for an explanation of the features 
of the sample portal.  

1. Right click the newly created “MobilePortalApp” application in the Application tree window. 

New Portal Project  

 

 

2. Choose New → Project. 
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3. The “New Project” dialog is displayed.  

Create New Project  

 

 

4. Select “Mobility” and “Sample Mobile Portal”. 

5. Enter “maportal” in the Project Name field. 

6. Click Create. 

The BEA Sample Mobility Portal Guide document explains the features of the “maportal” sample 
project. 
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Configure the Device Emulators 
This section describes how to configure the emulators for use within BEA Workshop. You can 
use the device emulators to see how the mobilized content will look on a particular device (for 
example phones, PDAs). Several emulators are available for download free of charge on the 
Internet. This section describes how to configure the emulators for use within BEA Workshop. 

1. To configure the tools and emulators for usage within the BEA Workshop environment, 
select IDE properties from the Tools Menu. Choose Tools → IDE Properties 

Select IDE Properties  

 

 
 

2. Now configure the emulators: 

3. Select the Emulators tab. 

4. Select WAP1.x emulator by browsing to the appropriate emulator executable file. 

Note: It is recommended that you use the Openwave Emulator, which can emulate WAP 1.x 
and XHTML-MP devices. However, emulators from Nokia, Ericsson, or others can also be 
used. If using an Openwave Emulator, select the OSDK62http.exe (for version 6.2) or the 
OSDK61http.exe (for version 6.1) in the installation directory where the emulator is installed, 
for example C:\Program Files\Openwave\SDK 6.1\program\http. 

5. Select WAP2.0 emulator by browsing to the appropriate emulator executable file. 
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6. Select PDA emulator by browsing to the appropriate emulator executable file. 

• You can find a PDA emulator at <bea>\weblogic81\mobility\tools\emulators\PDA.exe 

• Alternatively, to set up MS Internet Explorer to function as a PDA emulator, browse to 
your iexplore.exe in the PDA emulator text box as can be seen in the diagram below and 
select the Override device recognition to force PDA content check box.  

Setting up Internet Explorer as a PDA Emulator  

 

36 - BEA WebLogic Mobility Server Installation Guide 



Next Steps 

Next Steps 
Now that you have successfully installed WebLogic Mobility Server, you are almost ready to 
begin mobilizing your own web applications and portal projects.  

Before you do, it is recommended that you go through the BEA Mobilize Your Portal Guide, the 
BEA Sample Workshop Mobility Project Guide and the BEA Sample Mobility Portal Guide after 
using this guide. The BEA Mobilize Your Portal Guide explains how to mobilize a portal, the 
BEA Sample Workshop Mobility Project Guide provides a step-by-step exercise in mobilizing a 
sample workshop application, and the BEA Sample Mobility Portal Guide illustrates the features 
of a Mobilized BEA Portal Framework.
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2—Install WebLogic Mobility Server on Sun Solaris, 
RedHat Linux or HP-UX 
This chapter explains the installation procedure for installing WebLogic Mobility Server on Sun 
Solaris, Redhat Linux, and HP-UX 11. 

Introduction 
• The mobilityServer33_linux.bin installation application is used to install WebLogic Mobility 

Server on RedHat Linux 

• The mobilityServer33_solaris.bin installation application is used to install WebLogic 
Mobility Server on Sun Solaris 

• The mobilityServer33_hpux.bin installation application is used to install WebLogic Mobility 
Server on HP-UX 

License 
A BEA WebLogic Mobility Server license file must be integrated into the bea.license file of your 
WebLogic Server. 

Your sales representative should provide this file to you along with the product CDs.  Please 
contact your sales representative if you have not yet received your license file. 

Once you have updated your license, you will be able to develop and test mobile-device ready 
content. If you have a developer or evaluation license, the software installer will install an 
evaluation version of the Device Repository enabling testing on a number of popular device 
emulators as well as a number of popular mobile and PDA devices.  A production license must be 
present to install and use the full Device Repository. Note: An invalid license will result in 
HTML being delivered. 

Please contact a sales representative if you wish to extend your evaluation or developer license or 
upgrade to a production license. 

Installation Prerequisites 

Software Prerequisites 
The following software must be installed prior to installing WebLogic Mobility Server: 

• A supported operating system, from the following list: 

• Sun Solaris 10 

• RedHat Linux 2.1, 3.0 

• HP-UX 11 

• An application server: BEA WebLogic Platform 8.1 SP2, SP3, SP4 or SP5 

• An Internet Browser:  

• Netscape 4.75 or higher, or 

• Internet Explorer 5 or higher 
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• A database, from the following list (optional):  

• Oracle 9i, 10i 

• PointBase 4.4 

• Postgres 7.3.2+ 

• MySQL 3.53 and above 

• SQL Server 2000 

• Sybase Adaptive Server Enterprise 12.5 

• IBM DB2 Universal Database 8.1 

• Java JDK/JRE 1.4.x must be on the search path, with JAVA_HOME set correctly 

• A PDF viewer—either Adobe Acrobat Reader 4.0.x – 7.0.x or Xpdf is required on the search 
path; otherwise an error message will be displayed when you attempt to view PDF documents 

Installation Procedure for Sun Solaris, RedHat Linux, and HP-UX 

1. Open an xterm, telnet, or console window and run the WebLogic Mobility Server 
installation application: 

• For RedHat Linux, use the mobilityServer33_linux.bin installer 

• For Sun Solaris, use the mobilityServer33_solaris.bin installer 

• For HP-UX, use the mobilityServer33_hpux.bin installer 

2. The first stage of the installation is the “Introduction”. Press <Enter> to continue. 

3. The “Supported Platforms” screen then is displayed. Please read this and ensure that the 
installation environment meets the stated requirements. Press <Enter> to continue. 

4. The following stage of the installation is “Choose Product Features”. Enter the value 1 to 
select the WebLogic Mobility Server 3.3 installation, or the value 2 to select the WebLogic 
Mobility Server Client Applications installation. 

5. The “License Agreement” screen is displayed next. Read the license agreement text and enter 
the value Y if you accept the terms of the license agreement, or the value N if you do not  

Note: Selecting “N” will cancel the installation after prompting you to confirm cancellation. 

6. The “Choose Java Virtual Machine” stage is next. You must select a Java Virtual Machine 
for use by the installed application.  

• Enter the value 1 to select the specified default JVM 

• Enter the value 2 to select another Java VM. Note: This must be Java VM version 1.4. 
You will then be prompted to enter the absolute path to the Java VM executable and confirm 
that the path you have entered is correct by entering Y 

7. The “Choose Install Folder” stage is next. You must enter an absolution path to the location 
where WebLogic Mobility Server should be installed.  Alternatively, press <Enter> to 
accept the default location as shown. You must then confirm the Install Folder location by 
entering Y.  

Note: You must have write and execute permissions for the chosen installation folder. 
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8. The “Pre-Installation Summary” stage is next. Review the displayed installation configuration 
settings to ensure they are correct. If you are satisfied with the configuration settings, press 
<Enter> to continue. Otherwise, type back to return to a previous step and modify the 
configuration settings. 

9. The “Installation Complete” message will display following a successful install. Press 
<Enter> to exit the installer. 
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Next Steps 
Configuration of a WebLogic Mobility Server-Enabled Web 
Application 
Please see the BEA WebLogic Mobility Server Administration Guide for details on: 

• Creating the deployment environment for a mobilized web application 

• Configuring the WebLogic Mobility Server servlet filter 

• Configuring the web application’s Web Deployment Descriptor (web.xml file) for the 
WebLogic Mobility Server servlet filter 

Mobilize Your Own Applications  
Once you have installed and configured the product and the Device Repository, you will be ready 
to mobilize your own web applications. Please see the BEA WebLogic Mobility Server User 
Guide, specifically the “Working with Diagnostics” section, for information on configuring and 
using the Diagnostics tools. 
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