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C H A P T E R 1

About BEA Guardian

This chapter provides an overview of Guardian components, features, and key concepts. Also 
provided are basic instructions for using and navigating the Guardian User Interface and Online 
Help System. Topics include the following:

Introduction

Guardian User Interface

Guardian Online Help System

Guardian Command Line Interface

Key Concepts

Security

Privacy

Key Tasks

Example Scenarios

Supported Configurations

Supported Targets
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Introduction
What is Guardian?
Guardian is a diagnostic tool for identifying potential problems in your environment before they 
occur, and provides specific instructions for resolving them. Guardian is like having the entire 
BEA Customer Support Team scrutinize your domain and immediately present their findings and 
recommendations to you, at your convenience.

How do you use it?
First, activate one or more Domains in Guardian. A domain is a logically related group of 
WebLogic Server resources that you manage as a unit. You can also organize multiple domains 
into Domain Groups. Then, select one or more domains, select a Signature Bundle, and launch 
an Evaluation. Guardian then proceeds to evaluate the Signature Bundle against the specified 
domain(s), and generates a detailed report of potential issues and their remedies. You can then 
review the report and decide how to proceed. 

Where can I run it?
Guardian can run on Windows or Linux systems that have Java Version 5 or higher installed. 
Guardian can evaluate any platform based on WebLogic Server version 8.1 through 10.3, 
regardless of the operating system on which it is running. 

Guardian User Interface
This section provides an overview and basic navigation instructions for the Guardian User 
Interface. For a complete, detailed description of all interface components, see Chapter 3, 
“Reference.” For detailed instructions for specific Guardian tasks, see Chapter 2, “Tasks.”

In general, you will use the Guardian User Interface to perform the majority of Guardian tasks 
and activities. For some highly repetitive or complex tasks—for example, activating multiple 
Guardian domains in multiple Guardian instances—you may want to create a Guardian 
Command Line Interface (CLI) script to automate a series of tasks. For basic instructions on using 
the CLI, see “Command Line Interface” on page 73 on Chapter 2, “Tasks.” For a detailed 
description of all CLI commands and syntax, see “Command Line Interface” on page 134 of 
Chapter 3, “Reference.”
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The sections below provide a description and basic navigation instructions for each of the 
following elements: 

Guardian Main Window

– Main Menu Bar

– Main Toolbar

– Navigation Pane

– Document Pane

– Document View and Editor Titlebars

– Context Menus

Wizards

– Wizard Titlebar Menus

For a complete detailed description of the Guardian User Interface, see Chapter 3, “Reference.”

Guardian Main Window
The Guardian Main Window contains the following basic navigation and display components:

Main Menu Bar

Main Toolbar

Navigation Pane

– Explorer Tabs

– Explorer Toolbar Icons

– Explorer Toolbar Menus

Document Pane

– Document Views and Editors

– Document View and Editor Titlebars

Context Menus

The following sections provide instructions for using each of these components.
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Main Menu Bar
The Main Menu Bar is at the top of the BEA Guardian main window just below the BEA 
Guardian titlebar. The Menu Bar contains the following menus:

File Menu

Tools Menu

Window Menu

Help Menu

The Menu Bar menus in turn contain a series of options and submenus, some of which also lead 
to additional menus, dialog boxes, or wizards. The following sections provide an overview of 
each of these menus, and instructions for invoking them.

Keyboard Shortcuts
You can invoke many menus, submenus, and menu options by using a keyboard shortcut. To 
display Menu Bar menus, press the Alt key and type the menu selection key for the menu you 
want to display. The menu selection key is the letter underlined in the menu name when you press 
the Alt key.

Some menu options also have keyboard shortcuts, which consist of a specific sequence of 
characters pressed simultaneously. If a menu item has a keyboard shortcut, the key sequence is 
listed next to the item in the menu. To see the complete list of keyboard shortcuts, press 
Ctrl+Shift+L.
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File Menu
Table 1-1 describes the File menu options and submenus.

Table 1-1  File Menu

Menu Item Description

New > This option opens a submenu with the following options:
• Domain Group — Open the Add Domain Group dialog box for 

creating a new Domain Group.
• Domain — Open the Domain Activation Wizard.
• Inventory — Open the Inventory Wizard.
• Evaluation — Open the Evaluation Wizard.
• Shortcut — Open the Shortcut Wizard.

Close Close the current display in the Document Pane.

Close All Close all Document Pane displays.

Save As... Export the selected Domain Inventory or Evaluation as a file (PDF or 
HTML).

Print Print the contents of the Report tab or Source tab currently displayed in 
the Document Pane.

Import Open the Import dialog box for importing Guardian Preferences, 
Workspace, or Report Plug-in.

Export Open the Export dialog box for exporting Guardian Preferences, 
Workspace, or Report Plug-in.
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Tools Menu
Table 1-2 describes the Tools menu options and submenus.

Table 1-2  Tools Menu

Menu Item Description

Refresh Site List Update the list of BEA Support site identifiers available for creating 
support cases.

Purge Inactive 
Domains

Removes deactivated domains from the Domain Explorer and the 
Guardian Registry. This also removes the Domain Inventories, 
Evaluation Summaries, and any Case Creation Archives for those 
domains from the Guardian Workspace.

View Log > This opens a submenu with the following options:
• Signature Log — Display the Guardian Signature log file.
• Guardian Log — Display the Guardian log file.
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Window Menu
Table 1-3 describes the Window menu options and submenus.

Table 1-3  Window Menu

Menu Item Description

Show View Open a submenu containing options for opening the following Views:
• Domain Explorer — Opens the Domain Explorer in the Navigation 

Pane.
• Bundle Explorer — Opens the Bundle Explorer in the Navigation 

Pane.
• Shortcut Explorer — Opens the Shortcut Explorer in the 

Navigation Pane.
• Signature Explorer — Opens the Signature Explorer in the 

Navigation Pane.
• Active Domains Table — Opens the Active Domains Table in the 

Document Pane.
• Shortcuts Table — Opens the Shortcuts Table in the Document 

Pane.
• Progress View — Opens the Progress View in the Navigation Pane.
• Outline View — Opens the Outline View to the right of the 

Document Pane.

Reset Perspective Resets the Guardian displays to their default settings.

Preferences... Open the Preferences configuration page.
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Help Menu
Table 1-4 describes the Help menu options and submenus.

Table 1-4  Help Menu

Menu Item Description

Welcome Display the Guardian Welcome page. 

Help Contents Open the BEA Guardian Online Help System.

Search Open the Online Help Search utility.

Dynamic Help Opens the Guardian Dynamic Online Help pane (to the right of the 
Document Pane).

Cheat Sheet... Open the Cheat Sheet Selection dialog box for selecting and displaying 
a Guardian Cheat Sheet. The Cheat Sheet provides step-by-step 
instructions for certain Guardian tasks. Action buttons are provided for 
some tasks; click a button to initiate that task.

Manage Guardian > Open a submenu with the following options:
• Update Guardian — Open the Update Wizard.
• Manage Configuration — Open the Product Configuration 

Manager for performing the following tasks:
– Scan for Updates
– View Installation History
– Show Activities
– Add an Extension Location

Key Assist... Display the list of keyboard shortcuts.

Software Updates > Open a submenu with the following options:
• Find and Install... — Open the Install/Update dialog box for 

searching for and installing updates and new features.
• Manage Configuration — Open the Product Configuration 

Manager.

About BEA Guardian Open the About BEA Guardian dialog box. This displays the version of 
your current Guardian installation, and details about Guardian features, 
plug-ins, and configuration.
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Main Toolbar
The Main Toolbar is located below the Main Menu, and contains action buttons for the most 
common Guardian tasks. To identify a button, move your mouse pointer over the button; this 
displays the tool tip text for that button. 

Table 1-5 describes the Main Toolbar buttons.

Table 1-5  Guardian Main Toolbar Buttons

Button Description

Open Display the selected resource in the Document Pane.
• Open Active Domain Table when Target Domains is selected in the 

Domain Explorer.
• Open Domain Inventory when a Domain Inventory is selected in the 

Domain Explorer.
• Open Evaluation Summary when an Evaluation Summary is 

selected in the Domain Explorer. 
• Open Signature Details when a signature is selected in the 

Signature Explorer or Bundle Explorer. 
• Open Bundle Details when a bundle is selected in the Bundle 

Explorer. 
• Open Evaluation Wizard when a shortcut is selected in the Shortcut 

Explorer. 

Print Print the contents of the Report tab or Source tab currently displayed in 
the Document Pane.

Activate Open the Domain Activation Wizard.

Inventory Open the Inventory Wizard.

Evaluate Open the Evaluation Wizard.

Update Open the Update Wizard.
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Navigation Pane
The Navigation Pane resides in the left side of the BEA Guardian main window. The Navigation 
Pane contains several tabs leading to Explorer Views. You can have multiple Views open at once, 
but only one can be displayed at a time. Click on a tab to display an Explorer view. 

Explorer Tabs
Table 1-6 describes the Navigation Pane Explorer View tabs:

For a detailed description of each of the Explorer views, see “Navigation Pane” on page 93 of 
Chapter 3, “Reference.”

Table 1-6  Navigation Pane Explorer Tabs

Explorer Tab Description

Domain Explorer Open the Domain Explorer. This View enables you to browse, manage, 
and administer the domains you have defined in Guardian. Right-click in 
the Domain Explorer to open a context menu of domain operations. For 
instructions on Domain Explorer tasks, see “Domains” on page 47 in 
Chapter 2, “Tasks.”

Signature Explorer Open the Signature Explorer. This View enables you to browse the 
available signatures and view Signature Details for a selected signature. 
For instructionson Signature Explorer tasks, see “Signatures” on 
page 62 in Chapter 2, “Tasks.”

Bundle Explorer Open the Bundle Explorer. This View enables you to browse the 
available Signature Bundles and their contents. For instructions on 
Bundle Explorer tasks, see “Bundles” on page 69 in Chapter 2, “Tasks.”

Shortcut Exporer Open the Shortcut Explorer. This View enables you to view and manage 
your Evaluation Shortcuts. For instructions on Shortcut Explorer tasks, 
see “Shortcuts” on page 70 in Chapter 2, “Tasks.”
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Explorer Toolbar Icons
Below each Explorer titlebar is the Explorer toolbar. An Explorer toolbar may contain all or some 
of the following active icons:

Explorer Toolbar Menus
The Domain Explorer, Signature Explorer, and Bundle Explorer each contain a Menu icon in 
the right corner of the toolbar. Click the Menu icon to display a menu of operations for that 
Explorer. 

Table 1-8 describes the Explorer menus.

Table 1-7  Explorer Toolbar Icons

Icon Function

Close

Minimize

Maximize

Restore

Expand all items.

Collapse all items.

Open Explorer menu.

Link selected item with Editor.
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Document Pane
The Document Pane is located in the central portion of the BEA Guardian main window. The 
Document Pane displays the Document Views and Editors.

Document Views and Editors
Table 1-9 describes the Guardian Views and editors that can be displayed in the Documentation 
Pane.

Table 1-8  Explorer Menus

Explorer Menu Options

Domain Explorer The Domain Explorer menu contains the following options:
• Filter Domain Explorer — Open the Filter Domain Explorer 

dialog box to filter inventories and evaluations by date created. 
• Link with Editor — Link the selected item with an Editor.

Signature Explorer The Signature Explorer menu contains the following options:
• Sort Signatures > — This opens a submenu of the following options 

for sorting signatures:
– By Name
– By Severity

• Filters... — Open the Filters dialog box for filtering signatures in 
Signature Lists. For instructions, see “Filter Signatures” on 
page 63 in Chapter 2, “Tasks.”

• Link with Editor — Link the selected item with an Editor.

Bundle Explorer • Filters... — Open the Filters dialog box for filtering signatures in 
Signature Lists. For instructions, see “Filter Signatures” on 
page 63 in Chapter 2, “Tasks.”

• Sort Signatures > — This opens a submenu of the following options 
for sorting bundles and signatures in the Bundle Explorer:
– By Bundle Name, Signature Name
– By Bundle Name, Severity

• Link with Editor — Link the selected item with an Editor.
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Table 1-9  Document Pane Views and Editors

View/Editor Description

Active Domain Table Select Window > Show View > Active Domains Table to display this 
View. This contains a table of all of the domains currently activated in 
Guardian, and action buttons for the following tasks:
• Open Admin Console — Open an instance of the WebLogic Server 

Administration Console.
• Modify Domain — Open the Domain Properties configuration 

page for the selected domain.
• Deactivate Domain — Open the Domain Deactivation Wizard for 

the selected domain(s).

Domain Inventory Double-click on a Domain Inventory entry in the Inventory History 
folder in the Domain Explorer to display the Inventory Details for that 
inventory. The inventory includes descriptions of your servers, Java 
Virtual Machines, operating systems, databases, product versions, and 
certain configuration settings. The Domain Inventory View contains the 
following tabs:
• Overview — Display the Domain Inventory Overview for this 

Inventory.
• Source — Display the XML source for the Inventory.
• Report — Display the Domain Inventory report for this inventory.

Evaluation Summary Double-click on an Evaluation Summary entry in the Evaluation 
History folder in the Domain Explorer to display that Evaluation 
Summary. This contains a table of all detected signatures for the 
evaluated domain. Select a signature in the list to display the signature 
details and remedy for that signature.

Shortcut Table Select Window > Show View > Shortcuts Table to display this View. 
This contains a table of all of your Shortcuts, and action buttons for the 
following tasks:
• Add Shortcut — Open the Shortcut Wizard for creating Shortcuts.
• Delete Shortcut — Delete the selected Shortcut. A Confirm Delete 

dialog box prompts you to confirm the delete operation. Click OK to 
delete the Shortcut.
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Note: You can have multiple Views or Editors open in the Document Pane, but only one can be 
active at a time.

Document View and Editor Titlebars
Each View and Editor has a titlebar that contains the name of the View or Editor, an identity icon, 
and buttons to close, minimize, maximize, and restore the display.

You can also use View and Editor titlebars to do the following:

Double-click the titlebar to maximize a View or Editor, and double-click it again to restore 
it to its original size. 

Right-click on a titlebar to open the System Menu for that View or Editor.

You can group multiple Views or Editors together on a titlebar as a tab group. Tab groups 
can be moved together as a unit, using either the System Menu > Move menu option or 
drop cursors. Only the titlebar of the currently active View or Editor is visible in a tab 
group.

If you have more Views or Editors open than can fit on a titlebar, a Show List icon appears 
to the right of the titlebar tabs. The icon includes a number that indicates how many more 
of the open Views or Editors can fit on the titlebar. Click the icon to display a list of all the 
titlebar Views and Editors. Select an item from the list to make it active and bring it to the 
forefront of the Navigation Pane or Document Pane display. The items listed in bold font 
are those that cannot fit on the titlebar. The items not listed in bold are those that are 
already shown on the titlebar.

Signature Details Double-click on a signature entry in the Signature Explorer or Bundle 
Explorer. This View contains the following tabs:
• Overview — Display the Signature Overview for the signature.
• Source — Display the XML source for the signature.
• Report — Display the Signature Report for that signature.

Bundle Details Double-click on a Bundle node in the Bundle Explorer. This View 
provides a description and some additional details about the selected 
Bundle. Also included is the Signature Definition for the Bundle.

Table 1-9  Document Pane Views and Editors

View/Editor Description
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You can move Views or Editors by dragging their titlebars to different locations. 

– You can move the Views in the Navigation Pane almost anywhere, including outside 
the BEA Guardian main window. However, you can move Editors only within the 
Document Pane.

– As you drag a View or Editor titlebar, the mouse pointer changes into a drop cursor 
that indicates where the View or Editor will appear when you release it.

– The point in the titlebar at which you click determines what will be dragged. Click a 
View or Editor tab to move that View or Editor, but not the whole tab group. To move 
the whole tab group, click to the right of the tabs in the title bar, or select Move > Tab 
Group from the System Menu.

Context Menus
Many views and displays contain context menus. Right-click on an item or anywhere in a display 
to open the associated context menu. For a complete description of context menus, see Chapter 3, 
“Reference.”
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Wizards
BEA Guardian provides the several wizards for guiding you through some of the more complex 
or common Guardian tasks. 

Table 1-10 describes the Guardian wizards and how to invoke them.

Table 1-10  Guardian Wizards

Menu Item Description

Domain Activation Wizard Click Activate to open the Domain Activation Wizard. This 
contains fields and options for configuring and activating a 
domain in Guardian. For instructions on using this wizard, see 
“Activate Domain” on page 47 in Chapter 2, “Tasks.”

Domain Deactivation Wizard In Domain Explorer, right-click on a domain entry and select 
Deactivate Domain from the context menu to open this 
wizard. This contains a table of all active domains. For 
instructions on using this wizard, see “Deactivate Domain” on 
page 49 in Chapter 2, “Tasks.”

Evaluation Wizard Click Evaluate to open the Evaluation Wizard for evaluating 
one or more domains. For instructions on using this wizard, see 
“Evaluate Domain” on page 57 in Chapter 2, “Tasks.”

Support Case Wizard Select a signature in an Evaluation Summary and click Get 
more help from BEA support. This opens the Support Case 
Wizard for the selected signature. This enables you to create 
and submit a support case based on the selected signature. For 
instructions on using this wizard, see “Submit Support Case” 
on page 78 in Chapter 2, “Tasks.”

Inventory Wizard Click Inventory to open the Inventory Wizard. A Domain 
Inventory is a snapshot of all of the configuration details for a 
domain as it exists at that moment. For instructions on using 
this wizard, see “Inventory Domain” on page 56 in Chapter 2, 
“Tasks.”

Shortcut Wizard Select File > New > Shortcut to open the Shortcut Wizard for 
creating and modifying Shortcuts. For instructions on using 
this wizard, see “Create Shortcut” on page 70 in Chapter 2, 
“Tasks.”
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For a detailed description of each of the Guardian Wizards, see “Wizards” on page 116 of 
Chapter 3, “Reference.”

Wizard Titlebar Menus
Right-click a wizard titlebar to open a context menu of options to Move, Size, or Close the 
wizard. You can also move or resize a Wizard by dragging the titlebar or window borders.

Guardian Online Help System
The Guardian Online Help system has the following structure:

About BEA Guardian — This section provides an overview of Guardian components, 
features, and key concepts. Also provided are basic instructions for using and navigating 
the Guardian User Interface and Online Help System.

Tasks — This section provides detailed instructions for Guardian tasks and procedures. 
Tasks are categorized according to the component or feature to which they apply. The 
Tasks Help folder contains a number of subfolders, one for each task category. Expand a 
category folder to see the tasks relating to that topic.

Shortcut Evaluation Wizard Click the Shortcut Explorer tab to open the Shortcut 
Explorer. Then, double-click on a Shortcut name in the 
Shortcut list to open the Shortcut Evaluation Wizard. For 
instructions on using this wizard, see “Evaluate Shortcut” on 
page 72 in Chapter 2, “Tasks.”

Update Wizard Click Update to open the Update Wizard. This wizard 
enables you to automatically download new BEA Guardian 
software and signatures from the BEA Guardian update site. 
For instructions on using this wizard, see “Automatically 
Update Guardian” on page 81 in Chapter 2, “Tasks.”

WARNING: Upgrading from Guardian 1.0.x to Guardian 1.1 
must be done manually. For instructions, see “Manually 
Update Guardian” on page 83 and “Manually Update Guardian 
Registry” on page 86 in Chapter 2, “Tasks.”

Table 1-10  Guardian Wizards

Menu Item Description
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Reference — This section provides a detailed description of the Guardian User Interface 
components and features, and a detailed reference guide to the Guardian Command Line 
Interface.

Guardian Command Line Interface
The Guardian Command Line Interface is a command interpreter that is an executable .cmd 
batch file for Windows, and a .sh shell script for Linux. Both the Windows batch file and the 
Linux shell script are wrappers that accumulate and organize arguments to the Java command. 
You can invoke the Command Line Interface from a Windows Command Prompt window or a 
Linux terminal window. 

For basic instructions on using the CLI, see “Command Line Interface” on page 73 on Chapter 2, 
“Tasks.” For a detailed description of all CLI commands and syntax, see “Command Line 
Interface” on page 134 of Chapter 3, “Reference.”

Key Concepts
This section provides an overview of Guardian components, features, and key concepts. These 
include:

Guardian Agent

Guardian Workspace

Guardian Registry

Domain

Domain Groups

Domain Inventory

Signature

Signature Bundle

Signature Annotations

Evaluation

Snapshot Evaluation

Evaluation Summary



Key  Concepts

BEA Guardian User Guide 1-19

Signature Repository

Shortcut

Support Case

Guardian Agent
The Guardian Agent is a lightweight web application that gathers the data used for evaluations.

The Guardian Agent collects the following data:

JMX data

Java system properties

Database metadata for your JDBC connection pools

J2EE Deployment Descriptors from WebLogic instances

JRockit JMAPI data

JRockit Runtime Analyzer data

JRockit thread dump data

Multiple Guardian Agent Threads
If you have one or more managed servers in a domain, the Guardian Agent spawns the appropriate 
number of threads for communicating between the Guardian Agent on the WebLogic 
Administration Server, and the Guardian Agent running on the Managed Server(s).

An excessive number of threads can affect the performance of the Administration Server, so 
Guardian enables you to specify the maximum number of Agent threads that can be spawned. In 
addition, in order to manage Agent resources on both the Administration and Managed Servers, 
you can specify the maximum amount of time (in seconds) that can elapse before a thread is 
terminated. For instructions, see “Configure Maximum Agent Threads” on page 39 and 
“Configure Agent Thread Timeout” on page 40 in Chapter 2, “Tasks.”



About  BEA Guard ian

1-20 BEA Guardian User Guide

Guardian Workspace
The Guardian Workspace is the directory in which all of your Guardian data is stored. It includes 
the following data for each domain you have defined in Guardian:

Preferences

Domain Inventories

Evaluation Summaries

When you invoke Guardian, you are prompted to select a location for your Guardian Workspace. 
To prevent loss of work when Guardian is updated or uninstalled, select a Workspace location 
outside of the Guardian installation directory (see “Select Workspace” on page 41).You can also 
safely back up your Workspace data by exporting your Workspace to a file also located outside 
of your Guardian Installation directory. For instructions, see “Export Workspace” on page 42 of 
Chapter 1, “About BEA Guardian.”

Although the documents in the Guardian Workspace are persisted as XML files, they are best 
viewed through the Guardian User Interface. The Guardian User Interface provides a number of 
tools for viewing, managing, and processing your data, as well as better protection against 
unintended edits or deletions. For basic instructions on using the interface, see “Guardian User 
Interface” on page 2. For a detailed description of Guardian User Interface components and 
features, see Chapter 3, “Reference.” See Chapter 2, “Tasks,” for detailed instructions for using 
the interface to perform specific Guardian tasks.

Guardian Registry
The Guardian Registry is an XML document in which your BEA Guardian configuration 
specifications are maintained. The Guardian Registry is created during product installation, and 
updated whenever you modify your configuration or perform certain Guardian operations. The 
Guardian Registry identifies the domains you have activated, the Signature Bundles available for 
evaluation, the Shortcuts you have defined, and your Guardian Workspace location(s). 

Domain
A domain is a logically related group of WebLogic Server resources that are managed as a unit. 
A domain always includes at least one WebLogic Server instance called the Administration 
Server. The Administration Server acts as a central point of contact for server instances and 
system administration tools. A domain may also include additional WebLogic Server instances 
called Managed Servers. 
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Each BEA Guardian installation maintains a Guardian Registry of active domains. A domain is 
considered active when it is capable of being evaluated. You can activate and deactivate domains 
at will, and select which to evaluate at any given time.

Domain Groups
You can organize the domains in Guardian into Domain Groups for easier management. For 
instructions on creating and managing Domain Groups, see “Domain Groups” on page 52 in 
Chapter 2, “Tasks.”

Domain Inventory
A Domain Inventory is an XML document that describes the products in a Guardian domain. The 
inventory includes descriptions of your servers, Java Virtual Machines, operating systems, and 
databases. The descriptions include product versions as well as some configuration settings.

A Domain Inventory is created when you activate or evaluate a domain. The Inventory History 
is also refreshed each time a domain is evaluated. You can use the Domain Inventory Wizard 
in the Guardian User Interface to define and generate a new Domain Inventory. 

Domain Inventory files are stored and maintained in your Guardian Workspace. You can use the 
Domain Explorer in the Guardian User Interface to view and manage Domain Inventories. 

Signature
BEA Support has identified patterns in user domains that can cause problems. These patterns are 
described in XML documents called signatures.

Signatures describe potential problems based on information about your BEA WebLogic Servers 
and the environment in which they are deployed, including Java Virtual Machines (JVMs), 
operating systems, and databases. Signatures contain executable logic that can identify specific 
versions of these products as well as their configuration settings.

In addition to the potential problem description, signatures also contain a remedy 
recommendation and a severity level: 1-Critical, 2-Warning, or 3-Info.

To detect which signatures apply to your domain, you conduct an evaluation. When the 
evaluation is complete, the results are displayed in an Evaluation Summary. The Evaluation 
Summary lists all of the detected signatures, along with the severity level, description, and 
recommended remedy for each.
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Signatures form a primary component of BEA Guardian, since they contain the distilled 
knowledge of BEA Support for both detecting potential problems and resolving them.

Signature Bundle
A Signature Bundle is a group of signatures that are evaluated together against one or more 
specified domains. You can select which bundle to evaluate against which domain(s). Bundles 
determine the signatures—and consequently, the potential issues—for which to search. The 
domain(s) you specify determine where to search.

Signature Annotations
Signature Annotations enable you to tag a detected signature with one or more persistent 
annotations about that signature. 

An annotation contains the following information:

Type — This indicates the Annotation Type. There are two types: Ignore and Flag. 

Name — (Optional) This is a text field into which you can enter a short name for this 
annotation.

Comment — This is a text field into which you can enter comments or other notes about 
the signature. 

Timestamp — This records the date and time the annotation was created.

Domains — This specifies the Annotation Target for this annotation for this signature. 
This can be All Domains, This Domain, or This Evaluation. 

Evaluations — (Automatic) This specifies the Evaluation(s) to which this annotation 
applies for this signature.

You can use the Annotations Wizard to create, edit, and delete annotations. For instructions, see 
“Signature Annotations” on page 64 in Chapter 2, “Tasks.” 

In addition, you can use Signature Filters to specify which annotated signatures are to be 
displayed in the Signature Explorer, Bundle Explorer, and Evaluation Summaries. For 
instructions, see “Filter Annotated Signatures” on page 68 in Chapter 2, “Tasks.” For complete 
instructions on using filters, see “Filter Signatures” on page 63 in Chapter 2, “Tasks.” 
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Evaluation
To detect which signatures apply to your domain, you conduct an evaluation. When the 
evaluation is complete, the results are displayed in an Evaluation Summary. The Evaluation 
Summary lists all of the detected signatures, along with the severity level, description, and 
recommended remedy for each.

Snapshot Evaluation
A Snapshot Evaluation is a complete assessment of all of the configuration details for a specific 
domain, at the particular moment the evaluation is executed. 

You can compare two Snapshot Evaluations to see very quickly the differences between 
configurations for two domains, or the same domain at different points in its history. For 
instructions, see “Compare Inventories or Evaluations” on page 60 of Chapter 2, “Tasks.”

Evaluation Summary
The results of an evaluation are displayed in an Evaluation Summary. The Evaluation Summary 
lists all of the signatures from the specified bundle that were detected for the evaluated domain, 
along with the severity level, description, and recommended remedy for each signature.

Signature Repository
The Signature Repository contains the locally persisted store of signatures available for 
evaluation. When you download signatures from the Guardian update site, they arrive in a Java 
Archive (JAR) file. The JAR file is stored in the repository/archives directory of your 
Guardian installation directory.

Shortcut
A Shortcut enables you to streamline the evaluation procedure by predefining and storing the 
domain, Signature Bundle, and other parameters for evaluations that you perform frequently. You 
can then evaluate the Shortcut, saving you the effort of re-entering the parameter values each time 
you want to run the evaluation. 
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Support Case
A support case is a record created when you submit technical questions or issues to BEA Support. 
Customers with a support contract can open a support case on the BEA eSupport website or by 
calling BEA Customer Support.

Guardian enables you to open a BEA Customer Support case directly from a Guardian evaluation. 
When you conduct an evaluation that detects a signature, you can create and submit a support case 
directly from a selected signature in an Evaluation Summary. Guardian automatically creates the 
case and includes all of the information from the signature and submits it, enabling a BEA support 
engineer to begin working on your case right away. You can also add any additional attachments 
and notes before sending the support case to BEA

You also have the option not to submit the case immediately at the time of creation, but rather to 
save the case data as a Case Creation Archive for later submission. Case Creation Archives are 
stored as files with the file name extension .car. 

To learn more about BEA Support and support cases, see the BEA Customer Support Guidebook, 
which you can download from the BEA eSupport website.

Security

Authentication
To safeguard your domains, Guardian requires valid login credentials for all communications 
between Guardian and your Guardian domains. Whenever you conduct an evaluation or activate 
a domain, Guardian prompts you for the username and password of an Administrator or Monitor 
account on the target domain. You can choose to store the username and password so you do not 
have to enter them for every evaluation. All usernames, passwords, and server names persisted 
on disk are encrypted. 

Data Encryption
Any passwords, usernames, or server names persisted on disk are encrypted. This encryption 
helps prevent the disclosure of any clear text data that could compromise the security of your 
domain. SSL encryption is available for communication between Guardian and your domains and 
between Guardian and BEA. Guardian uses 128 bit open source encryption for SSL.
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Secure Transmission
Secure Sockets Layer (SSL) encryption is available for all communication with BEA over the 
Internet, and all communication with Guardian Agents in your target domain(s). Please note that 
Guardian uses 128 bit open source encryption for SSL. If you want to use SSL, there are three 
types of communication to consider:

Target domain communication - To use SSL encryption for communications between 
BEA Guardian and your target domain(s), select the https:// communications protocol 
option in the Domain Activation Wizard. For instructions, see “Activate Domain” on 
page 47 of Chapter 2, “Tasks.”

Signature downloads - To use SSL encryption when downloading signatures from BEA 
Support, select Require SSL in the Guardian Preferences configuration page. This will 
also set SSL encryption for uploading signature usage statistics (see “Privacy” on page 25). 
For instructions on configuring your Guardian preferences, see “Preferences” on page 44 of 
Chapter 2, “Tasks.”

Support case creation - To use SSL encryption when opening support cases with BEA 
Support, select Require SSL in the Guardian Preferences configuration page. For 
instructions on configuring your Guardian preferences, see “Preferences” on page 44 of 
Chapter 2, “Tasks.”

Privacy
When you download signatures into Guardian from BEA Support, BEA collects high level 
statistics about your signature usage, including the number of times each signature was evaluated 
and detected. No customer data is included in the usage statistics. This information is used only 
in aggregate to assess the effectiveness of each signature. This data is crucial to the continuous 
improvement of BEA Guardian.

The signature usage statistics contain the following information:

signature id — This is the unique identifier for the signature. 

type — This is the category of the signature.

fired — This is the number of times the signature was considered for use. This also 
includes the number of times the signature was disqualified before evaluation due to 
targeting products not present on the domain. 
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evaluated — This is the number of times the signature was actually compared against the 
target domain.

detected — This is the number of times the signature was actually found on the target 
domain 

The following is a sample signature usage statistic:

<?xml version="1.0" encoding="UTF-8"?>
<usage>
<signature id="123456.sig" type="Evaluation" fired="30" evaluated="18" 
detected="2" />
<signature id="234567.sig" type="Evaluation" fired="30" evaluated="20" 
detected="1" />
</usage>

Key Tasks
There are many ways to configure and use Guardian to diagnose the health of your domains. 
However, there are four essential tasks that can be considered the primary functions of Guardian. 
These are as follows:

Activate Domain

Inventory Domain

Evaluate Domain

Update Guardian

The following sections provide a brief description of each of these tasks. For a complete 
description of all Guardian tasks and procedures, see Chapter 2, “Tasks.”

Activate Domain
Activating a domain prepares the domain for evaluation and conducts an initial inventory of the 
domain configuration.

To activate a domain, use the Domain Activation Wizard. For instructions, see “Activate 
Domain” on page 26 of Chapter 2, “Tasks.”
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Inventory Domain
A Domain Inventory is a snapshot of all of the configuration details for a domain as it exists at 
that moment. The results are displayed in a Domain Inventory Overview in the Document Pane. 
The inventory is also added to the Inventory History folder in the Domain Explorer. Domain 
Inventories are also generated automatically whenever you activate or evaluate domains.

To inventory a domain, use the Inventory Wizard. For instructions, see “Inventory Domain” on 
page 27 of Chapter 2, “Tasks.”

Evaluate Domain
To detect which signatures apply to your domain, you conduct an evaluation. Guardian collects 
data about your domain environment, and identifies which signatures apply to the domain.When 
the evaluation is complete, the results are displayed in an Evaluation Summary. The Evaluation 
Summary lists all of the detected signatures, along with the severity level, description, and 
recommended remedy for each.

You can review the Evaluation Summary to determine your response to any signatures that are 
detected. If you need more help resolving the potential problem identified by the signature, you 
can use Guardian to create and submit a BEA support case.

For instructions on conducting evaluations, see “Evaluate Domain” on page 27 of Chapter 2, 
“Tasks.” 

Update Guardian
BEA Support Engineers create new signatures every day, and new application enhancements to 
Guardian are also periodically released. The Guardian Update feature enables Guardian to 
connect directly to the Guardian Update site to automatically download and install new signatures 
and product updates. To update Guardian on servers that do not have Internet access, you can 
perform a manual update.

For instructions for performing both automatic and manual updates, see “Updates and Upgrades” 
on page 81 of Chapter 2, “Tasks.” 
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Example Scenarios
The following scenarios are examples of some of the different ways you can use Guardian to find 
problems before they impact your environment.

Scenario 1: Development Cycle Evaluations
As you develop an application and migrate from development to quality assurance to production, 
you can run an evaluation at each stage. Guardian will help ensure that each phase of your 
development process is compliant with BEA best practices.

Scenario 2: Heavy Load Evaluations
Some signatures are designed to evalute runtime domain settings. Running an evaluation under 
heavy load can detect potential problems that would not otherwise be detected. BEA recommends 
conducting these evaluations during load and performance testing.

Scenario 3: Application Update Evaluations
After you update an existing application, you can run an evaluation to assess the deployment. 
Guardian will help you find any potential problems that could impact your upgrade.

Scenario 4: Vendor Software Update Evaluations
After you install a new BEA patch, service pack, or upgrade, or install or upgrade third party 
software, you can run an evaluation to identify any new issues that may have been introduced.

Scenario 5: Post Repair Evaluations
If Guardian earlier detected a signature, and you subsequently applied the remedy or made other 
changes to your system, you can run an evaluation to confirm that the signature is no longer 
detected and no new issues were introduced.

Scenario 6: Post Domain Change Evaluations
If you made changes to your domain configuration or settings, you can run an evaluation to 
confirm that the result is compliant with BEA best practices.
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Scenario 7: Scheduled Overnight Evaluations
If you are concerned about domain settings being incorrectly changed overnight, or your domain 
is approaching certain resource limits, you can schedule evaluations to run overnight. You can 
review the Evaluation Summary in the morning and decide if any detected signatures merit 
further investigation.

Scenario 8: Heartbeat Evaluations
Guardian evaluations are designed to have as minimal an impact on throughput and CPU usage 
as possible. If your domain has extra capacity, you can schedule Guardian to run evaluations at 
regular intervals; for example, every 15 minutes. Then, if any changes are made or certain 
thresholds are reached, you can be notified quickly.

Scenario 9: Diagnostic Evaluations
If you notice a problem on your domain, you can run an evaluation. Even if an earlier evaluation 
detected no signatures, something may have changed since that time to cause the new problem. 
Guardian can be your first line of defense in diagnosing and repairing domain problems.
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Supported Configurations
Supported Configurations are the environments in which the BEA Guardian application can be 
installed and run. This is distinct from the Supported Targets, which are the environments that 
Guardian can target for evaluations.

Note: Guardian requires Java Version 5 or above. 

Guardian supports the following environments: 

Supported Targets
Supported Targets are the environments that BEA Guardian can target for evaluations. This is 
distinct from Supported Configurations, which are the environments in which the Guardian 
application itself can be installed and run.

Basically, Guardian can target any platform for evaluation that allows it to install and 
communicate with the Guardian Agent. In addition, the Guardian Agent itself must have access 
to a specific set of Java system information properties and methods. The BEA products capable 
of supporting these operations are based on WebLogic Server versions 8.1 and above.

Table 1-11  Supported Operating Systems

Operating System Vendor/Version

Windows XP, 2003, 2000

Linux Red Hat Enterprise Linux 3, 4

Note: Requires Mozilla

Table 1-12  Supported Java Runtime Versions

Java Runtime Environment Version Vendor

V5 (also known as V1.5) or above JRockit, Sun
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The following BEA product versions are supported:

Note: For the most current information on Supported BEA product versions, please see the 
Guardian 1.1 Release Notes.

Table 1-13  Supported BEA Product Versions

BEA Product Versions

AquaLogic Data Services Platform 2.0 and above

AquaLogic Service Bus 2.1 and above

JRockit JDK Please see Guardian 1.1 Release Notes.

WebLogic Communications Platform SIP Server 3.0 and above

WebLogic Integration 8.1 and above

WebLogic Platform 8.1 and above

WebLogic Portal 8.1 and above

WebLogic RFID Enterprise Server 1.1 

2.0 

WebLogic Server 8.1 and above

WebLogic Virtual Edition 1.1
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C H A P T E R 2

Tasks

This chapter provides detailed instructions for using and managing the following Guardian 
features and components:

Basic Tasks

Guardian Agent

Workspaces

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Troubleshooting
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Support

Updates and Upgrades

Basic Tasks
There are many ways to configure and use Guardian to diagnose the health of your domains. 
However, there are four essential tasks that can be considered the primary functions of Guardian. 
These are as follows:

Activate Domain — Activating a domain prepares the domain for evaluation and conducts 
an initial inventory of the domain configuration. To activate a domain, use the Domain 
Activation Wizard. For instructions, see “Activate Domain” on page 47.

Inventory Domain — A Domain Inventory is an assessment of your current domain 
environment. The results are displayed in a Domain Inventory Overview in the Document 
Pane. The inventory is also added to the Inventory History folder in the Domain Explorer. 
Domain Inventories are also created automatically whenever you activate or evaluate 
domains. To inventory a domain, use the Inventory Wizard. For instructions, see 
“Inventory Domain” on page 56.

Evaluate Domain — To detect which signatures apply to your domain, you conduct an 
evaluation. Guardian collects data about your domain environment, and identifies which 
signatures apply to the domain.When the evaluation is complete, the results are displayed 
in an Evaluation Summary in the Document Pane. The Evaluation Summary lists all of 
the detected signatures, along with the severity level, description, and recommended 
remedy for each. You can review the Evaluation Summary to determine your response to 
any signatures that are detected. If you need more help resolving the potential problem the 
signature identified, you can use Guardian to create and submit a BEA support case. For 
instructions on conducting evaluations, see “Evaluate Domain” on page 57.

Updates and Upgrades — BEA Support Engineers create new signatures every day, and 
application enhancements to Guardian are also periodically released. The Guardian Update 
feature enables Guardian to connect directly to the Guardian Update Site to automatically 
download and install new signatures and product updates. To update Guardian on servers 
without Internet access, you can perform a manual update. For instructions for performing 
both automatic and manual updates, see “Updates and Upgrades” on page 81.
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There are numerous other Guardian tasks and activities, which are categorized according to the 
following topics:

Guardian Agent

Workspaces

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Troubleshooting

Support

Updates and Upgrades

The following sections provide detailed instructions for performing the tasks in each of these 
categories.
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Guardian Agent
This section provides instructions for the following tasks:

Manually Deploy Guardian Agent

– Deploy Guardian Agent from WebLogic Server Adminstration Console

– Deploy Guardian Agent to Multiple Servers

Configure Maximum Agent Threads

Configure Agent Thread Timeout

Manually Deploy Guardian Agent
For Guardian versions 1.0.7 and above, you must manually deploy the new Guardian Agent in 
WebLogic Server before you can use Guardian to evaluate your environment. 

Note: If you have enabled Online Signature/Software Updates in your Guardian 
Preferences, Guardian periodically performs an automatic update for the latest Guardian 
version. Clicking the Update button in Guardian also initiates a software version update. 
If you were previously able to activate domains and run evaluations in Guardian, but are 
no longer able to do so, this may be due to an update to Guardian 1.0.7 or above. You 
must delete the earlier Guardian Agent and deploy the new Agent to continue using 
Guardian.

You can use the WebLogic Server Administration Console to uninstall the existing Guardian 
Agent and then install and deploy the new Agent. The WebLogic Server Administration Console 
provides a series of Web-based deployment assistants that guide you through the deployment 
process. For a summary of the steps involved in deploying the Guardian Agent, see “Deploy 
Guardian Agent from WebLogic Server Adminstration Console” on page 37. For complete 
instructions on deploying applications, see the Administration Console Online Help, and 
WebLogic Server documentation. 

If you want to deploy the Guardian Agent to multiple servers, you can use a WebLogic Scripting 
Tool to automate this task. For basic instructions, see “Deploy Guardian Agent to Multiple 
Servers” on page 38. For instructions on using a script to activate multiple domains in Guardian, 
see “Activate Multiple Domains” on page 49. For complete instructions on using the WebLogic 
Scripting tool to deploy applications, see the WebLogic Scripting Tool documentation. 
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Deploy Guardian Agent from WebLogic Server Adminstration Console
You can use the WebLogic Server Administration Console to manually deploy the Guardian 
Agent on that server. This section provides a summary of the basic steps involved for WebLogic 
Server versions 9.0 and above. For complete instructions for your specific version of WebLogic 
Server, please see your WebLogic Server documentation and Administration Console Online 
Help. Please also refer to the Guardian 1.1 Installation Guide and Guardian 1.1 Release Notes 
for additional important information.

To use the Administration Console to manually deploy the Guardian Agent, do the following:

1. Start the WebLogic Administration Console, and select Lock & Edit in the left pane.

Caution: Make sure that Lock & Edit is selected for each of the following procedures.

2. Stop the existing Guardian Agent deployment in the WebLogic Server.

By default, the Guardian Agent is named bea-guardian-agent. 

Note: For detailed instructions for this procedure, see “Start and stop a deployed Enterprise 
Application” in the WebLogic Administration Console Online Help.

3. Delete the existing Guardian Agent deployment from the WebLogic Server, and activate your 
changes.

Note: For detailed instructions for this procedure, see “Delete an Enterprise Application” in 
the WebLogic Administration Console Online Help.

4. Install the new Guardian Agent in the WebLogic Server, and activate your changes.

The Guardian Agent is a WAR file named bea-guardian-agent.war, and is located in 
the following directory:

WARNING: Do not change the name of the Guardian Agent when deploying it. Be sure to 
use the default name, bea-guardian-agent.war.

<root>\guardian\plugins\com.bea.guardian.agent.weblogic_<guard-version>
\weblogic<wls-version>

Where: 

<root> is the parent directory for the Guardian installation. For example:
C:\\Program Files

<guard-version> is the current (updated) Guardian version.

<wls-version> is the version of WebLogic Server in which you are deploying this Agent. 
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If you are installing the Agent on WebLogic 8.1.x, install the bea-guardian-agent.war 
file located in the ..\weblogic8 directory. For WebLogic Server 9.x and 10.x, install the 
bea-guardian-agent.war file located in the ..\weblogic9 directory.

Note: For detailed instructions for this procedure, see the section entitled, “Install an 
Enterprise Application” in the Administration Console Online Help.

5. Start the new Guardian Agent in the WebLogic Server.

Note: For detailed instructions for this procedure, see “Start and stop a deployed Enterprise 
Application” in the WebLogic Administration Console Online Help.

6. Start Guardian and activate the neccessary domains in Guardian.

Note: For detailed instructions for this procedure, see “Activate Domain” in the BEA 
Guardian Online Help.

You can now use Guardian to evaluate the activated domains in your environment.

Deploy Guardian Agent to Multiple Servers
If you need to deploy the Guardian Agent to multiple servers in a cluster environment, you can 
use the weblogic.Deployer command in the WebLogic Server Command Line Interface to 
automate this task. You can also use the BEA WebLogic Diagnostics Framework (WLDF) to 
deploy the Agent. This section provides basic instructions for using the weblogic.Deployer 
command for this purpose. For instructions on using WLDF, please see the WebLogic 
Diagnostics Framework product documentation. 

Note: Please also refer to the Guardian 1.1 Installation Guide and Guardian 1.1 Release Notes 
for additional important information.

WARNING: Do not change the name of the Guardian Agent when deploying it. Be sure to use 
the default name, bea-guardian-agent.war.

At the WebLogic Server CLI prompt, enter the following command line:
java weblogic.Deployer -debug -adminurl http://<admin_url>:<port> -username 
<username> -password <password> –targets adminserver,<cluster1>,<cluster2> 
-deploy  -sourcerootforupload  <dir_path>\bea-guardian-agent.war

Where:

<admin_url> is the URL for the WLS Admin Server.

<port> is the port number for the WLS Admin Server.
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<cluster1>,<cluster2> are the names of all configured clusters.

<dir_path> is the directory path to the Guardian Agent WAR file 
(bea-guardian-agent.war).

Configure Maximum Agent Threads
If you have one or more managed servers in a domain, the Guardian Agent spawns the appropriate 
number of threads for communicating between the Guardian Agent on the WebLogic 
Administration Server, and the Guardian Agent running on the Managed Server(s). However, an 
excessive number of threads can affect the performance of the Administration Server. To control 
this, you can specify the maximum number of Agent threads to allocate to the WebLogic Server 
Administration Server for a specified domain. The Max. Agent Threads parameter setting 
determines this value. The default is 10. 

There are two ways to set the value for this parameter:

When activating the domain, you can set the Max. Agent Threads parameter in the 
Advanced tab page of the Domain Activation Wizard (see “Activate Domain” on 
page 47).

If the domain is already activated, you can set the Max. Agent Threads parameter in the 
Domain Properties dialog box (see below).

To set the Max. Agent Threads value for an activated domain, do the following:

1. In the Navigation pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on the domain name and select Modify Domain from the context menu.

This displays the Domain Properties dialog box.

3. Select or enter a value in the Max. Agent Threads field.

This can be an interger value from 1 to 20. The default is 10. 

4. Click OK.

This resets Max. Agent Threads to the specified value for the selected domain. 
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Configure Agent Thread Timeout
In order to manage Agent resources on both the WebLogic Administration Server and Managed 
Servers, Guardian enables you to specify the maximum amount of time (in seconds) that can 
elapse before a thread is terminated. The Agent Thread Timeout parameter governs this 
timeout. The default is 60. 

There are two ways to set the Agent Thread Timeout parameter:

When activating the domain, you can set the Agent Thread Timeout parameter in the 
Advanced tab page of the Domain Activation Wizard (see “Activate Domain” on page 47).

If the domain is already activated, you can set the Agent Thread Timeout parameter in 
the Domain Properties dialog box (see below).

To set the Agent Thread Timeout value for an activated domain, do the following:

1. In the Navigation pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on the domain name and select Modify Domain from the context menu.

This displays the Domain Properties dialog box.

3. Select or enter a value in the Agent Thread Timeout field.

This can be an integer value from 10 to 600. The default is 60. 

4. Click OK.

This resets Agent Thread Timeout to the specified value for the selected domain.

Workspaces
This section provides instructions for the following tasks:

Select Workspace

Export Workspace

Import Workspace

The Guardian Workspace is the directory in which all of your Guardian data is stored. It includes 
the following data for each domain you have defined in Guardian:

Preferences

Domain Inventories
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Evaluation Summaries

Case Archives (optional)

To prevent loss of work when Guardian is updated or uninstalled, your Workspace directory must 
be located outside of the Guardian installation directory. You can safely back up your Workspace 
data by exporting your Workspace to a file also located outside of your Guardian Installation 
directory. For instructions, see “Export Workspace” on page 42.

Select Workspace
To specify the location for your Guardian Workspace, you must restart Guardian and specify a 
new location in the Select Workspace dialog box during startup. 

WARNING: To prevent loss of work when Guardian is updated or uninstalled, your 
Workspace directory must be located outside of the Guardian installation 
directory. You can safely back up your Workspace data by exporting your 
Workspace to a file also located outside of your Guardian Installation directory. 
For instructions, see “Export Workspace” on page 42.

To select a Guardian Workspace when starting Guardian, do the following:

1. Start Guardian.

Guardian first displays the initial splash screen while loading, and then displays the Select 
Workspace dialog box.

2. Click Browse.

This opens the Browse For Folder dialog.

3. Select or create the folder (directory) to use as your Workspace folder.

Caution: Make sure this directory is not located within the Guardian installation directory.

To use an existing folder: Browse to the folder location and select the folder. 

To create a new folder: 

a. Click Make New Folder.

b. Select the location for the folder.

c. Enter the name of the folder
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4. Click OK.

This creates or selects the file and returns to the Select Workspace dialog box.

5. (Optional) Specify this as the default Workspace.

If you do not want to select the Workspace each time you start Guardian, select the 
checkbox for Use this as the default workspace and do not ask again. 

To change this setting at a later time, do the following:

a. Select Window > Preferences... to open the Preferences configuration page.

b. In the Preferences tree on the left, select Guardian.

c. Select the Prompt for workspace on startup checkbox.

d. Click OK.

The Select Workspace dialog box will be displayed the next time you start Guardian.

6. Click Finish.

Guardian loads the selected Workspace and completes the startup procedure.

Export Workspace
You can export your Guardian Workspace data to a file, which you can use for backup and 
recovery purposes, or to import to another Guardian instance.

WARNING: To prevent loss of work when Guardian is updated or uninstalled, make sure your 
Workspace and any Workspace export files are located outside of your Guardian 
Installation directory. 

To export a Guardian Workspace, do the following:

1. Select File > Export.

This opens the Export Workspace Wizard.

2. In the Export dialog box, open the Guardian folder and select Guardian Workspace.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This clears the Select an export destination field and redisplays the 
default folder tree.

3. Click Next.
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4. For Select File, specify the file name and location to which to save your Workspace data.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Click Save 
to select the file and return to the Export Workspace Wizard.

5. Click Finish.

This saves your current Workspace as a .zip file containing all of your Workspace data, 
including the guardian.registry, .project and .refresh files.

Import Workspace
You can import a Guardian Workspace from another Guardian instance, or an exported 
Workspace data file.

To import a Guardian Workspace, do the following:

1. Select File > Import.

This opens the Import Workspace Wizard.

2. In the Import Workspace Wizard, open the Guardian folder and select Guardian 
Workspace.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This clears the Select an import source field and redisplays the 
default folder tree.

3. Click Next.

4. For Select File, specify the Workspace file you want to import.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Click Save 
to select the file and return to the Import Workspace Wizard.

5. Click Finish.

This imports the selected Workspace data and returns to the main Guardian window. 
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Preferences
This section provides instructions for the following tasks:

Configure Preferences

Export Preferences

Import Preferences

Configure Preferences
You can use the Preferences page to configure your Guardian Preferences and customize your 
Guardian environment.

To configure your Guardian Preferences, do the following:

1. Open the Preferences configuration page.

You can use either of the following methods to open the Preferences configuration page:

– Press Ctrl+Shift+P. 

– Select Window > Preferences from the titlebar menu.

2. Open a folder and click on a category name to display the preferences in that category. 

The left pane of the Preferences configuration page is a navigation tree containing an 
extensive series of hierarchical folders and subfolders. Each folder and subfolder in the 
hierarchy is a category of preference attributes that you can configure. 

The top level folders are as follows:

– General

– Guardian

– Help

– Install/Update

Note: For a detailed description of all Preference page folders and parameters, see 
“Preferences” on page 115 in Chapter 3, “Reference.” 

3. (Optional) Click Apply to apply your preference settings for the current category, or click 
Restore Defaults to restore the default values for all Preference page parameters.
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4. When you have finished setting your preferences for each category, click OK.

This applies and saves all of your new Preference page settings.

Export Preferences
You can export your Guardian Preferences to a file for backup and recovery purposes, or to 
import to another Guardian instance.

To export your Guardian Preferences to a file, do the following:

1. Select File > Export.

This opens the Export Preferences Wizard.

2. In the Export Preferences Wizard, open the General folder and select Preferences.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This will clear the Select an export destination field and redisplay 
the default folder tree.

3. Click Next.

4. Specify the preferences to export.

Do one of the following:

– Select Export all to export all of your Guardian Preferences information.

– Select Choose specific preferences to export to display a selection list of preferences 
in the Preferences box. Then select the individual preferences you want to export, or 
click Select All. 

5. For To preference file, specify the file name and location to which to save your preferences 
information.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Then click 
Save to select the file and return to the Export Preferences Wizard.

6. Click Finish.

This saves your current preferences information as a .epf file in the specified location.
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Import Preferences
To import a Guardian Preferences from a file, do the following:

1. Select File > Import.

This opens the Import Preferences Wizard. 

2. In the Import Preferences Wizard, open the General folder and select Preferences.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This clears the Select an import source field and redisplays the 
default folder tree.

3. Click Next.

4. For From preference file, specify the file name and location of the file you want to import.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Then click 
Save to select the file and return to the Import Preferences Wizard.

5. Specify the preferences to import.

Do one of the following:

– Select Import all to import all preference information.

– Select Choose specific preferences to import to display a selection list of preferences 
in the Preferences box. Then select the individual preferences you want to import, or 
click Select All. 

6. Click Finish.

This replaces your current Preference page settings with the settings from the imported 
file. 



Domains

BEA Guardian User Guide 2-47

Domains
This section provides instructions for the following tasks:

Activate Domain

Activate Multiple Domains

Deactivate Domain

Modify Domain Properties

Purge All Inactive Domains

Activate Domain
A domain is considered active when it is capable of being evaluated. Activating a domain 
prepares it for evaluation and creates a new Domain Inventory.

Activating a domain also results in the following:

The new domain node is added to the Domain Explorer Target Domains folder.

Guardian inventories the domain, and displays the Domain Inventory Overview in the 
Document Pane. In the Domain Explorer, the new inventory is added to the Inventory 
History folder for that domain. 

The domain is added to the Active Domain Table. 

The domain is added to the Guardian Registry. 

A folder for the domain is added to the Guardian Workspace. The domain folder contains 
the data from all Domain Inventories and Evaluation Summaries for the domain.

To activate a domain, do the following:

Note: If you are unable to activate any domains, you may need to manually deploy the Guardian 
Agent. For instructions, see “Manually Deploy Guardian Agent” on page 36.

1. Open the Domain Activation Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+A. 

– Click Activate in the Main Toolbar. 
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– Select New > Domain from the File menu.

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click 
anywhere in the Domain Explorer and select Activate Domain from the context 
menu.

2. Click the General tab and configure the General Domain Properties.

The General tab contains the following fields:

– Protocol — Select one of the following from the drop-down menu:

• http:// — Select this to use the HTTP protocol without encryption.

• https:// — Select this to use HTTP protocol with Secure Sockets Layer (SSL) 
encryption.

Note: Guardian does not use 128 bit SSL encryption for domain activation.

– Host Name — This is the listen address for the WebLogic Administration Server in the 
target domain. 

– Port Number — This is the listen port for the WebLogic Administration Server for the 
target domain.

– Username — This is the username of a WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password — This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Remember Username/Password — This specifies that the domain credentials are to 
be stored so that you do not have to enter them for future domain operations. 
Usernames and passwords are encrypted when stored.

Note: If you preselected a deactivated domain when you invoked the Domain Activation 
Wizard, the Protocol, Hostname, and Port fields will be automatically filled with 
the appropriate values. 

3. Click the Advanced tab and enter the Advanced Domain Properties.

The Advanced tab contains the following fields and options:

– Enable Proxy Connection: Select this if a proxy server is to be used to access the 
target domain. Then, select a proxy server from the drop-down list. Click Add Proxy 
Servers to add proxy servers to this list (see “Add Inbound Proxy Servers” on page 54 
for complete instructions).
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– Max. Agent Threads: Select the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer value from 1 to 20. 
The default is 10.

– Agent Thread Timeout (secs): Specify the maximum number of seconds that can 
elapse before an Agent thread is deactivated when collecting data from managed 
servers. This can be an integer value from 10 to 600. The default is 60. 

– Domain Notes: Enter a text description or other details pertaining to this domain. 
These notes are displayed in inventories and evaluations for this domain.

4. Click Finish.

You can now evaluate and inventory the domain.

Activate Multiple Domains
If you need to activate multiple domains in Guardian, you can use a script to automate this 
procedure.

WARNING: You must deploy the Guardian Agent to each domain that is to be activated prior 
to running the activation script. For instructions, see “Deploy Guardian Agent to 
Multiple Servers,” above.

The following is an example script for activating multiple domains:
-gactivateDomain -t http://slp7:7001 -u un -p pw -c true

-gactivateDomain -t http://slp8:7001 -u un -p pw -c true

-gactivateDomain -t http://sqa-lldev:4044 -u un -p pw -c true

The script is then run in Guardian Headless Mode, by using the following command line:
guardianHeadless.cmd -gscript -f activatingScript.txt

For more information about running scripts, see “Run Scripts” on page 75.

Deactivate Domain
When you deactivate a domain, it is no longer available for evaluation. Any shortcuts that use the 
domain are removed from the Shortcut Table and Shortcut Explorer. The Domain Inventory and 
Evaluation Summary data persists after deactivation, but is not available for viewing in Domain 
Explorer. You must reactivate the domain before you can view the data or evaluate the domain.
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To deactivate a domain, do the following:

1. Open the Domain Deactivation Wizard.

Do one of the following:

– Click on the Domain Explorer tab to open the Domain Explorer. Then, right-click on 
a domain and select Deactivate from the context menu.

– Select Window > Show View > Active Domains Table. Then, select a domain from 
the table and click Deactivate Domain. 

2. Click on a domain entry to select it.

3. Click Finish.

This deactivates the domain and returns to the Domain Explorer or Active Domain 
Table. 

Note: The Domain Deactivation Wizard does not remove the BEA Guardian Agents that 
were installed when you activated the domains. For instructions on removing Agents, 
see the WebLogic Server Administration Console Online Help. For instructions on 
purging inactive domains from Guardian, see “Purge All Inactive Domains” on 
page 51.

Modify Domain Properties
You can modify the Domain Properties for a domain to customize the way BEA Guardian 
communicates with that domain. 

To modify the Domain Properties for a domain, do the following:

1. Open the Domain Properties configuration page.

Do one of the following:

– Select Window > Show View > Active Domains Table to open the Active Domains 
Table. Then, select a domain and click Modify Domain. 

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click on a 
domain in the Domain Explorer tree, and select Modify Domain from the context 
menu. 

2. Configure the Domain Properties.

The Domain Properties configuration page contains the following fields and options:

– Name: This contains the name for this domain. You cannot modify this value.
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– Username — This is the username of an WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password — This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Remember Username/Password — This specifies that the domain credentials are to 
be stored so that you do not have to enter them for future domain operations.

– Enable Proxy Connection: Select this if a proxy server is to be used to access the 
target domain. Then, select a proxy server from the drop-down list. Click Add Proxy 
Servers to add proxy servers to this list (see “Add Inbound Proxy Servers” on page 54 
for complete instructions).

– Max. Agent Threads: Select the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer value from 1 to 20. 
The default is 10.

– Agent Thread Timeout (secs): Specify the maximum number of seconds that can 
elapse before an Agent thread is deactivated when collecting data from managed 
servers. This can be an integer value from 10 to 600. The default is 60. 

– Notes: Enter a text description or other details pertaining to this domain.

3. Click OK.

This applies your new Domain Properties settings to the selected domain.

Purge All Inactive Domains
To remove all deactivated domains from the Domain Explorer, select Tools > Purge Inactive 
Domains. There is no confirmation request; the domains are purged immediately.

WARNING: Purging the inactive domains also deletes the associated Domain Inventories and 
Evaluation Summaries from the Guardian Workspace, and removes the domains 
from the Guardian Registry.
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Domain Groups
This section provides instructions for the following tasks:

Add Domain Group

Rename Domain Group

Delete Domain Group

Add Domain Group
To create and populate a new Domain Group, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on Target Domains and select Add Domain Group from the context menu.

This opens the Add Domain Group dialog box.

3. In the Name field, enter a name for the Domain Group.

4. Click OK.

This adds the new Domain Group to the Domain Explorer Domain Tree, and closes the 
Add Domain dialog box.

5. Populate the Domain Group.

In the Domain Explorer Domain tree, click on a domain name to select it, then drag and 
drop it into the new Domain Group folder. Repeat this step for each domain you want to 
include in the new Domain Group.

Rename Domain Group
To rename an existing Domain Group, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on Target Domains and select Rename Domain Group from the context menu.

This opens the Rename Domain Group dialog box.

3. In the Name field, enter the new name for the Domain Group.
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4. Click OK.

This renames the Domain Group in the Domain Explorer Domain Tree, and closes the 
Rename Domain dialog box.

Delete Domain Group
1. Click on the Domain Explorer tab to open the Domain Explorer.

2. Remove any domains from the Domain Group.

You cannot delete a Domain Group that contains a domain. If there are domains in the 
Domain Group, you can drag and drop the domains into the Target Domain folder, or into 
another Domain Group folder.

3. Right-click on the Domain Group you want to delete, and select Delete Domain Group from 
the context menu.

This displays a Domain Group Delete Confirmation dialog box prompting you to 
confirm the delete request.

4. Click OK.

This deletes the Domain Group from the Domain Explorer Domain Tree, and closes the 
Delete Confirmation dialog box.

Proxy Servers
This section provides instructions for the following tasks:

Add Inbound Proxy Servers

Enable Inbound Proxy Connection

Enable and Test Outbound Proxy
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Add Inbound Proxy Servers
If you want to use an inbound proxy server for communications between Guardian and the 
WebLogic Administration Server, you must first add the proxy server to Guardian.

To add an inbound proxy server, do the following:

1. Click Activate to open the Domain Activation Wizard.

2. Click the Advanced tab.

3. Click Add Proxy Servers to open the Proxy Servers Preferences configuration page.

4. Click Add to open the Proxy Properties dialog box. 

5. Enter the proxy server Hostname, Port, Username, and Password information. 

6. Click OK .

This adds the proxy server to the Proxy Servers list in the Proxy Servers configuration 
page, and dismisses the Proxy Properties dialog box. 

7. (Optional) Repeat steps four through six to add additional proxy servers to the list.

8. Click OK .

This adds the new proxy server to the Proxy Server drop-down list in the Advanced tab of 
the Domain Activation Wizard and dismisses the dialog box.

Enable Inbound Proxy Connection
If you want to use an inbound proxy server for communications between Guardian and the 
WebLogic Administration Server, you must enable the proxy connection. 

To enable an inbound proxy connection, do the following:

1. Manually deploy the Guardian Agent onto the target domain. 

2. If you have not already done so, add the proxy server to the Domain Activation wizard Proxy 
Server list.

For instructions, see “Add Inbound Proxy Servers” on page 54.
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3. Open the Domain Activation Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+A. 

– Click Activate in the Main Toolbar. 

– Select New > Domain from the File menu. 

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click in the 
Domain Explorer panel and select Activate Domain from the context menu.

4. Click the Advanced tab in the Activate Domain Wizard.

5. Check the Enable Proxy Connection checkbox.

6. Select the proxy server from the drop down list.

7. Click Finish.

Enable and Test Outbound Proxy
If you are using an outbound proxy server for communications between Guardian and the outside 
world, you will need to test the outbound proxy connection. 

To enable and test an outbound proxy server connection, do the following:

1. Select Window > Preferences from the titlebar menu.

This displays the Preferences configuration page.

2. In the Preferences folder tree (left pane) open the Guardian folder and select BEA Support.

This displays the BEA Support preferences, which include some settings for proxy testing.

3. In the BEA Support preferences, select the Requires Proxy checkbox.

4. Click Test Proxy.

After the test completes, a status message is displayed at the top of the page as to whether 
it was successful or not.
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Inventories and Evaluations
This section provides instructions for the following tasks:

Inventory Domain

View Domain Inventory

Evaluate Domain

Evaluate Snapshot

Compare Inventories or Evaluations

Export Inventory or Evaluation

Inventory Domain
A Domain Inventory is an assessment of your current domain environment. The results are 
displayed in a Domain Inventory Overview in the Document Pane. The inventory is also added 
to the Inventory History folder in the Domain Explorer. Domain Inventories are also created 
automatically whenever you activate or evaluate domains. 

To inventory a domain, do the following:

1. Open the Inventory Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+I. 

– Click Inventory on the Main Toolbar. 

– Select File > New > Inventory. 

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click on a 
domain name in the Domain Explorer tree and select Inventory from the context 
menu. 

2. If you did not preselect a domain when opening the wizard, select a domain from the 
Inventory Wizard domain table.

3. Enter the Username and Password of the Weblogic Server Administrator or Monitor account 
for the target domain.
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4. Click Finish.

This initiates the Domain Inventory and displays the results in a Domain Inventory 
Overview in the Document Pane.

View Domain Inventory
To view an existing Domain Inventory, do the following:

1. Click the Domain Explorer tab to open the Domain Explorer. 

2. Open the Inventory History folder for the domain.

3. Double-click on the inventory name to view the selected Domain Inventory Overview in the 
Document Pane.

Evaluate Domain
To identify potential problems before they occur, you can use the Evaluation Wizard to evaluate 
one or more domains. 

To evaluate a domain, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

1. Select a domain and open the Evaluation Wizard.

Use any of the following methods to select a domain and open the wizard:

– In the Domain Explorer, select a domain and then click the Evaluation button. To 
select multiple domains, press the Ctrl or Shift key while selecting additional items.

– Right-click on a domain and then select Evaluate from the context menu.

– Double-click a domain name in the Domain Explorer. 

– Select File > New > Evaluation from the titlebar. 

– Select Window > Show View > Active Domains Table to display the Active 
Domains Table. Then, double-click a domain name to open the wizard for the selected 
domain. 

2. In the Bundle field, select the Signature Bundle to evaluate.

Select a Signature Bundle from the Bundle field drop-down menu. The default is Default 
Signatures.
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3. Enter the credentials for the WebLogic Server for the selected domain.

In the Domain Credentials section, enter the following:

– Username: This is the username for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password: This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain.

If you selected multiple domains, you must supply the login credentials for each domain 
before you can launch the Evaluation. 

4. (Optional) Select the Remember username/password checkbox to save your login 
credentials for the selected domain(s).

Select this option if you want your login information to persist so that you do not have to 
enter it each time you evaluate this domain. This is especially useful if you routinely 
evaluate multiple domains concurrently. Usernames and passwords are encrypted when 
stored.

5. (Optional) Create a shortcut for this evaluation.

This is useful if you routinely perform this particular type of evaluation. To create a 
shortcut, select the Create Shortcut checkbox, and enter a brief name for the shortcut in 
the text field. For detailed instructions on creating, evaluating, and managing shortcuts, see 
the section entitled, “Shortcuts” on page 70.

6. Click Finish.

This initiates the evaluation and displays an Evaluation Summary of the results in the 
Document Pane. In the Domain Explorer, the new Domain Inventory is added to the 
Inventory History folder, and the new Evaluation Summary is added to the Evaluation 
History folder. 

Evaluate Snapshot
A Snapshot Evaluation is a complete assessment of all of the configuration details for a specific 
domain, at the particular moment the evaluation is executed. The process for performing a 
Snapshot Evaluation is the same as for any other type of evaluation. The primary difference is in 
the type of Signature Bundle you select for the evaluation, and the type of information the 
evaluation collects and evaluates. 
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Note: As with other evaluations, you can compare Snapshot Evaluations. Comparing two 
Snapshot Evaluations enables you to see very quickly the differences between 
configurations for those two domains. For instructions, see “Compare Inventories or 
Evaluations” on page 60.

Caution: Generating a Snapshot Evaluation of a large domain may consume a lot of memory, 
and take a long time to complete.

To evaluate a snapshot of a domain configuration, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

1. Select a domain and open the Evaluation Wizard.

Do one of the following:

– In the Domain Explorer, select a domain and then click the Evaluation button.

– Right-click on a domain name and then select Evaluate from the context menu.

2. In the Bundle field, select the type of snapshot to create and evaluate.

Select one of the following from the Bundle field drop-down menu:

– Snapshot - All

– Snapshot - JDBC

– Snapshot - JMS

– Snapshot - Security

3. Enter the credentials for the WebLogic Server for the selected domain.

In the Domain Credentials section, enter the following:

– Username: This is the username for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password: This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

4. Click Finish.

This initiates the Snapshot Evaluation and displays an Evaluation Summary of the results 
in the Document Pane. In the Domain Explorer, the new Domain Inventory is added to 
the Inventory History folder, and the new Evaluation Summary is added to the 
Evaluation History folder. 
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Compare Inventories or Evaluations
You can compare inventories or evaluations from the same or different domains. Both objects 
must be of the same type—that is, two inventories or two evaluations. You cannot compare an 
inventory against an evaluation. 

You can compare any two Evaluation Summaries. Comparing two Snapshot Evaluations is 
particularly useful, as a Snapshot Evaluation collects and evaluates all of the configuration data 
for the evaluated domain. Such a comparison enables you to see very quickly the differences 
between the configurations and their issues for those two domains. 

To compare two Domain Inventories or Evaluation Summaries, do the following:

1. In the Navigation pane, open the Domain Explorer.

Click the Domain Explorer tab, or select Window > Show View > Domain Explorer.

2. Open the History folder containing the resources to be compared (Inventory History or 
Evaluation History).

3. Select the two files to be compared.

Click on the first item to select it, and then hold down the Ctrl key and click on the second 
item.

4. Right-click in the Domain Explorer and select Compare from the context menu.

Note: The Compare option remains deactivated until two like items have been selected.

Selecting Compare opens the Text Compare display in the Document Pane. The 
differences between the two files are highlighted, and related segments are shown in boxed 
sections, with connectors indicating the relation.

The Text Compare navigation controls are as follows:

Go to next/previous segment — Click the up/down arrows at the top right corner of the 
Text Compare display.

Jump to a segment — Click on a segment bar in the far right column. 

Resize panels — Move your cursor over the center divider until the cursor changes to a 
double arrow. Then click and drag the divider to the left or right to resize the panels.
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Display Text Compare context menu — Right-click in the left or right Text Compare 
panel to display the Text Compare context menu. This menu has the following options:

– Copy — Copy the selected text. You can then use a text editor to paste the selected 
text into a file and save it.

– Select All — Select all text in the current panel. You can then use a text editor to paste 
the selected text into a file and save it.

– Ignore White Space — Remove white space characters in both panels. 

– Show Whitespace Characters — Show white space characters and carriage returns in 
both panels. A light blue dot indicates a white space characters. A light blue paragraph 
symbol indicates a carriage return.

– Show Line Numbers — Display line numbers in both panels.

– Find/Replace — Display the Find/Replace dialog box. Enter your search criteria and 
click Find to search in the selected panel. Replace is disabled for this page.

Export Inventory or Evaluation
You can export a Domain Inventory or Evaluation Summary report to a PDF or HTML file for 
external viewing or archiving.

To export a report, do the following:

1. Click the Domain Explorer tab in the Navigation Pane to open the Domain Explorer.

2. Open the History folder containing the report you want to save.

The Domain Explorer contains two History folders:

– Inventory History — This contains a linked list of the available Domain Inventory 
reports.

– Evaluation History — This contains a linked list of the available Evaluation Summary 
reports.

3. Open the report.

Double-click on a report name to open the report and display it in the Document Pane.

4. Select File > Save As.

This opens a standard Save As file browser.

5. Browse to the location to which to save the file.
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6. Select the type of file to which to save the report.

For the Save as type: field, select one of the following from the drop-down menu:

– PDF Files (*.pdf)

– HTML Files (*.html)

7. Enter a file name in the File name field.

8. Click OK.

Signatures
This section provides instructions for the following tasks:

View Signature Overview

Filter Signatures

Sort Signatures

View Signature Overview
To display the overview for a signature, do the following:

1. In the Navigation Pane, click on the Signature Explorer or Bundle Explorer tab.

This opens the Signature Explorer or Bundle Explorer, respectively. Signature 
Overviews are accessible only through these two Explorers.

2. Double-click on a signature name in the Navigation Pane.

This displays the overview for that signature in the Document Pane.
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Filter Signatures
You can use Signature Filters to specify which signatures are to be displayed in the Signature 
Explorer, Bundle Explorer, and Evaluation Summaries.

To apply Signature Filters, do the following:

1. Open the Filters dialog box.

– From the Signature Explorer or Bundle Explorer:

Click the Menu icon (small white delta in the upper right corner), and select Filters... 
from the context menu.

– From an Evaluation Summary:

Right-click on any signature in the Detected Signatures list, and select Filters... from 
the context menu.

2. Specify your filter settings.

Click a radio button to specify Show or Hide for each filter. The Signature Filters are as 
follows:

Name — Filter according to name. Specify all or a portion of a signature name to use as 
the filter criteria. This can be a character string or standard regular expression. Enter .* to 
filter all signatures. The default is Show all (.*).

Severity — Filter according to severity. Click a checkbox to select/deselect a severity 
level. These are: Critical, Warning, and Information. The default is Show all (all 
selected).

Type — Filter annotated signatures according to Annotation Type. Click a checkbox to 
select/deselect a type. There are two Annotation Types: Flag and Ignore. The default is 
Hide signatures with an Annotation Type of Ignore. For more information on Annotation 
Types, see “Signature Annotations” on page 22 in Chapter 1, “About BEA Guardian.” 

Annotation Name — Filter annotated signatures according to Annotation Name. Specify 
all or a portion of an Annotation Name to use as the filter criteria. This can be a character 
string or standard regular expression. Enter .* to filter all annotated signatures. The default 
is Show all (.*).

Comment — Filter annotated signatures according to annotation comment. Specify all or a 
portion of a comment to use as the filter criteria. This can be a character string or standard 
regular expression. Enter .* to filter all signatures. The default is Show all (.*).
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Domain — Filter annotated signatures in this domain, as specified above. 

Evaluation — Filter annotated signatures in this Evaluation, as specified above. 

3. Click OK.

This applies your filter specifications and returns to the Guardian main window.

Sort Signatures
You can sort the list of signatures displayed in the Signature Explorer, Bundle Explorer, and 
Evaluation Summaries.

1. In the Navigation Pane, click the Signature Explorer or Bundle Explorer tab to open one 
of these Explorers.

2. Click the Menu icon to open the Explorer menu.

3. Select Sort Signatures > to open the Sort submenu.

4. Select the category by which to sort.

Select one of the following:

– By Name

– By Severity

The signature lists are automatically reordered according to the selected category.

Signature Annotations
This section provides instructions for the following tasks:

Annotate Signature

Edit Annotation

Delete Annotation

View Annotations

Filter Annotated Signatures

You can use the Annotations Wizard to create, edit, delete, and view signature annotations. 
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You can access the Annotations Wizard from the Signatures List in any of the following 
contexts:

Evaluation Summary

Signature Explorer

Bundle Explorer

To open the wizard, right-click on a signature title and select Annotations > Manage 
Annotations from the context menu. 

Annotate Signature
To create an annotation and add it to a signature, do the following:

1. Navigate to the Signatures List containing the signature you want to annotate.

The contents of a Signatures List may vary according to the context in which it occurs. 
Signatures Lists can be found in the following locations:

– Evaluation Summary

– Signature Explorer

– Bundle Explorer

1. Open the Annotations Wizard.

Right-click on the signature title and select Annotations > Manage Annotations from the 
context menu. 

2. Click Add. 

This displays the Add dialog box.

3. Select an Annotation Type.

Select one of the following:

– Ignore — Ignore this signature for the specified targets. 

– Flag — Flag this signature for the specified targets.

4. (Optional) Enter a Name and Comment for the annotations.
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5. Select an Annotation Target.

Click the down-arrow next to the Apply to field to display a drop-down menu of 
Annotation Targets. Select one of the following:

– All Domains — Apply this annotation to this signature for all domains.

– This Domain — Apply this annotation to this signature for this domain, only. This 
option is available only if you are annotating a signature in an Evaluation Summary.

– This Evaluation — Apply this annotation to this signature in this evaluation, only. 
This option is available only if you are annotating a signature in an Evaluation 
Summary.

6. Click Finish.

This adds the new annotation to the Annotations list for the selected signature.

7. Click OK. 

This returns to the Guardian main window. Note that a decoration has been added to the 
icon for the annotated signature.

Edit Annotation
To change an existing annotation, do the following:

1. Navigate to the Signatures List containing the signature with the annotation you want to 
modify.

Note: If the signature is not included in the Signatures List(s), you may need to temporarily 
set one or more filter attributes to Show. For instructions, see “Filter Signatures” on 
page 63.

2. Open the Annotations Wizard.

Right-click on the title of the annotated signature and select Annotations > Manage 
Annotations from the context menu.

3. Select the annotation to be modified and click Edit. 

Note: The Edit button will be greyed out (deactivated) until you select an annotation.

This displays the Edit dialog box for the selected annotation.

4. Enter your changes.
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5. Click Finish.

This updates the Annotations list with your changes.

6. Click OK.

This updates the appropriate Signatures Lists and returns to the Guardian main window.

Note: If you modified any filter settings in step 1, you can reset the filters to their original 
settings now. For instructions, see “Filter Signatures” on page 63. 

Delete Annotation
To delete an annotation, do the following:

1. Navigate to the Signatures List containing the signature with the annotation you want to 
delete.

Note: If the signature is not included in the Signatures List(s), you may need to temporarily 
set one or more filter attributes to Show. For instructions, see “Filter Signatures” on 
page 63. 

2. Open the Annotations Wizard.

Right-click on the title of the annotated signature and select Annotations > Manage 
Annotations from the context menu.

3. Select the annotation to be modified and click Delete. 

Note: The Delete button remains deactivated until you select an annotation.

This removes the annotation from the Annotations list for that signature.

4. Click OK. 

This updates the appropriate Signatures Lists and returns to the Guardian main window.

Note: If you modified any filter settings in step 1, you can reset the filters to their original 
settings now. For instructions, see “Filter Signatures” on page 63. 
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View Annotations
You can view the annotations for a signature by selecting the signature and then opening the 
Annotations Wizard. The Annotations Wizard displays a table of all annotations for the selected 
signature.

You can access the Annotations Wizard from the Signatures List in any of the following 
contexts:

Evaluation Summary

Signature Explorer

Bundle Explorer

To open the wizard, right-click on a signature title and select Annotations > Manage 
Annotations from the context menu. 

Filter Annotated Signatures
You can use Signature Filters to specify which signatures to display in the Signature Explorer, 
Bundle Explorer, and Evaluation Summaries. Some filters apply specifically to annotated 
signatures and their attributes.

This section provides instructions for applying filters to annotated signatures, only. For complete 
instructions on using Signature Filters, see “Filter Signatures” on page 63.

To apply Annotation Filters, do the following:

1. Open the Evaluation Summary to which you want to apply the filter. 

2. Open the Filter Configuration wizard.

In the Signatures List, right-click on a signature name and select Filters... from the context 
menu.

3. Specify your filter settings.

Click a radio button to specify Show or Hide for each filter. The Signature Filters that 
apply to annotations are as follows:

Type — Filter annotated signatures according to Annotation Type. Click a checkbox to 
select/deselect a type. There are two Annotation Types: Flag and Ignore. The default is 
Hide signatures with an Annotation Type of Ignore. 
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Annotation Name — Filter annotated signatures according to Annotation Name. Specify 
all or a portion of an Annotation Name to use as the filter criteria. This can be a character 
string or a standard regular expression. Enter .* to filter all annotated signatures. The 
default is Show all (.*).

Comment — Filter annotated signatures according to annotation comment. Specify all or a 
portion of a comment to use as the filter criteria. This can be a character string or standard 
regular expression. Enter .* to filter all signatures. The default is Show all (.*).

4. Click OK.

This applies your filter specifications and returns to the Guardian main window.

Bundles
This section provides instructions for the following tasks:

Explore Bundles

View Bundle Overview

Explore Bundles
You can use the Bundle Explorer to view the available Signature Bundles and their contents. For 
a detailed description of the Bundle Explorer, see “Bundle Explorer” on page 101 in Chapter 3, 
“Reference.”

View Bundle Overview
To display an overview of the contents of a Bundle, do the following:

1. In the Navigation Pane, click the Bundle Explorer tab to open the Bundle Explorer.

2. In the Bundle Explorer, double-click on a bundle name.

This displays the selected Bundle Overivew in the Document Pane.
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Shortcuts
This section provides instructions for the following tasks:

Create Shortcut

Evaluate Shortcut

Delete Shortcut

A Shortcut enables you to streamline the evaluation procedure by predefining and storing the 
domain, Signature Bundle, and other parameters for evaluations that you perform frequently. You 
can then evaluate the Shortcut, saving you the effort of re-entering the values each time you want 
to run the evaluation. 

Create Shortcut
A Shortcut enables you to predefine the evaluation parameters for evaluations you perform 
frequently, saving you the effort of re-entering the values each time you run the evaluation.

There are two ways to create a Shortcut:

Create Shortcut with Shortcut Wizard — Use this method if you want to quickly create a 
Shortcut without evaluating the selected domain.

Create Shortcut with Evaluation Wizard — Use this method if you want to create a 
Shortcut when evaluating a domain. This method also enables you to enter and save the 
Administrator login credentials so that you do not have to enter them each time you 
evaluate the Shortcut. 

The following sections describe each of these procedures.

Create Shortcut with Shortcut Wizard
Use the Shortcut Wizard if you want to quickly create a Shortcut without evaluating the selected 
domain. However, you will not be able to enter and save the login credentials for the WebLogic 
Server Administrator or Monitor account. Consequently, you will need to enter these each time 
you evaluate the Shortcut. For instructions on storing the login credentials when creating a 
Shortcut, see “Create Shortcut with Evaluation Wizard” on page 71.
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To use the Shortcut Wizard to create a Shortcut, do the following:

1. Open the Shortcut Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+S. 

– Select File > New > Shortcut.

– Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
click Add Shortcut in the Shortcuts Table toolbar. 

– Right-click in the Domain Explorer or Shortcut Explorer and select Add Shortcut 
from the context menu. 

2. Select the domain to associate with the Shortcut. 

3. Select the Signature Bundle to associate with the Shortcut.

Select a Signature Bundle from the Bundle field drop-down menu. This is the Bundle that 
will be evaluated against the specified domain when you evaluate the Shortcut. The default 
is Default Signatures. 

4. Select the Create Shortcut checkbox and enter a brief name for the Shortcut.

5. Click Finish.

This adds the new Shortcut to the Shortcuts Table and the Shortcut Explorer tree. For 
instructions on evaluating a Shortcut, see “Evaluate Shortcut” on page 72.

Create Shortcut with Evaluation Wizard
You can create a Shortcut by selecting the Save as Shortcut option when using the Evaluation 
Wizard to evaluate a domain. This method of creating a Shortcut enables you to enter and store 
the Administrator login credentials so that you need not enter them each time you evaluate the 
Shortcut.

To use the Evaluation Wizard to create a Shortcut, do the following:

1. Open the Evaluation Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+E. 

– Select File > New > Evaluation.

– Right-click in the Domain Explorer and select Evaluate from the context menu. 
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2. Select the domain to associate with the Shortcut. 

3. In the Bundle field, select the Signatures Bundle to associate with the Shortcut.

Select a Signature Bundle from the Bundle field drop-down menu. This is the bundle that 
will be evaluated against the specified domain when you evaluate the Shortcut. The default 
is Default Signatures. 

4. Enter the Username and Password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

5. (Optional) Select the Remember username/password checkbox to store your login 
credentials for the selected domain(s).

Select this option if you want your login information to persist so that you do not have to 
enter it each time you evaluate this Shortcut. This is especially useful if you will be 
evaluating the Shortcut on a frequent basis. Usernames and passwords are encrypted when 
stored.

6. Select the Create Shortcut checkbox and enter a brief name for the Shortcut.

7. Click Finish.

This adds the new Shortcut to the Shortcuts Table and the Shortcut Explorer tree. For 
instructions on evaluating a Shortcut, see “Evaluate Shortcut” on page 72.

Evaluate Shortcut
A Shortcut enables you to predefine the evaluation parameters for evaluations you perform 
frequently, saving you the effort of re-entering the values each time you run the evaluation. To 
evaluate a Shortcut, use the Shortcut Evaluation Wizard.

To evaluate a Shortcut, do the following:

1. Open the Shortcut Evaluation Wizard.

You can do this using any of the following methods:

– Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
double-click on a Shortcut name in the Shortcut Table. 

– Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, double-click on 
a Shortcut name in the Shortcut list.

– Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, right-click on a 
Shortcut name in the Shortcut list and select Evaluate Shortcut from the context 
menu. 
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The Shortcut Evaluation Wizard opens with the predefined values for the selected 
Shortcut displayed in the domain table. You can change the Bundle selection. 

2. If necessary, enter the Username and Password for the WebLogic Server Administrator or 
Monitor account for the target domain.

If you selected the Remember username/password option when you activated the domain 
or defined the Shortcut, the Username and Password fields are prefilled. Otherwise, you 
must enter this information before launching the evaluation.

3. Click Finish.

This launches the evaluation, and returns you to the Guardian main window when the 
evaluation completes. As with a standard evaluation, the Domain Explorer History 
folders are updated to include an entry for the resulting Domain Inventory and Evaluation 
Summary. The results of the evaluation are displayed in an Evaluation Summary 
Overview in the Document Pane.

Delete Shortcut
You can use either of the following methods to delete a Shortcut:

Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
select a Shortcut from the Shortcut list and click Delete. 

Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, right-click on a 
Shortcut in the Shortcut list and select Delete Shortcut from the context menu. 

Command Line Interface
This section provides instructions for the following tasks:

Start Guardian Headless Mode

Run Scripts

Schedule Scripts

Receive Notifications

The Command Line Interface (CLI) is also referred to as Guardian Headless Mode. For a 
complete list of Guardian Command Line Interface commands and syntax, see “Command Line 
Interface” on page 134 of the Reference section of this manual. For instructions on starting the 
Command Line Interface, see the next section, “Start Guardian Headless Mode” on page 74.
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Start Guardian Headless Mode
The Guardian Command Line Interface (CLI)—also referred to as Guardian Headless Mode—is 
a set of Guardian commands that can be issued directly from the operating system command 
prompt. There is a Guardian CLI command for almost every task available in the Guardian User 
Interface. For a complete description of these commands and their syntax, see “Command Line 
Interface” on page 134 in Chapter 3, “Reference.”

To start the Guardian Command Line Interface, do the following:

Note: Guardian Command Line Interface commands are case sensitive.

1. At the operating system command prompt, change directories to the Guardian installation 
directory.
cd <root>\guardian\

Where:

<root> is the parent directory for the Guardian installation directory. 

2. Enter the Guardian Headless command.

– On Windows:
guardianHeadless.cmd

– On Linux:
guardianHeadless.sh

3. (Optional) To see a list of CLI commands and their syntax, enter the CLI Help command at 
the operating system prompt.

– On Windows:
guardianHeadless.cmd -ghelp

– On Linux:
guardianHeadless.sh -ghelp

The Command Line Interface uses your specified Guardian Workspace as the location for all CLI 
operations, unless you specify otherwise in each command. Identifying the Guardian Workspace 
location is essential for accessing the correct set of active domains, Domain Inventories, and 
Evaluation Summaries. For instructions on selecting a Guardian Workspace, see “Select 
Workspace” on page 41.
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IMPORTANT: Each command must include the prefix -g with no trailing space, as shown in 
the following examples:

guardianHeadless.cmd -glistActiveDomains 

guardianHeadless.cmd -gactivateDomain -t http://localhost:9116 -u un 
-p pw -c true -data "D:\MyData\Guardian Data Directories\
Installer-2079" 

guardianHeadless.cmd -gcreateShortcut -d Naxos_localhost_9116 -b 2 

guardianHeadless.cmd -gdeleteShortcut -s "Security Advisories in 
Naxos" 

The output of each command is sent to the following output file:
headless_output.txt

The output file is created in your current directory, and is overwritten each time you run a 
Guardian Headless Mode command.

For a complete list of Guardian Command Line Interface commands and syntax, see “Command 
Line Interface” on page 134 in Chapter 3, “Reference.”

Run Scripts
You can create a Guardian Command Line script to perform several Guardian tasks with one 
command. You can schedule scripts to run at specified times and intervals by using utilities such 
as the Windows Task Scheduler or the Linux crontab command.

To run a script, enter the following command at the operating system prompt:

On Windows:
guardianHeadless.cmd -gscript -f <script_name>

On Linux:
guardianHeadless.sh -gscript -f <script_name>

Where:

<script_name> is the path and name of your CLI script. 

To view the results of evaluations and inventories conducted from the CLI, use the Domain 
Explorer in the Guardian User Interface. 
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Schedule Scripts
To schedule a script to run automatically at a specified time, you can use utilities such as the 
Windows Task Scheduler or the Linux crontab command. For instructions on scheduling 
scripts, see your operating system documentation.

Receive Notifications
To receive notification of detected signatures, create an evaluation script and use the Windows 
Task Scheduler or the Linux crontab command to schedule the script to run at regular intervals. 
Each time the script runs, the signature.log file in the Guardian installation directory is 
updated with an entry for each detected signature. You can the configure a third party 
management tool to scan the log for detected signatures, and notify you when one is found.

Each signature.log entry starts with four number signs (####) and includes a timestamp for 
the entry. Each entry with a detected signature contains the label <detected> and is followed by 
a brief description which is also surrounded by angle brackets. The description includes the 
domain name. 

The following is a sample signature.log file:
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000022> 
<not detected> <Signature 000022 (Rotational Upgrade may cause 
java.io.StreamCorruptedException) not detected by username un evaluating 
bundle ID 0 in domain ID g-dev_slp7_7001.> 
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000027> 
<detected> <Signature 000027 (Native IO should be enabled in production mode 
for better performance) detected by username un evaluating bundle ID 0 in 
domain ID g-dev_slp7_7001.> 
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000055> 
<not detected> <Signature 000055 (JDK 1.5 is not certified for WebLogic 8.1) 
not detected by username un evaluating bundle ID 0 in domain ID 
g-dev_slp7_7001.> 
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Troubleshooting
This section provides instructions for the following tasks:

View Logfiles

Crash Recovery

Resolve Exceptions

View Logfiles
The BEA Guardian log files contain information that BEA Customer Support can use to diagnose 
and resolve issues with your system. 

The Guardian log files are as follows:

guardian.log —This is located in the Guardian installation directory you specified 
during installation. This file contains information about every operation the Guardian 
application performs. 

signature.log — This is located in the Guardian installation directory you specified 
during installation. This file contains information about each evaluation performed, 
including entries for all detected signatures. You can also use a command line script to 
automatically scan the signature.log for detected signatures, and automatically notify 
you when new signatures are detected.

.log — This is located in the .metadata subdirectory of the Guardian Workspace 
directory you specified when starting Guardian. This file contains information about 
certain Guardian operations. 

install.log — This is located in the ../configuration/org.eclipse.update 
subdirectory of the Guardian installation directory you specified during installation. This 
contains Guardian installation details. 

Crash Recovery
Guardian crashes are extremely unlikely, since Guardian uses the Eclipse Rich Client Platform. 
If Guardian does crash, simply restart Guardian. No additional cleanup operations are required.
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Resolve Exceptions
In the unlikely event of an exception, the recommended steps for resolving the issue are as 
follows:

1. Read the text of the error message to determine what is wrong.

2. Save the Exception Error window text with a screen capture, or cut and paste the text into a 
file.

3. Try the operation again to see if the issue recurs.

4. Copy the BEA Guardian log files to another location and save them for future reference 

5. Contact BEA Support for assistance 

Tip: To save log files, copy them to another location so that the error is among the last entries 
in the log file, making it easier to identify. For the location of Guardian log files, see 
“View Logfiles” on page 77.

Support
This section provides instructions for the following task:

Submit Support Case

Submit Support Case
You can use the Support Case Wizard to create a support case based on a detected signature, 
and automatically submit the case to BEA Customer Support. The wizard automatically creates 
the case with all of the signature-specific information required for a BEA support engineer to 
begin working on your case right away. You can also add any additional attachments and notes 
before sending the support case to BEA.

If you choose not to submit a support case, you can instead save the case information as a Case 
Creation Archive. Case Creation Archives are stored as files with the file name extension .car.
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Notes: Before you can create and submit a support case, you must first associate your eSupport 
ID with Guardian. For information, visit the BEA Customer Support site at 
https://support.bea.com.

If you are using a proxy server for outbound Guardian communications, make sure that 
you have enabled and tested the outbound proxy connection. For instructions, see 
“Enable and Test Outbound Proxy” on page 55.

To create and submit a support case, do the following:

1. Open the Evaluation Summary containing the signature you want to include in the support 
case.

Double-click on an Evaluation Summary entry in the Domain Explorer.

2. Select the signature you want to include in the support case.

Click on a signature entry to highlight it. This displays the Description and Remedy for 
the signature in the bottom portion of the Evaluation Summary display in the Document 
Pane.

3. Open the Support Case Wizard. 

Click the Get more help from BEA support link at the bottom of the signature Remedy 
section to open the wizard. This automatically includes the signature details in the new 
support case, and displays the first page of the Support Case Wizard, which is the 
Support Case Notes page.

4. (Optional) Enter any additional support case notes.

In the Additional Case Notes field, enter any additional text that may be helpful to BEA 
Customer Support in resolving your case. 

5. Click Next to proceed to the Select Case Attachments page.

Select the background information files to include with the support case. You can select 
one or more of the following:

– Case Attachments:

• Domain Inventory

• Detected Signature Results

– Recommended Attachments:

• Server Log
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– Other Attachments:

• Click the + icon to open a file browser from which you can select files to include. 

• Click the X icon to remove a file from the list.

6. Click Next to proceed to the Select Case Destination page.

7. Select the destination for the case. 

Select one of the following:

– Submit Case to BEA Support — Select this if you want to connect to the BEA 
Customer Support sita and upload the support case. 

– Save Case Creation Archive — Select this to save the support case as a Case Archive 
for uploading later. Enter the location to which to save the file, or click the elipsis (...) 
to open a file browser from which you can select the location. 

8. Click Next to proceed to the eSupport Login page.

9. Enter your eSupport Username and Password.

If you elected to submit the case, enter your eSupport Username and Password. If you 
elected to save the case as an archive for later submittal, these fields are disabled.

10. Click Next to proceed to the Select eSupport Site ID page.

11. Select the eSupport Site Identifier to use for this case.

Select an ID from the Enter Site ID drop down menu. If you have only one eSupport Site 
Identifier, this field is disabled. Otherwise, select an identifier from the Select Site drop 
down list. 

12. Click Finish to submit the case. 

If you elected to save the case to an archive file, a Case Creation Complete dialog box 
displays the date, time, and location of the file.

If you elected to submit your case, Guardian proceeds to connect to the eSupport site and 
submit the new support case to BEA Customer Support. When the submission completes, a 
Case Creation Complete dialog box displays the date, time, and location of the archive 
file. 

13. Click OK.

This dismisses the dialog box and returns to the Guardian main window.
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Updates and Upgrades
This section provides instructions for the following tasks:

Automatically Update Guardian

Manually Update Guardian

Check Product Configuration

Notes: Before you can update or upgrade Guardian, you must first associate your eSupport ID 
with Guardian. For information, visit the BEA Customer Support site at 
https://support.bea.com.

If you are using a proxy server for outbound Guardian communications, make sure that 
you have enabled and tested the outbound proxy connection. For instructions, see 
“Enable and Test Outbound Proxy” on page 55.

Automatically Update Guardian
To update Guardian, use the Update Wizard to download new BEA Guardian software and 
signatures from the BEA Guardian update site, http://guardian.bea.com/update.

Notes: Before you can update or upgrade Guardian, you must first associate your eSupport ID 
with Guardian. For information, visit the BEA Customer Support site at 
https://support.bea.com.

If you are using a proxy server for outbound Guardian communications, make sure that 
you have enabled and tested the outbound proxy connection. For instructions, see 
“Enable and Test Outbound Proxy” on page 55.

To update Guardian, do the following:

1. Open the Update Wizard.

Use one of the following methods to open the wizard:

– Press Ctrl+Shift+U. 

– Click the Update button on the Main Toolbar. 

– Select Help > Software Updates > Guardian Updates. 

2. Enter your BEA eSupport Username and Password to access your eSupport site identifiers.
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3. (Optional) Select the Remember Username/Password checkbox to store your login 
credentials for future use.

Select this option if you want your login information to persist so that you do not have to 
enter it each time you create a support case.

4. Click Next to proceed to the Select eSupport Site Id page.

5. Select your eSupport site identifier.

This displays the Password Required dialog box for connecting to the Guardian Update 
Site.

6. Click Next to proceed to the Password Required page.

7. Enter your BEA eSupport Username and Password and click OK.

This connects to the Guardian Update Site, initiates a search for new updates, and displays 
the results in the Search Results page of the wizard.

8. Select the available features to install.

Expand the folders in the Select the features to install tree to see the available selections.

To select features, do the following:

a. (Optional) To filter the results, you can select from the following filter options:

• Show the latest version of a feature only to display only the current version of 
each feature in the results.

• Select Filter patches included in other patches on the list to filter out duplicate 
patch entries.

b. (Optional) Click More Info to see details about a selection.

c. (Optional) Click Properties to display the properties for a selection.

d. (Optional) Click Select Required to automatically select all required updates.

e. Click the checkbox beside a feature name to select/deselect it.

9. Click Next to proceed to the Feature License page.

Accept the terms in the license agreement to proceed with the installation.

10. Click Next to proceed to the Installation page.
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11. Select the installation location, or accept the default.

Click Change Location to open a directory browser from which you can select the 
location. Click OK to enter your selection and close the browser. Click Next to proceed.

12. Verify the list of features to install, and click Install or Install All.

After the updates are installed, you are prompted as to whether to restart Guardian.

13. Click Yes to restart Guardian and incorporate the new features. 

Manually Update Guardian
To update Guardian on servers that do not have Internet access, you can perform a manual update. 
To do so, first automatically update Guardian on a server that has Internet access, and then copy 
the updated files to the server(s) without access.

WARNING: If you are upgrading from Guardian 1.0.x to Guardian 1.1.0 and want to preserve 
your Guardian Registry, you must first back up and then manually update the 
Guardian Registry. For instructions, see “Manually Update Guardian Registry” 
on page 86. Please also refer to the Guardian 1.1 Installation Guide and Guardian 
1.1 Release Notes for additional important information.

To manually update Guardian, do the following;

1. Automatically update Guardian on a server that has Internet access.

For instructions, see “Automatically Update Guardian” on page 81.

2. Shut down Guardian on the offline server(s).

Select File > Exit from the titlebar menu.

3. Update the Guardian Signatures Repository on the secure (offline) machine.

Copy the following directory and all of its contents from the updated server to the offline 
server(s) you want to update, overwriting the old contents:

<..>\guardian\repository\archives

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

Note: If you only want to update the Guardian Signatures Repository but not the Guardian 
application itself, you can skip the remainder of these steps.
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4. (Optional) Remove the old Signature Features directories from the offline server(s).

The Signature Features directories are kept in the following directory:

<..>\guardian\features\

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

The Signature Features directories are named according to the following convention:

com.bea.guardian.feature.signature.weblogic_<old_version>

Where:

<old_version> is the old signature release version. 

For example:
..\guardian\features\com.bea.guardian.feature.signature.weblogic_1.0.42

5. Copy the updated Signatures Features directory to the offline server(s).

Copy the following directory and all of its contents from the updated machine to the offline 
server(s):
..\guardian\features\com.bea.guardian.feature.signature.weblogic_<CurVersion>

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

<CurVersion> is the most current signature release version. 

6. (Optional) Remove the old Signature Plugins JAR files from the offline server(s).

The Signature Plugins JAR files reside in the following directory:

<..>\guardian\plugins\

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.
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The files are named according to the following convention:

com.bea.guardian.signature.weblogic_<old_version>

Where:

<old_version> is the old signature release version. 

7. Copy the updated Signatures Plugins file to the offline server(s).

Copy the following file from the updated machine to the offline server(s):
..\guardian\plugins\com.bea.guardian.signature.weblogic_<CurVersion>

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

<CurVersion> is the most current signature release version. 

8. Restart Guardian on the newly-updated offline servers.

9. Check the new configuration.

Do the following:

a. Select Help > Manage Guardian to open the Product Configuration page.

b. In the Product Configuration tree (left pane), expand the BEA Guardian folder and 
subfolders.

c. Check the version numbers for each item.
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Manually Update Guardian Registry
If you are upgrading from Guardian 1.0.x to Guardian 1.1, you must manually update the 
Guardian Registry. For instructions, please see the Guardian 1.1 Installation Guide and the 
Guardian 1.1 Release Notes.

Check Product Configuration
You can use the Product Configuration page to check the current configuration for a Guardian 
installation. This is especially useful if you have manually updated Guardian and want to check 
that the update was completed correctly.

To check the current Guardian configuration, do the following:

1. Select Help > Manage Guardian to open the Product Configuration page.

2. In the Product Configuration tree (left pane), expand the BEA Guardian folder and 
subfolders.

3. Check the version numbers for each item.
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C H A P T E R 3

Reference

This chapter provides a detailed description of the Guardian User Interface components and 
features, and a detailed reference guide to the Guardian Command Line Interface. Topics include 
the following:

Main Menu

Main Toolbar

Keyboard Shortcuts

Navigation Pane

Document Pane

Preferences

Wizards

Log Files

Command Line Interface
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Main Menu
The BEA Guardian Main Menu is located below the Main Titlebar and above the Main Toolbar. 
Running from left to right, the Main Menu headings are:

File 

Tools 

Window 

Help 

File Menu
The menu options in the File menu are:

New - Opens a submenu with: 

– Domain - Invokes the Domain Activation Wizard. 

– Inventory - Invokes the Inventory Wizard. 

– Evaluation - Invokes the Evaluation Wizard. 

– Shortcut - Invokes the Shortcut Wizard. 

Close - Closes the most recently opened or most recently active editor in the Document 
Pane. 

Close All - Closes all the open editors in the Document Pane. 

Print - Prints the contents of the Report tab for whichever one of these editors is active in 
the Document Pane: 

– Domain Inventory 

– Evaluation Summary 

– Signature Details 

– Bundle Details 

Import - Reserved for future use. 

Export - Reserved for future use. 

Exit - Closes the Guardian application. 
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Tools Menu
The menu options in the Tools menu are:

Refresh Site List - Updates the list of BEA Support site identifiers available for creating 
support cases. 

Purge Inactive Domains - Removes domains that have been deactivated from the Domain 
Explorer and the Guardian Registry. The Domain Inventories, Evaluation Summaries, and 
Case Creation Archives for each purged domain are deleted from the Guardian Workspace 
on disk. 

View Log - Opens the Guardian Log file and the Signature Log file. 

Window Menu
The menu options in the Window menu are:

Show View - Opens a submenu with the following choices to open certain views. Please 
note that if a view is already open it is brought to the forefront and made active rather than 
cloned: 

– Domain Explorer - Opens the Domain Explorer view in the Navigation Pane. 

– Bundle Explorer - Opens the Bundle Explorer view in the Navigation Pane. 

– Shortcut Explorer - Opens the Shortcut Explorer view in the Navigation Pane. 

– Signature Explorer - Opens the Signature Explorer view in the Navigation Pane. 

– Active Domains Table - Opens the Active Domains Table view in the Document Pane. 

– Shortcuts Table - Opens the Shortcuts Table view in the Document Pane. 

– Progress View - Opens the Progress View to the left of the Document Pane. 

– Outline View - Opens the Outline View to the right of the Document Pane. 

Reset Perspective - Resets the Guardian application window settings to their original 
values. This includes opening and arranging all of the Navigator views, opening the 
Outline and Progress views, and resizing the Document Pane. Any open views and editors 
remain open. 

Preferences - Opens the Preferences page. 
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Help Menu
The menu options in the Help menu are:

Welcome - Opens the Guardian Welcome Page. 

Help Contents - Opens the Guardian help system, which includes the Guardian User Guide, 
a guide to using the Guardian help, and a utility for searching help. 

Search - Opens a utility that searches the Guardian User Guide for the text you enter. 

Dynamic Help - Opens the Guardian dynamic help system. Dynamic help displays all the 
help text from the Guardian User Guide relating to the currently active view or editor. The 
dynamic help automatically updates itself to match each view or editor you select. 

Tips and Tricks - Opens a dialog box to select a Guardian Tips and Tricks table. The Tips 
and Tricks table describes how to perform certain Guardian tasks more efficiently. 

Cheat Sheet - Opens a dialog box to select a Guardian Cheat Sheet. The Cheat Sheet shows 
how to perform certain Guardian tasks, step by step. Some of the steps can be done for you 
automatically at the press of a button. 

Manage Guardian - Open the Manage Guardian submenu containing the following options:

– Update Guardian - Invoke the Update Wizard. 

– Manage Configuration - Open the Product Configuration Manager. You can use this to 
perform the following tasks: 

• Scan for Updates - Search for updates for all installed features and invokes the 
Update Wizard. 

• View Installation History - View all activites since installation of the product. 

• Show Activities - Display the steps that led to the current Guardian configuration.

• Add an Extension Location - Locate and add an Extension Location to the current 
configuration. An Extension Location contains all features and plugins previously 
installed.

Key Assist - Display a list of the Guardian Keyboard Shortcuts. 

About BEA Guardian - Display the Guardian version and features, plug-ins, and 
configuration details. 
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Related Tasks
Deactivate Domain 

Submit Support Case 

Related Reference
Domain Activation Wizard 

Evaluation Wizard 

Shortcut Wizard 

Document Pane 

Domain Inventory 

Evaluation Summary 

Signature Details 

Bundle Details 

Navigation Pane 

Domain Explorer 

Bundle Explorer 

Shortcut Explorer 

Signature Explorer 

Active Domains Table 

Shortcuts Table 

Keyboard Shortcuts 

Main Toolbar
The BEA Guardian Main Toolbar is located below the Main Titlebar and Main Menu and above 
the Navigation Pane. Running from left to right, the Main Toolbar buttons are:

Open - Opens the selected resource for editing or execution: 
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– Active Domains Table when Target Domains is selected in the Domain Explorer 

– Domain Inventory when a Domain Inventory is selected in the Domain Explorer 

– Evaluation Summary when an Evaluation Summary is selected in the Domain Explorer 

– Signature Details when a signature is selected in the Signature Explorer and Bundle 
Explorer 

– Bundle Details when a bundle is selected in the Bundle Explorer 

– Evaluation Wizard when a shortcut is selected in the Shortcut Explorer. 

Print - Prints the contents of the Report tab for whichever one of these editors is active in 
the Document Pane: 

– Domain Inventory 

– Evaluation Summary 

– Signature Details 

– Bundle Details 

Activate - Invokes the Domain Activation Wizard. 

Inventory - Invokes the Inventory Wizard. 

Evaluate - Invokes the Evaluation Wizard. 

Update - Invokes the Update Wizard. 

When the mouse pointer is over a toolbar button, a tool tip window pops up under the 
mouse pointer that says what the button does.

Related Reference
Navigation Pane 

Document Pane 

Active Domains Table 

Domain Explorer 

Domain Inventory 

Evaluation Summary 

Signature Details 
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Signature Explorer 

Bundle Explorer 

Bundle Details 

Shortcut Explorer 

Domain Activation Wizard 

Inventory Wizard 

Evaluation Wizard 

Update Wizard 

Keyboard Shortcuts
The Keyboard Shortcuts are sequences of keystrokes that enable you to perform certain Guardian 
graphical user interface operations without using the mouse pointer.

The following table lists the Guardian Keyboard Shortcuts and can be displayed by pressing 
Ctrl+Shift+L:

Related Reference
Main Menu 

Main Toolbar 

Navigation Pane
The Navigation Pane contains the follow views, which by default display on the left hand side of 
the BEA Guardian window:

Domain Explorer 

Bundle Explorer

Signature Explorer 

Shortcut Explorer 
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Explorer Toolbar Icons
Each Explorer toolbar may contain all or some of the following active icons:

Related Reference
Domain Explorer 

Bundle Explorer 

Signature Explorer 

Shortcut Explorer 

Icon Name

Close

Minimize

Maximize

Restore

Expand all items

Collapse all items

Menu

Link with Editor
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Domain Explorer
The Domain Explorer is a Navigator view that enables you to browse and interact with the 
domains that you have activated.

Domain Nodes
The first time you activate a domain, a domain node is added to the Target Domains folder. To 
distinguish between domains that could have the same name, the domain node name is a 
generated name. The generated name includes the host name and listen port you entered in the 
Domain Activation Wizard. The domain node name is also known as the domainId in the 
Guardian Command Line Interface.

The format of the generated domain name is: <domain name>_<host name>_<listen 
port>. For example, guardian-test_mj23_32292, would be the domain node name for a domain 
named "guardian-test" activated with a host name, "mj23", and a listen port, "32292".

The Domain Explorer includes both active and inactive domain nodes. Active domain nodes are 
listed in bold. Inactive domain nodes are not bold. Inactive domain nodes can be removed with 
the Purge Inactive Domains option in the Tools menu.

Domain nodes also include icons. As indicated below, one icon is for active domains and one is 
for inactive domains. Active domains can also be decorated with icons that indicate whether the 
username and password have been persisted, and whether the domain requires SSL encryption 
for all communication. Please note that Guardian uses 128 bit open source encryption for SSL.

The following graphic and table shows five domains with their icons:

Icon Meaning

Domain is active.

Domain is inactive.

Username and password have been persisted (icon decorates active domain 
icon).

Domain requires 128 bit SSL (icon decorates active domain icon).
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Domain History Folders
Each domain node contains folders that accumulate all your Domain Inventories and Evaluation 
Summaries. These folders are persisted on disk in the Guardian Workspace.

Inventory History Folder
Every time you activate, evaluate, or inventory a domain, a new Domain Inventory is created and 
added to the Inventory History folder for that domain. If you double-click a Domain Inventory, a 
Domain Inventory editor opens in the Document Pane.

To distinguish between Domain Inventories, the Domain Inventory name is a generated name. To 
enforce uniqueness, the generated name includes the domain name, host name, listen port, date 
and time it was created, in the format: <domain name>_<host name>_<listen 
port>_<date> <time>.

Evaluation History Folder
Every time you evaluate a domain, a new Evaluation Summary is created and added to the 
Evaluation History folder for that domain. If you double-click an Evaluation Summary, an 
Evaluation Summary editor opens in the Document Pane.

To distinguish between Evaluation Summaries, the Evaluation Summary name is a generated 
name. To enforce uniqueness, the generated name includes the bundle evaluated, date and time it 
was created, in the format: <bundle name>_<date> <time>.

The Evaluation Summary entry includes an icon that indicates whether any signatures were 
detected. If any signatures were detected, the icon is decorated with a severity indicator. The icon 
with its severity indicator identifies the most severe signature detected:

Domain Name Active/ 
Inactive

Password Persisted/ Not 
Persisted

128 bit SSL Enabled/ 
Not Enabled

816clusterdomain Inactive N/A N/A

guardian-dev Active Not Persisted Not Enabled

mydomain Active Persisted Not Enabled 

QA_815_windows Active Not Persisted Enabled

WLS92cluster Active Persisted Enabled
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Domain Explorer Menu
Click the Domain Explorer menu icon to display a menu containing the following options:

Filter Domain Explorer — This opens the Filter Domain Explorer dialog box. This 
enables you to filter out the older Domain Inventories and Evaluation Summaries.

Link with Editor — Link selected item with an Editor.

Domain Explorer Context Menu
The Domain Explorer has a context menu. To open it, right-click inside the Domain Explorer. 
The menu that pops up includes these choices:

Delete 

Activate 

Deactivate 

Modify Domain 

Inventory 

Add Shortcut 

Evaluate 

Evaluate Bundle 

Icon Severity Meaning

Critical The evaluation detected at least one critical signature.

Warning The evaluation detected at least one warning signature and 
no critical signatures.

Informational The evaluation detected at least one informational 
signature and no critical or warning signatures.

No Signature The evaluation did not detect any signatures.
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Please note that if you right-click any entry in an expanded, active domain node, or any entry in 
an active domain node is selected when you right-click, the Inventory, Add Shortcut, Evaluate, 
and Evaluate Bundle menu options will proceed as if that is the domain you want to target. Also, 
the Deactivate and Modify Domain menu options are unavailable unless you right-click directly 
on an active domain node, or an active domain node is selected when you right-click. Conversely, 
the Activate menu option is unavailable if an active domain node is selected.

The Delete menu option deletes the Domain Inventories and Evaluation Summaries that are 
selected in the Domain Explorer. It deletes the entries from the Domain Explorer as well as the 
underlying files from the Guardian Workspace. A confirmation box enables you to cancel the 
deletion. You can also use the Delete key on your keyboard to delete any selected Domain 
Inventories and Evaluation Summaries.

The Evaluate Bundle menu option opens a submenu that lists all the bundles available for 
evaluation. Selecting any of them invokes the Bundle Evaluation Wizard. The Bundle Evaluation 
Wizard opens with the currently selected domain and the bundle you select, just as if you had 
invoked a shortcut. The Bundle Evaluation Wizard works just like the Shortcut Evaluation 
Wizard. Unless an active domain node or one of its entries is selected, or you right-click an active 
domain node or one of its entries, the bundle list is greyed out and cannot be selected.

Domain Properties
The Domain Properties dialog box enables you to modify how BEA Guardian accesses a target 
domain. In particular, you can change:

The username and password Guardian uses to access the domain 

Whether to remember the username and password 

Whether to use a proxy server to access the domain 

There are two different ways to open the Domain Properties dialog box:

Select a domain in the Active Domains Table and click the Modify Domain button. 

Right-click a domain in the Domain Explorer and select Modify Domain. 

The Domain Properties dialog box includes the following components:

The domain name, read only 

The URL of the domain's Administration Server, read only 

The username and password of an administrator account on the domain 
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Please note that changing the username and password in Guardian does not change the 
username and password on the domain.

Whether to remember the username and password 

If selected, the username and password are encrypted and stored on disk. Then, whenever 
you evaluate, inventory, modify, or open an admin console to the domain, or submit a 
support case, the domain's username and password are filled in automatically. Otherwise, 
you have to enter them for each operation that accesses the domain.

Whether to use a proxy server to access the domain 

If selected, you must select the name of the proxy server from the drop down list. If there 
are no proxy servers in the drop down list, the Enable proxy connection check box is 
disabled. To add a proxy server, select Proxy from the Preferences page. Please note that in 
order to use a proxy server, you must also manually deploy the Guardian Agent onto the 
target domain.

Related Tasks
Evaluate Domain 

Inventory Domain 

Create Shortcut 

Submit Support Case 

Related Reference
Active Domains Table 

Domain Explorer 

Preferences 

Signature Explorer
The Signature Explorer is a Navigator view that enables you to browse and interact with the 
available signatures.

The signature entries include the following severity indicator icons. The severity indicator 
approximates the level of attention you should give the signature when it is detected.
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Double-click a signature in the Signature Explorer, to opena a Signature Details editor in the 
Document Pane.

Signature Explorer Titlebar
The Signature Explorer Titlebar contains the following active (clickable) icons:

Signature Explorer Menu
Click the Signature Explorer Menu icon to open a menu of options for sorting and filtering the 
signature list. These are as follows:

Icon Severity

Critical

Warning

Informational

Icon Name

Close

Minimize

Maximize

Restore

Menu
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The Sort Signatures submenu offers you these choices: 

– By Name - lists the signatures alphabetically by name. This is the default ordering 
when you first open the Signature Explorer. 

– By Severity - groups the signatures by severity level, and then lists the signatures 
alphabetically by name within each severity level. 

The Filters menu option opens the Signature Filters dialog box which enables you to 
specify which signatures you want to see listed in the Signature Explorer. 

Signature Explorer Context Menu
Right-click on a signature name in the Signature Explorer to display the Signature Explorer 
context menu with the following option:

Annotations — This opens a submenu with the following option:

– Manage Annotations: Select this to open the Annotations Wizard. For instructions on 
using this wizard, see “Signature Annotations” on page 64 of Chapter 2, “Tasks.”

Related Reference
Signature Details 

Document Pane 

Filters Wizard 

Bundle Explorer
The Bundle Explorer is a Navigator view for browsing and managing the available signature 
bundles.

The Bundle Explorer contains a top level folder named Bundles. In the Bundles folder is a node 
for each bundle that is available for evaluation. Each bundle node contains all the signatures for 
that bundle.

Signatures are grouped into different bundles based on their characteristics. For example, the 
Security Advisories bundle contains signatures that detect potential security problems for which 
BEA has issued security advisories. The Service Pack Remedy bundle contains signatures whose 
resolution requires installation of a specific service pack. The Bundle Details editor describes 
each of the Guardian signature bundles.
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The signature entries in each bundle node include the following severity indicator icons. The 
severity indicator approximates the level of attention you should give the signature when it is 
detected.

Double-click a bundle in the Bundle Explorer to open a Bundle Details editor in the Document 
Pane. Double-click a signature in the Bundle Explorer to open a Signature Details editor in the 
Document Pane.

Bundle Explorer TitleBar
The Bundle Explorer Titlebar contains these icons you can click:

Icon Severity

Critical

Warning

Informational

Icon Name

Close

Minimize

Maximize

Restore

Expand all items
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Bundle Explorer Menu
Click the Bundle Explorer Menu icon to open a menu with the following options:

Filters... — This opens the Filters dialog box for filtering signatures in Detected Signatures lists. 

Sort Signatures — This displays a submenu with options for sorting the signatures 
displayed in each bundle. From the Sort Signatures submenu, you can select:

– By Bundle Name, Signature Name - lists the signatures in each bundle alphabetically 
by name. This is the default ordering when you first open the Bundle Explorer. 

– By Bundle Name, Severity - groups the signatures in each bundle by severity level, 
and then lists the signatures alphabetically by name within each severity level. 

Note: Selecting either of the Sort Signatures choices collapses all the bundle nodes. To see 
the signatures in their new sort order, either click each bundle node individually to 
expand it, or click the Expand all items icon to expand all the bundle nodes.

Link with Editor — Link selected item with an editor.

Bundle Explorer Context Menu
Right-click on a signature name in the Bundle Explorer to display the Bundle Explorer context 
menu with the following option:

Annotations — This opens a submenu with the following option:

– Manage Annotations: Select this to open the Annotations Wizard. For instructions on 
using this wizard, see “Signature Annotations” on page 64 of Chapter 2, “Tasks.”

Related Reference
Bundle Details 

Document Pane 

Signature Details 

Collapse all items

Menu
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Shortcut Explorer
The Shortcut Explorer is a Navigation Pane view for managing the shortcuts you have created.

If you double-click a shortcut in the Shortcut Explorer, the Shortcut Evaluation Wizard opens 
with the shortcut target domain and signature bundle preselected. Shortcuts save steps by saving 
the domain and bundle so you do not have to select them each time you perform an evaluation.

Shortcut Explorer Context Menu
The Shortcut Explorer has a context menu. To open it, right-click inside the Shortcut Explorer. 
The menu that pops up contains the following options:

Add Shortcut 

Delete Shortcut 

Evaluate Shortcut 

If you right-click a shortcut, or a shortcut is selected when you right-click, the Delete Shortcut 
and Evaluate Shortcut menu options will proceed as if that is the shortcut you want to delete or 
evaluate. Conversely, the Delete Shortcut and Evaluate Shortcut menu options are unavailable 
unless you right-click directly on a shortcut, or a shortcut is selected when you right-click.

Related Tasks
Create Shortcut 

Delete Shortcut 

Evaluate Shortcut 

Related Reference
Navigation Pane 

Shortcut Evaluation Wizard 
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Document Pane
The Document Pane is the location where these BEA Guardian views and editors open, by default 
in the central region of the BEA Guardian window:

Active Domains Table 

Domain Inventory 

Evaluation Summary 

Signature Details 

Bundle Details 

Shortcuts Table 

Related Reference
Active Domains Table 

Domain Inventory 

Evaluation Summary 

Signature Details 

Bundle Details 

Shortcuts Table 

Active Domains Table
The Active Domains Table is a Document Pane view for managing the domains you have 
activated.

To open the Active Domains Table, select Show View > Active Domains Table from the BEA 
Guardian Window Menu.

The Active Domains Table lists the active domains, each having these columns:

Domain: the domain name 

Administration Server URL: the URL of the domain's Administration Server 
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Last Evaluation: the name of the Evaluation Summary for the most recent evaluation 
performed. 

By default, the domains are listed alphabetically by domain name. Clicking a column heading 
sorts the domains by that column. For example, clicking the Last Evaluation column sorts the 
domains alphabetically by the Evaluation Summary name of the last evaluation. Clicking the 
same column heading in succession alternates between sorting in alphabetical order and reverse 
alphabetical order.

Active Domains Table Toolbar
The Active Domains Table toolbar contains the following buttons. Please note that they cannot 
be clicked until you select one of the active domains listed:

Open Admin Console - opens a BEA Weblogic Server Administration Console in your 
Web browser. The Administration Console is a Web application that is hosted by the 
Administration Server which you specified in the Domain Activation Wizard. 

If you selected the Remember username/password check box when activating or modifying 
the domain, the browser will automatically log you into the Administration Console. If not, 
the browser will start at the Administration Console login page.

Administration Console documentation can be found on the BEA eDocs website for:

– BEA WebLogic Server 9.1 

– BEA WebLogic Server 8.1 

Modify Domain - opens the Domain Properties dialog box, which enables you to change 
how Guardian accesses the domain. 

Deactivate Domain - invokes the Domain Deactivation Wizard to deactivate the domain. 

Related Tasks
Activate Domain 

Create Shortcut 

Related Reference
Document Pane 

Evaluation Summary 
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Domain Activation Wizard 

Domain Properties 

Domain Deactivation Wizard 

Main Menu 

Domain Inventory
A Domain Inventory is an XML document, persisted in the Guardian Workspace, that describes 
the products in your domain. The Domain Inventory editor in the Document Pane enables you to 
interact with the Domain Inventory to better understand how BEA Guardian evaluates your 
domain.

A Domain Inventory is created when you activate a domain and a new one is created each time 
you evaluate a domain. You can also create a new Domain Inventory with the Inventory Wizard. 
The Inventory History folder in the Domain Explorer contains all the Domain Inventories for a 
domain.

You can open a Domain Inventory editor in any of the following ways:

Activate a domain, or inventory a domain. Then click the OK button in the Progress View. 

Double-click a Domain Inventory in the Inventory History folder of a domain in the 
Domain Explorer. 

Domain Inventory Tabs
On the bottom of the Domain Inventory editor are the following tabs for the different Domain 
Inventory representations. Please note that these representations are read only:

Overview - provides a summary of the Domain Inventory. It contains the following 
sections: 

– General Information - the domain name and date and time the Domain Inventory was 
created. 

– Servers - the number of servers in the domain, the number of servers active at the time 
of the inventory, a list of the servers, and information about each server. Please note 
that if a server is down at the time of an evaluation, it could mask some signatures from 
being detected. 

When you click on a server in the list, the following server information is displayed. 
Information on the first server in the list is displayed by default:
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• Server Details - the server's name and WebLogic version, whether the server is the 
Administration Server or not, and whether the server is in production mode or not. 

• Java Details - the Java vendor and version, and the Java Virtual Machine vendor, 
name, and version. 

• Operating System Details - the operating system name, version, and processor 
architecture. 

– JDBC - the number of JDBC connection pools, a list of the JDBC connection pools, 
and details about each JDBC connection pool. 

When you click on a JDBC connection pool in the list, the following JDBC connection 
pool details are displayed. JDBC connection pool details on the first JDBC connection 
pool in the list are displayed by default:

• the JDBC connection pool name 

• the JDBC data source name 

• the database product name and version 

• the JDBC driver name and version 

Source - provides the actual XML source for the Domain Inventory. It can be copied to 
your paste buffer or printed with the context menu. You can access the context menu by 
right-clicking inside the Domain Inventory. 

Report - provides all the information contained in the Overview tab in a printer friendly 
format. It can also be copied into your paste buffer or printed with the context menu. 

Domain Inventory Outline View
When the Outline View is open and the Domain Inventory editor is active, you can use the 
Outline View to control what the Domain Inventory editor displays. Clicking the Overview, 
Source, and Report nodes in the Outline View brings the corresponding tab of the Domain 
Inventory editor to the forefront. Expanding the Outline View Source node enables you to select 
specific XML tag names, causing the Domain Inventory editor to jump to those tags and 
hightlight them.
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Related Tasks
Activate Domain 

Evaluate Domain 

Inventory Domain

Related Reference
Document Pane 

Inventory Wizard 

Domain Explorer 

Evaluation Summary
An Evaluation Summary is created each time you evaluate a domain, and is persisted in the 
Guardian Workspace. The Evaluation Summary editor in the Document Pane enables you to 
interact with the Evaluation Summary and determine if you need to take any corrective action.

These are the different ways to open an Evaluation Summary:

Conduct an evaluation. An Evaluation Summary is opened automatically when the 
evaluation completes. 

Double-click an Evaluation Summary entry in the Evaluation History folder of the Domain 
Explorer. 

Evaluation Summary Tabs
On the bottom of the Evaluation Summary editor are the following tabs for the different 
Evaluation Summary representations. Please note that these representations are read only:

Overview - provides evaluation statistics and a list of detected signatures. It also includes a 
description and remedy recommendation for each signature detected in the evaluation. It 
contains the following sections. Each section can be expanded or collapsed by clicking the 
triangle icon in the heading. 

– General Information - the target domain name, the signature bundle evaluated, the date 
and time of the evaluation, the length of time to conduct the evaluation, and the number 
of signatures targeted, detected, not detected, and undetectable in the evaluation. 
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For a given bundle of signatures, some signatures may not be used in the evaluation 
because they target different products than the domain has. The ones that do target 
what the domain has are counted as Targeted Signatures. The Targeted Signatures are 
divided into Detected Signatures, which are actually found on the domain; and 
Undetected Signatures, which are not found on the domain. If a signature fails to 
evaluate, it is counted as an Undetectable Signature, and is considered flawed.

– Detected Signatures - a table that includes information about every signature detected 
in the evaluation, including the signature name, identification number, severity, area of 
impact, and BEA product affected. It also includes the signature topic and subtopic, 
which further narrow the category of potential problem found. If you submitted any 
support cases to BEA, the case information is listed as well. 

Clicking a detected signature displays information about it in the Description and 
Remedy sections. Information about the first detected signature is displayed by default. 
You can sort the detected signature table by clicking any of the column headings. The 
detected signatures are sorted by severity and name by default.

The Severity column of the detected signature table includes an icon that approximates 
the amount of attention you should give each signature that has been detected.

– Description - information about the signature, from the signature XML file itself. 
Description includes the signature name, severity, category of impact (for example, 
Server Outage, Performance, or User Viewable Error), and a detailed description. 

– Remedy - an explanation of how to resolve the potential problem, from the signature 
XML file itself. It includes the servers impacted by the signature and links to get more 
information about the potential problem. 

Icon Severity

Critical

Warning

Informational
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Remedy also includes a link, Get more help from BEA Support, which opens the 
Support Case Wizard. Opening a support case enables you to get more help from BEA 
to analyze and repair the potential problem that the signature detected.

Source - provides the actual XML source from the Evaluation Summary. It includes the 
raw data for each detected and undetected signature, and can be copied to your paste buffer 
or printed with the context menu. You can access the context menu by right-clicking inside 
the Evaluation Summary. 

Report - provides all the information contained in the Overview tab in a printer friendly 
format. It can also be copied into your paste buffer or printed with the context menu. 

Evaluation Summary Outline View
When the Outline View is open and the Evaluation Summary editor is active, you can use the 
Outline View to control what the Evaluation Summary editor displays. Clicking the Overview, 
Source, and Report nodes in the Outline View brings the corresponding tab of the Evaluation 
Summary editor to the forefront. Expanding the Outline View Source node enables you to select 
specific XML tag names, causing the Evaluation Summary editor to jump to those tags and 
highlight them.

Related Tasks
Evaluate Domain 

Related Reference
Document Pane 

Domain Explorer 

Signature Details
A signature is an XML document that identifies potential problems in your domain. The 
Signature Details editor in the Document Pane provides more information about each signature.

To open a Signature Details editor, double-click a signature in the Signature Explorer or Bundle 
Explorer.
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Signature Details Tabs
On the bottom of the Signature Details editor are the following tabs for the different Signature 
Details representations. Please note that these representations are read only:

Overview - provides information about the signature and how it was created. It contains 
these sections: 

– General Information - the signature identifier, name, publication date, and severity level 
(Critical, Warning, or Informational). 

– Description - an explanation of the signature in plain language, from the actual 
signature XML file itself. 

– Target - the XPath expression used to match the signature with the target domain's 
Domain Inventory. 

Source - provides the actual XML source for the signature. It includes the raw data for 
each signature, and can be copied to your paste buffer or printed with the context menu. 
You can access the context menu by right-clicking inside the Signature Details editor. 

Report - provides all the information contained in the Overview tab in a printer friendly 
format. It can also be copied into your paste buffer or printed with the context menu. 

Signature Details Outline View
When the Outline View is open and the Signature Details editor is active, you can use the Outline 
View to control what the Signature Details editor displays. Clicking the Overview, Source, and 
Report nodes in the Outline View brings the corresponding tabs of the Signature Details editor to 
the forefront. Expanding the Outline View Source node enables you to select specific XML tag 
names, causing the Signature Details editor to jump to those tags and hightlight them.

Related Reference
Document Pane 

Signature Explorer 

Bundle Explorer
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Bundle Details
A bundle is a group of signatures that are evaluated together. The Bundle Details editor in the 
Document Pane provides more information about each bundle.

To open a Bundle Details editor, double-click a bundle node in the Bundle Explorer.

Bundle Details Tabs
On the bottom of the Bundle Details editor are the following tabs for the different Bundle Details 
representations. Please note that these representations are read only:

Overview - provides information about the bundle and how it was created. It contains the 
following sections: 

– General Information - the bundle identifier, name, creation date, and modification date. 

– Description - a plain language description of the bundle. 

– Signature Def - the XPath expression that created the bundle. 

Report - provides all the information contained in the Overview tab in a printer friendly 
format. The report can be copied to your paste buffer or printed with the context menu. 
You can access the context menu by right-clicking inside the Bundle Details editor. 

Bundle Details Outline View
When the Outline View is open and the Bundle Details editor is active, you can use the Outline 
View to control what the Bundle Details editor displays. Clicking the Overview and Report nodes 
in the Outline View brings the corresponding tabs of the Bundle Details editor to the forefront.

Related Reference
Document Pane

Bundle Explorer 

Shortcuts Table
The Shortcuts Table is a view in the Document Pane that enables you to manage the shortcuts you 
have created.

To open the Shortcuts Table, select Show View > Shortcuts Table from the BEA Guardian 
Window menu.
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The Shortcuts Table lists the shortcuts, each having these columns:

Shortcut: the shortcut name 

Domain: the domain the shortcut targets 

Bundle: the signature bundle the shortcut evaluates 

By default, the shortcuts are listed alphabetically by shortcut name. Clicking a column heading 
sorts the shortcuts by that column. For example, clicking the Domain column sorts the shortcuts 
alphabetically by domain name. Clicking the same column heading in succession alternates 
between sorting in alphabetical order and reverse alphabetical order.

Shortcuts Table Toolbar
The Shortcuts Table toolbar contains buttons to add and delete shortcuts:

Clicking the Add Shortcut button invokes the Shortcut Wizard to create a new shortcut. 

Clicking the Delete Shortcut button pops up a confirmation box to confirm that you really 
want to delete the selected shortcut. Please note that the Delete Shortcut button can't be 
clicked until a shortcut has been selected. 

Related Tasks
Create Shortcut 

Delete Shortcut 

Related Reference
Document Pane 

Shortcut Wizard 

Shortcut Explorer 

Main Menu 
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Preferences
The Preferences page enables you to customize the BEA Guardian environment.

These are the different ways to open the Preferences page:

Press "Ctrl+Shift+P" 

Select Preferences from the Window menu. 

The Preferences page is a dialog box that enables you to select from the following main 
categories:

General - settings that control the appearance of, interaction with, and startup of Guardian. 
The ones most useful for Guardian are: 

– Keys - enables you to change Guardian's Keyboard Shortcuts. 

– Startup and Shutdown - enables you to change whether Guardian prompts you for the 
Guardian Workspace location when starting. 

Guardian - settings that control Guardian's data interactions and appearance. The ones most 
useful for Guardian are: 

– BEA Support - enables you to specify whether to use Secure Sockets Layer (SSL) 
encryption when creating support cases, and whether to use a proxy server when 
updating Guardian. Please note that Guardian uses 128 bit open source encryption for 
SSL. BEA Support also enables you to specify the hostname, port, and (optionally) the 
username and password for authentication for a proxy server. This is the proxy server 
that the Support Case Wizard would use to create a BEA Support Case.

– Proxy - enables you to add proxy servers to use when activating domains. 

Help - settings that control how Guardian help content is displayed. 

Install/Update - settings that control how the Guardian application is updated. The 
Automatic Updates section enables you to tell Guardian to automatically contact the BEA 
Guardian update site to find new signatures and application updates. The “Enable HTTP 
proxy connection” field enables you to specify the host address and port of the proxy 
server that the Update Wizard would use to access the BEA update server to download new 
signatures and software updates.
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Related Tasks
Submit Support Case 

Automatically Update Guardian 

Activate Domain 

Related Reference
Keyboard Shortcuts 

Main Menu 

Wizards
BEA Guardian provides the following wizards:

Domain Activation Wizard 

Domain Deactivation Wizard 

Evaluation Wizard 

Support Case Wizard 

Inventory Wizard 

Shortcut Wizard 

Shortcut Evaluation Wizard 

Update Wizard 

A Wizard is a series of one or more dialog boxes that enable you to complete certain BEA 
Guardian tasks. The wizard prompts you for the information BEA Guardian needs to complete 
the task. For example, the Evaluation Wizard prompts you for the target domain and the signature 
bundle to evaluate.

When all the required information is filled in, you can click the Finish button to actually execute 
the task. When the Domain Activation, Domain Deactivation, Evaluation, and Inventory Wizards 
finish, the Progress View indicates successful completion. The Update and Support Case Wizards 
have their own notification, and the Shortcut Wizard gives no notification.
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Related Tasks
Manually Deploy Guardian Agent

Activate Domain 

Deactivate Domain 

Evaluate Domain 

Submit Support Case 

Inventory Domain 

Create Shortcut 

Evaluate Shortcut 

Automatically Update Guardian 

Related Reference
Domain Activation Wizard 

Domain Deactivation Wizard 

Evaluation Wizard 

Support Case Wizard 

Inventory Wizard 

Shortcut Wizard 

Shortcut Evaluation Wizard 

Update Wizard 

Domain Explorer 
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Domain Activation Wizard
The Domain Activation Wizard prepares a target domain for evaluation by installing any needed 
Guardian Agents and creating a new Domain Inventory.

There are several different ways to invoke the Domain Activation Wizard:

Press Ctrl+Shift+A. 

Click the Activate button on the Main Toolbar. 

Select New > Domain from the File menu. 

Right-click inside the Domain Explorer and select Activate Domain from the pop-up 
context menu. 

The Domain Activation Wizard contains the following data entry fields:

The communication protocol - either http://, or https:// for Secure Sockets Layer (SSL) 
encryption. Please note that Guardian does not use 128 bit SSL encryption for domain 
activation.

The host name - the listen address of the target domain's Administration Server, for 
example, localhost, 66.248.193.194, or guardian-dev.bea.com 

The port number - the listen port for the target domain's Administration Server 

The username of an administrator account on the target domain 

The password of an administrator account on the target domain 

Whether to remember the username and password 

If selected, the username and password are encrypted and stored on disk. Then, whenever 
you access the domain, the username and password are filled in automatically. Otherwise, 
you have to enter them. The following Guardian operations require login credentials:

– Evaluate a domain 

– Inventory a domain 

– Modify a domain 

– Open an admin console 

– Submit a support case 
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Whether to use a proxy server to access the domain 

If selected, you must select the name of the proxy server from the drop down list. If there 
are no proxy servers in the drop down list, click the Add Proxy Server link to add one. 
Please note that in order to use a proxy server, you must also manually deploy the 
Guardian Agent onto the target domain.

If a deactivated domain is selected and the Domain Explorer is active when you invoke the 
Domain Activation Wizard, the communication protocol, host name, and listen port fields will be 
filled in automatically with the values for the deactivated domain. You still must enter the 
username and password.

Once you have entered the required data, click the Finish button to activate the domain. A 
progress indicator tracks the progress as the domain is activated.

The successful completion of the Domain Activation Wizard results in:

The domain is available for evaluation. 

Any needed Guardian Agents are installed on the domain. 

A new Domain Inventory editor is opened in the Document Pane. 

A domain node is added to the Domain Explorer, in the Target Domains folder. A Domain 
Inventory entry is also added to the domain node's Inventory History folder. 

The domain is added to the Active Domains Table. 

The domain is added to the Guardian Registry. 

A folder for the domain is added to the Guardian Workspace. The domain folder persists 
the Domain Inventories, Evaluation Summaries, and Case Creation Archives. 

Related Tasks
Activate Domain 

Deactivate Domain 

Evaluate Domain 

Inventory Domain 

Create Shortcut 

Submit Support Case 
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Related Reference
Domain Explorer 

Active Domains Table 

Domain Inventory 

Evaluation Summary 

Keyboard Shortcuts 

Main Toolbar 

Main Menu 

Domain Deactivation Wizard
The Domain Deactivation Wizard makes a domain unavailable for evaluation.

There are two different ways to invoke the Domain Deactivation Wizard:

Select a domain in the Active Domains Table and click the Deactivate Domain button. 

Right-click a domain in the Domain Explorer and select Deactivate Domain. 

The Domain Deactivation Wizard dialog box prompts you for the domains to deactivate. By 
default, the domains selected when you invoked the Domain Deactivation Wizard are 
highlighted. You can deactivate multiple domains at once.

When you have selected the domains to deactivate, click the Finish button. The deactivation 
completes immediately because the operation is local to Guardian and the domains are not 
contacted.

The successful completion of the Domain Deactivation Wizard results in:

A pop-up dialog box indicates successful completion. 

The Progress View shows the time the deactivation finished. 

The domains are removed from the Active Domains Table. 

The domains are still listed in the Domain Explorer so you can access their previous 
Domain Inventories and Evaluation Summaries. But they are no longer displayed with a 
bold font. 
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You can remove deactivated domains from the Domain Explorer with the Purge Inactive 
Domains option from the Tools menu.

Any shortcuts that target the deactivated domains are removed from the Shortcuts Table 
and Shortcut Explorer. 

The domains can no longer be selected for evaluations or inventories. However, you can 
activate the domain again at any time. 

Please note that the Domain Deactivation Wizard does not remove any of the Guardian Agents 
that were installed during domain activation. If you want to remove the Guardian Agents after 
deactivating a domain, you can use the deployment tools provided with WebLogic Server. 
Guardian Agents are deployed as Web Application Archive (WAR) files with the name, 
"bea-guardian-agent". Deployment documentation can be found on the BEA eDocs website for:

BEA WebLogic Server 8.1 

BEA WebLogic Server 9.1 

BEA WebLogic Server 9.2 

Related Tasks
Deactivate Domain 

Activate Domain 

Related Reference
Active Domains Table 

Domain Explorer 

Domain Inventory 

Evaluation Summary 

Shortcuts Table 

Shortcut Explorer 

Main Menu 
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Evaluation Wizard
The Evaluation Wizard enables you to evaluate one or more domains.

There are several different ways to invoke the Evaluation Wizard:

Press Ctrl+Shift+E. 

Click the Evaluate button on the Main Toolbar. 

Select New > Evaluation from the File menu. 

Double-click a domain in the Active Domains Table. 

Double-click a domain in the Domain Explorer. 

Right-click a domain in the Domain Explorer, or anywhere in the Domain Explorer, and 
select Evaluate from the pop-up context menu. 

The Evaluation Wizard dialog box contains the following data entry fields:

The domains to evaluate - click the domain you want to evaluate. Use the Ctrl or Shift 
keys when clicking to select more than one domain. Please note that any domain selected 
with the Domain Explorer or Active Domains Table active when the Evaluation Wizard is 
invoked will be preselected already. 

The bundle to evaluate - for each domain, you can select one bundle to evaluate. The 
Default Signatures bundle is selected by default. To change the bundle, click the bundle 
name and select a different bundle from the drop down list. 

The domain login credentials - if you checked the Remember username/password check 
box when activating or modifying the domain, the username and password are already 
filled in. Otherwise, the domain is displayed in italics, and you must enter the username 
and password in the Domain Credentials section. 

If you have multiple domains selected, every one must have its credentials filled in before 
you can launch the evaluation. If any of the selected domains are missing credentials, a 
message at the top of the dialog box says that the required credentials are missing and the 
Finish button is greyed out.

Whether to remember the username and password - if you check the Remember 
username/password check box, you won't have to enter domain login credentials for any 
future domain access operations. 
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Whether to create a shortcut - if you check the Create Shortcut check box, the domain and 
bundle evaluated are saved as a shortcut for future evaluations. If evaluating multiple 
domains, you must create a shortcut for each domain and bundle pair separately. 

When you check Create Shortcut, a default shortcut name is created in the text box next to 
it. The default shortcut name is in the form, "<bundle name> in <domain name>". You can 
change the shortcut name by editing the text box.

When you have finished editing the Evaluation Wizard dialog box, you can click the Finish 
button to launch the evaluation. A progress indicator tracks the progress as the evaluation 
executes.

The successful completion of the Evaluation Wizard results in:

The Progress View shows the time it finished for each domain evaluated. 

A new Evaluation Summary is opened in the Document Pane. 

The Domain Explorer is modified as follows: 

If you checked the Remember username/password check box, the domain node icon is 
decorated to indicate that the login credentials have been persisted. 

A new Evaluation Summary entry is added to the Evaluation History folder for each 
domain evaluated. 

A new Domain Inventory entry is added to the Inventory History folder for each domain 
evaluated. 

If you selected the Create Shortcut check box, the shortcut is added to both the Shortcut 
Explorer and the Shortcuts Table. 

Related Tasks
Evaluate Domain 

Activate Domain 

Create Shortcut 

Related Reference
Active Domains Table 

Domain Explorer 
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Bundle Details 

Domain Activation Wizard 

Evaluation Summary 

Document Pane 

Keyboard Shortcuts 

Main Toolbar

Main Menu 

Filters Wizard
The Filters Wizard enables you to specify which signatures to display in Signature Lists.

To open the Filters Wizard, click the Signature Explorer menu icon and select the Filters menu 
option.

The Filters Wizard contains the following components that determine which signatures are 
displayed:

Name Filter Pattern - a text box that enables you to enter a search pattern for the signature 
names you want to select. For example: 

– SSL* selects all signatures whose first three letters are SSL Please note that Guardian 
uses 128 bit open source encryption for SSL.

– *8.?* selects all the signatures relating to WebLogic Server Version 8 

Whether the names you select are displayed or filtered out depends on the following radio 
button settings. 

Show matching names - a radio button that causes the signatures matching the Name Filter 
Pattern text box to be displayed rather than filtered out. 

Hide matching names - a radio button that causes the signatures matching the Name Filter 
Pattern text box to be filtered out rather than displayed. 

Select the severity levels to include - a check box for each severity level: Critical, 
Warning, or Informational that further refines which signatures are displayed. Whatever the 
results are of the Name Filter Pattern text box and the Show matching names and Hide 
matching names radio buttons, only the signatures matching the severity levels selected in 
these check boxes are displayed. 
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Related Reference
Signature Explorer 

Inventory Wizard
The Inventory Wizard enables you to create a new Domain Inventory for one or more domains.

There are several different ways to invoke the Inventory Wizard:

Press "Ctrl+Shift+I". 

Click the Inventory button on the Main Toolbar. 

Select New > Inventory from the File menu. 

Right-click a domain in the Domain Explorer, or anywhere in the Domain Explorer, and 
select Inventory. 

The Inventory Wizard contains the following data entry fields:

The domains to inventory - click each domain to inventory. Use the Ctrl or Shift keys 
when clicking to select more than one domain. Please note that any domain selected with 
the Domain Explorer or Active Domains Table active when the Inventory Wizard is 
invoked will be preselected already. 

The domain login credentials - if you checked the Remember username/password check 
box when activating or modifying the domain, the username and password are already 
filled in. Otherwise, the domain is displayed in italics, and you must enter the username 
and password in the Domain Credentials section. 

If you have multiple domains selected, every one must have its credentials filled in before 
you can create the inventories. If any of the selected domains are missing credentials, a 
message at the top of the Inventory Wizard says that the required credentials are missing 
and the Finish button is greyed out.

Whether to remember the username and password - if you check the Remember 
username/password check box, you won't have to enter domain login credentials for any 
future domain access operations. 

When you have finished editing the Inventory Wizard, you can click the Finish button to create 
the inventories. A progress indicator tracks the progress as the inventories are created.
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The successful completion of the Inventory Wizard results in:

A new Domain Inventory editor is opened in the Document Pane for each domain you 
selected. 

The Domain Explorer is modified as follows: 

– If you checked the Remember username/password check box, the domain node icon is 
decorated to indicate that the login credentials have been persisted. 

– A new Domain Inventory entry is added to the Inventory History folder for each 
domain you selected. 

Related Tasks
Activate Domain 

Create Shortcut 

Related Reference
Domain Explorer

Active Domains Table 

Domain Activation Wizard 

Domain Inventory 

Document Pane 

Keyboard Shortcuts 

Main Toolbar 

Main Menu 

Shortcut Wizard
The Shortcut Wizard enables you to create a shortcut.

There are several different ways to invoke the Shortcut Wizard:

Press "Ctrl+Shift+S". 

Click the Add Shortcut button in the Shortcuts Table toolbar. 
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Select New > Shortcut from the File menu. 

Right-click inside the Shortcut Explorer and select Add Shortcut. 

The Shortcut Wizard contains the following data entry fields:

The domain to evaluate - click the domain you want to evaluate. Each shortcut can only 
evaluate one domain and one bundle at a time. Please note that any domain selected with 
the Domain Explorer or Active Domains Table active when the Shortcut Wizard is invoked 
will be preselected already. 

The bundle to evaluate - for each domain, you can select one bundle to evaluate. The 
Default Signatures bundle is selected by default. To change the bundle, click the bundle 
name and select a different bundle from the drop down list. 

The shortcut name - when you check the Create Shortcut check box, a default shortcut 
name is created in the text box next to it. The default shortcut name is in the form, 
"<bundle name> in <domain name>". You can change the shortcut name by editing the 
text box. 

When you have finished selecting the bundle, domain, and shortcut name, you can click the 
Finish button to create the shortcut. The successful completion of the Shortcut Wizard results in:

The shortcut is added to the list of shortcuts in the Shortcut Explorer. 

The shortcut is added to the list of shortcuts in the Shortcuts Table. 

Double clicking the shortcut name in the Shortcut Explorer or Shortcuts Table invokes the 
Shortcut Evaluation Wizard with the domain and bundle for that shortcut already selected.

Related Tasks
Create Shortcut 

Delete Shortcut 

Related Reference
Shortcuts Table 

Shortcut Explorer 

Domain Explorer

Active Domains Table 



Refe rence

3-128 BEA Guardian User Guide

Bundle Details 

Shortcut Evaluation Wizard 

Keyboard Shortcuts

Main Menu 

Shortcut Evaluation Wizard
The Shortcut Evaluation Wizard enables you to evaluate a domain with fewer steps than it would 
take using the Evaluation Wizard.

You can invoke the Shortcut Evaluation Wizard in any of the following ways:

Double-click a shortcut in the Shortcuts Table. 

Double-click a shortcut in the Shortcut Explorer. 

Right-click a shortcut in the Shortcut Explorer and select Evaluate Shortcut from the 
pop-up context menu. 

The Shortcut Evaluation Wizard opens with the domain and bundle specified in the shortcut 
preselected.

You can change the bundle, but only for the current evaluation. The bundle for that shortcut will 
remain unchanged for future invocations of the Shortcut Evaluation Wizard.

If you checked the Remember username/password check box when activating or modifying the 
domain, the username and password are already filled in. Otherwise, the domain is displayed in 
italics, and you must enter the username and password in the Domain Credentials section.

If you check the Remember username/password check box, you will not have to enter domain 
login credentials for any future domain access operations.

When you have finished editing the Shortcut Evaluation Wizard dialog box, you can click the 
Finish button to launch the evaluation. A progress indicator tracks the progress as the evaluation 
executes.

The successful completion of the Evaluation Wizard results in:

The Progress View shows the time it finished for each domain evaluated. 

A new Evaluation Summary is opened in the Document Pane. 

The Domain Explorer is modified as follows: 
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– If you checked the Remember username/password check box, the domain node icon is 
decorated to indicate that the login credentials have been persisted. 

– The Evaluation Summary is added to the target domain's Evaluation History folder for 
each domain evaluated. 

– A new Domain Inventory entry is added to the Inventory History folder for each 
domain evaluated. 

Related Tasks
Evaluate Shortcut 

Activate Domain 

Create Shortcut 

Related Reference
Evaluation Wizard 

Shortcuts Table 

Shortcut Explorer 

Domain Explorer 

Domain Activation Wizard 

Evaluation Summary 

Document Pane 

Support Case Wizard
The Support Case Wizard gathers the information needed to create a BEA support case. You can 
either connect to BEA to open an actual support case now, or save the case information in a Case 
Creation Archive to open a support case later.

To invoke the Support Case Wizard, click the Get more help from BEA support link in an 
Evaluation Summary. You can create a support case in response to any signature that is detected 
in an evaluation. 

You can open an Evaluation Summary either by performing an evaluation, or by double-clicking 
the Evaluation Summary entry in the Domain Explorer.
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The Support Case Wizard uses a sequence of dialog boxes to gather the information needed to 
open a support case and enable a BEA support engineer to begin working on it. The Support Case 
Wizard steps are:

Select Server Node - identify the server node on the domain that has the detected signature. 
If the node preselected in the dialog box is not the correct one, then you can change it by 
selecting an item from the pull down list. If there is only one server in your domain, then 
the Administration Server is used by default and this step is skipped. 

Support Case Notes - add any additional text that you feel may help resolve the support 
case sooner in the Additional Case Notes section. The Default Case Notes section already 
contains the text from the Evaluation Summary's description and remedy sections. 

Select Case Attachments - specify which background materials to send to BEA, for 
example, the server log or the domain configuration file. Each signature includes a list of 
attachments needed to resolve the case. Some, such as the Domain Inventory, are required 
to create a support case. They are listed in the Case Attachments section and cannot be 
unselected. Others, such as the Server Log, are optional. They are listed in the 
Recommended Attachments section and are selected by default, but can be unselected. 

If you feel additional attachments would help in resolving the support case sooner, you can 
add them to the Other Attachments section by clicking the plus sign icon and navigating to 
the attachment you want to add.

By submitting these background materials now, you save the BEA support engineer from 
having to contact you to get the same information later. This saves time in getting your 
support case resolved sooner.

Domain Login - enter the username and password to login to the domain and get the case 
attachments specified in the previous step. If you checked the Remember 
username/password check box when activating or modifying the domain, the username and 
password are already filled in. If you check the Remember username/password check box, 
you won't have to enter domain login credentials for any future domain access operations. 

Select Case Destination - select whether to connect to BEA and create a support case now, 
or save the case information as a Case Creation Archive, and create a support case later. 
Saving the case as a Case Creation Archive may be useful for people who are not 
connected to the Internet and need to send it to BEA from a different machine. 

If you choose to save the case as a Case Creation Archive, you must select a folder in 
which to save it. BEA recommends using the data/<domain node>/Case 
Creation Archives folder in the Guardian Workspace location you specified when 
you started Guardian.
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eSupport Login - enter your BEA eSupport username and password. This enables Guardian 
to log in to the eSupport website to get your list of available eSupport site identifiers and 
create the support case. If you select the Remember username/password check box, you 
won't have to enter your eSupport login credentials for future support cases. 

Select eSupport Site Id - if you have more than one eSupport site identifier, select the one 
to use for this support case. This step is skipped for most customers who have only one site 
identifier. 

The successful completion of the Support Case Wizard results in:

The Case Creation Complete dialog box gives you the support case number, date, and time 
of creation. The time includes the time zone of BEA's eSupport website. BEA recommends 
saving the case number to aid in future correspondence with BEA. 

Once the case has been created, it is treated like any other BEA support case. But, because 
the Support Case Wizard included attachments specific to the case and optional notes from 
you, BEA's support engineers can analyze it more efficiently.

If you earlier elected to save the case as a Case Creation Archive instead of connecting to 
BEA, the Case Creation Complete dialog box displays the date, time, and location of the 
archive file.

The Progress View shows the local time that the case was created. 

After the case has been created, the Evaluation Summary is updated with either the BEA 
support case number, or the name of the Case Creation Archive. The Get more help from 
BEA support link is no longer available. 

Related Tasks
Submit Support Case 

Activate Domain 

Create Shortcut 

Related Reference
Evaluation Summary 

Domain Explorer 

Domain Activation Wizard 

Domain Properties 
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Update Wizard
The Update Wizard downloads and installs new signatures and application features from the BEA 
Guardian update web site, http://guardian.bea.com/.

There are several different ways to invoke the Update Wizard:

Press Ctrl+Shift+U. 

Click the Update button on the Main Toolbar. 

Select Manage Guardian > Update Guardian from the Help Menu. 

The Update Wizard uses a sequence of dialog boxes to gather the information needed to 
download and install new signatures and application features. The Update Wizard steps are:

eSupport Login - enter your BEA eSupport username and password to access the Guardian 
update site. If you select the Remember username/password check box, you won't have to 
enter your eSupport login credentials for future updates. 

Select eSupport Site Id - if you have more than one eSupport site identifier, select the one 
to use for this update. Most customers only have one site identifier. 

eSupport Login - enter your BEA eSupport username and password again to access the 
Guardian update site. 

No updates for the currently installed features - if there are no new signatures or 
application features available, a dialog box suggests you try again later. BEA adds new 
signatures and application features to the Guardian update site when they are ready for 
customer use. 

Search Results - if there are new signatures or application features available, select which 
ones to install. All of them are selected by default, but you can expand the check box to 
select specific updates. 

Guardian signature updates are grouped under the Guardian Signatures heading, Guardian 
application feature updates are grouped under the Guardian heading. Select the check 
boxes next to the signature and application feature updates you want.

Feature License - click the radio button indicating that you accept the terms in the license 
agreement. 

Installation Location - you can change the installation location for each signature and 
application feature update, but BEA recommends using the default location. A progress 
indicator tracks the progress as the updates are downloaded. 
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Feature Verification - once the updates are downloaded, click the Install All button to 
integrate all the signature and application feature updates into Guardian in one step. 

Restart Guardian - once all the updates are installed, click the Yes button to restart 
Guardian. When Guardian restarts, all the new signatures and application features you 
downloaded will be available. 

Related Tasks
Automatically Update Guardian 

Related Reference
Keyboard Shortcuts 

Main Toolbar 

Main Menu 

Log Files
The BEA Guardian Log Files contain information that is typically only needed by BEA in the 
unlikely event of an exception. One situation where you may want to view a log file is running 
command line scripts and automatically scanning the signature.log for detected signatures.

The Guardian log files are:

guardian.log - located in the guardian installation directory you specified during 
installation. Contains information about every operation the Guardian application performs. 

signature.log - located in the guardian installation directory you specified during 
installation. Contains information about each evaluation performed. 

.log - located in the .metadata subdirectory of the Guardian Workspace directory you 
specified when starting Guardian. Contains information about certain Guardian operations. 

install.log - located in the configuration/org.eclipse.update subdirectory of the 
Guardian installation directory you specified during installation. Contains information 
about the Guardian installation itself. 
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Related Reference
Signature Log File 

Guardian Log File 

Signature Log File
A Signature Log File, signature.log, is located in the guardian installation directory you specified 
during installation. It contains information about each evaluation performed.

Related Reference
Log Files 

Guardian Log File 

Guardian Log File
The Guardian Log File, guardian.log, is located in the guardian installation directory you 
specified during installation. It contains information about every operation the BEA Guardian 
application performs.

Related Reference
Log Files 

Signature Log File 

Command Line Interface
The BEA Guardian Command Line Interface is accessed with a Windows Command Prompt 
window or a Linux terminal window. The Guardian command interpreter is an executable .cmd 
batch file for Windows, and a .sh shell script for Linux. Both the Windows batch file and the 
Linux shell script are wrappers that accumulate and organize arguments to the Java command.

To use the Guardian Command Line Interface, run the guardianHeadless.cmd (for Windows) or 
guardianHeadless.sh (for Linux) executable file which was placed in the installation directory 
you specified when you installed Guardian.
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If you have not previously set your Guardian Workspace location when starting the Graphical 
User Interface, the Guardian Command Line Interface will use a default Guardian Workspace 
location, unless you specify otherwise in each command. The default Guardian Workspace 
location is in your home directory; for example, C:\Documents and 
Settings\<username>\guardianWorkspace for Windows, and 
/home/<username>/guardianWorkspace for Linux. If you have previously set your 
Guardian Workspace location, the Guardian Command Line Interface will use that location for 
all its operations, unless you specify otherwise in each command. Identifying the Guardian 
Workspace location is essential for accessing the correct set of active domains, Domain 
Inventories, and Evaluation Summaries.

The Guardian Command Line Interface accepts a variety of commands that perform almost every 
task available with the Graphical User Interface. To see a list of the commands available and their 
syntax, type guardianHeadless -ghelp at the operating system command prompt. Please 
note that the Guardian Command Line Interface commands are case sensitive.

The output of each command is not sent to the console window. Instead, it is sent to the output 
file, headless_output.txt. The output file created in your current directory, and is 
overwritten each time you run it.

Also note that each command must have a prefix of -g, as shown in the examples below. Please 
pay special attention to the spacing, the arguments that require quotes, and the case sensitivity.

Examples:

guardianHeadless.cmd -glistActiveDomains 

guardianHeadless.cmd -gactivateDomain -t 
http://localhost:9116 -u un -p pw -c true -data 
"D:\MyData\Guardian Data Directories\Installer-2079" 

guardianHeadless.cmd -gcreateShortcut -d Naxos_localhost_9116 
-b 2 

guardianHeadless.cmd -gdeleteShortcut -s "Security Advisories 
in Naxos" 

The following table describes each Guardian command. After that is a syntax description for each 
command.
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The following list gives the syntax for each command that accepts arguments. Optional 
parameters are enclosed in square brackets:

activateDomain -t targetUrl -u username -p password [ -c persistCredentials ] [ -data 
workspaceDir ] 

– targetUrl: the http://listen-address:port-number format address of the 
domain's administration server (not in quotes) 

– username: administrator account username for the specified domain 

– password: administrator account password for the specified domain 

Command What It Does 

activateDomain Activates the domain specified to prepare it for evaluation and 
returns the domain identifier. 

createShortcut Creates a shortcut for the domain and bundle specified to save 
keystrokes in conducting evaluations. 

deactivateDomain Removes the domain specified from evaluation eligibility. 

deleteShortcut Deletes the shortcut specified. 

evaluateDomainBundle Evaluates the domain and bundle specified. Use the Graphical 
User Interface to see the evaluation results. 

evaluateShortcut Evaluates the domain and bundle associated with the shortcut 
specified. Use the Graphical User Interface to see the 
evaluation results.

help Displays usage information. 

listActiveDomains Lists the active domains available for evaluation in domain 
identifier format.

listBundles Lists the bundle identifier and bundle name of the bundles 
available for evaluation.

listShortcuts Lists the shortcuts available for evaluation.

script Executes the commands contained in the script file specified.
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– persistCredentials (true or false, without quotes): whether to persist the username and 
password in encrypted form (default = false) 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

createShortcut -d domainId [ -b bundleId ] [ -s shortcutName ] [ -data workspaceDir ] 

– domainId: the domain identifier for the shortcut 

– bundleId: the bundle identifier for the shortcut (default = 0, which is the identifier for 
the bundle named, "Default Signatures"). The values for all the bundles can be found 
with the listBundles command. 

– shortcutName: the name of the shortcut in quotes (default = "<bundle name> in 
<domain name>") 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

deactivateDomain -d domainId [ -l deleteUserData ] [ -data workspaceDir ] 

– domainId: the domain identifier of the domain to deactivate 

– deleteUserData (true or false, without quotes): whether to delete the Domain 
Inventories and Evaluation Summaries from the Guardian Workspace (default = false) 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

deleteShortcut -s shortcutName [ -data workspaceDir ] 

– shortcutName: the name of the shortcut to delete, in quotes, as shown with the 
listShortcuts command. 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

evaluateDomainBundle -d domainId [ -b bundleId ] [ -u username -p password ] [ -c 
persistCredentials ] [ -data workspaceDir ] 

– domainId: the domain identifier of the domain to evaluate 

– bundleId: the bundle identifier for the shortcut (default = 0, which is the identifier for 
the bundle named, "Default Signatures"). The values for all the bundles can be found 
with the listBundles command. 

– username: administrator account username for the specified domain (not required if 
persistCredentials set to true in activateDomain) 
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– password: administrator account password for the specified domain (not required if 
persistCredentials set to true in activateDomain) 

– persistCredentials (true or false, without quotes): whether to persist the username and 
password in encrypted form (default = false) 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

evaluateShortcut -s shortcutName [ -u username -p password ] [ -c persistCredentials ] [ 
-data workspaceDir ] 

– shortcutName: the name of the shortcut to evaluate in quotes 

– username: administrator account username for the specified domain (not required if 
persistCredentials set to true in activateDomain) 

– password: administrator account password for the specified domain (not required if 
persistCredentials set to true in activateDomain) 

– persistCredentials (true or false, without quotes): whether to persist the username and 
password in encrypted form (default = false) 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

help 

listActiveDomains [ -data workspaceDir ] 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

listBundles [ -data workspaceDir ] 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

listShortcuts [ -data workspaceDir ] 

– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

script -f scriptname [ -data workspaceDir ] 

– scriptname: the name of a script file containing Guardian commands. Each command 
has to be on a separate line. See Running Scripts for more information. 
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– workspaceDir: the full directory specification, in quotes, of the location of the Guardian 
Workspace 

Using Scripts
Scripts enable you to perform several Guardian tasks by issuing a single command in the 
Guardian Command Line Interface. You can schedule scripts to run at specified times and 
intervals by using utilities such as the Windows Task Scheduler or the Linux crontab command.

Here is an example of a script (activate.txt) that activates several domains:
activateDomain -t http://slp7:7001 -u un -p pw -c true
activateDomain -t http://slp8:7001 -u un -p pw -c true
activateDomain -t http://sqa-lldev:4044 -u un -p pw -c true
activateDomain -t http://slg-lldev:7001 -u un -p pw -c true
activateDomain -t http://slg-lldev:4401 -u un -p pw -c true
activateDomain -t http://mj23:32292 -u un -p pw -c true

To run this script, enter the command:

guardianHeadless -gscript -f activate.txt 

Here is an example of a script (evaluate.txt) that evaluates several domains:
evaluateDomainBundle -d guardian-dev_slp7_7001 -b 1 
evaluateDomainBundle -d guardian-dev_slp7_7001 -b 2 
evaluateDomainBundle -d guardian-dev2_slp8_7001 -b 0
evaluateDomainBundle -d guardian-qa_sqa-lldev_4044 
evaluateDomainBundle -d guardian-domain_slg-lldev_7001 -b 1
evaluateDomainBundle -d guardian-domain_slg-lldev_7001 -b 2
evaluateDomainBundle -d guardian-domain_slg-lldev_4401 
evaluateDomainBundle -d mydomain_mj23_32292

To run this script, enter the command:

guardianHeadless -gscript -f evaluate.txt 

To review the results of script evaluations, use the Guardian Graphical User Interface. The 
Domain Explorer Evaluation History folder contains an Evaluation Summary for each evaluation 
performed.
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Scheduling Scripts
To schedule a script to run automatically at a specified time, you can use utilities such as the 
Windows Task Scheduler or the Linux crontab command. For example, to schedule the 
evaluate.txt script, you would schedule the command:

guardianHeadless -gscript -f evaluate.txt 

Receiving Notifications
To receive notification of detected signatures, create an evaluation script and use the Windows 
Task Scheduler or the Linux crontab command to schedule the script to run at regular intervals. 
Each time the script runs an evaluation, the signature.log file in the Guardian installation 
directory is updated with an entry that tells whether the signature was detected or not. You can 
set a third party management tool to scan that log for detected signatures and notify you when one 
is found.

Each signature.log entry starts with four number signs (####) and includes a time stamp. Each 
entry with a detected signature contains <detected> and is followed by a brief description which 
is also surrounded by < >. The description includes the domain name. Following is a sample 
signature.log file:
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000022> 
<not detected> <Signature 000022 (Rotational Upgrade may cause 
java.io.StreamCorruptedException) not detected by username un evaluating 
bundle ID 0 in domain ID g-dev_slp7_7001.> 
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000027> 
<detected> <Signature 000027 (Native IO should be enabled in production mode 
for better performance) detected by username un evaluating bundle ID 0 in 
domain ID g-dev_slp7_7001.> 
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000055> 
<not detected> <Signature 000055 (JDK 1.5 is not certified for WebLogic 8.1) 
not detected by username un evaluating bundle ID 0 in domain ID 
g-dev_slp7_7001.> 
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Appendix A: Apache License

Apache License
The following applies to all products licensed under the Apache 2.0 License. You may not use 
the identified files except in compliance with the Apache License, Version 2.0 (the "License"). 
You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0. A copy 
of the license is also reproduced below. Unless required by applicable law or agreed to in writing, 
software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT 
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License 
for the specific language governing permissions and limitations under the License. 

Apache License 
Version 2.0, January 2004 

http://www.apache.org/licenses/ 

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION 

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined 
by Sections 1 through 9 of this document. 

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is 
granting the License. 

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are 
controlled by, or are under common control with that entity. For the purposes of this definition, 
"control" means (i) the power, direct or indirect, to cause the direction or management of such 
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entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the 
outstanding shares, or (iii) beneficial ownership of such entity. 

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by 
this License. 

"Source" form shall mean the preferred form for making modifications, including but not limited 
to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a 
Source form, including but not limited to compiled object code, generated documentation, and 
conversions to other media types. 

"Work" shall mean the work of authorship, whether in Source or Object form, made available 
under the License, as indicated by a copyright notice that is included in or attached to the work 
(an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or 
derived from) the Work and for which the editorial revisions, annotations, elaborations, or other 
modifications represent, as a whole, an original work of authorship. For the purposes of this 
License, Derivative Works shall not include works that remain separable from, or merely link (or 
bind by name) to the interfaces of, the Work and Derivative Works thereof. 

"Contribution" shall mean any work of authorship, including the original version of the Work and 
any modifications or additions to that Work or Derivative Works thereof, that is intentionally 
submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or 
Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this 
definition, "submitted" means any form of electronic, verbal, or written communication sent to 
the Licensor or its representatives, including but not limited to communication on electronic 
mailing lists, source code control systems, and issue tracking systems that are managed by, or on 
behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding 
communication that is conspicuously marked or otherwise designated in writing by the copyright 
owner as "Not a Contribution." 

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a 
Contribution has been received by Licensor and subsequently incorporated within the Work. 

2. Grant of Copyright License.  Subject to the terms and conditions of this License, each 
Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, 
irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, 
publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or 
Object form. 
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3. Grant of Patent License.  Subject to the terms and conditions of this License, each 
Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, 
irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, 
sell, import, and otherwise transfer the Work, where such license applies only to those patent 
claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone 
or by combination of their Contribution(s) with the Work to which such Contribution(s) was 
submitted. If You institute patent litigation against any entity (including a cross-claim or 
counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work 
constitutes direct or contributory patent infringement, then any patent licenses granted to You 
under this License for that Work shall terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works 
thereof in any medium, with or without modifications, and in Source or Object form, provided 
that You meet the following conditions: 

(a) You must give any other recipients of the Work or Derivative Works a copy of this License; 
and 

(b) You must cause any modified files to carry prominent notices stating that You changed the 
files; and (

c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright, 
patent, trademark, and attribution notices from the Source form of the Work, excluding those 
notices that do not pertain to any part of the Derivative Works; and 

(d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative 
Works that You distribute must include a readable copy of the attribution notices contained 
within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative 
Works, in at least one of the following places: within a NOTICE text file distributed as part of the 
Derivative Works; within the Source form or documentation, if provided along with the 
Derivative Works; or, within a display generated by the Derivative Works, if and wherever such 
third-party notices normally appear. The contents of the NOTICE file are for informational 
purposes only and do not modify the License. 

You may add Your own attribution notices within Derivative Works that You distribute, 
alongside or as an addendum to the NOTICE text from the Work, provided that such additional 
attribution notices cannot be construed as modifying the License. You may add Your own 
copyright statement to Your modifications and may provide additional or different license terms 
and conditions for use, reproduction, or distribution of Your modifications, or for any such 
Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work 
otherwise complies with the conditions stated in this License. 
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5.Submission of Contributions.  Unless You explicitly state otherwise, any Contribution 
intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms 
and conditions of this License, without any additional terms or conditions. Notwithstanding the 
above, nothing herein shall supersede or modify the terms of any separate license agreement you 
may have executed with Licensor regarding such Contributions. 

6. Trademarks.  This License does not grant permission to use the trade names, trademarks, 
service marks, or product names of the Licensor, except as required for reasonable and customary 
use in describing the origin of the Work and reproducing the content of the NOTICE file. 

7. Disclaimer of Warranty.  Unless required by applicable law or agreed to in writing, Licensor 
provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, 
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, 
including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, 
MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely 
responsible for determining the appropriateness of using or redistributing the Work and assume 
any risks associated with Your exercise of permissions under this License. 

8. Limitation of Liability.  In no event and under no legal theory, whether in tort (including 
negligence), contract, or otherwise, unless required by applicable law (such as deliberate and 
grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, 
including any direct, indirect, special, incidental, or consequential damages of any character 
arising as a result of this License or out of the use or inability to use the Work (including but not 
limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any 
and all other commercial damages or losses), even if such Contributor has been advised of the 
possibility of such damages. 

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative 
Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, 
indemnity, or other liability obligations and/or rights consistent with this License. However, in 
accepting such obligations, You may act only on Your own behalf and on Your sole 
responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, 
and hold each Contributor harmless for any liability incurred by, or claims asserted against, such 
Contributor by reason of your accepting any such warranty or additional liability. 

END OF TERMS AND CONDITIONS 

APPENDIX: How to apply the Apache License to your work

To apply the Apache License to your work, attach the following boilerplate notice, with the fields 
enclosed by brackets "[]" replaced with your own identifying information. (Don't include the 
brackets!) The text should be enclosed in the appropriate comment syntax for the file format. 
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We also recommend that a file or class name and description of purpose be included on the same 
"printed page" as the copyright notice for easier identification within third-party archives.

Copyright 2008 [name of copyright owner] Licensed under the Apache License, 

Version 2.0 (the "License"); you may not use this file except in compliance 

with the License. You may obtain a copy of the License at 

http://www.apache.org/licenses/LICENSE-2.0. Unless required by applicable 

law or agreed to in writing, software distributed under the License is 

distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY 

KIND, either express or implied. See the License for the specific language 

governing permissions and limitations under the License.
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Appendix B: Eclipse License

Eclipse Foundation Software User Agreement
March 17, 2005

Usage Of Content
THE ECLIPSE FOUNDATION MAKES AVAILABLE SOFTWARE, DOCUMENTATION, 
INFORMATION AND/OR OTHER MATERIALS FOR OPEN SOURCE PROJECTS 
(COLLECTIVELY "CONTENT"). USE OF THE CONTENT IS GOVERNED BY THE 
TERMS AND CONDITIONS OF THIS AGREEMENT AND/OR THE TERMS AND 
CONDITIONS OF LICENSE AGREEMENTS OR NOTICES INDICATED OR 
REFERENCED BELOW. BY USING THE CONTENT, YOU AGREE THAT YOUR USE OF 
THE CONTENT IS GOVERNED BY THIS AGREEMENT AND/OR THE TERMS AND 
CONDITIONS OF ANY APPLICABLE LICENSE AGREEMENTS OR NOTICES 
INDICATED OR REFERENCED BELOW. IF YOU DO NOT AGREE TO THE TERMS AND 
CONDITIONS OF THIS AGREEMENT AND THE TERMS AND CONDITIONS OF ANY 
APPLICABLE LICENSE AGREEMENTS OR NOTICES INDICATED OR REFERENCED 
BELOW, THEN YOU MAY NOT USE THE CONTENT.

Applicable Licenses
Unless otherwise indicated, all Content made available by the Eclipse Foundation is provided to 
you under the terms and conditions of the Eclipse Public License Version 1.0 ("EPL"). A copy of 
the EPL is provided with this Content and is also available at 
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http://www.eclipse.org/legal/epl-v10.html. For purposes of the EPL, "Program" will mean the 
Content.

Content includes, but is not limited to, source code, object code, documentation and other files 
maintained in the Eclipse.org CVS repository ("Repository") in CVS modules ("Modules") and 
made available as downloadable archives ("Downloads").

Content may be structured and packaged into modules to facilitate delivering, extending, 
and upgrading the Content. Typical modules may include plug-ins ("Plug-ins"), plug-in 
fragments ("Fragments"), and features ("Features").

Each Plug-in or Fragment may be packaged as a sub-directory or JAR (Java™ ARchive) in 
a directory named "plugins".

A Feature is a bundle of one or more Plug-ins and/or Fragments and associated material. 
Each Feature may be packaged as a sub-directory in a directory named "features". Within a 
Feature, files named "feature.xml" may contain a list of the names and version numbers of 
the Plug-ins and/or Fragments associated with that Feature.

Features may also include other Features ("Included Features"). Within a Feature, files 
named "feature.xml" may contain a list of the names and version numbers of Included 
Features.

The terms and conditions governing Plug-ins and Fragments should be contained in files named 
"about.html" ("Abouts"). The terms and conditions governing Features and Included Features 
should be contained in files named "license.html" ( "Feature Licenses"). Abouts and Feature 
Licenses may be located in any directory of a Download or Module including, but not limited to 
the following locations:

    * The top-level (root) directory

    * Plug-in and Fragment directories

    * Inside Plug-ins and Fragments packaged as JARs

    * Sub-directories of the directory named "src" of certain Plug-ins

    * Feature directories

Note: If a Feature made available by the Eclipse Foundation is installed using the Eclipse 
Update Manager, you must agree to a license ("Feature Update License") during the 
installation process. If the Feature contains Included Features, the Feature Update 
License should either provide you with the terms and conditions governing the Included 
Features or inform you where you can locate them. Feature Update Licenses may be 
found in the "license" property of files named "feature.properties" found within a 
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Feature. Such Abouts, Feature Licenses, and Feature Update Licenses contain the terms 
and conditions (or references to such terms and conditions) that govern your use of the 
associated Content in that directory.

THE ABOUTS, FEATURE LICENSES, AND FEATURE UPDATE LICENSES MAY REFER 
TO THE EPL OR OTHER LICENSE AGREEMENTS, NOTICES OR TERMS AND 
CONDITIONS. SOME OF THESE OTHER LICENSE AGREEMENTS MAY INCLUDE 
(BUT ARE NOT LIMITED TO):

Common Public License Version 1.0 
(available at http://www.eclipse.org/legal/cpl-v10.html)

Apache Software License 1.1 
(available at http://www.apache.org/licenses/LICENSE)

Apache Software License 2.0 
(available at http://www.apache.org/licenses/LICENSE-2.0)

IBM Public License 1.0 
(available at http://oss.software.ibm.com/developerworks/opensource/license10.html)

Metro Link Public License 1.00 
(available at http://www.opengroup.org/openmotif/supporters/metrolink/license.html)

Mozilla Public License Version 1.1 
(available at http://www.mozilla.org/MPL/MPL-1.1.html)

IT IS YOUR OBLIGATION TO READ AND ACCEPT ALL SUCH TERMS AND 
CONDITIONS PRIOR TO USE OF THE CONTENT. If no About, Feature License, or Feature 
Update License is provided, please contact the Eclipse Foundation to determine what terms and 
conditions govern that particular Content.

Cryptography
Content may contain encryption software. The country in which you are currently may have 
restrictions on the import, possession, and use, and/or re-export to another country, of encryption 
software. BEFORE using any encryption software, please check the country’s laws, regulations 
and policies concerning the import, possession, or use, and re-export of encryption software, to 
see if this is permitted.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both. 
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