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C H A P T E R 1

Introduction

CollabraSuite BEA Edition software offers a metaphorical representation of a physical 
workplace. The virtual environment is made up of rooms, which can be arranged into a virtual 
floor of unlimited rooms, thus allowing for the grouping of like rooms by functionality or other 
common means. The floors can then be arranged within a virtual building, and numerous 
buildings can be grouped to create a virtual campus. Within this campus and its encompassing 
buildings, floors, and rooms, users can communicate seamlessly. CollabraSuite BEA Edition 
provides a means of hosting private meetings, group communications, or seminar style 
conferences for an entire enterprise. 

When a user logs into the CollabraSuite BEA Edition system, they are entering a virtual room 
where they can meet other users, chat with users and share documents. Not only can users 
collaborate with others in their current room, but presence awareness capabilities enable them to 
see users working in other virtual rooms. Users can instantly join other users in any room by 
simply clicking a button. As users move around the collaborative environment, they can bring 
their virtual briefcase with them—a portable repository filled with documents that only they can 
see. Documents in a user’s briefcase can easily be shared with other users by dropping a 
document into a room filecabinet. In addition to storing private documents in a user’s briefcase, 
CollabraSuite BEA Edition provides the ability to store public documents in virtual file cabinets. 
These documents can then be viewed by users within the room the file cabinet is located. 

The metaphorical representation of a physical workspace provided by CollabraSuite BEA Edition 
software also offers security aspects of the physical environment. Strong security features make 
it possible to permit or deny access to all areas of the collaborative environment and its contents. 
Individual rooms can be locked with Access Control Lists (ACLs). Read and write ACLs control 
access to documents stored in rooms as well. The CollabraSuite BEA Edition environment 
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provides the flexibility and the security of the physical work environment, all while having the 
freedom to connect users in any location. 

CollabraSuite BEA Edition is developed completely in Java utilizing the Java 2 Enterprise 
Edition (J2EE) application model, making it deployable to multiple J2EE servers, existing 
applications or system frameworks such as portals or other suite products as a complementary 
technology. CollabraSuite BEA Edition components can be deployed using a flexible 
HTTP-style interface or by using the CollabraSuite BEA Edition custom tag library. 

This version of CollabraSuite BEA Edition is specifically designed for deployment to a BEA 
WebLogic Server®.  However the media does contain all of the necessary software and scripts to 
deploy to other application servers.   CollabraSpace recommends that you deploy CollabraSuite 
BEA Edition in a development domain prior to performing a deployment into an existing 
production environment. 

The rest of this document will guide you through the process of installing the CollabraSuite BEA 
Edition software. If you are upgrading an existing installation of CollabraSuite BEA Edition, see 
the appendix Upgrading CollabraSuite. It is assumed that the installer has some familiarity with 
J2EE applications and the BEA Weblogic application server. 

For additional assistance and information visit us at www.collabraspace.com 

Prerequisites
The following prerequisites must be satisfied before installing CollabraSuite BEA Edition. Please 
refer to the Supported Configurations Guide for supported versions of WebLogic and database 
systems.

Install WebLogic Server, WebLogic SIP Server, or WebLogic Platform.

Install a database accessible by the WebLogic server machine.

Create a database user for CollabraSuite BEA Edition that has permissions to connect to 
the database and create tables and indexes.

Install AquaLogic User Interaction (ALUI), if CollabraSuite BEA Edition is to be 
integrated into an ALUI environment.

http://www.collabraspace.com
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Installing CollabraSuite BEA Edition

The CollabraSuite BEA Edition software installs as a component inside of the WebLogic install 
directory.

Install CollabraSuite BEA Edition
Begin by running the installer. If upgrading from a previous version of CollabraSuite, first 
uninstall the previous version before installing the new verion of CollabraSuite. The installer 
should start automatically when the installation CD is placed in a Windows machine. If the 
installer does not launch or you are running on a different platform, the installer can be started 
manually:

For Windows, run installer\WebLogic\CollabraSuite-511-windows.exe. 

For Solaris, run installer/WebLogic/CollabraSuite-511-solaris.bin.

For Linux, run installer/WebLogic/CollabraSuite-511-linux.bin. 

Note: On Linux and Solaris, the installer can also be run in text mode by appending -i console 
to the command line parameters.
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1. Launch the installer and click Next on the Introduction Page.

Figure 2-1  Introduction
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2. Read and accept the terms of the license agreement and click Next.

Figure 2-2  License Agreement
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3. Choose the BEA home directory and click Next. For example: C:\bea or /opt/bea.

Figure 2-3  Locate BEA Home
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4. Review the pre-installation summary and click Install.

Figure 2-4  Pre-Install Summary
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5. At this point the CollabraSuite BEA Edition software has been sucessfully installed in the 
WebLogic home directory. Click Done to exit the installer.

Figure 2-5  Install Complete

Uninstalling CollabraSuite BEA Edition
Uninstalling CollabraSuite BEA Edition removes the software from the WebLogic installation 
directory. It does not affect any WebLogic domains containing CollabraSuite BEA Edition. 
Uninstalling CollabraSuite BEA Edition can be accomplished by running the following scripts:

For Windows, run WL_HOME\collabrasuite-511\uninstall\Uninstall 
CollabraSuite 511.exe. 

For Solaris, run WL_HOME/collabrasuite.511\uninstall\Uninstall 
CollabraSuite 511

For Linux, run WL_HOME/collabrasuite.511\uninstall\Uninstall CollabraSuite 
511 

Note: On Linux and Solaris, the uninstaller can also be run in text mode by appending 
-i console to the command line parameters.
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1. Launch the uninstaller and click Uninstall on the Confirmation Page.

Figure 2-6  Uninstall

2. The software will be uninstalled.



Ins ta l l i ng  Co l labraSu i te  BEA Ed i t i on

2-8 Installation Guide



Installation Guide 3-1

C H A P T E R 3

Configuring CollabraSuite BEA Edition

Create the Domain
While CollabraSuite BEA Edition may be successfully deployed into any type of WebLogic 
domain, a portal domain is required if CollabraSuite BEA Edition is to be deployed inside a 
WebLogic Portal. If a WebLogic domain has not yet been created at your site, use the WebLogic 
Configuration Wizard to create one. 

In this document, the directory where WebLogic is installed will be referred to as WL_HOME. For 
example, WL_HOME=C:\bea\weblogic81

The WebLogic domain directory will be referred to as DOMAIN_HOME. For example, 
DOMAIN_HOME=C:\bea\user_projects\domains\portalDomain

WebLogic 8.1
For WebLogic 8.1, domains must first be created and later extended with CollabraSuite BEA 
Edition. Consult BEA's website for directions on Creating a New WebLogic 8.1 Domain. 
(http://edocs.bea.com/platform/docs81/confgwiz/newdom.html). 

WebLogic 9
In WebLogic 9, CollabraSuite BEA Edition can be installed into a domain at creation time, or 
added later by extending the domain. Refer to the section Extend WebLogic 9/10 Domain below 
for instructions on configuring CollabraSuite BEA Edition when creating or extending the 
domain.

http://edocs.bea.com/platform/docs81/confgwiz/newdom.html
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WebLogic 10
In WebLogic 10, CollabraSuite BEA Edition can be installed into a domain at creation time, or 
added later by extending the domain. Refer to the section Extend WebLogic 9/10 Domain below 
for instructions on configuring CollabraSuite BEA Edition when creating or extending the 
domain.

WebLogic SIP Server 3.0
In WebLogic SIP Server 3.0, CollabraSuite BEA Edition can be installed into a domain at 
creation time, or added later by extending the domain. Refer to the section Extend WebLogic 
SIP Server Domain below for instructions on configuring CollabraSuite BEA Edition when 
creating or extending the domain.

Consult BEA’s website for directions on Creating a New WebLogic SIP Server Domain. 
(http://edocs.bea.com/wlcp/wlss30/install/quickstart.html#wp1089865)

Extend the Domain
CollabraSuite BEA Edition is installed into a WebLogic server instance by adding the appropriate 
configuration to the server's domain. This domain configuration is automated using an extension 
template containing the CollabraSuite BEA Edition software. The template can also be used to 
create the necessary database tables for CollabraSuite BEA Edition. If you're upgrading an 
existing installation of CollabraSuite BEA Edition, refer to the Upgrading CollabraSuite 
appendix.

Be sure to shut down WebLogic and backup your entire domain directory before applying the 
extension template to an existing domain. The Configuration Wizard will overwrite all scripts in 
the domain, removing any local modifications. One strategy for updating an existing domain with 
local customizations is to first make a copy of the domain. You can then apply the extension 
template to the copy. When finished with the template, copy the config.xml and the 
CollabraSuite.ear file back into the original domain. This will allow you to update a domain 
with CollabraSuite BEA Edition while preserving any local modifications.

WebLogic 8.1 Domain
The following section describes extending a WebLogic 8.1 domain. If you are using WebLogic 
9, skip this section and refer to the next section titled Extend WebLogic 9 Domain.

1. Run the BEA WebLogic Configuration Wizard.

http://edocs.bea.com/wlcp/wlss30/install/quickstart.html#wp1089865
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a. In Windows, you can use the Start menu to run the Configuration Wizard. For other 
platforms, you can execute the Configuration Wizard script located in the WebLogic 
installation directory:

% cd $WL_HOME/common/bin

% ./config.sh &

2. Extend an existing WebLogic configuration.

a. Choose Extend an existing WebLogic configuration.

b. Click Next.

Figure 3-1  Create or Extend Domain
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3. Select the configuration.

a. Use the tree to select the top level directory of domain you wish to extend with 
CollabraSuite BEA Edition functionality.

b. Click Next.

Figure 3-2  Choose Configuration Directory
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4. Select the CollabraSuite BEA Edition extension template.

a. Check CollabraSuite Extension under Configuration Extensions. Click Next.

Figure 3-3  Select Template

5. Define JDBC Components.

a. Click Yes when asked to define JDBC components.
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b. Click Next.

Note: If using Pointbase, see the Special PointBase Instructions for WebLogic 8.1. If 
using MySQL, see the Special MySQL Instructions.

Figure 3-4  Database Options

c. The template provides example CollabraSuite BEA Edition JDBC connection pools for 
Pointbase, Oracle, Sybase, MS SQL Server and MySQL. Choose the CollabraSuite BEA 
Edition connection pool for the database you will be using and delete the remaining 
CollabraSuite BEA Edition pools (those beginning with csuite). 

Note: If they exist, cgPool, cgJMSPool-nonXA and the portalPool should not be 
deleted.
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d. Fill in the correct values for DBMS name, DBMS host, User name and User password. 
Supports Local Transactions should not be checked.

e. Click Next.

Figure 3-5  Connection Pools
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f. Click Next to skip the Configure JDBC MultiPools page.

g. For the csuitePool Data Source, select the csuite Connection Pool from the drop down 
menu. 

h. Click Next.

Figure 3-6  Data Sources
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6. Test JDBC Connection Pools and Settings.

a. To test the pool, select the csuite Connection Pool and click Test Connection. You should 
see a successful connection test in the right hand panel.

Figure 3-7  Setup Database

7. Create the CollabraSuite BEA Edition Database Schema

a. If the database schema does not already exist, click on Load Database.

Note: In WebLogic 8.1, all database scripts are run contrary to the BEA documentation. 
This will result in any existing CollabraSuite BEA Edition tables being dropped and 
recreated, removing any previous CollabraSuite BEA Edition environment. If 
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upgrading an existing CollabraSuite BEA Edition environment, please refer to the 
Upgrading CollabraSuite appendix.

b. Click Next.

Figure 3-8  Setup Database
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8. Define JMS Components.

a. Click No when asked to define JMS components. The JMS configuration should not have 
to be modified.

b. Click Next.

Figure 3-9  Messaging Options
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9. Target Components to Servers.

a. Click No when asked to target components to servers. The components will be targeted to 
the server.

b. Click Next.

Figure 3-10  Target Options
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10. Configure Application Security.

a. Click No when asked to configure the application's security. The correct groups and roles 
have already been defined.

b. Click Next.

Figure 3-11  Security Options
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11. Extend the configuration.

a. If desired, use Browse to select the directory to place the CollabraSuite.ear.

Note: If you want to place the EAR under the applications directory located in the domain 
you may have to create the directory first.

b. Click Import.

Figure 3-12  WebLogic Configuration
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12. A successful import is indicated in the screen below.

a. Click Done to exit the Configuration Wizard.

Figure 3-13  Creating Configuration

WebLogic 9/10 Domain
This section describes extending a WebLogic 9 or WebLogic 10 domain. If you are using 
WebLogic 8.1, skip this section and proceed to the next section titled Finish Extending the 
Domain.

1. Run the BEA WebLogic Configuration Wizard.

a. In Windows, you can use the Start menu to run the Configuration Wizard. For other 
platforms, you can execute the Configuration Wizard script located in the WebLogic 
installation directory:

% cd $WL_HOME/common/bin
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% ./config.sh &

2. Extend an existing WebLogic domain.

a. Choose Extend an existing WebLogic domain.

b. Click Next.

Figure 3-14  Create or Extend Domain
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3. Select the existing configuration.

a. Use the tree to select the top level directory of the domain you wish to extend with 
CollabraSuite BEA Edition functionality.

b. Click Next.

Figure 3-15  Choose Domain
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4. Select the extension source.

a. Select the appropriate CollabraSuite BEA Edition template. Choose the CollabraSuite 
BEA Edition for ALUI if CollabraSuite BEA Edition is to be used with AquaLogic User 
Interaction (ALUI)

b. Click Next.

Figure 3-16  Select Extensions

5. Customize JDBC Settings

a. Click Yes when asked to modify JDBC data sources.



Ex tend  the  Domain

Installation Guide 3-19

b. Click Next.

Note: If using MySQL, see the Special MySQL Instructions.

Figure 3-17  Customize JDBC

6. Configure JDBC Data Sources.

a. Leave the Name and JNDI name fields unchanged. 
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b. Fill in the appropriate Database type and Driver.

Note: Refer to the Supported Configurations Guide for supported databases and drivers.

c. Fill in the appropriate values for DBMS name, DBMS host, DBMS port, User name and 
User password.

d. Check Supports global transactions, then select Emulate two phase commit.

Figure 3-18  Data Source
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e. Test the data source by clicking Test Connections.

f. In the Test Data Source Connections dialog, click the Test button next to the 
csuiteDataSource. You should see a successful connection test in the lower panel.

g. Click OK to dismiss the dialog.

h. Click Next.

Figure 3-19  Test Data Source
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7. Run Database Scripts

a. If the CollabraSuite BEA Edition database schema does not already exist, click Run 
Scripts.

Note: Any existing CollabraSuite BEA Edition tables will be dropped and recreated, 
removing any previous CollabraSuite BEA Edition environment. If upgrading 
CollabraSuite BEA Edition, please refer to the Upgrading CollabraSuite appendix.

b. Click Next.

Figure 3-20  Setup Database
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8. Review WebLogic Domain.

a. Click Next.

Figure 3-21  Review Domain

9. Extend WebLogic Domain.

a. Select the desired Application location. This is where the CollabraSuite.ear file will 
be installed.
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Note: If you want to place the EAR file under the applications directory in the domain 
you may have to create the directory first.

b. Click Extend.

Figure 3-22  Extend the Domain

10. A successful domain extension is displayed in the screen below.
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a. Click Done to exit the Configuration Wizard.

Figure 3-23  Create Domain

WebLogic SIP Server 3.0 Domain
This section describes extending a WebLogic SIP Server domain. If you are using WebLogic 
server (without SIP support), skip this section and proceed to the next section titled Finish 
Extending the Domain.

1. Follow all instuctions in the WebLogic 9 Domain section above

a. In step 4a (Select Extensions), ensure SIP server is also selected

2. Edit the startWebLogic script located in DOMAIN_HOME/bin

a. For Windows, add the following to the end of the file

set JAVA_OPTIONS=%JAVA_OPTIONS% -Dwlss.udp.listen.on.ephemeral=false
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b. For Linux, add the following to the end of the file

JAVA_OPTIONS=%JAVA_OPTIONS% -Dwlss.udp.listen.on.ephemeral=false

export JAVA_OPTIONS

Finish Extending the Domain
After extending a WebLogic 8.1 or 9 domain, complete the installation via the WebLogic 
console.

1. Start the WebLogic server

For Windows:
> cd %DOMAIN_HOME%

> startWebLogic.cmd

For Unix:
% cd $DOMAIN_HOME

% ./startWebLogic.sh

Note: Startup will take some time because the CollabraSuite BEA Edition JSPs are 
precompiled the first time the server is started after CollabraSuite BEA Edition has 
been deployed.

2. Verify the following groups exist; creating the groups if they are not present:

– CollabraSuiteAdministrators

– CollabraSuiteUsers

– CollabraSuiteRemote

Note: If using an LDAP, create the groups in the LDAP and add users to the appropriate 
groups within the LDAP manually.

3. Add any existing WebLogic users to the appropriate CollabraSuite groups:

– Users must belong to the CollabraSuiteUsers group in order to login to the 
CollabraSuite environment. 

Note: Users belonging to the ‘wlcs_customer’ and ‘users’ groups also have access to 
CollabraSuite.

– Users belonging to the CollabraSuiteAdministrators group can create a new 
CollabraSuite campus and administer any existing campus.
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Note: Users belonging to the ‘Administrators’ and ‘PortalSystemAdministrators’ 
groups also belong to the CollabraSuiteAdministrators group.

– A user account used to initialize a remote campus connection must belong to the 
CollabraSuiteRemote group. This is the user account listed on the Remote Campus 
Admin Details page.

Note: Prior to the 4.2 release, the group names were CollabraSuiteGroup, 
CollabraSuiteAdmin, and CollabraSuiteRemoteAPI. These group names are still 
supported in later releases, though new installations will use the updated group 
names.

4. For WebLogic 8.1, increase the size of the Default Execute Queue if necessary. 
CollabraSuite BEA Edition requires an available thread for every user logged in 
concurrently. Threads are also consumed by remote campus connections, depending on the 
settings in the Remote Campus Details page. The Default Execute Queue can be modified 
in the WebLogic Administration Console under 
Servers->ServerName->Configuration->General->Advanced Options-> Configure 
Execute Queues. Select the default execute queue and modify the Thread Count setting as 
appropriate.

5. Modify the mail settings.

a. Some CollabraSuite BEA Edition components generate email and therefore require a Mail 
Session. The mail session is created by the template and can be edited from the WebLogic 
Administration Console under Services->Mail->csuiteMailSession. Important 
properties of the mail session include:

• mail.host: SMTP mail server hostname; default=localhost

• mail.user: The user name used to connect to the mail server; default=empty

• mail.from: The return email address used when the sending user has not filled in 
their email address; default=collabraSuite@localhost

Note: For further details on the JavaMail API, refer to 
http://java.sun.com/products/javamail.

b. Advanced Mail options: CollabraSuite BEA Edition contains advanced mail formatting 
options that can configure email headers and footers; a bcc recipient list to be used; and a 
standard from address to be used. In order to configure these advanced mail settings, the 
ejb-jar.xml file within the csuite-ebj.jar in CollabraSuite.ear must be 
updated and the jars repackaged. The individual options are documented within the 
ejb-jar.xml file.

http://java.sun.com/products/javamail
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6. For WebLogic 9/10, configure Virtual Content Repository (VCR) support if necessary:

a. Enable Library Services in the VCR to enable support for versioning documents. This can 
be modified via the Portal Administration console.

b. Modify the VCR data source (named portalDataSource by default) to Support Global 
Transactions using Logging Last Resource. This can be modified via the WebLogic 
Administration console under Services-> JDBC-> Data Sources-> portalDataSource-> 
Configuration-> Transaction.

c. Users need to have permission to write into the VCR. Adding the users to the 
Administrators group addresses this.

7. Verify the HTTP timeouts. CollabraSuite BEA Edition requires an HTTP timeout of at least 
30 seconds. 

a. The WebLogic default of 10 minutes is well within the requirements for CollabraSuite 
BEA Edition. If necessary, this setting can be modified from the WebLogic 
Administration Console under Servers->ServerName->Tuning->Stuck Thread Max 
Time.

b. This timeout also applies to any HTTP proxies between the client and WebLogic. The 
HTTP proxy timeout must be greater than or equal to WebLogic's timeout. Again, most 
defaults are much larger than 30 seconds, so these settings should not have to be modified 
to accomodate CollabraSuite BEA Edition.

8. CollabraSuite BEA Edition licenses must be obtained from BEA. An evaluation license is 
available on the CollabraSuite BEA Edition download page. The existing BEA license 
should be updated via the BEA UpdateLicense tool.

Create the Collaborative Environment
Once the CollabraSuite BEA Edition software has been successfully installed, all other 
documentation and administration capabilities are available via the deployed CollabraSuite BEA 
Edition application. An list of all available documentation and links to the documents can be 
found deployed in the WebLogic server at http://host:port/csuite/docs

1. Create the initial collaborative environment by using the CollabraSuite BEA Edition 
administration web application.

a. If necessary, create a CollabraSuite BEA Edition administration user in WebLogic that 
belongs to the CollabraSuiteAdministrators group.
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b. Bring up the CollabraSuite BEA Edition administration web application at 
http://host:port/csuite/ria/admin and log in as an administrative user.

c. Create the desired campus, buildings, floors, and rooms.

d. Create the desired users

e. In a portal environment, create corresponding WebLogic users in the Portal 
Administration. Otherwise, create the WebLogic users in the WebLogic Administration 
Console. The WebLogic user name must match the CollabraSuite BEA Edition user login 
ID.  Alternatively, you can use the <setUserInfo> JSP tag inside a portlet to 
automatically create a CollabraSuite user that corresponds to the WebLogic user. See 
CollabraSuite.jspf in the sample portlets for an example of using the 
<setUserInfo> JSP tag.

Note: Refer to the CollabraSuite BEA Edition Administration Guide for more 
information on creating a collaborative environment.

Create the Portal
CollabraSuite can run inside either a WebLogic Portal or ALUI environment. If a portal already 
exists or is not needed, creating the portal may be skipped.

For details on creating a WebLogic Portal application, consult BEA's website on Getting Started 
with Portal Development. (http://edocs.bea.com/wlp/docs81/startdev/index.html)

For details on creating an ALUI portal, consult BEA’s ALUI Documentation 
(http://edocs.bea.com/alui/index.html)

Extend the Portal
The following sections describe integrating CollabraSuite BEA Edition into a portal 
environment. They can be skipped when portal integration is not required.

WebLogic 8.1 Portal
This section describes CollabraSuite BEA Edition integration with WebLogic Portal 8.1.

1. Start BEA WebLogic Workshop.

2. Open an existing portal application or create a new one via File->New->Application...

3. Select an existing web project or create a new one via File->New->Project...

http://edocs.bea.com/wlp/docs81/startdev/index.html
http://edocs.bea.com/wlp/docs81/startdev/index.html
http://edocs.bea.com/alui/index.html
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4. Right-click on the web project in the left-hand tree and select Install->CollabraSuite

5. Sample CollabraSuite BEA Edition portlets are available in the Data Palette. Simply select 
a portal page and drag the portlets onto the page in the desired location.

6. CollabraSuite BEA Edition provides a JSP tag library for creating custom CollabraSuite 
BEA Edition portlets. The CollabraSuite BEA Edition tags are available under the JSP 
Palette in WebLogic Workshop.

7. Edit the portlets/CollabraSuite/collabrasuite.jspf file as necessary:

a. Set the campusName variable to the correct campus name.

b. Uncomment the <setuserinfo> JSP tag to automatically create CollabraSuite BEA 
Edition user accounts if desired. 

Note: This requires Auto Account Creation to be enabled on the campus. See the CollabraSuite 
BEA Edition Administration Guide for details.

WebLogic 9.2/10.0 Portal
This section describes CollabraSuite BEA Edition integration with WebLogic Portal 9.2 and 
10.0.

1. Start BEA WebLogic Workshop.

2. Open an existing portal EAR project or create a new one via File->New->Portal EAR 
Project...

3. Select an existing portal WAR project or create a new one via File->New->Portal Web 
Project...

a. Select the following project facets:

– CollabraSuite->CollabraSuite Taglibs

– WebLogic Portal Collaboration->CollabraSuite Portlets

b. Choose to “Use Shared J2EE Libraries.”

4. Create a new Portal by right clicking on the portal webproject and selecting New->Portal

Note: There is a known issue in WebLogic 9.2/10.0 concerning the proper ordering of 
library modules. As a workaround, open the WebContent/WEB-INF/weblogic.xml 
file in the web project and re-order the library module references so that the first two 
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library modules are: collabrasuite-portlets-web-lib and collabrasuite-web-lib in 
that order.

5. Sample CollabraSuite BEA Edition portlets are available in the Data Palette. Simply select 
a portal page and drag them onto the page in the desired location.

6. CollabraSuite BEA Edition provides a JSP tag library for creating custom CollabraSuite 
BEA Edition portlets. The CollabraSuite BEA Edition tags are available under the JSP 
Design Palette in WebLogic Workshop.

7. Access the portlets/CollabraSuite/collabrasuite.jspf:

a. Go to the Merged Projects View (Window->Show View->Merged Projects)

b. Select the collabraSuite.jspf file

c. Right click and select "Copy To Project"

8. Edit the portlets/CollabraSuite/collabrasuite.jspf file as necessary:

a. Set the campusName variable to the correct campus name.

b. Uncomment the <setuserinfo> JSP tag to automatically create CollabraSuite BEA 
Edition user accounts if desired. 

Note: This requires Auto Account Creation to be enabled on the campus. See the CollabraSuite 
BEA Edition Administration Guide for details.

WebLogic 9.2/10.0 GroupSpace Portal
This section describes CollabraSuite BEA Edition integration with WebLogic 9.2 and 10.0 
GroupSpace portals. Please refer to the GroupSpace Guide 
(http://edocs.bea.com/wlp/docs92/groupspace/index.html) for details on creating a GroupSpace 
portal.

When creating a domain, select the following products:

Workshop for WebLogic Platform

WebLogic Portal

WebLogic Portal GroupSpace Framework

CollabraSuite BEA Edition

http://edocs.bea.com/wlp/docs92/groupspace/index.html
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1. Start BEA WebLogic Workshop.

2. Open an existing portal EAR project or create a new one via File->New->Portal EAR 
Project...

a. In addition to the WebLogic Portal and WebLogic Portal Collaboration facets, select 
the CollabraSuite GroupSpace Library Support facet.

3. Select an existing portal WAR project or create a new one via File->New->Portal Web 
Project...

a. In addition to the WebLogic Portal and WebLogic Portal Collaboration facets, select 
the following:

– CollabraSuite/CollabraSuite Taglibs

– WebLogic Portal Collaboration/CollabraSuite GroupSpace Support

– WebLogic Portal Collaboration/CollabraSuite Portlets

b. Choose to “Use Shared J2EE Libraries”

Note: There is a known issue in WebLogic 9.2/10.0 concerning the proper ordering of 
library modules. As a workaround, open the WebContent/WEB-INF/weblogic.xml 
file in the web project and re-order the library module references so that the first three 
library modules are: collabrasuite-groupspace-web-lib, 
collabrasuite-portlets-web-lib and collabrasuite-web-lib in that order.

Note: Once the CollabraSuite GroupSpace Support facet has been applied to a Web Project, 
that Web Project can only be used for GroupSpace portals. However, there can be 
multiple Web Projects deployed into a single domain, some of which support 
GroupSpace and some that do not.

4. Publish the EAR to the WebLogic server.

5. Open the portal administration console.

6. Create a new portal or select an existing portal.

7. Create a community template based on the groupspace.ctmeta file.

Note: There are other ways to create a community such as directly from a .community file. 
However, the only way currently supported is via a template based on the 
groupspace.ctmeta file.
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8. Create an initial community based on the template created in the previous step.

Note: The following CollabraSuite BEA Edition location is automatically created: 
GroupSpace Campus/GroupSpace Building/GroupSpace Floor. All GroupSpace 
communities will use this location

AquaLogic User Interaction (ALUI) Portal
This section describes CollabraSuite BEA Edition integration with BEA’s ALUI product.

When using WebLogic 8.1, the domain must first be extended using the CollabraSuite BEA 
Edition template as described above in the Extend the Domain section. The WebLogic 
Configuration Wizard must be run again to extend the domain with the CollabraSuite BEA 
Edition for ALUI template.

When using WebLogic 9.2, both templates can be applied at the same time, either during domain 
creation, or later by extending the domain.

1. Update the CollabraSuite_ALUI_Portlets deployment descriptors.

a. In order to automatically create WebLogic users corresponding to ALUI users, the name 
of a WebLogic administrative user is contained in the weblogic.xml file of the csALUI 
web application. The default username is weblogic. If the weblogic user doesn’t exist in 
the domain or it is not in the Administrators group, the weblogic.xml must be modified. 
Change the following XML in 
<applications_dir>/CollabraSuite_ALUI_Portlets.ear/csALUIWeb.war/WEB-INF/weblo
gic.xml to reflect the name of an administrative user in your domain:

<security-role-assignment>

<role-name>SSO_ROLE</role-name>

<principal-name>weblogic</principal-name>

</security-role-assignment>

<run-as-role-assignment>

<role-name>SSO_ROLE</role-name>

<run-as-principal-name>weblogic</run-as-principal-name>

</run-as-role-assignment>
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b. By default, CollabraSuite BEA Edition will create new users with the same user name that 
is used to log into ALUI, with a default homeroom of 
SampleCampus/SampleBuilding/SampleFloor/SampleRoom.  If you would like to 
change any of these defaults, you need to modify the Servlet parameters in the 
CollabraSuite_ALUI_Portlets EAR.  These are found in the web.xml file of the csALUI 
web application.

Note: Remember to redeploy this EAR if you make any modifications to the deployment 
descriptors.

2. Import the sample CollabraSuite BEA Edition portlets

a. If necessary, start up the server that is running the ALUI application.

b. Navigate to http://host:port/portal/server.pt

c. Log in as the Administrator. The default is 'Administrator' with no password.

d. Click on the Administration tab.

e. Under the Select Utility… tab, choose Migration - Import.

f. Click Browse… under File Path, and select the following file: 
<WL_HOME>/collabrasuite-511/ALUI/QuickStart/csALUISample.pte

g. Click Load Package.

h. Click Finish in the upper-right-hand corner of the window, and then click OK to confirm 
the migration.

i. You now have a sample ALUI Experience Definition that contains all of the CollabraSuite 
BEA Edition portlets, as well as a sample default page to log into that contains two 
CollabraSuite BEA Edition portlets.

3. Modify Remote Server Properties. The migration in the previous step created a remote 
server object, which should point to the CollabraSuite_ALUI_Portlets application that was 
deployed by the extension template.  To change the default of localhost as the server host 
and 7001 as the server port:

a. Make sure that the server running the ALUI application is running.

b. Log into the ALUI application as the Administrator.

c. Click on the Administration tab.

d. Click on the CollabraSuite Experience Definition link.
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e. Click on the Remote Server link, then click on the CS Remote Server link.

f. Change the host and port in the Base URL text field.

g. Click Finish in the upper-right-hand corner of the window.

h. Log out of the ALUI application.

4. Modify CollabraSuite BEA Edition Campus settings in the CollabraSuite BEA Edition 
Administration tool.

a. Make sure that the server running CollabraSuite BEA Edition is running.

b. Log into the CollabraSuite BEA Edition admin tool using the CollabraSuite BEA Edition 
admin account. The URL is http://host:port/csuite/ria/admin.

c. Make sure that the Auto-Account Creation checkbox is checked.  If not, check this box 
and click Save.

d. Log out of the CollabraSuite BEA Edition admin tool.

5. Configure ALUI timeout and authentication.

a. Verify the following values are set in the 
<PLUMTREE_INSTALL_DIR>/settings/portal/portalconfig.xml file 

• ImageServerConnectionURLTimeout:  -1

• CaptureBasicAuthenticationForPortlets:  1
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C H A P T E R 4

Appendices

WebLogic Domain Extension Summary
CollabraSuite BEA Edition J2EE components require specific services and security to be 
configured and deployed. The following table summarizes the configuration created by the 
CollabraSuite BEA Edition Domain Extension Template:

Table 4-1  Domain Extension Summary

Component Settings

JDBC Connection Pool Name: csuiteConnectionPool

JDBC Data Source Name: csuitePool

JNDI Name: weblogic.jdbc.jts.csuitePool

JMS Server Name: csuiteJMSServer

JNDI Name: weblogic.jms.csuiteEventTopic

JMS Connection Factory Name: csuiteConnectionFactory

JNDI Name: weblogic.jms.csuiteConnectionFactory

JMS Topic Name: csuiteEventTopic

JNDI Name: weblogic.jms.csuiteEventTopic

JMS Topic Name: csuiteRemoteEventTopic

JNDI Name: weblogic.jms.csuiteRemoteEventTopic
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WebLogic Portal Extension Summary
Integrating CollabraSuite BEA Edition J2EE components into a WebLogic portal requires 
specific files to be configured and deployed into the portal application. The following 
summarizes the configuration performed by the CollabraSuite BEA Edition Portal Extension 
Template:

The following files are copied into 
<portalApplication>/<portalProject>/WEB-INF/lib. They can be found on the 
distribution CD under the lib directory.
– csuite-taglib.jar

– common-server.jar

– csuite-client.jar

– csuite-ejb-client.jar

– csuite-i9n-client.jar

– csuite-ria-common.jar

– csuite-ria-client.jar

The following taglib is added to 
<portalApplication>/<portalProject>/WEB-INF/web.xml:

<taglib>

   <taglib-uri>csuite-taglib.tld</taglib-uri>

   <taglib-location>/WEB-INF/lib/csuite-taglib.jar</taglib-location>

Mail Session Name: csuiteMailSession

JNDI Name: csuiteMail

Admin User Name: csadmin

Default Password: password

Member of: CollabraSuiteUsers, CollabraSuiteAdministrators

User Group Name: CollabraSuiteUsers

Admin Group Name: CollabraSuiteAdministrators

Remote Group Name: CollabraSuiteRemote

Component Settings
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</taglib>

The following ejb-refs are added to 
<portalApplication>/<portalProject>/WEB-INF/web.xml:

<ejb-ref>

    <ejb-ref-name>ejb/CSuiteAdmin</ejb-ref-name>

    <ejb-ref-type>Session</ejb-ref-type>

<home>com.collabraspace.csuite.server.i9n.interfaces.CSuiteAdminRemo
teHome</home>

<remote>com.collabraspace.csuite.server.i9n.interfaces.CSuiteAdminRe
mote</remote>

</ejb-ref>

<ejb-ref>

    <ejb-ref-name>ejb/CSuiteCollaboration</ejb-ref-name>

    <ejb-ref-type>Session</ejb-ref-type>

<home>com.collabraspace.csuite.server.i9n.interfaces.CSuiteCollabora
tionRemoteHome</home>

<remote>com.collabraspace.csuite.server.i9n.interfaces.CSuiteCollabo
rationRemote</remote>

</ejb-ref>

The following ejb-refs are added to 
<portalApplication>/<portalProject>/WEB-INF/weblogic.xml:

<ejb-reference-description>

<ejb-ref-name>ejb/CSuiteAdmin</ejb-ref-name>

<jndi-name>ejb/CSuiteAdmin</jndi-name>

</ejb-reference-description>

<ejb-reference-description>

<ejb-ref-name>ejb/CSuiteCollaboration</ejb-ref-name>

<jndi-name>ejb/CSuiteCollaboration</jndi-name>

</ejb-reference-description>

Sample CollabraSuite portlets are installed under 
<portalApplication>/<portalProject>/portlets/CollabraSuite.
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Upgrading CollabraSuite
The process of upgrading an existing installation of CollabraSuite is similar to the process of 
creating a new installation.

1. Be sure to shut down WebLogic and backup your entire domain directory before applying the 
extension template to an existing domain. The Configuration Wizard will overwrite all scripts 
in the domain, removing any local modifications. One strategy for updating an existing 
domain with local customizations is to first make a copy of the domain. You can then apply 
the extension template to the copy. When finished with the template, copy the config.xml 
and the CollabraSuite.ear file back into the original domain. This will allow you to update 
a domain with CollabraSuite BEA Edition while preserving any local modifications.

2. With WebLogic running, delete the CollabraSuite BEA Edition application via the 
WebLogic Administration Console under Deployments/Applications.

3. Shutdown the WebLogic server.

4. Connect to the database configured for CollabraSuite BEA Edition and run the necessary 
upgrade SQL scripts. These scripts can be found under the CollabraSuite BEA Edition 
installation sql directory and they should be run in order. For example, to upgrade from 
CollabraSuite BEA Edition 3.4.5 to CollabraSuite BEA Edition 3.6.0, run alter320to350.sql 
and then run alter350to360.sql.

5. Extend the domain.

– For WebLogic 8.1, perform the steps 1-6 and 8-11 from Extending the Domain, 
extending the copy of the domain.  Be sure to skip step 7, which creates the 
CollabraSuite BEA Edition database schema.  In step 11, point to the applications 
directory in the original domain, rather than the copy of the domain.

– For WebLogic 9/10, perform the steps 1-6 and 8-10 from Extending the Domain, 
extending the copy of the domain.  Be sure to skip step 7, which creates the 
CollabraSuite BEA Edition database schema.

6. Choose to replace the existing configurations and Apply that choice to all future choices.

7. Copy the config.xml file from the copied domain into the original domain

8. If upgrading a WebLogic 8.1 portal, copy the following jars into 
<portalApplication>/<portalProject>/WEB-INF/lib. They can be found on the 
distribution CD under the lib directory.
– csuite-taglib.jar

– common-server.jar
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– csuite-client.jar

– csuite-ejb-client.jar

– csuite-i9n-client.jar

– csuite-ria-common.jar

– csuite-ria-client.jar

9. If upgrading a WebLogic 9.2 or WebLogic 10.0 portal, upgrade is supported only when 
using J2EE library modules. In this case, find any files that have been copied into the 
project from a CollabraSuite BEA Edition library module. Remove and then re-copy them 
into the local project applying any local customizations.

10. Start the WebLogic server.

11. Perform all steps in Finish Extending the Domain.

Clustering Configuration
This section discusses deployment of CollabraSuite into a WebLogic cluster. This section can 
safely be skipped for single server installations.

Note: Clustering is not supported with the PointBase database.

Use the WebLogic Domain Configuration wizard to extend a cluster domain as described in the 
Extend the Domain section of this guide.

In WebLogic 8.1 SP4 or later, the CollabraSuite components will automatically be targeted to the 
cluster. In earlier versions you may have to target the CollabraSuite components to the cluster 
manually.

Confirm the following configuration for the CollabraSuite JMS Connection factory:

General -> 'Server Affinity Enabled' is checked

Transactions -> 'XA Connection Factory Enabled' is checked

When running in a cluster, the system clocks of all server nodes must be synchronized by using 
Network Timing Protocol (NTP) or some similar means of clock synchronization.  When system 
clocks are not synchronized, incorrect event timestamps will occur and CollabraSuite users may 
be disconnected from the application.
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Supported Configurations
Please see the Supported Configurations Guide for supported platforms and known limitations 
associated with particular configurations.

Special UNIX Instructions
Some UNIX serves ship without a graphics card. These “headless” machines require an extra 
WebLogic startup parameter in order to support CollabraSuite. This parameter can be passed to 
WebLogic by adding the following line to startWebLogic.sh:
JAVA_OPTIONS=”${JAVA_OPTIONS} -Djava.awt.headless=true”

Special PointBase Instructions

WebLogic 8.1
When using PointBase with WebLogic 8.1, take the following special steps when extending a 
domain:

Before step 5, start PointBase:

For Windows:

> cd %DOMAIN_DIR%

> setDomainEnv.cmd

> %WL_HOME%\common\bin\startPointBase.cmd -port=9093 
-ini=%DOMAIN_DIR%\pointbase.ini

For Unix:

% cd $DOMAIN_DIR

% . setDomainEnv.sh

% ${WL_HOME}/common/bin/startPointBase.sh -port=9093 
-ini=${DOMAIN_DIR}/pointbase.ini

After step 7, stop PointBase:

For Windows:

> cd %DOMAIN_DIR%

> setDomainEnv.cmd

> %WL_HOME%\common\bin\stopPointBase.cmd -port=9093 -name=workshop
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For Unix:

% cd $DOMAIN_DIR

% . setDomainEnv.sh

% ${WL_HOME}/common/bin/stopPointBase.sh -port=9093 -name=workshop

Special MySQL Instructions

WebLogic 8.1
When using MySQL with WebLogic, some documentation states that the MySQL JDBC driver 
JAR file should be placed in the JDK's jre/lib/ext directory. However, this causes errors when 
deploying J2EE applications in WebLogic. Instead, follow these steps to deploy with MySQL:

1. Create a WL_HOME/server/ext/jdbc/mysql directory in the WebLogic installation and 
place the MySQL JDBC driver JAR file in it. For this example, the MySQL JDBC driver JAR 
file is mysql-connector-java-3.1.12-bin.jar.

2. Add the MySQL JDBC driver to the CLASSPATH:

a. For Windows, edit the WL_HOME\common\bin\commEnv.cmd script and add the 
following lines to the bottom of the file:

SET DATABASE_CLASSPATH=
%WL_HOME%\server\ext\jdbc\mysql\mysql-connector-java-3.1.12-bin.jar

SET WEBLOGIC_CLASSPATH=%WEBLOGIC_CLASSPATH%;%DATABASE_CLASSPATH%

b. For UNIX, edit the WL_HOME/common/bin/commEnv.sh script and add the following 
lines to the bottom of the file:

DATABASE_CLASSPATH=
${WL_HOME}/server/ext/jdbc/mysql/mysql-connector-java-3.1.12-bin.jar

export DATABASE_CLASSPATH

WEBLOGIC_CLASSPATH=${WEBLOGIC_CLASSPATH}:${DATABASE_CLASSPATH}

WebLogic 9/10
When using MySQL with WebLogic, some documentation states that the MySQL JDBC driver 
JAR file should be placed in the JDK's jre/lib/ext directory. However, this causes errors when 
deploying J2EE applications in WebLogic. Instead, follow these steps to deploy with MySQL:

1. Follow the instructions above for WebLogic 8.1.
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2. For Windows, edit the following lines at the bottom of 
WL_HOME\common\bin\config.cmd and add the text in bold:

IF "%ARGUMENTS%" == "" (

%JAVA_HOME%\bin\javaw %MEM_ARGS% 
-Xbootclasspath/a:%DATABASE_CLASSPATH% -jar configwiz.jar  %ARGUMENTS%

) ELSE (

%JAVA_HOME%\bin\java %MEM_ARGS% 
-Xbootclasspath/a:%DATABASE_CLASSPATH% -jar configwiz.jar %ARGUMENTS%

)

3. For UNIX, edit the following line at the bottom of WL_HOME\common\bin\config.sh and 
add the text in bold:

"${JAVA_HOME}/bin/java" ${MEM_ARGS} 
-Xbootclasspath/a:${DATABASE_CLASSPATH} -jar configwiz.jar ${ARGUMENTS}

Note: See the Known Limitations section of the Supported Configurations Guide for the 
compatible versions of MySQL.

Media Server Configuration
This section discusses configuring the CollabraSuite BEA Edition environment to utilize SIP 
functionality. The following steps must be taken before audio conferencing is available in the 
CollabraSuite BEA Edition application.

1. CollabraSuite BEA Edition must be installed into a WebLogic SIP Server domain.

2. The Asterisk Media Server must be installed via an RPM. The RPM can be found on the 
CollabraSuite BEA Editioninstallation CD under the media-server directory. Install the 
media server with:

% rpm -Uvh cs_media_server-5.1-1.rpm

3. The Asterisk media server must be configured by editing /etc/asterisk/sip.conf. The 
[general] section of the sip.conf file contains configuration data common to all SIP 
channels. Edit the following network related items:

– bindaddr -- specifies the internal IP address of the media server host.

– externip -- specifies the host’s external IP address if the media server also has an 
assigned external IP address.

– bindport -- specifies the port number for which the media server will be listening for 
SIP connections.  The standard SIP port is 5060, this is set to 6060 by default.  This 
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value should be the same as the SIP Server value provisioned for Media Server Port 
in the CollabraSuite BEA Edition Administration.

– localnet -- specifies which networks are local to the media server when the media 
server is available to clients on both internal and external networks. Entries are 
specified as a dotted decimal IP address and a subnet mask; for example, 
localnet=192.168.1.0/24. Multple local networks can be specified by using separate 
localnet lines in the configuration file.

4. Start the media server with:

% /sbin/service asterisk start

5. The SIP Server must be configured within CollabraSuite. Please see the Administration 
Guide for instructions to configure the SIP functionality within CollabraSuite.

6. Users must have a compatible soft phone installed and configured on their local machine. 
Please see the User Guide for instructions on soft phone configuration.
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